Automatic Capitalization

dr
driver49
Posts: 41
Joined: Fri Dec 05, 2014 4:30 pm
Platform: Mac

Mon Nov 27, 2017 2:38 pm Post

I'm getting a little tired of hunting through the new Preferences panel to find this stuff. So far this morning I've spent more time trying to get S3 to behave than I have actually writing...

The latest wrinkle? Automatic capitalization. Sometimes I will type a period, or an ellipsis (which Scrivener seems to think is a period) and the next character is capitalized, per screenshot attached. There is no way to defeat this automatic capitalization, a period will be followed by a capital letter every time.

How do I turn that off. I will decide when I want a letter to be capitalized.

Thanks,

--PS
Attachments
Screen Shot 2017-11-27 at 8.35.21 AM.png
Screen Shot 2017-11-27 at 8.35.21 AM.png (7.68 KiB) Viewed 1532 times

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Mon Nov 27, 2017 3:23 pm Post

Scrivener > Preferences > Corrections > Auto-Correction > [Various Options]

Corrections.jpg
Corrections.jpg (163.61 KiB) Viewed 1525 times

dr
driver49
Posts: 41
Joined: Fri Dec 05, 2014 4:30 pm
Platform: Mac

Mon Nov 27, 2017 5:59 pm Post

The Corrections panel. Of course. Duh.

Thanks,

--PS

je
jeffnesh
Posts: 9
Joined: Wed Jan 26, 2011 5:10 pm
Platform: Mac

Tue Nov 28, 2017 5:25 pm Post

However... a related issue. When *I* finally found that, and I unchecked "Fix capitalization of sentences", it STILL auto-capitalizes the first letter on a new line (paragraph).

I write poems. When I hit return to start a new line, it auto capitalizes, even though I have not hit shift, and my "Fix capitalization" is unchecked.

The only way to get it to work correctly is to turn off all the auto-correct functions, not just capitalization.

Is this a bug, or just a quirk?
jeffnesheim.com
highway30.org

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Tue Nov 28, 2017 6:06 pm Post

jeffnesh wrote:However... a related issue. When *I* finally found that, and I unchecked "Fix capitalization of sentences", it STILL auto-capitalizes the first letter on a new line (paragraph).

I write poems. When I hit return to start a new line, it auto capitalizes, even though I have not hit shift, and my "Fix capitalization" is unchecked.

The only way to get it to work correctly is to turn off all the auto-correct functions, not just capitalization.

Is this a bug, or just a quirk?


Probably the macOS system setting...

System Preferences.jpg
System Preferences.jpg (87.87 KiB) Viewed 1477 times