Hyperlinks not exporting in .docx

ki
kiaroskuro
Posts: 1
Joined: Fri Oct 20, 2017 5:29 am
Platform: Mac
Contact:

Fri Oct 20, 2017 5:38 am Post

Hi there... I'm a business blogger, and I've been using Scrivener to create my posts for the last month or so. I've been getting frustrated with the web link function in Scrivener, but everything else is wonderful.

When I export my document as a .docx, none of the web links in the text show up as links. They're in there, but I have to do extra formatting to make sure that they're visible. In a Word doc, they'd be both blue and underlined, and that's what my clients are looking for.

This is a problem because when I send my drafts to my clients, they need to know exactly what's a link and what's not before they upload it to their site.

Is there something I'm missing? Thanks!

br
brookter
Posts: 2101
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Fri Oct 20, 2017 6:18 am Post

This is the section on the manual for compiling hyperlinks (S8.5.7

When Scrivener Links can be Compiled

Depending upon the file format used , when compiling your work into a single file, Scrivener Links can be a feature that reside entirely within the realm of Scrivener, being stripped out of the final product, or something that can be used for linking (or referencing) that your readers can make use of. Some examples range from tables of content, cross-references, hyperlinks to the web, and more.

When compiling, unless the target format (such as RTF, PDF and HTML) supports point-to-point linking, they will be stripped from the output, and thus are handy for inserting useful links for your own purposes. For those formats that do support link- ing, you can opt-out of this behaviour in the Transformations compile option pane (subsection 24.15.2), by selecting “Remove all hyperlinks”.


Just so we've eliminated the obvious, have you made sure that the 'Remove all hyperlinks' tick box is unticked in the Compile > All Options > Transformation pane?

If that doesn't work, try compiling to RTF, rather than .docx and see whether they work there — it would at least be a fallback while the problem is investigated.

HTH.

Ma
Mac
Posts: 86
Joined: Tue Jun 19, 2012 11:28 am
Platform: Mac + iOS

Fri Oct 20, 2017 6:20 am Post

1. If you open your .docx in Pages, are the links there?

2. Compile > Transformations > Remove all hyperlinks. Is this option selected? If yes, deselect it and try again.

3a. Try Compile > Compile For Rich Text (.rtf – Word Compatible),

3b. Then choose RTF Compatibility and see if there is a tick next to Ensure hyperlinks are colored and underlined.

3c. Then try another compile to .docx

User avatar
kewms
Posts: 6240
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Fri Oct 20, 2017 6:23 am Post

If you end up compiling to RTF, make sure to check the "Ensure hyperlinks are colored and underlined" box in the Compile -> RTF Compatibility pane.

Make sure you have Word's automatic formatting options turned off, or at least be sure that you know what they are configured to do.

Katherine
Scrivener Support Team

jj
jjmccullough
Posts: 2
Joined: Mon Jul 30, 2018 3:09 pm
Platform: Mac

Mon Jul 30, 2018 3:18 pm Post

I have been having this issue too. It arose unexpectedly... at one time, any .docx would have all links clearly highlighted; today, for some reason, all the links appear "invisible," just as the OP described. They can be clicked in the exported .docx file, but unless you know where they are, you'd never find them.

Checking and unchecking the "hide hyperlinks" box did not work. However, I did find that exporting my document through the "compile" function, rather than the "export" function did work.

User avatar
KB
Site Admin
Posts: 20735
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Jul 30, 2018 3:22 pm Post

Are you exporting to RTF or Word? If to .docx or .doc, you should see them fine. If RTF, they might be invisible. Either way, in your Compile format, check that in the "Compatibility" settings "Ensure hyperlinks are coloured and highlighted" is ticked.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."