Typing cursor in editing Mode always flips to middle - how to stop?

om
omananda
Posts: 10
Joined: Sat Oct 14, 2017 9:54 am
Platform: Mac

Sat Oct 14, 2017 10:03 am Post

Typing cursor in editing Mode always flips to middle - how to stop?

Please advice. Looked in preferences - can not find. Where/how?

Thx

Hu
Hugh
Posts: 2444
Joined: Thu Mar 08, 2007 12:05 pm
Platform: Mac
Location: UK

Sat Oct 14, 2017 10:36 am Post

Do you mean "vertically centred"? If so, you almost certainly have Typewriter Scrolling toggled on: menu item Format > Options > Typewriter Scrolling. It's designed to keep the line you're typing vertically centred on your screen (or where you wish to keep it: the location is set in Scrivener > Preferences > Editor). You can find out more about this feature in the Scrivener Manual under the Help menu, in section 15.3.4.
'Listen, some quiet night, when you've shirked your work that day. Do you hear
that distant, almost inaudible clicking sound? That's one of your
competitors, working away in the night in
Paris or London or Erie, PA.'

om
omananda
Posts: 10
Joined: Sat Oct 14, 2017 9:54 am
Platform: Mac

Mon Oct 16, 2017 2:58 pm Post

NO. it's still doing it. I did what you suggested, but nothing changed. The typing cursor in full screen mode always goes to back to the middle of the screen whenever i make a change. do you understand what i mean? please advice if this setting can be changed. thx

User avatar
kewms
Posts: 6179
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Mon Oct 16, 2017 3:45 pm Post

Did you change the Typewriter Scrolling option while in Compose mode? It's set independently there and in the main editor.

Katherine
Scrivener Support Team

br
brookter
Posts: 2097
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Mon Oct 16, 2017 3:50 pm Post

Typewriter mode is set independently in editor mode and in composition mode, so it's possible you haven't toggled it off in one of the modes. Try toggling cmd-ctl-t and see whether it changes. (Easiest way to check: choose a document which is longer than a screen full and go the end, then toggle cmd-ctl-t.)

You can set the default position for each mode in Preferences (go to the Editor panel and the Composition mode panel).

The reason for the independent settings is that many people like to use Composition mode for banging out the text, where it's painful to have the cursor at the bottom of the screen, and the normal Editor mode for editing, where the jumping around as you edit is irritating. This way allows you to set sensible defaults for both.

EDIT: Ha... too slow.

s2
s2beck
Posts: 1
Joined: Tue Jun 30, 2020 3:23 am
Platform: Mac

Thu Jul 02, 2020 1:08 pm Post

I encountered this same problem in Scrivener v3.1.5 (on Mac OSX v10.15.5) without making a settings change. Maybe I accidentally clicked an icon or a control/option/command keystroke that made my cursor always return to the middle of the screen whenever I hit the return key.

Fortunately, after some digging through the Scrivener menus (a wonderful way to procrastinate on your writing, by the way), I found a way to fix the problem: Go to Scrivener menu / Preferences / Appearance / Main Editor / and then uncheck "Center the editor when using a fixed width" (see attached image). Hope it works as well for you as it did for me.

scrivener uncenter the editor.jpg
scrivener uncenter the editor.jpg (182.54 KiB) Viewed 149 times

User avatar
lunk
Posts: 4050
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Thu Jul 02, 2020 1:55 pm Post

s2beck wrote:I encountered this same problem in Scrivener v3.1.5 (on Mac OSX v10.15.5)

What you are showing is the horizontal positioning of the text within the Editor window, not the vertical centering of the cursor while writing.
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, all running Mojave.
* iOS Scrivener 1 on an iPhone 11 Pro, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS