Autocorrect dashes

el
elgarak
Posts: 4
Joined: Sat Jul 16, 2016 10:57 pm
Platform: Mac + iOS

Thu Sep 14, 2017 12:58 pm Post

Call me weird, but I want double-hyphens being autocorrected to en-dashes, and triple-hyphens to em-dashes (that's how it's working in LaTeX where I got used to it writing my theses, and for British or German I need en-dashes). I have this set-up in the system text settings. Scrivener 2 only has the option for correcting double-hyphens to em-dashes. Nevertheless, it worked fine (autocorrect defined in system text, Scrivener set to autocorrect to em-dashes. Would make en-dashes with two, em-dashes with three).

Until this morning, when Scrivener defaulted to em-dashes for double-hyphens. I do not know what has happened. If I turn off the Scrivener setting, it doesn't autocorrect dashes at all. The option for getting en-dashes is gone.

How do I get it back?

el
elgarak
Posts: 4
Joined: Sat Jul 16, 2016 10:57 pm
Platform: Mac + iOS

Thu Sep 14, 2017 1:10 pm Post

AAHHHH, ghosts!

It's working again. I didn't do anything! I just switched here to the forum, went back to Scrivener, and now it's working again.

WTF? Can someone explain that?

jo
joelfabes
Posts: 6
Joined: Mon Jan 11, 2016 6:01 pm
Platform: Mac

Thu Sep 14, 2017 5:50 pm Post

I had a similar thing happen yesterday, where Scrivener stopped auto-correcting quotes to smart quotes, as well as double-hyphens to em-dashes, despite the fact that all my settings were unchanged and definitely set to make those changes. I ended up following these steps:

1. Uncheck all the "Substitutions" options in Scrivener Preferences/Corrections
2. Quit the preferences pane
3. Re-open it
4. Re-check the boxes
5. Restart Scrivener

It was one of a couple solutions I found on this thread: https://www.kboards.com/index.php?topic=191334.0

Ah
Ahab
Posts: 776
Joined: Sun Oct 01, 2006 8:00 pm
Location: Maine

Thu Sep 14, 2017 7:44 pm Post

I've seen this bug since the advent of Sierra. (There's also a drag-and-drop issue that crops up also.)

The easiest solution I've found is to close Scrivener, restart Mac OS, and when you restart Scrivener everything works normally. This isn't a bug I'd expect Keith to fix any time soon. It seems to be Sierra-related, and will hopefully be a nonissue in Scriv3.0

el
elgarak
Posts: 4
Joined: Sat Jul 16, 2016 10:57 pm
Platform: Mac + iOS

Thu Sep 14, 2017 10:19 pm Post

Thanks. It seems I didn't do anything, but I guess I went through the preference panes of both Scrivener and system, and re-checked everything that did the trick.

So far, it seems to be a minor annoyance, given that I have written for months without anything like this to happen (at first I thought it was because I didn't do en-dashes, but by the other reports it happens with other autocorrect options as well. Seems I was just lucky). We'll see how it works in Scrivener 3.

al
alanisfuzzy
Posts: 1
Joined: Tue Dec 05, 2017 4:49 pm
Platform: Mac + iOS

Tue Dec 05, 2017 5:02 pm Post

I know this is an old thread, but I'm having the same problem. Scrivener suddenly stopped auto-formatting em dashes and smart quotes this week, despite me making no changes on my end (didn't change any settings, I'm working on the same existing projects, etc.).

I tried unchecking and rechecking the Substitutions boxes and restarted both Scrivener and my computer multiple times, but nothing has worked. Is there anything else you guys tried that might be helpful? I'm using Scrivener 2.8.1 on El Capitan.

Thanks!

de
deborahb
Posts: 15
Joined: Wed Jul 22, 2009 1:37 am

Mon Dec 11, 2017 3:27 am Post

Okay, I'm getting this, too. It's so annoying I'd like to roll back version 3.0 to my old, reliable 2.whatever.

I've tried turning off the smart quotes options everyplace, shutting down Scrivener, re-starting my Mac (OS Sierra 10.12.6).

Anybody come up with any new ideas on the whole smart quotes nightmare? HOW DO I TURN OFF SMART QUOTES OMG IT'S AWFUL.

ETA: Okay, I have found & staked every darn instance of this darn smart quote vampire now. I am victorious. (Could be simpler to turn this darn thing off, though, if you ask me.)
Last edited by deborahb on Tue Dec 12, 2017 5:08 am, edited 1 time in total.

User avatar
Silverdragon
Posts: 1479
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Mon Dec 11, 2017 4:43 am Post

Re: smart quotes in S3: Turn it off in System Preferences, Keyboard, in the Text pane. Also turn it off in Scrivener preferences, in the Corrections pane. Also turn it off in the Scrivener Edit menu: Edit > Substitutions > Smart Quotes. You may have to turn it off in the edit menu for every single project.

Like a freaking vampire, it has coffins everywhere, but that should stake it through the heart.
  • Fiction-writer curled up on her TP hoard.
  • Mac Scrivener 3.1.5, MacBook Air 11, MacOS 10.15.6 (Catalina)
  • IOS Scrivener 1.2.1; iPhone 8+, iPad 6; i(Pad)OS 13.6
  • Website: https://silverdrag0n.wordpress.com

de
deborahb
Posts: 15
Joined: Wed Jul 22, 2009 1:37 am

Tue Dec 12, 2017 5:09 am Post

Silverdragon wrote:Re: smart quotes in S3: Turn it off in System Preferences, Keyboard, in the Text pane. Also turn it off in Scrivener preferences, in the Corrections pane. Also turn it off in the Scrivener Edit menu: Edit > Substitutions > Smart Quotes. You may have to turn it off in the edit menu for every single project.

Like a freaking vampire, it has coffins everywhere, but that should stake it through the heart.


I can't find a way to hit 'LOVE' on your post, but your post nails it. No pun intended. ;p

User avatar
Silverdragon
Posts: 1479
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Tue Dec 12, 2017 8:06 am Post

You're welcome!

As I understand it, in S3 it works like this:

the System Preferences aren't supposed to affect smart quotes internal to Scriv, but sometimes they do. It's just safer if you want them off, to turn them off here. If you hate Smart Quotes in Scriv, you're probably not going to like them in Word, TextEdit, or Notes either.

the Scrivener Preferences affect whether the smart quotes menu item is toggled on when you create a new project. But of course if you just switched over to S3 from S2, the Scriv prefs are going to toggle that menu item on for every project you import if you don't change it.

Finally, independent of Scrivener Preferences, you can turn smart quotes on or off on a project-by-project basis with the Edit Menu item.Which is something you couldn't do in S2--smart quotes were either on or they were off, period, and controlled in Scrivener Prefs. So OK, if you're doing a novel and you're doing a thesis, you can have smart quotes off in the novel and on in the thesis, if you're so inclined. This increased flexibility may be of benefit to many, but as you say, it's darned hard to turn them off everywhere now. Or on everywhere, for that matter, if you change your mind. :|
  • Fiction-writer curled up on her TP hoard.
  • Mac Scrivener 3.1.5, MacBook Air 11, MacOS 10.15.6 (Catalina)
  • IOS Scrivener 1.2.1; iPhone 8+, iPad 6; i(Pad)OS 13.6
  • Website: https://silverdrag0n.wordpress.com