How to stop two dashes from being turned into an em dash?

Mi
Mirskyman
Posts: 80
Joined: Wed Jan 31, 2007 2:33 am
Location: California
Contact:

Thu Mar 23, 2017 5:59 am Post

Hi. This is as much a general Mac question as a Scrivener question.

Somewhere, on my Mac, I have a setting which changes two dashes into an em dash. So when I type two dashes, then hit space, the two dashes are replaced by an em dash. This happens in most applications, including Scrivener. However, it doesn't happen when I type in a web browser -- so it's apparently not a universal setting.

But I can't figure out where this setting is and how to change it. I looked in System Preferences> Keyboard> Text, but there's no shortcut there for turning two dashes into an em dash.

Does anyone know where the setting might be?

I don't want dashes to be turned into an em dash when I'm writing in Scrivener using Script Mode.

Thanks!

Mirskyman

Mi
Mirskyman
Posts: 80
Joined: Wed Jan 31, 2007 2:33 am
Location: California
Contact:

Thu Mar 23, 2017 6:08 am Post

I should add, in the Keyboard>Text preferences I unchecked "Use smart quote and dashes" but that didn't make a difference.

User avatar
nontroppo
Posts: 1254
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Thu Mar 23, 2017 6:55 am Post

Have you unchecked Scrivener > Preferences > Corrections > Replace a double hyphen with em-dashes?

Mi
Mirskyman
Posts: 80
Joined: Wed Jan 31, 2007 2:33 am
Location: California
Contact:

Thu Mar 23, 2017 1:09 pm Post

nontroppo, that worked! Thank you. I haven't used Scrivener for a number of months so I forgot about those settings.

wr
writerhoward
Posts: 91
Joined: Fri Dec 30, 2011 4:37 pm
Platform: Mac

Sun May 20, 2018 12:37 pm Post

nontroppo wrote:Have you unchecked Scrivener > Preferences > Corrections > Replace a double hyphen with em-dashes?

I just looked in Scrivener 3 on my MacBook and cannot find that option. Has it been relocated?

User avatar
nontroppo
Posts: 1254
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Sun May 20, 2018 12:54 pm Post

It has been renamed, I think it is now called Preferences ▶︎ Corrections ▶︎ Use smart dashes and ellipses in new projects, and to toggle it in existing projects Edit ▶︎ Substitutions ▶︎ Smart dashes and Ellipses.

wr
writerhoward
Posts: 91
Joined: Fri Dec 30, 2011 4:37 pm
Platform: Mac

Sun May 20, 2018 1:46 pm Post

nontroppo wrote:It has been renamed, I think it is now called Preferences ▶︎ Corrections ▶︎ Use smart dashes and ellipses in new projects, and to toggle it in existing projects Edit ▶︎ Substitutions ▶︎ Smart dashes and Ellipses.

That is checked, but when I type two dashes and a SPACE the two dashes are not replaced with an EM dash.
I'm using Scrivener version 3.0.2.
.

User avatar
nontroppo
Posts: 1254
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Mon May 21, 2018 5:51 am Post

Possibly you need to check System Preferences ▶︎ Keyboard ▶︎ Text ▶︎ Use smart quotes and dashes too?

wr
writerhoward
Posts: 91
Joined: Fri Dec 30, 2011 4:37 pm
Platform: Mac

Mon May 21, 2018 10:44 am Post

nontroppo wrote:Possibly you need to check System Preferences ▶︎ Keyboard ▶︎ Text ▶︎ Use smart quotes and dashes too?

That is checked too.

The strange thing is I just discovered that in other apps, such as the Notes app, if I type two dashes and a SPACE, the dashes are replaced with an em dash. Further, if I try to do it in other templates in Scrivener 3, such as the Blank template, as soon as I type the second dash both dashes are automatically converted to an em dash. The problem seems to occur only in the US Stage Play template.

User avatar
nontroppo
Posts: 1254
Joined: Mon Mar 05, 2007 5:22 pm
Platform: Mac
Location: Airstrip One

Mon May 21, 2018 11:07 am Post

There is a setting for screen/stage writing, could that be it?

Screen Shot 2018-05-21 at 19.06.40.png
Screen Shot 2018-05-21 at 19.06.40.png (4.13 KiB) Viewed 4225 times

wr
writerhoward
Posts: 91
Joined: Fri Dec 30, 2011 4:37 pm
Platform: Mac

Mon May 21, 2018 11:48 am Post

nontroppo wrote:There is a setting for screen/stage writing, could that be it?

Screen Shot 2018-05-21 at 19.06.40.png

How do I get to that setting?

User avatar
KB
Site Admin
Posts: 20834
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon May 21, 2018 1:42 pm Post

Under Preferences > Corrections, beneath the "Use smart dashes and ellipses in new projects" checkbox, there is another checkbox: "Disable smart dashes and ellipses in script mode". If that is ticked, smart dashes will not be used in scripts such as US Stage Play.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

wr
writerhoward
Posts: 91
Joined: Fri Dec 30, 2011 4:37 pm
Platform: Mac

Mon May 21, 2018 2:00 pm Post

KB wrote:Under Preferences > Corrections, beneath the "Use smart dashes and ellipses in new projects" checkbox, there is another checkbox: "Disable smart dashes and ellipses in script mode". If that is ticked, smart dashes will not be used in scripts such as US Stage Play.

All the best,
Keith


I see it. Thank you very much. Am I correct that it is preferable to leave that checkbox checked?

User avatar
KB
Site Admin
Posts: 20834
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon May 21, 2018 2:45 pm Post

I believe so - most scripts use two hyphens for dashes still, from what I have read.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
Amy Alkon
Posts: 2
Joined: Thu Jun 14, 2018 5:01 pm
Platform: Mac

Thu Jun 14, 2018 5:02 pm Post

nontroppo wrote:It has been renamed, I think it is now called Preferences ▶︎ Corrections ▶︎ Use smart dashes and ellipses in new projects, and to toggle it in existing projects Edit ▶︎ Substitutions ▶︎ Smart dashes and Ellipses.


Thank you -- I love you! So grateful to you. Been screwing around with this for half an hour. This worked.