Remove formatting in footnotes

User avatar
uhu
Posts: 97
Joined: Wed Oct 20, 2010 6:43 am
Platform: Mac
Contact:

Tue Oct 04, 2016 9:07 am Post

This sounds like a stupid question yet I couldn't find an answer (or thread) for this:
When working with footnotes, and accidentially applying a bulleted/numbered list, or wring font, I cannot remove the formatting. There is no option with right-click, and "Apply formatting preset" doesn't work with footnotes. Working in Compose mode, footnotes are in their separate window.

Is there a simple way to just remove all formatting in footnotes?

Also, in a similar matter: is it possible to set a keyboard shortcut for Paste Without Formatting? Shift+Command+V wouldn't work.
Thanks!
Book on Jugger, download for free –- a real-world post-apocalyptic sport :: twitter :: writing factbooks, novels and SciFi series books with Scrivener

ru
runa
Posts: 5
Joined: Wed Nov 02, 2016 4:49 pm
Platform: Mac

Wed Nov 02, 2016 4:53 pm Post

Hi Uhu,

I have a similar problem, which I will post in a different message, but to answer to your second question, some Mac applications require the combination Shift+alt+cmd+v to paste without format. This is the case with Safari, and also with Scrivener.

Hope it helps.

User avatar
AmberV
Posts: 24331
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Thu Nov 03, 2016 3:37 am Post

Although Shift-Opt-Cmd-V will strip formatting, bullets are also in part literal text; the tab + symbol + tab construct won’t be stripped from what you see, just like the letter ‘a’ wouldn’t. The same effect could be observed if you copied and pasted into a plain-text TextEdit window. You should note however that the list is “broken” in that if you put your cursor on the end of a line in the middle of the list and press return, it won’t act like a list. It’s just static text at this point.

So to get rid of the text bits, you’d want to use search replace most likely.

uhu wrote:There is no option with right-click, and “Apply formatting preset” doesn’t work with footnotes. Working in Compose mode, footnotes are in their separate window.

I don’t quite follow that part. To right-click on a footnote it doesn’t matter if it is in the sidebar or a floating window. The command is “Convert to Default Formatting” though, not “Apply formatting preset”, so we might be referring to different things. You should be seeing the former along with two other menu functions when you right-click on them. Maybe you are editing the text when right-clicking? Try when not editing.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
uhu
Posts: 97
Joined: Wed Oct 20, 2010 6:43 am
Platform: Mac
Contact:

Tue Nov 29, 2016 8:33 am Post

AmberV wrote:I don’t quite follow that part. To right-click on a footnote it doesn’t matter if it is in the sidebar or a floating window. The command is “Convert to Default Formatting” though, not “Apply formatting preset”, so we might be referring to different things. You should be seeing the former along with two other menu functions when you right-click on them. Maybe you are editing the text when right-clicking? Try when not editing.


Interesting. Exactly as you said, editing is the key. As soon as I edit a footnote, the right-click menu changes and doesn't offer the "Convert" feature anymore, but the "Apply", which doesn't work. Only if I click on the footnote before editing it, the two-option menu appears. Confusing :)

Thanks for the clarification!
Book on Jugger, download for free –- a real-world post-apocalyptic sport :: twitter :: writing factbooks, novels and SciFi series books with Scrivener

da
darthkt
Posts: 5
Joined: Tue Jan 30, 2018 9:31 pm
Platform: Mac

Wed Feb 21, 2018 1:53 pm Post

I had the same question regarding formatted text in the footnote panel – call me type A, but it was very irritating! I wish there was a global setting to force the footnotes to be unformatted. Until then, the right click works – thanks.

User avatar
AmberV
Posts: 24331
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Wed Feb 21, 2018 2:11 pm Post

I think converting the formatting to default is the closest concept to “unformatted footnotes” you’ll find in this software. Since it is a rich text editor, there isn’t really such a thing as unformatted text. The only close analogy to that is “defaults”, which is right back where we started.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles