How do I set a default font?

sc
scrivenerinnz
Posts: 1
Joined: Mon Aug 22, 2016 3:01 am
Platform: Mac

Mon Aug 22, 2016 3:06 am Post

I'm using Scrivener 2.6 for Mac, how do I set a new default font so I never have to see that horrible Cochin font again? thanks. I have tried to change the preferences but when I generate a new document it keeps defaluting to Cochin!

User avatar
markfasano
Posts: 56
Joined: Tue May 27, 2014 10:57 pm
Platform: Mac, Win + iOS
Location: Philly

Mon Aug 22, 2016 3:35 am Post

Try posting your question in the Mac forum

Fl
Flur
Posts: 86
Joined: Thu Nov 04, 2010 4:19 am
Platform: Mac + Windows
Location: Seattle, WA

Tue Sep 06, 2016 7:59 pm Post

I have this problem also and I have a default font set on my mac. The setting doesn't seem to carry over. Is there a way to do that in the iOS app, or is it supposed to carry over and this is a bug? Thanks.

EDIT: nvm, I see that AmberV answered this in a different head - "Sure, select some text you want to use as the default, tap the formatting brush, go into Formatting Options, then tap Set as Default Formatting." Thanks, AmberV!

User avatar
AmberV
Posts: 24407
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Tue Sep 06, 2016 8:17 pm Post

Here is an article in the knowledge base on fixing formatting and setting up defaults.

Moderator Note: moved topic to macOS support board.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

od
odysseus
Posts: 21
Joined: Mon Nov 20, 2006 5:50 pm

Fri Sep 30, 2016 3:52 pm Post

This still isn't working for me. Every time I create a new note, the Cochin font is used, but nowhere in any setting is Cochin specified! (and I just created a new project) In addition, if I used Documents > Convert > Convert Formatting to Default Text Style …, the font used is not converted to the default text style specified in Preferences > Formatting (and Project > Text Preferences… is not set to override global preferences).

Is this a bug associated with running Scrivener on mac OS Sierra?

User avatar
AmberV
Posts: 24407
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Fri Sep 30, 2016 10:17 pm Post

When you say it isn’t working in a new project, have you tried a dirt simple test along those lines, of using the Blank starter, and as soon as it loads doing absolutely nothing at all but typing in a few letters and seeing what the Format Bar prints regarding the font? You don’t even have to click anywhere since creating a new blank project boots your cursor into the editor.

As for bugs, I don’t see anything like this in 10.12 myself. You could try resetting your preferences file:

  1. Go to the main preferences panel in Scrivener and use the Manage... drop-down menu to backup a copy of your settings to the desktop.
  2. From the main Scrivener menu, select “Reveal Support Folder in Finder”. This will open a window in Finder.
  3. Quit Scrivener.
  4. Back in that Finder window opened in step #2, press Cmd-UpArrow twice. You should be in a “Library” folder, double-click on the “Preferences” folder.
  5. You should see one or two files starting with “com.literatureandlatte.scrivener2”. Move any files like that to the trash.
  6. Either log out and back in to your account, or open Terminal and issue the following command: killall -u $USER cfprefsd, to reset the preference cache system, which tends to ignore changes made to the disk.
  7. Reload Scrivener and verify the problem is gone.
  8. Use the Manage... drop-down to load your preferences from the desktop backup file.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

od
odysseus
Posts: 21
Joined: Mon Nov 20, 2006 5:50 pm

Fri Sep 30, 2016 11:15 pm Post

Even following those instructions (i.e. removing the prefs), the problem is not gone (i.e. the default font is "Cochin"). Helvetica should be the default notes font, but it isn't!
Attachments
font.png
font.png (150.68 KiB) Viewed 8252 times

User avatar
AmberV
Posts: 24407
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Sat Oct 01, 2016 2:41 am Post

Just to make sure we’re on the same page, earlier when you said you were making a new note, I figured you meant a new text file, and that you were typing into the main text editor, where you would normally write. Am I to understand that you are typing into the Inspector, within the “Notes” pane? If so that is where Helvetica would be applied, given your settings. As for the “Main Text Style” itself, well I can’t say for sure, but it looks like Cochin is your default font to me, with a 0.25" first-line indent and 1.2 line-height. All of that sample text in the top third of that pane is your default format. It's like a mini-editor, only you can't change the sample text, just style it.

If you find it easier, find some text in your editor that already looks the way you want it to, put your cursor in it, and then use the Use Formatting in Current Editor button this preference pane to bring those settings in.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

od
odysseus
Posts: 21
Joined: Mon Nov 20, 2006 5:50 pm

Sat Oct 01, 2016 2:09 pm Post

We're on the same page. I'm typing into the main text editor.

You are right in that Cochin is the default font, but where in the app does it indicate that Cochin is the default font? Just as importantly, why is Cochin the default font after I trashed the preferences?

Here's what fixed the problem. I performed some Google searches for "Scrivener formatting," and found an explanatory video that showed the user clicking on that "Aa" button (in the "mini-editor") and setting the font there. When I clicked on that button, I saw that Cochin was the default font, and I changed it to "Times" there. But how would the user know to click there? And that's what's being used in Notes, even though "Notes Font:" hasn't changed and still indicates Helvetica 12!

By the way, I had trouble getting the Use Formatting in Current Editor button to do anything!

User avatar
AmberV
Posts: 24407
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Oct 03, 2016 9:24 pm Post

You are right in that Cochin is the default font, but where in the app does it indicate that Cochin is the default font? Just as importantly, why is Cochin the default font after I trashed the preferences?

Cochin 14pt is the default font, so we would expect it to be there after a reset. The reset was more to check and make sure that setting wasn’t stuck in such a way that you couldn’t change it, or that it wouldn’t store your changes.

To answer your other question, it isn’t printed directly in the interface as words you can see, there is not always space enough to show all of the font selection controls. There is one other place where that happens, in the Formatting compile option pane, where you would use a very similar interface to change what things look like during compile.

Thanks to your comments I did spot an error in the user manual though, which refers to this button as an italic “A”. That’s what it was before the skin update last year.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

od
odysseus
Posts: 21
Joined: Mon Nov 20, 2006 5:50 pm

Mon Oct 03, 2016 10:19 pm Post

Again, you haven't explained why Scrivener indicates that Helvetica 12 is the Notes font but that isn't actually the font used in the body of notes; instead, the font appears to be determined by the "Aa" button in the ruler for "Main Text Style."

This is bad UI design, IMHO.

User avatar
AmberV
Posts: 24407
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Tue Oct 04, 2016 4:30 am Post

That would be bad design if it were working that way intentionally, but what are you are describing is not how it works when it is working correctly. I’ve tested what you report, and under no circumstances do I get main text font settings in the Scratch Pad, Project Notes window, or Document/Project Notes in the Inspector. The only setting that impacts new notes is the “Notes font” setting, for me.

So I must not be doing the right sequence of steps in order to see what you’re seeing, I could use some pointers on what to do.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

od
odysseus
Posts: 21
Joined: Mon Nov 20, 2006 5:50 pm

Tue Oct 04, 2016 11:00 am Post

If you delete preferences, restart your machine, relaunch Scrivener, start New Project, does "Notes Font:" indicate Cochin 14? Please post a screenshot. Maybe I'm not understanding what "Notes Font:" is supposed to change -- I’m talking about the main body of the note.

Hu
Hugh
Posts: 2444
Joined: Thu Mar 08, 2007 12:05 pm
Platform: Mac
Location: UK

Tue Oct 04, 2016 12:08 pm Post

"Notes font" in the Formatting Preferences refers to "...text font settings in the Scratch Pad, Project Notes window, or Document/Project Notes in the Inspector...", as Ioa/AmberV has written above. It does not refer to the text you are writing in the Editor pane of Scrivener, as part of a book or other long-form project. That is set in the uppermost section of that pane, under the ruler, using the "Aa" button top-left just under the Heading "Main Text Style" and just above the ruler.

(The word "Notes" has a particular meaning in Scrivener. It does not refer to the main body of the text that you are writing in the Editor. It refers to various kinds of meta-data which, when you are working on a long project, run alongside the main text and are not intended for readers to read, but instead help the writer to write. You can, if you so wish, use a different typeface in your Notes from that which you use in the Editor in your project, and those two different typefaces can be set in two different places - the "Aa" button and the "Notes font" window - on that pane in Formatting Preferences.)
'Listen, some quiet night, when you've shirked your work that day. Do you hear
that distant, almost inaudible clicking sound? That's one of your
competitors, working away in the night in
Paris or London or Erie, PA.'

od
odysseus
Posts: 21
Joined: Mon Nov 20, 2006 5:50 pm

Tue Oct 04, 2016 12:59 pm Post

Thanks, Hugh. I figured that we must have been talking about two different things.