Problem with Table of Content

Li
LittleClue
Posts: 11
Joined: Mon Nov 10, 2014 4:32 pm
Platform: Mac

Wed Jan 27, 2016 10:34 am Post

I create a table of content with copy-copy special-copy as toc. The toc shows the title, a tab stop, and the page number. When I compile to pdf the page number appears on the line below the title, meaning there is a line break. Ugly. I have one document where the TOC aligns properly and three where it doesn't. The three that don't work have a smaller page size.

User avatar
kewms
Posts: 6566
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Wed Jan 27, 2016 5:11 pm Post

LittleClue wrote:The three that don't work have a smaller page size.


That is likely the problem: the ToC is generated for a larger page than is actually available in the finished document.

Try creating the ToC in Page View in Scrivener, making sure that your page settings match what you'll actually be using. That will let you see and fix any problems before compiling.

Katherine
Scrivener Support Team

Li
LittleClue
Posts: 11
Joined: Mon Nov 10, 2014 4:32 pm
Platform: Mac

Thu Jan 28, 2016 3:55 am Post

Thanks for the input. What does that mean: "making sure that your page settings match what you'll actually be using."
The page settings are set to the actual size I'm publishing at createspace. I do the ToC copy and paste and after that I do not change any page settings. Also, I see no way of changing the TOC indents or formatting the TOC.

User avatar
kewms
Posts: 6566
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Thu Jan 28, 2016 7:21 am Post

You need to make sure that the settings used for Scrivener's Page View, which come from the File -> Page Setup command, match the settings used for your output document, which uses the File -> Compile -> Page Settings pane.

Also, in the File -> Compile -> Contents pane, check the Compile As-Is box for the ToC document.

The Format -> Show Ruler command will show tabs and indents and allow you to change them. The Format -> Options -> Show Invisibles command will show you tab characters in the ToC document itself.

Katherine
Scrivener Support Team

Li
LittleClue
Posts: 11
Joined: Mon Nov 10, 2014 4:32 pm
Platform: Mac

Fri Jan 29, 2016 5:43 am Post

It worked. Thank you!

Om
OmSwaha
Posts: 10
Joined: Thu Jan 12, 2017 3:44 am
Platform: Mac

Mon May 08, 2017 9:07 pm Post

Thanks - I had this problem too... :)

User avatar
DavidWSnow
Posts: 97
Joined: Wed Jun 22, 2016 10:25 pm
Platform: Mac
Location: Outside Seattle Washington

Tue May 09, 2017 3:15 pm Post

kewms' answer about page size seems also to answer my unanswered question in viewtopic.php?f=2&t=38319 It also points out that Scrivener treats File => Page Setup different that Compile => Page Settings => Page Setup when doing a Edit => Copy Special => Copy as TOC. This just might be a BUG.

I have always used the Compile setting to adjust my page size, I now realize that maybe I should never use that one.