El Capitan 10.11.2 crash on loading project to Full Screen

si
sidderke
Posts: 167
Joined: Thu Dec 03, 2015 11:34 pm
Platform: Mac

Tue Dec 15, 2015 9:57 pm Post

For me it's strange:

I've had a lot of crashes, but funnily, when I close a project... For instance: I have 2 projects open, I close one, it's busy making it's backup, and then it gives a message it crashed (taking the other one with it).

It's not been super annoying for me because:
- the autosave makes sure I never lose anything.
- I do have the feeling it first finished the backup and *then* crashes.
- unlike some other people here it never fails opening a project, and it never crashes *during* working, so I thought it was a simple bug somewhere that could get solved in a .1 update.
I sent some crash logs, but not all.

I have it both on my iMac and my Macbook Air. I have the latest El Capitan, latest version of Scrivener from the App Store. No old projects, I just started using the software lately for the first time.

User avatar
AmberV
Posts: 23910
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Tue Dec 15, 2015 10:43 pm Post

Important: If you are experiencing a crash that does not match the OP’s description, please search for an existing thread that matches your crash, or make a new one, thanks!

We’re still looking into the problem that involves crashing when loading existing projects on some systems. One common thing found in the crash reports is an OS X animation sequence that may be involved with transitioning the window to Full Screen mode. Is anyone experiencing this bug not using Full Screen mode on the affected projects?

There is a way to clear the project’s display settings while it is closed. Something you could try is duplicate or zip one of the projects in Finder to create a quick backup, then right-click on it and select “Show Package Contents”. Drill down into the Settings subfolder and set aside the ui.plist file. Now try double-clicking on the project to load it.

If that works, we’d appreciate a sample of your ui.plist file so we can try and reproduce it on our machines. PM it to me as an attachment or mail it in to our tech-support, referencing this thread URL in your e-mail.

I’ve had a lot of crashes, but funnily, when I close a project…


That’s an older bug from 10.10.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
Qlibet
Posts: 34
Joined: Thu Nov 05, 2009 10:49 pm
Platform: Mac
Location: Madrid (Spain)

Tue Dec 15, 2015 11:16 pm Post

AmberV wrote:[b]
There is a way to clear the project’s display settings while it is closed. Something you could try is duplicate or zip one of the projects in Finder to create a quick backup, then right-click on it and select “Show Package Contents”. Drill down into the Settings subfolder and set aside the ui.plist file. Now try double-clicking on the project to load it.


This seems to work for me.
Attachments
ui.plist.zip
(8.96 KiB) Downloaded 120 times

User avatar
AmberV
Posts: 23910
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Tue Dec 15, 2015 11:36 pm Post

Excellent, hopefully that works for everyone else. Thanks for the file, we'll take a look at that.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

ma
marcoiac
Posts: 445
Joined: Mon Aug 29, 2011 12:12 am
Platform: Mac

Wed Dec 16, 2015 5:42 am Post

AmberV wrote:One common thing found in the crash reports is an OS X animation sequence that may be involved with transitioning the window to Full Screen mode.


You may be onto something here. I don't think it's just Scrivener. I have seen other apps having suspicious crashes on my machines and I tend to use pretty much everything in full screen

sp
spacequeer
Posts: 4
Joined: Wed Sep 23, 2015 12:27 am
Platform: Mac

Wed Dec 16, 2015 6:01 pm Post

Removing the ui.plist worked for me as well, and I'd frequently crashed on full screen. Thanks y'all, file is attached below.
Attachments
ui.plist.zip
(25.01 KiB) Downloaded 79 times

User avatar
AmberV
Posts: 23910
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Wed Dec 16, 2015 11:15 pm Post

Thanks! Full Screen has never been the most stable of environments, from the very start it was a mess, and jamming the whole Split View system into it seems to have had a further negative effect on its stability. Hopefully we can find something in these files that suggests otherwise, but given the projects seem to work fine on other machines, there probably nothing at all wrong with them—just that they are requesting a view mode from the system that is inherently unstable.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

lu
lucouto
Posts: 4
Joined: Fri May 16, 2014 10:22 am
Platform: Mac

Thu Dec 17, 2015 1:15 pm Post

Same here: after deleting the ui.plist file inside an old project, I can finally open and use it. Not the ideal solution, but in the meanwhile it's working...

ev
evanleatherwood
Posts: 2
Joined: Tue Dec 15, 2015 9:31 pm
Platform: Mac

Thu Dec 17, 2015 3:35 pm Post

Hi all -- Turns out that my Scrivener preferences files were damaged during the upgrade to El Capitan. I had to go into the library and get rid of them, then everything started working just fine again.

Pasted below, find the fix from the Scrivener team:

<<>>

// PLEASE REPLY ABOVE THIS LINE
==================================================

I'm afraid the crash report was not attached to your email.

Have you tried resetting Scrivener's Preferences files? If not, please do so:
Please do this, which will reset Scrivener's Preferences file:

* Close Scrivener.

* Open Finder and click the "Go" option in the menu. Hold down the ALT/OPTION key to reveal the "Library" folder, then click it to open it.

-- If you are using the Mac App Store version of Scrivener, browse to "~/Library/Containers/com.literatureandlatte.scrivener2/Data/Library/Preferences"

-- If you are using the direct-sale version of Scrivener (downloaded from our website), browse to "~/Library/Preferences"

* Find any files that begin with "com.literatureandlatte.scrivener2" and copy these to your desktop (this is not to be confused with the com.literatureandlatte.scrivener2 folder that you encountered while getting to the Preferences folder).

* Now delete the original copies of the files that start with com.literatureandlatte.scrivener2.

* Restart Scrivener.

If your original account crashes, but a new one doesn't, one possibility is that the Preferences file for your original copy of Scrivener is damaged.

(Just to clarify, the El Capitan crash fix changed your Mac's *global* preferences file. Here, I'm just asking you to reset Scrivener's own preferences.)

Katherine

ka
karenranney
Posts: 8
Joined: Wed Nov 30, 2011 12:44 am
Platform: Mac

Fri Dec 18, 2015 1:27 am Post

Thank you. I've been crashing all day and this works. I haven't attached a crash report - got a little tired of sending them after five or so.

kr
krisjnic
Posts: 1
Joined: Sun Dec 20, 2015 4:12 pm
Platform: Mac
Location: Wisconsin, USA

Sun Dec 20, 2015 4:37 pm Post

evanleatherwood wrote: reset Scrivener's Preferences file:

* Close Scrivener.

* Open Finder and click the "Go" option in the menu. Hold down the ALT/OPTION key to reveal the "Library" folder, then click it to open it.

-- If you are using the Mac App Store version of Scrivener, browse to "~/Library/Containers/com.literatureandlatte.scrivener2/Data/Library/Preferences"

-- If you are using the direct-sale version of Scrivener (downloaded from our website), browse to "~/Library/Preferences"

* Find any files that begin with "com.literatureandlatte.scrivener2" and copy these to your desktop (this is not to be confused with the com.literatureandlatte.scrivener2 folder that you encountered while getting to the Preferences folder).

* Now delete the original copies of the files that start with com.literatureandlatte.scrivener2.

* Restart Scrivener.


Thanks, evanleatherwood for posting that fix. It worked for me.

Just to help anyone else, I can share of few of the things that helped me:
1. Launching Scrivener while holding the shift key and then opening up a new project. With a project open, I was able to open my old project just fine.
2. Once the old project was open, I exited full-screen mode. The old project opened and closed fine in regular screen mode.
3. Evenleatherwood's directions to reset the preferences allows me to open in full screen mode again (for now!). I lost a few preference settings, but no big deal.

So all is well with me now. Happy Writing! :D

jt
jtellison
Posts: 5
Joined: Mon Jan 11, 2010 10:40 pm

Wed Dec 23, 2015 1:17 am Post

JTell here -- this fix worked for me. Once I got the files open (after multiple reopen forces) I took it out of full screen mode, closed, and reopened with no problem.

A simple fix for the time being!

ni
nicwg
Posts: 25
Joined: Mon Oct 21, 2013 11:59 am
Platform: Mac + Windows

Tue Dec 29, 2015 5:50 pm Post

I didn't find that deleting the scrivener preference file worked for me. In fact it made the problem worse and I repasted the file from the desktop. However krsjnic's comment about reaccessing the file and then exiting full frame worked on my Intel Mac mini.

Phew!! Thanks. Hope this work round eventually gets sorted!!

User avatar
AmberV
Posts: 23910
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Thu Dec 31, 2015 8:10 pm Post

There should be no need to reset the application preferences, the piece of information that stores what mode (full screen or standard) a project should load in are saved inside the individual project’s settings file, as describe in my above post.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
kewms
Posts: 5630
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Fri Jan 01, 2016 6:02 am Post

What AmberV said. Resetting the Scrivener Preferences helped that specific individual -- he reposted a suggestion that I sent him through our support system -- but it's not a general solution for all crashes.

Generally speaking, I encourage users to simplify the problem as much as possible. First open Scrivener with no projects, then with one project at a time. The more precisely you can define the circumstances that cause a crash, the easier it is to fix the underlying cause.

Katherine
Scrivener Support Team

 

 

cron