Superscript issue on Compile issue

da
dazzjazz
Posts: 36
Joined: Fri Jul 24, 2015 4:54 am
Platform: Mac

Fri Aug 07, 2015 1:18 am Post

Hi,

Scrivener correctly reformats as superscript numbers when I type "1st" for example.
However, upon compile to Word docs, these become really small and unreadable.

The regular text is unchanged - I'm using Cochin 14pt.

How do I fix this please?

Darren

Br
Briar Kit
Posts: 1787
Joined: Thu Apr 04, 2013 9:04 am
Platform: Mac

Fri Aug 07, 2015 6:50 am Post

Until someone comes up with a better answer, a suggestion here…

viewtopic.php?f=2&t=31232&start=0&hilit=superscript+compile+word
Account closed January 2017

da
dazzjazz
Posts: 36
Joined: Fri Jul 24, 2015 4:54 am
Platform: Mac

Fri Aug 14, 2015 5:13 am Post

Thanks Briar, I will check it out, but would much prefer to fix this once and for all within Scrivener - any other takers on this issue?

re
reepicheep
Posts: 509
Joined: Sat Aug 22, 2009 5:11 pm
Platform: Mac + iOS

Fri Aug 14, 2015 9:45 am Post

I'd blame Word for this. Their text engine is replicating the work already done by Scrivener. You need to turn off the "superscript ordinal setting" in one of the products. Personally I'd switch off Word's version of that as I do all typing in Scrivener.
Techie details in case I forget

Scrivener 3.1.3 (11945)
Mac OS X 10.13.6
Scrivener 1.1.5 (1301)
iOS 9.3.5/12.3.1

User avatar
Cassady
Posts: 196
Joined: Sun Jun 16, 2013 12:06 pm
Platform: Mac + iOS
Location: Sqornshellous

Fri Aug 14, 2015 8:13 pm Post

I have the same issue - but made peace with the fact that I would search and replace in Word after the fact.

See some other suggestions here, that I will try out.

User avatar
xiamenese
Posts: 4370
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Fri Aug 14, 2015 10:10 pm Post

I use Nisus Writer Pro, and there is the same issue, but it doesn't faze me. In NWP I have set up the "Note reference" style to be 2 points smaller than body text, with baseline raised by two points. When I open an RTF produced by Scrivener, the note references are all superscripted, but I only have to select one, hit the "Select all" mechanism and unselect "Superscript" and they are all put right. Three clicks of the mouse to deal with all of them throughout the entire manuscript.

I'm sure Word can do the same, but I don't know how, since I haven't used Word since version 5.1a.

Mr X
The Scrivenato sometimes known as Mr X.
iMac 27" (late 2015) 10.15.4, 24GB RAM, 512GB SSID
MBP17" (late 2011) 10.13.6, 16GB RAM, 2TB SSID
2017 iPad, iPadOS 13.3, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

da
dazzjazz
Posts: 36
Joined: Fri Jul 24, 2015 4:54 am
Platform: Mac

Tue Aug 18, 2015 3:06 am Post

Thanks - how do I do that though? Can't find it!

reepicheep wrote:I'd blame Word for this. Their text engine is replicating the work already done by Scrivener. You need to turn off the "superscript ordinal setting" in one of the products. Personally I'd switch off Word's version of that as I do all typing in Scrivener.

da
dazzjazz
Posts: 36
Joined: Fri Jul 24, 2015 4:54 am
Platform: Mac

Sat Dec 10, 2016 1:11 am Post

This is still an issue - however, it seems to be Scrivener's fault and not Word's.

If I type in Word "13th", the "th" is converted to superscript at an acceptable font size.

Help!

da
dazzjazz
Posts: 36
Joined: Fri Jul 24, 2015 4:54 am
Platform: Mac

Sat Oct 07, 2017 11:42 pm Post

Hi all,
Sorry to raise this issue with superscripts again, but as I am getting really close to submitting my PhD, it's a headache I can do without.

Compiling to PDF renders the superscripts correctly, whereas compiling to Word doesn't. Elsewhere on this thread it is suggested to turn off superscripts in Word, which I've done and it makes no difference - is the problem Scrivener then?

Would appreciate a solution!

Thanks

Darren

User avatar
xiamenese
Posts: 4370
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Sun Oct 08, 2017 8:43 am Post

The problem is neither Scrivener’s nor Word’s; both text engines are applying superscript, which is proper in each, but when you when you open your text in Word—or NWP—it is super scripting already superscripted text. You have to turn it off in one of them, and it should be easier in Word, I imagine, just as it is in NWP.

As I said, I haven’t used Word in years, but there must be a way to select all superscripted text and unsuperscript it. Is there no one where you are who really knows their way around Word and can help you do it?

Mark
The Scrivenato sometimes known as Mr X.
iMac 27" (late 2015) 10.15.4, 24GB RAM, 512GB SSID
MBP17" (late 2011) 10.13.6, 16GB RAM, 2TB SSID
2017 iPad, iPadOS 13.3, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

br
brookter
Posts: 2101
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Sun Oct 08, 2017 9:28 am Post

There is way I think -- fiddly, but easy enough.

@Darren,

Try this -- but obviously give it a couple of test runs first. This using Word 15.33.

We're going to do it two parts: first, correct a single superscript so we know what attributes to change. Then we'll automate it using Find and Replace Formatting.

Step 1.

First of all, you need to find out what Word thinks it's doing. Highlight a reference and click cmd-D for the font dialogue. On the Font tab, you'll see that superscript is enabled. Check you're happy with the font / size etc. Then click on Advanced, and look at the position box. If it says 'Normal' (it did on mine) then change it to 'Raised'. By: will probably read 3pt. Click OK and see what's happened. You should see the superscript has been raised to a more normal position. Experiment with the value of Raised By and remember what works best.

Now you need to set the size of the font: do this either on the Font tab with font size, or in the Advanced using Scale %.

You may have to play around, but eventually you should get the effect you want. Remember the settings...

Step 2.

Now we'll apply the same settings to every reference.

1. Go to Edit > Find > Advanced Find and Replace... In the Find table, leave the Find what: box empty, and all the other tick boxes unticked. At bottom, press No Formatting to clear any previous format searches, then Format > Font... [Remember that the Find box itself must be empty -- you're looking for formatting only, not content.]

2. This will bring up the Find Format dialogue. On the Font tab, unselect everything except for Superscript. In Advanced, make sure all the boxes are empty (apart from Enable TrueType, which isn't relevant here).

3. Press enter to go back to the Find dialogue. You may want to click Find Next, to check it's picking up the references here.

4. Still in Advanced Find and Replace, go to the Replace tab and click No Formatting, then on Format > Font... again. Go to the Font tab and again, make sure everything is empty, apart from Superscript and your new Font Size. Then go to Advanced, and change Position to Raised, by <whatever you found was the best before>.

5. Click OK to go back to Advanced Find and Replace, then on Replace. You should see your references change to your chosen size / position.


This is fiddly and you'll probably have to do a fair amount of tweaking till you're happy with the results, so test it properly. I was hoping that word would assign a specific character style to the references, but I couldn't find one -- that would have made it a lot easier to search and replace.

But as you've tried everything else, perhaps this will get you through the PhD... Good luck.

(And if anyone's got an easier way, do tell....)

Ma
Mac
Posts: 86
Joined: Tue Jun 19, 2012 11:28 am
Platform: Mac + iOS

Sun Oct 08, 2017 9:52 am Post

1. Compile to doc or docx or rtf

2. Open in Pages, where superscript will be perfect

3. Save to Word, if necessary

Works?

da
dazzjazz
Posts: 36
Joined: Fri Jul 24, 2015 4:54 am
Platform: Mac

Sun Oct 08, 2017 10:12 pm Post

Thanks everyone - I will test out later in the week when I have some time, and report back.

Darren

da
dazzjazz
Posts: 36
Joined: Fri Jul 24, 2015 4:54 am
Platform: Mac

Fri Oct 13, 2017 2:01 am Post

No, this doesn't work unfortunately - Word is still screwing up the superscripts.

Mac wrote:1. Compile to doc or docx or rtf

2. Open in Pages, where superscript will be perfect

3. Save to Word, if necessary

Works?

da
dazzjazz
Posts: 36
Joined: Fri Jul 24, 2015 4:54 am
Platform: Mac

Fri Oct 13, 2017 2:19 am Post

Many thanks for this. I got it to work first time.
Some observations:

Word told me my superscripts were 9 point, but they were so very minuscule. More like 0.009 point! I don't understand this...I changed them to 14point and they look good and don't mess up the line height.

I'd rather not have to do this whole process but if I plan things right, I will only have to do it once.

Thanks again.

Darren


brookter wrote:There is way I think -- fiddly, but easy enough.