Problems creating image captions

we
wezlo
Posts: 19
Joined: Wed Nov 12, 2014 3:26 pm
Platform: Mac

Tue May 19, 2015 2:57 pm Post

Hi, I'm on OS X, using version 2.6

I'm having difficulty creating image captions for a project I'm working on. I've followed the instructions in the manual, but when I compile my document the captions aren't created. I've used both image placeholders and a copied image into a document, but nothing works. The image is inserted, but the caption is treated like a paragraph.

I know the captions don't work for every format, but according to the documentation they should work in ODT, and I can't seem to figure it out.

Basically, right now I'm trying variations of the placeholder and square brackets so...

Code: Select all

<$img: name;h=400> [caption]


I know it's something dumb I'm missing, can anyone help me out?

User avatar
AmberV
Posts: 23247
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Tue May 19, 2015 6:28 pm Post

The caption text formation you are referring to is a Scrivener-specific shorthand one can use to create captions with the MultiMarkdown system (ordinarily one would have to type out the entire image code by hand to get captions), that might be what you were reading about? MultiMarkdown does have its own ODT export format, but it is completely different than the ODT option at the top of the “Compile For” menu, so that may be the point of confusion.

In “normal”, non-Markdown style writing, there is no mechanism for creating captions as meta-data attached to a figure. If you need them to be specially formatted then that is something you’ll need to save for a later phase of the project, and for now just mark them down in some fashion so you can go through and convert them in a word processor later on.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

we
wezlo
Posts: 19
Joined: Wed Nov 12, 2014 3:26 pm
Platform: Mac

Wed Nov 11, 2015 11:26 pm Post

I'm sorry I missed this when you posted it, but thank you for the detailed response!