Can't use templates

jc
jcarman
Posts: 195
Joined: Sun Nov 01, 2009 6:28 pm

Mon Feb 16, 2015 11:00 pm Post

Hello,

I cannot use the "New from Template" item in Scrivener. Templates do not appear in the menu. Am I using the right directory for them? (That's my user name that's blacked out.)
Attachments
notemplates.jpg
notemplates.jpg (213.16 KiB) Viewed 482 times

User avatar
AmberV
Posts: 24882
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Tue Feb 17, 2015 12:47 am Post

These are for Document Templates, not Project Templates. The former are for creating boilerplate texts within your project, the latter are for creating whole project starters (and as such, these can actually set up and use document templates as a part of the project template). Incidentally where you manage projects is the File menu. If you want to start with a project template, use File/New Project... to load the template browser.

There is an interactive tutorial step (#21) that walks you through the basics of what this feature is, how to enable it in your projects and set up boilerplates. You’ll also find full documentation in the user manual PDF, §8.5 Document Templates, starting on the bottom of page 86.

Also, it appears you do not have a project open given the disabled state of that menu.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

jc
jcarman
Posts: 195
Joined: Sun Nov 01, 2009 6:28 pm

Tue Feb 17, 2015 2:34 am Post

Thank you, that makes much clear. However, if I want to have project templates in the dialog of the New Projects menu where does the directory lie for that?

-J

User avatar
AmberV
Posts: 24882
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Tue Feb 17, 2015 2:44 am Post

For project templates, you should have the right location, going by your screenshot. You can also get there from the “Reveal Support Folder in Finder” menu command, in the main Scrivener menu. Do note you can also import templates with the “Options” button in the lower left of the template chooser.

However one thing I noticed from your templates, by the icon they appear to be projects not templates. Make sure to create these using the File/Save As Template... command (doing so will automatically install them). The actual file will have a .scrivtemplate extension, not .scriv. So that may explain why you are not seeing anything come up.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

jc
jcarman
Posts: 195
Joined: Sun Nov 01, 2009 6:28 pm

Tue Feb 17, 2015 10:19 pm Post

You've hit the nail on the head. Right place, wrong format.

Thanks! That was a long-time itch.