Page 1 of 1

Missing underline

Posted: Thu Jan 23, 2014 2:54 pm
by seanmcint
When I export to a word doc and open in Pages, my underlines do not show up. According to the formatting menu the text is underlined but it is not. Also if I try and underline any text in the same document, the underline is not visible. :?:

Re: Missing underline

Posted: Thu Jan 23, 2014 6:34 pm
by KB
I can't think of anything that would cause that - underlines definitely work. I wonder if it could be a font issue. What font are you using? What happens if you try a different font?

Re: Missing underline

Posted: Thu Jan 23, 2014 6:47 pm
by Jaysen
Sorry if this is a stupid question, but are you exporting or compiling? If the later are you sure you are not overriding the formating in the compile settings?

Re: Missing underline

Posted: Fri Jan 24, 2014 1:43 pm
by seanmcint
Jaysen wrote:Sorry if this is a stupid question, but are you exporting or compiling? If the later are you sure you are not overriding the formating in the compile settings?


Yes, I am compiling to a docx file. However, when I open the file, in Pages, the formatting menu says that the text is underlined. Problem is, there is no underline visible on the page. I have tried exporting from pages to PDF and also printing.

I initially thought that I would add the underlines myself within Pages but it simply will not do it. A new Pages document functions normally.

Have attached a screenshot.

Screen Shot 2014-01-24 at 16.39.24.png
Screen Shot 2014-01-24 at 16.39.24.png (240.67 KiB) Viewed 208 times

Re: Missing underline

Posted: Fri Jan 24, 2014 1:50 pm
by Jaysen
As KB suggested (I should learn to never suggest anything once KB has posted) try changing the font in pages. Ex, highlight the offending text and use something other than courier. My bet is that there is no underline for the font (which seems odd to me). If that works, go back to compile and change the output font to the font that worked in pages. If that fixes the problem then it is 100% a font issue.

I must admit to being curious about the rest of the text from the sample provided.

Re: Missing underline

Posted: Fri Jan 24, 2014 2:39 pm
by KB
If the underline button is getting selected, then the underline is definitely being included in the file correctly and the problem is something in how it is getting displayed. If changing the font doesn't help, then another thing to check is whether the underline is white and thus not visible (although I'm not entirely sure how to change the underline colour in the new Pages).