Compilation for mobi & epub problems

po
pooks
Posts: 128
Joined: Mon Apr 28, 2008 11:23 pm

Sun Dec 15, 2013 2:56 pm Post

I have been struggling with this for days, and with a Tuesday release date, I'm really up against the wall.

Even though I've successfully created books this way before, this time, nothing is working. Is it the upgrade? No idea.

Copying the settings for earlier books doesn't work.

The ToC shows up like this:

CHAPTER ONE
Untitled Document
CHAPTER TWO
Untitled Document
[etc]

Because I don't title my chapters.

If I follow Keith's directions to remove the words 'untitled document' and use the space bar to put a blank space, I end up with double-spaced ToC in some parts but not others.

COVER
COPYRIGHT
DEDICATION
CHAPTER ONE

CHAPTER TWO

CHAPTER THREE

CHAPTER FOUR [etc.]

ABOUT THE AUTHOR
ABOUT THE PUBLISHER

This is only a couple of results. I have created 12 .mobis and not a single one of them has ended up well.

Help! Can someone please give me directions?

as
asotir
Posts: 190
Joined: Sun Jun 24, 2012 10:38 pm
Platform: Mac

Sun Dec 15, 2013 3:44 pm Post

Under compile, look at the Formatting tab. There you will see checkboxes for each of the file and folder levels. Uncheck the `Title' checkbox for your chapters. You should see in the preview field that the title goes away ... I have played with this on a sample file and achieved the results you want when compiling to a mobi file. (At first the title of the first document appeared, but that doc was not in a folder in the project - when i put it into a folder I got the results you desire.)

Note that all the documents in my test project have titles, some quite long. Just unchecking the Title checkbox kept the `Chapter One, two, three' et al but did not include the title in the table of contents, in the osX Kindle program.

Play around and good luck meeting your deadline.

asotir

po
pooks
Posts: 128
Joined: Mon Apr 28, 2008 11:23 pm

Sun Dec 15, 2013 5:16 pm Post

Thanks. I thought I'd already done that in one of my 12 attempts, but maybe not. Will certainly try again.

Also, "Cover" isn't showing up on my ToC. Not sure how to fix that.