"Word Lag"

Ev
EvPowers
Posts: 50
Joined: Thu May 26, 2011 5:09 pm
Platform: Mac

Thu Oct 24, 2013 3:59 pm Post

Since upgrading to Mavericks and V. 2.5.0., I get "word lag" when typing. It doesn't happen with every word, but with most. I'll start typing a word and the program will freeze for up to a second before catching up to my fingers. I also occasionally see the beach ball, but for a fraction of a second. These things never happened with ML and the last version of Scrivener.

Any ideas?

I have a late-2012 27" iMac with 24GB.
Writing on a late-2013 MacBook Pro running High Sierra and a 2017 12.9" iPad Pro.

Jo
Jordi Mora

Fri Oct 25, 2013 11:22 am Post

EvPowers wrote:Since upgrading to Mavericks and V. 2.5.0., I get "word lag" when typing. It doesn't happen with every word, but with most. I'll start typing a word and the program will freeze for up to a second before catching up to my fingers. I also occasionally see the beach ball, but for a fraction of a second. These things never happened with ML and the last version of Scrivener.

Any ideas?

I have a late-2012 27" iMac with 24GB.


Just to note that I am experiencing something similar this morning after the same double-update. There is a generally lagginess, which can be surprisingly uncomfortable, and then the occasional time when I will have finished typing a whole word before it appears on the screen. I've noticed the transient appearance of the beach ball too - would this indicate the auto-save in operation?

I have no other programmes running, and the same lag is not present when I'm writing in NWP. I have a 6 month old MBA 13".

Vi
Vinyassa
Posts: 11
Joined: Fri Jul 20, 2012 2:10 pm
Platform: Mac

Fri Oct 25, 2013 12:41 pm Post

For me exactly the same. Also after updating to Scrivener 2.5 and after installing Mavericks. In the old situation I had no problems, and I haven't experienced this problem in other programs that I use in Mavericks. I work on a MacBookAir 13", I think it's a model from approximately 2010. I hope someone can resolve this problem, because it makes me less happy using my good old Scrivener. Thanks!
Edit: I have been trying to solve this myself by putting off App Nap for Scrivener.app, but this wasn't the solution.

Br
Briar Kit
Posts: 1787
Joined: Thu Apr 04, 2013 9:04 am
Platform: Mac

Fri Oct 25, 2013 1:06 pm Post

Same here.
Account closed January 2017

User avatar
robertdguthrie
Posts: 3075
Joined: Mon Nov 09, 2009 10:06 pm
Platform: Mac
Location: St. Louis, MO, USA
Contact:

Fri Oct 25, 2013 2:02 pm Post

I fiddled with my settings a bit, because I've had trouble with the interaction of block cursors and fixed-width editors. That was fixed under Mtn. Lion (can't recall what the actual bug was?).

By disabling the fixed-width editor setting (Scrivener->Preferences->Editor->Use Fixed Width), I seem to have cleared it up with my very brief typing test. Perhaps those of you having this issue could try that? My cursor is still set to "Use block insertion point of 8 pixels" in the Editor preferences, if that has any bearing on the matter.
Often wrong, rarely in doubt.
Time for a change... I'm now rdale; same dog-avatar, same dog... channel?

Jo
Jordi Mora

Fri Oct 25, 2013 2:56 pm Post

robertdguthrie wrote:I fiddled with my settings a bit, because I've had trouble with the interaction of block cursors and fixed-width editors. That was fixed under Mtn. Lion (can't recall what the actual bug was?).

By disabling the fixed-width editor setting (Scrivener->Preferences->Editor->Use Fixed Width), I seem to have cleared it up with my very brief typing test. Perhaps those of you having this issue could try that? My cursor is still set to "Use block insertion point of 8 pixels" in the Editor preferences, if that has any bearing on the matter.


Thanks Robert - I rushed to try it but it didn't improve much and I still got the beachball.

Also just noted that no matter how I set the Compile main font it defaults to Devanagari MT - a font I have never chosen.

At the end of the day I'll shut down and see if a re-start with the fixed-width disabled makes a difference.

User avatar
robertdguthrie
Posts: 3075
Joined: Mon Nov 09, 2009 10:06 pm
Platform: Mac
Location: St. Louis, MO, USA
Contact:

Fri Oct 25, 2013 4:24 pm Post

I was just typing, and it seems my fix wasn't a fix for me either; the lag is rather sporadic. So never mind about the fixed width editor setting.

Addendum: I did just open a sample project where I was testing this bug on an alternative user account, which I created very recently (but before the Mavericks upgrade I did this morning). Editing in that Scrivener window does not exhibit this typing lag. I'm going to try two things; quit any services (like TypeItForMe) that weren't running on the other machine. If that doesn't seem to work, I'm going to try to archive my Scrivener settings on my main account and see if that solves the issue.
Often wrong, rarely in doubt.
Time for a change... I'm now rdale; same dog-avatar, same dog... channel?

User avatar
robertdguthrie
Posts: 3075
Joined: Mon Nov 09, 2009 10:06 pm
Platform: Mac
Location: St. Louis, MO, USA
Contact:

Fri Oct 25, 2013 5:01 pm Post

So, this is ultra weird; I can reliably trigger the lag by typing "seeing". Over and over, I get the lag after typing "se", though it will complete the word after a pause. I wonder if there's something going on with autocomplete or spell checking that triggers only on some words?
Often wrong, rarely in doubt.
Time for a change... I'm now rdale; same dog-avatar, same dog... channel?

User avatar
Jaysen
Posts: 6294
Joined: Mon Dec 17, 2007 4:00 am
Platform: Mac + Windows
Location: East-Be-Jesus-Nowhere SC, USA

Fri Oct 25, 2013 5:11 pm Post

That could be "positional" or qty of possible matches. What happens with "return"?

I have no idea how completion is done, but if it is using a web service you might try turning off net access to see if things get magically faster.
Jaysen

I have a wife and 2 kids that I can only attribute to a wiggle, a giggle, and the realization that she was out of my league so I might as well be happy with her as a friend. 26 years marriage later, I can't imagine life without her. -Me 10/7/09

ImageImage

Jo
Jordi Mora

Fri Oct 25, 2013 5:27 pm Post

robertdguthrie wrote:So, this is ultra weird; I can reliably trigger the lag by typing "seeing". Over and over, I get the lag after typing "se", though it will complete the word after a pause. I wonder if there's something going on with autocomplete or spell checking that triggers only on some words?


I thought the same so I disabled everything in the menu bar (Pop-clip, aText, Yoink, etc; even Alfred) and it didn't seem to make much difference. I disabled checking while typing too.

I'm going to try a few more pages with U3 just to make sure it's not something wider.

User avatar
robertdguthrie
Posts: 3075
Joined: Mon Nov 09, 2009 10:06 pm
Platform: Mac
Location: St. Louis, MO, USA
Contact:

Fri Oct 25, 2013 5:48 pm Post

It's definitely autocomplete for this particular word that really triggers it. "Return" does it a little. I think auto-completion is the key.

My setup: In Preferences->Corrections, I had "Suggest completions as you type" turned on, and "Only suggest completions from custom auto-complete list" under it was also on. I have "In script mode" off.

For a few minutes now, I've tested with the "Suggest completions as you type" option turned off, and I have not seen any lag from any word. I've typed as rapidly as I ever do, and the symptom has not appeared.

So, it appears that Scrivener and Mavericks' Text substitutions aren't playing nicely with one another. If you can live without Scrivener's Auto-Completions feature turned on, then you'll be able to type without lag until it's fixed. If anyone else can check this in their setup, that would help confirm if I've found the culprit or if I'm just barking up the wrong b-tree.
Often wrong, rarely in doubt.
Time for a change... I'm now rdale; same dog-avatar, same dog... channel?

Ev
EvPowers
Posts: 50
Joined: Thu May 26, 2011 5:09 pm
Platform: Mac

Fri Oct 25, 2013 6:00 pm Post

I haven't worked a lot in Scrivener the last couple of days, but it seems to have worked itself out for my. I tried "seeing" and "return" and many other words and it seems to have disappeared.

My computer has been on 5+ hours every day since updating to Mavericks. Not sure if that has anything to do with it but others have reported "glitches" disappearing after a day or two of operation.

User avatar
KB
Site Admin
Posts: 20900
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Fri Oct 25, 2013 7:26 pm Post

I've been running Scrivener on Mavericks for a couple of months now and have noticed no issues, although the latest GM seed does seem to have introduced some graphical glitches into the OS X text system. The main thing to bear in mind is that Scrivener just uses the standard NSText system, so this might be a Mavericks first release thing... Auto-complete or auto-correct sound like potential culprits, though, so I would try turning those off and seeing if that helps. Otherwise, if you can find any particular way of reproduction the slowdown, please let me know.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
robertdguthrie
Posts: 3075
Joined: Mon Nov 09, 2009 10:06 pm
Platform: Mac
Location: St. Louis, MO, USA
Contact:

Fri Oct 25, 2013 7:50 pm Post

For me, it reliably reproduces when I turn on "Suggest completions as you type". I wonder if it's some combination of that setting and another that I have set? Would you find it helpful for me to copy some Library file where my settings are stored? It's possible there's something in a .plist file or something that may be left over from previous versions, beta versions, etc... If you want any of those kinds of files, just let me know which ones, and I'll be glad to pass them on.
Often wrong, rarely in doubt.
Time for a change... I'm now rdale; same dog-avatar, same dog... channel?

User avatar
KB
Site Admin
Posts: 20900
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Fri Oct 25, 2013 8:31 pm Post

That option is a bit of an oddity, as it calls the auto-completion on each letter you type after a slight delay. It may be that Mavericks' auto-completion code is slower and thus causing the lag. I would just recommend turning it off. There are a tonne of things that are slower in Mavericks: Quick Look can take ages to show a preview, open and save panels can freeze, and lots more. We may just have to wait for some Mavericks updates for things to get faster again - it's always the risk of installing any first version of Apple software (or using first versions of their hardware, for that matter). They've made a lot of under-the-hood changes to squeeze extra battery life out of machines, and maybe this is having an effect on speed that they will need to address, but I'm just guessing here.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."