How to stay in cork board mode? (saving clicks!)

tr
troyscrivenerforum
Posts: 52
Joined: Tue Nov 22, 2011 2:02 pm
Platform: Mac + Windows

Tue Sep 24, 2013 1:04 pm Post

I'm currently outlining a project where I have some sequences set up as a folder, and separate scenes are associated with it in the hierarchy.

For example:

Sequence #1
> Scene A
> Scene B
> Scene C
> Scene D
> Scene E
> Scene F

Sequence #2
> Scene A
> Scene B
> Scene C
> Scene D
> Scene E
> Scene F

I like to click on the Sequence, in cork board mode, and write/edit in the index cards. I get a good overview of my sequence of events. However, when I jump to another sequence, and click, I'm taken out of cork board mode. Is this a bug? Shouldn't the cork board setting be persistent? I'm greeted with a black page in the middle column and constantly have to click up to the cork board button. Am I missing something in the preferences?

Thanks in advance.

User avatar
KB
Site Admin
Posts: 20729
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Sep 24, 2013 1:41 pm Post

This depends on what your "Sequence" documents are. If they are folders, then they should stay in corkboard mode; if not, then they should open in the text editor. When opening folders, they open in whatever group view mode was last used for a folder. When opening other documents, they always open in editor mode.

If you find that you use text containers (normal text documents, not folders, that have subdocuments) in such a way that you find you wish them to be treated the same as folders, opening in group view mode rather than editor mode, then turn on "Treat all documents with subdocuments as folders" in the "Navigation" pane.

Hope that helps.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

tr
troyscrivenerforum
Posts: 52
Joined: Tue Nov 22, 2011 2:02 pm
Platform: Mac + Windows

Tue Sep 24, 2013 1:50 pm Post

"Treat all documents with subdocuments as folders" in the "Navigation" pane.

Problem solved. You rock. Thank you.

User avatar
KB
Site Admin
Posts: 20729
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Sep 24, 2013 2:08 pm Post

Glad it helped!
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

ds
dspady
Posts: 104
Joined: Thu Sep 16, 2010 12:29 pm

Wed Sep 25, 2013 1:16 pm Post

This bugged me a lot too. Thanks for telling me how to correct it.
Don

ds
dspady
Posts: 104
Joined: Thu Sep 16, 2010 12:29 pm

Wed Sep 25, 2013 9:22 pm Post

This seems to have altered the Scrivenings view mode.
Used to be if I had
A
B
b1
b2
C
D
d2
and I clicked on A B and d2, that is all I would see. Now, If I click on B and d2, I get all of B, b1, b2, C D and d2. This takes away a lot of the utility of the Scrivenings mode.

Trouble is, I have reset the preferences, restarted Scrivener, and am still having the problem; i.e I can't get rid of the intervening text. Am I missing something.

Don

User avatar
AmberV
Posts: 24190
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Thu Oct 03, 2013 9:27 pm Post

I cannot reproduce this behaviour on my end. Are you sure you're using Cmd-click and not Shift-click? There shouldn't be any circumstances, no matter what your settings, where Cmd-clicking on "B" and "d2" would include not only child items of "B" but intermediate siblings as well.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

ds
dspady
Posts: 104
Joined: Thu Sep 16, 2010 12:29 pm

Fri Oct 04, 2013 12:36 pm Post

In all honesty, I am not certain. The behaviour has returned to normal now. I have used this command many times and do not think that I am mixing up Shift and CMD; however, I recently purchased a new keyboard (non-Mac, although machine is Mac) and maybe have not totally become comfortable with it.

Thanks for the response.

Don