Ragged right on compiled versions?

Ju
Just Write
Posts: 126
Joined: Tue Mar 25, 2008 1:12 pm
Location: NE Georgia, U.S.

Sat Dec 22, 2012 1:43 am Post

While formatting my novel for Kindle, I noticed that the right side is ragged right - not justified. I even noticed this when compiling for Novel format. I don't recall having to change this before in older versions of Scrivener. What's changed and how do I get justified right margins back?

Thanks!

User avatar
AmberV
Posts: 24307
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Sat Dec 22, 2012 1:47 am Post

This was changed a while back because people wanted to have control over justification. Prior to that point Scrivener just left justification empty if you used left alignment, since that is default anyway. So now you have to specifically set full justification in your formatting compile option pane.

However, we've recently learned the Amazon is cracking down on this matter, as they would like justification to remain open-ended and up to the software and reader preference (even though at this time I believe only one Kindle has an end-user toggle). So we've taken that back out for the next release (it's not in the current beta yet), and it should return to the old way of displaying however the device is set to display paragraphs. We'll just have to explain to people that this isn't something Amazon wants them to control.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Ju
Just Write
Posts: 126
Joined: Tue Mar 25, 2008 1:12 pm
Location: NE Georgia, U.S.

Sat Dec 22, 2012 1:58 am Post

So... Amazon WANTS the right edges ragged?

I guess I'm a bit confused. Sorry, Amber. It's been a long, long week.

ETA: If I want to print out a physical manuscript copy with justified margins, I'd have to change that by: clicking Compile, Formatting, and then where do I go from there?

User avatar
AmberV
Posts: 24307
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Sat Dec 22, 2012 2:15 am Post

No, if anything Amazon wants full justification. We enabled the ability to set ragged-right if the user wants it, and that is what is being removed.

In the Formatting pane, do you have the override checkbox ticked at the very top? If so, just go ahead and click the text icon in the list, and then use the mock editor to set full justification. That is where the ragged-right was coming from.

Otherwise, if you weren't overriding formatting all this time, you could turn that on and fix it here in one shot. Just be wary that if the book has a lot of special formatting in various places (like captions, block quotes and so on) you might need to just leave that alone and fix the alignment in the editor instead.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Ju
Just Write
Posts: 126
Joined: Tue Mar 25, 2008 1:12 pm
Location: NE Georgia, U.S.

Sat Dec 22, 2012 2:29 am Post

So sorry - I hate to be an idiot, but I'm not sure where this pane is...

I've tried looking under the menu bar and Format and I don't see anywhere where I can change that. I've also clicked on the Compile icon and from there, I do see Formatting under Compilation Options, and in there I see a bod for Override text and notes formatting. That's checked. Is that what you mean?

In other words, I'm really REALLY lost on where I fix this. Again, my apologies.

User avatar
AmberV
Posts: 24307
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Sat Dec 22, 2012 2:52 am Post

Image

That's where you should be. The arrow points to the justification tool in the format bar. Just click into the mock text editor below that, and then set the formatting for the text. You'll want to do that for each line in that list above it that has a checkmark in the "Text" column.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Ju
Just Write
Posts: 126
Joined: Tue Mar 25, 2008 1:12 pm
Location: NE Georgia, U.S.

Sat Dec 22, 2012 3:05 am Post

Thank you so much, Amber! Got it!