Keep Losing Paragraph Indent

User avatar
RonJeffries
Posts: 302
Joined: Sat Dec 08, 2012 6:19 pm
Platform: Mac

Sun Dec 09, 2012 11:25 pm Post

I'm using Scrivener pretty much out of the box so far. Normally, when I type text into a new document, it has a first line indent.

Some things seem to make this indent go away. I have found two. One is to enter list mode. When I exit list mode, the first line indent is gone. Another turns out to be to format a line to title or subheading or any of those. Once that is done, I can't get it to go back to indented text. I'd have expected setting it to body to do that, but it does not.

The only way I've found to get the format back is to copy the para, paste matching format into someplace that has it right, then cut it and paste it back where it belongs.

Clearly I'm missing some concept, and some way of getting the format back. Please advise me on both. Thanks!

User avatar
AmberV
Posts: 24790
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Dec 10, 2012 1:10 am Post

Yup, that's a known limitation with the way the system is set up. Basically, Scrivener uses a very simple "streamed formatting" concept, which isn't like styles in word processors that support stylesheets. It has no conception of formatting that occurred prior to the formatting you just used. What I do is set up a "Body" preset, which has my default paragraph settings. This way once I'm done with the odd formatting that changed things from default, I can easily get back to how I want thing for normal paragraphs. You can use OS X's keyboard shortcut tool to add a shortcut to the "Body" preset to make this even easier.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
RonJeffries
Posts: 302
Joined: Sat Dec 08, 2012 6:19 pm
Platform: Mac

Mon Dec 10, 2012 1:36 am Post

understood. can probably figure out how to do that. thanks!

User avatar
AmberV
Posts: 24790
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Dec 10, 2012 1:49 am Post

It is in the main System Preference. Click the Keyboard icon, and the shortcuts tab. You just have to add an application shortcut by typing in the name of the menu command. This can be used to add or change any shortcuts.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
RonJeffries
Posts: 302
Joined: Sat Dec 08, 2012 6:19 pm
Platform: Mac

Mon Dec 10, 2012 2:56 am Post

Thanks, I'll give it a go ...

Thanks again,