Scrivener really slowing down

la
larykirk
Posts: 16
Joined: Sun Jul 12, 2009 9:24 pm

Wed Mar 21, 2012 7:37 pm Post

All of sudden, Scrivener is being very slow to respond to even the most modest command, like inserting the cursor to change or add a word, and everything else.

My file is about 550mb? Is that simply too large? It has been >500mb for some time and I'm on a full speed 27" iMac with all the memory needed.

Any ideas about what's going on? It's very hard to write when it's lagging like that .....

User avatar
StaceyUK
Posts: 966
Joined: Mon Apr 13, 2009 5:00 pm
Platform: Mac, Win + iOS

Wed Mar 21, 2012 8:12 pm Post

Interesting, we've had people experiencing lag with the Windows version as well. I'm interested to see what solutions are offered and whether they could also apply in the Windows version.

One thing that springs to mind is are you using Scrivenings mode when the lag occurs?
Blessings, Stacey

System Specs

[b]Windows 10
Scrivener 1.9.7 / 2.8 /3.0.3/1.1.5 (1301)
Scapple 1.0.0.0
Windows 2.9.9.17 Beta

Hu
Hugh
Posts: 2444
Joined: Thu Mar 08, 2007 12:05 pm
Platform: Mac
Location: UK

Wed Mar 21, 2012 9:14 pm Post

Hmm, I don't have this problem with a file significantly bigger than yours and 4 GB of RAM. A factor that has been blamed in the past for slowing down earlier versions of Scrivener for the Mac is the use of external spell checkers and/or snippet inserters such as Spell Catcher, Typinator, TextExpander etc. Does that apply?

Alternatively, one step you could take that might help is to experiment with your autosave period: Scrivener > Preferences > General > Saving.
'Listen, some quiet night, when you've shirked your work that day. Do you hear
that distant, almost inaudible clicking sound? That's one of your
competitors, working away in the night in
Paris or London or Erie, PA.'

User avatar
Cosmicjive
Posts: 53
Joined: Wed Sep 22, 2010 8:14 pm
Platform: Mac + Windows
Location: Tustin, CA (USA)

Wed Mar 21, 2012 9:28 pm Post

larykirk,

Quick question: Do your documents have a lot of embedded images in them?

-Jeff

jr
jrzap
Posts: 4
Joined: Wed Jul 19, 2006 3:46 am
Platform: Mac

Mon Apr 16, 2012 1:45 am Post

I am suddenly having the same problem. My file is 650M with only one Quicktime file in it and a couple of pictures.

It starts slowing down at will! I can't replicate it. It does it on my MBAir and on a 17 inch

I thought it might Chrome because it was open or some other app with flash but after restart and without other apps open it keeps slowing down.

I type pretty fast, and Scrivener slows down so much that I have to stop and wait for the cursor.

I want to find a solution. Please help!

J

User avatar
Claudia
Posts: 164
Joined: Thu Jan 07, 2010 9:21 pm

Mon Apr 16, 2012 3:15 am Post

This is happening to me as well. It also happens to me in the short story template file... no images there, and it's a pretty small file... however, it's probably bigger than the template intends as I use to to contain several story folders... I just have duplicate folders and convert for each new story. Then I save all the drafts in subfolders. So I was wondering if the lag was due to my use of this template being too big for its design? However, I am also experiencing this in the novel template, which has only a couple of HTML pages in the research folder and otherwise is all text. There's about 50K words in the file now, but it will get to 100K. Not sure why it would lag. I haven't noticed if it's more likely to happen when the other file is open.

User avatar
Claudia
Posts: 164
Joined: Thu Jan 07, 2010 9:21 pm

Mon Apr 16, 2012 3:16 am Post

And also, no, I'm not using Scrivenings when this happens...

User avatar
KB
Site Admin
Posts: 20922
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Apr 16, 2012 9:26 am Post

Hmm, none of the projects mentioned here should cause any slowdown. Even on large projects, the only slowdown should be during project open and close, as Scrivener only opens the documents within the project as and when they are selected; it doesn't load the entire project into memory - that's the entire point of its file structure system. The only time I would say lag might be "expected" is if you were playing a QuickTime file in one split while typing in the other - that can eat up resources, but those resources should then be freed again as soon as a different file is selected in place of the media file.

I do most of my writing on a first generation 11" MacBook Air, and I have some fairly large projects I work on, with no slowdown, so this isn't anything to do with hardware, either (Scrivener was initially designed to run on an 11" iBook, so I've always been careful to ensure that it will run smoothly on lower-end systems.)

The first thing to rule out is, are you all using Scrivener 2.x? I assume so, but have to ask because Scrivener 1.x did have some occasional lag issues which were fixed in 2.x.

I'd also be grateful if anyone reporting slowdown could specify the exact OS they are on.

My first thought is that this could be down to an external program. The first thing to try, the next time this happens, is to fire up Activity Monitor (available in /Applications/Utilities), sort by the "%CPU" column, and see what is taking up the most resources. It may say Scrivener, but that could still be caused by a third-party plugin, so if that doesn't' throw up any useful results, the next thing to do is open Terminal.app (again in /Applications/Utilities), the type:

Code: Select all

top -F -R -o cpu


Then hit return.

Then type away in Scrivener with the Terminal window alongside it and see what processes are appearing at the top of the list in Terminal.

Another thing to try that is very helpful in these situation is to go to System Preferences and use "Users & Groups" to create a new user account temporarily. Log into that account and try using one of the projects that are slowing down in your main account (note that Scriv will open in trial mode on the temporary account, but don't worry about that). Is it still slow in this other user account? If not, you know for sure that something in your main user account is causing the problem.

Finally, with Scrivener closed, try the following:

1. In the Finder, open the "Go" menu. If on Lion, hold down the Option key to see the full list of items (some are hidden unless you hold down Option). Select "Library". This will open the ~/Library folder in a Finder window.

2. From the Finder window showing the contents of the ~/Library window, drill down into the Preferences folder.

3. In the ~/Library/Preferences folder, find the file entitled com.literatureandlatte.scrivener2.plist and move it to the Trash.

4. Re-launch Scrivener.

This will completely wipe the preferences - a corrupt preferences file can cause slowdown.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

jr
jrzap
Posts: 4
Joined: Wed Jul 19, 2006 3:46 am
Platform: Mac

Tue Apr 17, 2012 3:32 pm Post

Thanks Keith!

Will do! I am on a dateline of a writing projecto but Scrivener has been so amazing to me that I would anything to help you guys!

User avatar
KB
Site Admin
Posts: 20922
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Apr 17, 2012 3:48 pm Post

Thanks jrzap, much appreciated!
All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
Claudia
Posts: 164
Joined: Thu Jan 07, 2010 9:21 pm

Tue Apr 17, 2012 8:14 pm Post

Scrivener 2.2.

OS X 10.7. 3

New 11" Air

1.6GHZ i5 processor
4RAM DDR3

Whatever the larger SSD drives that was available of the 2 options, in case I wanted to bolt to Windows, which I sort of do. I don't like all this stupid holding down of keys you have to do in Mac.

Biggest draws on the Activity Monitor: TweetDeck and iTunes. They fluctuate, with TD going as high as 77. HOWEVER, this slowdown sometimes occurs when I am not hooked up to the internet and not running TD. I often work in a section of my house that has no internet signal. However, I am usually running iTunes, and I usually have external monitor, keyboard, speakers, etc, hooked up.

Hm. Now the rest of the page went away, so I guess I have to submit and try to do the rest of the homework later... Thanks though, and hope this helps for starters.

Online
User avatar
kewms
Posts: 7461
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Wed Apr 18, 2012 5:12 am Post

It wouldn't hurt to check your autosave interval. I suddenly had lag issues with version 2.0 and a new computer, when I'd never had them with the old version and the old configuration. Which didn't make any sense. But it turns out that the 2 second default save time corresponds nicely with my natural pause, so I was always catching Scrivener in mid-save. Making the interval longer fixed the problem.

Katherine
Scrivener Support Team

User avatar
Claudia
Posts: 164
Joined: Thu Jan 07, 2010 9:21 pm

Thu Apr 19, 2012 7:38 pm Post

Ok, will check. It looks like my last post on this topic didn't save, or else I posted it to the wrong thread. :0 The lag in at least one of the projects seems to be related to the typewriter bar. When that's turned on, it lags terribly. Turned off, no lag. Bummer, because I LOVE that feature. I'm using it in the regular editor, not in compose mode.

User avatar
KB
Site Admin
Posts: 20922
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Fri Apr 20, 2012 12:31 pm Post

What do you mean by the typewriter bar? Do you mean the formatting bar? Or do you mean typewriter mode?
All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
Claudia
Posts: 164
Joined: Thu Jan 07, 2010 9:21 pm

Sat Apr 21, 2012 11:00 pm Post

I mean when you click that typewriter icon and get it so that you always are typing in the middle of the screen. I suppose that's typewriter mode. But I think of it as a bar because I have the line where I'm typing set so that it's colored slightly differently than the rest of my screen.

I love this feature because it's so much nicer on my neck--now when I go back to Word and have to look at the bottom of my screen, I think what is the matter with these people.

Thanks--