Can't enlarge or shrink fonts

Le
Leisureguy
Posts: 8
Joined: Sun Feb 06, 2011 11:29 pm
Platform: Mac + Windows

Sun Feb 06, 2011 11:42 pm Post

I am running Scrivener 2.0 on OS X, and I'm a new Mac user. The font was too small for me to read comfortably, so I used Scrivener help and as soon as I typed "bigger", I got the illustration of the exact menu item, marked with a big blue arrow. Extremely slick.

Only problem: it doesn't work. Trying to make the font larger OR smaller using the command keys OR the menu item: nothing. Font stubbornly refuses to change size. And I can't read it very well at all.

Any ideas? I installed Scrivener yesterday and everything worked reasonably well.

User avatar
MimeticMouton
Posts: 8877
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sun Feb 06, 2011 11:56 pm Post

Welcome to Scrivener, the forums, and Mac! :)

You need to have text selected in order to use the command, and it will only apply to text in the editor (or QR window) or in project or document notes. If you want to change font sizes in other areas, such as the index card synopses or the binder, these are adjustable in Scrivener>Preferences.

In the Preferences you can also set the global default size for your text in new documents, so if you're regularly wanting size 18 font you could set that in Preferences:Formatting under Main Text Style. Once you've done that it will apply to new documents; to convert pre-existing ones, you can select them in the binder and choose Documents>Convert>Formatting to Default Text Style.

You also can set the editors to a higher zoom level (in the footer or View>Zoom), if you want to keep the text at a smaller size; this is set per editor, so if you work with a split or in Full Screen, you can choose different zoom levels for each. (In the general preferences you can also set the default zoom for new projects.) Given that you can easily compile a document with completely different formatting than what you use on-screen to write, however, changing the font size as above is probably what you want and will give you a crisper screen image.
Jennifer Hughes
(MM for short)

Le
Leisureguy
Posts: 8
Joined: Sun Feb 06, 2011 11:29 pm
Platform: Mac + Windows

Sun Feb 06, 2011 11:59 pm Post

Many thanks. That helps a lot. I'll give those a go.

User avatar
MimeticMouton
Posts: 8877
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Mon Feb 07, 2011 12:01 am Post

Sure thing. Let me know if you need help finding the preferences for any of the specific settings; there are a lot of options, and I didn't want to go through them all, not knowing exactly what you were after. ;)
Jennifer Hughes
(MM for short)

Le
Leisureguy
Posts: 8
Joined: Sun Feb 06, 2011 11:29 pm
Platform: Mac + Windows

Mon Feb 07, 2011 3:05 am Post

Okay, I'm fine with fonts now. I've been exploring more. My God! this is a great program! Wow! I've adjusted and tinkered and everything is terrific now.

Learning Mac and Scrivener at the same time is a little overwhelming, but fortunately I'm learning Spanish (just started a beginning course---but español solamente in class after the first day. So, relatively speaking, Mac and Scrivener are easy---at least people were trying to make those two make sense. But, in a way, it's much the same thing: try everything, remember what you can, and in time it becomes easier until it's obvious.

Anyway, I'm impressed. And thanks for the rapid response help.

BTW, I'm using Dropbox to work on my book at my MacBook and at my Win 7 desktop---not simultaneously, of course---and, in fact, very carefully NOT. But that's working quite well.

User avatar
KB
Site Admin
Posts: 20775
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Feb 07, 2011 9:53 am Post

Glad you got it sorted - thanks MM for helping, as always.

Many thanks for the kind words - glad you're liking Scrivener so far. And blimey, learning the Mac, Scrivener and Spanish at the same time - ambitious! Good luck!

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

ji
jimocarroll
Posts: 3
Joined: Wed Sep 22, 2010 8:12 pm

Sat Feb 12, 2011 8:16 pm Post

I would like to change things so that, by default, text in the main editor pane is 16 point. Yeah, I know...

But I'm 64 years old and using a 13 inch Macbook.

Selecting all the text and either changing the font size spinner or hitting the "bigger" icon works swell for the editor pane I'm in, but I'd like to make the change "sticky."

Any advice?

User avatar
MimeticMouton
Posts: 8877
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sat Feb 12, 2011 8:58 pm Post

In Scrivener>Preferences:Formatting, you can set the main text style to whatever size you want. This will affect its appearance in both split editors and full screen. It will only affect newly created documents, but you can select in the Binder all the existing ones you want to change and then choose Documents>Convert>Formatting to Default Text Style.

That will set the default for all projects; you can override it for individual projects by selecting the checkbox in Project>Text Preferences... and setting the text style there. Same thing, it will affect new documents and you'll need to use the Convert Formatting tool to change old ones.

If you just want to change the default zoom level for the Editor and Quick Reference windows in new projects, and not the actual font size, you can set the default in Scrivener>Preferences:Editor. It will affect both splits, but any changes you make once you're in the project (using the zoom selection in the footer or via View>Zoom) will stick, so until you change it again that editor window will always use that zoom level. (For which reason, changing this default preference won't affect your current Editor zoom levels in an existing project, although it will affect QR windows.)

Zoom is also available in Full Screen--hover your cursor at the bottom of the window and a menu will pop up, with text scaling on the left. You can also hover your mouse at the top and use the regular View>Zoom menu or the keyboard shortcuts (Shift-Cmd->/<). You can set the default zoom for new projects in Scrivener>Preferences:Full Screen.
Jennifer Hughes
(MM for short)

Le
Leisureguy
Posts: 8
Joined: Sun Feb 06, 2011 11:29 pm
Platform: Mac + Windows

Sun Feb 13, 2011 12:50 am Post

Cool. Many thanks.