MMD & 6x9 novel customizations

ja
janra
Posts: 471
Joined: Sun Jun 18, 2006 12:06 am
Platform: Mac
Location: Vancouver, BC

Sat Jan 06, 2007 4:08 am Post

One annoying thing I noticed about the MMD -> LaTeX export was that scene break indicators had to be put in manually; the scene separator option in the export dialogue only applies to RTF export.

When using sffms.xslt you can export scene titles and MMD assumes that titles one level below a chapter is a scene break, and puts the centred #. This is very cool, but the same technique doesn't work with the memoir-based xslt files, specifically the 6x9book.xslt (also memoir, memoir2sided, and so on).

I customized a copy of 6x9book.xslt and called it 6x9novel.xslt.

The customizations I made are all things that differ between fiction and non-fiction:

* removed the table of contents (left the command there but commented out so you can easily get it back)
* removed the index, glossary, bibliography - basically all the backmatter
* added the same behaviour as the sffms scene break marker
* added an MMD meta option so you can set what the scene break marker is

To use it, download 6x9novel.xslt from the link above and put it where MMD can find it (in the Multimarkdown/XSLT folder). Use it just like the 6x9book (which I'm assuming you know how to do), except for the following:

In your MMD settings, choose the 6x9novel as the xslt file.

Create a new MMD metadata item called 'Scenebreak', with a value of whatever you want displayed between scenes. I put a #. Whatever you put in here will be centered on a line by itself. Don't put LaTeX commands in here; the backslashes are escaped and they don't work.

When exporting, choose to export the titles of your scene files; this is how MMD knows where to put the scene breaks.

If you want an epigraph, make sure to put the text of the epigraph in the text portion of your chapter container as a blockquote, and not at the top of your first scene! This is because you want to see:

<chapter title>
<epigraph>
<hidden scene start>
<scene text>

instead of:

<chapter title>
<hidden scene start>
<scene text that starts with a blockquote>

The epigraph has to come before the title of the scene (which is hidden in the final output) for it to work.