Blank Frame or Crash on Startup

User avatar
Lord Lightning
Posts: 652
Joined: Fri Jun 23, 2006 4:58 am
Location: Somewhere else!

Thu Sep 21, 2006 1:56 am Post

If you get EITHER a crash on startup for a Project (New or Previous) or you see an empty box frame and no content with resize dots embedded in the frame lines, try this.

Scrivener’s fonts are set to Optima 12 for notes and Chalkboard 12 for polaroids titles by default. You may not have these in your fonts file so Scrivener may not be able to see them and therefore can’t call them.

For example, in its ~ (User) Library > Preferences file (com.literatureand latte.scivener.p.list), Scrivener needs to load SCRNotesFontName to see Notes and SCRPolaroidsTitleFontName to see Photograph titles, etc.

Two Choices:
Either

Choice A:
1. First close Scrivener.
2. Trash the Scrivener .plist file. It is called com.literatureandlatte.scrivener.plist. It is in your home Library 'PREFERENCES' folder - the one with the tilde (~)
3. Boot Scrivener
4. Go into Scrivener's Menu Bar:
Scrivener > Preferences > Fonts & Colours, and then make sure every one of the items in the list has a value: Font name and size.

Default notes font:
Index cards title font:
Photographs title font:
Index cards text font:
Status stamp font:

If you don’t have Optima 12 or Chalkboard 12 use other fonts.

Courier and Helvetica (or whatever you like) and sizes around 12-14 seem to look quite good.

Click the button on the bottom of the panel named APPLY then OK

Choice B:
Start at number 4 without trashing the .plist file and rebooting Scrivener.

If Choice B does not work first up then you will have to start at 1 and trash the preference file.
Lord Lightning

I'm a writer. I create worlds!
When I make a declarative statement it applies to ME. Not to everyone.