Removing style does not 100% revert text

User avatar
devinganger
Posts: 1996
Joined: Sat Nov 06, 2010 1:55 pm
Platform: Mac, Win + iOS
Location: Monroe, WA 98272 (CN97au)
Contact:

Tue Oct 30, 2018 1:15 am Post

In the attached test project with a single document and a single line of text:

1) Highlight the text, which is in the "default text format" for my computer (there is no project-specific default format defined).

2) Use right-click, Format menu, or Style panel, apply a style such as Block Quote.

3) Remove the style just applied/revert back to No Style.

4) Note that the indenting is not the same as it was when it started.

5) Hit Undo twice and see the original indent.
Attachments
NoStyleChangesIndent-bak-2018-10-29T18-07.zip
(83.56 KiB) Downloaded 176 times
--
Devin L. Ganger, WA7DLG
Not a L&L employee; opinions are those of my cat
Winner "Best in Class", 2018 My First Supervillain Photo Shoot

User avatar
auxbuss
Posts: 314
Joined: Mon Nov 30, 2015 9:50 pm
Platform: Mac
Contact:

Tue Oct 30, 2018 11:56 am Post

(This wasn't as helpful as I thought it might be, so I removed it. )
Last edited by auxbuss on Wed Oct 31, 2018 9:22 am, edited 1 time in total.
ImageImage

User avatar
AmberV
Posts: 24211
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Tue Oct 30, 2018 6:47 pm Post

Okay, the first thing I did was select the sample text in your document and set my default formatting to that. I then went through the checklist, but I got the same result that I started with, regarding indent settings. I tried Block Quote initially, but found your first-line indent is nearly identical to its block left indent, so I used Heading 1 as well, which has no indent.

The only difference should be the font, in our tests, as I don’t have the one you use by default and ended up with Helvetica.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
devinganger
Posts: 1996
Joined: Sat Nov 06, 2010 1:55 pm
Platform: Mac, Win + iOS
Location: Monroe, WA 98272 (CN97au)
Contact:

Wed Oct 31, 2018 4:07 am Post

AmberV wrote:Okay, the first thing I did was select the sample text in your document and set my default formatting to that. I then went through the checklist, but I got the same result that I started with, regarding indent settings. I tried Block Quote initially, but found your first-line indent is nearly identical to its block left indent, so I used Heading 1 as well, which has no indent.

The only difference should be the font, in our tests, as I don’t have the one you use by default and ended up with Helvetica.


I started this with an old v2 project (that had been converted to v3 a while ago).
I then made the following changes:
1) stripped out all other documents
2) changed the account-wide default format to the font in the test document
3) applied the default format to all text
4) used Save As to save the file to a new name

I then applied the styles.

I would have thought that applying the default format, since it didn't have any special indents or anything defined, would have overridden any tabs or indents defined in the text, so reverting back to No Style should have worked the same as you saw. Is that not the case?
--
Devin L. Ganger, WA7DLG
Not a L&L employee; opinions are those of my cat
Winner "Best in Class", 2018 My First Supervillain Photo Shoot

User avatar
AmberV
Posts: 24211
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Wed Oct 31, 2018 1:00 pm Post

The “No Style” setting will set text to the application or project default formatting, and as well, strip the style assignment from the cursor context. It’s a bit like the bulk document conversion tool with the option set to remove styles—the formatting result should be identical. Thus, if the basic order of things are:

  1. Apply default formatting to document with default settings.
  2. Change formatting of text in document (in any way).
  3. Apply “No Style” to text.

Then the result should be the text looking identical after the first and third steps.

I would have thought that applying the default format, since it didn’t have any special indents or anything defined, would have overridden any tabs or indents defined in the text, so reverting back to No Style should have worked the same as you saw. Is that not the case?


The only discrepancy I can see in there is that the sample project has an indent applied to the text, which I presume is the intended default formatting—so I don’t follow what you mean when you say the default format does not have any indents.

Image
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles