Scrivener 1.1 (1.055b) Public Beta - new and updated (AGAIN)

User avatar
juh
Posts: 156
Joined: Fri Dec 01, 2006 11:43 am
Location: Germany
Contact:

Sun May 20, 2007 8:37 am Post

Hi Keith,

thanks for this update, amazing!

KB wrote:- Hopefully fixed an ongoing bug that has caused the scaling of PDF files and web files to be insanely large on occasion on certain systems, unless the scale was set explicitly. (This error was caused by Scrivener trying to read a scale setting that did not exist; for most things, if something does not exist, it will return 0, which would have been safe; in this instance, the value returned was undefined, which meant the scale number could be randomly large).


With new projects import of web files now work, but in an old project, where I had huge scaled views it still does not work. Newly imported web pages are still huge scaled. Are there any preferences set in the files itself?

I speak of the project I sent you some days ago.

User avatar
KB
Site Admin
Posts: 20922
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Sun May 20, 2007 8:37 am Post

But first another thing. When creating a new project in 1.05b, I always get the message: "The project you are trying to load uses an older format … Would you loike to update it? A copy of the old project … etc." Is this expected behaviour?


Er, yes, if it is a pre-1.04 project. Did you not use the 1.04 betas? I thought you did. If you did and you have already updated your projects, ensure that you are definitely opening them with 1.05 and not a pre-1.039 version.

Best,
Keith

Ti
Timotheus
Posts: 442
Joined: Tue Jul 04, 2006 12:35 pm
Platform: Mac

Sun May 20, 2007 9:33 am Post

No, I'm talking about a completely new project (Shift-Command-N), and I'm definitely working with 1.05b. But I must add that I get this message only when selecting in "New Project Binder" some preexisting, rather old template. When I select an empty project, instead, everything is fine. Could this have anything to do with it?
Scrivener – Nisus – Bookends – Devonthink – Lightroom ••• MacMini 2018 / MacBook Pro 2014 (10.14.6) – iPhone 7

I went there and came back / It was nothing special / The river at high tide / The mountain veiled by misty rain

User avatar
KB
Site Admin
Posts: 20922
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Sun May 20, 2007 9:41 am Post

Ah, yes, right, that explains it. Yes, you will get that message because those templates were created from the old project format. The templates that come with Scrivener will be updated for the release version; the templates that you have created yourself you will need to update yourself. Just open it and re-save as Template.

Best,
Keith

User avatar
Siren
Posts: 759
Joined: Mon Mar 12, 2007 11:29 am
Platform: Mac + iOS
Location: U.K.

Sun May 20, 2007 11:09 am Post

KB wrote:Do you realise how much code and effort that would take just to get annotations out?

I was just hoping you had some handy reusable document-selection code lying around! :-) Don't worry - I can work round this by including place-marker annotations to show what's what and then just delete the bits I don't want in a particular export. Not a problem.
KB wrote:The Export Annotations feature is just intended as a rough and ready way of getting all annotations out of a project, to help whoever it was that was having this problem recently (you?).

Me, yes - and rest assured that I am delighted that you put something in to address the problem! I was thrilled to pieces when I saw it in the release notes - and even more thrilled when I tried it and found that it actually worked! :-) Thank you.

User avatar
KB
Site Admin
Posts: 20922
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Sun May 20, 2007 11:19 am Post

juh wrote:With new projects import of web files now work, but in an old project, where I had huge scaled views it still does not work. Newly imported web pages are still huge scaled. Are there any preferences set in the files itself?


What has happened is that the insanely large scale factor caused by the original bug has now been saved into your project, so although the bug is now gone, it has been saved into those old projects of yours. You have two options: 1) Just hit Zoom Out over and over again. At first, it will seem to do nothing because of how far the zoom in is, but eventually it will work. 2) This method is quicker but involves getting your hands dirty: ctrl-click on the project in the Finder and select "Show Package Contents". Then look for ui.xml and open it (it should open in a plain text editor or in Property List Editor; either is fine). Now just search for "mainDocumentEditor.webScale" and "supportingDocumentEditor.webScale" and set their associated value (one of them should be a ridiculously large number) to 1. (Don't worry if both can't be found - you will certainly find one of them, and that will be your culprit.)

Siren - just a thought, actually: rather than having a check list, I could add a checkbox to the Save As sheet saying something like "Selected documents only", and then only export annotations from documents that are selected in the binder. That is easier and makes more sense.

User avatar
Siren
Posts: 759
Joined: Mon Mar 12, 2007 11:29 am
Platform: Mac + iOS
Location: U.K.

Sun May 20, 2007 11:47 am Post

KB wrote:Siren - just a thought, actually: rather than having a check list, I could add a checkbox to the Save As sheet saying something like "Selected documents only", and then only export annotations from documents that are selected in the binder. That is easier and makes more sense.

That would be perfect in every way -- you're a star! Thank you :-)

Ga
Gaijin de Moscu
Posts: 95
Joined: Wed Jul 12, 2006 7:53 pm

Sun May 20, 2007 12:12 pm Post

Great stuff! 8)

Only one thing: when I begin typing, my cursor stays in the same spot, and the text goes to the left and disappears under the left frame. Maybe it's a matter of setting the correct preference?

I'm in a standard book mode, no screenplay or anything fancy.

User avatar
KB
Site Admin
Posts: 20922
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Sun May 20, 2007 12:15 pm Post

Gaijin - sounds like you have set the "Default Editor Width" preference to something massive, which is recommended in preferences if you want the window to fill the screen. However, in the new beta, "Fixed Width" is switched on by default, meaning your text view could be massive. This would cause the effect you describe. Try going to Preferences and turning off "Fixed width". I need to address this update clash for the release version, as it's bitten a few users.
Best,
Keith

Ga
Gaijin de Moscu
Posts: 95
Joined: Wed Jul 12, 2006 7:53 pm

Sun May 20, 2007 12:18 pm Post

KB wrote:Gaijin - sounds like you have set the "Default Editor Width" preference to something massive, which is recommended in preferences if you want the window to fill the screen. However, in the new beta, "Fixed Width" is switched on by default, meaning your text view could be massive. This would cause the effect you describe. Try going to Preferences and turning off "Fixed width". I need to address this update clash for the release version, as it's bitten a few users.
Best,
Keith


Indeed -- that's what it was. I changed to "use current" and it works perfectly now. Thanks much!

User avatar
juh
Posts: 156
Joined: Fri Dec 01, 2006 11:43 am
Location: Germany
Contact:

Sun May 20, 2007 12:36 pm Post

KB wrote:
juh wrote:With new projects import of web files now work, but in an old project, where I had huge scaled views it still does not work. Newly imported web pages are still huge scaled. Are there any preferences set in the files itself?


2) This method is quicker but involves getting your hands dirty: ctrl-click on the project in the Finder and select "Show Package Contents". Then look for ui.xml and open it (it should open in a plain text editor or in Property List Editor; either is fine). Now just search for "mainDocumentEditor.webScale" and "supportingDocumentEditor.webScale" and set their associated value (one of them should be a ridiculously large number) to 1. (Don't worry if both can't be found - you will certainly find one of them, and that will be your culprit.)


Wonderful. That worked. Thanks!

Ti
Timotheus
Posts: 442
Joined: Tue Jul 04, 2006 12:35 pm
Platform: Mac

Sun May 20, 2007 12:41 pm Post

See hereunder the results of some testing, regarding especially the brandnew footnotes importing feature.

1. Word.doc document, 4482 words, including 24 often rather long footnotes. Many italics. Converted into a Word.rtf document and then imported into Scrivener.
Result looks fine. Italics are reproduced flawlessly. Some minor things:
a. in the Word.doc version and in the Word.rtf version the spacing between the lines of the footnotes was somewhat smaller than the spacing between the lines of the main text. In Scrivener.rtf, the spacing is identical.
b. signs in small superscript (e.g. a small "2" after a publication year in a bibliographical reference, indicating the second edition of the book) are reproduced in superscript in normal size, which enlarges the spacing between the line containing the 2 in superscript and the preceding line.
c. In one note consisting of two paragraphs, the first paragraph has the same spacing between lines which all other notes have. The second paragraph, however, has a somewhat smaller spacing, and this smaller spacing is maintained in the rest of the paragraph of the main text, which follows after the note.
d. The Word.doc version contained one table consisting of one row divided into two colums: in the left column, the text was in regular face, in the right column, in italics. All this remains identical in the Word.rtf version. But in the Scrivener.rtf version the two columns are reduced to one, and the text in italics in the right column is placed under the text of the left column. The italics are preserved.

2. Word.doc, 44.187 words, including 250 (brief) footnotes. Converted into Word.rtf and then imported into Scrivener.
Result looks fine. The notes, which in the original document were in a smaller size than the main text, are reproduced in a smaller size. But the spacing between the lines of the notes, which in the original document was smaller too, remains rather large. Moreover, the spacing between the various lines of one and the same footnote doesn't always seem perfectly identical.

3. Monstrous Mellel document, 867.806 words, without footnotes. Converted into .rtf and then imported into Scrivener. Opens within a few seconds (impressive!). Result (italics etc.) looks good.

4. Very big Mellel document, 149.541 words, excluding many hundreds of footnotes, which in Mellel are divided into sections (in every new chapter, the couting starts anew). Converted into .rtf and then imported into Scrivener. The opening of the document takes some time, but the result looks rather good.
The notes, which were in smaller size in the original document, in Scrivener are in smaller size too.
The size between lines in the main text, however, is not always identical in the various parts of this very long document, nor is the length of the lines (in the original document, both are always constant).
The highlighting in the Mellel document gets lost in Scrivener, as could be expected.

As said hereabove, the notes which were in smaller size in the original document, in Scrivener appear in smaller size too. But new notes which will be added in Scrivener won't have this smaller size. Some new notes added to the second document mentioned hereabove appeared in a font size which was not just larger than the size of the other notes, but even larger than the font size of the main text. Here some fine tuning might be desirable.
Last edited by Timotheus on Sun May 20, 2007 6:27 pm, edited 1 time in total.
Scrivener – Nisus – Bookends – Devonthink – Lightroom ••• MacMini 2018 / MacBook Pro 2014 (10.14.6) – iPhone 7

I went there and came back / It was nothing special / The river at high tide / The mountain veiled by misty rain

User avatar
KB
Site Admin
Posts: 20922
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Sun May 20, 2007 12:53 pm Post

Thanks for testing, Timotheus. The results you report are highly encouraging. I certainly would not expect the import to be perfect - the differences in line spacing and the occasional font size change are absolutely normal and to be expected, I'm afraid. Scrivener has to grab the RTF tags and do its best to convert them mid-stream, while the Apple RTF code does the rest, so there will be font and spacing glitches. The fact that the footnotes and everything else are getting imported at all fills me with absolute joy. :)
Thanks!
Keith

User avatar
Lord Lightning
Posts: 652
Joined: Fri Jun 23, 2006 4:58 am
Location: Somewhere else!

Sun May 20, 2007 3:23 pm Post

Hi Keith

(1.1 (1.05b) is pure magic)

This is a query regarding importing a Final Draft Script into Scrivener via Final Draft Save As rtf.

As I read it the process is as follows (please check my assumptions on these steps).

While Text Only with Layout as a SAVE AS (export) preference in Final Draft gives a flawlessly formatted script when it is imported into Scrivener, it seems that RTF is the recommended way of importing. However, you need to set up the script format to read this.

For instance, the re-capitalise feature will only work if you are in script mode and if the script mode you are in recognises the formatting of the text so that it knows which elements to capitalise.

If you use the standard screenplay format in Scrivener, for instance, it won't recognise the elements of a script imported from Final Draft. The formatting needs to be identical.

At the moment, you can import successfully like this:

A. In Final Draft
1. Use Screenplay.fdt format in FD for New Document choice.

2. Then export (Save As) your Final Draft Script as Rich Text Format -RTF.

B. In Scrivener: Existing or new project.
3. Set the Scrivener document up as the Screenplay (Final Draft) script format (not the standard Screenplay script format). [Text > Scriptwriting > Screenplay (Final draft)

4. import your saved Final Draft rtf file into Scrivener. [Import > Files > Your saved Final Draft rtf script.
(There is a Scripts folder in the download and the readme explains how to install it. You must place the Scripts folder inside ~/Library/Application Support/Scrivener/Templates)

5. With this mode selected, use the re-capitalise function. [Text > Convert > Re-capitalize Script]

The only element that will not be recognised is Shot, which will be mistaken for Scene Heading.

If you used a different .fdt template, it won't be recognised by Scrivener by default - you will have to create your own Scrivener template (via Text > Scriptwriting > Script Settings...) that matches the FD template. This involves lots of playing with the ruler to get the FD RTF specs, and you will address it in the Help file.

And if you did use the screenplay.fdt file but didn't use Screenplay (Final Draft) in Scrivener, then again, it won't be recognised.

Is it necessary to use Tagger to do the export of the Final Draft rtf file or is Save As adequate?
Last edited by Lord Lightning on Mon May 21, 2007 5:11 am, edited 1 time in total.
Lord Lightning

I'm a writer. I create worlds!
When I make a declarative statement it applies to ME. Not to everyone.

St
Studio717
Posts: 376
Joined: Fri Aug 25, 2006 6:27 pm
Location: California

Sun May 20, 2007 4:51 pm Post

Siren wrote:
KB wrote:Siren - just a thought, actually: rather than having a check list, I could add a checkbox to the Save As sheet saying something like "Selected documents only", and then only export annotations from documents that are selected in the binder. That is easier and makes more sense.

That would be perfect in every way -- you're a star! Thank you :-)


What Siren said! :D

As I said earlier, though, it's wonderful just to be able to export them at all. Very very useful.

Thanks again for your amazing work.