Page 11 of 11

Posted: Wed May 16, 2007 11:45 pm
by bobembry
Keith

KB wrote:
Selecting some text and clicking the Copy Style icon on the toolbar and then selecting some other text with a different style and clicking Paste Style icon does nothing.

I think its the Paste Style icon that's not working right because using the keyboard shortcut for Paste Style changes the text.


Hi Bob,

Actually, "Copy Style" and "Paste Style" is a weird one. What it actually does is paste the ruler style (Text > Ruler > Copy Ruler & Paste Ruler), not the text attributes (font etc). This is based on the way this works in Pages, if I recall correctly, and other such apps. Not to be confused with "Paste and Match Style".

Best,
Keith


Opps, I was thinking it would Text > Font > Copy & Paste Style.

Thanks for your reply

Seems moving multiple documents bug is still with me

Posted: Wed May 16, 2007 11:57 pm
by bobembry
Hi Keith,

I'm back:

KB wrote: Fixed bug whereby moving multiple documents left, right, up or down in the binder could cause a crash or at the very least, strange behaviour, with an exception written to the console about a problem with the undo stack. (This was caused by the corkboard showing arbitrary items and resetting the undo stack when it shouldn’t.) Moving documents should work fine again now.


Sorry to keep pestering you, but I've had two sequential crashes by selected a group of documents and typing control command right arrow.

Want crash logs?

Thanks

Bob

Re: Seems moving multiple documents bug is still with me

Posted: Thu May 17, 2007 3:12 am
by bluloo
bobembry wrote:Hi Keith,

I'm back:

KB wrote: Fixed bug whereby moving multiple documents left, right, up or down in the binder could cause a crash or at the very least, strange behaviour, with an exception written to the console about a problem with the undo stack. (This was caused by the corkboard showing arbitrary items and resetting the undo stack when it shouldn’t.) Moving documents should work fine again now.


Sorry to keep pestering you, but I've had two sequential crashes by selected a group of documents and typing control command right arrow.

Want crash logs?

Thanks

Bob


Just an FYI. I've tried to produce this crash on my MacPro and cannot do so.

Are the documents in the same folder or in separate folders?

Was it a new project or an updated project from a previous version?

Re: Seems moving multiple documents bug is still with me

Posted: Thu May 17, 2007 3:51 am
by bobembry
bluloo wrote:
bobembry wrote:Hi Keith,

I'm back:

KB wrote: Fixed bug whereby moving multiple documents left, right, up or down in the binder could cause a crash or at the very least, strange behaviour, with an exception written to the console about a problem with the undo stack. (This was caused by the corkboard showing arbitrary items and resetting the undo stack when it shouldn’t.) Moving documents should work fine again now.


Sorry to keep pestering you, but I've had two sequential crashes by selected a group of documents and typing control command right arrow.

Want crash logs?

Thanks

Bob


Just an FYI. I've tried to produce this crash on my MacPro and cannot do so.

Are the documents in the same folder or in separate folders?

Was it a new project or an updated project from a previous version?


I started with a new project and imported the DragThing Quick Start document and then pasted the FAQ document into a new document and spilt it up by question. I converted the new document into Folder. The first split produced a new folder that I converted into a document. When I finished splitting up the FAQs I selected them and pressed the move key ... crash. If I select these child documents try to promote them ... crash

Posted: Thu May 17, 2007 8:28 pm
by KB
Yes, please post crash logs. Always post crash logs (along with what happened.) Are you sure this isn't happening in a lingering earlier version of Scrivener? This really should be fixed in 1.04.
Thanks,
Keith

Posted: Fri May 18, 2007 12:36 am
by bobembry
KB wrote:Yes, please post crash logs. Always post crash logs (along with what happened.) Are you sure this isn't happening in a lingering earlier version of Scrivener? This really should be fixed in 1.04.
Thanks,
Keith


I've restarted, I've downloaded a fresh copy (1.041b modified 5/12/07).

In the problematic project I selected the parent folder followed by Documents > Ungroup. All went well.

Selected the just promoted documents followed by Documents > Move > Move Right. No crash.

Repeated the Ungroup.

Repeated the document selection followed by Control Command Right Arrow. There is a brief pause. Crashed

I'm attaching an archive that contains the project and a text document with console entries and crash reports.

Thanks
Bob

Posted: Fri May 18, 2007 1:58 pm
by KB
Okay - thanks, Bob. Caught it and fixed it for the next release.
Thanks again,
Keith

Pop-up menu in outliner (minor)

Posted: Sat May 19, 2007 4:52 pm
by Simon
Keith,
This probably isn't 1.041-specific. When I have a full "Synopsis" in the outliner, the "Label" and "Status" popup menus are vertically centered to the whole item, rather than being positionned right below the mouse cursor. This is fine for single line items, but not so much otherwise... To reproduce this, enter a long-ish paragraph in the synopsis, switch to the outliner view, narrow its "Synopsis" column, and click on the "Label" item.
All the best,
Simon

Posted: Sat May 19, 2007 5:07 pm
by KB
You're right, Simon, this isn't 1.041 specific. Unfortunately, there isn't much I can do about it. By default, pop-up buttons in an outline view in Cocoa appear in the centre vertically. I can hack into it so that it appears at the top, but not so that the pop-up menu appears at the top.
Best,
Keith