Search found 100 matches

Advanced Search
by edf
Fri Aug 30, 2013 7:51 am
Forum: Scrivener on Linux (Unofficial)
Topic: Spell Check
Replies: 56
Views: 15449

Re: Spell Check

Hmm. When I had the choice of dictionaries in scrivener, and there was no actual spell-checking, it was because the 64-bit dictionaries were being used (instead of the 32-bit ones). Take a look at /usr/share/scrivener/lib/aspell, and make sure the .rws files are not symlinks to /var/lib/aspell. Idea...
by edf
Fri Aug 30, 2013 7:12 am
Forum: Scrivener on Linux (Unofficial)
Topic: Spell Check
Replies: 56
Views: 15449

Re: Spell Check

Ever have been ;) Make sure, when you start scrivener, that it is using the 32-bit libraries and support files (especially the dictionaries). This requires that the ASPELL_CONF environment variable be set to /usr/share/scrivener . I put the modifications to /usr/share/scrivener/bin/scrivener.sh in t...
by edf
Thu Aug 29, 2013 11:00 pm
Forum: Scrivener on Linux (Unofficial)
Topic: Spell Check
Replies: 56
Views: 15449

Re: Spell Check

This error indicates that you are running the 32-bit version of the aspell utility, but it is trying to load or link to the 64-bit libraries. In order to run the 32-bit executables (to generate 32-bit dictionaries), you have to set the environment variables AC_CONF, LD_LIBRARY_PATH, and PATH. Exampl...
by edf
Sun Aug 25, 2013 9:33 pm
Forum: Scrivener on Linux (Unofficial)
Topic: Spell Check
Replies: 56
Views: 15449

Re: Spell Check

After getting the 32-bit code working at the expense of interfering with system files (see http://www.literatureandlatte.com/forum/viewtopic.php?f=33&t=20489&#p159217 ), I began to wonder why aspell doesn't allow this sort of thing to be handled via an environment variable. It turns out, how...
by edf
Sun Aug 25, 2013 1:08 am
Forum: Scrivener on Linux (Unofficial)
Topic: Spell Check
Replies: 56
Views: 15449

Re: Spell Check

The libaspell-dev package just creates a symink from /usr/lib/libaspell.so to /usr/lib/libaspell.so.15.2.0 . I tried this and had no luck (64-bit Ubuntu 12.04 LTS). I downloaded the 32-bit .deb file for libaspell15, extracted it, and copied contents of usr/lib in the package to /usr/lib/i386-linux-g...
by edf
Sat Aug 24, 2013 9:46 pm
Forum: Scrivener on Linux (Unofficial)
Topic: A Mostly Complete Guide to Installing Scrivener on Linux
Replies: 40
Views: 100830

Re: A Mostly Complete Guide to Installing Scrivener on Linux

I'd like to add my notes for getting a complete (for my purposes) install of Scrivener on 64-bit Linux. bash$ lsb_release -d Description: Ubuntu 12.04.2 LTS bash$ uname -r -m 3.5.0-18-generic x86_64 A. Kindlegen Download the utility from http://www.amazon.com/gp/feature.html?docId=1000765211 (the 32...
by edf
Sat Apr 21, 2012 6:15 pm
Forum: Scrivener on Linux (Unofficial)
Topic: BETA 1.1.0 RELEASED
Replies: 69
Views: 17006

Re: BETA 1.1.0 RELEASED

Er, did the 64-bit versions ever get released? I couldn't find a link in this thread.

Been doing my writing in vi for two months now -- there really needs to be a Linux version that doesn't expire.
by edf
Thu Feb 16, 2012 7:21 pm
Forum: Scrivener on Linux (Unofficial)
Topic: .deb package stuff
Replies: 13
Views: 2153

Re: .deb package stuff

Slackware is still around? Haven't used that since the mid-90s :)
by edf
Tue Feb 14, 2012 8:52 pm
Forum: Scrivener on Linux (Unofficial)
Topic: Running Scrivener on Linux
Replies: 39
Views: 18695

Re: Running Scrivener on Linux

Again, I'd be willing to pay for what we already have... Ditto. If the Lit&&Lat guys feel bad about it charging for beta software, then make it a token amount (ten bucks?) to get a non-expiring beta. With the post-holiday work blitz now dying off, I'm starting to do more writing, and would ...
by edf
Tue Nov 08, 2011 9:16 pm
Forum: Scrivener on Linux (Unofficial)
Topic: ...Trial? Help, please.
Replies: 13
Views: 1598

Re: ...Trial? Help, please.

What's the point in limiting use of the beta when there there isn't a version to buy it yet I tend to agree with this. Obviously, the beta has to have *some* time limit so that people are encouraged to buy the finished version. Scrivener has been using beta expiration dates that are far too aggress...
by edf
Wed Oct 26, 2011 8:54 pm
Forum: Scrivener on Linux (Unofficial)
Topic: Regretting installing Ubuntu 11.10
Replies: 44
Views: 5169

Re: Regretting installing Ubuntu 11.10

This is a pretty tough conflict to resolve; tried a couple of workarounds, and nothing helped. 1. Killed off X (sudo /etc/init.d/kdm stop), logged in to a virtual console, and started X with Scrivenever as its only client (xinit /usr/local/LiteratureAndLatte/bin/Scrivener) -- no luck, same "inc...
by edf
Tue Oct 25, 2011 8:10 pm
Forum: Scrivener on Linux (Unofficial)
Topic: Regretting installing Ubuntu 11.10
Replies: 44
Views: 5169

Re: Regretting installing Ubuntu 11.10

I installed Kubuntu 11.10 32-bit in a VirtualBox instance and can reproduce this problem. The same error occurs when starting Scrivener from the launcher or from the command-line, with or without the LD_LIBRARY_PATH override. The problem occurs in both KDE and fluxbox, so it is not caused by a KDE b...
by edf
Sat Oct 22, 2011 8:48 pm
Forum: Scrivener on Linux (Unofficial)
Topic: Regretting installing Ubuntu 11.10
Replies: 44
Views: 5169

Re: Regretting installing Ubuntu 11.10

Running Scrivener on 11.10-64 is not going to reproduce the error; it would have to be 11.10-32. Scrivener is using 32-bit Qt libraries, which will not conflict with system Qt libraries on a 64-bit system (unless KDE is compiled as 32-but, which is extremely unlikely). It is only when there are 32-b...
by edf
Thu Oct 20, 2011 8:14 pm
Forum: Scrivener on Linux (Unofficial)
Topic: Regretting installing Ubuntu 11.10
Replies: 44
Views: 5169

Re: Regretting installing Ubuntu 11.10

That error could mean one of two things: * not all of the Qt libraries are installed * Scrivener cannot use the system Qt 4.7 libraries Try installing webkit (sudo apt-get install libqtwebkit4 libqt4-webkit) and see if that helps. Note: On my own (11.04 x86-64 Kubuntu) system, I have the same versio...
by edf
Tue Oct 18, 2011 4:53 pm
Forum: Scrivener on Linux (Unofficial)
Topic: Regretting installing Ubuntu 11.10
Replies: 44
Views: 5169

Re: Regretting installing Ubuntu 11.10

The LD_LIBRARY_PATH trick is to run Scrivener from the command line, using the LD_LIBRARY_PATH environment variable to override the system library settings: LD_LIBRARY_PATH=/usr/local/LiteratureAndLatte/lib /usr/local/LiteratureAndLatte/bin/Scrivener It sounds like this isn't going to help, I would ...