Search found 75 matches

by adrm
Tue Oct 22, 2019 12:09 pm
Forum: Beta Testing (Windows)
Topic: [LH4088] <b26> More issues with RegEx
Replies: 6
Views: 232

Re: [TD] <b26> More issues with RegEx

I suspect my problems stem from the current document search and the global project search differences as you suggest. Nonetheless, this is a major problem for someone like me, as non-breaking spaces, spaces in front of paragraphs, and soft line breaks crop up in my documents and need to be weeded ou...
by adrm
Mon Oct 21, 2019 2:14 pm
Forum: Beta Testing (Windows)
Topic: [LH4088] <b26> More issues with RegEx
Replies: 6
Views: 232

Re: <b26> More issues with RegEx

Testing your RegExp seem to work and return proper results. The only problem I can think of is that your documents are not within the current filter settings. Play with the "Search Included/Excluded Documents" Options in Binder search. If nothing helps, feel free to upload a small demo pr...
by adrm
Mon Oct 21, 2019 12:26 pm
Forum: Beta Testing (Windows)
Topic: [LH4088] <b26> More issues with RegEx
Replies: 6
Views: 232

Re: <b26> More issues with RegEx

This comes up often. Scrivener is using the regular expression syntax (QRegExp class and the QRegExp::RegExp2 style syntax) described at the following URL: https://doc.qt.io/qt-5/qregexp.html Most likely your regular expressions are not compatible with this syntax. We plan on jumping to QRegularExp...
by adrm
Mon Oct 21, 2019 8:34 am
Forum: Beta Testing (Windows)
Topic: [LH4088] <b26> More issues with RegEx
Replies: 6
Views: 232

[LH4088] <b26> More issues with RegEx

RexEx searches are incredibly useful, but Scrivener beta 26 still has a number of issues. Certain searches producing unexpected results: I use (^ ) or (^\s) to locate paragraphs starting with a space character. In beta 26 documents containing these are not listed on the left-hand Search Results colu...
by adrm
Thu Oct 17, 2019 6:06 pm
Forum: Beta Testing (Windows)
Topic: <b25> Folders set to section type Chapter no longer show up correctly in compiled DOCX
Replies: 7
Views: 236

Re: <b25> Folders set to section type Chapter no longer show up correctly in compiled DOCX

rwfranz wrote:
Does that help?



Thanks, it does help as a workaround, even if I find the whole thing quite inconvenient.
Hopefully, it's an error and will be fixed soon, but it's still present in beta 26.

Perhaps someone from L&L can comment on whether it's a bug or a feature?
by adrm
Tue Oct 15, 2019 9:53 am
Forum: Beta Testing (Windows)
Topic: <b25> Folders set to section type Chapter no longer show up correctly in compiled DOCX
Replies: 7
Views: 236

Re: <b25> Folders set to section type Chapter no longer show up correctly in compiled DOCX

No one else is seeing this? I get this issue even if I switch to one of the built-in formats that come with Scrivener. For example Paperback (6" x 9") Scrivener seems to recognize my Section Types correctly like it always did in the past. But the page breaks and the chapter headings no lon...
by adrm
Mon Oct 14, 2019 6:43 am
Forum: Beta Testing (Windows)
Topic: <b25> Folders set to section type Chapter no longer show up correctly in compiled DOCX
Replies: 7
Views: 236

Re: <b25> Folders set to section type Chapter no longer show up correctly in compiled DOCX

(Note that this is the same compile format I've been using for months now) The folders are assigned Section Type : "Chapter". In the compiler, the Section Type "Chapter" is assigned a Section Layout that is: Title Options, Title Prefix defined as "Chapter <$n>" Also, Se...
by adrm
Sun Oct 13, 2019 9:52 pm
Forum: Beta Testing (Windows)
Topic: <b25> Folders set to section type Chapter no longer show up correctly in compiled DOCX
Replies: 7
Views: 236

<b25> Folders set to section type Chapter no longer show up correctly in compiled DOCX

This is an older document that compiled fine in beta 24.

In b25, only a blank line appears where earlier versions gave me "Chapter 1", "Chapter 2", etc
by adrm
Fri Oct 11, 2019 3:27 pm
Forum: Beta Testing (Windows)
Topic: Beta 25 compiles Footnotes as Endnotes
Replies: 2
Views: 118

Re: Beta 25 compiles Footnotes as Endnotes

Not saying it's not happening to you, but with my manuscript, footnotes compile correctly in v25, as with earlier versions.

Correctly, except for that annoying "*" before the footnote number, inside the text. That's still present.
by adrm
Thu Oct 03, 2019 9:36 pm
Forum: Beta Testing (Windows)
Topic: <b24> Jumping cursor revisited
Replies: 4
Views: 153

Re: <b24> Jumping cursor revisited

If your hands are brushing the trackpad (the fleshy part at the base of the thumb often makes contact, in my experiences with trackpads), they may trigger the behavior no matter how stiff the trackpad is. I eventually turned it off and used a mouse instead. As I recall, there are things about a tra...
by adrm
Thu Oct 03, 2019 11:58 am
Forum: Beta Testing (Windows)
Topic: <b24> Jumping cursor revisited
Replies: 4
Views: 153

Re: <b24> Jumping cursor revisited

Yes, that is a possibility I've considered. I need to locate a mouse, as I'm mostly using Scrivener on my laptop. The trackpad is rather stiff, so I'm 99% certain I'm not clicking it inadvertently. It could be a driver problem, but at least I have the latest versions installed and I've not seen the ...
by adrm
Thu Oct 03, 2019 11:15 am
Forum: Beta Testing (Windows)
Topic: <b24> Jumping cursor revisited
Replies: 4
Views: 153

<b24> Jumping cursor revisited

Perhaps it's me being clumsy, but in beta 24 I've had a recurring problem today: 6-7 times today, while I was typing, the blinking cursor (i.e. the insertion point) jumped away from where it should be and ended up where the mouse cursor was hovering inside the same document. At first, I figured it h...
by adrm
Tue Sep 24, 2019 4:08 pm
Forum: Beta Testing (Windows)
Topic: [LH4025] Remove Comments option not working?
Replies: 1
Views: 97

[LH4025] Remove Comments option not working?

Can't see this one being flagged before.

Although the compiler's Remove Comments option is checked, Scrivener's comments appear in the compiled .DOCX as MS Word comments.
by adrm
Tue Sep 17, 2019 10:28 am
Forum: Beta Testing (Windows)
Topic: [LH3987] Bug? Сursor jumps to the top document spontaneously in Scrivening Mode
Replies: 20
Views: 863

Re: [B23] Bug? Сursor jumps to the top document spontaneously in Scrivening Mode

I didn't want to mention it before, as I wasn't completely sure I wasn't hitting any keys inadvertently. But now I'm quite sure it's not me: Occasionally (twice this morning) the cursor has jumped on me in regular, non-Scrivening mode. There was no line wrap going on either. Just me typing along at ...
by adrm
Sun Sep 15, 2019 9:42 am
Forum: Beta Testing (Windows)
Topic: [LH3987] Bug? Сursor jumps to the top document spontaneously in Scrivening Mode
Replies: 20
Views: 863

Re: [B23] Bug? Сursor jumps to the top document spontaneously in Scrivening Mode

I can confirm this one.

Frequently, the cursor jumps up to the preceding document while I'm typing.
In my case, it doesn't seem to be triggered by reaching the end of a line, i.e. I can't tell what makes it happen.