Search found 124 matches

Advanced Search
by adrm
Sat Oct 17, 2020 12:47 pm
Forum: Beta Testing (Windows)
Topic: Major Milestone
Replies: 5
Views: 437

Re: Major Milestone

Thanks for sharing your experience with the latest releases, guys! It gives us confidence to release the official release sooner then later. Please don't release the product before you are confident it's as stable and feature-rich as you planned. Nothing good will come from releasing a product that...
by adrm
Sun Jun 14, 2020 7:57 pm
Forum: Beta Testing (Windows)
Topic: <RC7> Very slow startup for first document, or...?
Replies: 6
Views: 263

SOLVED: <RC7> Very slow startup for first document, or...?

Problem solved.

By analyzing Scrivener's wait chain I noticed that the spool service was the 'bottleneck'.

Apparently, Scrivener tried to connect to a network printer that was offline and was stuck in a non-responding state before timing out.

Solution: setting another default printer.
by adrm
Sun Jun 14, 2020 12:59 pm
Forum: Beta Testing (Windows)
Topic: <RC7> Very slow startup for first document, or...?
Replies: 6
Views: 263

Re: <RC7> Very slow startup for first document, or...?

I timed it, and the actual time it takes for the first document to display is 36 seconds . Once Scrivener is active, opening another document is near-instantaneous. I now believe that my earlier reference to dictionary loading may be misleading/irrelevant. 1) I switched dictionaries without seeing ...
by adrm
Sun Jun 14, 2020 12:02 pm
Forum: Beta Testing (Windows)
Topic: <RC7> Very slow startup for first document, or...?
Replies: 6
Views: 263

Re: <RC7> Very slow startup for first document, or...?

I timed it, and the actual time it takes for the first document to display is 36 seconds . Once Scrivener is active, opening another document is near-instantaneous. I now believe that my earlier reference to dictionary loading may be misleading/irrelevant. 1) I switched dictionaries without seeing a...
by adrm
Sun Jun 14, 2020 7:14 am
Forum: Beta Testing (Windows)
Topic: <RC7> Very slow startup for first document, or...?
Replies: 6
Views: 263

Re: <RC7> Very slow startup for first document, or...?

Not sure if this is relevant:

1) The problem is only noticeable on my (modern) laptop, where I have tested both high-dpi and regular versions.
2) My desktop PC does not show this issue.
by adrm
Sun Jun 14, 2020 6:53 am
Forum: Beta Testing (Windows)
Topic: <RC7> Very slow startup for first document, or...?
Replies: 6
Views: 263

<RC7> Very slow startup for first document, or...?

Is it just me, or is RC7 much slower than previous releases when opening the first document after application startup? Even an almost empty document has a noticeably long delay (5-10 seconds?) before showing on-screen, while later documents open as snappily as before. I don't recall this happening w...
by adrm
Thu May 28, 2020 4:01 pm
Forum: Beta Testing (Windows)
Topic: How to access Linguistic Focus?
Replies: 16
Views: 909

Re: How to access Linguistic Focus?

Great addition.
I hope there will be a way to define a hot-key for it, though.
by adrm
Wed May 27, 2020 8:08 am
Forum: Beta Testing (Windows)
Topic: [LH4567] RC6 high DPI version not working?
Replies: 15
Views: 846

Re: [RC6} high DPI version not working?

I opened a couple of old projects on my high-DPI ultrabook, and so far everything looks normal.
by adrm
Sat May 16, 2020 1:00 pm
Forum: Beta Testing (Windows)
Topic: [NB] ! SERIOUS PROBLEM -- SCENE GONE !
Replies: 4
Views: 458

Re: ! SERIOUS PROBLEM -- SCENE GONE !

And sometimes I click on a binder entry and not realize I'm dragging it, and I drop it under another binder entry (every binder entry can act as both document and as a folder containing other binder entries) without even realizing I'm doing it. Indeed, this has happened to me, as well... a few times.
by adrm
Mon Apr 06, 2020 11:35 am
Forum: Beta Testing (Windows)
Topic: [RC1] Performance?
Replies: 11
Views: 404

Re: [RC1] Performance?

Out of curiosity, where do you see the slowdown?
I'm still on the last version before RC1, but a 100K word document seems very snappy on my ultrabook.

I tried Scrivening mode as well as jumping between individual chapters.
by adrm
Fri Mar 27, 2020 9:00 am
Forum: Beta Testing (Windows)
Topic: <b43> Assigning character styles seems unreliable
Replies: 1
Views: 130

Re: <b43> Assigning character styles - bug

The problem seems to be this: Having applied a character style via the Styles Panel, the style selection seems to "stick around". I.e. when I select another set of words, the previously used style is still highlighted in the panel, and can't be used. When this happens, one must either clic...
by adrm
Thu Mar 26, 2020 3:57 pm
Forum: Beta Testing (Windows)
Topic: <b43> Assigning character styles seems unreliable
Replies: 1
Views: 130

<b43> Assigning character styles seems unreliable

I'm pasting plain text into documents and frequently I need to apply a character style ( Italic ) to certain words. I use the Styles panel for this work. 80% (-ish) of the times the style is applied correctly, but in 1 out of 5 cases something goes wrong: According to the style info panels, the styl...
by adrm
Fri Mar 20, 2020 10:20 am
Forum: Beta Testing (Windows)
Topic: <b43> Annoying Find dialog
Replies: 0
Views: 1021

<b43> Annoying Find dialog

The current implementation of the Find dialog has some annoying quirks:

1) You need to click inside the main text window before the buttons become enabled (I think this one has been reported previously)

2) The dialog stays on top of / in front of any other application's window.
by adrm
Fri Mar 20, 2020 10:16 am
Forum: Beta Testing (Windows)
Topic: Scrivener 2.9.42: Removing Carriage Returns (CR's) [Windows 3 Beta #218
Replies: 4
Views: 2847

Re: Scrivener 2.9.42: Removing Carriage Returns (CR's) [Windows 3 Beta #218

If it's a soft carriage return, i.e. not an end of paragraph, you can regex search for \x{2028}

I haven't found a way to search for the end of paragraph, a.k.a. pilcrow mark :cry:
by adrm
Tue Mar 17, 2020 4:52 pm
Forum: Beta Testing (Windows)
Topic: Formatting error when editing with ProWritingAid
Replies: 10
Views: 1822

Re: Formatting error when editing with ProWritingAid

For those who use ProWritingAid. I've communicated with them about this issue for months now, and as far as I can tell, they have finally resolved the issue where PWA inserts a soft line break instead of an end of paragraph marker when you hit Enter. In short, as of version 2.0.36 (released 16th of ...