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Part I

Introduction

The maker of a sentence launches
out into the infinite and builds a
road into Chaos and old Night, and
is followed by those who hear him
with something of wild, creative
delight.
RalphWaldo Emerson
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Philosophy



The word processor, that staple of writers’ tools, is the digital age’s equivalent of
the typewriter. And as with the typewriter before it, theword processor is a great
tool for typing up a letter, for writing from a plan created somewhere else, or for
hammering out words to see where they lead you.
Ultimately, however, a word processor assumes a predominantly linear ap-

proach: you write the beginning first, the end last. You enter text, cut and paste,
perhaps even work with a basic outline, but the true focus is on presentation,
on producing a professional-looking document. The word processor offers lit-
tle in the way of the foundations on which writing is done—the planning, the
research, teasing out an effective structure.
In this sense, Scrivener is the opposite of aword processor, because Scrivener’s

focus is on how you put together a long document rather than on how it is pre-
sented. It is the digital equivalent of a writer’s studio, incorporating not only
the typewriter, but also the notebook, the index cards and corkboard, the jotted
plan, the scrapbook and the folder of research.
Scrivener was built to bring together the various tools of the working writer

in ways that only software can. Because this is where software comes into its
own—taking tasks that are disparate in the real world and integrating them. To
take just one example, in the analogue world, if youmove index cards around on
a corkboard, you also have to reshuffle the sections those cards represent in your
manuscript. In Scrivener, the corkboard and manuscript are integrated, so that
moving a card on the corkboard moves the associated section in the manuscript
and vice versa.
Every writer sneaks up on the blank page differently; accordingly, Scrivener

is designed to be flexible, to adapt to the writers’s workflow, not the other way
around. It works equally well for writing a novel, a doctoral dissertation, a short
story, a screenplay—or anything else. It doesn’t prescribe any particular struc-
ture or approach. Fiction writers often debate the merits of plunging in and
writing versus planning everything before typing a single word, but Scrivener is
agnostic and allows either approach—or a mix of both.
The core concepts of Scrivener are these:

— Its editor should be familiar to anyone who has used a word processor.

— You can break the manuscript down into sections as large or small as you
like, and work on it in any order.

— You can view sections as discrete chunks or in context with other sections.
In a novel, for instance, you could view a scene on its own, in the context
of its chapter, or in the context of the whole novel.

— Each section is associated with an optional synopsis, to indicate what the
section is or will be about.

— You can step back and see all the synopses in an outline or on a corkboard
to get an overview of the whole manuscript, or of a single chapter.
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— Awriting project is essentially a digital ring-binder in which you can store
and view images, web pages, recorded interviews andother research along-
side your writing.

— You can view more than one document at the same time: refer to notes
alongside a chapter, or bring up an image alongside the description you
are writing.

— What looks great in print is not always best for the screen, so you can
choose a different format for your exported or printed work without af-
fecting the original text, and you can tailor the formatting for a particular
output. An ebook can be formatted one way, a printed manuscript an-
other.

The underlying philosophy of Scrivener was in part inspired by a passage writ-
ten by the authorHilaryMantel in a collection of essays bywriters on the process
of writing entitled The Agony and the Ego. Hilary Mantel described a process of
“growing a book, rather than writing one,” which can be summarised thus:

1. During thefirst stage ofwriting, youmight jot ideas downon index cards—
phrases, character names, scene ideas; any insight or glimpse.

2. When you have gathered a few index cards, you might pin them to a cork-
board. Other ideas build around them, and you might even write out a
few paragraphs and pin them behind the index card with which they are
associated. At this stage, the index cards have no definite order.

3. Eventually, you may begin to see an order emerging and re-pin the index
cards accordingly.

4. After you have gathered enoughmaterial, you might take all of your index
cards, sheets of paper and jottings and place them into a ring-binder. You
are still free to move everything around, but now you have a good idea of
howmuch work you have done and howmuchmore work you have to do.

Scrivener, then, provides an environment in which you can “grow” your work
organically—an environment which in turn grows with your writing, to accom-
modate the multifarious stages of composition.
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2
About This
Manual



Scrivener has a wide variety of features to accommodate many different pur-
poses, including novels, screenplays, academic papers and dissertations, general
non-fiction, journalism, blogging, and much more. While it strives to present
as simple an interface as possible, once you start digging into the application,
you will find a degree of flexibility and complexity to suit even the most esoteric
needs. To help organise all of these concepts and features, the manual itself has
been split into four primary sections including an appendix. In each section the
features most useful to you during those phases of your real-world project will
be explained in depth:

1. Introduction (Part I): the first section goes over basic installation and up-
dating notes, and then introduces several fundamental concepts regarding
Scrivener’s interface, how it stores yourwork into “projects”, and how your
work is organised within those projects. This will be essential reading for
anyone new to the software, and an index into the various elements you’ll
see on screen as you learn.

2. Preparation (Part II): next, we’ll take a deeper look at all of the core or-
ganisation and management features of Scrivener. It could easily be said
that Scrivener is as much about organising your writings (and thematerial
you use to help write them) as it is about getting the actual typing done.
You may not need all of the topics we’ll go into in this section, but if you
have a question on how the program is meant to work at the higher, more
organisation levels of usage, chances are you’ll find it here.

3. Writing (Part III): beyond the obvious aspects ofworking in the text editor,
we’ll also go into themany other activities thatmust be donewhilewriting,
such asworkingwith images and inserting them into yourmanuscript, an-
notating your work with comments and footnotes, formatting, handling
revisions and so forth.

4. Final Phases (Part IV): getting your work out of the software and into the
hands of your agent, publisher, readers or wherever it needs to go next,
will be the final practical focus of the manual. We’ll also discuss options
for exporting files and printing copies.

5. Appendices (Part V): last but not least, we’ll go over every single menu
command, preference and miscellaneous reference you may need. These
sections can also serve as a large topical index, as you can easily look up
more advancedor in-depth topics by startingwithwhat you’ve foundwhile
exploring the interface.

Although it will endeavour to explain features in depth, the Scrivener User
Manual is intended as an exhaustive reference, rather than a training tool. The
best way to kickstart your use of the software is to take the Interactive Tutorial,
located in the Help menu.
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2.1. Terms & Conventions

Upgrading from Scrivener 2

If you’ve been using Scrivener for a while, you’ll also want to check out
our What’s New (Appendix F) appendix, as a few things will have moved
around or require your attentionwhen youfirst upgrade yourwork to the
new version. You can also keeps tabs on new developments in Updates
to Version 3 (section F.11).

This manual has been written using Scrivener (yes, we eat our own dog food!)
and is available in a few different formats from our web site. The writing style
makes use of MultiMarkdown formatting syntax and so demonstrates that sys-
tem as well.

Annotating this PDF

If you wish to make notes and annotate the PDF using software such as
Adobe Reader, it is recommended you download a separate copy from
the above linked page, or open the PDF from the Help menu and drag
the icon from the window’s title bar into your binder, or to Finder with
the Option key held down to create a copy. When Scrivener updates, it
will very likely overwrite the existing PDF in the installation (often with
revisions to the text), which will destroy any of your notes.

2.1 Terms &Conventions
Some features apply only to the standard version of the software, and others
only apply to the Mac App Store version. Various key features will be marked
to indicate this. If you have purchased the program directly from our web site,
then you have the standard version. If you used Apple’s App Store tool to buy
Scrivener, then you have the Mac App Store version. Sections applicable to only
one or the other will be indicated with the following markers:

— Standard retail version of Scrivener: ⟨Direct-sale only⟩

— Mac App Store version of Scrivener: ⟨MAS only⟩

Similar markings will be used to indicate when specific versions of macOS are
required for a particular feature to be available.

2.1.1 Interface &Menus
Whenever the documentation refers to an interface element that can be inter-
acted with, such as a button, the visible name for that element will be formatted
in dark red, such as “Click on the OK button to save changes”. Button labels,
keyboard shortcuts and menu items will all be displayed in this fashion.

7

https://www.literatureandlatte.com/learn-and-support/user-guides


2.1. Terms & Conventions

Menus will be displayed in a hierarchy using the “ ▸ ” character to separate
top-level, submenus, and commands. E.g. to convert a range of selected text
to uppercase, invoke the Edit ▸Transformations ▸MakeUppercase command. Some
menu commands change their name depending on usage. The parts that change
will be indicated like so: View ▸Text Editing ▸Show|Hide Invisibles.

Difficulty Seeing the Labels?

We have prepared an alternate version of this project that may increase
the visibility of hyperlinks and interface labels in this project, for those
with red/green colour blindness.

Some of the names for various elements within Scrivener are customisable on
a per project basis, and how you name these will impact much of the interface.
A good example is the “Label” setting, which can be used to colour-code your
work. How it is referred to can be changed in settings (to something like “Point
of View” or “Rewrite Status”), andwill impact the names ofmenu items andother
bits of interface that refer to it. In all cases, this documentationwill refer to these
malleable elements by their default names.
The names of features will be capitalised as proper nouns if it is necessary to

differentiate them from standard nouns. A Collection is a group for organising
loose documents, while the word “collection” may be used to indicate a casual
grouping of items and not necessarily a formal Collection.

2.1.2 Keyboard shortcuts
Keyboard shortcuts will use the following symbols:

— ⌘: The Command key, or the Apple key, is the one located directly to the
left and right of your spacebar.

— ⌥: The Option key is also labelled the Alt key on some keyboards, depend-
ing on which country you purchased your Mac from. Some laptops only
have one Option key on the left side.

— ⌃: Control is usually located to the left and right of the Option keys on
their respective side. Some laptops only have one Control key between
the Option key and the Fn key on the left side.

— ⇧: The Shift keys are rarely used by themselves in shortcuts but are often
used in combination with other modifier keys.

— The arrow keys on your keyboard will often be shortened to the four sym-
bols: ↑ ↓ ← and→.

When a keyboard shortcut requires a combination of modifier keys, they will
be printed together. Example: ⇧⌥⌘V (whichmatches Edit ▸PasteandMatchStyle)
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2.2. Finding Things in this Manual

means you should hold down all of thesemodifier keys together and then tap the
V key on your keyboard.
TheMac distinguishes between the Return key and the Enter key in some con-

texts. Specifically to Scrivener, we will point out the few places where using one
key over another will make a difference. If you are using a compact or laptop
keyboard, you may need to use the Fn-Return key combination to press the Enter
key.

2.1.3 TheGear Button
With the release of macOS 11, Apple has changed how the gear menu button
looks. This documentation will refer to that button using the symbol, but be
aware that on older version of macOS, this button will appear as a gear .

2.1.4 Settings Labels
Scrivener hasmany Settings (found in Scrivener ▸Settings…).1 They are organised
into a hierarchy starting with a major category along the top of the window (like
“Behaviors”), and sometimes into secondary tabs, either along the top or if there
are several sub-categories, along the left, in a list. To refer to a specific category,
we would say, “Behaviors: Navigation”. If a subcategory has further sections
within it, then we’ll say something like, “Appearance: Binder: Fonts”.
The labels used in the interface to denote settings will be marked in dark

brown boldface, where theBinder Font is a font setting locatedwithin the afore-
mentioned settings pane.

2.1.5 Filenames & Paths
In cases where file paths are printed, the UNIX convention of providing a short-
hand to describe your personal home folder will be used. An examplemight look
like:

~/Documents

The tilde is a shorthand whichmeans: /Users/yourusername. In this case, the
path refers to the Documents folder in your home folder.

2.2 Finding Things in this Manual
This PDF has been birthed within the age of digital documentation, and a proper
index has never been compiled for it. Despite this, in practice you should have

1Onolder versions ofmacOS themenu commandwill be printed as “Preferences”, and references
to System Settings (“System Preferences”) locations may no longer be accurate.
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2.3. Spot a Problem?

little difficulty in locating the topic you are interested in. Modern PDF reader
software features excellent searching capabilities; most things can be discovered
merely by searching for the proper names of things as labelled inmenus, buttons
or dialogue boxes.
Additionally, the appendices have been written to be used as a sort of topical

index. If you have a question about a particular menu command or setting you
can find them in Menus & Keyboard Shortcuts (Appendix A) and Settings (Ap-
pendix B). Throughout themanual itself, cross-references tomore thorough de-
scriptions of the featurewill be provided. Interface inOverview (chapter 4) offers
a visual guide of themain project window alongwith numerous cross-references
to additional documentation, and serves as away of learning the names of things
in the software.
Lastly, if you are using a PDF reader with a contents sidebar feature you will

find a very detailed table of contents has been provided. You can thus narrow
down what you are looking for from vague topics in this fashion.

2.3 Spot a Problem?
A user manual is a living document. It evolves constantly as the software itself
evolves, and as a result it can oftentimes be difficult to keep edited to the same
calibre we’d expect of a finished and published book. If you spot a problem, or
have a suggestion that would make this a better resource for you, we’d love to
hear about it. Drop us a line at contact@literatureandlatte.com.
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Installation &
Upgrading



3.1. Installation

3.1 Installation
⟨Direct-sale only⟩ If you purchased Scrivener through the Mac App Store (MAS),
then this section will not be relevant to you, as it pertains to the registration,
installation, and maintenance of the standard retail version. When purchasing
software through the MAS, all such tasks are done through the store software it-
self. If you require assistance installing or updating Scrivener through the Store,
consult Apple’s documentation on the matter.
Whether you have purchased Scrivener or are looking to give it a try-out, the

download and installation process will be an identical, as we use the “shareware”
model of providing a try-before-you-buy version that can be unlockedwith a key
at any time. Thus it will be the key that is important to keep safe, more so than
the downloadable software. To begin:

1. If you have not already downloaded the trial version from the Literature &
Latte web site, do so now.

2. When the installation DMG finishes downloading, locate it in your web
browser’s download folder and double-click to open the installer.

3. Drag the Scrivener icon to Applications folder, as indicated by the arrow.1

4. Eject the installation DMG by using the File ▸Eject command in Finder on
the installation window.

5. Open the Applications folder in Finder and double-click the Scrivener icon
to launch the software. If you drag the icon to your Dock, always do so
from the Applications folder, not the installation DMG.

Software complains about not being installed correctly?

If you attempt to run Scrivener from a place that resembles the installa-
tion DMG, you may get a message offering the chance to have it installed
for you.a If you intend to run Scrivener from outside of an Applications
folder, then you should check the box that will inhibit this warning from
appearing again in the future.

aIn technical terms, thatmeans a removable volume or a disk that is read–only. If either
of those conditions exist the warning message will be triggered.

1 If you lack permissions to install software into the main system Applications folder, you can
create an “Applications” folder in your home folder and drag Scrivener (and other software) there,
instead.
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3.1. Installation

3.1.1 The Trial Version
You can try out all of the features of Scrivener for 30 non-consecutive days with-
out having to pay or register. During that period, Scrivener will be fully func-
tional. After 30 days of use (and one grace session so you can export your work),
you will no longer be able to access Scrivener at all unless you register. If you
are getting close to the end of your trial and have decided to not purchase Scriv-
ener, please skip forward to the sections on Compiling the Draft (chapter 23) and
Exporting (chapter 25), for details on getting your work out of the program.
During the trial period, whenever you launch Scrivener, you will be reminded

of how many trial days you have left. From the same window you can choose to
buy a licence right in the software.

3.1.2 Purchasing Scrivener
Should you choose to purchase the software, registration will be a seamless pro-
cess of unlocking the copy you’ve already downloaded. All of your settings and
work will be right where you left them. Use the Help ▸Purchase Scrivener…menu
command, and click the “buy” button to launch the built-in store.2

When you buy a licence within the software, it will be activated automatically
for you at the conclusion of a successful purchase. You will also be emailed your
unique serial number, in case automatic activation fails. Make sure that you keep
this serial number, along with the email address you used, in a safe place, as you
will need both to register Scrivener again in the future.
If you have lost your serial number, clicking the Retrieve Lost Serial… button in

the registration window will take you to our self-service support site, where you
can request to have the information sent to your email address again. If for some
reason you cannot get that to work, or no longer have access to the email used
to purchase the software, please contact us on our support page.

3.1.3 Upgrading andDiscounts
If you have been using the older version of Scrivener for some time, and are a
registered user, then youwill either be eligible for a discount, or if you purchased
recently enough, a free upgrade. In order to determine your eligibility, use the
Help ▸PurchaseScrivener…menu command, and click the “Upgrade from an older
version” link, found below the large “buy” button.
Youwill be asked to input your legacy serial number. Our systemwill check the

validity of this number, and whether it is eligible for a free upgrade. Depending
upon the outcome, a couponwill be applied to your purchase of Scrivener. If you

2 A secure connection will be established between your computer and our vendor, Paddle. Scriv-
ener itself will not gather your purchasing information or personal details, unless you opt–in to
signing up for our newsletter when asked. If youwould prefer to use the security of your browser
to make the transaction, visit our web store.
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3.1. Installation

are eligible for a free copy, you will still need to finish the check-out procedure,
but will skip the final payment phase.

3.1.4 Registering Scrivener
If automatic activation failed, you purchased Scrivener through the web store,
received your licence as a gift or are simply reinstalling the software—you can
register Scrivener at any time by clicking on the Enter License… button in the
demowindow that appearswhenever you launch Scrivener, or by using the Scriv-
ener ▸Enter Licence…menu command.

1. In the first field, supply your current email address, or the address used to
purchase the software originally.

2. Copy and paste the unique serial number in the “Serial Number” box,mak-
ing sure that the hyphens are included as indicated, and that there are no
unwanted spaces at the beginning or end of the pasted text.

3. Click the Register button.

If you receive a message stating that the information is invalid:

— Check and make sure they are in the right order. Your email should be in
the top field; the serial number in the second field.

— Ensure the serial number you have looks correct. It should be a long se-
quence of capital letters and numerals, separated into five groups by hy-
phens.

After clicking the registration button, Scrivener will attempt to authenticate
your copy over the Internet. An active Internet connection is necessary to ac-
tivate the software. If you cannot immediately activate, you can proceed using
the software, but will have to go through this procedure until such a time as you
can bring the system online.
Once Scrivener has been registered, you can begin using it immediately. There

will no longer be a time limit on its use and you will no longer see the nag box at
startup.

3.1.5 Application Updates
The second time Scrivener is launched you will be presented with a panel asking
whether or not Scrivener should automatically check for updates over the Inter-
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3.1. Installation

net. Use of this feature may cause a delay in startup, whenever it is scheduled to
check for an update.3

— Click the Check Automatically button to have Scrivener perform a daily
check for updates.

— Click the Don’tCheck button to opt out. You can always manually have the
software check for an update by using the Scrivener ▸Check for Updates…
menu command.

You can change the automatic update settings in Scrivener ▸Settings…, under
the General: Startup tab, Automatically check for updates. Once enabled, ad-
just how frequently the software checks in with our server to see if there is a
newer version.
When an update is detected, a window will appear with information about

the update and some buttons to install or defer the update. It is recommended
you brief yourself with the update notes, as sometimes changes in operation or
system compatibility can occur. You can view the full list of changes at any time
on our web site.

— Install Update: download the newer version of Scrivener and have it in-
stalled for you automatically. Note that you can work while it is down-
loading, but the software will need to restart at some point to implement
the upgrade.

— Remind Me Later: dismiss the update panel and return to your work. You
will be notified again the next time an update check is performed.

— Skip This Version: dismiss the update panel and return to your work. You
will never be notified about this specific version number again, but youwill
be alerted of future updates beyond the current one.

Automatically download and install updates in the future If you leave this
option checkedwhen clicking the Install Update button, then Scrivener will
never bother you about updates in the future. Instead it will start down-
loading them as soon as they are available, and will inform you of when
the download is complete so that you can have it install and restart the
software.

3 No personal information or even anonymous system information will be sent to our server,
other thanwhat is strictly necessary to form a connection between any twomachines (IP address,
client version and the file being requested). It will download a copy of the update file, which will
be checked against your version number internally.
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3.2. Upgrading to Scrivener 3

Software vs Your Work
Unlike some mobile devices, standard operating systems don’t conflate
your work with the software icon and there is no connection between
the two. Computers are considerably more robust and well designed for
content creators. Like all programs, Scrivener saves your work into files
separate from the software. Upgrading versions, registering your trial,
or switching to a beta build will have no impact on your data (save that
you of course will not be able to open them so long as Scrivener is not
installed).

3.1.6 Portable Installations
Wedonot recommend installing Scrivener on a portable drive that you routinely
remove from your computer. It is best to install and register Scrivener on each
machine independently and keep your data portable. In most cases this can be
done with a single user licence, but you should check with our licensing details
to verify.

3.2 Upgrading to Scrivener 3
Major paid upgrades to the software represent large overhauls to the software.
You may be alerted to this in the standard update panel, leading to more infor-
mation on our site, rather than offering to replace your current copy of Scrivener
v2 in place. To audition the new version, it might be a better idea to download
the demo from our website directly, and run it alongside the older version.
It is our hope that you find major upgrades to be familiar to use in most

regards, but if you are a veteran of the software, there will always be new or
changed areas worth investigating. The built-in interactive tutorial, found in
the Help menu has a guided tour of what has changed, and if you require more
detail, please refer to the appendix, where you will find a full guide on modified
and added features in Scrivener 3 (Appendix F).

Close to a deadline?
The main thing you may wish to be aware of, prior to upgrading Scriv-
ener, is that you will need to reconfigure the compile settings of your
projects. We have made every effort to make the transition as painless as
possible, but given the extent of the overhaul that has been done it is not
possible to copy all of the settings across for you. So if you are on a tight
deadline and have a lot of complicated compile settings in play, it might
be best to hold off on upgrading that project until such a time as you have
the leisure to review the new options and see how they can implement
the effects you were looking to achieve with the older settings.
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3.2. Upgrading to Scrivener 3

3.2.1 RunningMultiple Versions
While it is possible (and safe) to run more than one version of Scrivener at once
on your computer, it is advisable to first uninstall the older version prior to in-
stalling the new version. To do this, make sure Scrivener is closed, then drag its
icon from the Applications folder to the Trash in your Dock. Once the old ver-
sion is uninstalled, follow the installation instructions provided in the previous
section.
In some cases, you may need to keep an older copy around. When running

multiple versions of a program, you’ll want to keep the following in mind:

— To open older projects in Scrivener 1 or 2, youwill need to drag these items
onto their specific program icons, or use the File ▸Open…menu command
fromwithin these older versions. When double-clicking on projects in the
Finder they will most likely open in the new version (you can cancel the
project upgrade procedure if you make a mistake).

— So long as you have both versions installed, the Mac might get confused
over the Services, which can be used to clip information from other pro-
grams into Scrivener. Once you have fully uninstalled the old version of
Scrivener, these clipping services should work just fine after a reboot.

— It is safe to run both copies at once, as they use different settings, though
they will share common resources like project templates and various pre-
sets. If it is important to keep some of these distinct, we advise using nam-
ing schemes to do so.

3.2.2 Upgrading Projects
The project file format has been updated considerably, and new or upgraded
projects cannot be opened in older versions of the software. The first time you
load each of your older projects you will be presented with a dialogue box asking
if you wish to upgrade the project format. Review the instructions and advice
provided in Project Format Upgrades (subsection 5.1.6) for further information
on that process.

3.2.3 Recovered Files
Older versions of Scrivener’s project format were designed before the concept
of synchronisation, or “cloud” servers, became popular. A common method of
handling conflicts with these systems is to duplicate files that have been edited
in two different places at once. In the past, these duplicate files were left unre-
marked, and left to accumulate within Scrivener’s project format.
Scrivener 3 includes a much more thorough project repair system that runs

whenever you open a project, and this will include the first time the project is
updated from an older version. The result for some people might be years worth

17



3.3. Setting Up Your System

of old conflict files being rooted out, and presented to you as “recovered files” in
the binder! Youmight also be asked to choose between several different binders.
This may be alarming at first, but bear in mind Scrivener is merely going

through old duplicate files it is only now detecting. Going forward you will be
made more immediately aware of them as they occur.

3.2.4 Saving Your Projects forOlder Versions
As noted, once you have upgraded your project to the new format, it will no
longer be directly accessible to Scrivener 2.x for macOS, or 1.x for Windows.
However it is possible to save a copy of your project in a format that can be read
with these older versions, and even later load the modified project back into v3
with minimal loss of new settings and features.
The procedure is simple, but it’s important to understand that you won’t be

able to share the project directly. If you’ve been working through a medium like
Dropbox, with all devices and collaborators sharing one single project, you will
need to adjust your working habits slightly.
To save a copy of your project in legacy format:

1. Open the project you need to save, and use the File ▸Export ▸as Scrivener 2
Project…menu command.

2. Select a location to save the copy (if using the cloud, choosing your shared
folder would be a good option here) and select a name for the project.

3. Click Save

This will create a completely new copy of the project in a format that can be
edited freely by older versions of Scrivener. However, when you wish to load the
project back into Scrivener 3.x, it will need to be upgraded once again.
This method will therefore require a little management of project files which

will accumulate every time you switch versions—and it also means that with
larger projects that take considerable time to fully save andupgrade, itmaynot be
a feasible way of working at all. In such cases, it may be easier to keep a separate
copy of the older version of Scrivener (which you are entitled to use and unlock
with your version 3 serial number, if purchased directly fromus) and simply defer
upgrading the project to v3 until such a time that all machines that need to work
with the project can read and work in that format.

3.3 Setting Up Your System
For most uses, Scrivener will be ready to go as soon as you install it. However
if you’re interested in some of the optional extras it provides, this section will
describe how to set them up.
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3.3.1 Setting Up SystemServices
Scrivener comes with a number of system-wide Services that you may use to
more easily capture information from other software. As with all Services, they
can be configured in System Settings: Keyboard: Keyboard Shortcuts, within
the “Services” tab.4 You will find all of our services located within the “Text”
subsection of this pane. Read more about Scrivener Services (section 9.3).

3.3.2 Installing Extras
⟨MAS only⟩ If you are using the MAS version and wish to use the “Print PDF to
Scrivener” feature from print panels Mac-wide, you will need to install the alias
yourself:

1. Open two Finder windows, one pointing to the Applications folder where
Scrivener is installed, and the second to the “PDF Services” folder in your
user Library folder.5

2. Drag the Scrivener icon from the Applications window to the PDF Services
window. This will create an alias (the icon should have a curved arrow in
the corner of it where you dropped it).

3. Rename the alias in the PDF Services folder to something like “Save PDF to
Scrivener”.

It is also not possible to install the custom Scrivener colour swatch groupwith
the MAS version. The Scrivener group will still show up in the palette, but any
changes youmake to itwill be lost after you restart the program. Tomake perma-
nent changes, you’ll need to create your own group called “Scrivener Custom”.
The best way to do this is to rename the Scrivener set to “Scrivener Custom”,
using the button menu to the right of the palette selection menu. This will cre-
ate a persistent colour swatch group for you, preloaded with all of Scrivener’s
built-in colours. Refer to Naming Text Highlights (subsection 18.5.1) for more
information.

3.3.3 Setting upMultiMarkdown or Pandoc
⟨Direct-sale only⟩ For those interested in using Scrivener as a platform for au-
thoring semantic or technical markup, Scrivener comes with MultiMarkdown
embedded within it, and all of the extra files necessary to produce documents of

4Onolder versions ofmacOS themenucommandwill be printed as “Preferences”, and references
to System Settings (“System Preferences”) locations may no longer be accurate.
5 Hold down the Option key when using the “Go” menu in Finder to get there.
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any type, directly out of Scrivener (chapter 21).6 However you may want to up-
date MMD to a newer version if the one we provide is older. Additionally, those
using the LATEX document typesetting system will get cleaner compile results by
installing the diverse LATEX support files that MultiMarkdown uses to build dif-
ferent document types. Youwill find instructions for downloading and installing
MultiMarkdown on its website. Scrivenerwill check for andmake use of any ver-
sion of MultiMarkdown you’ve installed yourself, so long as it is installed in the
standard location:

/usr/local/bin

Scrivener also supports a few Pandoc export options. However given the size
of Pandoc, we are unable to embed a copy of it within Scrivener, and youwill not
see any compile options for it, unless you install it yourself on the system. You
will find download and installation instructions on the Pandoc website. Once
installed, and Scrivener has been restarted, you should see the Pandoc entries at
the bottom of the compile file type list.

3.4 Staying Informed
If you would like to keep up to date on the latest developments and releases of
Scrivener, you can sign up for our low-volume newsletter using Help ▸Keep Up
to Date…. Once you submit the form, a confirmation email will be sent to the
address you provide. You will need to click a link within this email before you
will be officially added to the list. If you cannot find the confirmation email after
24 hours, check your spam folders, and consider adding “literatureandlatte.com”
to your white-list.
The “Keep Up to Date…” window also has links to our Twitter feed and Face-

book page. We frequently publish small tricks and tips through these channels.

6 Recent versions ofMultiMarkdown, which are embedded in Scrivener, are not compatible with
macOS 10.13. You will need to install your own copy in order to regain access to the conversion
options in the compiler.
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Scrivener’s interface has been carefully designed to scale across a wide range
of uses. At its most minimal, the programmay look nomore complicated than a
basic text editor, such as TextEdit; at its most complex it can fill a multi-monitor
workstation with expansive detail into a major project comprised of thousands
of components.
In this section, we will go over some of the basic interface elements that will

be present in nearly every project you work in, as well as the way we’ll be talking
and thinking about the software. Advanced featureswill be gradually introduced
when they pertain to specific areas of the writing process. We’ll try to point you
to those areas as we go along, making this chapter a sort of “index” of the things
you can see and make use of in the software.



4.1. The Project Window

4.1 The ProjectWindow
When you initially run Scrivener, you will be presented with a Getting Started
and project template selection window (Figure 5.1). Whenever you are ready to
start a new project, whether it be a new novel or paper for a journal, you’ll use
this interface to select a starting template (subsection 5.1.1). (This window can
be used to load existing projects you’ve created, as well, with the buttons along
the bottom.)
If you wish to play around in a safe and simplified area while following along

in this chapter, click on the “Blank” category in the left list, and then use the
“Blank” starter to create a basic empty project.

Figure 4.1 The five main areas of the project window.

The main project interface comprises five main elements (Figure 4.1), not all
of which are visible when a new project is created. Each of these elements will
be explained in greater detail in the following sections.

a) Toolbar (subsection 4.1.1): frequently used tools displayed in a standard
fashion, familiar to most macOS applications, that can be customised as
you see fit.

b) Binder (subsection 4.1.3): themaster list of all the documents and resources
in your project, from your work in progress to scribbled down notes to
extensive research materials. Its visibility can be toggled from the View
button, on the far left of the default toolbar.

c) Format Bar (section 4.1.4): frequently used text formatting tools, available
to the main text editor and a few other subsidiary text editing contexts as
well.
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d) Editors (subsection 4.1.4): this multi-purpose area is where all file viewing
and text editing is done. The editor can be split into two panes (as shown
here in horizontal orientation). These splits can show two parts of the
same document, or two different items altogether.

e) Inspector (subsection 4.1.5): a feature-packed tool providing information
about the currently active split. Its visibility can be toggled with the blue
‘i’ button on the far right hand side of the default toolbar.

The main interface sections (binder, editors, and inspector) can be resized
by dragging the divider line between them, and many of the smaller elements
within these areas can be resized as well.

4.1.1 Toolbar
Spanning the width along the top portion of the project window is a customis-
able toolbar, with convenient access to some of Scrivener’s most used features.
To change the order, add, or remove icons, use the View ▸Customize Toolbar…
menu item, or right-click on the toolbar to switch between text, icon and text +
icon display modes.
There are four styles of buttons used on the toolbar:

1. Multifunction: these have a downward facing arrow on the right side of
the button with a dividing line between the arrow and the rest of the
button—such as the “View” button on the far left side. These buttonswork
just like the main menu in that you can click once to show the respective
options and click again to choose one, or click and hold, move the mouse
and then release the button on the desired option to select it.

2. Multifunction with a default action: when there is a dividing line between
the icon and the downward arrow—such as the “Add” button. The left side
of the button can be clicked once to activate the button’s default behaviour.
If you click on the arrow side of the button, it will act exactly as described
above and provide additional options.

3. Simple: the button only has one function and clicking it performs that
function.

4. Toggle button: you can think of these as being a bit like one single button
with more than one setting. You select from one of the provided options
by clicking on the associated icon within it. The “Group Mode” button is
an example of this kind.

It is also possible to hide the toolbar by using theView ▸HideToolbarmenu item.
All functions present on the toolbar have alternate access throughout the rest of
the interface or through menus.
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TheDefault Button Set
We’ve curated a selection of buttons for quick access to commonly used func-
tions. We’ll go over these buttons in brief, pointing you to additional reading
material if you are curious to read more on the feature itself. You aren’t stuck
with any of our choices; any of the buttons can be removed and there is a broad
selection of alternative buttons available to be added.

Figure 4.2 Default toolbar (left): view settings, search and item editing.

The left end of the toolbar contains the following functions:

View Quickly toggle a fewof the primary organisational tools in the projectwin-
dow and formatting tools in the editor. Also provides access to any saved
project window layouts (section 12.3). All of the options found in this mul-
tifunction button can be individually added to the toolbar.

Search The default action of this button toggles the display of the project search
(section 11.1) field that appears above the binder sidebar when active. The
multifunction button provides additional access to Scrivener’s numerous
search capabilities (sans Quick Search, which has its own field on the tool-
bar). Project Search and Project Replace can be individually added to the
toolbar.

Add The default action adds a new text entry, while the multifunction button
provides a full list of file types you can add. There are many ways to add
new items in Scrivener, refer to Adding New Items (subsection 6.3.1) for
further detail, and for importing existing material into the project, File
Import (section 9.1).

Trash Moves the selected items to the Trash folder (subsection 6.2.3). Also avail-
able as the command, Documents ▸Move to Trash (⌘Delete).

Insert This multifunction button is only available when working within a text
editor. It provides for the insertion of images, inspector comments and
footnotes, links and tables into text.

Footnotes, Comments and Tables can be added as separate buttons, and
otherwise all insertion commands (andmuchmore) are located within the
Insertmenu, as well as a number being available from the Touch Bar.

Quick Ref Opens the selected items, or the currently edited text, into separate
windows, called “QuickReference panels”. You can also drag any icon from
the projectwindowor search panels onto this button to load the associated
item in a window. Also available for the currently selected item or active
text editor as Navigate ▸Open ▸asQuick Reference.
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Figure 4.3 Default toolbar (middle): quick search and view modes.

Within the middle group of icons are the following features:

Quick Search Similar to the URL bar in a web browser, this tool displays the
name of the document you are currently working on within the editor,
and clicking into the tool lets you type the name of the thing you’d like to
jump to next. Beyond that, this tool has a few functions worth reading up
on if you wish to make more of it (section 11.5).

For keyboard users, move the cursor into this tool with the keyboard
shortcut, ⌃⌥G. You can also use Quick Search without a toolbar (subsec-
tion 11.5.4).

ViewMode These three buttons toggle between the various viewmodes the ed-
itor makes use of. The group view mode can also be disabled to reveal
the standard single-document editor, by clicking on the active button. If
you’ve never looked into viewmodes before, we’ll go over those below (sec-
tion 4.2). From left to right, the buttons are:

— Document/Scrivenings (⌘1)

— Corkboard (⌘2)

— Outline (⌘3)

Figure 4.4 Default toolbar (right): compile, bookmarks, composition mode
and inspector toggle.

Last but not least, let’s take a look at the third and rightmost group of buttons
(Figure 4.4):

Compile How you will export your work to a particular format, like a Word
file, PDF, Markdown or an ePub. If you’re ready to compile, you’ll want
to head on over to the section on Compiling the Draft (chapter 23), other-
wise, there is much to learn before then—and most likely much more to
write!

Bookmarks Lists your “project bookmarks”; frequently used documents from
your binder, the Internet or your computer. Click the button to load the
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bookmark list, and drag things into the list to store them. You can also
drag things directly onto the icon itself to store them at the bottom of the
bookmark list automatically.

While the panel is open, you can tear it off by clicking and dragging any-
where along the panel border. This can be handy if you’re using the list a
lot andwish to leave it visible above your project for a while. This system is
very flexible and augments a number of other features in Scrivener. Read
more about Project and Document Bookmarks (section 10.3) to find out
more.

Compose Opens the Composition Mode writing view, which blots out the en-
tire interface, making it easier to concentrate solely upon your words.
Click this to load the current editor or selected items into composition
mode (section 16.1).

Inspector Toggles the visibility of the inspector sidebar (chapter 13) on the right
side of the project window. This can also be done with the⌥⌘ I shortcut.

4.1.2 Basic Concepts
Before we take a look at the three main interface components within the
project—the binder, editor area and inspector—it would beworthwhile to spend
a moment examining how these three elements interact with one another.

Left to Right Navigation
The rules are very simple, and should work in a manner you may find familiar
from other programs:

— A panel or sidebar works with what has been done to the immediate left
of that panel:

— If you click on a folder in the binder, it is loaded in the main editor to its
right.

— If you click on an index card within the corkboard that is loaded in the
editor, that index card is examined by the inspector to its right.

— This never works in reverse: if you navigate into a folder using just the
editor to do so, the binder to the left will not change its configuration to
follow suit—but our changing perspectivewithin the editorwill impact the
inspector.

— Navigation never skips over sections. If you click on a folder in the binder,
that doesn’t necessarily mean that the inspector will examine that folder,
because it doesn’t pay attention to the binder. All the inspector cares about
is the editor to its immediate left. That corkboard we loaded using the
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binder might already have an index card selected within it—and that is
what we’ll be inspecting.

We may also end up inspecting the folder we clicked on in the binder,
but it’s important to consider that it’s not because we clicked on it in the
binder, but because when no index cards are selected in the editor, the im-
plied selection is the folder we clicked on, or what you can see in the editor
header bar.

Selection & Focus
Selection, and the areas of the project window with “focus” (when the cursor
is in a particular area of the window), are often important in Scrivener. There
are many features that only work from within certain contexts. A good example
of this is the Edit ▸Transformations ▸Make Uppercase menu command. It has no
meaning when a selection of index cards is currently active, as it works upon
selected text. If there is a selection restriction on a feature, thismanual will often
indicate as such using the following terminology:

— Active: this relates to “focus”, or where the application is currently accept-
ing keyboard input. In other words, if you tapped the ‘h’ key, that is where
the ‘h’ would be sent. In some cases this might not do much or anything
at all, but in an active editor it would insert an ‘h’ letter.

— Active selection: expanding on the above, an active selection is when some-
thing is selectedwithin the active area of the application. An examplemight
be some selected text in the editor, or three selected items in the binder
or corkboard. Active selections are often used as the target for various
commands in themenus. An example would beDocuments ▸Convert ▸Text
to Default Formatting…, which resets text formatting for the three selected
corkboard items. On the other hand that same command will reformat
the contents of the editor window if the editor has focus.

— Inactive selection: if you select a folder in your binder and then click in the
editor, the selection will become dimmer. Inactive selections are seldom
used, but there are a few cases: when exporting, andwhen dropping things
onto an inactive selection—such as assigning a keyword by dragging and
dropping it onto several dozen selected items in the background.

— Active editor: for cases where the interface is split, this not only means any
editor must be selected, but specifically the editor you wish to perform
the function on. Some commands do not require text to be selected, only
an editor to be active, others will perform universal actions if no text is
selected, still others will refuse to work unless you have a selection.

— Item Selection: or “selected items”, refers to the selection of documents (or
“items”, more generally) in the binder sidebar, corkboard or outline views
in the editor. Item selections are often used in conjunction with com-
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mands such as those found in the Documents menu, like “Move To”, that
moves a group of selected items to another place in the project.

4.1.3 The Binder
The large sidebar on the left-hand side of the project window is what we call the
Binder. As in many programs featuring a sidebar, it’s the first place to go when
you want to change what you’re looking at in the main viewing or editing areas
to the right.
In Scrivener, we call it a binder because it acts as a metaphorical ring-binder,

providing amaster list of all the items you’reworkingwith in a particular project,
from your working draft on down to research and notes. You can create as many
folders and files as you wish in the binder, import research files into it, and or-
ganise them all together in a completely freeform manner.
The binder always comes with three special folders:

1. Draft: it’s almost best to think of this one as a document, as all of the pieces
of text and folders you group those pieces intowill be sewn up into a single
file when you export it—or what we refer to as “compiling”. This is where
you write!

This folder will sometimes be referred to by other names in some of the
built-in templates. If you cannot find a folder called “Draft”, look for the
special icon as seen in Figure 4.5.

2. Research: although you can put research files everywhere except for in the
draft folder, this dedicated folder is always available for your convenience.

3. Trash: as you might expect, this is where deleted stuff goes. It works just
like the Trash in Finder in that it holds the things you delete until you
empty it.

Figure 4.5 Collection tab list at the top of the binder sidebar, currently show-
ing the main binder.
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In addition to the binder list itself, this sidebar area is also host to search re-
sults when trawling the entire project, saved search results and curated lists of
items—the latter two of which we refer to as “Collections”. These will be neatly
organised into a tab list (Figure 4.5), which can be revealed with the View button
in the toolbar, or the View ▸ShowCollectionsmenu command. You can also easily
navigate from one to another with the Navigate ▸Collections ▸ submenu. When
the tab list is hidden, you can return to the binder at any time by clicking the×
button, marked as (a) in Figure 10.4.
Given how these different lists interact with the project window in a similar

fashion, we’ll sometimes refer to this sidebar as being the “binder sidebar”, as
a way of referring to all of the various features available from this left sidebar.
If you come across instructions stating that the binder sidebar selection will be
used for a particular feature, this nearly always means the selection can be made
within a search result or a collection too, not just the binder.
Given its central position in the project, both as interface and as a data struc-

ture, we couldn’t possibly go over everything about the binder right here. If
you’re interested in reading more about it, I’d recommend the following topics:

See Also…
— The Binder & its Outline (chapter 6).

— Project Navigation (chapter 12).

— Using Collections (section 10.2).

— Project Search (section 11.1).

4.1.4 Editor
The main editor occupies the large space to the right of the binder, and will be
your main working area for all manner of tasks. It automatically loads what you
click on in the binder. Not only is it where youwill be doingmost of yourwriting,
but it also has the ability to display groups of selected items in various useful
fashions—which we will be getting into shortly—and is a capable multimedia,
PDF and web archive viewer, too. The editor will take on different appearances
and functions depending onwhat sort of document you are displaying andwhich
group view mode you are in.
At the top of the editor is a header bar that contains the name of the document

or thing you are currently viewing, alongwith someuseful buttons for navigation
between documents, the history of things you’ve viewed, and so forth. You’ll
want to brief yourself on the header bar (subsection 8.1.1) at some point, as a
familiarity with its capabilities will greatly enhance your ability to use the editor.
Below each editor pane is a Footer Bar. This will change depending on the

type of document visible and the current editor mode. The details of its usage
can be found in the section on the footer bar (subsection 8.1.2).
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Figure 4.6 The editor, split into two paneswith two copyholders, demonstrat-
ing its flexibility and multitasking uses.

See Also…
— View Modes (section 4.2): the editor is also host to “group views”, such

as the corkboard. Visit this topic for further information on the various
group and text view modes available and how to make use of them.

— The Editor & its Views (chapter 8): the editor itself, as one of the central
components of the project window, is discussed in depth in this chapter,
along with everything you need to know about the corkboard, outliner,
splits and copyholders.

— Writing and Editing (chapter 15): if you’re mainly looking for help on text
editing itself, visit this topic for a start, but the entire third part of this
manual is devoted towhat is, as youmight expect, the biggest part of using
Scrivener.

— Writing Environments (chapter 16): covers different editor writing modes
that can be used to change how text is presented, such as Composition
Mode for focusing on the text alone, or Page View for simulating a text-
on-paper look that is common in word processors.

— Viewing Media in the Editor (subsection 8.1.3): for details on how various
read-only media are displayed in the editor.

31



4.1. The Project Window

Splitting the Editor
A signature feature of Scrivener is the ability to split the editor into two panes.
This can be used to work in two different areas of a longer document at once,
or to load other documents, folders, media or whatever you need into a second
reference split. In this way you can review older revisions in split view, research
material or whatever else you require while writing.
To split the editor (or close the other split), use the button on the far right

of the header bar, or the commands in the View ▸Editor Layout ▸ submenu. Read
more about splitting the editor (subsection 8.1.4).

Format Bar
The Format Bar stretches right across the top of the editor (both of them if
the view is split), below the main toolbar, and provides quick access to com-
monly used text formatting tools. It can be hidden when not needed with the
View ▸Text Editing ▸Hide Format Bar menu command (⇧⌘R). For more informa-
tion, read about the format bar (subsection 15.7.2).

Copyholders
In addition to the twomain splits, you can also pin a document to either (or both,
for a total of four panes) of the editor splits in what we call a “copyholder”; like
the thing you’d clip to the side of your computermonitor to hold a sheet of paper.
Copyholders are not full split editors, and are thus only capable of displaying the
media itself or the text content of an item—as depicted in Figure 4.6. Want to
check it out quickly?

Figure 4.7 The copyholder header bar where you can (a) detach and (b) close
the view.

1. Try using theNavigate ▸Open ▸ inCopyholdermenu command to clip the file
you’re looking at to the current split. Now you can navigate elsewhere and
keep tabs on where you were. You can also drag any document icon into
the header bar with the Opt key held down to open it as a copyholder.

2. Detach a copyholder from the project window by clicking the button
marked (a) in Figure 4.7. This, by the way, is a Quick Reference panel (sec-
tion 12.6).

3. Close the copyholder when you’re done with the× button, marked (b).

Read more about using copyholders (subsection 8.1.5).

32



4.1. The Project Window

4.1.5 The Inspector
The Inspector is the lastmajor component in our overview of the interface. Typ-
ically hidden from view in new projects, it will always be on the right side of the
project window when made visible. Its purpose is to display all metadata and
auxiliary information associated with the document shown in the active editor
pane, or if the editor is showing a group view, the selected itemwithin that pane.
To show or hide the pane, click the blue “i” button in the toolbar (Figure 4.4),

or use the ⌥⌘ I shortcut.
The inspector has five different tabs, accessed via buttons along the very top

of the Inspector (Figure 13.2). Click on a tab button to select it and show its
associated pane. Here are a few tabs you might find useful from the very start:

— Synopsis & Notes: the first tab, shaped like a notepad, contains the “index
card” (subsection 8.2.1) that will represent this item when displayed on a
corkboard. Below the card is an area where you can jot down notes per-
taining to the item itself. Readmore about these inDocumentNotes (sub-
section 13.3.2).

— Bookmarks: the second tab from the left contains listings for both project
and document bookmarks (section 10.3). Switch between the two by click-
ing on the header, or by pressing⌘6. Below the list is a preview and editing
area. You’ll always have key documents on hand with this tool!

— Footnotes & Comments: skipping over a couple, the last tab in the list,
shaped like a speech balloon, will list any linked footnotes and comments
(section 18.3) found within the displayed editor text. If you’re writing non-
fiction or doing a lot of editing, this tab will be essential.

Finally, at the very bottom of the inspector you’ll find access to the “Label” and
“Status” fields. Use these to easily tag documents with colour or text (and use the
“Edit…” selection at the bottom of these popup menus to configure them).
For more information on the inspector in general and an in-depth look into

each of the individual tabs, refer to the chapter on the inspector (chapter 13).

4.1.6 BlockingOut Distractions
With all of this interface going on (never mind the Internet in the background!),
it may at times be nice to blot out everything and focus on the words alone.

CompositionMode
Composition mode is a way of editing text that will hide not only the rest of
Scrivener, but the rest of your computer as well, allowing you to concentrate
fully on the production of text. It only works for documents and folders, and
while it provides access to the system menus, Quick Reference panels and the
inspector, its default state is to simply display the text you are working on in a
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“page” in the middle of your screen. To enter composition mode, click into the
editor you wish to focus on and use one of the following methods:

— Click the Composition Mode toolbar button (Figure 16.2).

— Use the View ▸Enter CompositionModemenu command (⌥⌘F).

— Get back to the main interface with the Esc key.

Once there, slide the mouse to the bottom of the screen to access display and
navigation functions, and to the top of the screen to access the main application
menus (some commands will be disabled if they call upon functions not appli-
cable to this view mode). Read more about Composition Mode (section 16.1).

FocusMode
There are times where even our own words can get in the way! The idea behind
Focus mode is to fade out text that you aren’t currently working on. You can
choose to have the current line, sentence or paragraph focused in this manner.
Read more about Focus Mode (section 16.4).

Full ScreenMode
Full screen mode, as provided by macOS, pushes the Dock and main system
menubar off-screen, providing themaximumamount of screen space to thewin-
dow you’ve moved to full screen. This action also puts the software in its own
segregated virtual desktop or “Space”, which cannot host windows from other
programs (that includes Dictionary.app), or have even Scrivener’s own windows
(like preexisting Quick Reference panels) moved into it. New windows that you
open while working in full screen will remain in that view, but existing win-
dows will not, and cannot be moved afterwards without closing them and then
re-opening them.
To enter Full Screen mode use one of the following methods:

— Click the green “traffic light” button along the top left of the window, as
in most Mac applications.

— Use the View ▸Enter Full Screenmenu command (⌃⌘F).

— From Mission Control, drag the project window to a new Space, or com-
bine Scrivener with an existing full screen application to split the Space
with another program.

Slide-out Sidebars

When hidden for whatever reason, the binder and inspector sidebars will be-
come sliding panels that appear whenmoving the mouse to the respective edges
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of the screen, or if you use any of the keyboard shortcuts that might other-
wise reveal these sidebars as part of their function. For example, pressing ⌥⌘R
(Navigate ▸Reveal in Binder, to display the item you are viewing in the editor) in
full screen mode will cause the binder to slide out, showing you the file you are
revealing. When used in this fashion, the binder will slide back out of view after
a short delay, unless you place the mouse over the panel.
If you click into either sidebar,moving focus to that pane, then itwill stay open

until you click somewhere outside of it, or use a keyboard shortcut to move the
focus to another pane.

Hiding Sidebars Automatically

On smaller screens, or even as a general preference, you might want to
dismiss the binder or inspector sidebars automatically to maximise the
amount of space provided to the editor(s) or to better focus on content.
TheHide binder and inspector when entering full screenmode option,
found in the Appearance: Full Screen Setting tab will do this for you.

This behaviour cannot be disabled, but you can cause the binder or inspector
sidebar to remain fixed on the screen, as it normally would be within the project
window, by using the typical methods to toggle the visibility of these sidebars:

— For the binder: View ▸Show Binder (⌥⌘B), or the View button on the tool-
bar.

— For the inspector: View ▸Show Inspector (⌥⌘ I), or the Inspector button on
the toolbar.

Full Screen & Layouts

Saved layouts (which will discuss in the following section) will remember if they
have been configured while in full screen mode. Switching to a layout that has
been marked with a full screen icon beside it will enter full screen as well as
rearrange the window. If you do not wish for a layout to transition the window
to full screen, you can hold down the Option key when selecting the layout for
use.
If no layout has been selected as a full screen default, then the current window

settings will merely be expanded until the project window fills the screen.

4.1.7 SavingWindowSettings
Now thatwe’ve gone over the basic capabilities of the project window, youmight
be wondering whether something as flexible as this can have its configuration
saved for future use. Of course, yes you can. We provide a few simple layout
examples out of the box that you can experiment with, but eventually you’re
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probably going to want to learn how to save your settings so you can get them
back. Refer to Saved Layouts (section 12.3) for the details.

Return to chapter ⤴

4.2 ViewModes
Now that we’ve gone over the principal elements of the project window, as well
as how to save arrangements of these elements into layouts, let’s take a look at
what themain editor view provides. Scrivener’s editor is more than a typical text
editor, but also an organisational tool and research viewer. Where the binder
gives us the forest as an overview of the project’s contents, the editor with its
larger viewing area, can godown into the trees, andmakeuse of visualmetaphors
(such as a corkboard) that wouldn’t fit neatly in the binder area.

Figure 4.8 The Corkboard, Outliner and Scrivenings views, all showing the
same folder in their own unique ways.
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How items are visualised together is what we refer to as a “group view mode”.
There are three such group view modes available in Scrivener, each tailored to
different tasks and preferences:

— Corkboard: depicts each document you are viewing as an index card, with
a place to type in the title and an area below to describe or summarise the
contents of that item; what we call the synopsis.

— Outliner: using a similarmetaphor as the binder, it displays yourwork as a
nested list. You can add columns to track all manner of details, fromword
counts to modification dates to columns you can even make up yourself.
Maybe you’d like to track fromwhich city a particular section of notes was
drafted on a long trip, for example. Think of it as a cross between the
binder and a spreadsheet, and you’ll be on the right track.

— Scrivenings: provides way of viewing and editing many different pieces of
text from your binder, all at once. On the right hand side of Figure 4.8 we
can see each chunk of text separated by a divider, and an optional heading,
taken from the index card title.

4.2.1 HowViewModes are Selected
View modes are automatically used when the editor is asked to view more than
one document at a time, for any reason at all. This can happen if you ⌘Click on
more than one binder item or when merely clicking on a folder.
Changing your preferred view mode is as simple as switching to the one you

want; there are no settings you have to change; the program adapts to how you
work and continues working that way until you change the mode to something
else.

How does this work with splits?

If you’ve been reading along, you’ve probably already encountered the
concept of splitting the editor so that you can be doing two things at
once. The preferred viewmode is per split, meaning you can dedicate one
side of your project window to working with a corkboard and another
side to working with the text alone in Scrivenings mode—or any other
combination that suits you.

4.2.2 ViewModes, Files and Folders
We’re going to get a little esoteric here, but given it’s the sort of thing you might
run into accidentally, we might as well get one fundamental concept about files
and folders out of the way: in Scrivener, both file or folder items can contain
text and children. This is why we tend to prefer generic terms like “items” and
“containers”, and will even sometimes include folders under the umbrella term,
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“documents”—because in Scrivener they are all very nearly the same thing in
different clothes (or icons, literally).
The implication: when viewing a folder you can turn off the current view

mode to read or add text to it as a file, which might very well be an empty text
editor at first. Likewise for files you are allowed to select a view mode manually,
which would present you with an empty corkboard or outliner at first.
There’s more to it than that, but for now, just be aware that if you click on

something and it comes up blank when you expect there to be cards (or text),
the first thing to check is the ViewMode indicator in the toolbar. If you wish to
read more about what can be done with these capabilities, refer to Folders are
Files are Folders (section 7.3).
That is a lot of theory to hold in mind, so let’s get on with how these things

are actually used.

4.2.3 TheGroupMode Toolbar Button
As we’ve discussed, the group view mode control in the main toolbar is three-
way toggle button (Figure 4.9). The individual buttonswithin it are: Scrivenings,
Corkboard and Outliner, respectively.
Depicted is the control when a group of items or a container has been selected.

When a single item has been selected, the label will change to “ViewMode”, and
the icon on the far left will depict a single page, representing “document mode”
(which isn’t a view mode by definition, but rather what we get when not using a
view mode).

Figure 4.9 Segmented control in groupmodewith Scriveningsmode selected.

This set of buttons displays the preferred view mode with a shaded back-
ground. That means the active editor will always use that method to display
groups of content until you change it again while viewing a group. Here’s how
to use it:

— Click on any of the icons in the control to switch to that view type. The
view for the active editor will immediately change, and simultaneously set
your preferred group view mode for the editor.

— Click the shaded, or active, view mode to disable group view and see the
text of the container that you are viewing. None of the icons will be shaded
in this state.

All three buttons can be accessed from the top of the View menu as well, or
by using the associated shortcut keys. These work in the same fashion as the
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toolbar, where invoking View ▸Corkboard while you are already viewing an item
as a corkboard will switch that view mode off and drop to single text mode.

Bringing it All Together

Take a moment to play around with the view mode buttons in the tool-
bar, or their corresponding shortcut keys, to see howyou can get themost
out of Scrivener’s unique file and folder structure. As you become com-
fortable with toggling view modes, you might find you use a variety of
them even as you work with one section of text. For example I like to use
a combination of Scrivenings mode and outliner, where the former lets
me work on the section of text, and the latter lets me work with and see
the overall structure of that text. I can select an item in the outliner and
switch back to Scrivenings mode to jump straight to that chunk of text
and start working on it.

4.2.4 Corkboard
Scrivener has made the corkboard metaphor popular in modern writing soft-
ware. The concept of representing ideas or segments of writing as index cards
and arranging them to represent the structure a book is useful enough that writ-
ers have been doing similar with real corkboards for decades. Let us take a look
at what the digital version can do for you.
The important thing to realise with the corkboard is that each of the displayed

index cards represents a file or folder in your binder outline. They display the
title and the synopsis (a short description of the item), and optionally can rep-
resent a few kinds of metadata as well (such as the “To Do” status shown in the
figure on the first card). Just remember, cards are documents, and conversely
documents can all be viewed as cards.
It then follows that the card represents the chunk of text from its associated

file, and that the order in which we see the cards listed indicates how the un-
derlying text will read. Dragging and dropping a card moves not only the card,
but the associated text in relation to those chunks of text around it—much like
cutting and pasting that same chunk of text to a different area of themanuscript
would, only without all of the mess.

Upgrading from Scrivener 2

Looking for the traditional corkboard background texture? In order to
keep up with modern trends, Scrivener now uses a pale “cork” colour in-
stead of a real-world texture, but if you prefer the old school look, you’ll
find it tucked away in theCorkboard background setting in the Appear-
ance: Corkboard: Colors tab.
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Figure 4.10 Corkboard view: the cards are titled at the top, with short descrip-
tions written for the first two.

Scrivener takes the basic index card concept a little further than just showing
your files as a grid of cards. There are two secondary corkboard modes that pro-
vide additional visualisation tools for different purposes. Both of these tools act
as a sort of preference, meaning that when you view that particular folder as a
corkboard in the future, it will automatically prefer one of these modes:

— Freeform (subsection 8.2.4): you are not constrained to viewing index
cards in columns and rows; you can use freeform mode to move cards
around as freely as youmight on a desk or real corkboard. Youmight group
together cards that are related, but scattered throughout your draft, spread
things out in a chronological order, move cards from one column to an-
other as they go through various stages of revision… the choice is yours.

— Label View (subsection 8.2.5): focusing on Scrivener’s “label” metadata
(subsection 10.4.3), that lets you associate a colour with your cards, this
corkboard mode displays cards in “rails”, one for each label. You can drag
cards from one rail to another to set their label assignment. It’s a bit like
the technique putting coloured tape on a corkboard and attaching cards
to them according to their plot device, character PoV, or whatever you use
labels for.
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Figure 4.11 The corkboard footer bar.

The editor footer bar, along the bottom of the view, has a few buttons for con-
trolling corkboard appearance (Figure 4.11):

a) Standard & Freeform toggle: click the left or right side of this control to
select between these two modes, respectively.

b) Arrange by Label view: when active, this option will be lit up in blue Click
it again to disable the mode. (The Standard & Freeform toggle will be re-
placed with an orientation toggle when using this mode.)

c) Corkboard options: change appearance and layout options of the index
cards by clicking on this button.

When selectingmore than one group at a time corkboards will be displayed in
a “stack”. You can work with cards from multiple sections of your work at once
in this way.
If all of this sounds terribly useful to you, it may be a good time to head over

to the full section documenting the corkboard (section 8.2).

4.2.5 Outliner
What the binder presents as a simple nested list of items, the outliner expands
uponby showing additional information and giving youmore space toworkwith
titles. Since the outliner provides feedback for so much metadata, it is a handy
place for easilymaking and viewing bulk changes to your documents. Many peo-
ple like to brainstorm in the outliner view aswell, as it showsmore than one level
of depth at once, whereas the corkboard is designed to focus onone level of depth
at a time.
By default, each row in the outlinewill consist of a title in bold text followed by

the synopsis summary text below in a lighter shade, or a bit of the text content for
the file, if provided. What was shown as a “stamp” across the face of the first card
in the corkboard example is displayed here in a separate column (Figure 4.12).

— Whether synopses are visible can be toggled with the button on the right-
hand side of the footer bar, or with the Touch Bar on compatible systems.

— Columns can be added or removed by right-clicking in the column header
bar area, clicking on the › button on the right-hand side of the header, or
by using the View ▸Outliner Options ▸ submenu.

As with the corkboard, there are many features and uses for the outliner (sec-
tion 8.3).
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Figure 4.12 Outline view: showing the same information as the corkboard
view before (Figure 4.10), plus some word count progress.

4.2.6 Scrivenings

Figure 4.13 Scriveningsmode: showing the text content of our example folder.

The last of the three viewmodes is unique in that it displays the group of items
as a long text document, one file after the other. It is thus only available to se-
lections of more than one text document (or folder)—images and other forms
of media will be ignored by the tool. All of the text content (even empty docu-
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ments) will be stacked together as if on a long spool of paper, letting you read
through as large a section of text as you want.
As you write and edit text in this view, each of the corresponding documents

will be updated as you work, behind the scenes. The overall effect is as if you
were working in a single long document, but in fact you are editing potentially
many sections of the binder at once.
Scrivenings (frequently referred to as a “Scrivenings session”) are fully auto-

matic. You don’t need to worry about saving them, or what will happen if you
click on something and they go away. It is merely a way of pulling together a
number of files so you can edit their text at once, and then releasing them when
you move on.
You can quickly navigate within a long session of text by clicking on the “Nav-

igate through Scrivenings” button, located in the right-hand side group of but-
tons in the editor header bar, and marked as (a) in Figure 4.13. This will reveal
a table of contents for the current Scrivenings session. Click on the section you
wish to edit, then anywhere else to dismiss the contents.
For more information on how to best take advantage of this editing mode, see

Editing Multiple Documents with Scrivenings (section 15.5).

Return to chapter ⤴

4.3 DarkMode

Figure 4.14 Scrivener project window in light and dark appearance.

⟨macOS 10.14+⟩ On systems running macOS “Mojave” and greater, Scrivener
offers a full DarkMode experience. Likemost software, it will select an appropri-
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ate lookdepending on your choice ofDark or LightMode, in the SystemSettings:
Appearance pane.1

To achieve two fundamentally different appearances, most of the colour set-
tings in the Appearance settings pane now store Dark and Light mode colours
separately. While you are in Dark Mode, changing the background colour for
the main binder sidebar will have no impact on how the binder looks in Light
Mode, to give one example. Saving colour sets as Themes (subsection B.1.1) now
saves those themes according to the light mode they were saved under. And
just as with Light Mode, nearly every aspect of the Dark Mode interface can be
changed.

Going Against the Flow

In keeping with Scrivener’s philosophy of giving you a flexible working
environment, you can override your system settings to display Scrivener
in Dark or Light Mode at all times, with the Scrivener ▸Appearance ▸ sub-
menu.

4.3.1 HowColourWorks in the Editors
When in Dark Mode, Scrivener will automatically filter the colours you make
use of in the main text editors, with the goal of keeping text within a range that
remains easy to read on a dark background. When you use any tool for setting
colour in the editor, your choice will set how that colour appears when using
Light Mode—or what some may refer to as the “true” colour, since that is what
youwill getwhen you print—notDarkMode. If you intend to primarily useDark
Mode and have no interest in what an inline annotation looks like when printed,
then you may be happier changing how colour is handled in the editor.

Figure 4.15 From left to right: natural lighting, filtered for dark backgrounds,
direct colour pass-thru and lastly, full monochromatic override.

Colour handling can be adjusted in the Appearance: Main Editor: Colors set-

1Onolder versions ofmacOS themenu commandwill be printed as “Preferences”, and references
to System Settings (“System Preferences”) locations may no longer be accurate.
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tings pane (section B.5.8), with the Text setting.2 Beneath the colour swatch
where the text override is set, you can choose from three modes (Figure 4.15):

— Desaturate custom colors: the default setting, and demonstrated in the top-
right sample. This provides you with an overall sense of how you use
colour in Light Mode, without causing bad interactions between colours
that are difficult to read. Filtering impacts alluse of colour in the editor, in-
cluding those coming from inline annotations, inspector comments, style
backgrounds and so forth.

— Show colored text as-is: in the lower left sample, is for those that intend
to work exclusively in dark mode. The setting gives you direct control
when changing colours in the editor, rather than having your choice fil-
tered, based on how it will look in a different appearance mode.

— Override all colors: in the lower right sample, this cuts on screen visual
noise to a minimum by removing all colour from the editor. Colour will
be indicated by varying shades of lightness and darkness alone.

4.3.2 Keeping Text Editing Light
The first time you open a project in Dark Mode, you will be asked whether you
prefer dark or light editors in themain projectwindow. This settingwill only im-
pact the two main text editor splits, and their respective copyholders. All other
areas capable of displaying text, such as Quick Reference panels and various in-
spector panes, will remain dark.
Whether you prefer to keep the editors light so that you can view the original

design of the text as it will print, or merely as a preference, you are not stuck
with your initial choice. At any time you can toggle editor lightness with the
Scrivener ▸Appearance ▸KeepMain Editors Light (⇧⌥⌘L) command.
When editors are operating in LightMode (as shown in Figure 4.16), all of their

Appearance settings will be taken from the way the software appears in Light
Mode. As a convenience, a select portion of these settings will be made available
to you in the Appearance: Light Editors settings pane (subsection B.5.17), so you
needn’t switch back to Light Mode merely to tweak the background colour of
your editor slightly.

Return to chapter ⤴

2 These options are also available to the Composition Mode portion of the Appearance settings
pane.
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Figure 4.16 Retaining natural colouring in the main editors can be useful for
some workflows.

4.4 Keyboard & Trackpad
Now thatwe’ve coveredmost of what you’ll encounter on the screen, let’s turn to
a part of the interfacewe don’t often think asmuch about: what goes on beneath
our fingertips. If you’re using a regular old keyboard andmouse, then chances are
Scrivener won’t be throwing any surprises at you—though in general it might be
good to know thatweput a lot of effort intomaking Scrivener a keyboard friendly
program. It comes packed with hundreds of shortcuts out of the box, and is
designed so that you can move throughout the entire project window interface
without even lifting your fingers off of the keyboard. If that’s not your thing, no
worries, we put a lot of effort into make the mouse useful, too!
Beyond that, there are a few special pieces of hardware that Apple provides

with some models of the Mac, and we do our best to support these where we
can.

4.4.1 TrackpadGestures
Scrivener supports two of Apple’s built-in gestures, if you have the hardware to
support them and default System Settings:

Force Touch A force click on anywordwill bring upApple’s “LookUp” interface,
including quick access to dictionary definitions.

Pinch Zoom When viewing PDFs or images, you can use the pinch zoom gesture
to adjust the magnification of editor for that particular document.
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4.4.2 Touch Bar
Whenusing Apple’s TouchBar hardware, Scrivenerwill provide a number of use-
ful functions depending on what you are currently doing within the software, or
what we will refer to here as “contexts”.
Some buttons will be available in all contexts, and can be thought of as being

global in that sense. Depending on what you are doing with the software, you
mayfindmore specific buttons listed per context that provide access to functions
that onlymake sense within that area of the software, like the Style button in the
text editor. If youwant a quick “cheat sheet” onwhat the buttons are called, sim-
ply use the View ▸Customize Touch Bar… command to look up the button labels.
The Touch Bar for Scrivener is customisable both at the global and contextual

level. Global buttons can be addedor removed fromany viewwithin the software
that supports special touch bar features, and the changesmade to global buttons
will—you guessed it—be global.
To modify how the Touch Bar works for one area of the interface, such as the

binder, first click into that area of the window to activate the bar and then use
the View ▸Customize Touch Bar… menu command. This will open the standard
interface for dragging buttons in and out of the Touch Bar; if you require fur-
ther instructions on how to do so, please consult Apple’s documentation on the
matter.

Global Buttons
Adding or removing these buttons from any context will impact all contexts col-
lectively.

Figure 4.17 Global buttons: Layout, Project Search and Add.

— Layout: quick access to toggling the visibility of the binder, collection list
and inspector. This feature also has a three-way control for changing how
the editor views should be split (Figure 4.19).

— Project Search: moves the cursor to the project search field above the
binder, or if applicable, cancels the current search and closes the search
result list.

— Add: located on the far right by default, this button provides a convenient
way to add new items to your binder, or the view you are currentlyworking
within (Figure 4.18). After generic files and folders, any available document
template files from the project will be listed, followed by found shared doc-
ument templates. Refer to Document Templates (section 7.5) for more in-
formation on these features.
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Figure 4.18 Add Buttons: files, folders and example project and shared tem-
plates.

Figure 4.19 Layout options: Binder, Collection List, Split Horizontal, Vertical,
None and Inspector.

Lose a Button?
Given how some buttons are shown in all contexts, if you add too many
additional buttons to the Touch Bar, you might run into cases where
there was no space left to show all of the buttons you requested. In this
case, the software will have no resort but to remove a button or two for
you.

Binder Sidebar
The binder, along with the other various views that can occupy the left sidebar,
have a few special buttons available. The binder button set itself cannot be cus-
tomised, though additional global buttons can be addedwhile using this context.

Figure 4.20 Binder: Collections, Labels, Status and Search Result Sorting.

— Collections: quickly select between the different available binder views.
By default this will consist of the binder itself and the most recent search
results you’ve gathered, but it will include any collection lists you add to
the project too; colour-coded, naturally!

— Labels: brings up a list of available labels in the project for assignment to
all selected items in the sidebar. Displays the colour of the currently active
label colour, or a dotted circle (as shown) when none is applied.

— Status: aswith the label button, used to set the status indicator for selected
binder items.

— Icon: select a custom icon for the currently selected items, or tap “Default”
to set them back to the default binder icons.

— Sort: the final button only appears when viewing a search result or search
collection list in the sidebar. Youmay sort the list by binder order (default),
the titles of items or their creation dates, and invert the current sort order.
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Corkboard Buttons
This bar also has the Icon, Labels and Status buttons available to it.

Corkboard: Selection Affects, Open,
Corkboard Layout

— Selection Affects: causes the active selection in this group view to be au-
tomatically opened in the opposing split view or attached copyholder (just
like how the binder works). If you have both a copyholder and a split
view then this button will rotate between targeting the two options and
no auto-load. Refer to Linking Splits Together (subsection 12.2.5) for fur-
ther information.

— Open: simply opens the selected documents within the current editor
view, in the same fashion that using the ⌥⌘O shortcut would do.

— Corkboard Layout: the choices presented behind this button will depend
upon the state the corkboard is in, and correlate with the options that are
provided in a similar control found in the footer bar beneath the corkboard
on the right-hand side. The Arrange by Label (subsection 8.2.5) button is
available in all corkboard contexts.

– Freeform and standard corkboard views simply provide the ability to
toggle between these two types, with the currently activemode being
the highlighted button. (Figure 4.21)

– When viewing a stack of corkboards, a selection of groups, there will
be three layout options provided as described in Stacked Corkboards
(subsection 8.2.8): Grid, Horizontal and Vertical stacking.

– In Label View, the choices will be between default horizontal align-
ment and vertical (Figure 4.22).

Figure 4.21 Corkboard Layout: Standard, Freeform and Label View toggles.

Figure 4.22 Corkboard Orientation: Grid, Horizontal and Vertical.

Outliner Buttons
This bar also has the Icon, Labels and Status buttons from the binder view, as
well as the Open and Select Affects buttons from the corkboard view, above.
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The outliner bar otherwise only contains one unique button, theHide|Show
Synopsis toggle. This button correlates with the option found in the footer bar
of the outliner and simply toggles whether or not synopses will be displayed be-
neath the title line (subsection 8.3.5).

Text Editing Buttons
As you might expect, the text editing areas of Scrivener are where most of the
Touch Bar buttons dwell. Additionally, you will be provided with five separately
configurable bars for different areas of the software:

1. Document notes in the inspector.

2. Comments and footnotes in the inspector.

3. When editing the contents of a table in the main editors.

4. Editing rich text in the scratchpad.

5. And finally of course the main text content itself, which can be accessed
through the main editors, the bookmarks inspector pane, quick reference
panels and copyholders.

We will first look over the default set provided to themain content text (other
areas start simpler and may provide a limited set of buttons depending on what
features they support), and then go over the optional buttons that you can swap
in or add as you wish.

Figure 4.23 Editor Defaults: Styles/Scriptwriting, Highlighter, Lists, Quick
Reference

— Styles/Scriptwriting: the first button will use one of two modes, depend-
ing on whether the editor is currently in scriptwriting or standard editing
mode.

– Scriptwriting: a list of scriptwriting elements available in the project
settings will be displayed when tapping the button.

– Standard: a list of project styles will be displayed instead.

In both cases, the current element/style under the cursor will be printed
in the button. For styles this can include compound declarations, such as
“Block Quote+Emphasis”, for emphasised text within a block quote.

Both scriptwriting elements and styles (whichever is currently applicable)
can also be accessed with the ⇧⌘Y shortcut.

50



4.4. Keyboard & Trackpad

— Highlight: quickly highlight text with a chosen colour from the colour
chooser bar that will appear when tapping on this button. The current
highlight colour will be selected in this bar. You can strip out highlights by
tapping on the first button (below).

Figure 4.24 Remove colour from text.

— Lists: select from a convenient list of common bullet and enumeration
types, for creating lists in your document. For custom options, tap the
“…” button at the end, and for further choices use the main list tool in the
Format Bar (subsection 15.7.2) or Format ▸Lists ▸ submenu.

— QuickReference: whenever this button appears in the Touch Bar, you can
use it to open the current selection or current text file that you are editing
as a Quick Reference panel (section 12.6). Very useful for those “hold that
thought” moments.

Now for those options! Everyone works differently and while our set was cho-
sen primarily to increase the accessibility of a few features that are otherwise out
of the way, youmight prefer a different function in place of them. The following
list will describe each button in order from left to right in Figure 4.25. Again, not
every button listed here is available in every text editing context. If you don’t see
a button listed, chances are that means the editor itself does not support that
type of formatting (such as adjusting the line-height of some footnote text).

Figure 4.25 Optional buttons available to the text editing context. (Combined
bold/italic/underscore control not shown.)

— Bookmark: toggles whether or not the current document is a project
bookmark (section 10.3). The button will fill in when the document is a
bookmark, and become hollow otherwise.

— Text Colour: similar to the default Highlight button, only for changing
the colour of text or removing colour from text. Also accessible with the
⇧⌘C shortcut.
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— Strikethrough: toggle whether or not the selected text is struck out. Use-
ful if you wish to mark text for removal without deleting it (or to simply
keep a to-do list in Scrivener).

— Add Link: add a hyperlink to the text, either attached to the selected text,
or by inserting the URL at the cursor position (subsection 15.7.3). Also ac-
cessible with the ⌘K shortcut.

— Table: brings up the table editing palette and creates a new table if the
cursor is not already within one.

— Text Alignment: accesses the four basic paragraph alignment options,
otherwise serviced by the shortcuts in the Format ▸Paragraph ▸ submenu,
and on the main Format Bar (subsection 15.7.2).

— Indents: opens up controls for impacting three different indent character-
istics on the selected text with a pair of buttons for each type (Figure 4.26).
The left button decreases the amount of indent, or move the indent point
leftwhile the right button increases, ormoves the indent point right, as de-
tailed in the Format ▸Paragraph ▸ Increase/Decrease Indents ▸ submenu (sec-
tion A.10).

– Block indent: all indent levels in the paragraph are moved right or
left uniformly, or together. However reducing the indent repeat-
edly will “flatten” all indents and eventually cause the paragraph to
be flush left.

– First line indent: only the first line the paragraph has its indent in-
creased or decreased.

– Hanging indent: the main body of the paragraph has its indent in-
creased or decreased.

— LineHeight: select between a few common line-height factors (1.0, 1.2, 1.5
and 2.0) or open the main Format ▸Paragraph ▸Line and Paragraph Spacing…
tool, with the “Choose” button.

— Insert Image: brings up the file dialogue chooser, where you can select an
image that will be inserted at the current cursor location.

— Add Comment: adds a comment to the selected text, otherwise available
via the⇧⌘* shortcut.

— Add Footnote: adds a footnote to the selected text, otherwise available via
the ⌃⌘8 shortcut.

— Format (not shown): this combo button contains basic commands for
Bold, Italics and Underscore along with Strikethrough.
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Figure 4.26 Indent buttons: block indent, first-line indent andhanging indent
by pairs.

Table Editing Buttons
When the cursor is within a table in the editor, the Touch Bar takes on a discrete
context from the text editor itself, with table adjustment tools and a few editing
buttons by default. This bar can be customised separately from the editor touch
bar to hold any of the buttons from the editor that you desire.
In addition to theTable button itself (described before), there are twoprovided

buttons (Figure 4.27) for modifying tables:

Figure 4.27 Tables: Insert rows and columns.

— Insert Row: adds a new row to the table below the current row that the
cursor or selection is currently within. Note that when you are editing the
last cell of a table, it is not necessary to create a new row, you can simply
hit Tab to create a new row and move to the first cell within it.

— Insert Column: insert a new column to the right of the one the cursor is
currently within.

Inspector Buttons
The last major area of the interface to cover is the inspector (which also pertains
to the inspector split in quick reference panels, and thefloating inspector in com-
position mode). Just as the inspector does more than a few tricks, its Touch Bar
support varies depending on what you are doing within it.
With the exception of the few text editing areas, touch bar buttons in the in-

spector are not directly customisable, but you can still access customisation to
manage the global button set (section 4.4.2).

Figure 4.28 Inspector Buttons: show text synopsis, edit bookmark, select
comment colour.

— When editing rich text content within Document Notes or when work-
ing with text content in the Bookmark Preview area, the standard text
editing touch bar will be used (although document notes will use its own
separately customisable bar).
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— Notes Pane: a single button is provided to toggle between showing the
synopsis as text or an image. Thebutton for toggling to an image resembles
the insert image button on the main text editing touch bar (Figure 4.25),
while the button to toggle back to text mode looks like an index card.

— BookmarksPane: the bookmark list area provides two buttons, onewhich
simply loads the select bookmarks as Quick Reference panes, using the
button already provided in the text editor default set (Figure 4.23), while
the second edits the bookmark.

– Editing an internal reference merely opens the bookmarked docu-
ment’s title for renaming. It is synonymous with hitting the Esc key.

– The button is more interesting when editing an external bookmark,
where it then provides access to both the description and storedURL,
otherwise accessible through the right-click contextual menu.

— Snapshot Pane: the buttons provided while viewing snapshots merely
mimic the buttons provided in the interface, but largely only accessible
through use of the mouse. As the buttons are all self-explanatory, refer to
the documentation on the Snapshots Tab (section 13.6) for more informa-
tion on their usage.

— Comments & Footnotes Pane: when editing the contents of a note, a sim-
plified text editing touch bar is used. Otherwise, selected comments may
have their colours changed with the provided button for doing so.

Compile Related Buttons
Lastly, the compile window has a few buttons to help you manage your compile
settings more easily.

— Assign Section Layouts: corresponds to the button along the bottom of
the layout preview area. Use this to change the look and feel of your doc-
ument when it compiles.

— Close: simply closes the compile window without saving any of your set-
tings.

— Reset: use this if you don’t like where things have gone in this session, and
wish to restore your settings to how they were when you first opened the
compile window. This corresponds to a button on the compile pane that
you can reveal by holding down the Option key.

— Save & Close: for when you want to make a small change to how the
project compiles, such as adding a Replacement, without actually compil-
ing. This corresponds to a button on the compile pane that you can reveal
by holding down the Option key.
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— Compile: when it’s time to get down to brass tacks, this is your button.

Return to chapter ⤴

4.5 Interface Language & Localisation
If you have your computer set up to display itself in a particular language already,
you may already see Scrivener in translated form. The default setting is “System
Default” which should track whatever language your computer is set to.
To manually switch the language used by the software in menus, buttons and

throughout the rest of the interface:

1. Open the Settings pane (Scrivener ▸Settings…).

2. In the “General” tab, click on the “Language” option in the sidebar.

3. Select your chosen language from the dropdown tool.

4. Restart the software.

Supported languages are:

— Chinese (Mandarin)

— French

— German

— Italian

— Japanese

— Korean

— Portuguese (Brazilian)

— Spanish

— Swedish

Return to chapter ⤴
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Don’t worry, wewon’t attempt to go into every facet ofwhat can be in a project
in this chapter, you could safely say that’s the rest of the manual! Instead we
will focus on the project itself, as the largest unit of measurement in Scrivener; a
container for the text youwrite and thematerial you accumulate to support your
writings. As a citizen of the folders and files on the computer you write with, a
project is themost important first thing to learn how to work with. It represents
the filing cabinet that your work will be filling. Knowing where it is and how to
get it open is the first step to getting all of that paper off of your desk and neatly
sorted. So let’s dig in!



5.1. The Basics of Using Projects

5.1 The Basics of Using Projects
Scrivener is a project based application, meaning you can create separate storage
containers to organise your different interests into. These projects are stored on
the computer in the folder you designated upon creating them. In this way it is
quite similar to any program that loads and saves files to your disk—rather than a
database style program (like Evernote orOneNote) where all of your information
ismanaged behind the scenes ormaybe even online. These projects will be saved
into your Documents folder by default, though you can choose to organise them
however you like, even after you’ve created them, again like you’d organise your
DOCX files or PDFs into folders.

KnowWhere Your Work is Saved
Some find it convenient to rely upon the File ▸Recent Projects ▸ submenu
to organise their projects, or simply let Scrivenermaintainwhich projects
are open whenever they start Scrivener for the day. These tools are valu-
able, but shouldn’t be a substitute for good organisation on your com-
puter. External adjustments to the system or reinstallation can some-
times cause Scrivener to lose track of projects, and youwill want to know
where your work lives so you can get it back on these lists.

The intended use of a project is to store everything relating to a single major
work, whether it be your next novel, a screenplay for a film, a doctoral disserta-
tion or a serial collection of articles for a magazine. This is a general guideline
that can be approached in a flexible manner. It is possible to use a project as a
daily journal ormaybe a collection of random things you intend to one day utilise
in future projects. Ultimately, the choice is up to you; a project can be as large
or small as it needs to be.
These alternatives will be explored in more detail later on, but you should

know early in the process that if you feel you would benefit from having shared
research and notes for multiple real-world projects, you won’t be penalised for
doing so, and in fact the software works great under that approach. Also you
should know that merging and splitting projects is fairly painless, so even if you
change your mind later on, it won’t be a major setback.
To get a little technical, on the disk a project is a cohesive folder of files, which

will appear as a single bundled package on a Mac, containing all of the pieces
that make up your project, all using industry standard formats to do so. The
accessibility of this format is meant to be used as a last resort safeguard, not as
a way to allow you to edit a project in places where Scrivener is not available.
Project damage and data loss can occur from attempting to edit the internal
files by hand.
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5.1.1 Creating a NewProject
When you first start Scrivener, you will be presented with a Project Templates
window (Figure 5.1), which also includes a handy “Getting Started” section in
the left sidebar.1 In addition to providing an easy selection mechanism for new
projects based on templates, you can also start from scratch with “Blank”, or
open existing projects from your disk with the buttons along the bottom. To call
up this window later on, use the File ▸New Project…menu command, or use the
shortcut: ⇧⌘N.

Figure 5.1 The Project Templates window is where youwill start whenmaking
a new project.

Along the left side of the window are template categories. A number of useful
templates have been provided, and any templates you create or import into the
software will be organised into these categories as well. To read more about
creating and managing templates, see Project Templates (section 5.4).
To create a new project:

1. Click on the desired template tile to make it active, or select the “Blank”

1 You may hide this category (or choose to reveal it again) using the Options button in the lower
left of this window.
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template to startwith a fresh project that can be constructed to your needs.

2. Click the Choose… button (you can also just double-click on the template
icon).

3. Enter the name of your project in the “Save As” field. This is what you will
use to identify your project in the future. It can be changed later (using
your file manager while the project is closed) if you please, so don’t worry
if your work in progress doesn’t have a name yet!

4. The next step is selecting where you would like to save the project file. It is
a good idea to choose a place on your disk that you will remember.

5. The Create button will activate once you have supplied a name and valid
save location. Click this button to proceed, and in a few seconds you’ll
have a brand new project open, ready for writing!

5.1.2 Saving andMaking Copies
As with many modern programs, your projects automatically save the work you
do in them on as you go. By default, thismeans that after two seconds of inactiv-
ity, the project will be fully saved. You can monitor this process by watching the
upper-left corner of the window. The left-most “traffic light” button will have a
dot inside of it whenever the project contains pending edits that need to be saved
to the disk. When you stop typing or clicking in the program for a moment the
mark will disappear and now everything is saved to the disk.
You can change how rapidly this happens by adjusting the inactivity interval

in the General: Saving settings pane. If you have selected a very long interval for
some reason, you might wish to manually save the project now and then. This
can be done with the standard File ▸Save command, or pressing⌘S. But in most
cases it will not be necessary to manually save like this.
Occasionally you might need to create a copy of the project you are working

on. This can be a useful tool when youwish to experimentwith a series of radical
structural changes. To create a new separate copy of the project and continue
working in the new copy:

1. Use the File ▸SaveAs…menu command (⇧⌘S), and choose a new name for
the project.

2. Type in the name of the new copy for this project and select a folder to
save it in (or use the same folder if you wish).

3. Click the Save button.

At this point the active project will become the new one you just created, and
the old copy will be closed in the background.
If instead youmerely wish to create a backup, or a maybe leave a trail of major

milestones rather than switching projects, read about creating backups on the
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fly (subsection 5.2.2). It is also recommended you use this method when creating
copies of the project with the intention of storing or sharing them over the ’net
(section 5.3.1).
Since Scrivener projects are stored right on your disk, you can use the Finder

to manage them, create duplicates, and archive old versions. Always be sure to
close your projects before doing so.

5.1.3 Opening Existing Projects
Existing projects can be opened in a variety of ways. For convenience, your Mac
keeps track of the last several projects you have opened, and stores them in a
list, accessible from File ▸Recent Projects…. This list can also be accessed from
the Project Template window, via the Open Recent button along the bottom.
Secondly, by default Scrivener will remember any projects you leave open

when you quit, and will re-open these for you next time you start the software.
This behaviour can be changed in the General: Startup settings pane.
You can also open older projects that are no longer in any convenience lists us-

ing File ▸Open… (⌘O), or click the Open an Existing Project… button in the Project
Templates window, and navigating to the projectmanually with the file dialogue
box.

Can I Keep My Own List of Projects?

There may be projects you would like to “pin” in such a way that they are
always conveniently available from within the software. Refer to Setting
Favourite Projects (subsection 5.1.4), in the following section.

Finding andManaging Projects as Files
Finally, as with managing projects that have been saved, you can also use the
Dock, Finder, Spotlight, or other system tools to open files stored on your drive.
In Finder, double-click the project you wish to open. Spotlight is also handy
when a project gets misplaced and you are unsure of where it is saved.
If you don’t recall the name of the project orwhere you saved it, you can search

for “kind:Scrivener Project” to find every Scrivener project in your Spotlight in-
dex. If you’re using the direct-sale version, we have created a convenience menu
command for you: File ▸Find All Projects in Spotlight.
When trying to sort out the differences between near similar versions of a

project, you will find that the Quick Look information for your projects is quite
extensive. A stylised outline of the “Draft” folder will be presented to you, which
provides a small amount of information per outline item using a similar set of
rules as those described in Titles and Adaptive Naming (section 7.2). Use this
ability to figure out which project is the correct version, before opening it.
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5.1.4 Setting Favourite Projects
For those projects you would like to always keep track of, no matter how infre-
quently you may use them, you can “pin” a project to the main Filemenu:

1. Open the project you want to set as a favourite.

2. Use the File ▸Add Project to Favoritesmenu command.

The project will now be tracked (even if you change the name of it or move it
to another location) and listed in the File ▸Favorite Projects ▸ submenu. To stop
tracking a project:

1. Open the project you wish to stop tracking as a favourite.

2. Use the File ▸Remove Project from Favoritesmenu command.

Given the nature of howScrivener tracks a project on yourmachine, these lists
cannot be transferred betweenMacs or PCs, so youwill need tomake this setting
on each device you use.
If a project can no longer be found, it will be automatically removed from the

list of favourites for you.

5.1.5 Moving andDeleting Projects
Despite technically being folders full of files, you can otherwise treat the project
as you would any other file on your system. Everything that Scrivener needs to
work with the project is contained within the project file, and so moving it will
have no detrimental effect on it. This also makes it easy to copy all of the work
you need from one machine to another, since all of your research and working
material is self-contained in the project.2

Always close a project prior to moving it. While a project is open, Scrivener
maintains a very close connection with the files inside of it. Since it cannot pre-
dict where you will move the project the software may no longer save files in the
correct location, and can lead to lostwork or needing tomanually put the project
back together again.
You will want to be aware of this “package” format when using Internet ser-

vices to copy the file, attaching it to an email, or in essence doing anythingwith it
that involves non-Mac technology. It is often best to zip the project into a single
archive file prior to using non-Mac technology to transfer the project.
As with all file based programs, it is not possible to delete old and unwanted

projects from within Scrivener. To remove projects you no longer want, use the

2 There are some exceptions if you choose to link to research material, use linked images and
other such things along those lines, but these are more advanced uses of Scrivener and it is as-
sumed you will know what you are doing if you use links.
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standard filemanagement tools as youwouldwith other folders and files on your
computer.

5.1.6 Project Format Upgrades
If you’ve used Scrivener in the past, it is very likely youwill need to upgrade older
projects to the new format used by 3.0. Beyond that, from time to time we may
need tomodify the format to add or change features. By and large this should be
a painless procedure, and we take steps to ensure it is a safe one as well.
When opening an older project you will be asked if you wish to update the

project. It is safe to cancel, your project will not be touched by this version of
Scrivener and it will stop loading it. In most cases you will want to update it by
clicking the Update Project button.

Coffee Break Alert
Larger projects may take some time to update. A complete copy of the
entire project will be created before the updating process is started, so
for projects that measure in the gigabytes, it may take a long time for the
full process to complete. It is strongly encouraged that you let the pro-
cess complete fully, rather than interrupting it. If you are in the middle
of a busy schedule or coming up on a hard deadline, it might be best to
defer upgrading Scrivener until you have time to devote to the process.
For very large projects, such as those over several dozen gigabytes, you
might want to contact tech support for assistance in getting the project
upgraded without taking hours to do so.

The first action that will be taken is to create a complete backup of the project
in its current state in the same folderwhere theproject is presently located. If you
have a project called “My Thesis.scriv” in your Documents folder, then a backup
project called “My Thesis Backup.scriv” will be placed in your Documents folder
prior to attempting the upgrade. This is your first layer of protection as that copy
will be precisely the same as it was before starting the upgrade.
Next, your project will be updated to the new format. At the conclusion of the

process, the project will open.
If for some reason the project did not update correctly or open at the con-

clusion of the process, the backup created earlier will be handy to restore from.
Again using our example from above, set aside or delete the “My Thesis.scriv”
project and rename “MyThesis Backup.scriv” to how it should be, then try again.
If you have repeated difficulty updating the project, please contact technical sup-
port.
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Upgrading from Scrivener 2

If you’ve been using the iOS version with your 2.x projects, you might be
wondering if it will work with the new format seamlessly. The answer
is yes! The iOS version was programmed from the very start to work
with 3.0 projects, and has been capable of working with them from its
inception. In fact you might find a few new features unlocked in iOS for
you once you upgrade to 3.0, such as making use of a project’s styles and
tracking your daily writing progress with the writing history feature.

Projects will not open in older versions of the software for either platform.
Make sure to update all of your machines to these versions or greater, and make
sure that your colleagues are up to date as well if you collaborate by sharing a
project.

Return to chapter ⤴

5.2 Backing Up YourWork
Regularly backing up your work is an important part of the writing process in
that it keeps your efforts safe, and while there are many external strategies for
keeping yourwork safe from catastrophes andmistakes, themost important part
is remembering to do it.

5.2.1 Configuring Automated Backups
Fortunately, by default, Scrivenerwill protect yourwork frombasicmistakes (like
accidentally trashing an entire chapter, or using a global search and replace tool
to change all instances of “the” to “catastrophe”). The default rules are as follows:

— The project will be backed up whenever the project is closed.

— The backups will be stored in your user folder:

∼/Library/Application Support/Scrivener/Backups

For those using theMacApp Store version, youwill need to set up a backup
folder yourself, as the software cannot do so automatically.

— They will be zip compressed to save space and protect the internal files
from external utilities.

— Backups will be rotated (old ones deleted) to keep no more than 5 backups
per project

The location, along with several other settings, can be changed in the Backup
settings pane (section B.9).
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It is important to note that the backup system, as it ships by default, is set up
with a common method of working in mind, whereby you close your project on
a regular basis (say at the end of every day). If you find your own work habits
deviate from that, you would do well to go over the settings in the Backup tab to
suit your style of working. Here are a few common variations:

— Those who leave their projects open for weeks or even months at a time,
will most certainly want to change the backup settings to be triggered by
manual saves, and remember to run a manual save (⌘S) at least once a day
for maximum protection.

— On the other hand, if you open and close projectsmultiple times a day, you
might find the default limit of only five copies too limiting. Mistakes you’d
like to revert may have rolled off the backup list because five backups were
created in the past 24 hours. Increasing the number of stored backups to a
higher value means more drive space will be used for each project, but will
ensure you have something from more than a few sessions ago to restore
from.

— Read about the various options available (section B.9).

Working in a Secured Environment

In cases where security is a concern (if you are working with confidential
files in a protected area for example) the automated backup systemmight
present a security risk if it produces files in an unencrypted area of your
hard drive. If you are working in an encrypted environment, make sure
the backup location is set to also output to that area. You can also set
individual projects to back themselves up to a custom location in Project
Settings (section C.9).

5.2.2 Manually Backing Up
Backups can be created whenever and wherever you want. Use File ▸Back
Up ▸Back Up To… and select a backup location and filename. The “Backup as ZIP
file” option in the file dialogue will compress the backup project into a zip file
after saving it, and is thus useful when backing up to remote storage locations,
such as a file server or through cloud sync, or to attach the project to an email. By
default, backup file names will be timestamped, making it easy to find a precise
version later on and reducing confusion over which version of the project is the
most up to date. Use of this command is separate from the automatic backup
system and will not influence it in any way.
It is also possible to manually trigger the automatic backup system, even for

projects which have been excluded from it, by using File ▸Back Up ▸Back Up Now
command (hold down the Option key to back up all open projects with the
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File ▸Back Up ▸Back Up All Projects Now command). This will follow any relevant
options that have been set in the Backup Settings, such as how many to keep
andwhere to store them. Do be aware that since automatic andmanual backups
rotate the oldest versions out, frequent use of this command can roll older back-
ups off faster than you would like; consider increasing how many old backups
Scrivener keeps.
Frequent use of these features will help safeguard your work in progress, and

it is recommended that you start forming a habit of making backups whenever a
decent amount of work has been committed to the project. Anyonewho has lost
a lot of work to a hard drive failure or catastrophic event can tell you the most
important thing to getting work done is making sure your work backed up.

5.2.3 Restoring fromBackups
And the secondmost important thing is knowing how to get your work restored
from your backups! In the unfortunate event that a backup is needed to fix a
problem with your current working project, you can make use of Scrivener’s au-
tomatic backups to restore from an earlier version. By default these backups will
be tucked away in a safe out-of-the-way place, to help avoid them being inadver-
tently opened and modified.
If you are unsure of where your backups are located:3

1. Reveal the folder they are stored within by opening the Backup settings
pane.

For projects with a custom backup folder set, you will need to use the
Project ▸Project Settings…menu command and navigate to the Backup tab
from there.

2. Click the Open backup folder… button at the bottom of either pane.

Now that you have the backup folder open in your file manager, you will find
a number of files named respectively with the projects they relate to. After the
project name there will be a sequence number or a date stamp (an optional set-
ting).

3 For backups you have created manually, you will need to use your file manager to navigate to
where you saved them and skip over the following checklist.
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What are zip files and how do I use them?

By default these files will be stored in compressed “zip” format. Zip files
are a “container” file format. You can think of container files as being a
bit like boxes. You can stuff other things into a box, tape it up and store
it in the attic. It takes up less space and protects the things inside the box
to a degree, making them easier to move around together.
Just as a cardboard box is not the things you put into it, so long as your

project is in a .zip file, it is not a Scrivener project andmust be “unpacked”
from the box. Onmost systems, this is as easy as double-clicking the .zip
file and either dragging the project folder out of your default zip viewer,
or waiting for the project to be extracted automatically in the folder view
alongside the original .zip.

With the correct backup folder opened, you are ready to proceed:

1. Locate the most recent backup. The sequence number cannot be used to
determine this as Scrivener rotates through numbers. If you have not en-
abled the date stamp option in Scrivener, you will need to use your file
manager to determine the most recent copy.

2. Copy the backup(s) youwish to examine to another folder by holding down
the Option key while dragging the files to your Desktop or another conve-
nient location. It is never a good idea to open the original backups, or to
work within the backup folder.4

3. For zipped backups, you will need to first open the .zip file in the Finder by
double-clicking on it.

If your backups are not zipped, you will be able to open them directly like
normal projects, and then it will be even more important to create copies
of the backups to work on.

4. Examine each backup you’ve copied. If the backup contains the problem
as well, then proceed to the next older backup, continuing until you find
a valid copy.

When you find a good copy to pull from, use one of the following methods to
restore your work:

— Full project restoration:

4 Wewant to set aside a complete copy of all current backups for this project; otherwise opening
and closing them may rotate (delete) the very backups you‘re looking for. Creating a separate
static copy of the backups in a folder outside of Scrivener’s reach is the safest way to avoid that
problem.
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1. If applicable, close the chosen backup project.

2. Remove the unwanted version of the project from its original folder.

3. Replace it with the restored copy, renaming it if necessary.

— Partial restoration: to restore only pieces of a project, you can open your
current working version at the same time as the backup, and drag those
pieces from the restored backup project into the liveworking project, from
binder to binder (section 6.3.4), or by copying and pasting the bits of text
you want to restore.

This can be a useful approach if you’ve done a lot of work since the last
backup, and have only just noticed that one file had been accidentally
messed up some time ago, and there are no snapshots to recover from.5

Once you’ve finished, the backup copies you duplicated can be disposed of or
archived into a safe location, just in case.

5.2.4 Managing Backups for Large Projects
Very large projects can conflict with what would ordinarily be good settings for
the automated backup system. If a project has reached a point where backing
it up automatically has become a nuisance, rather than decreasing the amount
of backup security globally, consider excluding the large project from the auto-
mated system (section C.9).
Once this project is excluded the backup system will ignore it entirely. It will

then be up to you to keepmanual backups of the project. The File ▸BackUp ▸Back
UpNow feature is useful in this regard.

5.2.5 Tips for Using TimeMachine
Time Machine will automatically back up your computer once every hour, and
store backups as far back in time as possible, reducing the frequency of these
backups the further back in time you go.
This presents a unique problemwith Scrivener in that the hourly backup rou-

tine is likely to run while you are working in Scrivener. This means that Time
Machine will be capturing your project while it is open and in progress. Fre-
quent users of Scrivener may very well keep their projects open for weeks at a
time, meaning good backups of their project will be few and far between.
There are a few tips you can use to help Time Machine work effectively with

Scrivener:

5 Snapshots are a useful feature for protecting your text within the project, and are an additional
layer of protection on top of backups. Read more about them in Using Snapshots (section 15.8).
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1. Time Machine can be set to run manually at any time of your choosing,
using themenu status icon in the upper-right hand portion of your display.
You can thus controlwhenTimeMachinemakes a backup of your projects,
making sure they are closed first.

2. As Time Machine starts to erase hourly backups that are old, it saves only
the last backupsmade in a single day. In conjunction with the first tip, you
canmake certain that your “safe” backups are retained once TimeMachine
starts erasing old backups, by always running Time Machine manually at
the end of every day with all of your projects closed.

3. Always use Apple’s Time Machine interface to restore projects. That goes
for all forms of using Time Machine’s disk storage.

Going the extra mile

Time Machine is a wonderful tool for what it does, but it shouldn’t be
used as your sole backup for two important reasons. First, being attached
to your computer at all times, it is thus susceptible to the same risks of
damage and loss due to theft or catastrophe. Second, no backup system
should be considered infallible, and thus you should have more than one
method. TimeMachine isn’t perfect; don’t let it be your single safety net.

Return to chapter ⤴

5.3 Beyond the Basics of Using Projects
In this section we’ll go over some of the more advanced techniques you might
require in certain scenarios. We’ll cover how to best work cross-platform, col-
laboration, splitting & merging projects and more.

5.3.1 Tips forWorkingwith Projects
Working Cross-Platform
The Scrivener project format is fully compatible with its companion platforms,
whether that be macOS, Windows or iOS.6 No conversion is necessary, and all
platforms can work off of the same source file (at different times; no project
should ever be opened more than once simultaneously). The primary difference

6 OnmacOS, only Scrivener version 2.0 and greater is cross–platform compatible. If you intend
to use the Windows version as well to edit your projects, you should consider upgrading to the
latest version (and besides, Scrivener 1 is very old at the time of this writing, and has not been
modified in many years). Additionally for iOS compatibility you will need the project updated to
version 2.7+ on macOS or 1.8+ on Windows.
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in appearance betweenWindows and themacOS and iOS platforms is thatWin-
dows does not have a “package” or “bundle” format. Thus, the Scrivener project
will appear in its ordinary state, a folder. This is invisible to a Mac user, but in
fact there is no difference between the two at a file level—it’s purely in how we
see and work with that project.
Toopen a project on theMac, youneedonly double-click the “MyProject.scriv”

project bundle, or open it from within Scrivener. On Windows this will be a
folder, so you will need to descend into the “MyProject.scriv” folder and select
(or double-click on) the “MyProject.scrivx” file that you will find at the top level
within that folder.
To transfer projects between computers, always make sure to copy the entire

“MyProject.scriv” folder fromWindows, not just the .scrivx file by itself; the en-
tire folder is your project.

Sharing ProjectsOver the Internet
If you wish to share a project using the Internet, you might think to attach it
as an email, or upload it to a file sharing service so that one can download it or
save a copy to an online backup service. Given that a project is a folder of files
the best way to send a project is as a single “document”, and the easiest way to
do that is to use zip files (or whatever archive format you prefer). This can also
prove a reliable way of copying projects to some types of external storage, such
as USB thumb drives, if you run into difficulties or slowness copying projects the
usual way.
There are numerous tools for creating zip files, including using the operating

system itself, but if you’re looking for an easy way to do so fromwithin Scrivener,
try using the File ▸BackUp ▸BackUpTo…menu command fromwithin the project
you wish to send. Within that dialogue box you will find an option to back up as
a zip file. This will “pack” your entire project into a single compressed file which
will transfer across the ’net more quickly and safely.

Opening zipped projects

Zip files do not load in Scrivener, you will need to “unpack” the project
from the zip file before it can be opened. This is usually as simple as
double-clicking on the zip file and extracting the contents to your disk
somewhere, then loading the project from that location as you normally
would. I probably sound like a broken record at this point, but as always,
if the project looks like a folder in the archive, make sure to extract the
entire folder ending in “.scriv”, not just parts of the folder.

If you later wish to merge edits that have been made to this project by a col-
laborator or editor, you might be able to make use of the process described in
Splitting & Merging Projects (subsection 5.3.2).
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Project Size Limitations
Since Scrivener was primarily written with the long-form author in mind, much
effort has been put into making the project format as robust as possible. It can
handle book-lengthmanuscriptswith ease, store large quantities of researchma-
terial, and handle many thousands of individual components, even on a single
corkboard. Scrivener has been tested against projects with millions of words in
them; way beyond what it would normally have to face. So for ordinary usage,
you will never need to worry about limitations.
There is one caveat to keep inmind, however: the bigger your project is on the

disk, the longer it will take to produce backups. When combined with the auto-
mated backup system, this could mean waiting long periods of time for backups
to complete in the most extreme cases. While Scrivener is capable of handling a
large amount of media, some users have found it better to use database software
in conjunction with Scrivener, when gigabytes of data are involved.
There is no universal rule of thumb on upper limits, this will be whatever you

are comfortable with, and how much available storage space you have in order
to keep consistent backups. If you have an 8GB project, that means each backup
will consume another 8GB maximum (less if you use the slower zip archival op-
tion), and will take as long to produce as it would to duplicate 8GB of data on
your hard drive.
Another option is to disable automatic backups for the large project. This can

be done in each project’s backup settings (section C.9). You can also divert a
project’s backups to a different folder or disk, if running out of space on your
main disk is a concern.

Sandboxing and Authorised Folders
⟨MAS only⟩ Sandboxing is a technology used by all software sold through Apple’s
Mac App Store. Sandboxing works by limiting the tasks that applications are
allowed to perform. One such limitation is that applications can only access files
and directories that the user has granted access using an Open or Save panel.
For the most part you shouldn’t notice this restriction. When you open a

Scrivener project, in most cases all of the files it needs are contained within that
project file and by opening the project you have given Scrivener permission to
operate on those files, meaning that you can edit, save and work as usual. Addi-
tionally, the files it makes use of as settings, such as templates, custom icons and
so forth are located in a “safe” area it has complete access to. However, there are
certain types of files that, under sandboxing, Scrivener will not be able to access
so easily or in some cases at all:

— Bookmarks: Scrivener’s inspector can store a list of bookmarks to external
files. Because these files are stored outside the project, Scrivener may not
be able to open them by default.

— Aliased research files: it is possible to import research files as aliases us-
ing File ▸ Import ▸Research Files as Aliases…. Scrivener won’t be able to open
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such files after you reload the project, and when you try to open such
files in the editor you will see a message telling you that the file cannot
be opened.

— Linked images in text: when inserting an image into text as a link back to
the original file on disk (using Insert ▸ Image Linked to File…), if the original
images are stored in locations to which sandboxing does not grant Scriv-
ener access by default, these images may not appear correctly in the text,
a placeholder being displayed instead.

— Post-processing and command-line integration: those who make use of the
Mac’s broader toolset, integrating Scrivenerwith command-line tools such
as MultiMarkdown, Pandoc, LaTeX and so forth, are advised to not use
sandboxed software. If you haven’t purchased Scrivener yet, we’d advise
doing so directly rather than through Apple, but if you’ve already bought
the program you can switch to the direct-sale version to lift all of the above
limitations.

How toGrant Scrivener Access toMore Files

Fortunately, there’s an easy way to grant Scrivener permission to various loca-
tions on your computer so that Scrivener can still use all of these files seamlessly.
Here’s how:

1. Use the Scrivener ▸Authorize Folder Access… menu command to open the
directory access panel.

2. To grant Scrivener permission to access external files, simply click on the
AddFolders… button. This will bring up anOpen panel fromwhich you can
select the directories you wish Scrivener to have access to. Alternatively,
you can drag folders into the “Accessible Folders” list from the Finder.

To stop Scrivener accessing files, select the folders in the list that you no longer
wish Scrivener to have access to and click on Remove Access.

Tips for Authorising Folders

When you grant Scrivener permission to access a directory, it will be able to ac-
cess all of the files inside subdirectories of that folder too. Thus, you need only
select the highest level folders that you feel comfortable giving to Scrivener.
The main thing to consider when adding folders to the list is which files you

need Scrivener to access. For instance:

— If you tend to import many different files into Scrivener as aliases (using
File ▸ Import ▸Research Files as Aliases…), or if you make heavy use of Scriv-
ener’s Bookmarks feature to refer to external files, then you may wish to
consider adding your entire home folder to the list of accessible folders.
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This will give Scrivener access to all folders inside your home folder with-
out you having to add them all separately, such as your Pictures, Movies
and Documents folders.

— If you are very careful aboutwhere you store all the files on your hard drive,
and you only tend to add images to Scrivener as linked files and import a
few sound and movie files as aliases, you might only need to add the ∼/
Pictures,∼/Movies and∼/Music folders to the list.

— Perhaps the safest and easiest approach would simply be to have a folder
somewhere on your hard drive for storing your research documents, and
only grant Scrivener access to that.

Essentially, though, for any files you want to be able to view in Scrivener that
are not stored inside the project, you must grant access to one of the folders
containing that file. For instance, suppose you have bookmarked the file “∼/
Documents/Ideas/Writing/MyGreatIdea.pdf”. For Scrivener to be able to open
that file, you must grant access to one of the following folders:

— “∼/Documents/Ideas/Writing”: in which case Scrivener will be able to ac-
cess all files inside the “Writing” folder.

— “∼/Documents/Ideas”: in which case Scrivener will be able to access all
files in the “Ideas” folder, as well as any folders contained in the “Ideas”
folder and any files or folders inside those.

— “∼/Documents”: inwhich case Scrivenerwill be able to access all files, fold-
ers, subfolders and sub-files within the “Documents” folder.

— “∼/”: in which case Scrivener will have full access to your home folder.
(Adding this is the easiest option if you do not want to have to worry about
authorising the right folders every time you add a new file, but it is also the
least “secure”.)

5.3.2 Splitting &Merging Projects
In this section you will find tools for helping to realise large-scale decisions like
merging two ormore projects together, or splitting a large one into smaller satel-
lite projects. You will also find tips for merging changes from one project fork
into another, as a form of synchronisation, which can come in handy for collab-
oration or working on the go.

Splitting Projects Up
Occasionally, one or more portions of your project might exceed the scope of
your original planning and contain portions within them that should become
their own projects. A classic example of this might be a chapter in a biography
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that ends up becoming another biography about different person entirely, or a
short story that keeps growing and starts to become a trilogy of novels.
Whatever your reasons may be, there are fortunately basic procedures for

splitting your project. There are two ways of going about it:

1. Create a new project for the pieces that merit moving them out of the
parent project. You can use whatever template you wish for this, or even
blank, it doesn’t matter. With the original project open alongside the new
one, position the windows so that you can see both binders at once. Now
simply drag and drop the pieces from the old project into the new project’s
binder. That’s it, you’re done (you may want to delete the original copy
from the old project to truly “split” them). Refer to Copying Files and Fold-
ers Between Projects (section 6.3.4) for the details.

2. Use File ▸Save As… to create a forked copy of the entire project (subsec-
tion 5.1.2). Once you’ve created a new copy, you will immediately begin
working in the new one. Simply delete everything from the binder that
isn’t necessary for this new project.

The first method might work better if your needs are simple, but if you find
important aspects of the project are getting lost in the translation, the second
method is by far the safest as it comprises a complete and 100% identical copy of
the starting project, from every word you’ve written into it to its most obscure
settings.

Merging Projects Together
If what you are looking to do is merge two completely different projects into
one—like say novel A and novel B are going to be part of a trilogy and you want
them together—then use the File ▸ Import ▸Scrivener Project…menu command. If
you are asked to “import andmerge”, it is important to use the ImportOnly button
instead.

Consider Linking Instead of Merging

Scrivener projects can have detailed connective relationships made be-
tween themwithout having to lump everything together into one binder.
If you mainly just want to make some research readily available, you
might be better off using a link (subsection 10.1.6) instead of fully copying
that material around into your project.

Merging Changes fromOne Project into Another
It is possible to merge edits from one project into another, in cases where these
two separate projects have come from an original source at some point in the
past. For example, if you take a copy of your project with you on a trip using
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your laptop and returnhome, discovering that you’dmade a few changes at home
before packing up the laptop, you could use this feature to merge the two forks
of the project back together again with the File ▸ Import ▸Scrivener Project…menu
command.
The followingmethods for copying a project can all result in versions that can

be merged back together in the future:

— Duplication or any form of copying the project on the disk itself. This is
always best done while the project is closed, otherwise your collaborator
may get a confusing warning about the project appearing open on your
machine.

— Use of the File ▸Back Up ▸Back Up To… command, which is particularly use-
ful if you are handing the project off via email, as you can zip it into a single
file here for easy transmission.

— Use of the File ▸SaveAs… command. Donote this commandwillmove your
session to the new copy of the project, meaning if you continue working
in the new one, the old copy you left behind should be the one you send.

Effective Use of ProjectMerge

The following procedure outlines best practices for the use of this feature. De-
viating from this procedure should only be done with care:

1. Create a copy of the project using one of the above methods.

2. At this point is safe to work in either or both projects simultaneously. For
the best results you will want to avoid editing the same precise binder
items while the two copies are “forked”.

3. Once you are ready to merge the projects, open the copy you consider to
be the “master” copy, and from it, use the File ▸ Import ▸Scrivener Project…
menu command, and select the second project using the file chooser.

4. Youwill receive amessage alerting you to the fact that the imported project
appears to be a copy of the current project, and will be offered a choice on
how to proceed:

— Click the Import and Merge button to incorporate the edits into the
binder.

— Click the Import Only button to import the whole project as its own
set of folders into the binder. If the two projects are very similar, this
will result in many duplicates, however this can be desirable if the
above method did not work as expected or if the two sources have
diverged significantly enough that they no longer merge properly.
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— And of course, the Cancel buttonwill back out of the procedure with-
out modifying the current project.

— You are strongly advised to leave theBack up project beforemerging
option enabled unless you have taken your own precautions!

5. At the conclusion of the process, your binder sidebar will switch to show-
ing a “Merged Documents” list of all the items that were added or modi-
fied in the project. Take this opportunity to review the changes in detail.
If conflicts occurred, where you both edited the same item independently,
you may need to manually merge the result yourself. Once you are fin-
ished, you can close this sidebar view (it is actually a collection, so it won’t
go anywhere until you delete it or merge again) with the × button in the
binder sidebar header.

Scrivener does its best to retain as much data as possible from both
projects, using the following mechanisms:

— Whenever the main text of a file has been changed by merge, a snap-
shot will be taken for the older copy of the text.

— If changes have beenmade to the same item that involve the synopsis
or its document notes in the inspector, then a summary page will be
created showing both versions so you can easily copy and paste the
correct version into the conflicted item.

— Metadata changes will be merged, so long as the same binder items
are not edited in both forks.

6. The project you merged from will not be altered in any way by these pro-
cedures. Once you have confirmed a successful merge, it would in most
cases be best to discard that copy or archive it to reduce confusion.

Just the Facts, Ma’am

Only content found in the binder will be merged. Alterations to a
project’s settings, compile format, new keywords, other metadata added,
and so forth will be ignored. There is an exception in the case of meta-
data, in that if a binder item uses a metadata setting, it will be merged. If
you need to merge metadata adjustments (such as new custom list fields,
labels or keywords), then ensure these values are assigned to some binder
item (perhaps creating a disposable item specifically for that purpose). All
other important project-level adjustments (including new custommeta-
data fields) should be communicated in one form or another.
The satellite project can be opened alongside the original, prior to

merging, to copy the new metadata settings. Refer to Copying Settings
Between Projects (section C.1) for further information on this topic.
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Merging two projects together involves a lot of guesswork, and what a com-
puter thinks is right may not always be what is really right—for that I’m afraid
we still need humans. The software will do its best to retain as much of both
of the projects as possible, but in some cases you may lose information. Having
the software create a backup will give you a point to step back to if the merge
goes afoul, or if it only made mistakes in a few areas, you can open up the older
backup along side the project and manually restore just those pieces you need
from its binder.

See Also…
— Restoring from Backups (subsection 5.2.3): when things don’t go as

planned, use these instructions to get back to a better starting point.

— Copying Files and Folders Between Projects (section 6.3.4): it might some-
times be best to only copy a few things rather than perform a full merge, or
maybe you only need to restore a portions from a backup. These instruc-
tions can help with both cases.

— Using Snapshots (section 15.8): the project merge feature will take a snap-
shot of an item whenever the main text of it has been altered by the pro-
cess. A familiarity with this feature will help resolve problem.

— Saved Layouts (section 12.3): if you are collaborating with another person,
the two of youmight have different ideas on how the project should be dis-
played. Use layouts to save your settings so you can restore your preferred
settings whenever you wish.

Collaboratingwith the Import Project Feature

This capability could allow for a limited form of collaboration between two peo-
ple. If you provide someone with a copy of your project and continue working
on it, while they make revisions to the project on their own, you can later on
merge their changes back into your project.
It is possible to limit what you send to a collaborator, and have the additions

or changes they’ve made merged back into the full project later on. For example
you can use the File ▸Save As… command to create their copy and then delete
everything from the project except for the chapter or two they intend to work
on. When importing and merging their edits later on, only that portion of the
binder will be updated.
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Can Projects Be Merged Multiple Times?

In a word, no. You will always want to create a new merged copy of the
project for your collaborator, rather than having them continue to work
in their own satellite copy. Otherwise, not only will they lack the ben-
efit of seeing any changes you have made to the project, this could ulti-
mately result in strange results as the two copies of the project growmore
and more apart from one another. Whenever you merge a collaborator’s
changes, always provide them with a new updated copy of the project!

This is a simple form of merging, with certain limitations, and one that will
benefit greatly from good communication between the two people working on
the project. In most cases you will get the best results if each individual sticks
to editing different areas of the project, rather than freely working on the same
individual binder items. Here are a few problematic areas to watch out for:

— Your collaborator adds files to a folder you move to the trash: the result
will be that the files they added to the project will be in the trash as well,
as they were assigned to a folder that you trashed independently.

— They add files to a folder that was not only trashed but fully deleted: in
that case the folder will be “resurrected” back into its original position in
the outline, because the child files they added to it depend upon it.

— You both edit the same item’s text: the latest version will be used, however
a snapshot of the chronologically older edit will be taken as well, so you
can review the conflicting changes using that feature and manually merge
the text edits as you see fit. This can also be used to revert the text if the
merging process chose the wrong copy.

— If metadata is edited simultaneously: if for example both of you set the
same item to a different label, the most recent modification date will take
precedence. There will be no mirror copy showing the older changes, so
this is one area where communication will be important. If metadata is
being used heavily in the project by both people, it will be best to stick to
editing different areas of the project at once.

Return to chapter ⤴

5.4 Project Templates
Simply put, project templates are ordinary projects that have had some basic
startermaterial added to their binders and some settings tweaked to reduce how
muchwork you need to exert to get started on a new project. They are in a word,
well, two words: starting points.
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In our built-in templates, the example items added to the binder are guides for
how youmight organise yourwork, not forms that you have to fill out or features
that must be worked around if you prefer another approach. The items you will
find in the binder are like any other items you’ve added to projects on your own.
They can be deleted, modified, duplicated, or set aside and ignored.
One need not start with a template at all. In fact many prefer the simplicity

and flexibility of starting with a blank slate. Whatever route you take, as you are
learning the software, feel free to experiment with the different templates we’ve
provided. You may find valuable insight into how you could use the program,
even if you never use the template in question.
Lastly, you can create your own templates for future use, as a way of further

customising Scrivener’s default behaviour, as many settings are specific only to
individual projects rather than global to the application.7

5.4.1 Getting Startedwith Built-in Templates
In our built-in templates you will find a help document at the very top of the
Binder that explainswhat the purpose of the template is, howbest to use it and in
some cases, step-by-step instructions for popularmodifications that can bemade
to its design. Most also contain a sample PDF in the Research folder showing how
the final draft will look, using its default settings.

Figure 5.2 Look for the blue “information” icon to get help on a template.

Beyond the help file, here are a few things to keep in mind as you explore a
new template:

— It is possible to rename theDraft andResearch folders, and some templates
have done so for clarity, such as the short story format (Figure 5.2), where
the draft has been renamed to “Manuscript”. Feel free to rename this to
something more appropriate, like the title of your work.

— Some templates will have document templates (section 7.5) set up within
them, providing a few special types of document (like character sheets).
You can modify the items in this folder to customise them or add your
own.

7 If you’re looking for general information on how to create a new project from a template, please
refer to Creating a New Project (subsection 5.1.1).
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After you have created a project from a template, there will be no connec-
tion to the original template, meaning existing projects that you created from a
template will not be modified to reflect changes made to the template they were
created with.

5.4.2 Converting a Project to a Different Template
The short answer is that there is rarely a need to do this as there would be lit-
tle benefit in doing so. Everything about a template can be exported into other
projects, and so the best approach may be to bring select elements of the tem-
plate into your project, rather than copying your work into a brand new project.
The specifics of how to do so are better documented in relation to those features
themselves, so below you will find a handy list of cross-references to areas of a
template that you might find useful to transport:

1. Transferring stylesheets betweenprojects, inCopying Stylesheets Between
Projects (section 17.5).

2. Making project compile settings global, in Project vs My Formats (subsec-
tion 24.1.1).

3. Copying files and folders between projects, in Copying Files and Folders
Between Projects (section 6.3.4).

4. Copying Section Types, in Transferring Section Types Between Projects
(subsection C.2.4)

5.4.3 Creating YourOwnTemplates
Creating custom templates is as easy as creating a new project, and if you of-
ten set up projects with the same starter items—like character sheets, keywords,
or custom labels—personalised templates can save you a lot of time. Here is a
list (by no means complete) of things that are commonly changed or added to
custom templates:

— Custom labels & status: add the types of labels, preferred colours, and sta-
tus stamps that you find useful for your projects.

— Project bookmarks: try making a list of writing resources, critique groups,
and research portals that you often use.

— Character sheets or research note starters: use document templates (sec-
tion 7.5) to supply yourself with your favourite starter documents.

— Compile settings: since they can be stored in the project settings, you can
configure these so that your future projects will be ready for one-click ex-
port (or close to it!).
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— Collections: standard collections as well as saved search collections can be
placed in a template as well.

— Starter story structure, essay skeleton, snowflake methods, thesis model
or blueprint outline: set up your favourite or necessary techniques and
outlines in the draft.

The important concept to keep in mind is that whatever you can save within
a project, you can save as part of a template8. There are a few differences (mostly
pertaining to how a template is loaded and the description and thumbnail that
can be saved with it), but for the most part you should consider a template no
different from an ordinary project.
Try not to worry about getting everything perfect the first time through. It is

easy to update existing templates with revised material; this will be covered in
detail in the following pages.
Once you have set everything up, use the File ▸Save As Template… menu item

to start the template creation process.

Figure 5.3 Fill out the simple form to create a template out of the open project.

In the New Project Template window (Figure 5.3), provide the following de-
tails:

8 Technically, there is a 50 MB size limit to what can be saved as a template, but given that a
template is intended as a starter project, you are unlikely to ever encounter this restriction.
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Title The visible title of the template, as you want it to appear in the template
browser.

Category Declares which section to add the template to in the browser.

Select “Custom” to create your own category, using the name supplied in
the text field below. Any existing categories that have been installed into
the software will be listed for your convenience.

Icon Here you can select the appearance of the template thumbnail. You can
choose from a number of available presets, or if you wish to make your
thumbnail stand out from the built-in templates, you can click the Save
Icon… button, which will generate a file for you based on the currently se-
lected thumbnail. “Blank” is a good choice if you want a clean canvas to
start from.

After you have edited the image using your favourite image editor and
saved it, you can use the Icon menu to select “Choose…”, at the bottom
of the list, and then select the image you edited.

Save styles into template If you’ve created styles that are important to the pre-
sentation and functioning of the template, you can choose to have them
added into new projects upon use of the template. If you leave this option
off, then the default set of styles (as seen in the “Blank” starter) will be used
instead. The styles will be saved into the template no matter, merely left
inactive, should you change your mind in the future and revise the tem-
plate to include them (subsection 5.4.4).

After clicking OK, the template will be saved into the system, and you can
delete the original project or continue working in it without affecting the tem-
plate.

Template Placeholders
There are several placeholders (Table 5.1) that you can type into the editor that
will be particularly useful if you intend to share the template with others. When
making a template for yourself, you could just write in your name and address
on yourmanuscript submission cover-page, but this wouldn’t work sowell if you
wish to share the template.9

Place the template variable where the intended text should occur (for example
you could put the <$template_projectName> placeholder on the title page and
format it nicely), and when the template is used to create a new project, it will

9 In fact Scrivener will check your templates for stuff that looks like your personal information
and warn you if you wish to proceed.
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request relevant information from your settings (using the information you pro-
vide in the General: Author Information settings pane (subsection B.2.3)) and fill
in what details it can.

Table 5.1 Project Template Placeholders

Placeholder Description

<$template_firstName> First name from your settings.

<$template_lastName> Last name.

<$template_fullName> Combines the first and last name for you, ordering them
according to system language settings.

<$template_initial> First letter of first name.

<$template_street> Street address.

<$template_city> City.

<$template_ZIP> Postal code.

<$template_state> State or county.

<$template_country> Country.

<$template_phoneNumber> First phone number.

<$template_email> Email address from settings.

<$template_projectName> The file name of the project from when it was created.
Note this will not include the “.scriv” portion on the end.

CustomCategories
The project templates that you create, or acquire from others, can sort them-
selves into custom categories, which will appear in the template chooser sidebar
along with the built-in categories (Fiction, Non-Fiction, and so forth).

Upgrading from Scrivener 2

If you are still using Scrivener 2, these categories will not be visible, and
the projects organised into them will all be filed to the “Miscellaneous”
section. Of course, if the project template itself is in v3 format then they
will not work in the legacy version of Scrivener anyway.

To create a new category:

Categories are defined by the templates themselves, rather than being something
you create first and then put templates into. Thus, if you download a template
from the Web, it may install itself into a new category automatically.
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To make new categories, this will be done either in the process of creating a
new templatewith the File ▸SaveAsTemplate…menucommand (subsection 5.4.3),
or updating one that has already been created by right-clickingon it and selecting
Edit Template Info… from the contextual menu (subsection 5.4.4). Either way you
will arrive at the “Save as Template…” dialogue:

1. From the “Save as Template…” panel, click the Category dropdown and
select “Custom” from the bottom of the list.

2. Type in the name of the category as it will be seen in the template chooser
sidebar. Any existing categories will be listed here for your convenience,
and can be selected by clicking on the button to the right of the text field.

3. Confirm the rest of the settings and click the OK button.

4. Use the File ▸NewProject…menu command (⇧⌘N) to view the results.

To rename an existing category:

This will update all templates foundwithin that category. If you copy these tem-
plates to another machine, they will assign themselves to the revised category
name.

1. Open the new project template chooser.

2. Right-click on the category and select “Rename Custom Category…”.

3. Type in the new name and click OK.

Categories cannot be removed directly. They will be removed automatically
from the sidebar when all templates using it have been removed or modified to
no longer be in that category.

5.4.4 Revising Templates
If all youwish to do ismodify theway a template appears in the template chooser,
or to enable or disable whether its built-in styles are used when creating new
projects, then you need only edit the template in place:

1. Bring up the new project window with File ▸NewProject… (⇧⌘N).

2. Right-click on the template youwish tomodify and select the EditTemplate
Info… command.

3. Make the changes you desire, and click OK to save them.
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Can I Modify the Built-in Templates?

Built-in templates cannot be overwritten or modified, but you can create
projects from them for editing and then save yourmodifications as a new
template by giving it a new name.

To update the content of a template that has already been saved:

1. Create a temporary project using the template you are wanting to adjust.
The name and location are unimportant to the process.

If you need to edit a template that uses placeholders (many of the built-
in templates do), follow these instructions when creating the temporary
project for editing the template:

a) Bring up the new project window with
File ▸NewProject… (⇧⌘N).

b) Select the template you wish to revise.

c) Hold down the Option key, and click on the Create button.

d) You can let go of the Option key and give the project a name.

This procedurewill stop the substitution of these placeholders so you
can edit the template file and then save it as an updatewithout having
personal information inserted into it.

2. Make any desired changes to this temporary project.

3. Use the File ▸SaveAsTemplate…menu command. When editing an existing
template, the information from the original template will be filled in for
you, so you do not have to worry about retyping in the title10 or adjusting
the icon every single time. If you do not need to make any changes here,
just click the OK button.

4. If this is a custom template you are updating, you will be asked if you want
to overwrite the existing template or keep both and sort it out later.

5. Discard the temporary project, or set it aside for future adjustments to this
template.

10 If you change the title, it will no longer be considered a replacement or update to the original
template, meaning you’ll end up with two of them.
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Upgrading from Scrivener 2

If you’ve developed a number of templates in previous versions of Scriv-
ener, the good news is that you won’t have to domuch of anything to use
them in Scrivener 3, and if you leave them alone you’ll be able to continue
using them in the older version as well
.
Upon use, youmay notice that the project created by the template will

be upgraded seamlessly for you. You might eventually want to update
these to the version 3 format to avoid this step; simply follow the same
directions you would to make a revision to an existing template (subsec-
tion 5.4.4). Having done so in the new version, the project template itself
will now be stored in the new format (it will no longer work with older
versions of Scrivener).

5.4.5 Managing Templates
In the Template browser window, the Options button in the bottom left (Fig-
ure 5.1) provides the following features for managing your templates (you can
also right-click directly on the template tile itself to access this menu):

Set Selected Template as Default Changes the default template selection to the
template you currently have selected. Once set, the next time you call up
this window it will highlight that template for you for quick access.

Hide Getting Started Hides the “Getting Started” category at the top of the cat-
egory list. The functions it provides can also be accessed from the Help
menu at any time, so it is safe to remove the category once you’ve famil-
iarised yourself with the program. You can also reveal it again using this
same option menu.

Import Templates… If you have downloaded templates from theWeb or copied
your custom templates from another computer, use this feature to import
the files into the template system automatically.

Export Selected Template… Useful for sharing your templates on the Web,
with other authors or for transferring templates to another working com-
puter.

Edit Info… Modifies how the template appears in the template chooser, such
as its title, icon, category or whether or not it builds predetermined styles
into the new projects created with it. Refer to Revising Templates (subsec-
tion 5.4.4) for further information. Built-in templates cannot be edited.

Reveal in the Finder Reveals the selected template on the disk, using your file
manager.
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Delete Selected Template When a custom template is selected, you can use this
menu item to remove it from your system. Built-in templates cannot be
removed.

For those interested in managing these as files directly, rather than using the
above commands, templates are stored in Scrivener’s support folder (use the
Scrivener ▸Reveal Support Folder in Findermenu command to get here easily), un-
der the “ProjectTemplates” subfolder. Changes made to this folder will be re-
flected in the template chooser window after it has been closed and reopened.

Return to chapter ⤴

5.5 Adjusting a Project’s Settings
Each individual project that you create will have many settings available to it,
both as on-the-fly adjustments that can be made using the main application
menus (primarily the View menu), as well as those options found within the
Project ▸Project Settings… panel. Refer to Project Settings (Appendix C) for full
documentation on the following settings:

— Section Types (section C.2): concerning how documents within the
project are categorised into types, such as “chapter”, “scene”, “subsection”,
“table” and so forth.

— Label List & Status List (section C.3): set up the label colours and status
markers used within the project.

— CustomMetadata (section C.4): design the types of metadata you can use
to categorise your items in the project.

— Formatting (section C.5): override application defaults for how the text in
your project should be formattedwithin the editor (as opposed tohow they
will format when you compile).

— Auto-Complete List (section C.6): make adjustments to the auto-comp-
letion dictionary used within this project.

— Special Folders (section C.7): setup for both the document templates
folder, and where new project bookmark files should be stored (if you
would prefer that to choosing where they are stored upon creation).

— Background Images (section C.8): set a backdrop to your composition
mode environment, or use a special image for the freeform corkboard
background.

— Backup (section C.9): override application defaults for how this project
will be backed up (or even if it is).

Return to chapter ⤴
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The Binder is the document browser on the left of the main project window
(Figure 6.1) where you can organise your writing as individual topical pieces,
research files and so forth. This is going to be like your ring-binder in the
real world, where you would stash all of the notes, research documents, never
mind the work in progress itself. Everything that represents information in your
project, from an idle thought to a formal paper on a topic you are writing about,
will be stored somewhere in the binder.
To that end, the sidebar on the left is a fundamental building block in how a

newproject begins, all theway to being a cornerstone inhowyouwill export your
work and close the project down for good (or at least until the next revision!).
This chapter will go over the various aspects of using the binder, setting it up
for a new project and how best to use Scriveners’ features to structure, navigate
within, edit and write your draft.

Wondering if a project can have multiple binders?

It cannot, any more than a bucket cannot have multiple buckets. The
project and the binder are one and the same, and both full encompass
everything within it. There are however ways of creating multiple lists
of items within your binder, which can for a time replace the binder list
in the left sidebar, allowing you to focus on a particular group of items,
or even organise them differently. For more information on this feature,
refer to Using Collections (section 10.2).



6.1. What is Outlining?

Figure 6.1 A typical project window, with the binder on the left and an editor
on the right.

6.1 What is Outlining?
If likemany authors you are accustomed to working in word processors formost
of your writing, you no doubt have a few habits and ideas that you’ll inevitably
bring with you to Scrivener. If you intend to get the most out of what this pro-
gramoffers, there are a few fundamentalsworth learning,mulling over and even-
tually applying to your approach. Fear not, we aren’t going to say you have to
learn how to plot out your outline in advance before dipping quill into ink pot!
The point here is to get a feel for what that framework is, so that you can decide
how best to make use of it.
Scrivener provides a simple means toward working with many multiple

smaller pieces of text. This user manual, for example, has each section of the
manual in its own document, and is comprised of nearly 2,500 such snippets of
text arranged into a detailed indented list of topics (Figure 6.2). Thatmechanism
is what we call an “outline” in software.
While the manual often uses this structure to produce visible headings when

exported, we need not necessarily think in terms of parts, chapters, sections and
subsections—especially early in a project’s development. We could merely or-
ganising things topically, or even chaotically into groups you intend to disperse
later once you figure out how all of these pieces of text are meant to fit together.
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This approach grants you ultimate flexibility in how you think around the struc-
ture of your work. Your outline needn’t serve some external stipulation while
creatively constructing it—rather, it can be used to augment your own under-
standing of the topical layout of the text.

Figure 6.2 An excerpt of the outline used to organise this section of the man-
ual you are reading; current section marked in orange.

If you have never used nor even heard of the type of software referred to as
an “outliner” before, there will be some useful jargon to learn, as it will be used
elsewhere in this manual to refer a few simple concepts concisely:

— Outlining is in part a visual metaphor that declares some things as being
children to other things, based upon their relative level of indent. If some-
thing is indented “beneath” an item, then it is considered a child of it, and
that item is a parent to it. In Figure 6.2, “The Draft Folder” is a child item
of “The Three Root Folders”, the latter of which is also a parent of “The
Trash Folder”.

— A list of parent and child items is sometimes referred to as a tree.

— The action of putting items beneath another is sometimes referred to as
“nesting”. We can also say that indented subdocuments are “nested” be-
neath another item.

— A child (or a leaf ) can only ever have one parent.

— Items at the same level of indentation are referred to as “siblings”.

— A crucial feature of digital outlining in principle is that you can hide child
portions of the outline by folding, or collapsing their respective “parents”,
keeping your screen focused on what you are currently working on.

You could draw a connection between this approach and the outlines youmay
have had to compose prior to writing an essay assignment. Unlike those pen and
paper outlines, you can imagine the digital counterpart as being as though each
line on the paper essay had a stack of pages beneath it, where that portion of the
essay is represented by the topic line it relates to. Thus, moving a heading in a
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digital outlinemoves the stack of paper along with it, thus changing the order of
the longform text this outline represents.
This is all a bit abstract, so let’s move on to some applied examples of the con-

cept, starting with the three basic top level groups (folders, parents or trees) that
every project will be working around.

Return to chapter ⤴

6.2 The Three Root Folders
The binder has three default root folderswhich cannot be deleted ormoved from
the top level. They can be renamed and moved around among each other, but
not within each other or other folders. To use Scrivener effectively, it is very
important to understand the significance of these folders.

Figure 6.3 The three default top-level folders

6.2.1 TheDraft Folder
As the name suggests, the Draft folder is where you place all of the files you want
to include in the actual work that others will read. How you structure it is en-
tirely up to you—you may have parts and chapters, or you may have separate
files for each scene within each chapter, or even separate files for each individual
paragraph if you so wish.

My Project Doesn’t Have a “Draft” Folder

Some of the templates that we provide with the software have had the
“Draft” folder renamed to somethingmoremeaningful to that template’s
purpose. For example the Novel template has the draft folder renamed
to “Manuscript”. The draft folder can be renamed to whatever you wish.
The key thing to look for is the special icon (Figure 6.3). Only one item
can have that icon, so nomatter what it is called, that is yourDraft folder.
You can also use the Navigate ▸Reveal Draft Folder command at any time
to bring up the binder and highlight the draft folder, no matter what it is
called.
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At a basic level, everything that goes inside the Draft folder will be compiled
into one long text file when you use the “Compile…” command from the File
menu1. Thus, the draft folder is central to Scrivener: ultimately, you are aiming
to write and arrange everything inside this folder so that each of the elements
it contains form an organic whole that can then be output as a singular file to
the format you require. It is less useful to think of its contents as files, then, and
more useful to think of it as a personal table of contents for the text that will
become a document when you export.
Another good way to think of the draft is that it represents a long spool of pa-

per or a scroll. In a normal word processor, this entire spool would be presented
to you in a single window, with one scrollbar. Moving text around within that
spool means cutting and pasting it from one spot to the next. In Scrivener, you
can take that long spool of text and chop it up as you please. The compile feature
offers a way to “tape” the whole thing back together into a single spool.
Because the draft folder is what is used to create the final manuscript, it is

unique in that it can only contain text and folder items. That isn’t to say you
cannot include illustrations and figures in your work, they can be inserted into
the text editor just as with any typical word processor, but that the listing in the
binder can only be text sections, either as a loose list or organised into logical
groupings.

6.2.2 The Research Folder
The Research folder is the default import location for non-text documents such
as images, PDF files and so on (although it can hold text files too). You can create
as many subfolders as needed to organise your research, or you can rename it
and create other folders in the root level to hold different types of research or
supporting material. Technically speaking, anywhere outside of the draft folder
is a valid place to organise research, old drafts, notes and inspirational materials.
As noted, some import functions will target this folder if no other target is

provided. If you imported something, such as clipping a PDF to Scrivener from
another program’s print panel and don’t knowwhere the PDF ended up, check in
the Research folder first.

6.2.3 The Trash Folder
Whenever you delete a file in Scrivener (by pressing ⌘Delete, for instance, or
by selecting the Documents ▸Move to Trash menu item), the file is not actually
removed from the project but is instead moved to the special Trash folder just

1 As is often the case with Scrivener, there are many exceptions. The contents of the draft folder
can be dynamic, only compiling into the final document under certain conditions, never com-
piling at all or only piecemeal, but for now it is good to think of the draft folder in the binder as
a structural take on the larger work you will be exporting.
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like the Trash in the Dock. You can tell at a glance when items are in the trash
folder as its iconwill appear like an overflowing trash can. Permanently purge all
trashed files from the project with the Project ▸Empty Trash…menu command.

Deleting Only Selected Items from Trash

Topermanently delete individual files from theTrash, without fully emp-
tying it, select the items you wish to purge from the project and use the
Edit ▸Delete menu command, or by right-clicking on the selected items
from within the trash.

Files that have been placed in the trash will have their icons ghosted through-
out the software. This is mostly useful where trashed files are displayed in other
contexts, such as when listed in a search result.

Return to chapter ⤴

6.3 Using the Binder
Effectively working with the resources in your project is essential in a program
designed to accumulate them. While the basics may serve everyone well up to
a certain point, if you ever find Scrivener starting to feel a little awkward, you
might want to come back to this section and review the various tools available
for selection, modification of selection, focusing on content and movement of
items with mouse, keyboard, menu commands and shortcuts.
Managing items and navigating among them is one of the chief areas of this

program’s design; it has a lot of depth that can be explored, both in its feature
set and in how those features can be combined to create powerful workflows.

Relevant Settings

This section will refer to a few different options that impact how some
of the described behaviour below will work. Unless otherwise noted, all
options referred to in this section are located in the “Behaviors” settings
pane, under “Dragging & Dropping” (subsection B.4.4).

We aren’t going to be exploring every detail of how folders and files work here.
If you’re looking for a more in-depth look at items themselves, refer to All About
Files and Folders (chapter 7).

6.3.1 AddingNew Items
Before going about working with items in your binder, you’ll need a few to start
with. There are three basic types of itemnative to Scrivener’s binder: files, folders
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and file groups—or what you get when you indent one file under another—let’s
talk about how to make these things and what to expect while doing so.
Although this is a section about the binder, it is worth noting that you can add

newfiles and folders fromnearly every contextwithin the projectwindow. If you
are editing a text file you can use one of the methods below to add a new doc-
ument, and Scrivener will consider the currently edited document as “selected”
for determining where the new item will be placed.
Scrivener tries to keep your context persistent: for example if you’re writing

in a document’s Notes inspector pane and press ⌘N to create a new file, you’ll
end up typing in that new file’s Notes pane. If you create a new folder from the
main text editor, you’ll be able to start creating new cards on its corkboard im-
mediately. Want to give the new thing a name before getting to work? Click into
the editor header bar to edit its name, or use the shortcut: ⌃⌥⌘T.
Something to bear inmind is that naming things in Scrivenermight not always

be important to do immediately. Unlike files on your system, your items will
be given useful “handles” if you leave the name off of it. Read more about this
capability in Titles and Adaptive Naming (section 7.2).

TheManyWays to Add Things
Sincemaking new documents is such a vital part of Scrivener we’ve provided nu-
merous ways to go about doing so, from toolbar buttons, to keyboard shortcuts
to simply pressing the Return key. Let’s go over the options:

The “Add” button in the toolbar This is a multipurpose button, as indicated
by the downward facing arrow on the right-hand side (Figure 6.4). That
means if you click on the left side, it will create a new text file. If you click
on the arrow, you’ll get a selection of available types for this project. By
default that will be files, folders and web pages (the latter will be disabled
if you’re trying to add within the Draft folder area). If the project has Doc-
ument Templates (section 7.5) you’ll see those listed here as well, and after
those you’ll see any shared document templates (subsection 7.5.3).

Figure 6.4 The “Add” button on the default toolbar.

Footer bar buttons Along the bottom of the binder sidebar, corkboard and out-
liner views youwill find a footer bar with a few buttons for adding files and
folders (Figure 6.5).
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Figure 6.5 Binder footer bar: Add Text, Add Folder and access to the contex-
tual menu.

Contextual menu The “Add” submenu in the right-click contextual menu pro-
vides all of the basic options found when clicking the downward arrow on
the toolbar “Add” icon. In addition, it also provides quick access to the
File ▸ Import ▸Files…menu command (⇧⌘ I) as “Existing Files…”.

Menus & keyboard shortcuts There are several shortcuts available for adding
new items:

— Project ▸New Text (⌘N): adds a new text file. In cases where the se-
lected item has default subdocument template (subsection 7.5.2) as-
signed to it, the name of that template will be printed instead. E.g.
when clicking on the “Characters” folder to add a new character
sketch, in the Novel project template, the menu command will read,
“New Character Sketch”.

— Project ▸NewFolder (⌥⌘N): adds a new empty folder.

— Return: by default this will add a new text file (or default template if
applicable). Note that this key is also used to confirm changes being
made to the title of an item, so if you have been typing in the name
of one item and wish to make a new one, you’ll need to tap it twice.

— The ⇧⌥⌘N keyboard shortcut can be used to create the primay doc-
ument template (first entry in the Project ▸New From Template ▸ sub-
menu), if the project has document templates enabled.

Dragging text If you select text in any program and drop it into Scrivener’s
binder, corkboard or outliner views, a new item will be created in that lo-
cation with the text you dropped. If this is done from within Scrivener’s
editors, then text will be moved into the new file. This is a great way to
break apart a larger file: you can scroll through, selecting chunks of text
and moving that text to new files wherever you drop them. Where you
drop the text will matter:

— Onto a folder or file group or in between binder items: the text will
be added as a new file nested within the container you dropped on,
or at the location of the drop.

— Onto another file: the text will be appended to that file.
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— Onto a folder or file group with the Control key held down: the text
will be appended to the group’s main text.

— Onto another file with the Control key held down: the text will be
added as a new file beneath it, and thus turning the file into a file
group with a new subdocument.

The behaviour to move dragged text can be disabled with the Delete text
dragged to other areas option, in the Behaviors: Dragging & Dropping
settings pane (subsection B.4.4).

Adding items with the Touch Bar Last but not least, if you own a Mac with a
Touch Bar, one of the default buttons provided universally is the “Add”
button, again represented with a “+” sign. With the exception of import-
ing web pages, it essentially replicates the options provided by the “Add”
button in the toolbar, when clicking the downward arrow. Refer to the
Touch Bar’s Global Buttons (section 4.4.2) for more information.

FiguringOutWhere ThingsWill Go
A basic concept to be aware of is that Scrivener will create new items relative
to your current selection in the active view (be it the binder, editor or its copy-
holder). For example if we select a file in the binder and add a new text file, the
file will be created after the selected file. When the focus is in another area of
the project window, the selected item in the active editor view will be used. For
example, if you create a new itemwhile typing in the editor the new itemwill be
created relative to the item being edited. In cases such as these, Scrivener will
attempt to preserve your current focus—in this example, youwould go on typing
in the main editor for the new item.

HowThings AreNestedWhen Added

You may have noticed that sometimes files seem to be nested when you create
them and other times they aren’t. The logic behind this is very simple, though
a little unorthodox if you’re used to file managers or other outliners. Scrivener’s
logic is designed to produce the most often desired result, and can be simply
understood by what type of thing you are creating:

— When creating a folder, the behaviour will always be to add the folder as a
sibling to the selected item.

— When creating a file, if a folder is selected, it will be nested as a child to
that folder. Most often you’ll want to fill up a new folder with files, so this
works to your advantage.

— When creating a file with another file selected, then it will be created as a
sibling. Againmost often youwon’t want to nest the file beneath the other
file, but if you do simply hit the Edit ▸Move ▸Move Right shortcut: ⌃⌘→.
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There are a few exceptions:

— When the Draft or Research folder is selected then anything you add will
be nested beneath it. This is in part to help prevent cases where one tries
to create a new folder or file in the draft, and ends up accidentally adding it
to the root level, where it will not compile. If youwant to create a folder or
file at the root level, then select something other than Draft or Research,
or use the Edit ▸Move ▸Move Left shortcut ⌃⌘←, after creating it.

— If a group has a default subdocument template assigned to it (like the char-
acter sheet folder in some of our built-in templates), and if that default
template so happens to be a folder, then in that case the new folder will be
a child.

When items are nested upon creation the behaviour is to add that item to the
very bottom of its child list. If you want to create the item at a specific location
within the folder, it is better to select the sibling to place it after.

How Can I Modify These Defaults?

There are two preferences to adjust how some of these interactions oc-
cur, both located in the Behaviors: Folders & Files settings pane (subsec-
tion B.4.5). Always create new items as siblings does just what youwould
expect. No longer will files be nested under folders (however the two ex-
ceptions above cannot be overridden). Secondly, Treat all documents
with subdocuments as folderswill make it so all of the above behaviours
apply to file groups as well as folders. Now when you select a file group
and hit the Return key, the new file will be nested beneath. This setting
also broadly impacts how file groups work in general: they will now use
group views (like corkboard)when you click on them, among otherminor
adjustments.

Renaming Items
To rename an item you’ve created, double-click the title to toggle editing mode.
You can also use Esc key to toggle editing mode on the selected item. You can
click elsewhere to save the modified title, or use the Return key to confirm your
changes.
If a title is left blank, Scrivener takes a dynamic approach to how things are

named. You can read more about titles in Titles and Adaptive Naming (sec-
tion 7.2).

6.3.2 Selecting Items
Any single item can be selected by pointing the mouse at it and clicking, I think
we can all agree about that one. While that does the trick for most tasks, Scriv-
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ener was also built around the concept of selecting and working with multiple
items at once. Not only does this make it easy to do tasks with many items si-
multaneously (say, to move ten files from one section of the outline to another
with drag and drop), but the editor itself will react accordingly, displaying those
items you select as a group.

How does this work with the editor?
In this chapter we will mainly focus on the binder sidebar itself, rather
than how it interacts with the editor. If you want to bridge that gap in
your reading, The Editor (section 8.1) begins this discussion in reference
to how the editor itself can be used to receive and display items, but the
Project Navigation (chapter 12) section is where you will find the most
complete reference on how the sidebar and the editor work together.

KeyboardNavigation
The four arrow keys by themselves will move the selection around in the outline
according to the following rules, and can be augmentedwith a fewmodifier keys:

— ↑ and ↓ move the selection up and down the list from one visible item to
the next.

— ← will move the selection leftward in the hierarchy, selecting the parent
of whatever was selected when pressing the key. The left key will also col-
lapse the selection, if any of the selected items are expanded. If a group
(or all groups within the selection) is already collapsed the left key will act
normally.

— Adding the ⇧ key to the ↑ and ↓ keys will expand or contract the current
selection, depending uponwhichway you startedwhen first holding down
shift. For example: ⇧↑ will leave the item you started with selected, but
add the prior item to the selection as well, while pressing the combination
a second time will add a third. At this point, ⇧↓ will contract the selec-
tion, or remove the top item from it, resulting in the first two items you
had selected. This all works in exact inverse when starting in the opposite
direction.

— ⌃⌥↑ and ⌃⌥↓ will jump from one visible container to the next, skipping
over any regular items in between.2

— ⌥↑ and⌥↓ jump your selection to the top or bottom of the outline, respec-
tively. This command, when combined with the Shift key will select from

2 This behaviour is expanded to include all containers when Treat all documents with subdoc-
uments as folders is set to true, in the Behaviors: Folders & Files settings pane (subsection B.4.5).
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the current point to the top or bottom of the list. This is different from
theHome and End keys, which will only scroll the view, thus retaining your
current selection.

With theMouse
Selecting items with the pointer (whether it be controlled by mouse, trackpad,
tablet or joystick) taps into a standard set of functions that are broadly useful in
many applications.

— As noted above, simply clicking on an item will select it and simultane-
ously remove the previous selection, meaning you’ll only ever have one
item selected at a time when clicking.

— Hold down the Command key to add or remove individual items from the
current selection. Like clicking normally, this only works on the thing you
click on, one at a time. You can also toggle the selection off for the one
item you have selected.

— Hold down the Shift key to select all of the items in between the first point
selected and the point where you click. So for example if you click on C
and then ⇧Click on E, the result would be to have C, D and E selected. If
you then ⇧Click on A, the result would be A, B and C, because C remains
the first selected item.

— Given the logic governing these twomodifiers, they can be combined. Go-
ing from the prior example, if we select A,⇧Click on C,⌘Click on E (which
resets the last selected item) then ⇧Click on G, the result will be A, B, C
then E, F and G selected.

6.3.3 FindingWhere You Are in theOutline
When you click on items in the binder and then move over to the editor, the
last thing you selected will remain highlighted in the binder until you yourself
change it. If the editor ends up viewing something other than what you clicked
on in the binder (for example, loading a corkboard first, and then fromwithin the
editor corkboard, loading one of the cards so you can write in it), the highlight
will no longer be pointing at the thing the editor is working with.
There are a few advantages to this behaviour, all whichwork together tomain-

tain the binder sidebar as a workspace that you have control over:

— Itmeans you can always get back towhere youwere, since that initial point
of navigation is “bookmarked” for you in the binder.

— Since the binder isn’t required to always highlight what you are editing,
whether folders are collapsed can remain entirely up to you.

— Where you scroll the binder is left up to you.
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Under default settings, if the item you are editing is visible in the binder, a
smaller secondary highlight will be placed on the item you are currently viewing.
In Figure 6.6, we can imagine the author initially clicked on the folder named
“The Last Woman Standing” (which we can hope is a working title) and then
later went on to write into the subdocuments within this folder—currently in
“our heroine enters the arena”.

Figure 6.6 The binder highlights what we select as well as what we edit.

This form of highlighting is “passive” in the sense that it won’t violate any of
the above principles. If in our example “The Last Woman Standing” was a col-
lapsed folder and we couldn’t see the scene files within it, then there would sim-
ply be no secondary highlight. If we had scrolled to another part of the binder,
this itemwould be highlighted—butwe’d have to scroll back to the spot ourselves
to see it.
If you find this behaviour distracting, the current document indicator can be

disabled in the Appearance: Binder: Options settings pane (section B.5.2), with
Show current editor document indicator.
For those cases where you really do want to see what you’re editing no mat-

ter what it takes to do so, then use the Navigate ▸Reveal in Binder (⌥⌘R) menu
command. This will first reveal the binder if necessary, then switch to the main
binder listing (in case you are viewing search results for example), open any fold-
ers necessary to display the item and finallymove the primary selection highlight
to the item(s) you have selected. This all-purpose command is useful for finding
your place, if you’ve wandered far away from where you started, locating where
search results came from ormerely just to synchronise the binder with your cur-
rent editing session.

6.3.4 Moving andCopying Things Around
Once you’ve got things selected, youmightwant tomove them fromone place to
another. Simple drag and drop with the mouse will often suffice, but there may
be times when more precision is required, or in some cases, where the distance
betweenhere and there is too far to easily drag. As youmight be coming to expect
by now, there are a few different tools in this chest.

Moving with the mouse Items can be moved around in the binder with drag
and drop. Pick up the item by clicking and holding the mouse button
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down, then drag the mouse pointer to where you wish to drop the items,
releasing the button. The binder will display target, in accent colour, un-
derneath the pointer, showingwhere the dropwill endup. Slide themouse
left or right to control the indent level of the drop point, and leave the
mouse along the top or bottom edge of the view to dynamically scroll it.

If the place you want a drop a thing is inside of a group that is collapsed,
hold the item over it for amoment and it will expand for you. If youwould
prefer “spring-loaded” folders like this to collapse again after you drop, you
can set theCollapse auto-expanded outline items after drag and drop, in
the Behaviors: Dragging & Dropping settings pane (subsection B.4.4).

Copying with the mouse Although not enabled by default, you can toggle this
capability with theOption-dragging creates duplicates option, in the Be-
haviors: Dragging & Dropping settings pane (subsection B.4.4).

Another approach is to duplicate the files with the Documents ▸Duplicate ▸
with Subdocuments and Unique Title command (⌘D), which will create a
copy right alongside the original that you can drag and drop to the in-
tended location.

Moving items with the keyboard The ⌃⌘↑, ⌃⌘↓, ⌃⌘←, ⌃⌘→ keys can be used
to move an item around spatially in the binder, step by step. Up and down
will move the item in the outline respectively, while left and right will pro-
mote and demote the item. E.g. selecting a folder that holds the contents
of chapter eight, and pressing ⌃⌘↓ will move it down one spot, swapping
its position with the chapter below. It will now be chapter nine, and the
other chapter will be eight.

With the Toolbar Although not present in the default set of toolbar icons, you
can add item movement buttons (shaped like blue arrows) to the main
toolbar (subsection 4.1.1), provided as either a four-way set of movement
buttons, or two pairs of up/down and left/right buttons. These operate in
a similar fashion to keyboardmovement, one step at a time in the indicated
direction.

By the icon A bit of knowledge that can save you a lot of time is that everywhere
you see an icon in Scrivener, you can drag it, and in doing so it will act as
a proxy for that item, just as though you dragged it from the binder or any
other view. Youmight bewriting in a file in the editor and realise youwant
to move the text you are working on to a spot in the binder on your left.
You could attempt to locate the item in the binder and then drag it from
point A to B, but instead you can drag the icon straight out of the header
bar directly to B. Done, and you can keep writing without pause.
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MovingMultiple Items
When multiple items are selected most methods for moving them will gather
these items together at the target location, in the same order.

— If the view you selected from has been sorted (such as in the search results
sidebar or the outliner) then the moved items will be assembled in the tar-
get location using that sorted order. For example, if you drag the sorted
items back into the folder they came from then the effect is to reorganise
the items within that folder.

If that is not what you want, then use the Navigate ▸Reveal in Binder (⌥⌘R)
command first, and then move them.

— When using the keyboard to move multiple items within a folder (up and
down), the relative position of those items will be preserved. In effect, it
will be as though each itemwere moved individually one at a time. Select-
ing the second and fourth items andmoving themupwould result in these
items now being the first and third in the list, transposing the items they
displaced down one slot.

Use drag and drop if you want to gather the selected items to one place
within the folder.

— Items can be promoted and demoted (outdented and indented) with the
keyboard, and when doing so they will be gathered together. Items must
all be from the same container and level in the outline when doing so.

Long distance travel
When you need to move a selection far enough that the point of its destination
is out of sight, neither keyboard nor the mouse may be the most efficient way to
do so. To fill in that gap, we have two methods that should help:

1. The Documents ▸Move To submenu presents a list of all the items in your
binder, each and every one of them a potential target for your drop. The
item you select will become the parent for the selected item(s), placed at
the end of the target item’s child list. An item that is not a group will be-
come one by targeting it with this command.

Once you have moved a file using this menu, a “Move to ‘X’ again” com-
mand will be added to the Documents menu that will move the currently
selected item to the last used move location, with the added keyboard
shortcut, ⌥⌘T.

2. If you prefer the mouse for all things, consider using the main editor as
a long distance tool. Select the item(s) you wish to move, which will load
them into the main editor, then scroll to the drop point and drag the icon
from the editor header bar into the binder, or formultiple selections, select
the items in the editor and drop them into the binder.
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It might also sometimes be easier to do things the other way around. You
can load a folder into the editor as a corkboard or outline, lock it (subsec-
tion 12.2.1), and then freely drag binder items into it. With more than one
split available (never mind the history tool making multiple folders easily
available to you), it is possible to efficiently work with dozens of remotely
scattered targets and hundreds of files.

Copying files long distance

You might have noticed, from investigating the menu in an earlier tip,
that it is also possible to create a long distance copy of an item via the
Documents ▸Copy To ▸ submenu. The behaviour is otherwise identical to
the Move To command.

Copying Files and Folders Between Projects
The easiest way to copy a file from one project to another will be through the
following steps:

1. Open both of the projects at once.

2. Drag the item icon from the binder, corkboard or outliner view, or any-
where where you can see its icon and it is draggable.

3. Drop the icon into the project youwish to copy the item to, into a location
where files can be dropped.

If you drop into a text editor or bookmarks list you’ll get a link back to the
item in the original project instead of a copy.

4. Alternatively, use the Documents ▸Copy to Project ▸ submenu to file the se-
lected documents directly into another open project, via the binder item
selection menu. This command will record where you last filed a docu-
ment, and create a convenience menu command that continues filing se-
lected items to this project: Documents ▸CopytoProject ▸Copyto“X”Project
Again (⇧⌥⌘C).

When copying items between different projects, Scrivener will do its best to
keep as much of the information intact that it can. If you make use of the in-
spector to keep notes on your documents, tag them with keywords, use other
metadata, take snapshots and so forth, you will notice that just about everything
copies from one project to another. Here are some things that will be created (or
copied over, however you wish to look at it) in the new project when copying:

— Keywords

— Labels
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— Status

— CustomMetadata list entries (if a list field by the same name already exists,
but it lacks a specific value in its dropdown menu, an entry will be added
if the item requests it)

The following aspects of a file will be carried over:

— Title & Synopsis

— Main text content or media content (for example if dragging an image)

— Any style assignmentswithin the text, provided there are like-named styles
in the target project (the formatting will remain for you to update if you
wish to do so)

— Notes

— Bookmarks (note that if your drag includes internal links between the
dragged documents, these cross-references will be preserved. If you drag
an item with bookmarks referring to items not included in the drag, those
will be discarded from the copied item)

— CustomMetadata values (if the target project also has those fields by name)

— Custom icon assignment (if the icon is not available to the target project
youmay not see it, but the assignment will remain and start working once
the icon is present)

— Snapshots

— Section type (if a section type of the same name is available in the target
project)

— Any document writing goals and settings (subsection 20.1.2).

— Whether the document should be included in compile.

There are a few things Scrivener won’t copy:

— Default subdocument section type.

— Default template for subdocuments.

— Project settings that apply to that item, such as compile settings, or
whether a folder is the project’s document template folder.

6.3.5 Expanding andCollapsing the Tree
Once thenumber of elements in your binder exceeds a certain point, itmayprove
beneficial to learn a few of the tools available for handling a large quantity of
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items. The most recognisable of these is one you’ve already been introduced to:
the “tree” view, or outline, where you can collapse portions of the tree to decrease
the amount of information on your screen.
The ability to collapse and expand larger areas of the outline, either surgically

or in bulk, can mean the difference between getting bogged down in too many
details and obtaining focus in your work by keeping only the keystone informa-
tion you need at your fingertips, and making it easy to find and get to the stuff
that’s hidden, when you need it.

By elements As usual, we’ll get the basics out of the way first. To expand or col-
lapse portions of the outline, click on the arrow to the left of any group to
reveal or hide its contents. The state of every arrow will always be remem-
bered, meaning you can expand or collapse areas within larger chunks of
the tree, and then collapse thewhole thing, assured thanwhen you expand
it again it will be as you left it.3

Use the ← or → keys to open or close the selected containers, respectively.
The former key has a special behaviour in that if the group you have se-
lected is already collapsed, it will move your selection to the parent of the
current group, one level up.

Expand or collapse an entire tree with the Option key held down when
clicking on an arrow or in combination with the arrow keys on your key-
board. All subgroups will be impacted by this operation.

Incrementally by level Sometimes fully expanding a section of the tree will be
more than you want, but you still wish to expand down two or more lev-
els. This can be done by alternating between two different complementary
commands:

1. Press → to expand the tree one level.

2. Use the Edit ▸Select ▸Select Subgroupsmenu command to move your
selection from the main group to all of the items within it that are
also groups.

3. You guessed it, → again to expand the second level. Repeat until the
tree is expanded enough for your purposes.

Reveal and hide everything The menu commands “Expand All” (⌘9) and “Col-
lapse All” (⌘0) in the View ▸Outline submenu will expand or collapse every
container in the view at once. Both of these commands work in several
areas of the interface, where it is possible to expand or collapse items.

3 Meanwhile the outliner stores its own states, in fact on a per–container basis, making each
folder or file group a discrete workspace of its own in terms of what you can see within it.
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Collapse all to current level Working in a similar fashion to Collapse All, this
command will collapse the entire outline below the currently selected
item’s level. Thus if you if have an outline that has six levels of depth, and
select a folder on level 3, using this command will completely collapse all
items except those at levels one, two and three, which will remain as they
were.

When multiple items are selected, the least indented item in the selection
will be used to determine the level by which the tree will be collapsed.

Hoisting the Binder
If the idea of blotting out everything in your binder, save for the contents of
one folder appeals to you (like one chapter in the draft), hoisting is what you’re
looking for.
To hoist, select a container and use the View ▸Outline ▸Hoist Bindermenu com-

mand. While a container is hoisted, the appearance of the binder will change
(Figure 6.7). A header bar will be added to the sidebar, printing the name of the
container that has been selected along with a few functions (if you’re familiar
with collections, you might recognise the interface):

— The× buttonmarked (a) will unhoist the view, returning to the full binder.
You can also use the View ▸Outline ▸Unhoist Bindermenu command.

— The ↪ button beside the close button will load the hoisted container into
the main editor—just like clicking on it as a folder would do in the full
binder.

Figure 6.7 Hoisting the binder: before and after.

When you hoist a folder, any containers within that folder will be collapsed
or expanded in accordance with how they would appear in the normal binder.
However any changes you make to disclosure while the view is hoisted will be
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discarded upon return to the full binder, leaving you free to more fully expand
sections of the outline that you’d rather leave hidden by default.

Can the Outliner be Hoisted?
In a sense, the outline and corkboard views are hoisted by their very na-
ture. When you click on a folder in the binder, their contents (and down-
ward in the case of the outliner) are loaded into the editor view, with the
name of the container you clicked on printed in the header bar above. If
you wish to hoist within the view however, to isolate one folder from the
restwithin an outliner, or to load an index card as a corkboardwithin that
editor, select the items you wish to hoist and use the Navigate ▸Open ▸
submenu to select the same editor you’re currently using, or press the
⌥⌘O shortcut.

Marking Items as Separators
In longer outlines it can prove useful to add visual separators so that you can
more easily see landmarks in a large outline as you scroll through it. This is done
by marking existing items as being separators, by drawing a shaded box around
it. This is an item setting, and as such will be duplicated along with the item, or
included as part of a document template (section 7.5).
To mark an item as a separator, select the item and right-click on it, choosing

the “Show as Binder Separator(s)” contextual menu toggle.

Return to chapter ⤴

6.4 Multiple Selections
A multiple selection is a concept you will encounter throughout this manual, as
Scrivener considers selections to be a kindof feature in andof itself. For example,
if you select five files in the binder and then navigate elsewhere in the editor,
the selection itself will be inserted into the history queue, meaning you can click
the “back” button in the editor header bar (subsection 8.1.1) to return to your
selection later on.
You may also note that the editor header bar, which typically displays the

name of the thing you are viewing, prints “Multiple Selection”, with a special
icon; dragging that icon will by synonymous with dragging the selected items
together—you can even drag themultiple selection icon to another editor header
bar to clone the selection into both editors.
There are two basic forms of multiple selection that will act differently in the

editor:

1. A selection of containers: be they folders or file groups, if the entirety of your
selection is comprised of these, then the group views will act as follows:
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Figure 6.8 Marking a significant entry as a separatormakes it easy to find later
on.

— Corkboards will become stacked (subsection 8.2.8), so that each con-
tainer is listed one after the other.

— TheOutliner will show the groups with disclosure arrows so you can
expand their contents and work with their descendent items.

— Scrivenings mode will display not only the text of the selected con-
tainers, but all of their child items as well.

2. A mixed selection of containers and files:

— Corkboard will display all of the items one after the other in a single
grid or label view.

— Outliner will present a flat list, not allowing the contents of contain-
ers to be revealed.

This flat list approach can be used to your advantage, as it means you
can readily sort by outliner columns nomatter where the items came
from initially.

— Scrivenings mode will only work with the text content of the explic-
itly selected text items.
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3. Therefore, if you intend to use one of the above behaviours and are get-
ting the wrong type, then modify your selection accordingly, even if artifi-
cially, to achieve that effect. Somemight want to just edit the text content
of their chapter folders without all of the chapter subdocuments, so the
solution is to select one token file anywhere in the binder to trigger the
mixed selection case.

In a few ways, Scrivener treats a selection like a thing, but it is important to
understand what they cannot do. What you are viewing in the editor doesn’t
“exist” anywhere in the project:

— The main editor view will always display a multiple selection in a group
viewmode. It is not possible to “turn off” a group viewmode, like you can
with a folder or text group, because there is nothing behind the multiple
selection to edit. If the currently preferred group viewmode is single-text,
then a multiple selection will fall back to Scrivenings mode.

— Freeform corkboard view cannot be used, because your card placements
would have no place to be saved to, and would be lost the moment you
clicked anywhere else.

— You will not be able to add new items to the view, nor re-arrange existing
items, because their relationship amongst each other does not necessarily
correlate with anything in the binder in a linear fashion.

— Items can however be moved from a multiple selection. The result of this
action won’t be to remove it from the selection, but the card will bemoved
to the location you dropped it to in the binder or other editor.

In all other ways, the editor view can be used as you’ve learned how to use it.
Cards can be filled in on the corkboard, labels can be assigned, you can edit the
text of a selection in Scrivenings and outliner columns can be sorted.

Want to Save a Selection?
With the usefulness selections have in Scrivener, you might want to save
them for future use (and remember that History saves them until they
eventually roll off of the end of the list). To do so, with the items selected,
use the Documents ▸Add to Collection ▸New Collection… menu command.
The collection tab interface will appear above the binder and you can
type in a name for your “selection”. To recall it in the future, simply visit
that collection and select the items within it. Read more about Using
Collections (section 10.2).

Return to chapter ⤴
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If you’ve ever spent a little time organising documents on your computer,
you’ve probably encountered the concept of folders, and how we can use them
as ways to store groups of files together. Not only does a folder help us associate
those files as being related to a commonpurpose, they have a very practical result
in how the contents of folders are hidden from view until you open them.
Scrivener makes use of a similar approach whereby you have some things that

act as “containers” (like folders), that you canput other things into, such as files or
even other containers. Where it differs from the traditional approach is in how
anything can be a container, even other files. This is a more advanced topic that
you can read about at your leisure (section 7.3). Until you’re ready for that topic,
for now consider the role of folders and files as you are familiar with them, and
how that concept could benefit how you arrange the text of your work. Imagine
if it were easy to store scenes inside of chapters, or subsections inside of articles,
in the same way we can store PDF files into folders on a disk.
If you’re looking for the basics of how to use the binder to create new files and

folders, refer to Adding New Items (subsection 6.3.1). In this section we will be
taking a deeper look at what files and folders represent and how to use them in
your project, rather than the broader management topic of how to add, remove
and organise them.
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7.1 Binder Icons
You’ve seen a small taste of this in the preceding chapter, but there are many
binder icons used to show the type of item, and in the case of folder and text
documents, hints about their status as well (Table 7.1).
A new document that you’ve just createdwill look like an empty sheet of paper

until you add a synopsis to it, changing the icon to an index card. If you start
typing into the main text editor, the icon will then show a sheet of paper with
lines on it. Likewise, folders will display if they have synopsis or text content in
the form of a small badge. These visual cues can provide a vital bird’s eye view of
how your outline is progressing beyond being a mere outline.

Table 7.1 File and Folder Binder Icons

Icon Explanation

Text Document Icons

An empty text document.

A synopsis has been added to the document, but nothing has been
typed into the main text.

This text file has text content.

Scriptwriting documents.

These variations of the above icons indicate that the text item con-
tains subdocuments, child items indented beneath them.

Folder Document Icons

A standard folder document.

The small index card badge means this folder has a synopsis added
to it.

A printed page badge indicates the folder has main text content.

Snapshot Indicators

Any of the above icon variations can be “dog-eared”. When an icon
has a flap folded over in the top-right corner, thatmeans the itemhas
snapshots (section 15.8) saved for it.

Return to chapter ⤴

7.2 Titles and Adaptive Naming
The title of an item is featured prominently in every location where items are
represented. There are many ways to change the title of an item:
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— In the binder, double-click on the item to edit its name. You can also use
the Esc key to toggle editing mode from the keyboard on and off.

— When viewing the item in the main editor, Quick Reference panel or a
Copyholder, you can click into the editor header bar where the title is
printed to edit its name (⌃⌥⌘T).1 The Return key will bring you back to
where you were typing in the editor.

— In the inspector’s Notes Tab (section 13.3), the depiction of an index card
at the top of the pane can be freely edited.

— If you would like to set the title by using some existing text in the editor,
select the text and use the Documents ▸Auto-Fill ▸Set Selected Text as Title
menu command (⇧⌥⌘T).

Youmight bewondering if Scrivener requires you to name each and every item
that you put into the binder. As you might expect from such a leading question,
the answer is no! In fact it can often be advantageous to leave the title empty
(we even have a command for retroactively nuking titles, withDocuments ▸Auto-
Fill ▸Clear Titles).

Upgrading from Scrivener 2

If you’ve been using the iOS version of Scrivener, you may have already
seen this new behaviour in action, and you can probably skip this sec-
tion. All you really need to know is that Scrivener on the desktop now
supports that same method fully, and you can more freely leave items
without titles in all contexts.

When in effect, the title will be displayed in a grey italic text treatment (typi-
cally used in software to indicate placeholder text), usingwhatever content it can
find to give the item a “handle”. Adaptive naming works by checking for avail-
able text in a few different places, using a descending list of sources. If a source
is lower on the list, that means anything above it will be displayed instead:

1. The title: obviously, if you have given an item a name, we’ll use that name
wherever we can.

2. The synopsis: if an item has a synopsis typed in, then the first line of its text
will stand in for the title in those placeswhere the synopsis is not otherwise
shown.

3. Main text content: any text foundwithin themain content areawill be used
if the item has neither of the above. If your text files start with a heading,
this can mean not having to worry much about meaningful names at all.

1 If you are viewing multiple items in Scrivenings mode, only the latter portion displayed after
the colon is editable.
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4. Placeholder text: finally, if an item has none of the above typed in, then
it will simply print “Untitled Document” or “Untitled Folder” in all places
other than the corkboard, which itself will display an entirely blank card.

How this information is printed depends upon the context, but in general the
rules are simple: if a thing needs to be represented by a line of text (such as in
the binder), then preview text will stand in for the title, where it will be printed
in grey italic text.
If the view also contains other information (like the synopsis part of the index

card on the corkboard or outliner, or the main text itself in Scrivenings mode
with View ▸Text Editing ▸ShowTitles in Scrivenings enabled), then the slot ordinar-
ily occupied by the title will either be left blank or will be collapsed.

Figure 7.1 Adaptive item naming in action on the corkboard.

On the corkboard (Figure 7.1), titles will only ever be printed in the title area
of the index card if you’ve given the item a title yourself, such as in the top left
corner. In the lower left we see the synopsis area filledwith text coming from the
main editor. If you prefer to use the corkboard as an overview of the text itself
rather than a place to jot down summaries to yourself, then leaving the cards
blank will seamlessly do that for you. Finally on the right we have a card with
nothing added to it, and no text written for it.
If you would like to make adaptive synopses permanent, use the Docu-

ments ▸Auto-Fill ▸Set Synopsis fromMain Textmenu command (⇧⌥⌘ I).
How adaptive naming will be calculated in the outliner (Figure 7.2) depends

upon whether synopses are being shown within it. Named documents will use a
bolder title by default, with the synopses in a smaller and slightly greyer font. If
the item lacks a title, the area where the title would normally be printed will be
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Figure 7.2 Adaptive item naming, according to whether synopses are (a)
shown or (b) not.

collapsed and just the synopsis will be shown. Finally the synopses itself will use
content from the main text only if the document does not have a title.
The binder, editor header bars, text links and other cases where a thing would

only have the title to represent it, all follow the same rules used by the outliner
when synopses are hidden. E.g. if a document has a synopsis but no title, in
a Quick Reference panel (section 12.6) it will display the first few words of the
synopsis as a placeholder title in its header bar.

Do Adaptive Titles Export?

Adaptive names will be used when exporting individual binder items via
the File ▸Export ▸Files…menu command. Otherwise, these are not real ti-
tles, they are meant to be useful tokens of representation while working
in the project. Thus, by default they will not be included in the compiled
output as a formal title. This policy can be changed as part of your com-
pile format settings, in the compile format pane (subsection 24.2.2).

Return to chapter ⤴
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7.3 Folders are Files are Folders
Earlier we discussed how Scrivener uses folders and files like your desktop com-
puter does, but let’s take a look at a few important differences between the simple
approach used by file systems, and how Scrivener as an outliner works.
To start, we should take a fresh look at what a folder really is in Scrivener:

1. Select a folder in one of your projects by clicking on it in the binder. You’ll
probably get a corkboard viewof its child items or perhaps an outliner view
if that is how you have things set up. This is all pretty straight-forward
and not too unlike viewing the contents of a folder on your disk, but what
happens if you close the corkboard?

2. With the folder still selected, click the currently activeGroupMode button
(you can tell which mode is active by its shaded background) in the main
toolbar, the View menu or use the respective keyboard shortcut. This will
disable the current group view, bringing us to a blank view with a blinking
cursor that looks suspiciously like an empty text document. In fact, that’s
precisely what it is.

3. Type in some text and see what happens: the folder’s icon will have
changed, now sporting what looks like a little page of paper in its corner
(Figure 7.3).

Figure 7.3 This folder icon indicates that you’ve typed text on the folder’s text
file itself.

Let’s try something a little more radical:

1. Right-click on the folder in the binder and select the command, “Convert
to File”. The icon will change to a stack of papers.

2. Delete the line youwrote in that item and it will turn into a stack of empty
papers.

3. Go ahead and right-click and select “Convert to Folder” to get it back the
way it was. You didn’t lose any information, the only thing that changed is
the underlying type of the item, which doesn’t mean asmuch as youmight
now suspect.

When an item has other items beneath it, but it is a file, it is referred to as a file
group (or sometimes “a document with subdocuments”, when we’re being really
formal about it). Fundamentally it can behave as a folder does, you can even use
the View ▸Corkboardmenu commandwith a file group selected and view its child
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items as index cards. This documentation will often refer to either folders or file
groups as “groups” or “containers”, when the distinction does not matter.
If the concept of putting files in files doesn’t make sense yet, try this:

1. Select one of your files in the binder.

You should see its text appear in the editor as you always do.

2. But let’s do the same thing we did earlier with the folder and toggle cork-
board view. This time instead of toggling it off, we’re toggling it on.

It will be empty, but you are now looking at the corkboard for that file.

3. With the focus in the Corkboard, add a new document to it.

An index card should appear, just as if you were adding items to a folder.
In the binder, you’ll notice that the icon for this file has changed to the
aforementioned stack of paper. You can do this with any kind of file by the
way, you can even organise PDFs on one master PDF’s corkboard.

What is all of this flexibility good for? You don’t have to be thinking in terms
of constrictive structural elements (like chapters and sections and scene) as you
flesh out the skeleton for your book from fragments of text and snippets of dia-
logue. You can add items as you go, build out new corkboards and change things
to folders or back to files once a structure begins to emerge—it’s up to you. Scriv-
ener lets you work the way you find most comfortable.
In Scrivener, the concept of what is a group is fluid. It’s an important con-

cept to grasp, because organising your book will inevitably mean a hierarchy of
documents, and wherever that hierarchy takes you it will take so in the form of
folders, or their cousins, the file group. The concept of hierarchy is important,
because itmeans you can keep the parts of the book you aren’t currently working
on tucked away, and that means you can feel free to break things down as far as
youwant, nomatter howmany hundreds of items youmake in the binder, if you
sort things into folders (or file groups!) you can always keep the clutter at bay.
For more, read What is Outlining? (section 6.1).

7.3.1 Tips for Using ViewModeswith Folders and
Files

When toggling view mode settings on files, folders and file groups, there are a
few special cases to keep in mind:

— When the view mode has been explicitly set to single text file mode—if
you turn off the corkboard to edit a folder’s text—then the viewmode will
remain text-only until changed, no matter what type of item you click on
in the binder.

— There is no underlying item to edit when selectingmore than one thing in
the binder at once, so if the preferred group view mode is off as described

118



7.4. Custom Icons

in the previous point, then Scrivenings mode will be used as a fallback for
text, and the corkbord for media items.

— It is possible to lock a view mode for a specific folder (subsection 12.2.2),
meaning whenever you revisit the container in the future it will always
override the preferred viewmodewhile viewing it (but itwon’t change your
preference in doing so).

— If you’ve been experimenting along the way, you might have noticed that
files with subdocuments are treated differently from folders in that they
go on acting as files when you click on them in the binder. If you’d prefer
all containers to act alike in Scrivener, try the Treat all documents with
subdocuments as folders option, in the Behaviors: Folders & Files settings
pane (subsection B.4.5). This opens up additional features as well, other-
wise exclusive to folders.

Return to chapter ⤴

7.4 Custom Icons
Custom icons can be used to embellish the appearance of your binder items.
Anything can have a custom icon, even the three root folders: Draft, Research,
and Trash.
There are a few ways you can change the icon for an item:

— Select one or more items in the binder sidebar, corkboard or outliner, and
use the Documents ▸Change Icon submenu. This also works while viewing
an item in the main editor, or within a Scrivenings session.

— Access the item’s contextual menu, and use the “Change Icon” submenu.

— Use the quick icon selection menu by holding down the Option key when
right-clicking on it.

— If yourMac comes equippedwith aTouchBar, you can add the Icon button
to the binder and group contexts for easy visual two-touch access to the
icon list.

The icon menu is organised into two major parts. The first part displays up
to five of the most recent icon selections you’ve made, so you can quickly use
them again (if you have never used the feature before, you won’t see this yet).
The recent icon list is retained between sessions, and is universal to all of your
projects. The second section in themenu displays sets of icons, grouped together
to save space, and finally all of the remaining ungrouped icons that are available.
To remove a custom icon assignment, resetting it to its default binder icon,

select Documents ▸Change Icon ▸Reset Icon to Default, located at the top of the
menu.
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Setting an icon over and over?

If you find yourself using a particular icon frequently, you might wish to
make a document template (subsection 7.5.1) for it, so that you do not
have to constantly re-apply icons to new files or folders. Additionally,
since these are all located in the main application menu, you can make
use of custom keyboard shortcuts (section A.1) to assign a hot key to a
specific icon.

7.4.1 Creating YourOwn Icons
In adding your own icons to Scrivener youhave the choice of installing them into
individual projects or making to them available to all of the projects you use. To
add an icon

1. Load the icon manager with Documents ▸Change Icon ▸Manage Custom
Icons…

2. Then either:

a) For global icons made available to all projects, click the+ button be-
low the lower table. Icons install this way will only be visible while
using this computer account.

b) For adding icons to the current project use the + button below the
upper table. These will be visible no matter where you take the
project, but will only be available to that project.

Naturally, if you install them into both panes then they will be available
wherever you go and to every project.

3. Find the graphics file you wish to convert to an icon with the file chooser,
and click the Open button. If the graphics file is too large or the wrong
shape, Scrivener will automatically resize it for you.

You can also drag and drop images into either list to import icons.

Tips for Sharp Icons
After you add an icon to the manager, what you see in the window is what you
will see in the binder and other views. If the icon looks distorted or blurry to
you in this window, then it will look that way everywhere. You can remove a
bad attempt and try again using the following tips for creating sharp and great
looking icons:

— Common problems are files with lots of white or transparent padding
around them. Open these files in a graphics editor (even Preview will do
for simple cropping) and use the software to cut out the excess padding.
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— Transparent backgrounds will always be best, so that the icon blends in
with the various elements of the user interface where it will appear.

— The optimal icon size is 90px× 90px. This will ensure they look good on
all devices and platforms, including iOS. If that is not a concern:

– For icons on high-resolution screens, use 32px× 32px.

– For icons on low-resolution screens, use 16px× 16px. Inmost cases it
is better to use high-resolution icons, as the amount of scaling down
to 16px will be minimal.

— These dimensions refer to the literal size of the graphic rather than the
visual part of it. The built-in Scrivener icons are a few pixels smaller than
that to make space for some of the taller icons. Therefore if you want your
custom icons to fit in with the stock icons, it is often best to size them a
few pixels smaller with a little transparent padding around the graphic.

CreatingHigh-Resolution Custom Icons
If you intend for your icons to look good on both Retina and standard displays
youwill need to supply two different icons (16px square for standard; 32px square
(at 144 DPI) for high resolution). Importing a dual-purpose icon is simple:

— Name the low-resolution version normally, like “Name of Icon.jpg” (you
will see “Name of Icon” in the interface).

— Name the high-resolution version with the same name, only adding “@2x”
to the end of the name, like “Name of Icon@2x.jpg”.

— When both are imported simultaneously into the icon manager, they will
be combined into a icon for you. The appropriate version will display de-
pending upon your display resolution.

These icons will not appear on iOS

Although the above instructionswill produce the best results on thedesk-
top versions of Scrivener, they will not appear on iOS when created this
way. If it is important that you see your icons on that platform, you’ll
want to use the larger 90px × 90px icon size. The other platforms will
need to resize the images down to size and this can result in a minor loss
of quality.

Creating YourOwn Icon Sets
How you name your custom icons will determine whether or not they are
grouped together as a set in the custom icon menu (like the built-in “Flag” set).
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The format for this naming convention is “Category (Icon Name)”, such as “Flag
(Blue)”. This causes this particular icon to be grouped together with the Flag set
and displayed in the menu as “Blue”.

Making Icons iOSCompatible
Naturally, icons that are installed on your computer will not appear on iOS if
you take your project to that platform. However if you load your icons into the
project, it will use them if it can (section 7.4.2).
The iOS version of Scrivener uses a different size icon than either macOS or

Windows versions. This canmean thatmaking an icon that looks crisp and clean
between all platforms isn’t viable, but a reasonable compromise can be made by
using the larger 90px × 90px size and letting each system downsize it dynami-
cally for you.
Graphics that are too small, such as those that came from older versions of

Scrivener, cannot be displayed on iOS without considerable loss of quality, and
so they will not be displayed.

Icons fromOther Sources
UsingMac Finder Icons

Many icon packs for theMac are distributed as Finder icons. If you would like to
use an icon that you have seen in the Finder, the easiest way to create a custom
icon for it is to follow these steps:

1. Select a file in the Finder that has this icon.

2. Press⌘ I to get info on that file.

3. Click once in the small icon in the upper-left corner of the info palette.
You will see a halo surround it when it is properly selected.

4. Press⌘C to copy the icon.

5. Open Preview.app and press⌘N to create a new file off of the clipboard.

6. You will probably see several options to choose from in the sidebar. Select
the 32 pixel 144 DPI image for retina, 16 pixel 72 DPI version for standard
(you’ll want both if you are making a hybrid icon as described above)—or
if you wish to create an iOS compatible icon, choose the 128 pixel 72 DPI
version.

7. Press⌘C once again to copy the single icon choice; and then⌘N to create
another new document from the clipboard with just this version of the
icon.
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8. If you chose the 128 pixel version, use the Tools ▸Adjust Size… command to
resample the graphic down to 90px× 90px. Otherwise, you can skip this
step.

9. Now you can save this icon to your Desktop or some other convenient
location. It is best to use the PNG or TIFF format, leaving the “Alpha” box
checked.

Using Emoji for Icons

You can use Emoji, or indeed any character at all including Unicode symbols or
regular letters and numbers, as icons in Scrivener. These will be visible on iOS
as well, and owing to their scalable size, will be crisp on all screen resolutions.
To create an icon from a character:

1. Select the binder item you wish to apply the new icon to.

2. Use the Documents ▸Change Icon ▸ Icon fromText…menu command.

3. Insert the character you wish to have turned into an icon. (The “Emoji &
Symbols” palette will be opened for your convenience, simply double-click
on the icon you want to insert it into the text field.)

4. Click the OK button.

Text based icons will be listed in the Documents ▸Change Icon ▸ submenu, un-
der recently used icons, and will also be listed in a special submenu, Text Based
Icons ▸ , which will list all text based icons in use in the project. These kinds of
icons can only be added to individual projects.
If you’d like to make them available to other projects you can drag an example

item from one binder to another to bring it in—and of course you can add such
files to a starter project template so your favourites are always easily available.
Custom text icons that are no longer in use by the project will be removed

from the menu after Scrivener is closed.

7.4.2 Managing Your Icons
Icon Assignments are “Sticky”

It is good to keep inmind that when you assign a custom icon to an item,
it will remain assigned to that icon by name even if an icon by that name
cannot be located. This is what keeps your assignments safe no matter
where the project is taken, but it also means that when you rename or
delete icons and then later add them back or change their names to what
they were, old items that had been assigned to them will start showing
these icons again.
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Renaming icons
You are not stuck with an icon name if you don’t like it, but take the caution
above to heart. If you have already used this icon for some time in your projects,
all of those items referring to it will lose the assignment (unless you change the
name back), as they will only ever be looking for the old file name on the disk.

1. Open the icon manager with Documents ▸Change Icon ▸Manage Custom
Icons…

2. Double-click on the name of the icon you wish to rename.

Take care to not modify or remove the extension of the icon unless you know
what you are doing.

Removing icons
You can remove an icon from either the current project or globally from your
computer. This will not strip the assignments to that icon from other projects,
and so if you ever change yourmind and add the icon back, you’ll find all of those
items go right back to working the way they used to.

1. Open the icon manager with Documents ▸Change Icon ▸Manage Custom
Icons…

2. Select the icon(s) you wish to delete (Shift and Command work here).

3. Click the respective − button beneath the table associated with the se-
lected icons.

Copying Icons BetweenGlobal and Project
Icons can be dragged between the lower and upper sections individually, or en
masse. Icons in the lower list will be available to all of your projects; past, present
and future. Icons in the top list will only be visible to that project; however they
can be duplicates of icons that are in the lower list. If you’ve created an icon for
a project, and later decide you’d like to use it everywhere, you can simply drag
and drop it into the lower table. If you try to drag an iconwith an identical name
from one list to another, you will be informed of the collision, and confirmation
will be required before it is replaced.
When Scrivener loads your project, it first checks within the project itself for

any necessary icons, then it checks the computer. This means any duplicate
names (not graphics) in the top list will override any names in the bottom list.
To move an icon between projects, you would need to copy the icon to the

global list, switch to the other project and then copy it from the global list into
that project. You could remove the icon from the global list if that point if you
wanted to.
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Custom Icon Portability
The final thing to consider is whether or not icons will be visible off of your
computer. If you’ve been adding icons to your computer, in the lower half of
the pane, then when you take your project file to another computer all of those
iconswill not be displayed. Theywill still be assigned, but since Scrivener cannot
locate any replacement icons, they will simply be ignored until you return to the
original computer.
So when working on multiple computers, it is good idea to drag your global

icon list into the project list above. Thisway your iconswill be availablewherever
you go, and once you are on the second computer, you can drag them back into
its global list, installing them on that computer as well.
When collaborating with other individuals, it is a good idea to install custom

icons into the project package. This way everyone can see and use them.

Icons on theDisk
Scrivener checks a couple of locations for files when working with icons, mean-
ing you canmanage icons yourself directly with a filemanager if you prefer to do
so over the user interface in Scrivener. Global icons will be located in Scrivener’s
support folder, use the Scrivener ▸Reveal Support Folder in Findermenu command,
and then double-click on the “Icons” folder.
For project-specific icons, theywill be stored directly in the project itself. With

the project closed, right-click on the project file in Finder and select “Show Pack-
age Contents” to view the project’s internal folder and file structure and double-
click the “Icons” subfolder within the project’s “.scriv” folder to view your icons
directly. As always, take the precaution of backing up your project prior to edit-
ing its internal files directly.

Return to chapter ⤴

7.5 Document Templates
If you have ever found yourself creating items in the binder and repetitively
changing their settings, or wondered how our built-in templates have those
handy sheets you can use to create character dossiers and such, then the Docu-
ment Template feature may end up saving you a lot of time with a little set up.
Templates give you the ability to designate a set of binder items that can be

used to create copies of themselves elsewhere in the binder. Much as with the
Documents ▸Duplicate commands, nearly every aspect of the item will be faith-
fully reproduced when you use the template.
As a feature of your project, templates dwell within its binder, and indeed they

are otherwise normal documents right in the mix with everything else in the
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project.2 Since document templates are binder items, they tap into the full range
of customisation and connectivity that all items share. Here are a few examples:

— The various metadata, notes, keywords, custom icon, bookmarks, synop-
sis, and of course any text in the main editor.3

— Groups in the templates folder will create copies of their children as well,
making for a simple way to produce boilerplate outline structure.

— Compile settings that have been applied to the item will be carried along,
such as its Section Type (section 7.6) as well as whether it is set to be in-
cluded in the compiled product at all. (E.g. you could create a “Chapter
Notes” template, meant to be used in the Draft but not included in the
compiled output.)

— Functional settings, such as which view mode (subsection 12.2.2) a folder
should use when you click on it in the binder, writing goals, their settings
and more.

— In short, anything you can do to a binder item can be established as a start-
ing point for new items.

7.5.1 UsingDocument Templates
Unless you started with a project that already has a document template folder
designated, the first thing youwill need to do is create a place for your templates,
and then tell the project that is what you wish to use this folder for:

Setting a Document Template Folder
Each project can only have one template folder at a time. To set it up, you’ll need
a folder to start with; it can be empty or already contain a few items you wish
to use as templates (the only stipulation is that it must be outside of the Draft
folder). Once you’ve created a folder, it will need to designated it as being the
official templates folder for this project:

1. Open project settings with the Project ▸Project Settings…menu command
(⌥⌘ ,).

2. Click on the Special Folders tab.

3. Using the dropdown menu in the Templates Folder section, select the
group you wish to use.

2 A notable exception are Shared Templates, which are in fact files on the disk that all of your
projects can use as global document templates (subsection 7.5.3).
3 Snapshots will not be reproduced into the duplicated copy.
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4. Click the OK button.

The binder icon for your designated templates folder will change to indicate
its status, and all of the items indented beneath it will have a small blue “T”
badge added to their icons (Figure 7.4). This badge will be present anywhere
its icon may be used, helping you distinguish them from ordinary items in lists
like search results or collections.

Figure 7.4 Example of a Templates Folder with some file and folder-based
templates.

Someof the built-in project templateswill comewith a template folder already
set up for you. Keep an eye out for the special folder icon; wherever you see it,
you can add your ownfiles to it to expand the template capabilities of the project,
and change or remove the examples we’ve provided.

Can I save my starter templates for future use?

If you accumulate a collection of templates you often use, youmightwish
to create your own project template (subsection 5.4.3) so that everything
is all ready to go the next time you start a new work. You might also
be interested in the ability to store template files on the disk, instantly
available to all projects (subsection 7.5.3).

CreatingDocument Templates
Creating new templates is as easy as creating a normal file or folder item in the
binder. There is nothing special about these items, save for their position within
the designated templates folder, meaning you can change their status as tem-
plates by dragging items in or out of this folder.
Any type of file that you can add to the binder (which is just about every-

thing) can become a template. For many types of files this wouldn’t serve much
purpose—who needs dozens of copies of the same PDF document—but for ed-
itable documents, like Scapple boards or spreadsheet starter files, the template
feature can be of considerable use.
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How can I give templates their own default text formatting?

To cause a template to have different default formatting than what is
standard for the project (or global Settings), simply add a small amount of
placeholder text into the document template, and format it the way you
would prefer. Leave the placeholder text selected; since text selections
are copied to the new item, you’ll only need to type over the placeholder
text, rather than manually selecting and deleting it every time.

CreatingNew Items fromTemplates
With an active template folder and a few starter items to work with, you can
create copies of these items elsewhere in the project via the Project ▸New From
Template submenu, or by using the green + button in the toolbar. The items in
eithermenuwill be arranged precisely as they have been organised in the binder,
with groups becoming further submenus. Creating new items from templates
will follow all of the same rules and behaviours used to create built-in types like
text files and folders.
If you have a Mac with a Touch Bar, document templates will be appended to

the Add button, which by default appears on the far right hand side of the Touch
Bar in all applicable contexts.
Here are some additional tips & behaviours to be aware of:

— If you select a group from the menu, it and all of its child items, will be
created in the selected position.

— The order of items within the template folder will determine how they
appear in the menu, thus you can organise the menu directly by changing
the position of items within the templates folder.

— The topmost template item in the template folder is a special spot as it will
be given a keyboard shortcut, ⇧⌥⌘N.

— Document templates have no connection with the item that they were
modelled after. It is safe to delete or modify a template without any reper-
cussions on the items that have been created from it.

— You can move items out of the template folder that are not being actively
used. If you ever need them again, just move them back in.

It is also possible to assign your own keyboard shortcuts to other items, using
the instructions in Custom Keyboard Shortcuts (section A.1).

ClearingDocument Template Folder
Use the following instructions to clear the template folder setting:
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1. Open project settings with the Project ▸Project Settings…menu command
(⌥⌘ ,).

2. Click on the Special Folders tab.

3. Using the dropdown menu in the Templates Folder section to select “No
Templates Folder”, at the very top of the menu.

4. Click the OK button.

This action will not delete anything in your project. It will merely remove the
special status from the previously designated templates folder. It is thus safe to
switch between different folders, perhaps to facilitate different phaseswithin the
project’s lifespan.

7.5.2 Default Subdocument Template
Something youmay have noticed, from a fewof the built-in project templateswe
provide, is that when you add items to some folders they use a specific document
template automatically (e.g. the “Characters” folder in the Novel template).
To set up a folder to work this way:

1. Select the folder in the binder, corkboard or outliner (even the special root
folders Draft and Research can be set).

2. Use the Documents ▸Default Template for Subdocuments submenu, and se-
lect the desired template for this folder’s new text items.

Assigning a default template to a container will modify all of Scrivener’s or-
dinary methods for creating text files within it.4 This applies to almost all of the
actions that create new blank text files, but no actions which would result in
an item that already has an explicit identity, such as choosing to create another
document template specifically. Here are the exceptions to when the document
template would be used:

— If you import a pre-existing text file into this folder, then it be imported as
ordinary text.

— When right-clicking on the folder and using the Add ▸NewText command
explicitly, you will get precisely what you asked for, a normal text item.

Resetting Subdocuments toDefaults
To remove a default subdocument template assignment from a folder:

4 That the default template might be a folder is aside from that, it would still be methods for
creating new files that is overridden.
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1. Select the folder in the binder, corkboard or outliner.

2. Use the Documents ▸Default Template for Subdocuments submenu and se-
lect the “Text” entry at the top.

CascadingDefault Templates
Each folder (or file group as the case may be) can have its own default type as-
signment. Where subgroups are concerned, the default type “cascades” into all
subgroups, no matter how deeply nested. The exception to this is when a sub-
group within that hierarchy has its own default template assigned.

Figure 7.5 A demonstration of multiple subdocument templates in action.

In the provided illustration (Figure 7.5), a container called “Character” has
been set up to use a “Character Sheet” template as its default subdocument tem-
plate. Adding a new item to this container will result in the “Character Sheet”
template style. If that was all that had been configured, these character sheets
would create further character sheets beneath them, on account of the cascad-
ing rule. However in this case they have been set up as part of their template
definition to use the “Trait” document template for their child items. Thus it
overrides the default supplied by the “Character” folder. Any new items created
within them will automatically be “Traits”.
The subdocument default setting is itself something that will be duplicated

along with the rest of the template, and thus allow quick scaffolding of common
types.

Returning to default text at a deeper level

It is not possible to select the normal text item as a default subdocument
template. For caseswhere youwish to have a default template at only cer-
tain levels, but then revert to regular text documents at all deeper levels,
the best approach will be to create a template that is otherwise left alone
as a normal text item, that you can select as a default from the menu.
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7.5.3 Shared Templates on theDisk
For cases where you would like to provide a set of default file types for all of the
projects you use, the shared templates foldermight be your best bet. This feature
keeps watch of a specified folder on your disk, into which you can place any files
that are valid to be imported into Scrivener.

1. In the General: Shared Templates settings pane (subsection B.2.7), click
the Choose… button.

2. Select the folder you wish to place your shared template files within.

You should now see any files you place into this folder appear within the
Project ▸New from Template submenu, below any templates found within
that project, if applicable.

The important caveat is that unlike document templates that are housed
within the binder of a project, they will of course not be proper Scrivener binder
items, and their usage mimics more the process of importing a file into the
binder. So if the purpose of your template is to set metadata or set up the editor
a certain way, these will not provide a solution for you.
If for whatever reason you no longer want to use a shared templates folder,

you can click the Clear button (alongside the button that reveals the folder in
Finder) to remove the assignment.

7.5.4 Copying Templates Between Projects
If youwould like to copy some templates you created into another project, simply
drag and drop the templates folder (or individual items from one template folder
into another) between open project binders.
Scrivenerwill not copy the templates folder setting across, so if you are copying

the entire folder, you will need to set it up (section 7.5.1) after copying it.

Return to chapter ⤴

7.6 Section Types
Section Types are a fundamental component to how Scrivener works; they di-
rectly correlate to how your work will be formatted when you export it, in a
process we call “compiling”. Despite being primarily an export tool, they are
something you will want to introduce yourself to early on, because on this side
of the project, where it comes to pure writing and not worrying about format-
ting, you will still want to be aware of them as a way of categorising elements of
your work into how we will think of them as components of a book, magazine
article, thesis or whatever it is you plan to write.
To use an example from a novel, we are thinking less of how a chapter break

should look, or how a chunk of text in a scene should look, and thinking more
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on the simple fact that there will be chapter breaks and scene text (and probably
a few other elements such as these).

Shouldn’t the software do this for me?
In a word, yes. All of our built-in project templates have been designed
with a basic spectrum of types, all wired up to use those types seamlessly
in their compile settings. Nevertheless, thiswill probably be good reading
to bookmark for such a time where you want to modify those templates
or make your own projects, you will know how they work and what to
change.

7.6.1 Overview of Section Types in Practice

Figure 7.6 Section Types: example of a non-fiction oriented project with sub-
sections &c.

Figure 7.6 illustrates some example settings from a project with several types
created in the list within the first tab (on the left). These are the sorts of types you
might find in a rather involved technical document, similar to the user manual
you are reading. The second tab (on the right) shows how some of these types
will be automatically applied to the outline structure of such a project. To point
out a few details:

— The “root” level refers to the top of the binder, which is technically out-
side of the draft. These levels will not typically be compiled, but it is still
possible to assign types to them as theymay serve some purpose in compi-
lation or other uses (for example youwill often keep front and backmatter
material in separate folders outside of the draft).
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— Folders in this example are defined as having three functional levels,
“Parts”, “Chapters” and “Notes to Self”. This project has been designed
to make use of file groups for all major and minor sections within the
work. We can imagine that the 3rd level folder type would be used to
contain drafting and editing notes that will be set up to be ignored by the
compiler—not printed in the final output.

— Our file groups start out as front or backmatter, and then are used to print
unnumbered sections at the same level that chapter folders would exist,
giving us the flexibility of having a section type that doesn’t impact chapter
numbering, and potentially won’t even be in the table of contents. Beyond
that point, file groups turn into sections, subsections and so forth until
finally ending as unnumbered sections again.

— Youmight notice some types in the list on the left are not applied automat-
ically to the outline, like the Figure and Table sections. These are meant
to be appliedmanually, or perhaps as defined by document templates (sec-
tion 7.5), as you work.

— Text documents operate as front and backmatter sections when at the top
of the draft outline (we could imagine a preface being in a single file for
instance), and at all levels deeper they print straight text with no titling—
thus their separations in the output might even be invisible to the reader,
giving you a greater depth of insight into the book structure than is nec-
essary for reading it.

For a more detailed look into how these settings work and what we mean by
“levels”, refer to the documentation on the Section Types tab of Project Settings
(section C.2).
Let’s take a look at how our example will look when applied to some material

in a hypothetical draft folder. We will use an outliner view (section 8.3) with the
“Section Types” column visible (Figure 7.7). Recalling that we have the “Part”
type assigned to “Level 1 folders”, and “Chapter” assigned to “Level 2 folders”, we
can see where the folder named “Red Book” is on level one and thus acting as a
“Part”, while the nested folder beneath it on level two, “The Role of Colour in
Symbolism” is automatically assigned to act as a “Chapter”.
Italicised text in this column indicates assignments made automatically by

your settings; they are using what we refer to as “structure-based” settings. The
two examples in regular font, “Table” and “Figure”, have been manually applied
to these items, overridingwhat theywould have been otherwise, “Untitled Text”.
Would you like to use these section types as a starting point for your own

project, or maybe just to experiment with the settings we’ve discussed? Down-
load the extras pack (Appendix G) from our website, and look for the file called
“1-section_types-technical_book.scrtypes”. Refer to the instructions on import-
ing section types (subsection C.2.4) to bring them into your project.
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Figure 7.7 Some example binder items using the structure defined earlier.

7.6.2 Applying Section TypesManually
We looked into setting up your binder structure to use Section Types automati-
cally, but sometimes you’ll need to override these settings. There are three ways
to change a section type, one of which is suitable for adjusting many items at
once. All three methods use the same core menu layout, so we’ll take a look at
that first (in the meanwhile, try right-clicking on any item in the binder and ex-
amining its “Section Types” submenu, to follow along):

Structure-Based This is a built-in option that causes the item to inherit its type
based on the project’s settings. If for example the project is set up so that
all folders are assigned to the “Chapter” type, then using this setting on a
folder would cause it to act like a chapter—if we converted that item to a
file, then it would probably inherit a different section type. When items
are set this way, the name of the type they are assigned to is displayed in
grey italic text.

If the structure-based assignment is inherited from a parent folder of
the item (see Default Subdocument Type, below), rather than the global
project settings, then the name of the folder making that override will be
indicated in the Section Type selection dropdown menu. E.g. if a folder
named “Glossary” overrides the section type layout for its child items to
“Glossary Entry”, thenwhen examining the section type dropdown for one
of these files, it will read “Structure-Based (from ‘Glossary’)”.
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Upgrading from Scrivener 2

If you’ve upgraded your project from an older version of Scrivener, any
documents that had their “Compile As-Is” checkbox enabledwill be auto-
matically assigned to a “N/A” type. In the updated projects default com-
pile settings, this section type will be assigned to the “As-Is” layout, caus-
ing it to act as it did before. Refer to the Section Types, Page Breaks and
As-Is (section F.2) appendix for more information on how your projects
will upgrade to this new system.

Listing of project section types The next part of the selection menu will con-
tain a list of all section types defined in the first tab of project settings.
Choose one to manually assign a type to the item no matter where you
put it in the draft outline. Manually assigned types will appear in black
regular text, as opposed to grey italic text.

Default Subdocument Type This portion of themenu only appears when view-
ing a folder or file group. Choosing a defined type will cause all of its
child items (and their child items and so on, until another group changes
the subdocument default) to be assigned to a particular type, regardless of
project settings.

The default, “Structure-Based”, will cause all child items to use either
project settings or any default subdocument types set from folders at a
higher level.

Edit… Brings you to the Section Types project settings pane (section C.2).

Now with the choices themselves out of the way, let’s take a look at the three
places where you can make use of them.

In the Inspector

Figure 7.8 The inspector is a handy way to view and adjust the section types
of individual items.
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As shown in Figure 7.8:

a) Click the Metadata inspector tab (section 13.5).

b) Expand the “General Metadata” section if necessary.

c) Click the dropdown control to open the section type menu.

In theOutliner
Aswe have seen previously (Figure 7.7), the outliner viewwith the “Section Type”
column added to it (use the View ▸OutlinerOptions ▸SectionTypemenu command
if you don’t see it) is a great way to get an overview of the type assignments for
large groups of items. To change an assignment for an item, click into the section
type cell for that item’s row and make your selection from the menu.

With the Contextual Menu
When you need to change the section type assignment for many items at once,
the right-click contextual menu is the way to do it:

1. Select the items you wish to change in any group view or in the binder
sidebar.

2. Right-click on the selection, and use the “Section Type” submenu to
change their type.

When you have a mixed selection, the “Default Subdocument Type” portion
of themenuwill never be shown. Keep your selections confined to containers of
any type if you need access to it.

7.6.3 Combining Section Typeswith Document
Templates

Although you typically won’t have to bother with section types outside of the
draft folder, document templates (section 7.5) are one placewhere they can prove
useful. When youuse a document templatewith amanually applied section type,
newly create documents from it will also be so assigned. Here are a few examples
of this concept:

— From our earlier example, we had a “Table” and “Figure” section type. In-
stead of setting that manually every time we need to insert a figure, we
could instead use a document template, which would also set a custom
icon, a keyword so they can be easily gathered by search and maybe with
even a little boilerplate text like a place to paste in the image with a styled
caption all set up (Figure 7.9).
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Figure 7.9 A fewdocument templateswith predefined section types, including
some boilerplate, displayed in the lower half.

— Templates that are containers can also have a default subdocument type
assigned to them. If you typically need areas of your book to function dif-
ferently from what is standard, this can be a good trick for doing so.

See Also…
— Section Types (section 7.6): a basic introduction to the usage of section

types in a project.

— Project Settings (section C.2): how to set up section types in your project
settings, and optionally configure how they will be automatically assigned
to items in the outline structure.

— Section Layouts (section 23.3): how theywill end up being usedwhen com-
piling your draft to a final format.

— You can search the project for all documents of a particular type with
Project Search (section 11.1), and filter the outliner and corkboard likewise
(subsection 11.4.3).

— If you’d prefer a more hands-on approach, the Interactive Tutorial, avail-
able from the Helpmenu, also contains a step-by-step guide to building a
simple set of section types and then learning how to compile with them.
We also have video tutorials available on our site.

Return to chapter ⤴
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Part II

Preparation

The pages are still blank, but there
is a miraculous feeling of the words
being there, written in invisible ink
and clamoring to become visible.
Vladimir Nabokov



A driving goal behind Scrivener is to be your first stop when a new major
project is embarked upon. Much of its design is pitched toward tools that ad-
dress the early phases of a writing project—when you’re still putting together
basic ideas and investigatory research and you need tools that can be as vague as
you are, tools that can, as you refine your ideas, become richer andmore attuned
to the intricacies of your work in progress.
Another Scrivener principle is that what works best for your readers and even

your editor might not work best for you as a writer. As writers, we see the text
in a different way, and we have different demands on how we organise that text.
A formal table of contents is great for a reader, but is it the best tool for a writer?
What if you could have your own table of contents, one that evolved out of the
structure of the work itself, to a level of detail you require and no less or greater?
What if you could go beyond formal lists and work with keywords (or “tags” as
you might refer to them) as a method for organising work?
The level of fuzziness between preparation and writing in Scrivener is very

intentional, because the same tools you use to build up initial structures and
ideaswill be the tools you use towrite, edit, and complete your text. In Scrivener,
there is no separation between outline and book order or content. This seamless
approach will help you get straight into the writing phase, even while you are
still planning and evolving the work. Conversely, you can just easily start writing
prose immediately, and let the bigger picture emerge organically out of what you
write.
This sectionwill cover themajority of the tools that youmayuse to accomplish

these goals.
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The editor in Scrivener is a multi-function viewer, organisation and editing
tool; it is where you will be spending most of your time in the software. In this
chapter we will first cover the editor view itself, and then dive into its flexible
organisational tools, the corkboard and the outliner. For topics relating to text
editing itself, head over toWriting and Editing (chapter 15), including the ability
to edit multiple text files at once, in Editing Multiple Documents with Scriven-
ings (section 15.5).



8.1. The Editor

Looking for a basic overview?

This chapter is an exhaustive reference of what the editor is capable of. If
you’d like a quick summary of its capabilities so you can knowwhich top-
ics are of interest to you and worth further investigation, check out the
Interface in Overview (chapter 4) chapter, and in particular its material
on the editor (subsection 4.1.4).

8.1 The Editor
Before getting into what one does with content in the editor, there is plenty of
ground to cover in themany things the editor itself cando. In this sectionwe’ll go
over header and footer bars, which adapt their controls to what you are working
on in themain viewing area itself; how to split the editor in two (and the various
ways in whichwe can integrate those two panes with each other and the binder);
how to attach additional documents to each editorwith “copyholders” andfinally
some basics on viewing different types of supported research such as PDF and
media.

8.1.1 Header Bar
The header bar appears at the top of each editor pane. It is the primary tool for
project and document navigation within the editor, finding out where you are
or what you are looking at and controlling split view states of the editor.

Figure 8.1 The editor header bar

It contains the following functions; we’ll go into detail on each of them in the
rest of this section:

a) History: much as in a Web browser, scroll back or forward through the
history of documents you have viewed in this editor. You can also right-
click (or click and hold) to access a full listing.

b) Icon and Title: the icon can be dragged, producing the same result as drag-
ging the item from the binder would, and the title of the document to its
right can also be edited by clicking into the text.

c) Inspector lock & navigation: these two tools are contextual. The grey
dot with an ‘i’ in it will appear when the inspector has been locked to
this specific split (subsection 13.1.1). Clicking it will unlock the inspector.
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The second tool allows for quick navigation through scrivenings (subsec-
tion 15.5.3), and stacked corkboards (subsection 8.2.8); it’s like a table of
contents for these sessions and supported PDF files.

d) Next/Prev Documents: these buttons flip through the list of items in the
binder sidebar one by one.

e) Split view control: this button toggles split view editing (subsection 8.1.4),
and also functions as a way to flip the orientation when theOpt key is held
down while clicking.

Finding the Path of an Item

When a single item is shown in the editor, hovering the mouse pointer
over the header bar will display the “path” of the item in a tooltip. This
is similar to a file path on your system. It will show the lineage of folders
the item came from, all the way back up to the root level of the binder.

The visibility of the header bar can be toggled with the View ▸Editor Lay-
out ▸Show|HideHeader Viewmenu command.

TheActive Editor and Targeted Editor in Split Views
There are two concepts to be aware of when using splits:

— Targeting: the split that is targetedwill have an accented background. This
means anything you click in the binder sidebar will be loaded within that
split.

— Active: this is the split you are working in, or where you have clicked into
the editor last. In some cases that may not be the split that is targeted
(by default the two conditions are one and the same). The active split is
indicated by an underscore along the bottom of the header bar.

The header bar will use a background colour to indicate different states when
necessary (Figure 8.2):

1. Grey: when the editor is not split, this is simply all you’ll ever see. If the
editor is split, grey is used for whichever split is not targeted at the time.

2. Dark Grey: when an editor has been locked, it will darken and acquire a
lock icon to remind you that clicks in the Binder will not load any files into
the editor.

3. Accented:1 when splits are in use, this denotes the active and targeted split.

1 The actual accent colourwill differ depending upon the colour you select in the SystemSettings:
Appearance pane.
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Figure 8.2 Header bar status is indicated by coloured backgrounds and an un-
derscore.

Any actions taken which will impact the current editor will bemade to the
accented side, and any typing or commands you use will use this split.

4. Lastly we have the accented “underscore” itself, which indicates that this is
where you are typing, where the inspector will be pulling metadata from,
and where commands you use that impact the active editor will occur.
Since it is grey, it however will not be where binder clicks are loaded.

In some cases you can end up with an active split that isn’t currently tar-
geted by the binder, as shown. For example if you use the Navigate ▸Binder
Selection Affects ▸Other Editor, then the accented background will always
be in opposition to whichever split is active. If we used Navigate ▸Binder
Select Affects ▸Both Editors instead, then both splits are targeted, meaning
both will have an accented background, but only one split can have the ac-
tive underscore. Read more about these capabilities in Changing How the
Binder Works Persistently (section 12.2.3).

Let’s go over each of the different elements in the header bar.

History
On the left side of the header bar, marked (a) in Figure 8.1 are the history nav-
igation buttons, which should be familiar in usage from any Web browser. Use
these to navigate backward (⌘[) and forward (⌘]) through the navigation history.
If you right-click (or click andhold) on either of the arrowbuttons, amenuwill

be provided, making it easy to jump straight to something far back or forward in
the history without having to go through each point in between.
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History From Afar

Editor splits can have their history browsed through from the opposing
split even while you are typing in it. This can be a great way to effec-
tively store even more research content into your active session, as you
can seamlessly flip backward (⌥⌘[) and forward (⌥⌘]) between sources
in the other split while writing in the main split.

WithQuick Reference &Copyholders

Although there are no buttons for navigating history in these contexts, themenu
commands and shortcuts are both available for use, once the panel has been used
to view more than one thing. Unlike in the editor, panes will only store their
history lists for the duration of the session, but within that session, each Quick
Referencewindow and copyholder panewill remember its history even after you
close and reopen the pane itself.
In the case of Quick Reference panels, you wouldn’t ordinarily have changed

the content within the window, but that can be done if you make use of the
the bookmark sidebar (section 12.6.3) to navigate between a few different book-
marked documents.

Header Bar Icon
Proceeding left to right, after the navigation buttons you’ll see an icon (between
markers (a) and (b) in Figure 8.1). For binder items that you are viewing in the
editor, the icon can be double-clicked to load the item into a Quick Reference
panel, or dragged and dropped (see below).
When viewing binder items, the header bar is merely another place where an

icon is shown, but since the editor also is capable of showing things that are not
documents, there are a few other icons that you will see (Table 8.1).

Table 8.1 Header Bar Status Icons

Icon Explanation

Multiple selections (section 6.4) will display an icon in accordance with
the current view mode in use: scrivenings, corkboard and outline, re-
spectively.

The first icon indicates that you are viewing the contents of a collection
in the editor (section 10.2.1), the second icon is used for search results and
saved search collections.

This icon will be used when Viewing Snapshots in the Editor (subsec-
tion 15.8.3).
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IconDrag andDrop Functions

Nearly every depiction of an icon in the software can be dragged and dropped,
serving in most cases as a proxy for the file it represents. Here are a few practical
examples of how dragging an icon out of the editor could be used:

— Into the text of the opposing split to create a hyperlink pointing back to
the document in this split, or into that document’s bookmark list in the
inspector.

— Into the header bar of the other split to load it a second time (subsec-
tion 12.1.1).

— Into a collection tab to assign it to that collection.

— Into a corkboard or outliner view in the other split, or the binder sidebar,
to move the document to the dropped location.

There are a class of things that the editor can view that do not formally exist as
items in the main project binder. These include collections, multiple selections
and snapshots. As for the latter, it cannot be dragged from the header bar at all,
but the other two types of things have their own behaviour to be aware of:

— Collections: these can only be dragged into other header bars, for cloning
that view into the other editor.

— Multiple Selections: dragging from the header bar in this case has a very
important alternate behaviour: it drags all of the items included in the
selection. Thismakes it very easy to batch assign a selection to a collection,
or create a link list of them in a text editor but it can also be used to move
items fromwherever theymay be found in the binder to one central folder
or location.

The order in which the items will be conveyed will relate to their original
binder order. If youwish to drag a group of items and have them conveyed
in their sorted order you should select them from the outliner view itself.

— Snapshots: snapshot icons cannot be dragged.

Header Bar Contextual Menu
The main editor header bar itself can be right-clicked (anywhere except for the
history buttons, which have their own right-click functions) to reveal a contex-
tual menu with a number of commands from the main menus, but also some
unique commands you won’t find elsewhere. The following is a listing of all the
commands that are available and their uses:

Reveal in Binder Displays the location of the currently edited file in the binder,
opening the sidebar and switching to the binder if necessary (you can also
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use the ⌥⌘R shortcut). It will also expand any containers to reveal the
position of the item if it is nested. When used from the icon header bar
menu with a multiple selection, all of the entries included in the selection
will be highlighted in the binder.

This is most useful when the method you used to arrive at the current
document did not involve clicking in the binder (such as using the history
navigation buttons or using a link), or if you are currently viewing a col-
lection and wish to find where the file is actually located in your project
outline.

Reveal in Collection If the item is located within any collections (even search
results collections), then this submenu will list them. Selecting one of the
options in the menu will open that collection in the binder sidebar and
highlight the document within the list.

Given that it also finds copies from search result collections, projects with
a large number of items or several saved search collectionsmay experience
a little lagwhen displaying the contents of thismenu to allow time for each
search tab to refresh in the background. If you are only interested in seeing
which manually organised collections an item comes from, it will be more
efficient to use the Documents ▸Add to Collection ▸ submenu and refer to
which collections are greyed out (as you cannot add an item to a collection
it is already in).

Reveal in Other Editor If the item you are viewing in the editor is listed in the
other editor—for example if the other editor is showing a corkboard with
this document somewhere in it—then this command will be available and
it will function precisely as Reveal in Binder does, only targeting the other
editor’s view instead.

Path Operating in a fashion similar to Reveal in Binder, this command instead
allows you to select and reveal from the full path of the current document.
The top entrywill always be the current document; the entry below that its
immediate parent; and so on until the root of the project binder is reached.
When a selection from this menu is made, in addition to revealing the se-
lected item in the binder, it will also be loaded into the main editor, re-
placing whatever you were viewing previously.

This command always works on individual files. When a Scrivenings ses-
sion is in use, the active portion of the session that you are currently work-
ing on will be revealed in the path.

Go To Document This menu functions precisely the same as the Navigate ▸Go
To ▸ submenu does (section A.7), and is thus provided as a convenience to
using the main application menu. If the binder is hidden or you would
rather not scroll and open folders, for instance.
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Go To Collection This menu functions precisely the same as the Navigate ▸Go
To ▸Collection ▸ submenu does, and is thus provided as a convenience to
using the main application menu.

Take Snapshot If the current thing you are viewing in the editor is text, this
command will take a snapshot (section 15.8) of the text in the main editor
and archive it for future reference. This command always impacts only
one text file. When used in a Scrivenings session, only the active portion
of the session your cursor is currently within will be saved to a snapshot.

View Snapshot in Other Editor or Copyholder The next two submenus pro-
vide the same exact contents, listing any snapshots found for the current
document. Selecting one of the entries will load the specified snapshot
in either the other editor, opening a split if necessary to do so (you can
read more about that capability in Viewing Snapshots in the Editor (sub-
section 15.8.3)). The second menu option will of course load the snap-
shot into the current editor’s copyholder (subsection 8.1.5). Hold down
the Option key to load the snapshot with comparison mode engaged (sub-
section 13.6.4).

You can also drag anddrop snapshots into eithermain editor or copyholder
header bars.

Reopen previous Copyholder document If the current split has previously had
a Copyholder attached to it during this session, the last document that
was viewed within it will be listed in the contextual menu, at this position.
In this way, you can close and reopen the Copyholder without having to
worry too much about looking things up again.

Match Split Documents Opens viewed content in the other editor, in essence
cloning the viewofwhat you are looking at, alongwith viewmode settings.
E.g. if you have a corkboard view on the left editor and a Scrivenings ses-
sion on the right, then using this command on the left editor would cause
the right editor to show a corkboard as well.

You can also drag and drop the icon into the other split’s header bar to
clone the view, though in that case the group view mode of the editor will
be preserved.

Lock In Place Locks the active editor so that no binder clicks or other external
navigation requests will affect it. When an editor is locked, its header bar
will turn dark grey (subsection 12.2.1). This can also be done with the⌥⌘L
keyboard shortcut.

Lock Inspector to Editor Refer to Locking the Inspector (subsection 13.1.1) for
information on how this works.

Lock Group ViewMode When viewing a container or collection group, this
command will be activated. It will lock the currently used view mode for
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this container so that it will always load as you left it, nomatter the current
preferred view mode of the editor (subsection 12.2.2).

Header Bar Title
Continuing along our journey of the header bar, we arrive at the name of the
thing being viewed itself, marked (b) in Figure 8.1. As you navigate through the
project, the title here will update to reflect the current contents of the editor.
In most simple cases, it will display the title of the document you are currently
viewing or editing.
When viewing a group of items in a corkboard or outliner, the name of the

viewed container will be displayed (not anything selected within it). In the case
of a Scrivenings session, the name of the container will be displayed first, in grey
text. Suffixed to the container name will be the name of the current document
you are editing within that session.

Editing the Title

Click into the text area, make your edits and then press Return to confirm the
changes, sending the cursor to the editor viewer area. You can also use the Navi-
gate ▸MoveFocusTo ▸HeaderBarTitlemenu command (⌃⌥⌘T) tomove the cursor
and edit the title without using the mouse.
In Scrivenings mode the title will be both grey and black. You can interact

with the black portion of the title field (Figure 15.5).

Inspector Locked to Editor Indicator
The button under the (c) marker in Figure 8.1 will appear when the inspector has
been locked to this editor split, and thus serves as a visual indicator of which split
the inspector is making use of. You can click the button to dismiss the lock.

Content Navigation Button
The button on the right side, marked (c) in Figure 8.1, makes it possible to navi-
gate within certain types of content displayed in the editor. It will appear under
four distinct conditions:

— If the editor is displaying a Scrivenings session (section 15.5), this is the
“Jump to Scrivening” button. One entry for each chunk of text (or “scriven-
ing”) will be displayed, offering quick navigation within a section, or mere
reference of where you are within the overall session.

— When viewing a stack of corkboards (subsection 8.2.8) the tool will gener-
ate a list of every corkboard in the list, so you can quickly jump from one
to the next or see where you are in the stack.
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— In Outliner mode, each container will be listed so you can jump straight
to a certain spot in a large outline.

— If viewing a PDF file that contains a built-in table of contents, that listing
will be shown in this menu, and can be used to jump directly to sections
within the PDF.

In all cases the usage of the tool is identical:

1. Click the button to load a miniature “table of contents” for the session.
This will be in indented format for clarity, and thus is also a way of check-
ing what level you are currently at within a long session.

2. Use the mouse to click on a desired section, scrolling the view to the place
where it begins in the text. You can also use the arrow keys to sequentially
move through the session contents.

3. When you are finished using the tool, click anywhere outside of it to dis-
miss.

Outline Navigation
Next, you will find two chevron style arrows pointing up and down, under the
(d) marker in Figure 8.1. These arrows provide sequential navigation within the
project sidebar (be it the binder, search results or collection list).
Clicking the up arrow (or using the ⌥⌘↑ shortcut) will move you to the doc-

ument immediately above the current document in the sidebar. The selected
document will always be the one immediately above, even if that item is cur-
rently hidden and on an entirely different hierarchical level. Clicking the down
arrow (⌥⌘↓) will always move you to the document immediately below the cur-
rent one.
If you are viewing a container as a Scrivenings session, the behaviour of this

feature will modify slightly, in that the current session will not be dismissed. It
thus can be used as a form of navigation within a Scrivenings session. For more
information, refer to Quick Navigation Through Scrivenings (subsection 15.5.3).

Split View Button
The last button on our tour, marked (e) in Figure 8.1, is a multi-purpose button
for controlling editor splits. What will happen when you click on it will change
depending upon the current layout of the projectwindowand your last used split
orientation.
The function of the buttons as shown in Figure 8.3 are:

1. Changes the split orientation to horizontal (with one editor above and an-
other below), opening a split if necessary. You can also use the⌥⌘= short-
cut.
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Figure 8.3 The three split button states: split horizontal, vertical and close
split.

2. The same as the above, only splitting vertically (with one editor on the left
and another on the right). You can also use ⌘”.

3. Returns the editor to a single view, closing the opposing split. You can think
of it as a way of selecting which view to keep around. The keyboard short-
cut⌘ ’ can be used, and whichever editor is currently active will be the one
retained.

To see the first or second button state while splits are open, you will need
to hold down the Option key. This also has the effect of rotating which split
orientation will be used to split the interface when no split is yet open.
See also: Splitting the Editor (subsection 8.1.4).

8.1.2 Footer Bar
Below each editor pane is the footer bar. This is themost dynamic element of the
editor, in that it will change depending on the type of document visible and the
current editor mode. Where the header bar is mostly geared toward managing
the editor itself (navigating to different documents, locking the view, etc.), the
footer bar generally concerns itself with manipulating or providing information
about the content in the editor.

Figure 8.4 The standard text editing footer bar includes: text zoom, statistics,
goal tracking and compile status.

This section mainly focusses on the footer bar’s features in text editing mode,
as well as general buttons available to the group viewmodes, corkboard and out-
liner.

— For information on the various other document footer bars, see Viewing
Media in the Editor (subsection 8.1.3).

— For details on how to use the footer bar in script mode, see Scriptwriting
(chapter 19).
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As with the header bar, the footer bar can have its visibility toggled with
View ▸Editor Layout ▸Show|Hide Footer View.

Group ViewControls

Figure 8.5 The footer bar controls for outliner and corkboard.

Both the corkboard and outliner will feature the same cluster of controls on
the left side of the footer bar (Figure 8.5):

— The + button creates a new text item—the same as would do when using
any of the other methods for doing so, such as ⌘N or Project ▸NewText.

— The button to its right creates a new folder in the same fashion as
Project ▸NewFolder.

— The button provides the same convenience commands found when
right-clicking on a card or outliner row directly, and thus requires a se-
lection.

— Next, the auto-load button is used to link this group view with either the
other split or this editor’s copyholder. See Linking Splits Together (sub-
section 12.2.5) for more information about that capability.

— Finally the number of items being shown is printed for your information.
When there are selected items in the view, it will also print howmany you
have selected.

Figure 8.6 The right-hand side of the editor footer bar in corkboard mode.

Corkboard Footer Bar Buttons

The corkboard will have a few additional buttons on the right-hand side of the
footer bar (Figure 8.6):

1. The first set of buttonswill change depending on corkboard settings. Refer
to The Corkboard Modes and its Footer Bar (subsection 8.2.2) for details
on all but the last button.

2. The final button provides settings for changing the size and layout of index
cards (subsection 8.2.6).
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Outliner Footer Bar Buttons

The outliner features two special buttons on the right-hand side of the footer
bar:

1. The first will centre the content of the outliner horizontally in the editor
view (subsection 8.3.9).

2. The second button toggles whether synopses are shown in the main Title
column.

Text Zoom
Text content will display a percentage-based control on the far left. Using this
you can make the size of the text larger or smaller without changing the font
(subsection 15.3.1).

Real-Time Text Statistics
When editing text (save for when using Scriptwriting mode), the middle of the
footer will display statistics about the text you are editing, andwill be updated in
real-time as you type. The displayworks for all visible text, even if it would other-
wise not be compiled, andwill aggregate all text togetherwhenusing Scrivenings
view. This counter will also display the statistics for the current text selection if
one exists. When the counter is displaying selected text, the colourwill turn blue
to indicate that it is no longer counting the entire editor.
The statistics displayed in this area are set by the Live counts show option in

the Editing: Options settings pane. Pages will only be counted when using Page
View (section 16.2).

Extended Text Statistics

Clicking in the statistics area will reveal a pop-over, which will display additional
information, such as estimated reading time, but more importantly, it provides
a quick count without inline footnotes or annotations (by default).

Counting the Current Section in Scrivenings

If you need to get the count for the current section you are working on
within a Scrivenings session, you can use the selection counting feature
mentioned above in conjunctionwith the Edit ▸Select ▸SelectCurrentText
command (⌥⌘A). This will conveniently select only the text of the cur-
rent section you are editing.

Text Goals
When editing a single document in standard (not scriptwriting) mode, a small
target iconwill appear on the right side of the footer bar (Figure 8.4). This button
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display options for setting the word or character goal you intend to achieve in
the current text section. Refer to Document Goals (subsection 20.1.2) for further
documentation on this feature.

Included in Compile Indicator

Figure 8.7 Whether a document will appear in the final compiled output is
indicated by this icon.

The last element on the footer bar, which appears in text editing mode for all
text and folder items in the binder, is an indication of whether or not the active
document will be included in compile. When the icon has a small checkmark
in the corner it will be included in the output (unless other conditions exclude
it, such as selecting a different chapter as a target). A small “X” icon means this
document will not be included.
This can also be changed in the inspector’s metadata tab (section 13.5), as an

outliner column, and in the compile overview itself.

8.1.3 ViewingMedia in the Editor
The editor is capable of viewing many of the file types that you will need for
research and creative use, and as such, Scrivener has been designed to work as a
central hub for such materials. Sometimes you will want a more capable viewer
or editor however, and being able to easily load files into such environments is
essential:

Figure 8.8 The editor footer bar contains useful buttons for external editing.

— With anymedia file selected in the binder, or from the active editor, use the
Navigate ▸Open ▸ in External Editor command (This command is also avail-
able from the binder contextual menu.).
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— In the footer bar of the main editor, click the ↪ button to load the viewed
item into an external editor Figure 8.8.

— If you right-click on this button you will be presented with a list of all the
installed applications that claim to be able to work with this type of file.
Choosing one of these will present you with the option of either:

– Loading the current item alone in that editor from now on, by click-
ing the No button.

– Always loading this type of file in the selected application, from all
projects in Scrivener, by clicking the Yes button.

Changes made to the file will be saved within the Scrivener project directly.
If Scrivener is capable of previewing the material in its editor, it will provide a
refresh button in the rightmost position of the footer bar.

Viewing Images
The image viewer is displayed in the main editor area whenever an image docu-
ment is selected or opened.

Zooming and Rotating Viewed Images

The current magnification of the image will be displayed in the footer bar of the
editor, along with the customary controls for external editing and refreshing.

— Pan around within a large image by clicking and dragging with the mouse.

— Zoom in and out with the standard View ▸Zoom ▸ commands and shortcut
keys.

— Further zoom and rotation settings can be accessed by double-clicking
anywhere within the image, bringing up the Image Tools palette (Fig-
ure 8.9).

The slider at the top of the palette adjusts themagnification of the image. The
button to the left of the slider zooms the image as far out as it will go (that is,
makes it as small as possible). The button on the right of the slider zooms the
image as far in as it will go (makes it as large as possible).
Below the slider, tick the Scale to fit option to have Scrivener keep the im-

age sized within the editor at all times. This will disable all other magnification
commands for this image (including manual zoom).
The Flip Horizontally and Vertically checkboxes will display the image in-

verted by that axis.
The remaining buttons, from left to right:

1. Rotate the image by 90° clockwise (or anticlockwisewhenOption-clicked).
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Figure 8.9 Double-click on an image to bring up the “Image Tools” palette.

2. Fit the image to the current viewable area as a one-time adjustment, leav-
ing you free to change the size manually.

3. Lastly, reset the magnification of the image to 100%.

Viewing PDFs
Themain editor serves as a basic PDF viewer, suitable for referencingworkswhile
you write.

Figure 8.10 Editor footer bar displaying PDF controls.

The PDF view is displayed when a PDF document is selected. You can control
the display of the viewer via controls provided in the footer bar, and with the
contextual menu when right-clicking anywhere within the viewer.

— Use the page selector on the left to skip from one page to the next with the
arrow buttons, or jump directly to a page by clicking on the paper icon and
typing in a number. Unlike the standard scrolling and PgUp/Down keys,
these methods attempt to keep each page you navigate to flush along the
top.

— Zoom settings for PDF display are not in the footer bar, but you can con-
trol the display of the PDF document via the View ▸PDFDisplay ▸ submenu,
and you can zoom in and out of it using the “Zoom In” and “Zoom Out”
controls in the View ▸Zoom ▸ submenu. You can access most of these tools
via right-clicking in the viewer.

— In the header bar on the right hand side in a PDF table of contents naviga-
tion button, as documented in the Header Bar (subsection 8.1.1).

— The middle of the footer bar shows the total page count (literal) as well as
what page you are currently viewing.
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— On the right-hand side of the footer bar, the Open in External Editor but-
ton (⌃⌘O) will open the PDF in your preferred reader. If you wish to make
edits to the PDF, such as adding notes or otherwise annotating it, you will
need to make use of this feature. Simple annotations will be displayed in
the viewer (but you will need to use an external reader to view pop-up
notes).

— Lastly, if you’ve made changes to the PDF in other programs, the Refresh
button will reload the PDF in the viewer.

Annotating PDFs

As with ordinary text, you can select ranges of text in a PDF file and high-
light them with ⇧⌘H. This tool is limited to the yellow colour. You may
also strike out portions of text using⇧⌘_. It is not possible to insert com-
ments into a PDF using Scrivener. To give a PDF file advanced treatment,
view it in an external editor via Navigate ▸Open ▸ in External Editor (⌃⌘O),
such as Preview, or Adobe Acrobat. Any changes made to the PDF, once
saved, will show up in Scrivener after you refresh the file display.

PDFContextual Menu
When right-clicking on a PDF, a number of display options will be provided.
These are chiefly documented in the View Menu (section A.6), under “PDF Dis-
play”. Additionally you will find commands for navigating to the next/previous
page, along with some useful commands for copying text, looking up the word
in Dictionary.app, or searching the Web.

ViewingMultimedia Documents
A multimedia viewer is used to display movie and sound files. From the con-
trol interface (which will appear when the mouse is moved within the viewing
area) you can play or pause themovie, change the volume, or step backwards and
forwards by a few seconds.
There are further tools to further aid transcription:

— You can use the⌘Return shortcut key to pause and resume amedia stream,
even while you are typing in the other editor.

— You may skip forward and backward by a number of seconds with the
⇧⌥⌘] and ⇧⌥⌘[ shortcuts, respectively. As with the above, these short-
cuts also work from the opposing split.

— An optional feature is provided on a per-project basis that can rewind
the playback by a set number of seconds whenever paused. Enable the
feature with theNavigate ▸Media ▸Rewind on Pausemenu toggle, and adjust
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the amount of rewind in the Behaviors: Playback settings pane (subsec-
tion B.4.8).

— The time stamp from the active media viewer can be inserted into the text
with the Insert ▸Media Time Stampmenu command.2

ViewingWeb Pages
The web view displays archived web pages, which will in most cases be a pre-
served copy of the page at the time it was imported. Even if the page changes
live, or is subsequently removed, your copy will be safely stored.3

By default, clicking on any links in the page will send the URL to your default
Web browser. If you would like to (at your own risk) make it possible to navigate
to links through Scrivener, then you can disable this restriction with the Allow
limited navigation in web pages setting in the Behaviors: Navigation settings
pane (subsection B.4.6).4 The editor history function will consider all Web navi-
gation to be one “event”. To navigate back and forwardwithin the history of page
navigation itself, use the contextualmenu by right-clicking anywhere within the
page.
When theweb view is shown, the content of the footerwill display the original

URL a as a link that can be clicked on to open the original page in the system’s
default browser. Right-click on the link to copy the URL to the clipboard.
You can increase and decrease the size of the web page font using the standard

View ▸Zoom ▸ submenu and standard shortcuts.

Viewing UnsupportedDocument Types
Scrivener will let you import files into the Binder that it cannot display in the ed-
itor. Unsupported file types will use anyQuick Look preview provided by Finder,
or the default system icon if available.

Figure 8.11 The footer bar when viewing media: Quick Look, Open in Exter-
nal Editor and Reload.

To view the file in its default viewer:

2 Modify the time stamp format in the Behaviors: settings pane (subsection B.4.8).
3 Some pages do not followWeb development standards as well as others, and youmay find they
do not archive properly or at all, resulting in missing content after a while, or even blank and
malfunctioning pages shortly after archival. There is unfortunately nothing we can do about
pages that do not load all of their content into the session you are viewing.
4 Click while holding down the Option key to invert the behaviour in settings for that one navi-
gation event.
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— Double-click the icon to load the file in the default external editor for that
file type.

— Click the “Open in External Editor” button in the editor footer bar, or
right-click on the button to select an alternate application (and optionally
set it as the default for that file type).

— Use the Navigate ▸Open ▸Open in External Editormenu command
(⌃⌘O).

— If you just want a quick preview in a floatingwindow, click theQuick Look
icon in the footer bar.

As with supported files, unsupported files are fully managed (copied) into the
project package itself.

Reloading Edited Research
When viewingmost forms ofmedia the editor will feature a “refresh” icon on the
far right of the footer bar (Figure 8.11). Clicking this buttonwill reload the file off
of the disk; something youmay need to do when editing the file externally. This
works for files that have been imported fully into the project as well as those that
have been linked from the disk using an alias.

8.1.4 Splitting the Editor
Scrivener’s editor uses a technique known as editor splitting. You may have en-
countered split screen editing in other applications, but the level of integration
and power between the two splits in Scrivener is likely to be unfamiliar.5 Rather
than arbitrarily splitting the interface any number of times and ways, the editor
uses a two-way split system designed to be capable of working together, provid-
ing one unified way of doing more than one thing at a time.

Splitting Documents

Looking for tips onhow topermanently split a document into twopieces?
Head on over to Splitting the Document (subsection 15.4.1) for further
details. Splitting the editor, as discussed here, is a purely visual tool.

If you are unfamiliar with splitting an editor in general, you can think of it as
a way of opening a second editor in which you can view text from other areas
of the same file you’re working on, or even content from another binder item
entirely.

5 Unless you have fond memories of software like Norton Commander from days of yore!
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When the same item is loaded into both splits (which is what happens when
you create a new split), any edits made to either side will be immediately shown
in the other split. Using two splits makes it easy to edit or refer to other parts of
the document without scrolling back and forth.
Loading another item into the second split makes referencing a snap. While

you could use the history functions to jump back and forth between a reference
source and the portion of yourmanuscript that you are editing, splitswill present
both items to you at once, even allowing you to play media in the second split
while recording notes or transcribing it as it plays.

How can I load things into the other split without switching to it?

You may at times want to load materials from the binder into the other
split directly (even opening it if necessary). To do so, hold down the Op-
tion key when clicking on items in the binder. The item will be loaded in
the inactive split, leaving you free to continue as you were in the primary
split. Read more about this capability (section 12.2.3).

In addition to standard file viewing and editing, you can also use splits to do
anything else that you would ordinarily do in a single editor. You can mix Cork-
board, Outliner, and Scrivening sessions together, and even link the splits so that
clicking on cards or outliner rows automatically loads the item in the second split
for you.

Horizontal and Vertical Splits

Figure 8.12 The editor can be split vertically (left) and horizontally (right).

The editor interface can be split vertically or horizontally. Vertical mode is
most suitable to viewing two text documents side-by-side as it maximises ver-
tical space. Horizontal mode creates a split with content on the top and bot-
tom. You can switch between orientations by choosing the opposite split type in
the View ▸Editor Layout ▸ submenu, or Option clicking the split icon in the editor
header bar (section 8.1.1).
When initially splitting the editor, a copy of what you’re working on will be

created beside the current one. From that point onward you can take that editor
in its own direction. Everything that you can do to a single editor window can
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be done to a split window, and those changes will be remembered for that side
of the split. An example of this would be view modes, where each side has its
own group view settings, allowing for workflows such as having the left side set
to Outliner, and the right side set to Scrivenings.
Each split also has its own persistent history queue,6 view modes, zoom set-

tings, outliner columns and so on.
You can adjust the comparative size of the splits by dragging the strip along the

middle that separates them. This can be done freely, though there are limits to
how small a split can be made. To reset the splits to be of equal width or height,
double-click the splitter bar with your mouse.

Quickly switching between editors

It is easy to jump between splits without using themouse, by using⌃⌥⌘E
and⌃⌥⌘R. The former targets the left or bottom editor, depending upon
orientation; the latter shortcut targets the right or top split. Addition-
ally the keystroke that cycles between the binder and the editor, ⌃Tab,
will include both splits in the rotation. Hint: if you’re rapidly switching
between two splits, consider temporarily hiding the binder so that this
shortcut simply jumps between the two panes.

Managing Split Views
If you wish to swap the actual position of the material in the editors (E.g. so
that the content on the left now appears on the right), use the View ▸Editor Lay-
out ▸Swap Editorsmenu command. This swaps all aspects of the editors, includ-
ing history queue, view modes, display settings and so forth.
To clone the contents of both splits, right-click the header bar for the side

you wish to clone, and select the “Match Split Document” command. This will
duplicate your current view mode (but not its settings) into the other editor.
If all you want to “clone” into the other split is the content it is viewing, then

drag and drop the icon from one header bar to another.

Controlling theOpposing Split
There are a few commands that you can use to impact the editor you are not
currently working in, reducing the need for flipping back and forth between
them. These are located in the Navigate ▸Editor ▸Other Editor ▸ submenu, and
have shortcuts for handy usage:

— Remote history access: Just as you can quickly flip through the history with
⌘[ and ⌘], you can cause the other editor to jump back and forth in its

6 The history queue is not lost by closing a split, and consequently you are never really going to
lose your place even if you close a split.

161



8.1. The Editor

own history queue with ⌥⌘[ and ⌥⌘]. A nice trick here, when working
with a sequence of reference documents, is to “pre-load” them into your
reference split by clicking on each one sequentially. Now they are loaded
into the history queue and easily accessible while you write in the other
split.

— Remote scrolling: To scroll the other text editor up and down, use ⌃⌥⌘↑
and⌃⌥⌘↓. This command does notworkwhen the other editor is viewing
corkboard or outliner views, or media that would not otherwise respond
to scrolling.

— Controlling media: While typing in one split, you can start and stopQuick-
Time movies and audio tracks with⌘Return, making this setup extremely
useful for transcription. If you have Rewind on Pause enabled (sec-
tion 8.1.3), this shortcut will also rewind the piece by a set amount (3 sec-
onds by default), making it easy to catch up.

If you’re looking for ways to integrate navigation between the two splits, for
instance so that clicking on a card in the corkboard opens it as a text editor in
the opposing split, check out Linking Splits Together (subsection 12.2.5).

8.1.5 Using Copyholders
Much like a document clip that you canmount to the side of your desktopmon-
itor, the Copyholder is a way of clipping something from the binder to an editor.
It will stick until you remove it, asmost forms of navigationwill ignore the copy-
holder.
This subordinate relationship is suggested by the header bar design. Copy-

holders use a smaller and simpler header bar that is nested within the main
editor’s. As with Quick Reference panels (section 12.6), copyholders focus on
the content of the thing you are looking at, rather than providing view modes
and the many other organisational and navigational capabilities the main edi-
tors themselves provide. E.g. if you load a folder into a copyholder, you will see
that folder’s text content rather than a group view of that folder’s child items.
Copyholders can of course be considered “active” in the same sense that an ed-

itor would be, and are indicated in the same fashion. They will never acquire an
accented header bar, which indicates binder targeting, but an accent underscore
will indicate when a copyholder has keyboard focus (Figure 8.14). When active,
commands that would ordinarily modify the editor will impact the copyholder.
We could for example zoom in and out of the image on the copyholder with the
⌘> and ⌘< shortcut keys, rather than changing the main text’s magnification
level.
While working in an editor, you can move your keyboard focus to its copy-

holder with the Navigate ▸Move Focus To ▸Copyholder command (⌃⌥⌘D). If only
one copyholder is open at that time, this will also work from anywhere else in
the project window, including the other editor.
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Figure 8.13 Copyholders extend how much material you can work with at
once in the project window. With up to two splits, each with their
own copyholder, you could be working on four items at once.

Figure 8.14 Copyholders feature a simpler header bar, nested beneath its as-
sociated editor’s.

Copyholders aren’t just about editing or viewing content. Given their nature
of remaining fixed to one thing until you change the content yourself, they are
useful as a way of marking your place; clipping an item to the side of your view
so that you can get back to it at any time, or using it to create hyperlinks in other
documents via drag and drop from its header bar icon.

Loading an Item in a Copyholder
There are a few different ways to load an item into a copyholder:

— Using the Navigate ▸Open ▸ in Copyholdermenu command. This command
is also available as a contextual menu item from an editor’s outliner or
corkboard views.
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1. Select the item you wish to load, from any binder, corkboard or out-
liner view.

2. Use the menu command to load the copyholder into the active split
(the one with an accent underline beneath its header bar).

— Click to drag an item’s icon, and while dragging hold down the Option key
on the keyboard, dropping the item on the editor’s header bar.

Most often you would do this from the binder, but nearly every icon you
see in Scrivener can be dragged to a header bar, even from a Quick Refer-
ence panel—or the very same editor itself, which would have the action of
loading the editor’s content into its own copyholder, a potentially useful
trick if you intend to navigate elsewhere, but don’t want to keep tabs on
where you were.

— Alternatively to the above, hold down the Option key prior to clicking and
dragging to have the keyboard focus moved to the Copyholder at the con-
clusion of the drag and drop.

Creating an Item from aCopyholder
If a new text or folder item is created while the focus is within a copyholder, the
item will be created relative to the binder position of the item the copyholder is
viewing, not the main editor. Otherwise, the new item will be created in accor-
dance with the normal rules for placing them (section 6.3.1).

Changing theOrientation and Size
To adjust a copyholder’s position, use the View ▸Editor Layout ▸Copyholder Posi-
tion ▸ submenu, or right-click on the copyholder’s header bar, selecting one of:

— Left

— Right

— Top

— Bottom

Your choices will be necessarily limited to the opposing orientation when the
main editors are split. This also means that a copyholder might change its ori-
entation automatically to make space for a split if one is opened in the same
orientation as it.
Click and drag on the line between it and themain editor to adjust how tall or

wide it is.
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Changing a Copyholder’s Content
Although a copyholder pane will resist most requests to change its content, in
addition to the normal methods of loading material into a copyholder, you can
manually change what you are working on with the following additional meth-
ods:

— Navigation commands, such as selecting a document from the Navi-
gate ▸GoTo ▸ submenu will navigate the Copyholder if it has focus.

— The copyholder header bar is a valid target for dropping item icons.

— When using Quick Search, pressing the Return key with the focus in a
Copyholder the result will be loaded there.

— The Navigate ▸Go To ▸Previous Document and Next Document menu com-
mands (and keyboard shortcuts) will impact the Copyholder when it has
focus. This form of navigation follows the same rules described in Outline
Navigation (section 8.1.1), only it operates from the Copyholder’s context
for determining which binder item to select.

— If the document in the main editor has other binder items bookmarked in
its Bookmarks Tab (section 13.4), then you can quickly view the contents
of these bookmarks in its respective copyholder by right-clicking on the
header bar.

Once you have viewed a few different things within the Copyholder, the stan-
dard history keyboard shortcuts (⌘[ and⌘]) can be used to flip between recently
viewed items. This history will be retained during the current session, even if
you close the Copyholder for a while.

Detaching a Copyholder to aWindow
To detach a copyholder, converting it to a Quick Reference panel, click the sec-
ond icon from the right in its header bar. Alternatively, to view the content in
a Quick Reference window without losing the copyholder, double-click on the
icon in the copyholder header bar, instead, or use the Navigate ▸Open ▸as Quick
Referencemenu command.
There is no one-click trick to embed a Quick Reference window back into the

editor, but you can drag the icon from the Quick Ref’s header bar into an editor
split with the Option key held down, and then close the window yourself.

Closing a Copyholder and Reopening Content
When you are finished with a copyholder and its content, click the × button in
the right-hand corner of pane, or use the View ▸Editor Layout ▸Close Copyholder
menu command (⌥⌘-).
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To return to a recently viewed item, right-click on the copyholder header bar
and select it from the “Recent” submenu. Thiswill list every itemyouhave placed
on this copyholder (each split stores its own recent list) during the current ses-
sion.
You can also reopen a recently closed copyholder by right-clicking on the

main editor header bar, and selecting the “Reopen ‘X’ on Copyholder” contex-
tual menu command.

Linking Copyholder Content to a Split

Figure 8.15 The corkboard in this editor has been linked to the copyholder
above it. Cards selected in the corkboard are automatically loaded
in the copyholder.

In addition to providing a more stable reference in the project window, the
copyholder feature can also be used to automatically display the content you
have selected in its primary editor. This provides a way of forming a secondary,
or even tertiary, level of navigation in your project, that donot disrupt your usage
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of the main splits themselves. The following are a few examples for when this
can be useful:

— You have a PDF you are referencing in the left split and a simple list of notes
in an outline view in the right splitwith a copyholder showing the contents
of those notes below it.

— The left split is be set to always receive binder clicks, which in turn auto-
loads corkboard or outliner clicks into the right split. Adding a copyholder
that auto-loads clicked items from the right split provides additional nav-
igation depth.

Read further on Linking Splits Together (subsection 12.2.5).

Return to chapter ⤴

8.2 TheCorkboard
The corkboard provides a familiar, visual way of viewing documents in your
binder. You can arrange index cards in direct correlation with their binder order
using either a grid view or label view, or alternatively as a freeform corkboard
where cards can be freely moved about without directly impacting the structure
of the book. You can visualise this as a bit like looking at specimens on a slide.
Each slide has a slice of a tree branch on it. To look at a different (whether deeper
or higher) portion of the branch, you’ll need to load a different slide. The cork-
board displays one layer at a time, and by clicking up and down in the binder
folder hierarchy you can view different layers, or different branches one by one.

8.2.1 SoWhat are Index Cards, Anyway?
Wewill soon explore the corkboard in depth, but first let’s take a look at what the
index cards themselves represent. A concept that can take some adjustment to
is the relationship between index cards, the corkboard and the text of the book
itself.
A good way of thinking about index cards is as a fancy kind of file icon. Imag-

ine if your file manager had a way of displaying files that let you type in short
descriptions of those files, and maybe tag them by colour or keywords and so
forth. While it can be a little limiting to think of Scrivener’s binder as a list of
“files”, it can be useful to compare them to something familiar.
In the context of the corkboard, cards help us visualise the order and structure

of the content they stand in for. Just as with a real-world corkboard, we aren’t
going to be using that to type up our text directly, we use it to help us understand
the stack of paper beside the typewriter. The difference in Scrivener is that the
card is linked to the actual text itself, so that when wemove a card from one side
of the board to another, that chunk of text is “magically” moved within the pile
of paper.
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With the understanding that the corkboard is there to help us create a map of
our text overall, and the index card describes each piece of it that is listed in the
binder, let’s take a closer look at the index card itself, as a feature.

The Three Core Elements of an Index Card

Figure 8.16 The “deck of cards” appearance means this card is a container for
other cards, or what would be represented as a collapsable group
in the binder or outliner.

At its most minimal, you’ll only see the three core elements that cannot be
removed: the icon, title, and synopsis. In this example we see a simpler card, but
another thing to take note of is the “deck of cards” appearance (Figure 8.16). This
indicates it is a container for more cards one level beneath this corkboard.

Icon This is the same icon you see in the binder, editor header bar, in bookmark
lists, search results and so on.

Double-click the icon to load this card into the main editor (or as a cork-
board if the card represents a stack of items).

Title The editable name of the item, as it will be represented throughout the
software. If this area appears blank that simply means it has no title. Try
using the Navigation ▸Reveal in Bindermenu command to see what it looks
like in that context.

Synopsis Meant to be a brief encapsulation of what the document’s purpose is,
but you can use it forwhatever you like. Some people use it to keep track of
the things they need yet to do, others keep highly visible notes about what
they’ve written so far, and some don’t even fill them in at all just leaving
them blank, letting the software preview a few lines of text from the main
text.

Whatever you end up using them for, it is important to realise that they
are separate from the actual text of the document, and in most cases what
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you type into them will not appear in the final book. If you’d prefer to use
the corkboard as an initial rough draft tool, the Documents ▸Auto-Fill ▸Set
Synopsis fromMainTextmenu command (⇧⌥⌘ I), on any number of selected
cards, will become integral to how you work.

Editing the Contents of Index Cards

— Double-click the Title area to rename the card, or press the Esc key.

— Double-click in the Synopsis area to edit it.

– UseOption-Return to add a new line, as by default Return by itself will
confirm editing on the card.

– When the card is showing a preview of the text content it represents,
the preview text will vanish when you start editing. Use the Docu-
ments ▸Auto-Fill ▸SetSynopsis fromMainTextmenu command tomake
this text editable, first, if you intend to use the preview text as a start-
ing point for your synopsis.

— Once you are editing the title or synopsis of a card, use Tab and ⇧Tab to
navigate between these two editable fields.

– This will also jump from one card to the next, in the respective direc-
tion (wrapping to the beginning or end of the corkboard).

— To stop editing and confirm your edits, press the Return or Esc key, or click
outside of the card.

Optional Index Card Elements
There are seven different components that can provide additional information
on your index cards.

1. The document icon: you should recognise one of these by now, they are
displayed in many different contexts within the project window and they
all work the same.

2. The card number: enabled with View ▸CorkboardOptions ▸ShowCardNum-
ber, this follows the icon on the first row and indicates the position of this
card relative to the other cards on the corkboard.

3. The title of the document: this area may be left blank if the item has not
been given a formal title.

4. Synopsis: the largest block of text on the card. This can also display the
first few lines of the document if the synopsis is left blank.
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Figure 8.17 A few different examples of how index cards can be displayed on
the corkboard.

5. The label colour: the strip along the left side of the card (pink in this case).
This is a default setting that can be switched off with View ▸Corkboard
Options ▸Hide Label Colors Along Edges (⌃⌘P). If you forget what a colour
stands for, hover the mouse over the strip to read its written label in a
tooltip.

6. The status stamp: diagonal text stamped along the synopsis area of the
card (“First Draft” in this case). Enable this with View ▸Corkboard Op-
tions ▸ShowStatus Stamps (⌃⌘S).

7. Keyword colours: the pieces of “tape”, if you will, along the right side of
the card indicate this card has three keywords assigned to it. Enable these
with View ▸CorkboardOptions ▸Show Keyword Colors (⌃⌘K). As with the la-
bel, you can hover yourmouse over each individual keyword colour to read
its name in a tooltip.

Also shown in Figure 8.17, it is possible to tint the colour of the entire card
based on its label, as well as the icon itself (but the latter has ramifications ev-
erywhere the icon can be seen). These options, among others, can be explored
from the View ▸Show Label Color In ▸ submenu.7

7 All of the options you select for corkboard appearance and label tinting will be saved into the
project, so if you prefer a certain look by default, consider creating your own starter project tem-
plate. Index card appearance settings can also optionally be stored in Saved Layouts (section 12.3).
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8.2.2 TheCorkboardModes and its Footer Bar

Figure 8.18 The right-hand side of the editor footer bar in corkboard mode.

The corkboard has three distinct modes of operation. The buttons along the
right-hand side of the corkboard footer bar (Figure 8.6) are used to switch be-
tween them, and control view options within them, where applicable:8

— Linear vs Freeform toggle: the first control is a simple toggle button that
switches between these modes, discussed in the two following sections.
You can freely switch between thesemodes at any timewithout losing your
settings or freeform card arrangements.

When using the freeform corkboard, an additional button will preface the
toggle: Commit. This button takes your card layout and uses it to influence
the actual order of cards in the binder (section 8.2.4).

— The Arrange by Label button is the third icon from the left, and operates as
an independentmode that can be activated from either linear or freeform.

— Lastly the Corkboard Options (subsection 8.2.6) button is where you set
up split-dependent settings such as card size andmost of the view options
for linear corkboards.

— There is one other layout of buttons that you will see in this area: when
multiple groups are selected in the binder, and corkboards are “stacked”,
then stacking display options will be provided (subsection 8.2.8).

The three corkboard modes (standard, freeform, and arranged by label) are
considered a form of per-folder viewing preference; they will stay the way you
left them.

8.2.3 Linear Corkboard
As displayed in the back of Figure 8.19 with a reddish background, the cards are
arranged in rows and columns where the first card in the folder is in the upper
left corner and the last card is at the very bottom.9

Using the linear corkboard, moving items around will change the actual or-
der of those items in the binder. This makes it very useful for getting a “bird’s
eye” view of a section of your book, and enables you to affect changes upon the

8 Most of these toggles are also available on the Touch Bar, when any corkboard has the context.
9 Well, if you are using an RTL language and have chosen to Arrange cards from right to left in
the Appearance: Corkboard: Options tab (subsection B.5.4), then the first card in the folder will
be in the top right–hand corner, of course.
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Figure 8.19 The same story told three different ways: linear, freeform and ar-
ranged by label.

ordering of that book with simple drag and drop (you can also use the ⌃⌘Arrow
keys to move cards around in the direction corresponding to each arrow key).

8.2.4 FreeformCorkboard
Pictured in the middle of Figure 8.19 with a blue background is an example
Freeform Corkboard. These have the same “single layer, single group” method
of looking at your binder structure, but they do not have a linked relationship
with its ordering. Instead, you can move cards around freely like you might on a
desk or actual corkboard on a wall (remember those?).
Freeform mode can be useful for playing with an ordering idea without ac-

tually impacting binder order. You might wish to see how a sequence of scenes
looks without actually changing the order and confusing things up in the binder,
or rearrange things according to someworkflow,moving cards to the right as you
complete some task with them.

Switching BetweenModes
To switch to freeform view, use one of the following methods:
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— Click the small “stack of cards” icon in the toggle control, in the lower-right
hand corner of the footer bar (Figure 8.6).

— Click the grid icon to its left to return to standard linear mode.

— The View ▸Corkboard Options ▸Freeform menu toggle can also be used to
switch between modes.

Switch betweenmodes as it suits you in themoment. Scrivenerwill remember
the position of your cards in freeform mode when you return to it.

Freeform toggle disabled?

In order to remember where you move cards to on the board, Scrivener
must have a place to store that information—such as the Collection you
are viewing, or the parent folder for these cards. Multiple selections of
items, or search results whichmight change fromoneminute to the next,
have no place to store card positions and the feature is thus unavailable
to them. Consider saving selected items from these contexts as a new
Collection (subsection 10.2.2).

SelectingMultiple Cards
Multiple cards can be selected with the following methods:

— Drawing a “marquee” around them:

1. Click and drag starting on the background and move the mouse to
create a rectangle.

2. Any cards that touch the rectangle will be selected when you release
the mouse button.

— Use the traditional Cmd click modifier key for adding or removing cards
from a selection individually.

Snap toGrid
Do you like how you can move cards around freely in freeform mode, but wish
you could keep things lined up a little neater? TheView ▸CorkboardOptions ▸Snap
toGridmenu toggle might suit you. This setting impacts all freeform corkboards
in the project. There are a few things to be aware of:

— Cards will not be snapped to a grid until you move them yourself.

— If you select several cards at once, only the card that your mouse was over
when you start the drag will be snapped to the grid. The rest will maintain
their original relative positioning from the clicked card.
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The grid spacing and its appearance can be changed in the Appearance: Cork-
board settings pane (subsection B.5.4).

CommitOrder
If you reach a point where you would like to make the ordering of cards perma-
nent in the binder, you can choose to commit the freeform order back to outline
order. Click the Commit button in the footer bar, or use the View ▸Corkboard
Options ▸Commit FreeformOrdermenu command.
You will be given a few options to define your ordering style. You may prefer

to lay things out left to right, right to left or top down; this panel will let you
apply the ordering no matter which way you work. Once you select an option,
nothing may appear to happen unless you were paying attention to the binder.
Committing the order will never disrupt the cards position in Freeform mode.
When using freeform corkboards for this purpose, you might find it useful

to enable the View ▸Corkboard Options ▸Show Card Numbersmenu toggle. Num-
bers will always be based upon the outline order of the cards, not their spatial
arrangement, and thus serve as a useful reference.

8.2.5 Arrange by Label

Figure 8.20 Labels form “threads” on the corkboard and dragging cards onto
the threads assigns them to that label.

The final corkboard mode is one that can be used as an alternative to either
freeform or linear corkboards. When making use of the label feature to mark
sections of your draft for one purpose or another, label view turns that particular
piece ofmetadata into a “axis”, bywhichwe can visualise the distribution of cards
along it.
Each label available in your Project Settings will be depicted as a “thread” or

track, using the colour associated with that label. Cards will be placed along that
track if they have been assigned to that label. To reference a label’s name, hover
your mouse anywhere over the coloured track to get a tooltip.
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Figure 8.21 The corkboard footer bar when Arrange by Label is active.

To switch to this mode, click the button showing two cards on “tracks” or
“threads”, to the right of the grid/freeform toggle button (Figure 8.21). You can
also use the View ▸Corkboard Options ▸Arrange by Label menu toggle. The pre-
cise name of that menu will differ if you refer to labels by another name in your
Project Settings (section C.3). If you use labels to track tension for example, it
would read “Arrange by Tension”.
When active, the button will be highlighted, as shown in the figure, and the

toggle control to the left will switch to an orientation control. Clicking this con-
trol toggles the label threads between rows and columns.

HowCards are Display in Label View
There are two axes used to display cards:

Across the tracks When viewing label tracks in horizontal orientation, such as
in Figure 8.20, the columns represent the position of items within the
folder. Column 1 is the first card in the folder, “Contents” in this case,
which does not have a label assignment. Column 2 is a card assigned to
the first label thread and is the second card in the folder.

Therefore, you can only have one card per column—havingmore than one
per column would be illogical, as it would mean two pieces of text occupy
the same position in the book.

Along the tracks Each thread represents one label in the project—and they will
be displayed in the order you configure using the Project Settings: Label
List tab (section C.3). Many cards can be assigned to the same label, or
none at all.

The first track in the view will be “clear”. This represents no label assign-
ment.

Moving Cards Across and Along Label Threads
Just as with the other corkboard views, you can freely drag and drop cards to
move them around, and as with standard grid view, movement can directly im-
pact the order of the cards among their group, so long as movement is done on
a “along the tracks”.
Referring again to our example corkboard (Figure 8.20), if we selected the card

in the second column (the one marked “Done”) and dragged it to the right of
the card in the fourth column—or the second card on its same track, the effect
would be to move it down to the fourth item in the draft folder, between “Vari-
ation Under Nature” and “Struggle for Existence” (the lone purple card in the
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fifth column. If this still isn’t making sense, it might be easier to keep the binder
open to the folder you are working in so you can see how items move within the
binder as you drag them in this view—or vice versa, how if you change the order
of them in the binder, they move in this view.

Figure 8.22 Dropping a card onto the “Finalised” label track.

When dragging a card from “across the tracks”, from one to another, we aren’t
moving it in the folder, we are changing its label assignment. The name of the
label will be printed in the outline where the card will be dropped (Figure 8.22).
Whenmultiple cards are selected andmoved together, theywill all be gathered

together so that they fall one after another in the binder itself, and arranged onto
the one label row you dropped them on.

Using the keyboard to select The arrow keys on your keyboard will move the
selection. In horizontal orientation, the ↑ and ↓ arrow keys select along
the label while → and ← keys select along binder order. The orientation is
inverted when using vertical lines to display labels instead of horizontal.

These keys can be combined with the Shift key to modify the selection in
that direction.

Using the keyboard to move cards Movement of cards is done through the
commands found in the Edit ▸Move ▸ submenu, and aswith the linear cork-
board, is done in a strictly spatial or intuitive fashion. If you press ⌃⌘→
then the card will be moved one column to the right—or having the same
effect as moving that card one slot down in the binder. The “up” and
“down” directions change the card’s label assignment.

As before, when using a vertical orientation the precise action changes, but
the spatial left/right up/down interaction is the same.

Creating Cards on a Thread
By default you can double-click directly on a track to create a new card automati-
cally assigned to that label in the position you double-click on, pushing the stack
of cards to the right (or down when using vertical orientation) to make space for
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it in the place where you double-clicked. This can be disabled in with Always
creates a new card when arranged by label setting in the Behaviors: Double-
Clicking Setting tab (subsection B.4.3).

8.2.6 CorkboardOptions

Figure 8.23 Corkboard appearance options are available in the footer bar.

The corkboard options pop-over contains settings for adjusting the layout and
shape of index cards. These settings are specific to each split, making it possible
to have a different visual appearance for each view. Any changes made will be
saved with the project, meaning you can save your preferred defaults into a cus-
tom project template for future use. They can also be stored into Saved Layouts
(section 12.3).
To access the pop-over, click on the “Corkboard options” footer bar button,

as shown (Figure 8.23). Since the interaction between some of these settings are
interdependent, here is a useful guide for adjusting the settings based on what
you want:

— For a large corkboard that ignores the width of the editor: disable Size to
fit editor, set the Card across to the desired corkboard width, and adjust
the Card size slider as desired.

— Cards that have a fixed size that wrap to the width of the editor: disable
Size to fit editor, set Cards across to “Auto”, and adjust the Card Size as
desired.

— Cards that adjust their size according to the editor width: setCards across
to the desired amount and enable Size to fit editor.

Using Zoom to Adjust Card Size

The Zoom In (⌘>) and ZoomOut (⌘<) shortcuts can be used to change
the card size swiftly and without bringing up the option panel.
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Card Size There are two ways of arranging index cards within a corkboard. The
first is to set the size of cards and then let the corkboard wrap the cards
as they fit, the second is to provide a number of cards you always want
to see in each row, and let the corkboard resize the cards to fit that num-
ber. When the latter method is in use (see below, for setting that), the Size
control will be disabled.

In the freeform and labelmodes, only the card sizemethod applies as there
is no automatic wrapping or fitting of a certain number of cards within the
view.

Ratio Determines the size ratio between height and width. By default this will
be 6 × 4, which closely emulates the appearance of real index cards. If
you write very long or very short synopses however, you might find that
adjusting this to produce shorter or taller cards will be of benefit.

Spacing This option is not relevant to the freeform corkboard mode.

The amount of space that will be drawn between index cards, both verti-
cally and horizontally. To pack more cards into the display at once, move
the slider toward the left. To spread out the cards and make them more
distinct, move the slider to the right.

Cards Across This option is only relevant to standard corkboards.

Set this to the number of cards you would like to have appear in each row.
Use “Auto” to have Scrivener determine this amount based on the size of
the cards. When Size to fit editor is disabled, it is possible for corkboards to
grow larger than the editor size, which may be desired for some purposes,
and will require horizontal scrolling in order to see the entire corkboard
contents. You can choose any number between 1 and 10 cards across, or
use the “Other…” option to specify any arbitrary amount.

Keyword chips Set the maximum number of keyword colours to be “taped” to
the right side of the index card. When a document has more than that
amount assigned to it, all keywords below the specified point (as listed in
the inspector Keywords panel) will be ignored. You may wish to adjust
the Ratio to increase the height of the index card, if you want to view
large numbers of keyword chips at once. You will need View ▸Corkboard
Options ▸ShowKeyword Colors enabled to see the effects of this.

Size to fit editor This option is only relevant to standard corkboards.

When the Cards Across option is set to anything other than “Auto”, this
optionwill resize the cards to fit the current editorwidth. With this option
off, the card size optionwill be used, and cards will be forced towrap at the
specified number regardless of the window size.
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That’s not all!
There are a number of other appearance related Settings that you can set,
which can dramatically alter the look and feel of the corkboard and its
index cards. Most of these options are located in the Appearance: Cork-
board (subsection B.5.4) and Appearance: Index Cards (subsection B.5.6)
settings panes.

If you enable theAllowdrop ons in corkboard setting in the Behaviors: Drag-
ging & Dropping settings pane (subsection B.4.4)—you’ll also be able to stack
cards with other cards, just as you would drop items onto others in the binder or
outliner.

8.2.7 Images on the Corkboard
When working in an area of the binder outside of the draft folder, it is possible
to import image files into your binder directly, and they will be displayed on the
corkboard as thumbnails of those graphics.
Images can also be used instead of a text synopsis for all other items as well.

Refer to Synopsis Images vs Text (section 13.3.1) for more information, and the
section following it for tips on adjusting the size, position and cropping of the
thumbnail image within the index card.

8.2.8 StackedCorkboards
Whenmore than one container of any type has been selected, the corkboard will
switch to a special stacking mode displaying the contents of each container sep-
arated by a line.10 By default, this will wrap each container’s section as though it
were an individual corkboard; cards will be displayed according to the settings
in corkboard options (subsection 8.2.6). You can also select between vertical or
horizontal stacking by clicking on one of the left two buttons in the segmented
control, found on the right side of the footer bar, near the view options button
(Figure 8.24) or with the Touch Bar, which will display more selected contain-
ers on the screen at once, making it easier to get a large-scale overview of the
contents of your work.

— Grid: the traditional corkboard view mode.

— Horizontal: places all of the cards within each container on a single row,
so you can easily view them sequentially and scroll left or right to view
subsections.

10 Youmight find the Edit ▸Select ▸Select Subgroupsmenu command to be handy for setting this
up.
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Figure 8.24 Get the big picture by stacking multiple groups together.

— Vertical: as with horizontal, instead displaying each container as a single-
card column, scrolling left and right to view containers and up and down
to view cards.

The View ▸CorkboardOptions ▸Number Per Sectionmenu toggle is provided for
use with stacked corkboards. When enabled, index card numbering will restart
for each corkboard. When disabled, cards will be numbered sequentially across
containers.

Losing Your Place?

The “navigate through groups” button along the upper-right edge of the
corkboard header bar (section 8.1.1) will present a list of every group dis-
played in the current corkboard stack. Simply click where you want to
go, or use the arrow keys to scroll through boards.

Return to chapter ⤴

8.3 TheOutliner
Outliner mode shows all of the descendants of the selected document, along
with any associated metadata you’ve chosen to reveal, in a tabular format like a
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spreadsheet. The default configuration will show the title and synopsis in the
main column on the left and some common metadata in additional columns.

8.3.1 Collapsing and Expanding theOutline
Much like with the binder, the outliner can be collapsed or expanded to keep
the display tidy and only showing what you need to work with, and most of the
tools available for that are identical. Refer to the documentation on managing
the binder outline, for further details (subsection 6.3.5).

8.3.2 Editing Content in theOutliner
Most columns that allow you to edit their data will provide controls for doing so.

— Title & Synopsis: edit these by double-clicking on the text, or by press-
ing Esc on the keyboard. While editing you can move between title and
synopsis with the arrow keys. Press Return to exit editing mode.

— Checkboxes: for example, “Include in Compile” will present a checkbox
that you can click to toggle whether a document is meant to compile. You
can impact many checkboxes at once by holding down the Option key and
clicking on any checkbox. All visible checkboxes will be impacted. This
means if items have been hidden with their disclosure arrows in the out-
liner, they will not be impacted. If you select a number of items first and
Option click on a checkbox, only those selected items will be modified.

— Some columns that offer a fixed set of choices from a list, like “Label” or
“Section Type”, will provide dropdown menus that you can use to adjust
the metadata for a row.

If you need to impact more than one row at once to change custommeta-
data, list fields, labels, status or section types: select these rows first and
then use right-click to access the contextual menu, instead of clicking di-
rectly in the outliner.

— Columns with editable text, such as the custom text metadata or even the
title, should be double-clicked to edit. Once you are typing in a text field
you can use the Tab and⇧Tab keys to jump between cells. You can also use
the arrow keys on your keyboard tomove between cells in a fashion similar
to a spreadsheet.

8.3.3 Managing Columns
To add or remove columns from the display, click the small chevron button
above the scrollbar (Figure 8.25), right-click the column header row, or use the
View ▸Outliner Options ▸ submenu.
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Figure 8.25 Click to manage which columns appear in the outliner view.

— Column settings are saved per editor split. You could set up an outliner to
perform a particular role on the left side of your screen, while displaying
extended information on the right side.

— To change the order inwhich the columns are displayed, drag and drop the
column header to the desired location.

— You can resize the column width by moving your mouse between column
header titles until the cursor changes to a double-pointed arrow, then click
and drag to increase or decrease thewidth of the column. Double-click the
divider to set the column to the left to an optimal width.

— Column setups, including all of the above tweaks, are optionally stored in
Saved Layouts (section 12.3).

8.3.4 List of Available Columns
The following three options changehow the contents of theTitle columnappear.
This columnwill be labeled “Title and Synopsis”when the “with Synopsis” option
is checked.

— Title

– and Synopsis

– with Icons

– with Numbers

Corresponding to general metadata, the first two columns allow changing the
Label and Status of each row individually. The remaining three columns are
read-only. Keywords will be underlined using the colour that has been assigned
to that keyword.

— Label

— Status

— Section Type

— Keywords
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– as Color Chips

— Created Date

— Modified Date

The next set of columns pertain to statistics. The first pair show the word
or character counts for each item in the outliner. The second pair will not only
show the statistics for that row, but will sum up all of its nested child items as
well. E.g. a folder with 250 in it, and containing five text items with 1,000 words
each, would display 5,250 in the Total Word Count column.

— Word Count

— Character Count

— Total Word Count

— Total Character Count

The “Include in Compile” column is for managing whether or not documents
should be included in compile. In most cases this will only be relevant to the
draft folder, but as some features can include documents from outside of the
draft, the checkboxes will always be available for text and folder items.
Targets and progress tracking: similarly to statistics, these show your set

goals for each item in the outliner, with the “total” variants adding up the com-
bined goals for all descendants as well. The special Progress and Total Progress
columns show how far you have come toward these goals, using a progress bar.

— Target

— Target Type

— Progress

— Total Target

— Total Progress

Lastly, any custommetadata fields youhave createdwill be listed at the bottom
of the list. To configure these, click the CustomColumns… option to be taken to
the project settings pane (section C.4).

8.3.5 Special Columns
In addition to the standard columns, there are three choices which impact the
main Title column. They are indented beneath the Title option in the column
menu.
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— and Synopsis: embeds the text of the index card synopsis field beneath
the title. With this option enabled, the title will be emboldened and you
can edit both Title and Synopsis together right in the outliner. The Show
/Hide Synopsis button in the footer bar (or Touch Bar) provides a shortcut
to turning this special column on or off.11

— with Icons: when disabled, item icons will be removed from the outliner
display, producing a cleaner, more “text like” appearance.

— with Numbers: each item in the outliner will be numbered in relation
to the other items within the view, using hierarchical numbering (1, 1.1,
1.2, 1.2.1), and when located within the Draft folder, the software will at-
tempt to keep these numbers consistent throughout the Draft. They are
not meant to correlate with any form of numbering produced by the com-
piler, though universal use of the hierarchical numbering placeholder (the
“Enumerated Outline” compile format for example) may produce similar
enough results for these numbers to be useful as a reference.

The Keywords column also has a secondary option available to it by uncheck-
ing the as Color Chips flag, to print each keyword by name in the outliner, un-
derscored with the keyword’s associated colour (Figure 8.26).

Figure 8.26 Keywords can be displayed as (a) printed terms or (b) colour chips.

8.3.6 Sorting by Columns
To sort by columns, click on the column header. The first click will sort in as-
cending order, the second click by descending and finally a third click will turn
off sorting.
This form of sorting is a way of viewing information in the Outliner. It will

not impact the underlying order of the items in the Binder, and can thus be safely

11 The Title (and Synopsis) column is also special in that if it is the only column present, it will
automatically fill the entire width of the outliner.
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used to visualise information without disrupting your book structure. This is a
session-based tool, meaning project will never loadwith columns already sorted.
To sort items permanently, so that they are arranged in the binder in that or-

der:

1. Select all of the outliner rows you wish to sort.

2. Either:

— Drag and drop the selection back into the folder they reside within.

— Use the Documents ▸Move To ▸ submenu to select a target location.

When items are dragged, their selection order is used for the drop; thus drag-
ging them back into the folder they came from will reorder them in according
with their visible order in theOutliner (or Corkboard, for thatmatter) view. This
cannot be used to reorder many items within subfolders at once. You’ll need to
reorder each folder individually.
To permanently sort alphabetically by item titles, it will be more convenient

to use the Edit ▸Sort ▸ submenu on a selected folder.

8.3.7 Navigating in LargerOutlines
The content navigation button (section 8.1.1), on the right-hand side of the editor
header bar, can be used to navigatewithin large outlines. A list of every container
found within the outline will be presented. The nearest parent container of the
item you have selected will be highlighted for your reference. Click on any of the
entires to scroll the outliner and select the row.

8.3.8 Using a Fixed RowHeight
The outliner can be altered to use a display mode more akin to a list on iOS, or
in a program like Apple’s Mail.app, where each entry in the list occupies a fixed
height rather than like an ordinary outliner, where each row is as tall as it needs
to be to fit the content.
This alternative display mode provides a more consistent experience when

scrolling to find a particular item. For items lacking a synopsis, a little of the
main text content will be printed, if available (Figure 8.27).
The typical for this featurewould be to show synopses, however thismode can

be used without them. When synopses are hidden, outliner rows will be fixed to
one line of height per row.12

12 Mainly that will be of interest when using custom text metadata fields that have been set to
wrap. These fields act more like the synopsis does by default, but when fixed width is used, will
be forced to truncate at the first line.
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Figure 8.27 The left outliner is using traditional variable rowheights; the right
is using a fixed row height.

8.3.9 CentringOutliner Content
The Center Content setting helps to change the outliner from a spreadsheet
looking device to somethingmore like a text editor—if you’re looking for a com-
fortable environment to focus on the text of your outline with, this may be the
option for you. When checked, the data of the outliner will be centred within
the full width of the split (Figure 8.28).
Since it is still the outliner, you can add any additional columns you need to

organise your thoughts, but this option will not do much if the overall width
of the outliner is as wide as the editor itself, and will do nothing if there are
more columns than screen space. Thismode can also be toggled using the button
indicated in the inset of the figure, on the right-hand side of the footer bar.

Return to chapter ⤴
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Figure 8.28 Develop the outline in a comfortable environment with the Cen-
ter content option.
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9.1 File Import
Whether you are using Scrivener for the first time and want to use it with docu-
ments you have already created in other programs or have reference files laying
around that you want to bring into an existing project, chances are that at some
point you will want to import documents created in other word processors and
programs into your Scrivener project. Fortunately, this is one of the things Scriv-
ener is designed to do.
Importing files into the project binder means that these files will be copied

(and possibly transformed into a fashion that Scrivener can use) into the project
itself. The original copies on your disk will not be removed or altered in any way.
There are three ways to import documents from other programs:

1. Drag and Drop. In the Finder, select the files you wish to import and then
just drag them straight into the binder, corkboard or outliner views. When
dragging folders, all of the contents of that folder will be added recursively,
and the file structure on your disk will be recreated in the binder.
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2. The File ▸ Import ▸ submenu provides some handymethods for bringing ex-
isting material into your project binder, including directly off of the Web,
if you have the URL.

In cases where the imported material has some sort of innate or option-
ally defined structure, the File ▸ Import ▸ Import andSplit… command will at-
tempt to convert that into outline hierarchy. Word processing stylesheets,
Markdown style headings, Final Draft and Fountain slug-lines can all be
split automatically, as well as any text content at all with manually sup-
plied split markers (subsection 9.1.6).

3. Copy and paste. That good old standby that nearly alwaysworks in a pinch
will often be the easiest or bestway to get small bits of information (or even
large chunks if you prefer) between different programs.

When importing text documents of any kind, they are internally converted to
a format Scrivener can work with (again, note that this has no effect on the orig-
inal file on your disk). Some formatting or even data may be lost in the transla-
tion, such as documentswith complex embedded information, like Excel spread-
sheets.
Whenusing the importmenu commands,material will be imported according

to where the current binder selection is set. The specific rules for how import
works are by and large the same as those used when creating new items from
within Scrivener (section 6.3.1). There are a few exceptions:

— If your selection is anywhere inside the special “Draft” folder, you will be
unable to import media of any kind. Only text documents can be created
or imported into this area where you write.

— When importing via some external command, such as dropping a file onto
Scrivener’s icon in the Dock, using the “Print to PDF” feature, a clipping
service or when importing an entire Scrivener project, the selection point
will be ignored. Such items will be imported either into the root level of
the binder or into the Research folder.

When using drag and drop, the dropped material will be placed wherever the
drop indicator is positioned with the mouse. If you try to drag media into the
Draft, the dropwill be prohibited until youmove themouse away from that area.

9.1.1 Supported File Formats
Scrivener supports the following text document types. Some document formats
will require additional documentation and be documented in the pages follow-
ing this list:

— RTF (rich text format): a universal rich text standard, and an official alter-
native format for Microsoft Word. This is often the best format to use for
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importing from word processors, purely upon the basis of speed, ubiquity
and compatibility. As it is Scrivener’s native internal format, no complex
conversion is required of it.

— RTFD (rich text format directory): A proprietary Apple rich text format
commonly used by macOS Cocoa applications.

— DOC&DOCX (MicrosoftWord format): themain formats used byMicrosoft
Word and the writing industry.

— ODT (Open Document Text): format used by OpenOffice and related
projects such as LibreOffice.1

Havingdifficulties getting clean formatting fromyourwordprocessor?

Most word processors will do a better job of converting their native for-
mat to the RTF format, than Scrivener will be capable of doing. If you are
getting bad formatting, missing elements such as images, or even errors,
then try opening the original file in your word processor, use its “Save As”
feature to create an RTF file, then import that into Scrivener instead.

— TXT (plain text): Scrivener works with Unicode UTF-8 encoding, which
most text files are. If a plain text document gets imported as gibberish you
may need to convert it to UTF-8 format using TextEdit before importing
it into Scrivener. If all else fails, use copy and paste from a program that
opens it fine.

Files with the following extensions will be imported as text as well: .log,
.tex, .xml, .markdown, .md and .mmd. Additional extensions can be added
to the Sharing: Import Setting tab (section B.8.1), under Plain text import
formats.

— PDF (portable document format): standard format for preserving and pub-
lishing documents in a read-only format.

— HTML (hypertext markup language): the language of the Web. Imported
HTML files can be converted to either text to extract just the formatted
content, or toWebArchive for full layout archival. WebArchive files them-
selves can also be imported directly into Scrivener.

— FDX (Final Draft format): using the standard document format for Final
Draft (version 8 or greater), you can import scripts directly into any area of
the binder and have those imported documents converted to Scrivener’s
scripting format.

1 For superior export and import quality, it is recommended you install Java for .doc and .odt
formats. Alternatively, RTF is often as good or better to use.
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— .fountain (Fountain plain-text screenplay): like Markdown, this format is
more of a convention of how you type within a plain-text file. This makes
the format suitable for editing on nearly any digital device.

— OPML (Outline Processor Markup Language): commonly exported from
outlining and mind-map style software, this format will let you transfer
an outline tree from one application to another.

— No extension. Documents with no extension are imported into Scrivener
as plain text files (note that this can often be a source of confusion - if
you try to import older RTF or DOC file that have no extension, when you
import it into Scrivener you will see all of the raw code because it will be
imported as plain text. Make sure you add the appropriate extension be-
fore importing to ensure that Scrivener recognises it as a word processor
file).

As well as these text file types, Scrivener also supports all of the main image
file types (TIF, JPG, GIF, PNG, BMP etc), all of the main audio/visual formats (MOV,
MPG, WAV, MP3 etc).
Beyond the supported formats, you can import any type of file at all into the

non-draft areas of your binder. Although Scrivener cannot view every format
out there natively, it can at least host these files, keeping them organised to-
gether with the rest of your research, fromwhich they can be opened in external
viewers with the Navigate ▸Open ▸ in External Editormenu command (⌃⌘O). Refer
to Viewing Unsupported Document Types (section 8.1.3) for more information
on how to work with these types of files.

9.1.2 Web Page
The File ▸ Import ▸WebPage… command lets you enter theURL of a web page that
you would like to import. The web page will be fully downloaded and archived
into your project, meaning you will no longer need to be connected to the Inter-
net to view it, and if the original page is removed or changed, your personal copy
will remain.
To generate an editable copy of the page, convert it into a text file by using

Documents ▸Convert ▸Web and PDF Files to Text. If you would prefer all web pages
to be imported as text, set the Convert imported WebArchives and web pages
to text, option in the Sharing: Import Setting tab (section B.8.1).

192



9.1. File Import

Functional Web Pages or “Apps”

Many sites these days are functional in that you can do things inside the
webpage after you load it. A good example of this is Google Docs, Ever-
note or even a simple search form. These sorts of pages, if they require a
login, will typically not import correctly as Scrivener is not a full browser,
capable of storing cookies. Try to find a way of exporting the data in a
static form, such as importing a printable version of the page, exporting
as PDF from your browser or even simple old copy and paste, if the site
lacks export capabilities.

It may be possible to drag and drop sites directly into the binder from the URL
bar in your browser, or hyperlinks in the page itself. Whether thatworks properly
will depend on which browser you use.

9.1.3 Plain Text Formatted Screenplay
Not to be confused with the Fountain format, this import method is for plain-
text files typed in screenplay format directly, or exported from Movie Magic
Screenwriter and other programs that export plain-text scripts. Use this utility
to have them converted into Scrivener’s screenplay scripting format automati-
cally.

9.1.4 OPML andOutline Files
Outliner files using the OPML format can be imported into Scrivener, retaining
the original hierarchy and converting it into a binder outline. This can be useful
if you do your initial brainstorming in a dedicated outliner ormind-mapping ap-
plication. Some applications support attaching “notes” to each outliner header.
Notes such as these may be imported into the main text area, or the metadata
field of your choice. Other outliners treat the outline more like a folding text
editor, as such that you would want the outline imported as text rather than as
headings.
The settings for adjusting how OPML is imported are located in the Sharing:

Import Setting tab (section B.8.1).

9.1.5 Scrivener Project
It is possible to import an entire Scrivener project off the disk into the binder of
the current project, using the File ▸ Import ▸Scrivener Project… menu command.
The full binder structure of the other project will be imported into a folder,
named after the project, at the bottomof the binder. All of the text, synopses and
notes will be imported, along with snapshots andmost other forms of metadata.
This tool can be of use if you work with software capable of exporting Scrivener
projects, such as Index Card for iPad.
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An alternate usage for this feature is to import a different version of the project,
edited separately from the original either by yourself or another. WhenScrivener
detects that the project you are importing appears to have once been a copy of
the same project, it offers to merge the two projects together (subsection 5.3.2).
This command can also be used to import, and therefore restore, corrupted

projects. If you have a project that has somehow become corrupted so that it can
no longer be opened in Scrivener, use this command from a new blank project
to have Scrivener do its best to retrieve all the data. The outline structure may
not be recovered from badly corrupted projects, but every attempt to import the
raw data will be made.

9.1.6 Import and Split
Use the File ▸ Import ▸ Import and Split… menu command in cases where the im-
ported document contains textual or structural elements that could be used to
automatically break up the imported file into a more detailed binder outline.
The available options for doing so will depend upon the file type being im-

ported. For example if you import a .docx file, options pertaining to its stylesheet
outline will be presented. If you import a .md or .mmd Markdown file, then
Markdown options will be presented.

Looking to Split with More Control?

Not every document can be easily split in a predictable fashion using this
tool—some might require a little reading to figure out where structural
splits are best placed. In that case, it may be best to import the document
normally, as a single file, and then use the available tools for Splitting the
Document (subsection 15.4.1).

Word Processing Files with Stylesheets
Used by files with .docx, .doc, .rtf and .odt file extensions.
Word processing documents that use a stylesheet to establish a heading out-

line (such as “Heading 1”, “Heading 2” and so forth) can be imported into the
project as a structured outline. Each heading will generate a new document
in the binder, named by the text of that heading, and nested according to its
stylesheet outline depth. All text following the heading, up until the next, will
be inserted into that item’s main text content.
In the provided example (Figure 9.1), we have a word processing file from the

likes of Microsoft Word or LibreOffice, marked (a). This file could be imported
directly into Scrivener using normal means, but if done so you would just one
get one single file in the binder for the entire document. By using the Import
and Split command instead, we end up with a simple draft outline marked (b),
and if you look closely you will see that in the Scrivenings session to the right of
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the binder, we have the original copy intact but separated into individual chunks
of text.
Use the Remove first lines of text when splitting by outline option in the

Import and Split dialogue to strip out the headings themselves from the text,
leaving only the body text. This will be desirable if you intend to use compile
settings that generate headings automatically for you, based upon the outline
structure itself. In other words you will only see “A First Level Heading” in the
binder, not the editor, but when you export it may all be set up to produce a
document identical to the original (b).

Figure 9.1 This document imports as an outline structure in Scrivener.

Split by Separator
Used by all standard text document extensions, except for scriptwriting docu-
ments. This includes word processing and Markdown files, which can use this
behaviour as an alternative to their structural options, by enabling the Split into
sections by finding separators in the text option.
Type in the separator that was used in the text to denote where one section

ends and the other begins. A common example might be a “#” character, used
to break scenes in a standard manuscript. Any line in the document that begins
with the text entered into this field will be removed from the file and used to
split the imported document. This process continues, further splitting the work
into subsequent binder items, until all of these separators have been processed.
A portion of the remainder of the line following the separator, or if the en-

tire separator was removed, the line following the separator, will be used to title
documents. In the following example, we could split by the phrase “Chapter:”,
which would cause the section to be called “The Red Book”:
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Chapter: The Red Book

If we split by the sequence “—”, then the section following this break point
would be called “Stately, plump Buck Mulligan came from the stairhe…” (yes,
the title shortening code has no respect for good prose):

---
Stately, plump Buck Mulligan came from the stairhead, bearing a bowl
of lather on which a mirror and a razor lay crossed.

Markdown Files
Used by files with .markdown, .md, .mmd and .txt file extensions.
Similar to stylesheet outlines in a word processing file, Markdown headings

describe a document structure that can be recreated in the binder. If a Multi-
Markdown or YAML style metadata block is found at the beginning of the file, it
will be inserted as the first document at the top level.2 Below that, each header
found in the Markdown file will be used to create a new document at an ap-
propriate level of depth, with any text following that header up to the point of
the next header included in that document. Only “ATX” hash style headers are
supported.

Convert Markdown When this option is ticked, Scrivener will use the Multi-
Markdown engine to convert the imported content to rich text, removing
all Markdown formatting in the process.3

If you require more precise control over the appearance of the document,
you are advised to use your preferredMarkdown engine to generate a doc-
ument to your specifications, and then import that into Scrivener. For
example, you could use the Pandoc engine to create a .docx file with a far
superior level of quality, and then import that.

Final Draft and Fountain
When splitting .fdx or .fountain files:

— Final Draft: are imported using this tool the file chooser options will pro-
vide a selection of elements to choose from. You can select any one ele-
ment to split by. The imported script file will be split into multiple binder
items at the requested break points, in addition to splitting at any scene

2 When exporting, the Compiler can use this file to merge metadata found in the draft folder
with any fields supplied in compile settings (section 21.6).
3 This process is done via the HTML output that Markdown creates, and so in essence Scrivener
will be importing an HTML version of the original document. This may result in several limita-
tions that you deem unacceptable.
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headings (select “Scene Headings” to only break on those). Scene sum-
marieswill be imported into synopses and scene titleswill replace the stock
slugline where provided.

— Fountain: screenplays written using this plain-text markup system will be
automatically split up by scene. Scene descriptions will be placed into the
synopsis card, if used.

9.1.7 FromScapple Documents
Scapple, the freeform text editing software from Literature & Latte, gives you an
easy to use interface for roughing out a new idea.
At some point, it may be advantageous to move your idea from Scapple into

Scrivener. There are three ways of doing so:

1. If individual notes are dragged from an open Scapple document into the
Scrivener binder, or into a freeform corkboard (subsection 8.2.4), they will
be converted into individual binder items, one per note.

When dropping into a freeform corkboard, they will be placed spatially
within the freeform corkboard in accordance with their relative positions
in the Scapple document (this cannot be precise, since index cards are all
identical in size and Scapple notes change their height depending on how
much content they have within them). If dropped into the binder, the spa-
tial properties will not be maintained. This will be useful in cases where
the conversion from notes to index cards is not advantageous and results
in a lot of overlapping.

2. When bringing in a Scapple document that is not intended to be converted
into individual items, one per note, youwouldwant to export as a text doc-
ument from Scapple (using your preferred method from the File ▸Export ▸
submenu in Scapple), and then import that as you would import any other
text document into Scrivener.

If youfind this results in a confusing order, itmight be better to use thefirst
method, and then once you have the order set up correctly in the binder,
select all of the imported items and use the Documents ▸Mergemenu com-
mand to concatenate them into a single document in the binder.

3. If a Scapple document is dragged into the binder as a file, it will imported
as research, rather than as individual notes. A Quick Look preview of the
document will be displayed for you in the editor when you view it. You
can now open it as you would any other unsupported media format via
the Navigate ▸Open ▸ in External Editor menu command, or clicking the ap-
plication icon in the footer bar of the editor. This will be the most useful
choice if the contents of your planning session are not meant to form a
literal foundation for the work you will be doing in Scrivener, but rather
as a reference to build from.
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Imported Scapple notes will use the first line of text in the note as the binder
title. You can choose to this line removed on import, if you tend to use the first
line strictly for titling your notes in Scapple, in the Sharing: Import Setting tab
(section B.8.1).

Return to chapter ⤴

9.2 Linking to ResearchMaterial
As mentioned before, the typical methods for bringing research material into
your project fully duplicates those records into the project itself. No connection
to the original file on the disk is retained, and in this way it becomes a part of
the project. If you move or sync the project to another computer, your research
material will conveniently follow. There are a few downsides to this approach:

— When you need to continue referring to or editing these resources on a
regular basis, it can be less efficient having to open them one by one us-
ing the Navigate ▸Open ▸ in External Editor command. Having access to your
research using the standard file management tools on your computer can
provide considerable flexibility.

— Adding lots of material bloats the project size. While the project format
itself is capable of great quantities of imported material4, this can slow
down the automatic backup routine, discouraging good practices.

The solution is linking to these files in-place, instead of importing them into
the project. The result of this link will be presented in the binder as a fully func-
tional copy of that file.

Linked Research Files Are Computer Specific

The downside to linking is that if youmove or sync the project to another
computer, the research fileswill no longer be available. The linkswill stay
in place, and all metadata or organisation you have assigned to themwill
remain, but the source of the file will be inaccessible until you return to
the primary computer where the link was established, even if the files
are on both computers in the same place. The magic that makes them
capable of being followed aroundwhen renamedormoved depends upon
a link that is specific to that computer.

4 Refer to Project Size Limitations (section 5.3.1) if you’re curious about the scale we are referring
to here.
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9.2.1 Creating links to resources
There are a fewways to do establish a link between the original files on your disk
and your project binder:

— Use the menu command, File ▸ Import ▸Research Files as Aliases.., and select
the files to import from the file dialogue box.

— Drag and drop existing aliases from your file manager into the binder.

— Drag and drop a normal file into the binder with theOption and Command
keys held down, just as you would do to create an alias in Finder.

This feature is only available for non-text research (PDF, multimedia, and web
files) that Scrivener can display in the editor window. It is not possible to link
to a supported word processor files or plain-text documents; consider exporting
them to PDF if you just want a read-only copy of the text made available.

9.2.2 Using andmanaging linked resources

Figure 9.2 Linked resources will be displayed with a small arrow in the lower-
left corner of the icon.

Everything you have learned so far about working with research files can be
applied to linked resources. These itemswill act just like files imported or created
in the binder. They can be organised into folders, given index card text on the
corkboard, tagged with keywords, viewed in splits and so forth.
To locate the original source file for the alias, right-click on the item in the

binder and select the “Reveal in the Finder” contextual menu command.

9.2.3 Workingwith broken links or updating
resources

If the original files are renamed ormoved, the link will adjust accordingly. How-
ever in some cases linksmay break and need to be repaired, or youmay just want
to update the link to point to a different version of the file:

1. Select the link in the binder that you wish to change or repair:

2. Use the Documents ▸Change Alias Source…menu command.

3. Use the file dialogue box to select the source for the item you wish to redi-
rect the binder link to.
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Return to chapter ⤴

9.3 Scrivener Services
Scrivener installs several clipping services that aid in grabbing text from other
applications and getting them straight into Scrivener without having to worry
about manually switching between programs and then pasting in the text your-
self. The Services menu is not found in the main menu bar, but in the Services
submenu of the application menu (which will be named according to whichever
application currently has the focus). In all cases, you will need text to be selected
for the appropriate services to become available. Services are also often displayed
when right-clicking on text in native macOS applications.

Services don’t show up

If you have just installed Scrivener, you may need to log out of your ac-
count and back in for the system to properly register the services. They
may also need to be enabled in the System Settings: Keyboard: Keyboard
Shortcuts: Services pane. Ensure there are checkboxes beside each ser-
vice you wish to make use of. You can also assign global keyboard short-
cuts to them here.

Where the clipped text shows up will depend in part on the service chosen.
In all cases, the active project (the last project in use, even if Scrivener is in the
background) will be used as a target, and in some cases the active document or
split will be used as the target. In all cases, you must have at least one project
open for services to work. If you wish to collect text into Scrivener, but do not
yet have a project created, you can use the Scratchpad Panel (section 9.4) instead.
Each clipping service has an alternate form that will bring the selected text in

unformatted. This can be useful when clipping text from the web, which often
has inappropriate text colour and other formatting applied to it. All methods
include an optional titling prompt. If you supply a separator or title, this will be
placed into the document separating it from whatever content already existed.
When using the formatted services, the title will use bold text.
The following methods are available:

Append to Notes The selected text will be appended to the active split’s docu-
ment notes pane (subsection 13.3.2), which may not appear to do anything
unless you have the inspector open.

Append to Text The selected text will be appended to the active document’s
main text area. If the current document in Scrivener is not one that can
hold text (for instance, if it is an image document), the Scrivener icon will
bounce and Scrivenerwill display awarning panel telling you that you can-
not append text to any open documents, and asking if you would like to
create a new clipping for the text instead.
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Make New Clipping Create a new text document in the active project in Scriv-
ener from the selected text. All new clippings are placed inside a “Clip-
pings” folder which will be created as necessary at the bottom of the
project’s binder. This service is slightly different from the above two in
that the title you provide will be used to name the clipping document that
is created in the binder. A default, date-based title will be provided in case
you do not wish to bother with naming them individually.

You can adjust whether or not you are prompted for a title, or whether Scriv-
ener comes to the foreground after using a Service, in the General: Services Set-
tings tab (subsection B.2.4).

Return to chapter ⤴

9.4 Scratchpad Panel
The scratchpad is a simple tool for jotting down notes from anywhere on your
computer. It is not tied to any specific project and floats above all otherwindows,
even other applications, so it never gets lost and exists on every virtual desktop.
It is useful as an inbox for ideas, a note-taking tool while doing research in other
software or simply as a place to jot down your grocery list in a pinch.
Access the scratchpad by using theWindow ▸ShowScratchpadmenu command

(⇧⌘Return), or you can right-click on the Scrivener icon in the Dock and select
“Scratchpad”. The shortcut is universal, meaning you can use it to toggle the
window even while working in other programs, so long as Scrivener is running
in the background.

Figure 9.3 The Scratchpad is a simple way to jot down notes from anywhere.
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— The top half of the window contains a list of all the notes you currently
have stored in the scratchpad.

— With the mouse, click on a note in the list to load it into the lower half,
then click into the text area and edit away.

— Using the keyboard, notes can be selected with the ↑ and ↓ keys, and you
can switch between the list and text area with ⌃Tab.

— New notes can be created by clicking the + button in footer bar, or by
pressing the Return key.

— Rename notes by double-clicking on the name of the note in the list, or by
using the Esc key while it is selected.

— Delete notes with the− button, or by pressing⌘Delete. Deleted notes will
be moved to the your Mac’s Trash can and could be restored back to the
scratchpad folder if you make a mistake.

— Change the zoom level to magnify or shrink text size, with the standard
View ▸Zoom ▸ submenu, or keyboard shortcuts.

9.4.1 CopyingNotes Into Projects
When projects are open, the Send to Project… button will provide you with a list
of all opened projects, each providing two methods of bringing notes into the
project:

1. Append Text To: the contents of the selected note will be appended after
any existing text of the document you select in the project submenu. A
list of your binder will be arranged so you can easily select any text item.
Research files cannot be selected since they cannot have text appended to
them.

2. Import as Subdocument of : a new document will be created beneath the se-
lected document. This submenu operates in a similar fashion to the above,
though it will allow you to select any of the items in the binder since all
types can contain children. The name of the scratchpad note will be used
to populate the title field for the new document.

9.4.2 Using the Scratchpad Beyond Scrivener
The scratchpad has a two-way relationship with the folder it is linked to on your
disk. You may have been asked to set this folder up when you first started using
it, but if you didn’t, make note of where that is: you can find its location in the
General: Scratch Pad settings pane (subsection B.2.6).
When saving files (of the type you tell it to use; RTF, TXT, etc.) into this folder

using other programs, the scratchpad will display them in the list, the next time
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you use the tool, or after clicking the refresh button, in the lower left corner.
Likewise, edits made to existing notes with external editors will show up in the
scratchpad.

Sharing a Scratchpad Between Devices

While in Settings, note you can modify the types of files used to store
your notes. Since this is a normal folder of files you could place it in a
cloud folder and share it with other devices. It might be useful to decide
upon a note file format that will work across platforms. RTF will be good
when sharing a scratchpad between Scrivener on macOS and Windows,
and TXT is always a safe choice ifmobile apps are involved. With the latter
you canmodify the file extension used, which may be of use if you prefer
Markdown editors, for example.

Return to chapter ⤴

9.5 Text Appending Tools
Text selections in your project can be easily appended to other texts within the
same project:

Append Selection to Document This command is available in the contextual
menuwhen right-clicking on selected text and aswell from the Editmenu.
The command will provide a binder item selection submenu. Best used
when the target document is not visible, or you want to remain in the
source document after the append action. The menu will also have a
“New…” command at the top of it which will let you create a new item
in the binder with the selected text as its contents.

The original text will not be removed from its source, but it will remain
selected meaning it could be easily removed with the Delete key.

Drag and Drop From the other direction, drag binder items into the current
text editor, with the Option key held down.5 As you drag the binder item
into the editor, the cursor position will move to indicate the drop point,
or where the text will be inserted. This can be done from any draggable
icon in the interface, including those produced by the Quick Search Tool
(section 11.5).

Return to chapter ⤴

5Without themodifier key, dragging a document into the active text editorwill create a hyperlink
to that document.
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9.6 Print as PDF to Scrivener
If the information you wish to import into Scrivener is locked in a format that
cannot be used, a commonway of capturing this information is to print the doc-
ument from the source application, andwhen the print dialogue appears, use the
PDF dropdown menu to select the target application. You should see option to
“Save PDF to Scrivener”. Upon selecting this choice, the Mac will save the docu-
ment to a PDF file and then transfer that file to your active project. The imported
PDF file will appear in your Research folder.

Printing to Scrivener from the MAS version

If you purchased Scrivener from Apple, then the PDF printing facility will
not be installed automatically. Follow the provided instructions (subsec-
tion 3.3.2) to add this feature to your Mac.

Return to chapter ⤴

9.7 Cleaning Up Imported Items
After having gathered a number of items together into your project, you may
wish to clean up the formatting of them, or to check and ensure you haven’t
imported the same material more than once:

— For cleaning up formatting, refer to
resetting formatting (subsection 15.7.5).

— You can check to see if you’ve accidentally imported the same material
more than once, by finding duplications (section 11.1.3).

— Sometimes the duplications will be to individual bits of text, rather than
of whole documents. The Matching Text Finder (subsection 13.4.4) tool is
designed to help with finding those.

Return to chapter ⤴
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to the reader to help in their navigation of the material, or even purely for your
own benefit, stripped from the output when you finalise the work.

10.1.1 Creating Internal Links
There are several ways to form hyperlinks between items in Scrivener, ranging
from methods that rely purely upon the keyboard, to methods that make use
of menu systems, to the simple dragging and dropping of items from nearly any
view into any editor capable of linking. We’ll go over eachmethod in this section,
describing their pros and cons, and how they can be modified with Settings.

Drag andDrop
To create a link to a specific item, or list of items if several are selected, drag the
item into a text editor1 dropping them where you would like to create a link.
The blinking cursor beneath the mouse pointer will indicate where the link(s)
will be inserted. When creating links in this fashion, they will be automatically
titled by the name of the document that was dragged, and in the case of multiple
documents, they will be listed one per line.
Alternatively, if you select some text in the editor first and then drag an itemon

top of the selected text, the hyperlink will be applied to the selected text, rather
than dropping the name of the item into the editor.

If You Can See It, Link It!

You don’t have to hunt down something in the binder to drag and drop it
if you can already see it. Wherever there is an icon associatedwith an item
somewhere in the interface, chances are you can drag it into a text editor
to create a link to that item. That includes search results from the Quick
Search field in the toolbar, from Bookmark lists in the inspector, toolbar
orQuick Reference sidebar, other editor header bars, copyholders, Quick
Reference panel headers, index cards, etc.

Select Text and Link
For cases where the item you wish to link to doesn’t exist yet, or isn’t readily
available for drag and drop, you can also create links using a browsable menu to
select the link target:

1. Either select the text you wish to link from, and then right-click on the
selected text, or right-click at the point in the text where you would like
to insert a named link.

1 In this case that means the main text editors, the Notes sidebar or Bookmarks preview areas in
the inspector, copyholders or those panes within Quick Reference panels.
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2. Use the Link to Document submenu to create a new link to a chosen item
(also located in the Edit menu).

The contents of this submenu contains several convenience features as well
as a full listing of every item in the binder:

Figure 10.1 Creating a new character sheet in a folder, using the “New Link”
command.

NewLink

Brings up a dialogue giving you the option between linking to and creating a
new item (choosing where to place it) or navigating through a list of them that
already exist. In Figure 10.1 we might have selected the name “Sònia Casasús”
in the scene we were writing, used the ⌘L shortcut to bring up the “New Link”
panel and then selected the “Major Characters” folder to create a new file for
Sònia with a link to her name from the scene text.

Destination Use dropdownmenu to select where the new document should be
placed in the binder. This will default to the Research folder, and after that
point will use whatever location you chose previously.

Title Provide in the name of the new binder item that will be created. The text
you selected from the editor will be provided for convenience.

Only show containers in destination list When disabled the dropdown menu
above will display all items in the binder, allowing the formation of new
containers by creating the new linked item beneath the selected docu-
ment2.

2 If this concept is unfamiliar, I would suggest reading Folders are Files are Folders (section 7.3).
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Upon clickingOK aQuickReference panelwill be opened to the new item. You
can change what Scrivener does after new documents are created from links, in
the Behaviors: Document Links settings pane (subsection B.4.2), with theOpen
new document links in setting.

Suggestions

Back to the “Link to Document” submenu, below the New Link entry is a “Sug-
gestions” area that will appear if the selected text contains text found in any ex-
isting binder item titles. This is handy when you have typed out the name of a
binder item, andwish to create a link to it. This sectionwill not appear if no titles
suitably similar to the selected text are found. Going back to our prior example, if
we refer to “Sònia” in the text and wish to link to her character sheet again, then
selecting and right-clicking on her name would present that character sheet at
the top of the submenu (Figure 10.2).

Figure 10.2 Main contextual menu removed for brevity.

Bookmarks

If any items have been added to the Project Bookmarks list they will be given
priority access at the top of this submenu. Consider bookmarking frequently
linked to items to make it easier to access them (section 10.3).

Binder List

The remainder of the list will be organised into a binder item selection submenu.
Containers will be converted into submenus listing their child items from the
binder, but can themselves be selected as link targets.

Select Items andCopy
To create links to multiple items as a list, there are two approaches you can take,
beyond the already discussed method of dragging and dropping selected items:

209



10.1. Linking Documents Together

1. For a list of items indented by their outline levels use the Edit ▸Copy Spe-
cial ▸CopyDocumentsasStructuredLinkListmenu command and then paste
the indented text into an editor.

2. If instead you need a flat list of links, then use the standard Edit ▸Copy (⌘C)
command.

Wiki Link Style
If you’ve ever used a wiki to organise your ideas, then you know the use of links
can even be a good brainstorming tool, as you can build a to-do list of things
to write “remotely” with links while writing. Scrivener provides a similar mech-
anism via an optional method for typing in new links, even to files that don’t
exist yet, while you write. To enable this method, visit the Corrections tab of
Scrivener’s Settings, and turn onAutomatically detect [[document links]] in the
Data-Detection section.
While typing in the text you would enter double left brackets, type in the title

of the item you wish to link to, and then close it with a second pair of right
brackets, as shown above. Scrivener will detect what you are trying to do, and if
it finds an exact match in the binder, will link it for you automatically.3 If it does
not recognise the text inside the brackets the New Link dialogue (Figure 10.1)
will be opened, giving you the option to either create a new item and place it in
the binder, or via the second tab, “Link to Existing Document”, navigate to an
existing document in the binder, for those cases where the name of what you
wish to link to does notmatch the text you typed in. Once substitution has been
performed, the brackets will be removed.

Quickly Filling in Titles

A natural compliment to this feature is the Edit ▸Completions ▸Complete
a Document Title menu command and shortcut (⌃Esc). Type in the first
part of a title and then use the shortcut to fill in the rest.

As with other automated corrections, wiki style linking works only on newly
typed material. If you have previously typed in double-bracketed words, and
then enable the option, you will need to type in the brackets again.
If you are usingMultiMarkdown (or a similar markup) to write, you may need

to use an additional square bracket around the double-brackets if you intend for
the link to be a cross-reference in the compiled output. Scrivener will remove
the double-brackets, leaving any other brackets around the text alone.

3 If multiple items in the binder use that same title, the first from the topwill be used for the link.
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LinkingWithout Linking
Have you ever wished you could have an automatically generated network of
cross-references between research, written material and notes without having
to make your own links or drag your own bookmarks around? Scrivener gives
you precisely that capability with its title scanning capability. Here is a simple
example:

1. Create two documents in your binder, calling one whatever you want, and
the second document “Link to me”.

2. In the first document, type in the word “Link”, or even “Link to me”, and
select the words you typed in.

3. Right-click on the selection.

Near the very top of the contextual menu you will find a command, “Open
‘Link to me”’. Click on that, and you’ll jump straight to that document in the
current editor.
Any item that has a title—and by that we mean titles generated via Titles and

Adaptive Naming (section 7.2) as well, so we might as well say, any item that has
text—canbecome a topical look-up for phrases of similar text that you right-click
on in the main editor or document notes inspector pane. In effect this gives you
a pervasive network “links” throughout your project without the litter of visible
links everywhere you go, and without the necessity of having to create those
links yourself.

Links are Circular
By default, whenever you link to another document in your binder, a Document
Bookmark (section 10.3) will be created for the item you linked from, in the book-
mark list of item you linked to—orwhat is commonly referred to as a back-link. If
I have a document called “Links are Circular” (and so aremy references, it seems)
and create a document link to another file called “Textual Marks”, then if I were
to click on the Textual Marks item in the binder and view its bookmark list, I
would find an entry for “Links are Circular”, pointing back to this document.
In this way I can see which sections have linked to other sections. If I make an

edit to the “TextualMarks” document in the future, I might review its bookmark
list to find all of the documents that linked to it in the past, as they might need
editing as well.

10.1.2 Using andManaging Links
To use links, click on them with the mouse pointer, as you would in a web
browser. By default, internal links will open in the other split, similarly to how
it would work if the item had been clicked in the binder (e.g. clicking on the link
to a folder will use the current group view for that split, such as the corkboard).
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If you would like to see where the link will take you without actually going
there: hover your mouse over the link for a moment, and the full binder path of
the item will be printed in a tooltip.
Where the link will open can be changed in the following ways:

— Right-click on an internal link to access the “Open Document Link In”
submenu for additional ways to open a link. In some contexts, the only
option will be to load the link in a QuickReference panel (section 12.6).

— To permanently change how links load, navigate to the Behaviors: Docu-
ment Links settings pane, and adjust theOpen clicked document links in
setting.

— Hold down theCommand keywhen clicking on the link, to use an alternate
behaviour based on the aforementioned setting:

– Other Editor (default setting) and Copyholder: open in Quick Refer-
ence panel.

– Current Editor and Quick Reference Panel: open in other editor.

RemovingDocument Links
Document links canbe removedwith theEdit ▸RemoveLinkmenucommand (also
available in the contextual menu when right-clicking on a link). Any link falling
within the currently selected text will be removed, so there is no need to be pre-
cise about what you select, but if you select only part of a link, just that part will
be removed. When bulk text is selected, many links can be cleaned out of the
text at once.

Changing a Link Target
The link target, what Scrivener will load when you click on the link, can be
changed by selecting the link and using any of the methods you would use to
create a new link. You can also use the Edit ▸Edit Link… menu command (⌘K)
to select the new document from a column browser. This can also be done by
right-clicking on the link.

Updating Link Text Automatically
When using internal links as a form of cross-referencing, a mechanism for up-
dating the link text with revised section titles will prove useful. For example, if
you change a section name from “Absinthe” to “Chartreuse”, with another link
pointing to it using the text, “exotic liquors”, you might want to fix the link that
refers to it by literal name, but not the second link which remains accurate in
description.
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— If you are certain that all of the internal links you have created in your draft
are meant to be printing the title of the thing they link to as readable text,
then you can select large portions of text at once, even in a Scrivenings ses-
sion, and fix the links using the Edit ▸Text Tidying ▸Update Document Links
to Use Target Titles command in batches.

— You may also fix links one-by-one when you come across them with this
command (just make sure the whole link is selected). This command is
also available in the contextual menu when right-clicking on a link (which
will also automatically select the entire link for you), or a selection of text
that contains document links.

— This command will also clean out broken links, those pointing to binder
items that no longer exist, by removing the hyperlink from the text in the
editor and otherwise leaving the text itself alone.

How to Quickly Find Links to Fix

After you have updated a section title and know there are links point-
ing to the old title you need to fix, you can easily locate them without
proofreading the entire book yourself. Use the Edit ▸Find ▸Find by Format-
ting… (⌃⌥⌘F) command to make quick work of this, by setting the Find
type to “Links”, the Link type to “Document Link”, and then provide the
old title to the Containing text field. In combination with the Next and
Previous buttons, the Replacewith Title button can be clicked fix old refer-
ences as you locate them. Read more about the Find by Formatting Tool
(section 11.6).

ConfiguringHowLinks Look and Feel
Most of the configuration options for links are located within the Behaviors:
Document Links settings pane (subsection B.4.2). There you can configure how
links will act when they are clicked, as well as what will happen when new links
are created.
The appearance of links can be customised in the Appearance: Textual Marks

settings pane (subsection B.5.16):

— Change the colour of “Links” in the color tab.

— Select whether links should be underscored in the options tab.

10.1.3 General Referencingwith Bookmarks
It is worth mentioning that hyperlinks in the text or notes are not the only way
to tie two different items together. If you would prefer a general link between
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two items, stored as a list in the inspector sidebar, then Document Bookmarks
(section 10.3) are the way to do so.

10.1.4 Compiling Document Links
When compiling your work, the links you use can be a feature used solely as an
authoring and editing tool by stripping themoutwith theRemove all hyperlinks
setting, from the General Options (gear-shaped button) section of compile set-
tings (subsection 23.4.3). This setting will not remove links that are being used
as functional features, such as the page number placeholder or links that have
been used to include images or text.
Such links can optionally be converted into the kind of cross-referencing your

readers can make use of. Some examples range from tables of contents, “see
also” style cross-references and hyperlinks to the web. All of the types of files
Scrivener can create support linking in one form or another.4 For these more
complex uses, read on.

Combining Links with Placeholders
Scrivener comes packedwithmany useful placeholder tags that can be typed into
yourwork and substituted for dynamic informationwhen you compile. A simple
example of this is the <$modifiedDate> placeholder, which prints the modifica-
tion date of the binder item you type it into.5

An interesting capability you have at your disposal is combining these place-
holders with document links. When selecting a placeholder in its entirety and
linking to another documentwith it, themetadatawill be extracted from the link
target rather than the item you typed the placeholder into. From our previous
example, if you select the <$modifiedDate> placeholder and link it to another
document, the modification date for the target will print in this section.
You may style or format the placeholder in the manner you would like to see

the final text formatted. Since placeholders (with the notable exception of the
<$include> placeholder (subsection 10.1.5)) are all plain text they will always use
the formatting context they are included within.

Creating Cross-References for your Readers
Sometimes you may need a link to adjust the hyperlink text—what your read-
ers will see—to match the given title for the section it refers to. For example,
youmight need the Table of Contents list to print their chapter numbers, which

4 Plain–text will need you to provide instructions on how to convert links to text equivalents, in
the Markup Options compile format pane (section 24.10).
5 You can readmore about this capability with theHelp ▸ List ofAll Placeholders…menu command.
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won’t exist until you compile the draft. This method requires a few conditions
to function properly:

— Link text which is solely the title of the document it links to.

— A title prefix or suffix applied to the document level that contains the links.

— Finally, compiling to a Format that has the Update titles in document
links with prefix and suffix settings option set in the “Document Title
Links” pane (this is the default for all of our built-in compile formats).

Since titles can be added to, or even entirely replaced by the compiler, this
set of features will ensure that referenced titles in links will remain valid after
export. This can be used even in formats that do not support linking, since it
primarily is concerned with keeping the text of your document up to date with
the final presentation of its structure.
Let’s say for example we have the phrase “How to Grow Better Tomatoes”

linked to a document of the same name. The compile settings for the project
are such that in the final output the document will be printed as “Chapter 7” on
one line, with the title below it. Thus the corrected title in the text will read,
“Chapter 7 - How to Grow Better Tomatoes” (a hyphen will replace carriage re-
turns).
If you wish to cross-reference a section in a more generic fashion, without

displaying the entire title, the hierarchical numbering placeholder (<$hn>) can be
used as your link text. For this to work, the document it links to must be using
a Section Layout that adds the <$hn> placeholder to its title. This technique will
mainly be useful if you intend to cross-reference to a section without including
the title, using a generic “(see section 1.2.3)” style nomenclature.

What About Page Numbers?

In printmedia it is of course a commonpractice to include a page number
with a cross-reference, so your readers needn’t look that up themselves. If
you link the page numbering placeholder, <$p>, to a particular document
in theDraft, the compilerwill insert the a special reference for compatible
word processors to print calculated page number for that text. We could
therefore add to the above example a reference that reads, “Chapter 7 -
How to Grow Better Tomatoes (pg. 87)”.

10.1.5 Including Text FromOther Documents
In cases where multiple areas of your intended document will include identi-
cal information, it can at times be advantageous to keep only one single source,
whether in the binder or as a file on the disk. The idea being, if you need to fix
a typo or make a factual correction to all of the different places in the book that
text is used, you can do so in one single location rather than tracking down every
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instance and fixing them individually. Here are a few ideas for how this feature
can enhance your work:

— If you have been looking for a way to “clone” or “alias” binder items inmul-
tiple locations of your tree, this is a way of effectively doing so. The two
items will be distinct, but use the same content.

— Copying whole contents is one use, but the <$include> tag can be used to
insert smaller elements into longer texts. This can be useful for common
snippets, figures and tables kept in separate files, and so forth.

— When used to insert text from files off your disk, multiple projects can in-
sert material from a common source—a great way to manage such things
as author bios and keeping your compiled ebooks with up to date informa-
tion about your other works.

— They can be used to insert quotations and other snippets of text into the
title area or a document’s prefix and suffix fields, when compiling. Refer to
Using Placeholders in the Prefix and Suffix (subsection 24.2.8) for further
information.

Creating Textual Links
There are several approaches to using the <$include> placeholder, each with
their own distinct advantages:

— Specify the binder name of the item youwish to include in the placeholder
itself: <$include:nameOfItem>. This method is direct and simple, which
may be reason enough to use it. There are some advantages with more
advanced usage:

– Referring to a document by its namewith text means the request can
be modified with Replacements during compilation.

For example you could create a set of documents called “Paperback-
Other Works”, and “Ebook-Other Works”, but refer to these with
your placeholder as <$include:-Other Works>. The compile replace-
ment would look for the phrase -Other Works and replace it with the
full name, appropriate for that edition of the book.

– When using this placeholder from within compile settings them-
selves, you will need to use this method.

– A downside to be aware of is that you might end up including an un-
intended document, if there are more than one items in the binder
with the name you typed in.

— In part to answer the latter limitation, applying a link to the placeholder is
a more specific way of designating a binder item:
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1. Type the <$include> placeholder into the document where you wish
to have the mirrored or cloned text printed.

2. Select the placeholder in its entirety and use the document link fea-
ture to point it at the item you wish to have imported into this spot.

— The third possibility is to supply a file system path into the placeholder,
which will insert material from plain-text (TXT) or rich text (RTF) files on
your disk. This is a very simple process that will not insert images, foot-
notes or comments.

– Paths can be absolute, meaning the full system path to the file is sup-
plied:

<$include:/Users/account/Documents/filename.rtf>

– Paths can also be made relative to the project’s location on the disk.
This example would refer to a file in the same folder as the project:
<$include:filename.rtf>

– If you are working cross-platform, andwish to compile from both PC
and Mac, consider using Replacements to convert your path struc-
ture according to which system you are using.

How Included Text FormattingWorks
Since included text can represent formatted information, styles and formatting
will be determined based on usage:

— The included text will always use its character styling—even if that means
“no style”.

— Included text brings along its paragraph styling if the placeholder is on a
line of its own. A block quote will remain a block quote when inserted.

— The paragraph style will be omitted if the included text is inline within an-
other paragraph. It will however still bring in its own character formatting
or styles.

— Naturally, text coming in from .TXT files will use whatever formatting con-
text they are inserted into.

— The Section Type of the source document will be ignored. The inserted
text will be treated according to the type of document it is inserted into.

— An exception to the above is when placeholders are used from the compile
Format settings. In this case the original document’s formatting will be
used, including any compile settings that may be applicable to the original
item’s Section Type.
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10.1.6 External Links
Looking to link to external resources from Scrivener?

This section pertains to creating links to items in your projects that can
be taken externally to other projects or programs—not linking to exter-
nal sources from Scrivener. For general hyperlinks to the Web or other
software, refer to subsection 15.7.3.

It is not only possible to link to and from individual items within a project,
but between projects as well. With external links you can easily refer back to
individual components of your project from outside of it. Indeed, these links
can be used in any software that has a concept of linking.
This capability is accomplished via the use of a special type of URL, much like

a link to the Web, only designed to work locally on your machine. These links
will instruct Scrivener to launch, open the target project and then display the
requested resource in the editor. If Scrivener or the project is already open, then
clicking the link will have a much more immediate effect.

Linking Items Between Projects
There are two different approaches (both very similar to creating internal links
within a project) to creating a link to an item from another project:

— As bookmark:

1. Open the inspector in the project you link in, and click on the book-
mark icon (second from the left) to load the bookmarks tab (sec-
tion 13.4).

2. Select Document or Project Bookmarks (use the latter for a global
link), and then drag and drop the item from the other project into
the bookmark list.

3. Alternatively, use the Edit ▸Copy Special ▸Copy Document as External
Linkmenu command, and then paste into the bookmark list with⌘V.
Thismethodwill bemore useful if youneed to link to the item several
times from different projects or bookmark lists.

— As a hyperlink in the text:

1. Drag the item from one project into another project’s text editor area
(this includes notes and bookmark previews in the inspector).

2. Alternatively, use the special copy command mentioned above to
paste into the editor. When pasting, only the URL can be pasted;
if you prefer to see a title link, use the drag and dropmethod instead.
You can also paste this form of link into the Edit ▸Add Link… panel.
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Linking FromOther Programs
— To copy an external link, select the item you wish to link to and use the

Edit ▸CopySpecial ▸CopyDocumentasExternalLink. This plain-textURL can
be pasted into link fields, text editors and so forth.

— Alternatively, right-click on the item directly in the binder, and select
“Copy Document Link” from the contextual menu.

Advanced External URLOptions
Those familiar with editing URLs may notice that the scheme uses the familiar
key and value attribute system. The basic URL produced by the following com-
mands specifies an ‘id’ with the UUID for the selected item. Most people will
be perfectly happy with the above tools for creating links automatically, but if
you would like to exert a little more control over how the links works, such as
loading multiple items at once, or using splits, then read on.
The link is comprised of the following elements:

x-scrivener-item:///path/to/project.scriv?id=UUID&key=value

— The first part, x-scrivener-item:// is the “protocol”, or what is used to
route the link request to Scrivener on your system.

— Next is a hard-coded path to your project. Links cannot survive projects
being renamed or moved, without the path being edited in the URL. So
bear in mind that if you intend to link to a particular project heavily, you
might want to be very sure of its name and location, first.

— The question mark separates the basic request from optional attributes.
Most links will have an “id=UUID” key value pair, which loads an item into
the editor. If a link lacks this pair, the action will simply be to load the
project.

— The provided table lists optional attributes that you can add to the URL to
cause Scrivener to behave differently when loading the item (Table 10.1).
These should be added to the URL, separated with the ampersand symbol,
such as &view=qr, which will cause Scrivener to load the indicated item in
a Quick Reference panel, rather than using the editor.

Return to chapter ⤴

10.2 Using Collections
Collections are a way to further organise the content in your binder using lists,
which can pull from anywhere in the project and be displayed in any order you
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Table 10.1 External URL Options

Key Values Description

id Valid UUID The UUID of a specific binder item within the project. This
comes supplied with the URL when using theEdit ▸Copy Spe-
cial ▸Copy Document as External Link menu command, and in
most cases that will be the practical way to get that informa-
tion.

doc Binder title Instead of referring to the internal ID you can refer to the
binder title of an item. The first item in the binder matching
that name will be selected. As this is a URL, all rules pertain-
ing to encoding URLs properly should be followed, including
spaces (%20).

id1,
doc1

Valid UUID or
Binder title

Instructs the project to load additional binder items (using
any rules provided with the view settings, below, or using
Quick Reference panels by default). Any amount can be sup-
plied, such as id1, id2, id3…

view Select from one of the provided values below, for example:
view=qr.

qr Open the document in a Quick Reference panel instead of
themain projectwindow. Whenmultiple items are indicated,
they will all be loaded into their own panel.

copyholder, ch Open the document in the currently active editor’s Copy-
holder, creating one if necessary.

split Use the active split without disturbing the layout, loading the
first document into the active split and the second into the
other split.

split-h Split the editor horizontally if necessary and load the docu-
ments into each split.

split-v As above, but with a vertical split.
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please. These lists can even be automatically gathered for you using search cri-
teria you save into them. If you’d like to have a concise list of every document
flagged with the status of “Needs Rewrite”, or if you want to focus on the flow of
text within a chapter and play with the structure without changing the original,
never mind endless other possibilities, this is the feature you’re looking for.
You can think of the entries in the list of a collections as being a bit like a list

of aliases to the original items. Changes made in the editor to items within the
collection will also be made to the originals in the binder, and thus it is better to
think of them as being the same item, only being shown in two ormore places at
once. A single item can be in no collection, one or inmany—and in all cases, each
instance will point back to the same original item in the binder. If that sounds
confusing, thinkof howProject Searchworks (section 11.1), where a list of items is
created in the sidebar for you, matching your search terms—you wouldn’t think
of the search results as being separate items. (In fact, search results have a lot in
common with collections, as you’ll soon see.)
Here are some example uses for collections:

— Experiment with an alternate scene flow without disrupting the original
layout.

— Collect all scenes that still need editing.

— Designate items that you wish to share with another author using one of
the various syncing methods.

— Search for any occurrence of words you tend to overuse. Saving a search
that looks for “any word” amongst the listed words and clicking on this
tab would highlight all of the problemwords in the text editor, listing only
those sections of the binder that contain them.

— Create a special compile groupwith an alternate selection and export order
so you can compile only select portions of your draft folder.

— Store saved searches for future use, or to monitor workflows.

There are two types of collections that you can create and save, and a third
“type” that is simply the built-in “Search Results” list:

1. Standard Collections: allows you to freely add, shuffle and remove items as
you work. This is the most flexible and freeform type of collection (sub-
section 10.2.2).

2. Saved Search Collections: indicated with a magnifying glass icon beside
their name, these collections will be dynamically populated by a list of
items that match a stored search query every time you view the tab (sub-
section 10.2.4).
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3. Search Results: a special built-in collection that cannot be removed. Any
project searches will have their query and results stored in this collection
automatically for future referencing.

10.2.1 TheCollection Tab List
To reveal the collection interface, click the View icon in the toolbar and use the
Show Collections command, or use the View ▸ShowCollectionsmenu command.

Figure 10.3 The collection tab list with (a) the binder selected and (b) a collec-
tion.

Each entry in the tab list represents a single collection. In the figure (Fig-
ure 10.3), the “Binder” tab is selected on the side marked (a). While not a true
collection, this is one way you can navigate back to the main binder. On the in-
set marked (b) we have the “New Collection” tab selected. Also take note of the
added optional toolbar button to the right of the View button that you can add.
This button will toggle the collection list with a single click.
Usage of the tab list to switch between and manage your collections is as fol-

lows:

— Click on any tab to select it; when a tab is selected, it will set the back-
ground colour of the binder background and the name of the collection in
the tab list will be printed in bold and black text.

Additionally, a header bar (using the collection colour)will appear between
the tab list and the content area of the sidebar, printing the name of the
active tab and providing a few utility buttons (we’ll go over those in the
following section).
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— You could hide the collections interface at this point and continueworking
in that tab. The background colour of the sidebar and the header bar will
help remind you that you are not in the full Binder.

— To rename a collection: double-click on its name in the collection tab list,
revise the text and press Return to confirm the changes. You can also re-
name a collection from the editor header bar, when viewing its contents
in the main editor window.6

— Whenfirst created, a collectionwill be assignedwith an automatically gen-
erated colour, but you can pick your own by clicking the downward facing
chevron button, which can be seen in Figure 10.3 to the right of the label
“New Collection”.

— To change the order of any tabs in the list, drag and drop them up or down
in the list. This will also impact their order in various menus throughout
Scrivener, such as Navigate ▸Collections.

TheCollectionHeader Bar

Figure 10.4 Search results header: (a) close and return to binder, (b) load re-
sults in editor and (c) sort results.

The header barwhich appears between the tab list interface and themain con-
tent area (or simply at the very top when the list is closed) contains a number of
useful functions (Figure 10.4). In the figure, we’re viewing the built-in “Search
Results” list.

a) The × button will dismiss the current collection view and return you to
the main binder.

b) Click the ↪ button to load the contents of the collection sidebar into the
editor area on the right (the targeted editor will be used when the inter-

6 The dedicated “Binder” and “Search Results” tabs cannot be renamed.
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face is split). This will treat the collection in a similar fashion as viewing a
folder.

c) Search collections, such as the “Search Results” list depicted in the figure,
can also be sorted (section 10.2.4). Sort order can also be adjusted with the
Touch Bar.

d) The magnifying glass icon on the right side doubles as a status indicator,
letting you know that the contents of the list below are being dynamically
generated from a search result, and is also a button that when clicked, will
reveal the search criteria used to assemble the list, in the Project Search
interface (section 11.1).

Lastly, collections you create can have their colour modified by clicking a
chevron icon that will appear directly to the right of the name in the header
area (it can be seen in the inset marked (b) in the prior figure (Figure 10.3). The
search results and binder tabs use a unified colour across all projects, and can
be adjusted in the Colors tab of the Appearance: Binder settings pane (subsec-
tion B.5.2).

Disappearing Collection Tabs

On account of how scrollbars are hidden by default on a Mac, unless
scrolling, it may not be obvious that the Collection tab interface can be
scrolled, causing tabs to mysteriously disappear. If you do not like this
behaviour, you can change your Mac’s system settings in the System Set-
tings: Appearance pane to always show scrollbars.

Viewing the Contents of a Collection in the Editor
The contents of a collection are not solely a feature of the sidebar. If you would
like to make full use of the capabilities afforded by the main editor’s group view
modes:

1. While viewing a collection in the sidebar, click the ↪ button in the collec-
tion header bar.

2. Direct navigation to collections is possible from the header bar contextual
menu (section 8.1.1), under “Go To Collection”. No sidebar necessary!

3. This submenu is also available from the Navigate ▸GoTo ▸Collections ▸ sub-
menu.

Once loaded into an editor, the collection will function similarly to viewing a
folder in the editor. It will remember settings you apply to it, such as whether
you used label view or freeform corkboard (the position of the cards will be saved
into that collection), if a viewmode has been locked to it and so forth. When you
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navigate away to something else, you can return to it with the history feature as
well.

Why do the Editor and Sidebar Contents Mismatch?

In the case of lists that were the result of a search, the contents of the
list imported into the editor will match the latest search results, and thus
may differ fromwhat you see in the sidebar if it has been open for awhile.
The list in the editor will refresh whenever it is viewed (including when
moving past it via the history feature). The sidebar can be refreshed by
switching from one tab to another, or by pressing Return in the search
field at the top of the binder sidebar.

If you would prefer to view only a portion of the collection in the main editor
you can simply select those items fromwithin the list in the sameway youmight
do so in the binder, forming a multiple selection (section 6.4).

10.2.2 Standard Collections
Standard collections are just the ticket for storing ad hoc lists of items. You have
full control over what is listed within them as well as the order in which they
appear. There are a few ways to create a new collection:

1. Click the + button in the tab list header, marked (a) in Figure 10.5. Any
items that youhave selected in the active view (including the binder, search
results, or even other collections), will be automatically added to it. It is
perfectly fine to create an empty collection from no selection, too.

2. You can also create a new collection at any time by using the Docu-
ments ▸Add to Collection ▸New Collection menu command. As above, any
selected items in the current view (or the current text document you are
editing) will be added to the new collection. The tab list will open, and
your cursor will be placed in the collection’s label area so that it can be
named.

Once a collection has been created, you can add or remove items to it, so it is
not critical to select everything you need before you create it.

Adding To andManaging a Collection List
There are several methods for adding items to an existing collection:

— With the tab list revealed, drag selection of icons from anywhere icons can
be dragged from, and drop them on the desired collection tab. They will
be added to the bottom of the collection list.
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Figure 10.5 The standard collection interface.

If you hold over the target tab for a moment, Scrivener will switch to the
tab allowing you to drop the items precisely where youwant to place them
in the list.

— In variation to the above, if you hold down the Option key while dragging
a container to a collection tab, it and all of its descendent items will be
added.

— Use the Documents ▸Add to Collection submenu. This works on selected
items in the binder, corkboard or outliner, as well as from the text editor.

— In the binder sidebar, even from other collections, you can right-click on
item(s) to access the “Add to Collection” menu.

In all cases, if an item already exists in the collection it will not be added again,
and its original position will not be changed, so it is safe to err on the side of
“over-selection”.
Items can be reordered within the list using click and drag, or the samemove-

ment key combinations used in the binder (⌃⌘↑ for up, and⌃⌘↓ for down). Since
there is no hierarchy in a Collection, you will not be able to nest items.

New items created in a collection
Within a standard collection, youmay create new items using all of the ordinary
methods available for doing so. Since collections are uncoupled from the binder
structure in every way, new items will be placed into a folder, created for you if
necessary, with a name corresponding to the collection title they were created
from. These folders will be created at the top level of the binder, right before the
Trash folder. An example might be a new text file called “Joseph” in the “Char-
acters” collection. When you return to the binder, you will find a new text file
called “Joseph” in a folder named “Characters (Unsorted)”. You can freely move
this new document wherever you’d like.
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It’s important to note that this is a one-way process. You cannot addnew items
to the collection by adding them to the folder in the binder.

Removing Items from the List
Remove items by selecting them in the collection sidebar, and then clicking the
− button in the lower header bar marked (b), or by simply pressing Delete on
your keyboard.

Trashing Items From a Collection

To not only remove an item from a collection but send it to the trash as
well, then use the standard⌘Delete shortcut.

Deleting the Collection
To delete the entire collection:

1. Select the collection from the tab list that you wish to remove.

2. Click the− button in the upper title bar, marked (a).

3. You will need to confirm this action as there is no way to undo it.

Cloning and Backing UpCollections
The easiest way to create a copy of one collection (including automatically gen-
erated ones, such as sync collections, or search results) is to create a new one
with the full contents of the one you wish to copy:

1. Navigate to the collection you wish to clone with the
Navigate ▸Collections ▸ submenu.

2. Select all of the items in the binder sidebar with ⌘A.

3. Either click the + button in the collections header bar, or use the Docu-
ments ▸Add toCollection ▸NewCollectionmenu command.

You also can “back up” a standard collection by storing the list into another
document’s bookmark list. This can be useful if you have a lot of collections
bulking up the list, and have a few that are seldom used. Here is an example of
how this can be done:

1. Create a new document in the binder to store your collection list.

2. Open the inspector sidebar and click on the bookmark tab (section 13.4),
or press ⌃⌥⌘N twice. If the list is not showing “Document Bookmarks”
click the header bar to switch to them, or press⌘6.
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3. Use Navigate ▸Lock in Place (⌥⌘L) to lock the editor so that you can freely
work in the sidebar.

4. Use the Navigate ▸Collections ▸ submenu to load the collection you wish to
save into the sidebar if necessary.

5. Select all of the items you wish to save and drag them into the document’s
bookmark list.

Later on, if you ever wish to restore this collection after having removed it by
adding a new collection and then dragging and dropping the bookmark list into
the collection sidebar.

10.2.3 The Special “Search Result” Collection
If you have used the project search feature (section 11.1) before, then you’ve been
using a collection without perhaps realising it. Search results are placed into a
special built-in collection every time you run a search, and the criteria of your
search are saved into it along with the project. This means the last search that
you ran will always be available to you, even between sessions.
Like the “Binder” tab in the collection tab list, the “Search Result” tab cannot

be deleted or renamed, and there will always be one included with every new
project, even if search has never been used.
Some aspects of its behaviour also apply to saved searches, discussed in the

next section:

— When you click on the Search Results tab, the previous search criteria will
be loaded into the search bar tool, allowing you to further tweak the results
if you desire.

— Since search results are a direct product of search criteria, you cannotman-
ually add, remove, or change the order of items from this collection, as you
can with the standard type.

Upgrading from Scrivener 2

In previous versions of Scrivener you could display additional columns in
search result style collection sidebars. This feature has been removed, as
it is simple to open the list into one of the editors, where the full outliner
can be used to display and sort by the kinds of metadata that were once
here—never mind everything else the editor view can do.

10.2.4 Saved Search Result Collections
When you find yourself running the same few project searches over and over, it’s
probably a good time to learn how to save them for easy single-click recall in the
future. To create a new saved search:
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1. Start with an active search of any sort. If you are unsure of how to get a
search started, refer to Project Search (section 11.1). All of the settings you
select from the magnifying glass menu as well as what you type in will be
saved into the collection’s settings.7

2. With the project search field visible, click the magnifying glass icon to the
left of where youwould normally type in your search term, and choose the
“Save Search as Collection…” command at the bottom of the option list.

3. You will be asked to give the saved search a name. Click the OK button to
proceed.

If the search was set to Search in the “Label” scope, and the text you entered
precisely matches a label name, the associated colour will be used for the tab’s
colour as a convenience.
Saved searches load as a static list when you first click on them. If desired, you

can refresh the list by opening the Project Search field and pressing the Return
key (section 11.1.1).

Sorting the Results in the Sidebar
The contents of search lists can be sorted by clicking on the buttonmarked (c) in
Figure 10.4. All search lists share the same sort settings. The following criteria
are available:

— Binder Order: this is the default setting. No sorting will be done on the list,
with each item listed in the order they appear within the binder from top
to bottom.

— Sort by Title: the list will be sorted by the given names of items. If titles are
changed while working in the list, it will keep itself sorted dynamically.

— Sort by Date: which in this case refers to the created date of the item.

Below these options you will find a toggle for switching between ascending
and descending sort order.

NeedMore?
If you require more settings, or wish to sort by another type of metadata
entirely, then load the search result (section 10.2.1) into one of the editor
splits and use the outliner tool to sort (subsection 8.3.6) or further filter
the search results (section 11.4).

7 There is one exception: searches performed using the “Binder SelectionOnly” option cannot be
saved for future use, because the binder selection is a temporary state which changes whenever
you click in the binder. If you find yourself unable to save a search, make sure this option is
disabled.
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Updating the Saved SearchQuery
To refine or modify the search settings stored into a saved search collection:

1. You will need to start with an active search—loading the search collection
tab is sufficient.

2. Open the project search field if it is not visible: click the search button in
the toolbar, or use the⇧⌘F shortcut.

3. Modify the search settings with the magnifying glass menu. Your changes
will be automatically saved into the collection.

When resetting all search parameters with the “Reset Search Options” com-
mand, or when changing the text you are searching for, your search will be
moved to the Search Results tab, rather than directly modifying the collection.
To update a saved search collection with the current project search settings

directly:

1. If necessary, open the collections tab list with View ▸ShowCollections.

2. Right-click on the saved search collection in the tab list, and select the
“Update Saved Search to Use Current Search Settings” command.

All settings and text used in the current project search will replace the cur-
rent saved search settings.

Converting a Saved Search to a Standard Collection
Given their dynamic nature, the contents of a saved search list cannot be added
to, removed from or reorganised (outside of sorting). If you wish to “freeze” a
search list so that you can play with it freely, or simply to store it for later refer-
ence, there are two ways you can do so:

— Convert the saved search to a standard type: This will destroy the saved
search, so only use this method if you no longer need the search criteria.
To convert a saved search result to a standard collection, select the tab in
the sidebar, and use themenu command, Navigate ▸Collections ▸Convert to
Standard Collection.

— Copy the contents into a new collection: This is quite easy to do. Select
all of the items (⌘A) in the search result list, and click the+ button in the
collection header bar to create a new StandardCollection from the current
selection. The items will be listed in the new collection in the order they
were sorted within the search list.

Deleting Saved Search Collections
Saved search collections can be removed in the same fashion as standard collec-
tions, by selecting the tab and clicking the − button, marked (a) in Figure 10.5.
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Since clicking on a saved search collection automatically loads its search param-
eters into the project search tool, you can effectively undo this by switching the
SearchResults tab and recreating the collection from themagnifying glassmenu.

10.2.5 Back to the Binder
You might wish to know the overall disposition of a collection list in the binder,
or where a select few items in the list are located in the overall structure of the
project. The Navigate ▸Reveal in Binder menu command (⌥⌘R) works from col-
lections and search results. Since this command can be used on many items at
once, it makes for a handy way to see what isn’t in large collections, too.
It is possible to select some or all of the items in a collection and instruct Scriv-

ener to gather them all together into one spot, based on the order of their ap-
pearance in the collection. There are several ways of doing so:

— Drag & drop: you will need to have the collection tab interface visible. Se-
lect the files you wish to gather, drag them to the binder tab and hold for
a moment. The binder will activate, and you can drop the selection wher-
ever you please.

If theOption-dragging creates duplicates setting is enabled in the Behav-
iors: Dragging&Dropping settings pane, holding down theOption keywill
work here to duplicate the dragged items instead of moving them.

— Documents ▸Move To ▸ submenu: select the items you wish to gather to-
gether, and either use the main application menu or the contextual menu
to move them to a selected item or container. This action will operate in
the background, leaving your focus in the collection.

Likewise, Documents ▸Copy To ▸ can be used if you would prefer to dupli-
cate the items rather than move them.

— When youwant to gather the selection into a new folder, after having used
Navigate ▸Reveal in Binder, follow-up with the Documents ▸New Folder from
Selectionmenu command.

Experienced users of outliner style programs may recognise this ability as
“mark and gather”. The marking phase is done by assigning documents to a col-
lection. Moving them back out to the binder then gathers them quickly into one
focused spot. This can be an extremely useful technique for some workflows.
This technique can also be useful for implementing an experimental text flow.

If a chapter or section just doesn’t read well, you can quickly create a new collec-
tion with the contents of that section as files and then reorganise the flow using
the collection’s ability to view itself as a corkboard or outliner—and of course
reading the text with Scrivenings mode. Once you are satisfied with the new
layout, select the contents of the collection and drag them back into the original
folder in the binder using the above method. The items will be re-organised for
you back into that folder and become the new book structure.
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Return to chapter ⤴

10.3 Project andDocument Bookmarks
No doubt you’ve encountered the concept of bookmarking web sites in your
browser. We could say that at its most basic level, bookmarking binder items
is similar to this concept in that you can create and organise lists of important
or frequently used items, making them easier access and keep in mind. As with
browser bookmarks, they can be used to refer to files on your disk or resources
on the ’net, but Scrivener’s bookmark feature goes further.

Upgrading from Scrivener 2

If you’re searching this manual for “Favorites”, “Project Notes”, “Project
References” or “Document References”, you might want to head on over
to the article addressing what has become of these features in theWhat’s
New section (section F.4). The section you are reading now addresses
a new feature which combines all of the above into one single cohesive
system.

Figure 10.6 Bookmarks are readily accessible via a single click from this tool-
bar button.

In this section we’ll go over how bookmarks can be used as a universally avail-
able scratchpad, either used in a separate window or embedded into the inspec-
tor sidebar on the right hand side of the main project window. They can also be

232



10.3. Project and Document Bookmarks

used to boost your efficiency when using those types of menus that work with
or target binder items, such as the Navigate ▸GoTo ▸ submenu, by placing book-
marked items at the top of the list.
In addition to each project’s global bookmark list, every item in the binder

can also store its own list of bookmarks (available exclusively through the in-
spector). This way you can “scope” your bookmarks, having some globally avail-
able throughout the project, while each document’s bookmark list will only be
displayed when editing that document. The latter will be additionally useful in
cross-referencing binder items together.
We’ll go into the specifics of adding, removing andmanaging bookmarks after

covering the different areas bookmarks are used within. If you are brand new
to the concept and want to have a little to play with while reading through the
introduction here, do the following:

1. Click on the Bookmarks toolbar icon (Figure 10.6).

2. As instructed within the blank area of this panel, simply drag and drop
anything from your binder into the panel.

You’ve now got bookmarks (well, one of them anyway). With something start
with, let’s take a look at the various areas of the interface these bookmarks can
work within.

10.3.1 The Bookmark List and Floating Panel
The list that pops up when you click the bookmark icon is simple (Figure 10.7),
but provides for more flexibility than you might think at first glance:

— Click on a bookmark to load a binder item in the active editor.

— Double-click to load the bookmark into a Quick Reference panel. You will
also need to double-click to confirm loading if the bookmark is to an ex-
ternal resource, such as a web page or file on your disk.

— Hold down the Option key when clicking to load the bookmark in the in-
active editor split, opening one if necessary to do so.

— Bookmarked folders will have a small arrow icon to the right of the folder
name in the list. Click on this button to reveal the contents of that folder
in a menu, and select from it to navigate the editor to the chosen subdoc-
ument. The Option key method described above works here as well.

— Right-click to access extensive contextual menu options. These are the
same as those offered when right-clicking on bookmarks in the inspector.
Refer to the full documentation on the inspector’s bookmark list in Open-
ing and Using Bookmarks (subsection 13.4.2).
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Figure 10.7 The floating bookmark list can be converted to a browser.

While clicking on a button in the toolbar can be handy, there may be times
where you want the list to hang around a bit more permanently. The easiest
way to do so will be to grab any edge of the toolbar list with your mouse and
drag way—the panel will “tear off” of the toolbar and become a floating window
at that point. Alternatively use the Project ▸Show Project Bookmarksmenu com-
mand (⇧⌘B) to bring up the panel directly. In addition to all of the capabilities
listed above, the floating panel also provides a few additional functions:

— The button in the lower left makes it easy to add a link if you don’t have
the original in front of you handy for drag and drop.

— The− button is used to delete selected bookmarks.

— In the upper right-hand corner is a button that converts this floating panel
into a Quick Reference window, which serves as a bookmark browser.

10.3.2 The Inspector’s Bookmarks Tab
The inspector tab itself is fully documented in the chapter on the inspector (sec-
tion 13.4), but given the integrated role this tab plays with the rest of the project
window, we’ll cover a few concepts here as well. If you are unfamiliar with the
inspector in general, see Figure 10.8 for a quick overview on how to load book-
marks into the right sidebar of the project window.
The inspector, as a tool that is embedded directly into the project window as

a sidebar, is ideal for playing host to your bookmarks. It can be useful having
what amounts to a global notepad in the sidebar, at your fingertips no matter
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Figure 10.8 View bookmarks in the inspector by (1) revealing the inspector, (2)
switching to the bookmarks tab, (3) selection between project or
document bookmarks and (4) using the preview area to work with
the content of the bookmark, selected in the list above.

what part of the project you are working on. Project bookmarks provide this
capability, by promoting any binder item at all to this global list.
This concept is also applied to cross-referencing between sections of your

work and research, by viewing and editing Document Bookmarks right in the
same area of the inspector.
As in older versions of Scrivener (with the similar “References” feature), when-

ever you link to, or bookmark, an item from another a back-link bookmark will
be created, letting you know which items have linked to something simply by
looking at its document bookmark list.
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Figure 10.9 The bookmark list can be expanded into a Quick Reference panel
for quick access to your notes and research.

10.3.3 Workingwith Bookmarks in aQuick
Reference Panel

There are three ways to browse bookmarks in a separate window, two of which
are demonstrated in Figure 10.9:

1. Click the button in the upper right-hand corner of a floating bookmark
pane,marked (a), to convert it into aQuickReferencewindowwith a book-
mark sidebar. The same command and shortcut that brings up the float-
ing bookmark list will, if the list is the active window, convert it to a Quick
Reference window.

2. Any existing Quick Reference panel can browse project bookmarks by
clicking the bookmark button in the lower left-hand corner, marked (b).
You can also use the same Project ▸ShowProject Bookmarks command, and
⇧⌘B keyboard shortcut, to toggle this sidebar on and off when the active
window is a Quick Ref panel.

3. If you want to get straight to this type of window without going through
other windows or panels first, hold down the Option key while using the
Project menu, and select the “Show Project Bookmarks as Quick Refer-
ence” menu command that will appear. This can also be done from the
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keyboard, with the ⇧⌥⌘B shortcut.

The main difference with the bookmark list in a Quick Ref panel versus its
floating form is that it will acquire a + button in its footer bar. This is a unique
capability to this form of working with bookmarks. Instead of creating a book-
mark from an existing source you will be creating a brand new document in the
binder.
In most cases you will be asked where you would like to save the new file in

the binder. After you choose a location and click the OK button, the new note
will be created into the sidebar and you can begin typing in a name for it. Click
into the editor area of theQuick Reference panel, or press the Return key to start
jotting down your notes.
You can switch between sidebar and editor focus with the ⌃Tab keyboard

shortcut.

Default NewBookmarks Folder
When creating a new bookmark note from the sidebar you will be asked where
you would like to save it. This part of the process can be bypassed by clicking the
Do not ask again checkbox below the group selection tool. From that point on,
new notes created in the sidebar will automatically be filed into this folder for
you.8

If you change your mind about using a centralised folder in the future, you
can modify it in Project ▸Project Settings…, under the Special Folders pane (sec-
tion C.7). Select the “Ask Every Time” option at the top of the Default New
Bookmarks Folder dropdown to disable auto-filing.

10.3.4 Bookmarks in Binder ItemMenus
Adding items as project bookmarks will elevate their presence in some menus
that allow you to select binder items from a submenu hierarchy:

— Edit ▸Link to Document: for creating hyperlinks to documents. This menu
is also available when right-clicking on text in the editor.

— Navigate ▸Go To: navigate the active editor to any spot in the binder. This
menu also appears in the editor header bar iconmenu and the composition
mode control strip along the bottom of the screen.

— Navigate ▸Quick Reference: opens a Quick Reference panel for the selected
item.

8 If you have a strong preference as to how future projects should have this aspect set up, consider
saving your settings into a project template (subsection 5.4.3).
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10.3.5 Managing Bookmarks
With themain areas that bookmarks areworkedwithnowcovered, the following
serves as a reference for performing basic management tasks.

Adding Bookmarks
There are several ways to add a project bookmark:

— Click on the bookmark button in the main application toolbar (Fig-
ure 10.6), or use the ⇧⌘B shortcut to bring up the list in a floating panel.
Drag and drop the resource you wish to bookmark into the list.

— When using the floating form of the bookmark panel, you can also click on
the button to add new bookmarks. This button is functionally identical
to the button featured in the inspector (subsection 13.4.1). It also appears
in the Quick Reference bookmark sidebar.

— While editing a document in the text editor (or the section you are work-
ing on within a larger Scrivenings session), bookmark it with the Docu-
ments ▸Add to Project Bookmarks menu command. You can also use this
command on any selected amount of items in the binder sidebar, cork-
board or outliner views. This command is also available from the binder
in the right-click contextual menu.

— If you own a keyboard with a Touch Bar you can add a project bookmark
toggle button to the text editing context.

— Use the Paste command (⌘V) if you have a URI of any type on the clip-
board. This includes URLs to the web, file links and scheme links—
including external links copied from other Scrivener projects (you can also
drag directly from the other project’s binder as well).

To create document bookmarks youmust first open the inspector to the book-
marks pane, as illustrated in Figure 10.8, then:

— Copy and paste, as described above.

— Drag and drop the resource into the document bookmark list. This in-
cludes binder items or their icons, from wherever they can be dragged, as
well as from hyperlinks and internal links from text editing views.

— Click the button in the upper-right corner of the inspector listing and
use the “Add Internal Bookmark” submenu to select an item from the full
binder listing.

For external resources, the software will attempt to generate a title for the
bookmark, depending on the type of link it is. If it is a plain-text URL youmight
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get a generic title such as “Link”, but files will use the file name for the title, and
hyperlinks will try to use website titles, or the link title automatically.
Internal bookmarks are always linked directly to the name and icon of the

binder item they refer to.

Removing Bookmarks
Select the bookmark(s) you wish to delete and use one of:

— Use the same ⌘Delete shortcut you would use to trash an item from the
binder sidebar.

— Right-click on the selection and use the “Delete Selected Bookmark” con-
textual menu command.

— Inverse to the menu command to bookmark one or many files, the Docu-
ments ▸Remove fromProject Bookmarks command is available for the active
editor, binder sidebar, corkboard and outliner views. This command is
also available in the binder as a right-click contextual menu command.

— With the Touch Bar, removing an item from the bookmark list is a toggle,
and tapping it again will remove the bookmark status.

Editing Bookmark Titles
Bookmarks can have their name changed by right-clicking on the bookmark and
selecting the “Edit Bookmark” option, or by using the Esc key. If you own a key-
boardwith aTouchBar, youwill find a pencil iconwhen your keyboard focus is in
a bookmark list. Tap this to edit bookmarks. Within the Quick Reference book-
marks sidebar you can double-click on bookmarks to edit their titles or rename
the items they link to.
There are additional tools for managing bookmarks that are exclusively avail-

able from the inspector (section 13.4.2), such as updating its URL.

Renaming Internal Bookmarks is Renaming Items

Be aware that if you rename an internal bookmark (one that is a link to
another item in the sameproject binder) youwill be renaming the original
item. This is in fact less like a “bookmark” in the traditional sense of the
word, and more a second place to access and modify that original item.

Organising Bookmarks
Bookmarks are listed in the order they were created, but you can adjust their
organisation to suit your uses of them. In the case of project bookmarks, the
order will impact every context where they are displayed. It may be a productiv-
ity boost to keep frequently used items near the top of the list, where they will
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be more easily accessed from tools like Navigate ▸Go To ▸ submenu, which only
displays the top five bookmarks.

— Click and drag to reorder bookmarks among themselves. This works from
within any of the editable bookmark lists in the software, including the
toolbar popup.

— Bookmarks can be sorted alphabetically from within the list. With the
keyboard focus in the list, use the Edit ▸Sort ▸Sort Ascending or Descend-
ingmenu commands. This is a one-off command; you will need to reuse it
if you wish to sort bookmarks again.

Copying Links and URLs
Sometimes you just want a link from the bookmark, rather than doing anything
with it immediately. Perhaps you want to store it in another program or load a
URL into a browser that isn’t your default.

1. To copy a hyperlink, suitable for pasting into documents as a clickable link
with a friendly title, you can use the ⌘C shortcut on any selected book-
mark:

— File and URL links will use the bookmark name for the link title.

— Document bookmarks will use the document name. When pasted
back into a text editor in the same project they will become docu-
ment links. If you paste them into another project or into any other
external context they will become external links to that binder item.
I.e. clicking on the link in a word processing file in LibreOfficewould
open the item in your project directly.

2. To copy just the URL as a plain-text address, right-click on the bookmark
in any context and use the “Copy URL” contextual menu command.

If you’re looking for ways to copy the bookmark itself—perhaps to move a
document bookmark to a project bookmark, or duplicate a list of bookmarks
to another document, the inspector tab will be the best place for doing so (sec-
tion 10.3.5).

Copying Bookmarks Between Items
Bookmarks of all types can be freely copied andpasted between lists, both project
and document alike. They can also be dragged from one list to another—a
possibility between Document Bookmarks when Quick Reference panels (sec-
tion 12.6) are in play.
Collection lists (section 10.2) and internal bookmarks are very similar to one

another. You can almost think of bookmarks as being private collection list that
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each item in the binder has available for use. You can freely drag and drop items
between bookmark and collection lists.

Sharing Bookmarks Between Projects
If you drag items from the binder of one project, into the bookmark tab of an-
other (either project or document bookmarks are a valid target), this will store a
special external direct link to the individual items you dropped. Double-clicking
this bookmark will load the project if necessary and open the item you linked to
within it. Read more about cross-project item links in External Links (subsec-
tion 10.1.6).
External bookmarks can be copied and pasted from one project’s bookmark

tab to another, and in most cases this will be the preferable way to doing so, as
dragging bookmarks between projects will cause a loss of their titling informa-
tion.

Return to chapter ⤴

10.4 OrganisingwithMetadata
Documents of all kinds can have various metadata associated with them. Meta-
data is a way of talking about something without changing it directly. A sim-
ple example from the analogue world could be a Post-It note on a paper-clipped
stack of paper. The Post-It note is a kind of metadata, as is the paper-clip. Just
as with these paper-world tools, digital metadata can help us more easily search
for tagged items, either visually while browsing, or through tools such as project
search (section 11.1).
Let’s go over each of the types of metadata that Scrivener provides to items,

the basics of how they can be set up, assigned, and how they will in general be
displayed within the software. The main interface for viewing and editing all of
the metadata for a given document is the inspector; here we will focus on the
bigger picture, so you should refer to that section for the details on using that
pane (chapter 13).

10.4.1 The Title of an Item
Themost important piece ofmetadata any itemhas is so fundamental youmight
not even instinctively think of it as being metadata: its Title. The title will be
used to identify the document in the many views, menus, as well as exporting
items as files and oftentimes as headings in a compiled document.
Refer to Titles and Adaptive Naming (section 7.2) for further information on

using titles.
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10.4.2 The Synopsis of an Item
The Synopsis is a plain-text field, primarily intended to be a short summation of
the contents of the document, though how you choose to use it is entirely up to
you. The synopsis is displayed in three prominent areas:

1. Corkboard: used to display the content area of the card.

2. Outliner: will be placed beneath the title by default.

3. Inspector: if you need to reference an item’s synopsis without finding it in
a list somewhere, the inspector sidebar’s Notes tab, or the special Synopsis
split in a Quick Reference panel will be the best approach.

Instead of the text synopsis, you can elect to use an image to represent a doc-
ument on the corkboard. This image will be used on the corkboard and in the
inspector, but whatever text exists in the standard synopsis field will be used in
the outliner, as described above, and in the various export and print options that
include a synopsis field.

10.4.3 Labels & Status
The next two forms of metadata are flexible in how you can refer to themwithin
a project. You can give these fields custom names and the interface and menu
commands will adjust accordingly. If you wanted, you could have “POV” and
“Location” instead of label and status, or “Focus” and “Type”, or “Monkeys” and
“Bananas” for that matter. The documentation will of course continue to refer
to them as labels and status for the sake of simplicity.
All new projects come with a few generic labels and status, but you will most

likely wish to add your own or change them completely. Use the Project ▸Project
Settings… menu command to access panes via Label List & Status List (sec-
tion C.3).
After the title itself, they are the most visible form of metadata. They can

be represented in the corkboard and outliner views, are always present along
the bottom of the inspector and Quick Reference panels and are given priority
placement in most printing methods.
Aswith allmetadata, one of the primary purposes of using them is tomake our

searches more powerful and specific. In addition to regular project searches by
label or status, you can also use these types to filter outliner & corkboard views
(section 11.4).

Label Colours
Since label colours can be used to accent various areas of the projectwindow, you
can choose colours that reflect how prominent you wish them to be. For exam-
ple, richer more vibrant colours can be used among pastel choices to indicated
tension, or priority.
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Label colour can be expressed in the following ways:

— On the corkboard, index cards will bear a strip along the left edge of the
card indicating label assignment. UseView ▸CorkboardOptions ▸ShowLabel
Color Along Edges (⌃⌘P) to toggle their visibility.

— There is an entire corkboardmode dedicated to working with labels. Read
more about that in Arrange by Label (subsection 8.2.5).

— The outliner has the label column added as a default to all new projects.

— As previously mentioned, the View ▸Use Label Color In ▸ submenu contains
a number of options for tinting various areas of the project window or
elements within it with the label colour:

– Binder: A dot will be placed to the right of an item in the binder, sig-
nifying its label setting. If you prefer the binder row be highlighted,
use the “Show as Background Color in Binder” option, below.

– Icons: Only the iconswill be tinted throughout the project. Wherever
the icon for an item appears (such as in the editor header bar, next to
the title in corkboard, in search results, and so forth) it will be tinted
using the colour of the assigned label.

– Index Cards: The entire background “paper” for index cards will be
tinted using the assigned label colour. This includes the index card
that appears at the top of the inspector.

– Outliner Rows: The background for the entire row will be filled in
with the label colour.

– Scrivenings Titles: When View ▸Text Editing ▸Show Titles in Scrivenings
is enabled, the line of text used to print the title of a document in
Scrivenings mode will be tinted using the label colour of the corre-
sponding document, giving you a valuable look at your labels colours
directly in the text editor.

— When printing outlines or corkboards (chapter 26), label colour can be
added for effect (it will be enabled by default on index card printouts).

Status Stamps
As with labels, the status field can have its representative name altered to suit
your project’s unique requirements. By default, this field represents the status
of a document in terms of its completion, such as “To do” or “Rough draft”, but
this field can be used for whatever purpose you desire.
Unlike the label, there is no corresponding colour, and so its display potential

is more limited:
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— On the corkboard, they can be displayed as an optional “stamp” across
the face of the card with the View ▸CorkboardOptions ▸ShowStatus Stamps
menu toggle (⌃⌘S).

— In the outliner, the status is one of the default columns that comes with
every new project.

— An item’s Status settingwill be used to help you identify untitled snapshots
(subsection 15.8.1), such as “Untitled (First Draft)”.

10.4.4 CustomMetadata
For all of the things we couldn’t think of. With four different types of field
and extensive support for searching and filtering, custom metadata picks up
where the stock tools leave off. These can be used to create however many fields
you need in a dedicated form built into the inspector pane, as sortable outliner
columns or tools for filtering corkboard, outliner views and project searches:

— Text: a simple text field. This tool is great if you need tomark sectionswith
a specific piece of information that is often different for each item in the
outline, but has a common theme. Useful for bulk text with an optional
word wrap, or short snippets of information. E.g. a non-fiction book on
edible plants might use a text field to record the Latin name of the plant
discussed in that outline item. This information is something you would
probably want to print in the book as well (and you could, with placehold-
ers used to insertmetadata into the text, but that’s amore advanced topic!),
but itmight also be useful to you as an author to have a concise list of these
names in the outliner as a dedicated column.

— Checkbox: the simple act of saying yes or no about a thing can yield a lot
of flexibility in how you work. Create simple to-do lists, mark when blog
articles have been published or track phases of a large editing project in
conjunction with searches by checkbox state.

— List: if you find yourself wishing you can add another dropdown field like
label or status provides, this is the tool to use. Using a similar approach as
the status field, you can add list items, organise them and choose a default.

— Date: store date and time information with an easy to use calendar inter-
face coupled with a natural language recognition system that lets you type
in things like “monday” and have the computer figure out for you when
the next Monday will be. Use this to store publication dates, timeline in-
formation, deadlines and so on.

Get started with setting up your own fields by using the Project ▸Project Set-
tings… command, in theCustomMetadata pane, and be sure to check out the fol-
lowing references for further documentation on the various places where these
fields are set up and used.
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See Also…
— Overview: how custom metadata (subsection 10.4.4) can benefit your

work.

— Settings: adjusting the available fields and their settings, in project settings
(section C.4).

— Inspector: editing custom metadata on a per-item basis with a form built
into the inspector (subsection 13.5.2).

— You can use list and checkbox type fields to filter outliner & corkboard
views (section 11.4).

10.4.5 Using Keywords
Each document can have a list of keywords associatedwith it (what youmight be
more familiar with as “tags” in some other programs). These are useful for mak-
ing documents easily searchable—for instance, you can list all characters and lo-
cations connected with a scene, even if they are not mentioned explicitly in the
text. Creative uses for keywords also include extended status control, editing
milestones, plot management, and whatever else you can think of.
Their biggest advantage is innon-exclusive assignments. Adocument canonly

have one label, and thus be one type of thing at a time, but you can have as many
keywords as you need assigned to one item, creating compound descriptions of
items, and allowing for overlap with other items that may not be similar, but yet
still share some common attribute.
Keywords can be displayed in the following fashions:

— On index cards in the corkboard, as coloured strips of “tape” along the
right-hand side: use the View ▸Corkboard Options ▸Show Keyword Colors
(⌃⌘K) menu toggle.

— As an outliner column, where they can be listed by name with View ▸Out-
linerOptions ▸Keywords, and as the default sub-option as coloured squares,
with … ▸as Color Chips.

— As an editable list, in the Keywords pane of the metadata inspector tab
(subsection 13.5.3).

As with labels, keywords each have an associated colour displayed beside the
keyword in the inspector list, as an underscore in the relevant outliner column,
and in the Project Keywords window (see below). Additionally, keywords can be
used in the corkboard as small coloured tabs along the right-hand edge of the
card. The visibility of these can be toggled with View ▸Corkboard Options ▸Show
Keyword Colors (⌃⌘K).
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Keywords are Case-Sensitive

When you assign keywords to documents from their inspector pane, they
will automatically suggest any existing keywords fromwithin the project.
However you should be aware that keywords are case-sensitive, meaning
that if you have a keyword called “Software” in the master list, but start
typing in “sof” in the inspector, nothing will be suggested, and indeed
adding it as “software” would create a new entry in the list.

Project Keywords Panel
The Project Keywords panel holds all of the keywords in use by the project.
As you assign keywords to items, using the Inspector’s Metadata tab (subsec-
tion 13.5.3), they will be added automatically to the central project list, making it
a complete reference of all keywords in use within the project (you can also cre-
ate keywords for future use here, without assigning them to anything yet). The
panel is also how you will handle bulk management of keyword assignments for
many items at once.
You can access this pane via Project ▸Show Project Keywords (⇧⌘K) or by

double-clicking any of the keywords in the Inspector pane.

Figure 10.10 The Project Keywords panel shows all keywords in the project.

You can create or delete keywords by using the buttons at the bottom of the
panel (Figure 10.10):

— The left-most button creates a new keyword as a sibling of the selected
keyword. If we selected “Status” in the example and clicked this button
the keyword would be on the same level as “Topics” and ”Status.

You can also create new sibling keywords with the Return key.
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— The second button creates a new keyword as a child of the selection. With
the same example but clicking this button, the keyword would be added
along with “In Editing”, “Proofing” and “Final”.

— The third button deletes the selected keywords. If any of the keywords in
the selection are assigned to items in the project you will be warned and
asked to confirm the deletion.

Organising Keywords

The Project Keywords panel is a freeform work space where you can organise
your keywords into groups and arrange them sequentially, by topic or however
you see fit.

— To change the order of keywords within the list, use drag and drop, or the
keyboard shortcuts from the Edit ▸Move ▸ submenu.

— You can also drag any keyword onto any other keyword to nest keywords.

In the example figure, we have nested “Software”, “Writing” and “Blogs”
into a keyword called “Topics”. This relationship ismerely for organisation
within this panel. The “Blog” keyword will not print that it is a “Topic” in
other areas of the software, and indeed the “Topics” entry is itself a key-
word that can be individually assigned to items.

Prefer Alphabetical Sorting?

While the keyword list will leave the organisation up to you, it is possible
to manually sort the entire list alphabetically whenever you wish to do
so, via the Edit ▸Sort ▸Sort Ascending or Sort Descending commands.

Assigning Keywordswith the Panel

Use any of the following methods to assign keywords from the panel to docu-
ments in the main project window:

— Select and drag the desired keywords from the panel and drop them into
the keywords pane in the inspector, a Quick Reference keyword split,
the header view above the document editor or onto the document in the
binder, corkboard or outliner.

— If there is a multiple selection in the binder, corkboard or outliner then all
selected keywords will be applied to all selected documents.

— Hold the Option key down whilst dragging to drag not only the keyword
but also any parent keyword(s) under which it is grouped.
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— Right-click on the selected keywords (or use the button) and select the
“Add Keywords to Selected Documents” command. This method will ap-
ply the selected keywords to all documents within the active Scrivenings
session.

— Cut, Copy and Paste can be used to spread keywords around between any
context where they can be selected and edited.

Removing Keywordswith the Panel

If you need to remove a specific keyword from an item, it will be easiest to do so
from its keyword list in the inspector’smetadata tab. However in caseswhere you
need to remove a keyword from several documents at once, the project keywords
panel is the best place to do so:

1. Select the documents youwish to remove the keyword from, in the binder,
outliner or corkboard.

2. Open the Project Keywords panel and select the keywords you wish to re-
move from the selected documents.

3. Right-click on the selected keywords (or use the button), and use the
“Remove Keywords from Selected Documents” command.

Changing KeywordsGlobally
Intuitively, if you change thenameof a keyword from theProjectKeywords panel
it will be altered throughout the entire project. Likewise changing the colour can
be done from this panel. To do either, first use the Project ▸ShowProjectKeywords
menu command to load the keywords panel.
To change the name of a keyword:

1. Double-click on the name of it in the panel, or press the Esc key, and edit
the label.

2. Click elsewhere to confirm your change, or press the Return or Esc key.

To modify the colour assigned to a keyword:

1. Double-click the colour chip itself.

2. This will bring up the standard colour chooser. Close this panel when you
are done.

3. You can recolour several keywords in a row by leaving the panel open, then
selecting the next keyword and choosing a colour.
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Deleting a Keyword from the Project
To fully remove a keyword from a project, not only from themaster keyword list
but from every item that was using it as well, you will need to use the Project
Keywords pane:

1. Open Project ▸ShowProject Keywords (⇧⌘K).

2. Select the keyword(s) you wish to remove. You can select multiple key-
words with the Shift and Cmd keys.

3. Click the − button in the footer bar, or press the Delete key on your key-
board.

For keywords that were not assigned to any items in the binder, this will
be done silently andwithout confirmation. If a keyword is in use, then you
will be warned and asked to confirm the removal.

Searching by Keywords
Although you can manually run a project search (section 11.1) for keywords, the
Project Keywords window provides a convenience button for this that will set
things up for you.

1. Select the keywords you need to hunt down, from the floating window.

2. Click the magnifying glass button in the bottom right-hand side of the
panel.

There are optional search modes that can be accessed by right-clicking on the
button. Upon selection of one of the following search tools, the desired search
will be immediately used, or updated if the Search Result list is already showing:

— Search Keywords Only: this is the default search mode. The project search
tool will be set so that only keywords are scanned throughout the project.

— Search All Content: words found in text that match the keywords will
looked for in all searchable areas of the project—in the main text editors,
through binder titles, custom metadata, labels, synopses and so forth.

— Show Document with No Keywords: simply put, any documents in your
project that have no keywords assigned to them will be returned in the
result list. This setting requires no keyword selection, nor will it use one.

If you have selected more than one keyword, then only those documents that
contain all of the assigned keywords will be returned (boolean AND). If you
would prefer any (OR) of the keywords instead, then click the magnifying glass
icon to the left of the project search field, and select “Any word”.
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Are These Regular Project Searches?

Yes, and no. The search engine being used is of course the standard
project search tool, and you will get results just like you do when search-
ing a project normally. However the keyword search utility will not per-
manently change your search settings. If you dismiss a keywords search
and then type in the same keyword again by hand into the project search
tool, the search result will likely be different unless your settings just so
happen to perfectly match one of the presets described above.

Importing and Exporting Keywords
If you would like to copy keywords from one project into another, follow these
steps:

1. Open both projects, and in each, use the Project ▸Show Project Keywords
menu command to open their respective keyword lists.

2. Select the keywords youwish to copy fromone list and drag and drop them
into the other project’s keyword list. Colour assignmentswill be preserved.

This will always duplicate the keywords into the new project, so existing
keywords with the same name will not be overwritten.

There may be cases where you want to either preserve your keywords outside
of Scrivener, or bring in a list ofwords to be used as keywords. Scrivener supports
dragging or copying and pasting into, and out of, any text editor as well.

— Export: select the keywords you want to export and drag or copy and paste
them into any text editor in any program.

This will create a comma-delineated list of terms.

— Import: as you might have suspected, the list of terms you created when
exporting keywords can be dragged or pasted straight back into a Project
Keywords pane to import them as keywords.

In addition to comma-delineated lists, you can also format your list as one
keyword per line.

See Also…
— Project Search (section 11.1): although the panel has a useful button for

invoking a project search, itmight be a good idea to knowhow that feature
works as well, so you can fine-tune results if needed.

— Metadata inspector tab (subsection 13.5.3): you will most often interact
with keywords in the inspector’s metadata tab, assigning them to docu-
ments directly.
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10.4.6 Exporting and PrintingMetadata
All metadata can be exported in a variety of ways, usually text-based for maxi-
mum compatibility, so you needn’t fear having important organisational infor-
mation being “locked-in” with the project format. Metadata can be exported in
the following fashions:

— Compiling: you can include the metadata for each section of your draft
when compiling, by setting up Section Layouts designed for that purpose
(section 24.2.1).

Additionally, Scrivener comes with placeholder codes that can be used to
print metadata when compiling. You will find a list of these placeholders
in the Help ▸List of All Placeholders…menu command. In conjunction with
the Section Layout feature, the possibility for creating your own template
outputs for metadata are endless, but you can also simply print metadata
directly into the content area by adding the placeholders into the text ed-
itor.

— File export:

– With File ▸Export ▸Files…, metadata can be exported as sidecar .txt
files along with the content (section 25.2)

– Using File ▸Export ▸Outliner Contents as CSV… every single type of
metadata in the software can be exported to spreadsheet format.

— Printing: when printing documents from the editor, there are numerous
options available for including metadata (chapter 26).

— Drag & Drop and import: When dragging documents from one Scrivener
project to another, or using the File ▸ Import ▸ScrivenerProject…menu com-
mand, all metadata will be preserved where applicable. In some cases, like
custom metadata, matching fields will need to be prepared, as new field
types will not be created in the target project with drag and drop.

Refer to Copying Settings Between Projects (section C.1) for general infor-
mation on transferring metadata settings from one project to another.

— Outline and Corkboard printing: both of these printing methods optionally
allowmetadata to be used in the printout. Unlike the above two examples,
these allow for a more fine-grained approach, letting you export just the
label or keywords if you want.

10.4.7 SettingMetadata toMany Items
The inspector provides a simple interface for adjusting metadata, but it only
works on one selected item at a time. Some kinds of metadata can be set in a
bulk, or batch fashion using other means. How to do so depends on the kind of
metadata you want to change:
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— For keywords use the project keywords panel (section 10.4.5).

— For list types, such as the Section Type, Label, Status and custom lists:

1. Select the items you want to bulk change. This can be done with the
binder sidebar, corkboard or outliner.

2. Right-click on the selection.

3. In the contextual menu, examine the field name you want to change,
and from its submenu select the value to set the selected items to.

— For checkbox types you will need to use the outliner.

1. Select the items you want to bulk change. The selection can bemade
from anywhere, but the result will need to be viewed in the main ed-
itor using the View ▸Outline group view mode (section 8.3).

2. Use the View ▸Outliner Options submenu to add the field you want to
change.

3. There are now two approaches you can take:

a) Option-Click on any of the checkboxes to toggle all of the visible
checkboxes along with it.

The key word here is visible. Use the outliner’s ability to collapse
trees of items in your favour, if you only want to impact certain
levels of items.

b) First select, using the Shift and Cmd keys to do so, and then
Option-Click on any of the checkboxes within the selection. The
behaviour will be as described above, but it will only toggle the
checkboxes in the selected rows.

The other forms ofmetadata, such as freeform text fields and dates, cannot be
changed in bulk.

Return to chapter ⤴
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Being a tool designed to bring research, writing materials and the work itself
all together into one interface, methods for searching through the haystack and
finding your needle of themoment are paramount, and recognised with filtering
and searching tools at every level of the software, from the binder on down to
finding specific images within your text.
The first two methods we will look at cover most basic needs:

— Project Search (section 11.1) is a binder tool that can scour the entire
project’s text content and return a list of matching items, right in the side-
bar itself. Hosting the search result list in the sidebar means full access to
the same document management tools you would use in the binder.

— Document Find and Replace (section 11.2) helps you locate instances of
text within an editor, in a familiar step by step fashion through the text,
or even within smaller bits of text, like the synopsis area in the inspector.
This tool is also capable of replacing text.

The rest of this chapter will cover tools for handling specific types of searching
(and replacing):

— Project Replace (section 11.3) for bulk project-wide replacements, from spe-
cific areas of the project, such as selected Titles alone, to complete replace-
ment wherever text can be stored.

— Filter Outliner & Corkboard Views (section 11.4) for a quick way to find
that one card you’re looking for in a folder, or perhaps to only view those
items marked as “first draft” in your outliner.

— The Quick Search Tool (section 11.5) sits in the main application toolbar
and serves as a quick way to get to a specific document in your editor. Sim-
ply type in the phrase from the document you’re looking for, or part of its
name, hit Return and off you go.

— Finally, the Find by Formatting Tool (section 11.6) works a lot like regular
text Find does in your editors, using a step by step method, only it is de-
signed to find formatting. Search by styles, inline annotations, comments,
footnotes, images, tables, links, colours & highlights andmore. Unlike reg-
ular Find, this tool will by default jump from one text file to the next in the
binder, in the direction you are searching (next or previous).

If a search tool has a small magnifying glass icon with a downward facing ar-
row to the left of the area where you type in text, options will be placed there to
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Figure 11.1 Filtering the corkboard: the magnifying glass icon in the search
field grants extra searching options.

modify the search. In the case of Figure 11.1, we can click on this icon to broaden
the search to include all text and notes (rather than just the stuff we can see on
the index cards), or gain access to the regular expressions (section 11.7) search
syntax.

11.1 Project Search
With the Project Search tool, you can quickly scour the project and get a list
of every matching document in the sidebar. This can be as simple as typing in
the word “hello” and finding every item that has that word in it (and by that we
mean nearly everything about a document that consists of text, from assigned
keywords, labels, the title to its synopsis and soon). There are a bounty of options
for putting together some fairly surgical searches too, should you need them.

11.1.1 The Basics
Project search gathers all matching binder documents into a list in the left side-
bar, temporarily replacing the binder. You can think of it as a way of “filtering”
the binder so that it only shows those items that match the search. Searching
in this fashion is more like searching the web for pages, or your email inbox—
and as with these kinds of tools, once you get into a specific web page or email,
you would then use regular text find to step through matching text to find the
specific phrase you are looking for.
To indicate that you are no longer looking at the binder, the background

colour of the sidebar will change to purple and some additional controls will
be added to the top of the sidebar. When you are ready to dismiss the search and
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return to the binder, click the small× button in the sidebar heading, marked (a)
in Figure 10.4, or simply tap Esc while in the search field to dismiss the search
results (and tap Esc again to dismiss the search field itself).

Can I easily get back to a search list?

Yes! Search results are stored into a special collection that cannot
be removed, which always stores the last search you used, even af-
ter closing and reopening the project. If the list of collections is hid-
den, the easy way to get back to your search list will be with the Navi-
gate ▸Collections ▸Search Results menu command. Otherwise, it will be
easiest to simply click on the “Search Results” collection tab in the list.
For more about navigating among and using collections in general, read
Using Collections (section 10.2).

Starting a NewSearch
There are two ways to start a new project search:

1. Click the “Search” button in the toolbar to reveal the search field (Fig-
ure 11.2).

2. Use the command, Edit ▸Find ▸Search in Project… (⇧⌘F), to open the field
and place the cursor there in one move.

Figure 11.2 The default project search field, with the “Search” toolbar button
above.

Now all you have to do is start typing. As you type, matching documents will
be returned to you in the list below the search field. When nothing is entered in
the search field, greyed out text will inform you of the current search mode. By
default this is “All (Any Word)”, meaning all searchable elements in the project
will be examined with the “any word” operator—any word you type in will result
in a match if the document contains it somewhere.
The search scope, data type, and operatormode can be adjusted via the project

search options menu. Click on themagnifying glass to the left of the typing area
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in the search field (Figure 11.2) to review the available options.1

FindingMatches in the Editor
In addition to highlighting all matched text for easy visual recognition, the text
you searched for will be automatically loaded into the text find tool for you. This
means you can immediately use the keyboard shortcut to find the next search re-
sult within themain editor (⌘G), even without loading the Find window before-
hand. Refer to Document Find and Replace (section 11.2) for additional details
on this tool.
If nothing is found, bear inmind that searching the project can examinemany

different types of elements, the matched text may not be in the main editor—it
might be a label or keyword, for example.

Browsing and Sorting Results
You can use a search result list just like you would use the binder normally. Oth-
erwise, while typing in a search, you can flip through search results with the ↑
and ↓ keys on your keyboard, loading the result into the currently active editor
(use theTab key tomove your cursor into the result list itself). Refer to the section
on Selecting Items (subsection 6.3.2) for tips on viewing multiple items.

Figure 11.3 Use the “Previous” and “Next” document buttons to flip between
search results.

From within the editor context, you can jump from one search result to the
next using the “Previous” and “Next” document buttons on the right-hand side
of the editor header bar (Figure 11.3), or use the associated keyboard shortcuts:
⌥⌘↑ and⌥⌘↓.
The list of results can also be sorted, using the control marked (c) in Fig-

ure 10.4:

— The Binder Order is the default, merely listing items in the order they are
found within the binder.

— Sort by Title: sorts by the visible title in the list, including any automati-
cally generated titles if the items do not have specific names given to them.
When using this sort mode, the A-Z option becomes available. Disable it
from this menu to search in descending order instead.

1 If for some reason the search field is visible but you haven’t used it yet, the standard but some-
what oddmacOS behaviour of disabling the control will be in effect. If you want to go directly to
the magnifying glass menu, click where the magnifying glass will be once the field is active. This
will activate the field and bring up the options menu in one click.
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— Sort by Date: sorts the list by Created Date in ascending order. When
using this sort mode, the optional behaviour becomes Newest First, and
is disabled by default.

Locating Results in the Binder
In addition to locating and reviewing content itself, you might want to use the
Project Search feature purely as away of locating and selectingmatching items in
the binder itself. Since searching uses the binder sidebar itself to show the result
list, you will need to use the Navigate ▸Reveal in Binder (⌥⌘R) command to close
search results and return to the binder with each selected result highlighted in
the binder. This command will expand any hierarchy necessary to fully reveal
the selected items.
The command can also be used from the editor to reveal then item you’re cur-

rently reviewing.

Refreshing Results
As you type, the contents of the search result list will refresh dynamically, nar-
rowing down the result efficiently. However once you’ve stopped typing, actions
taken elsewhere in the project window that might impact search results will not
update the list. This allows you to work off the list without it constantly chang-
ing beneath you. To manually refresh the results click into the search field and
hit the Return key.
For cases where you’ve loaded search results into an editor (as above), you can

refresh the list by clicking the button to load the list into the editor again, or
simply navigate away from and then back to the list with the history buttons.

Project search finds nothing, or not everything it should.

Project Search has a number of options, some of which are telegraphed
as grey placeholder text when the search field is empty. If you get un-
usual results, double-check search settings as described in the following
sections, by clicking on themagnifying glass button to the left of the text
field itself. You can also reset search options to default from this menu
(section 11.1.2).

Taking Results to the Editor
In some cases youmay want a little more space to work with your search results,
or access to some of the powerful capabilities afforded by the outliner and cork-
board view modes. At any time, click the ↪ button marked (b) in Figure 10.4 to
load the contents of the sidebar list into the active editor.
This is also a greatway to search again, if the initial search result was too broad

and you want to search by a second factor. With the focus in the editor, press
⌘F to bring up the outliner & corkboard search tool (section 11.4).
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11.1.2 Search Settings
All project search settings are accessed via a menu interface. Bring it up by click-
ing on the magnifying glass to the left of the search field.

Search In
The initial section of the options menu is for selecting the type of element that
project search should look within. You can select multiple elements by holding
down the Option key and clicking on a type. Option clicking can also be used to
toggle a field off without disturbing the overall multiple selection. To return to
using a single element, either select “All”, or select any element without using
the Option key.

— All: the default searchmode. Every element of an item containing search-
able text will be queried for matches.

— Title: only the titles of binder items will be searched.

— Text: the text contents of files and folders will be queried. This does not
include notes and synopses.

— Notes: an item’s inspector notes will be searched.

— Synopsis: the synopsis field for each document will be searched. This is
anything that has been typed into the text area of an index card or in the
synopsis portion of the outliner, not any text automatically generated for
the corkboard.

— Keywords: matches found within an item’s keyword list. You can also
perform keyword searches quickly by using project keywords panel (sec-
tion 10.4.5).

— Label: the text (not colour) of the label metadata will be searched. Note
the nameof thismetadata field can be changed per project. Available labels
and status for the project can be referenced in the Project Settings: Label
& Status List panes (section C.3).

— Status: the text of the status metadata will be searched. Note the name of
this metadata field can be changed per project.

— Section Type: documents can be searched for by their type. This makes
it easy to hunt down all items flagged as being a “Chapter” for instance,
or a “Figure”. A project will list its available section types in the Project
Settings: Section Types pane (section C.2).

Following the standard list above, any custommetadata fields you’ve added to
the project will be listed in a separate section. Select from these to search within
that field specifically. How searching works within the field is determined by its
type (“text” type metadata fields work identically to all other text searches):
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Checkbox Search by “yes”, “true” or “1” to find all items that have been checked.
Searching for “no”, “false” or “0” will return those items that have not been
checked.

List These work just like the status and label elements do, using regular text
searches to find which items match the text you’ve typed in.

Date Search by any part of a date as text. For example “04” would return items
set to April, but it would also find items set to the 4th day of any month.
You can type in more of the date to be more precise, such as “2017–04” to
weed out those using the 4th day.

In addition tomatching dates by text, you can use our relative datematch-
ing syntax as well. Refer to Searching by modification and creation date
(section 11.1.3).

Operator
Select the method by which your text will be used by the search engine:

— AnyWord: the default search method. Queried documents must contain
at least one of the words typed into the search field. Analogous to logical
OR.

— AllWords: every word entered into the search field must be present. Doc-
uments which only match some of the words will not be returned. Words
can be entered in any order. Analogous to logical AND. You can also enter
double-quoted phrases mixed in with single words, working in the same
manner as Exact Phrase, below.

— Exact Phrase: what you type into the field will be queried precisely as it
is typed in. “The book” will only match documents that have the phrase
“the book” as written, not documents that just have theword “book” or the
phrase “book the”. It will also return documents that contain “the books”.
For exclusive matching, useWhole Word.

— Whole Word: unlike any of the above search methods, the term supplied
will only match whole words. A search for “Jo” will only return documents
with that word, not documents that also contain “Jocelyne”.

— RegEx: enables the powerful Regular Expression search syntax (sec-
tion 11.7).

Options
Provides a few extra options, as well as setting scope limiters. Scopes instruct
the search engine to only scan select parts of your binder.
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— SearchDraft Only: will only look in the “Draft” folder of the binder. Note
that if the name of draft folder has been changed in the project, the title of
this option will reflect that name change.

— Search Binder SelectionOnly: preselect items in the binder and then per-
form the search against those items only. The selection you make will im-
plicitly include all subdocuments as well in the selection. So if you wish
to search an entire “chapter folder” with many subsections within it, you
need only select the one master folder.

— Exclude Trash Documents: ordinarily, items located in the trash will be
discovered by search results, represented by faded icons in the search re-
sults list. If you’d rather not see them at all, use this option to disable Trash
folder searching. This option is not used by Saved Search Collections.

— Search “Included” Documents: regard documents that have beenmarked
as “Include in Compile” in their metadata. This option can be combined
with the below, and one must always be selected (otherwise you wouldn’t
find anything!)

— Search “Excluded” Documents: regard documents that have not been
marked as “Include inCompile” in theirmetadata. This option can be com-
bined with the above, and when both are selected, this particular setting
will be ignored.

— Case Sensitive: by default, the search engine ignores letter case. If you
need to search for proper nouns and are getting a lot of false positives, this
option can help.

— Ignore Diacritics: those symbols used to mark letters, such as ‘é’, will be
ignored, meaning that é = e for the purposes of search results.

— Invert Results: all of those items that do not match the current search
criteria will be listed. For example, if you search for the label, “Red”, then
only items not marked with the red label will appear.

— Find Duplicates: the search result list will be checked for items with du-
plicate content within them. Items notmatching search results will not be
found. For more information on how this feature works, refer to Finding
Duplications (section 11.1.3).

Resetting SearchOptions
To reset all search settings to a few simple default settings, select the “Reset
Search Options” command in the magnifying glass menu. This will change the
settings to the following settings:

— Search in: All
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— Operator: Any Word

— Options: all disabled, save for the two toggles to search for both “included”
and “excluded” documents.

11.1.3 Special Search Terms
Beyond simply typing in the text you want to find, there are some useful tricks
you can use to narrow down your search further, or even mix certain types of
search together.

Mixing exact phrases with all words If you want to find every document con-
taining a word as well as a particular phrase, put the phrase in double-
quotes while leaving the search operator set to “All Words”. The term Bob
"black car"would locate all documents referring to a “black car” that also
mention Bob. The quotes cause the phrase to be treated as a word.

Finding things that don’t have a word Sometimes the most efficient way to
make a long list of search results shorter is to omit themost commonword
that you aren’t looking for. Place a hyphen directly in front of such a word
to remove it from the list of possibilities. A simple example would be to
search the “Text” for Lydia -Dovahkiin, to find all documentsmentioning
Lydia that do not also refer to a certain individual named Dovahkiin.

This technique can be used with the AnyWord and All Word operators. It
can also be combined with quoted phrases. For example, Lydia -"Needs
Proofing" could still include documents that contain both “Lydia” and
“needs” or “proofing”, but never when the two latter words form a phrase.

Finding everything To return a list of everything in the project, use the uni-
versal wildcard by typing in a single asterisk (*) into the search bar. It can
sometimes be useful to build a list of all items in the binder, usually in
conjunction with loading the search result into an editor, where you can
do such things as sorting by label to view your binder clustered by label
assignment, or by modification date to review recently changed files.

If you want to find an actual asterisk all by itself, then set the search Op-
erator to “RegEx” and search for \*.

Finding everything by type The above method of using a single asterisk can be
combined with all available search options. For example: you can find all
items in the Draft folder, or all items that have had a label (any label at
all) assigned to them, or with the “Invert Results” option, you can find all
item’s that don’t have a label assigned yet.
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Searching bymodification and creation date
A common desire is to locate items that have been modified recently, or to find
files that were createdwithin a certain window of time. Scrivener supports these
operations and many more besides, using its special date search syntax.
When suffixing a search term with either of the keywords mdate: or cdate:,

project search will combine the current “Search In” settings to also search for
Modified Date or Created Date respectively. When used alone, they will simply
return a list of all documents based upon that date request. Thus a search for
‘cdate:2017’ will return all documents created in the year 2017. Searching for
‘Ourense cdate:2017’ will find documents referring to this city, created in the
year of 2017. Refer to Table 11.1 for detailed information on the available search
codes.
If you’d rather not have to remember these search terms, you can also simply

right-click on the magnifying glass icon and select “Search Modified Dates” or
“SearchCreatedDates” to insert the term for you. Doing sowill replacewhatever
you’ve already typed in.

FindingDuplications
Discovering binder items with duplicated information can be useful for a variety
of tasks. Youmight simply be trying to clean up an “inbox” style project thatmay
have had material inadvertently imported more than once over the years. Or
maybe you need to verify that your draft folder has no duplicated titles within it.
Project search can be set to Find Duplicates, in the search option menu. This

option works after a result list has been assembled, and thus only scans for du-
plications within the list. All unique search results will be removed, presenting
a list of only those items with duplicate data. In this mode, the default “Binder
order” sort method will cluster duplicated items together, even if they nowhere
near each other in the binder itself.
What is considered duplication depends on the “Search in” setting:

— All: the items must be complete duplications in every way.

— Label: when searching for an individual type of metadata, such as the la-
bel, only documents with duplicate labels will be listed. The items may
otherwise be entirely unlike one another.

— Multiple fields: if more than one metadata field is selected, then duplica-
tion must occur in each of the selected fields/

For cases where you are looking for matching fragments of text, down to the
sentence level of granularity rather than wholly duplicated texts, the Matching
Text Finder (subsection 13.4.4) tool will better help you.

264



11.1. Project Search

Table 11.1 Date Search Syntax

Search Term Description

By a Given Date

YYYY-MM-DD or
YYYY/MM/DD

Find everything from a specific day, such as 2017–
04–08, which will find everything on the 8th of
April, 2017.

YYYY All entires found within the specified year.

By a Relative Date

#d Find everything written since the number of days
specified. Eg. “7d” would find everything edited
within the last week. Use “0d” to search for dates
matching today (whereas 1d would include yester-
day as well).

#m As above, but using months. Eg. “6m” will find ev-
erything edited in the past half year, or six months.

#y As above, but using years.

Searching Before and After

> Expands any of the above forms to also find every-
thing since the given date. >2014 will provide a list
of all edits within the year 2014 or later, while 2014
by itself just returns edits from within that year.
Those thatwork thatway inherently do not require
the bracket, thus >7d is the same as 7d by itself.

< As above, but in this case edits found on or before
the given date. Thus <2y will return everything
older than two years.
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Combining Search Terms
Most of the techniqueswe’ve discussed can be combined together to createmore
specific and complicated search criteria. Here are some examples:

— If you are searching in the “Notes” field for the word “ToDo”, but only
want to find those documents that haven’t been modified recently, you
would use the term, ToDo mdate:<6m, which would find every document
with “ToDo” in the inspector notes that hasn’t been modified in the past
six months.

— You can search for all documents with the “Needs Formatting” keyword
that has not beenmarked with a status of “RoughDraft”, by setting Search
In… to both “Keywords” and “Status”, theOperator to either “AnyWords”
or “AllWords”, andfinally typing in "needs formatting" -"rough draft".

— Searching in Status and Keywords for “First Draft”, with Find duplicates
enabled: in this case either the Status or Keywords metadata fields must
contain the phrase “first draft” (in this case Status most likely will), and
then duplications will be checked for both fields. Consequently only those
items set to First Draft status that contain an identical keyword list will be
ultimately listed in results.

— Let’s say you have a custom metadata field, called “Published”, which is a
simple checkbox. When searching by this field, yes cdate:2014 returns all
documents marked as published that were created within the year 2014.

Refer to Table 11.1 for a complete list of available date searches.

11.1.4 Save Search As Collection…
With so many different options you might be looking for a way to save “smart
folders” or searches. The command at the bottom of the options menu will save
your current search settings into a search result collection (subsection 10.2.4). As
with search results, these collection tabs will build a list of results whenever you
load them.

11.1.5 Using a Saved Search Collection for New
Searches

Whenever you click on a saved search tab (or use anymethod at all to load a saved
search into the binder sidebar), all of the settings that were used to establish that
list will be loaded into the project search settings for you, meaning the collection
tab could be less about the list of documents it generates when you click on it,
and more about the diverse options it sets when doing so.
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1. With the collection tabs open, click on the search collection containing
the type of search you want to repeat with a different term. Or use the
Navigate ▸Collections ▸ submenu to load the list directly into the sidebar.

2. Use your preferredmethod to invokeproject search and type in anew term.

3. The result will be to create a new Search Result list using all of the settings
stored in the saved search.

You could update the search collection (section 10.2.4) if you intended to
use this variation more frequently for a while, or even create a new search
result collection entirely.

An applied example ofwhere thismight be useful is if you’ve set up a fewdiffer-
ent options to look for a character by name, looking only within themanuscript,
to only consider whole words, be case sensitive and ignore all documents ex-
cluded from compilation. The saved search result will remember the name of
the character you typed in at the time it was saved, but you can easily use that
search as a springboard for hunting down any character by name, by bringing up
the project search field and typing in a different name.

Return to chapter ⤴

11.2 Document Find and Replace
As with many programs that work with text, you are provided with a standard
find and replace window which can be called up while the keyboard focus is in
any text area, with Edit ▸Find ▸Find… (⌘F). The find panel operates only in the cur-
rent context. To replace text throughout the entire project, use Project Replace
(section 11.3); to search for text in all documents, use Project Search (section 11.1).
The buttons along the right of the windowwill take action on the settings you

apply to it: The Next and Previous buttons will jump from one result to the next,
using the current selection or cursor position as a starting point. When the last
match is discovered the tool will wrap around to the end or beginning of the
document as needed, and continue searching.
To close the tool, either click the appropriate icon in the title bar, use Return

to find the next match and close the window automatically or tap the Esc key.

Finding and Replacing Text in Footnotes and Comments

Find and replace will function on any comments or footnotes in the in-
spector pane (section 18.3), even if the keyboard focus is in the main edi-
tor. Replace will always work, even if the inspector is closed, but for Find
to highlight matches, the inspector must already be open.
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11.2.1 Find and ReplaceOptions
There are three replacement options:

— Replace: replaces the currently selected text with the contents of the “Re-
place” field. This works on any selection, but will most often be used after
clicking the Next or Previous buttons.

— Replace & Find: equivalent to clicking the Replace button followed by the
Next button.

— Replace All: replaces all matches from the “Find” field in the current text
with the contents of the “Replace” field with no further interaction. The
total number of replacements that weremade by the last use of this button
will be printed in the lower-right corner of the window.

Replace All Scope These two options determine the scope of how much text
will be impacted when clicking the Replace All button:

— Entire Document: all of the text in the current view (which may be
multiple documents when using Scrivenings mode) will be searched
and replaced.

— Selected Text: only the selected text will be searched and replaced.
Since this commandwill remove the selection, itmeans youwill need
to apply a new selection if you intend to continue searching and re-
placing this way.

Find Options These options impact how the text within the “Find” field is
treated. They are used for both regular searching and replacing:

— The mode dropdown at the top contains the following options:

— Contains: the tool will find any sequence of text that matches what
has been typed into the “Find” field, even if it is found within a word.

— Startswith: text will only be found if aword beginswith the supplied
text.

— Whole word: only words that match the text from start to finish
will be matched. For example, “sam” will only find that word, not
“Samantha”.

— Endswith: text will only be found if the word ends with the supplied
text.

— Regular Expression (RegEx): enables the regular expression search
syntax for both “Find” and “Replace” fields. When replacing, refer to
a stored value from the initial search pattern using Perl-style ($1, $2…)
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syntax for doing so. The find tool cannot work with whitespace sym-
bols, such as \n and \t in the replacement field. Use literalwhitespace
characters instead (which can be insertedwith Spacebar,⌥Return and
⌥Tab).

— IgnoreCase: the letter case typed into the “Find” fieldwill be ignored.
Thus “sam” will not find “Sam”.

— Ignore Diacritics: accents on characters will be ignored. Thus
“naïve” will also find “naive”. This option is not available to the
stricter regular expression mode is enabled.

11.2.2 Searchingwith the Keyboard
In addition to the buttons available in the panel, there are some keyboard short-
cuts you can learn which can reduce the reliance upon clicking within the panel
to carry out searches. These commands are also available in the Edit ▸Find ▸ sub-
menu:

— Return: nearly synonymous with clicking the “Next” button, with one im-
portant difference, the Find window will be automatically dismissed after
you press Return. The search term will be saved however, allowing you to
continue using the two following shortcuts without any interface in your
way.

— ⌘G: finds the next available match; will wrap around to the top of the
document if there are no more matches available below the current point.
This command works even if the Find panel is closed, and it will operate
off of the last active editor split (even if that split is not focused, though
searching will move your keyboard focus to the editor)

— ⇧⌘G: finds the previous match; as above, but will wrap around to the bot-
tom of the document. As with forward searching, this command uses the
last active split and will focus the editor as necessary.

— ⌘E: used to load the currently selected text into the “Find” field without
opening the panel. Using this method you can easily locate further occur-
rences of existing text without any user interface, when combined with
the next and previous match shortcuts, above.

Return to chapter ⤴

11.3 Project Replace
The menu command, Edit ▸Find ▸Project Replace… provides the utility of replac-
ing text throughout the entire project. A progress bar at the bottom of the dia-
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logue shows you the progress of the replacement operation—bear in mind that
this could take a little while on large projects.

There’s No Going Back FromHere!

Given that this process must go through all of the documents in your
project, opening and closing them as it goes, Project Replace cannot be
undone (and youwill bewarnedwhen you try)! You can use the Swap but-
ton to exchange the search term for the replacement text and try to in-
verse the replacement operation, but in some cases thismight have unex-
pected results. The best course of action is to take a back up prior to using
this tool (the File ▸Back Up ▸Back Up To… command is particularly handy
for cases like these). A simple mistake can render your entire draft illegi-
ble, or even worse, produce subtle flaws that are difficult to find without
reading the entire work.

To include carriage returns or tabs in your search or replacement field, hold
down the Option key and then press Return or Tab, and ⌥⌘Return for line feeds.
For your convenience, invisible characters will be printed using visible symbols.

Replace Here is where you will type in the text used to look for matches. This
can be pre-filled using the Edit ▸Find ▸UseSelection forFindmenu command
(⌘E).

With The text provided in the first box will be replaced with the text provided
here. This can be empty if you wish, having the effect of removing the
phrase from the project wherever it occurs.

Swap Click this button to swap the contents of theWith field for the Replace
field. Maybe you didn’t want to change the name of your antagonist after
all!

Search mode The dropdown menu below the swap button, and the two check-
boxes following it, are where you will set how the text in the Replace field
should be evaluated. The rules here are identical to those documented
previously (subsection 11.2.1). The Whole Word option in particular can
be useful here; without it, searching for the character name “Sam” and
replacing it with “Joseph” could end you up with such (bleakly) amusing
concoctions as “Josephe” in place of every “same”.

Scope Set whether the entire project should be modified, or only those items
that youhave previously selected in the binder, corkboard or outliner. This
requires an explicit selection of each item that should be impacted. Child
items of folders will not be modified.

Affect Select which elements of each binder item this command shouldmodify.
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— Titles: the titles of the documents as they appear in the binder.

— Text: standard text editor contents (including any linked footnotes
and comments from within that text).

— Notes: any inspector note fields that are attached to documents.

— Synopses: the text content of each index card.

— CustomMetadata: text type custom fields will have their text exam-
ined and changed.

— Snapshots: archived snapshots will be changed (take special care
with this one, as snapshots are typically an internal backup mecha-
nism) as well as any linked footnotes and comments originating from
those snapshots.

Return to chapter ⤴

11.4 Filter Outliner &Corkboard Views

Figure 11.4 Outliner and corkboard views canbefilteredby a variety of criteria.

The corkboard and outliner views are capable of simple filtering, making it
a cinch to quickly find that one text file you know is somewhere in a list of a
hundred cards in a folder, or to only show rows in the outliner that have been
labelled a certain colour, to name a few.
A filtered view has certain limitations owing to how it filters items directly in

the same view. When using a filter the matching items will be presented in a flat
list and you will be unable to reorder or create new items within that list. In this
fashion it is similar to howmultiple selection work (section 6.4). Similarly, label
view and freeform corkboards cannot be filtered directly—the result of filtering
these views will be to revert to a flat list so long as the filter is applied.
Filter settings will be remembered per each split for the current session. All

of the settings that you applied the last time the filter was used will be reapplied
automatically when calling up the filter panel. This can be useful when navigat-
ing to search results and then using history to return to the view—you can press
⌘F to return to the filtered view after⌘[ to go back in history.

11.4.1 Starting a New Filter
Start a new filter on the current corkboard or outliner by using the Edit ▸Find ▸
Filter… menu command (⌘F), type in the text you’re looking for, and Scrivener
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will start scouring through all visible text in the view and present a list of only
those items that contain matching text.2

To move the focus into the search result list, press the Return key.

Magnifying Glass Menu There are two additional options that impactwhatwill
be found based on what you type in the search field. Access them by click-
ing the magnifying glass button, to the direct left of where you type in the
search text.

— Include Text andNotes in Search: to broadenwhat is found, beyond
what you can see in the view you are filtering, this optionwill include
the main text content (available for folders and files only) and docu-
ment notes (subsection 13.3.2).

— Use Regular Expressions (RegEx): enables regular expression syntax
support.

Additional Filtering Options To the very left of the panel you will find an ex-
pansion arrow that when clicked will reveal additional options for search-
ing by compile status and metadata. Figure 11.4 displays the filter panel
with this additional section opened. You will need the panel expanded,
and the Filter checkbox enabled, to access the following two sections.

11.4.2 Filtering by Compile Status
To get started, click the disclosure arrow on the far right-hand side of the filter
panel. The first two dropdown menus along the top contain filters for whether
a document is in the draft folder, and whether it is set to be compiled:

Draft folder status The first dropdown is for filtering whether or not the items
in the view are currently located within the draft folder. This will most
often be usefulwhenfiltering collections or search results, where the items
in the corkboard or outliner may have come from anywhere in the binder:

— Items Anywhere: the default setting is to not filter items by whether
or not they are in the draft.

— Draft ItemsOnly: only those items currently foundwithin the Draft
folder will be matched.

— Non-Draft Items Only: only those items found outside of the Draft
folder will be matched.

2 What constitutes text is based on the visible information in the view. If you add a column to the
outliner, or show status stamps on the corkboard, then any text found within those additional
fields will be evaluated along with the rest, even if the visual representation of that field lacks
text (like a keyword colour chip).
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Included or Excluded from Compile Independent of whether an item is in the
draft folder, you can filter matches by whether or not their “Include in
Compile” checkbox is enabled in the general metadata area of the inspec-
tor pane (subsection 13.5.1)

— All: the default setting is to not filter items by whether or not they
are included in compile.

— Included: only those items with the “Include in Compile” checkbox
ticked will be matched.

— Excluded: only items with “Include in Compile” disabled will be
matched.

11.4.3 Filtering byMetadata
Although you can add the appropriate column in outliner view to search within
it, it may sometimes be desirable to make certain you are only finding results
from within that particular metadata field—or on the corkboard to be able to
search for fields that cannot be displayed within it. To get started, click the dis-
closure arrow on the far right-hand side of the filter panel, and look to the bot-
tom row of dropdown menus provided.

Enable Metadata Filtering In the first dropdownmenu youwill want to change
the selection from the default “Any” to either one of “Include” or “Exclude”.
The former will cause the filter to only return results that match themeta-
data criteria you set up in the next two dropdown boxes. The latter option
will only return results that do notmatch what you specify.

Metadata Field Next you will need to specify which metadata field the results
should be filtered by, in the second dropdown menu:

— Items with Label: filter by assigned labels. The name of this entry
may change depending upon project settings for how labels are re-
ferred to.

— Items with Status: filter by assigned status. The name of this en-
try may change depending upon project settings for how status are
referred to.

— Items by Section Type: filter by the type of section a document is.
You could for example search for all “Chapter” items in the corkboard,
or create a list of all “Glossary Entries”. What choices you have here
depend on how you’ve set up your project (or how the project was set
up if you’re using an unmodified template).

— The remainder of the menu will list any custommetadata fields that
have been assigned to the project.
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Metadata Value Most of the metadata types available to filter by are list-type
fields, meaning there will be a set number of possibilities to choose from
in the third dropdown. For example, if you choose to filter by label, you
will then select which label to filter by.

The one exceptionwill be any custom checkbox fields. Again youwill have
a list to choose from, but the choice will be very simple: yes, or no.

11.4.4 Resetting and Refreshing Results
To clear the current search term, either press the Esc key on your keyboard, or
click the × button on the right-hand side of the typing area. If the text field is
already empty then pressing Esc an additional time will close the filter panel.
If items themselves change in such a way that their presence in the filtered list

would change, either to be added or excluded, the result will not automatically
refresh. You will need to do so yourself by clicking the button, to the right of
the text entry area.

11.4.5 Closing the Filter Bar
When you are finished filtering the view, click the Done button on the far right
of the filter bar to close the panel and restore the view. From the keyboard you
can use the Esc key to clear the text from the current filter, and when the filter
text is empty, Esc will also close the panel.
Filters will also be closed automatically whenever navigating away from the

filtered view, or when closing and opening the project.

11.4.6 Workingwith Results in ExtendedUsage
You may sometimes wish to hop back and forth between results without losing
your place or having to reset the filter every time you return to the corkboard or
outline. There are a few different approaches you can take that avoid navigating
with the editor you are filtering from:

— Naturally there is the other split. We’ve assumed it is being used for some-
thing else at the moment however, but this basic approach of selecting
a search result and using the Navigate ▸Open ▸ in Other Editor command
(⇧⌘O) deserves mention.

— Copyholders, particularly with the ability to auto-load the things you click
on into the copyholder (subsection 12.2.5) can be a great way of browsing
through and editing a filtered view:

1. Select the search result you wish to view and use the Navigate ▸
Open ▸ in Copyholder menu command (also available from the right-
click contextual menu), or drag it to the editor header bar with the
Option key held down.
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2. The Navigate ▸Corkboard|Outliner Selection Affects ▸Copyholder menu
toggle (or click the “auto-load” button in the footer bar (Figure 12.3) so
that it becomes highlights and the arrow is pointing into the box) will
make it so what you click on in the editor list will automatically load
into the editor’s respective copyholder. If you own a keyboard with a
Touch Bar, you’ll find a button on your keyboard that resembles this
icon. Use it to toggle the mode on without reaching for the mouse.

3. If you need to get over to the copyholder view to edit, the ⌃⌥⌘D
shortcut can come in handy.

— If you’re already using the copyholder for something as well as the other
split, or if you just want the convenience of doing everything in one view,
there is a trick for opening all of the search results into the current editor:

1. Select all of the search results you wish to work with (⌘A might be
easiest here).

2. Use the Spacebar or ⌥⌘O shortcut, or drag the items to the editor
header bar if you prefer the mouse. This will load the selected items
into the editor as a multiple selection rather than a filtered result of a
larger group of items. Now as you navigate into these items and then
hit the Back button to return, you will be returning to this selection
as your base of operation.

— Lastly, for a more permanent solution, using collections (section 10.2) to
store a list of items for future use:

1. Select all of the search results you wish to work with (⌘A might be
easiest here).

2. Use the Documents ▸Add to Collection ▸New Collection… menu com-
mand, or select an existing collection.

Return to chapter ⤴

11.5 Quick Search Tool
Sometimes you want to jot down a quick idea or note-to-self within a particular
document in your project, but you don’t want to hunt around for it in the binder
(maybe it isn’t even visible), or maybe you are already using project search and
don’t want to change the settings for one quick lookup. Quick Search bridges
that gap, providing a method for quickly locating and navigating to items based
on their title, synopsis or text. It is located front and centre in the application
toolbar (Figure 11.5).
The name of the document you are currently working on in the main editor

will be printed here, for your reference. Think of it a bit like the URL bar in a

275



11.5. Quick Search Tool

Figure 11.5 The Quick Search tool resembles the URL bar in some Web
browsers.

browser. It shows you the page you are viewing, but otherwise you can click into
it and type in a new address, or even search for a page by name.

Looking for a little asymmetry?

By default the Quick Search tool will attempt to keep itself in the middle
of the toolbar. If you would prefer to have it off to the side, then right-
click anywhere in the toolbar and disable the Center ‘Quick Search’ tog-
gle.

11.5.1 Starting a NewQuick Search
You can start using it much like you would any search tool:

— Click into the bar to place your cursor there.

— Or, use the ⌃⌥G shortcut (or the Edit ▸Find ▸Quick Searchmenu command)
to move the cursor into it.

Once you start typing, search results will begin appearing, narrowing down in
scope the more you type. Search will be done by “Exact Phrase”
The list may be categorised with up to three sections of results:

1. Titles: prioritised by titles that match what you’ve typed in, or that be-
gin with the typed in text. E.g. if you type in “Research”, you will find it
near the top even if there are hundreds of files above it that use that word
in their names (unless of course you have hundreds of documents named
“Research”, but then this probably isn’t the best tool for the job!).

2. Synopses: exact phrases foundwithin hand-crafted synopses (as opposed to
preview text generated in such places as the corkboard) will appear listed
below titles.

3. Text: any documents containing the phrase you have typed, with a little
context around the phrase printed for your reference.
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Still can’t find it?
If after typing in a good amount of text you cannot narrow down the list
enough to make it useful or find what you are looking for, click the “Full
Project Search” button at the bottom of the result list to take your search
settings and what you’ve typed so far, into the binder sidebar for further
refinement.

11.5.2 UsingQuick Search Results
Once you have found the item you are looking for, click on the result to load the
item directly into the active editor. From the keyboard, use the arrow keys to
move the selection bar up and down; pressing Return on the desired result. The
selection bar automatically highlights the first result in the list, meaning you can
always press Return to jump to the first result.
Add modifier keys to change how result selection works:

— Shift key: load the search result as a Quick Reference panel.

— Option key: load the result in the other editor split, creating one if nec-
essary. Split focus will not change, meaning you can look up reference
material while writing in the other split.

When selecting from a text-based result (rather than title or synopsis hit) then
the first bit of text that matches what you searched for will be scrolled to and
selected automatically. The text find tool (Edit ▸Find ▸Find…) will in all cases be
set to your search term, meaning you can use the keyboard shortcut for walking
through search results (⌘G).
Searching isn’t solely about reading or editing things. Often we search with

the intention of doing something with the things we find. Every entry in the
search result list can be dragged and dropped, producing an identical result as
dragging from the binder itself would. They are, like all other icons in Scrivener,
full proxies for the items they represent (subsection 12.1.1).

11.5.3 Project Targets and theQuick Search Tool
Searching aside, this tool also serves as a convenient means of tracking progress
toward setDraft or session goals. To get startedwith goals, hold down theOption
key on your keyboard and click in the Quick Search tool itself. This will bring up
the Project Targets panel (subsection 20.1.1), where you can edit your goals and
change options on how those goals should be met.
The progress bars function in two different modes, depicted in the first two

examples in Figure 11.6:

1. If only a draft target or session target alone has been set, the progress to-
ward that target will be displayed as a progress bar along the bottom of the
Quick Search tool.
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Figure 11.6 The various ways progress can be monitored via Quick Search.

2. If both a draft target and session target are the draft targetwill be displayed
along the top with the session target using the bottom track.

As shown in the third example, when you’ve opted to show a draft overrun,
and have written in excess of your goal, a teal progress bar will creep up on the
left showing how far over you are.
Lastly, you can hover over the tool with the mouse to print a numerical read-

out. Leave the mouse there while typing to keep this information available.

11.5.4 Quick Searchwithout a Toolbar
If you do not prefer using application toolbars, or maybe you just don’t want this
particular function on the toolbar, theQuick Search tool remains accessible: the
shortcut thatwill ordinarilymove the cursor to the fieldwill instead create a pop-
up search field.
Taking action on a search result will automatically dismiss the Quick Search

tool. If you’re thinking this all works a bit like Spotlight, you wouldn’t be wrong
in that assessment!
To close the tool without doing anything with it, either press Esc (potentially

twice, after first clearing any typed in text) or ⌘W to close it immediately. The
latter will save your search text for future use.

11.5.5 Quick Search Settings
There are a few settings that adjust howproject target trackingworks in this tool,
located in theAppearance: Target Progress Bars settings pane (subsectionB.5.15):

— If you’d rather not be distracted by progress bars while writing, but still
wish to make use of goals, you can disable feedback by disabling the Show
progress bars in Quick Search toolbar item option.
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— The default colours are designed to fit in with the rest of the system. If you
would prefer they use the colours other progress bars do in the software,
then set Use custom colors in toolbar progress bars.

— The colours themselves can be changed in the “Colors” tab of this settings
pane. This impacts all progress tracking bars in the software.

Return to chapter ⤴

11.6 Find by Formatting Tool
The “Find by Formatting” utility can be invoked from Edit ▸Find ▸Find by Format-
ting… (⌃⌥⌘F). It gathers together a number of powerful project-wide search tools
for otherwise difficult to locate things, such as inline images by name; cross-
reference links; text by style; inline annotations & footnotes; and so on. The
anatomy of the tool is quite simple, let’s take a look (Figure 11.7):

Figure 11.7 Find by Formatting: for finding stuff other than text.

The Find dropdown at the very top is where you select the type of thing you
are hunting down, such as pictures, footnotes or revision tracking markup (to
mention a few). The following two controls below are universal to each search
mode:

— Containing text: narrows down the search tomatch results with the spec-
ified text. In the provided example, we would only find the phrase typed
into the field if it were highlighted in yellow.

The type of search used here will always be “exact phrase”.

— Search in: there are two choices available: “All Documents” will search
all text documents in the binder (even outside of the Draft), starting from
the current point in the active editor. “Current Editor” will constrain the
search to only text foundwithin the active editor. In both cases, searchwill
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automatically wrap around to the top or bottom of the document/binder
once you’ve reached the last result in the current search direction.

Taking aWhile to Find Stuff?

If you have the Search inmode set to “All Documents” and are searching
within a large project, it may take a while for Scrivener to locate results,
especially if the results are located far apart. There is no search index
for things like bold text, so the software has to manually trawl through
the text to findmatching conditions. If you know the general area where
you’d like to search, such as one chapter of your book, it would be best to
use Scrivenings mode to view that section of text, and set the Search in
mode to “Current Editor”.

As with the standard text find panel, it can be left floating over the project
window as you click the Next and Previous buttons, so you can edit immediately
after coming across a match, and then going back to search without having to
call up the palette again. Also like the standard text searching it can run in “back-
ground mode” as well. Once a search criteria has been set up, you can close the
window and use the following commands to step through results without the
panel getting in the way:

— Edit ▸Find ▸FindNext Formatting (⇧⌥⌘G)

— Edit ▸Find ▸Find Previous Formatting (⌃⌥⌘G)

The rest of the panel, in the shaded grey area, will change depending upon the
current Findmode. We’ll now go over what each the search types do, and their
special options.

11.6.1 Highlighted Text
Looks for text that has been highlighted using the highlight feature (section 18.5).

Limit search to color When the checkbox is enabled, only those highlights
matching the chosen colour will be found. If this is disabled, all highlight
colours will be considered a match. Note that the colour must be precisely
the same, so it is often best to stick to using basic or custom swatches or
the built-in highlighter defaults when using this tool.

To select a colour, right-click on the colour chip to select fromScrivener’s stan-
dard stock colours, or left click to open the colour chooser directly.
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11.6.2 Comments & Footnotes
Search within any inspector-based comments or footnotes in the project. By
default both will be considered for potential matches, but you can narrow this
down by selecting one of Comments or Footnotes from the Typemenu.

11.6.3 Inline Annotations and Footnotes
Searching for inline annotations gives you three colour matching options:

— Any Color: No limits will be made on the search results.

— Limit Search toColor: will only find annotations of precisely the specified
colour.

— Exclude Color from Search: any annotations precisely matching the pro-
vided colour will be excluded from the search.

(Inline footnotes have no additional options.)

11.6.4 Revision Colour
This tool will search by a particular revision level, selected from the dropdown
menu, matching those used by the Format ▸RevisionMode ▸ submenu while edit-
ing. Since these colours can be changed in the Editing: Revisions Setting tab,
inconsistencies between stored markings and current settings can result if col-
laborators are not using the same Settings, or if you change these settings mid-
way through a project. If you intend tomake use of Revisions in general it will be
a good idea to establish a standard before embarking on a major editing effort.
This feature will step through any edits that have been made while using a

particular revision level, including any overstrikes that have been made.

Upgrading from Scrivener 2

By the same token, if upon upgrading an older project to Scrivener 3’s
format you find this tool no longer locates older revisionmarkings, that’ll
be because the default colours have been very slightly changed. Further
instructions for rectifying this are provided in The Devil in the Details
(section F.9), under “Modified Default Revisions Colours”.

11.6.5 Colored Text
The interface for this type of search is similar to the highlight search type. You
can provide a custom colour restriction in the additional criteria section. The
colour choice needs to be precise, so using custom swatches or built-in presets
will generally be easiest. As with the highlight tool, right-click on the colour chip
to select from Scrivener’s standard stock colours, or left click to open the colour
chooser directly.
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11.6.6 Style
The stylesheet for the current project will be presented in the Style Name drop-
down. If you wish to search only within block quotes, code blocks or headings,
this is where you would do so. This tool will mainly be of use if you want to walk
through style usage throughout the project, or hunt down specific text found
within a specific style. There are additional search capabilities if you’re mainly
interested in selecting or finding all text assigned to a specific style. Refer to
Selecting and Searching for Styles (subsection 17.4.1) for more information.

11.6.7 Character Format
Common direct formatting can be searched for using this tool. Any number of
options in the additional criteria can be stipulated. They work in an additive
fashion, so if you have both bold and underline selected, a successfulmatchmust
be both bold and underlined. Keep with next search for paragraphs that have
hidden the Format ▸Paragraph ▸KeepWith Nextmarker added.

11.6.8 Links
You may search for hyperlinks of any sort using this tool. By default all links
will be matched, but if you wish to narrow the search down, use the Link type
dropdown. The “Web/File Link” will in fact locate all links3, save for internal
document links.
When using “All Links” or “Web/File Link” as your link type, the Containing

text field will search not only for the visible hyperlink text you can see in the
editor, but within the stored URL as well.
When using the “Document link” link type, the Replace with Title button can

be used to replace the visible text of the link with the Binder title of the item it
points to. This can be useful for updating cross-references in your draft, if you
know the underlying name of the item has changed.4

11.6.9 Images
Inline images in text fileswill be found by this tool. This includes fully embedded
graphics that have been pasted or inserted into the file, as well as images that
have been linked to files on the disk, via the Insert ▸ Image Linked to File… menu
command, or images linked to binder files via Insert ▸ Image Linked to Document.
This will not find images referenced with a placeholder—given that placeholders
are simple text, you can use the regular text searching tools to locate these.

3 Such as mail, ftp, protocol links to other software (or other Scrivener projects) and so on.
4 This can also be accomplished with the Edit ▸Update Links to Use Target Titlesmenu command
at any time, even by right–clicking on a link in the editor.
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In this mode, the Containing text field will be renamed to Name contains
text, and the text you enter here will be used to look for the name of the image,
whether that be its filename on the disk, its name if fully embedded (double-
click on an image in the editor to view or edit its name) or the binder titles of the
images when linked in that fashion.

11.6.10 Tables
Tables inserted into text documents will be found with this tool. Matching text
contained within any cell of the table will cause it to be found. In all cases the
entire table will be selected.

11.6.11 Preserved Formatting Text
This will find text which has been marked as “Preserve Formatting”, via the For-
mat ▸Preserve Formatting command.

Return to chapter ⤴

11.7 Regular Expressions
Regular expressions are an advanced search syntax that can also be used tomake
complex replacements. If you knowwhat they are, you are probably delighted to
hear we support them. If you don’t, we could not even begin to document this
search syntax; entire books even larger than this user manual have been writ-
ten on the topic! If you would like to learn how to use them, there are plenty of
recipes, learning resources and tutorials on the Web, as well as those aforemen-
tioned books.
Regular expression support is provided in the following locations:

— Project Search: select “RegEx” from the operator section of the magnifying
glass icon menu.

— Project Replace: using Edit ▸Find ▸Project Replace…, enable regular expres-
sions by selecting “Regular Expressions (RegEx)” from the dropdownmenu
containing search modes.

— Find: the standard Edit ▸Find ▸Find… text searching tool supports them. Se-
lect “Regular Expressions (RegEx)” from the dropdownmenu at the top of
the “Find Options” section.

— Outliner & Corkboard filtering: when invoking Edit ▸Find ▸Find… from an
outliner or corkboard view, click themagnifying glass and select “Use Reg-
ular Expressions (RegEx)”.

— Compile replacements: RegEx can be used in compile-time replacements,
which alter the output without changing the original text.
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Scrivener uses the stock RegEx engine supplied by the Mac, which uses the
UTF-8 compatible ICU guidelines. ICU is mostly compatible with PCRE, which
is considered to be the standard for extended regular expression syntax.
When used for replacing text in the compile pane, document find panel or

project replace, you will need to address stored variables using the dollarsign-
numeral syntax, such as $1 for the first stored variable, $2 for the second and so
forth.

Return to chapter ⤴
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Moving around within a large project is an important part of writing effi-
ciently, and especially in an application like Scrivener where cutting your work
up into many small pieces is second nature. It’s such an important aspect of the
software, we have an entire top level menu devoted to navigation (section A.7).
An average book might have anywhere between several dozen, to hundreds

or even thousands of sections arranged into many levels of groups in the Draft
folder alone, and that’s not counting any research you may have added to the
project. We will cover how flexible the project window is, both as an adaptive
tool that can be shaped to your current task, and as a way of building more
static workflows (like a 3-pane browser, common to mail clients). Along with
the binder, there are two primary tools for making sense of all of these pieces:
the outliner (section 8.3) and the corkboard (section 8.2).



12.1. General Navigation

In this chapter we will concentrate on how to use these tools, the binder and
other navigational tools to, as we say, see the forest or the trees.

12.1 General Navigation
Some navigation features are common to both the corkboard and the outliner:

— Double-click on any icon (to the left of the title itself) to load that doc-
ument in the current editor. This process is sometimes referred to as
“drilling down” into the outline.

— Alternatively, use the Spacebar or the ⌥⌘O shortcut to load the selected
items in the current editor. When more than one item is selected, the
effect will be to isolate them from their context, as a flat list. This latter
usage is quite useful when you have a large group of items, but only wish
to work with a selection, non-linear or otherwise, of those items.

— ⇧⌘O loads the selected item(s) in the opposing split, opening a new one if
necessary. This command can also be used from the binder, when youwish
to target the split that clicking in the binder wouldn’t otherwise impact.

The following command can be used from any group view mode (including
Scrivenings) as well as the binder sidebar:

— Unlikemost other formsof navigation, theNavigate ▸GoTo ▸Selection com-
mand (⌘4) will always load the selected item as a single document in the
active editor, even if the selection is a container. This can be useful if you
like to jot down notes into a folder’s text area. Since this command will
disregard the usual view mode preference (such as viewing containers as
a corkboard) it also has no impact on that preference. Use of it will not
cause containers to load as single documents in the future.

When used in a Scrivenings session, the effect is to “isolate” the text your
cursor or selection is currently within, allowing you to focus on that one
section alone.

These commands can be used from within the editor in all contexts:

— Sometimes you may want to go “up” a level of hierarchy, to the enclosing
group of the selection—instead of “down” (or deeper in the nesting order),
as all of the above commands do—and for those cases, use Navigate ▸Go
To ▸EnclosingGroup (⌃⌘R). Viewing the enclosing group will also select the
currently viewed item. For example, if you have a folder in your corkboard
called “Chapter 10”, and that folder is nested beneath theDraft folder, then
using this commandwill select theDraft folder in the editor, with “Chapter
10” selected within it.
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When used in a Scrivenings session, the effect is to broaden the current
text content to include a larger section of the work.

— The Navigate ▸Go To ▸Previous Document and Next Document commands
(⌥⌘↑ & ⌥⌘↓ respectively) will walk through the order of items as listed
in the binder sidebar from the current vantage point. This form of naviga-
tion is also available as buttons on the editor header bar itself, on the right-
hand side beside the split button, as up and down arrows. The contextual
distinction here is key: if the sidebar is showing search results, then these
buttons will walk through that list of items. If the binder itself is showing,
the result will be to move through the binder stack one by one. If the item
you are viewing in the editor is not listed in the sidebar then this form of
navigation will be disabled as there would be no way to get from the cur-
rent point to any frame of reference within the sidebar list.

Within a Scrivenings session these commands will jump from one section
to the next within the session until you get to the end of the session in
either direction.

12.1.1 Header Bar Drag andDrop
As mentioned before, Scrivener has extensive support for the concept of drag
and drop. There are many areas where you can drag icons from and nearly just
as many that you can drag to. The header bars on the editor splits are one such
target, and they have two basic modes of usage:

1. Dropping binder items: in this case the items (if plural, it will form a mul-
tiple selection) are loaded in the editor, much as though you had selected
or clicked on them in the binder.

— When holding down the Option key the action will be to load the
item (no plurality in this case!) into the editor’s copyholder (subsec-
tion 8.1.5).

— You can also drag an item directly to an existing copyholder’s smaller
header bar.

— This action will not break the locked condition of an editor.

2. Dropping snapshots: when dragged from either the inspector or the snap-
shots manager the action will be to load the snapshot as a read-only copy
in the main editor. Readmore about these capabilities in Using Snapshots
(section 15.8).

Here are a few ideas for how this capability can be used:

— If your Navigate ▸Binder Affects ▸ settings are such that the editor you wish
to load an item in does not receive binder clicks, you can use drag and drop
to manually load the document anyway.
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— From theBookmarksTab (section 13.4) of the inspector. You can also right-
click on a bookmark and choose to load it in either editor.1

— From a Quick Reference header bar. If you’ve had a document open in a
separate window but wish to “dock” it into the main project window, drag
the header bar icon from the Quick Reference panel into a header bar to
load it there.

12.1.2 Go ToMenu
The Navigate ▸Go To ▸ submenu can at times be a handy substitute for other
methods, particularly in cases where the binder is hidden, or if the item youwish
to navigate to is bookmarked (section 10.3) for quick access. The Go Tomenu al-
ways takes action on the active split, even when it has been locked.
The “Collections” entry within the Go To submenu will navigate themain ed-

itor to a collection list, rather than showing it in the sidebar as would be tradi-
tionally done. Viewing collections in the editors brings all of their organisational
and visualisation prowess to bear upon them.
There are three locations where this menu appears:

1. The main application menu: Navigate ▸GoTo.

2. From the editor header bar icon menu, as “Go To Document”.

3. In composition mode, the Go To menu is available as a button in the con-
trol strip along the bottomof the screen. This formhas a special behaviour
when using Scrivenings mode in that it will only show items from the cur-
rent editing session rather than the entire binder.

In all cases, both containers (represented as submenus in this context) and
items can be selected. When a group is selected, it will be loadedwith the current
view mode. When the command is used from contexts that can only display
text, such as copyholders and composition mode then the text editor for that
container itself will be shown instead (and may be empty).

Return to chapter ⤴

12.2 Controlling Sidebar and Editor
Integration

With few exceptions, whatever you click on in the binder sidebar will be au-
tomatically loaded into the active editor. This can become more complicated

1 If you would prefer bookmarks always load in one of the editors instead of a separate window,
tune the Open Inspector bookmarks in… setting, in the Behaviors: Document Links settings
pane (subsection B.4.2).
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when there is more than one editor split in use. Occasionally you’ll want to load
things in another split so as to not disturb your current environment. Or you
may even want everything to load in the other editor as a matter of course, no
matter which editor is currently active. Youmay also want the binder to be com-
pletely decoupled from the editors so that all changes to what you are editing
becomes a manual process.
This sectionwill go over the sorts of adjustments you canmake to change how

the project window works in a persistent fashion, as well as showing you a few
one-off tricks you can use to make use of additional splits without a whole lot of
clicking around.

Figure 12.1 A complex demonstration synthesising the techniques in this sec-
tion.

Taking a look at Figure 12.1 we can see a combination of different features be-
ing used together to create a workflow that emulates how some 3-pane software
works in principle, with an additional twist that most cannot do. If you would
like to play with this example yourself while following along, you will find this
project in the Extras Pack (Appendix G), as “3-complex_layouts.scriv”.2

a) The first thing to note is that the left split header bar is accented, even
though the active editor is indicated as being the right split. Thismeanswe
have set up the binder to only affect the left editor when clicking on items
within it. Our right editor will never be changed by what we do in the
binder sidebar (this is accomplished by using theNavigate ▸BinderSelection

2 Do not be concerned if all of the files are empty save for the letter ‘a’, this is meant mainly to
demonstrate the UI setup, not to provide a copy of the entire book!
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Affects ▸Left Editor Only menu toggle. At the bottom of the left editor is
a blue button indicating that whatever we click on in the left editor will
automatically load into the right editor—in other words it will act a little
bit like the binder does.

b) The accented underscore in the right editor’s header bar indicates it is the
active split. It is where we are working—where our cursor keys will move
the selection highlight bar and so forth. It is viewing a folder that was
clicked in the left editor split. At the bottom of this split you’ll find that a
blue button again, only this time it is indicating that whatever we click on
in the right editor will be automatically loaded in the copyholder below it.

c) Finally we get to the copyholder, or some actual text in this example. The
right half of the project window acts a bit like a mini-browser of its own.
You can create and work with items in the upper half and then edit the
text of them in the lower half.

Naturally not every project will require all of these features to be enabled at
once, but now that you’ve seen a little of Scrivener’s flexibility in what it can do,
you might have a few ideas for how you can use bits and pieces of this example
in your own work.
Now that we’ve summarised the strategy, let’s get into all of tactics that can be

used to achieve it.

See Also…
— Splitting the Editor (subsection 8.1.4): much of what we’ll be talking about

in this section will only be beneficial if you’re working with split views.

— The Active Editor and Targeted Editor in Split Views (section 8.1.1): for
more information on how the editors signal their integration with the
binder.

— Selecting Items (subsection 6.3.2): the basics on how the binderworkswith
the editors in general.

12.2.1 Locking the Editor
A tool that can save you a lot of time, and solve a lot of arbitrary “how do I
do this…” type questions is knowing how to essentially turn off project nav-
igation. The editor—or each side, when split—can be locked with the Navi-
gate ▸Editor ▸Lock in Placemenu command (⌥⌘L)3. The header bar for the editor
will be changed to a dark grey (or lighter grey, in DarkMode) and will have a lock
icon added to the right hand side. Whenever you take an action that would ordi-

3 This feature can also be accessed from the header bar contextual menu (section 8.1.1).
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narily have loaded content into that editor, the request will instead by diverted
to the other editor, unless it is also locked, or the request originated from it.

Upgrading from Scrivener 2

In previous versions of Scrivener, locking the editor had the effect of
keeping all navigation inert so long as that split was active, rather than
always diverting navigation to an available unlocked split instead. If you
would prefer the older behaviour, set theWhen focused editor is locked
in place to “Binder selection does nothing”, in the Behaviors: Navigation
settings pane.

Locking the editor inhibits external navigation from impacting the locked ed-
itor. This makes it easy to keep your editing session stable while using other
tools.
What locking will not do is prohibit actions taken fromwithin the editor itself,

or those we might consider desired actions. This includes use of editor navi-
gation functions (such as history), manually dragging items to the header bar,
hyperlink usage4 or menu navigation commands. Locking is meant primarily to
keep the interface from taking actions that the software would ordinarily take
automatically. Locking will not inhibit intentional actions that youmake. These
actions will navigate as requested and cancel the lock state in doing so.5

An exception to the typical lock behaviour is when it makes sense to scroll
your view, or select itemswithin it, based on an external selection that otherwise
would impact the editor. Ifwhenusing a locked group viewyou click on aportion
of the outline that is containedwithin that view, then the editor will scroll to the
right spot and select that item. For example, in a large locked corkboard, you can
jump to individual cards by clicking on them in the binder, or jump to sections
of your text in a Scrivenings session. This behaviour leaves the lock intact, so if
you later click on something else outside of the view nothing will happen.

12.2.2 Locking theGroup ViewMode
Under normal conditions, the view mode used when selecting a group of items
is determined by the last view mode you used (subsection 4.2.1). In most cases
this works quite well as we tend to do tasks in bunches. Sometimes however,
you might wish to designate a certain container as always being shown using a
particular view mode, no matter what the current preferred view mode may be.

4 When links are set to load in the current editor, in the Behaviors: Document Links settings
pane (subsection B.4.2).
5 The one exception to this rule of thumb is when manually loading bookmarks into the locked
pane; this will be blocked as though it were a single click action.
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Figure 12.2 The lock icon indicates the container you are viewing has been
locked to the outliner group view mode.

To set a container (defined as a folder, file group or collection) to use a partic-
ular viewmode, use the Navigate ▸Editor ▸LockGroupViewModemenu command
on the active editor you wish to freeze.6 If the toolbar is visible, you’ll see a small
lock badge added to the associated view button in the toolbar (Figure 12.2). So
long as the viewmode is locked, changing the viewmode while viewing the con-
tainer will modify which view mode it should use in the future.
Here is an example of how this feature might work:

1. A folder (A) is set to have its group view mode locked to corkboard mode.

2. Another folder (B) is clicked on, and the view mode changed to outliner.

3. When switching back to folder A, the view mode returns to corkboard.

4. Viewing folder B, or any other unlocked folder in the binder, will return to
outliner mode.

5. Now if folder A is viewed again and changed to Scrivenings, folder B (and
the rest of the project) will use Scrivenings mode as per normal. Addition-
ally, this actionwill also lock the selected viewmode to folder A. It will now
use Scrivenings mode by preference instead of the corkboard.

There is no limit to the number of containers that can be locked to a view
mode in a project. The setting is unique to that container and does not impact
anything else.

Locking the Group View is a Persistent Setting

If a container is duplicated, its settings will be carried along to the dupli-
cate. For example if the setting is applied to a document template (sec-
tion 7.5), then each new instance created using that template will also
bear that setting. However from that point on these new containers will
maintain their own settings; changing onewill not impact the others that
came from it, or vice versa.

12.2.3 AdjustingWhat the Binder Affects
Earlier we spoke of adjusting whether the binder should interact with a particu-
lar split or leave it alone. Let’s take a look at two different ways of doing that—

6 This command is also available from the header bar contextual menu (section 8.1.1).
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one for quick one-offs and another for persistently altering how the binder in-
teracts with splits.

When Loading Items
Holding down the Option key when clicking will cause the item to be loaded in
the other split, opening one if necessary. Here are the contexts andmethods this
blends with:

— Clicking on individual items in the binder.

— Combined with modifier keys to add or remove from Multiple Selections
(section 6.4) in the other split. ⌥⌘Click will add or remove the item you
clicked on to the other split’s group view (forming a group if currently only
one item is showing). ⌥⇧Click adds ranges of items to the other editor, as
you would expect.

— When clicking on items in the Project Bookmarks panel (subsection 10.3.1).

— Clicking on, or when pressingOption-Return to load items from the Quick
Search Tool (section 11.5).

Use of these methods to load items in the inactive split will not activate the
other split. You can thus load supporting material with a single click and then
keep typing as you were.

ChangingHow the BinderWorks Persistently
By default the active split is synonymous with the targeted split. If you click in
the top editor the header bar is shaded with an accent colour and is underlined
likewise. You wouldn’t be blamed for thinking that was one visual effect, but in
fact it is two. The accent shade indicates the binder will load things into that
editor when you click on them (targeted), and the underscore indicates that this
is the split you’re currently working within (active). If we can tell the binder to
only target one split but can still of course easilywork in either, then therewill be
times when the underscore is on the grey split, not the accented one (Figure 8.2).
The Navigate ▸Binder Selection Affects ▸ submenu is how you will get to the

point of seeing such variations in the first place. If you still have that sample
project handy from earlier in this section, you might want to play with each op-
tion to see how they work:

— Current Editor: This is the default behaviour out of the box. Whichever
split you clicked in last will be targeted.

— Other Editor: Whichever split is not currently active will be targeted. This
way your current work space is never disturbed by usage of the binder.

— Top|Left Editor Only: The top or left split (depending upon orientation)
will always take binder clicks no matter which split is active.

294



12.2. Controlling Sidebar and Editor Integration

— Bottom|Right Editor Only: The bottom or right split (depending upon ori-
entation) will always take binder clicks no matter which split is active.

— Both Editors: In this special case, both editors will update whenever you
click on something in the binder. This will most often be useful when
using two different group view modes. You could have an outliner in the
left view and a Scrivenings session in the right, both showing the same area
of the binder in their own unique ways.

— None: Neither editor will update when using the binder. In this mode of
usage, youwill alwaysneed tomanually open items into an editor. This can
be done by using the Open commands in the right-click menu or Navigate
menu, or by drag and drop into the header bar.

12.2.4 Making Splits Load by Type
If you would like to use the split views to achieve a stricter form of navigation,
where groups of items always load in one side and text content on the other,
the Navigate ▸Binder Selection Affects ▸Open Non-Group Items in Othermenu tog-
gle may achieve what you are looking for.7

A good practical demonstration of how this feature is intended to work is
provided with the Three-pane built-in layouts (section E.2). When the Nav-
igate ▸Outliner|Corkboard Selection Affects ▸Other Editor menu toggle is enabled
this feature will work together with it in a way unlike how “Binder Affects” and
“Outliner/Corkboard Affects” would typically work by themselves, even if you
have them both enabled. When clicking on a group in the binder, two things
will happen:

— The group will be loaded into the split the binder affects, displayed using
whatever view mode you are using in that split.

— If the affected split is displayed as a corkboard or outliner, then the other
split will automatically loadwhatever youwereworking on lastwithin that
group. For example if you click on a folder called “Geographical Distri-
bution” and then within that folder click on a subdocument called “Sum-
mary”, loading the text of that file into the other editor, when you next
load “Geographical Distribution” from the binder, “Summary” will auto-
matically load in the other split as well.

It’s worth noting that this secondary behaviour may in fact load a group
into the other split, if the last thing you clicked on in “Geographical Dis-
tribution” was a subgroup.

7 The definition of “other editor” in this case will always be the split not affected by the settings
in this menu, and the label of the menu command itself will change to reflect that. When both
editors are targeted by the binder, the right or bottom split is always considered the other editor.
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I’m Still Getting Groups in the Other Split

This setting is very specific: it only impacts what happens when non-
group items are clicked in the binder sidebar. If you load a group through
some other means (say a bookmark, or by clicking on a group in the nav-
igation split) then Scrivener will dutifully load that group in the content
split. This isn’t a way of forcing the editor to never load groups, or forc-
ing a split to never load text, but a way of directing how simple clicks
in the binder tend to favour that approach. No other method of naviga-
tion, be it history, hyperlink navigation or what have you, will trigger this
behaviour.

12.2.5 Linking Splits Together
In addition to tuning how the binder sidebar works with splits, you can also ad-
just how splits work together, or with attached copyholders within either split.

Figure 12.3 The “auto-load” button, in the editor footer bar, is accented when
activated.

Both corkboard and outliner views have an auto-load feature that when en-
abled, will load any selected item(s) in the other split or the editor’s copyholder,
much like when clicking on an item in the binder. These modes can be swapped
between by clicking on the indicator in the footer bar, at the bottom of the edi-
tor, or via themenu commands listed below. There are threemodes of operation,
two of which are illustrated in Figure 12.3. The following menu commands can
all be found in the Navigate ▸Outliner|Corkboard Selection Affects ▸ submenu:

1. When the editor has a copyholder attached to it, clicking this button will
enable the auto-load into copyholder feature, and the icon will look like
the top example. You can think of it has “sending” to the other side of the
editor window. This can be enabled with the Copyholder command.

2. When the editor is split, then clicking the button enables auto-load in
other editor mode. The icon in that case looks like the bottom example,
depicting the action as “sending” out of the current editor split. This can
be enabled with the Other Editor command.

3. When disabled, the button will be drawn in grey to indicate it is inactive.
You can directly disable the setting with the None command.

296



12.3. Saved Layouts

If the editor is split and the current editor has a copyholder then clicking on
this button will rotate between all three modes. When neither copyholder nor
splits are available this feature does nothing, even if it has been activated in the
past. It will wait passively until the right conditions exist.
If you have a keyboard with a Touch Bar and your context is currently within

a corkboard or outliner view, then you will find a button on your keyboard that
resembles the button in the footer bar. Use this to toggle auto-load modes di-
rectly.

Return to chapter ⤴

12.3 Saved Layouts

Figure 12.4 Scrivener’s diversity and flexibility benefits from being able to save
your workflows into Layouts.

In the course of using Scrivener, you may find that you shift how you use the
project window, depending onwhat you are doing, or which phase of the project
you are in. In the early stages of a project you might focus on a large corkboard
without any other interface to get in the way. As structure starts to emerge,
you may have the binder open with the corkboard in the top editor and text in
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the bottom editor; whilst composing, you may have only the text open, with
the binder, inspector and toolbar hidden. Or perhaps you switch between com-
puters frequently, and like to use an expansive project window on your desktop
monitor, but prefer a compact window on your laptop.
Or, maybe you’d like to do these things, but tend not to because you’re put off

by the amount of adjustment it would take to change the window around.
By saving the settings of the window for future recall, the Layouts feature

makes rapidly switching between these workflows a cinch. Once you get things
set up the way you like, you never have go through the process of hiding the
binder, toggling the format bar, resizing the window and so forth. You can even
indicate that display preferences, such as outliner column settings and whether
or not labels tint index cards, are used by the layout.

Upgrading from Scrivener 2

If you have legacy layouts saved from older versions of Scrivener, youwill
find they still exist in the list in the new version. Youmay try to use them,
but we cannot guarantee that they will work properly. It would be safest
to try and reproduce their settings by hand, and then update the layout
with the new version of Scrivener.

12.3.1 What Layouts Save
To clarify what may already be obvious: layouts are not a part of any particular
project, and as such they will not save information specific to any one project,
such as things like the collection you are using in the sidebar, whether anyQuick
Reference panels are open or which folder you are viewing as a corkboard in the
editor (it will however save that a particular editor is using the corkboard view
mode). Even within one individual project, these details might change or no
longer be relevant as time goes by. Here is a list of things layouts do save:

— Window size and position and the sizes of elements within them, such as
how wide the binder is or the ratio between the two splits.

— Binder, collection list and inspector visibility.

— Split type (horizontal/vertical/none).

— Corkboard (freeform & layout)/outliner/scrivenings/editor mode for each
split, regardless of the currently selected content.

— Which split(s) the Navigate ▸Binder Selection Affects option is set to.

— Whether Navigate ▸Corkboard|Outliner Selection Affects the other editor or
copyholder (but not the presence of a copyholder itself, as that is likeQuick
Reference panels a project-dependent piece of information).

— Header and footer bar visibility in either split.
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— Whether editors are locked in place.

— Ruler and format bar visibility.

— Line numbering in the editors.

— Full Screen status.

12.3.2 Creating a New Layout

Figure 12.5 Layouts panel with the interactive tutorial’s window settings
saved.

To get started, open the Layouts panel (Figure 12.5) with theWindow ▸
Layouts ▸ManageLayouts…menu command (⇧⌘)). If you do not have any layouts
saved yet, you won’t see much beyond some help text.

1. If you havemore than one project open, make sure the project you wish to
capture is the active window by clicking anywhere within it. Whether or
not the projectwindow is in Full Screenmodewill be saved, so if youwould
rather not have that a part of your layout, be sure to leave Full Screenmode
first.

2. Click the+ button in the lower left corner of the panel.

3. Type in a meaningful name for the layout.

A screenshot of the window will also be taken and displayed on the right
(you can update it later on if you don’t quite like how it turned out).

At this point all of the important details of your project window settings
have been saved. They can be recalled later at any time into any project
window you wish to apply them to.

4. Select from either of the options listed below the thumbnail that you feel
are relevant to the layout. These options are always saved into the layout—
the checkboxes merely determine whether using the layout in the future
will set these options to the project window. They can thus be freely tog-
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gled at any time to produce a limited or expanded effect on the current
project window, without changing the underlying layout.

Save outliner and corkboard settings All corkboard display settings, such as
card size, ratio, card wrapping, and so on will be restored when using the
layout. Additionally the corkboard modes for freeform and label view will
be restored, and since this has the effect of setting thesemodes to the con-
tainers being viewed, use of a layout will modify the items at the time of
application.

In the outliner, the layoutwill restorewhich columns are visible or hidden,
along with their positioning and widths. Custom metadata columns will
be restored if matching names are found within the project.

Preserve all metadata appearance options This will determine whether or not
label tinting used in the various areas of the interface; and pin, stamp, and
keyword chip visibility in the corkboard, will be restored when using the
layout.

12.3.3 Switching Between Layouts
Need to get back to where you started?

Before you select a layout for your projectwindow, it’s important to know
that when you apply one, you’ll be overwriting all of its current display
settings. Consequently if your current view settings are important, you
might want to save them into their own layout first.

There are three ways to switch between layouts:

1. Use the Window ▸Layouts ▸ submenu and select the saved layout from the
menu.

2. The “View” button in the main application toolbar (Figure 4.2) will list any
available layouts at the bottom of the menu.

With both of these methods, if you hold down theOption key while select-
ing the layout, its Full Screen setting (whether on or off) will be ignored.

3. With the “Manage Layouts” panel (Figure 12.5), use one of the following
methods:

— Double-click the icon of the layout you wish to load.

— Press the Return key on the selected layout.

— Select the layout and click the Use button below the list of layouts.
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12.3.4 Setting a Full ScreenDefault
It is possible to select a layout for use by all projects that are taken into Full Screen
mode, as a kind of default layout for that way of working. This is a special be-
haviour that breaks some of the rules with regards to how project layout in gen-
eral works:

— The designated Full Screen layout will be used when taking a project into
Full Screen mode. When taking that project out of Full Screen mode (or
even simply closing it), it will resume using its original layout settings.
Thus the full screen layout will not be saved into the project’s own display
settings.

— Consequently, changes made to the layout of the project while in full
screen mode will not be preserved upon return to standard multitasking.
Everything will be precisely as you left it before entering full screen mode.

— Changes that fall under the auspices ofmetadata appearance and outliner/
corkboard settings will on the other hand be preserved. For example if
you take a project into full screen and then decide to tint index cards with
label colour with View ▸UseLabelColor In ▸ IndexCards, then upon return to
standard multitasking, index cards will remain tinted. On the other hand
if you open up the tab stop ruler in Full Screen mode, it will be gone once
you return.

12.3.5 Managing Layouts
All layout management is done within the “Manage Layouts” panel, which can
be loaded with theWindow ▸Layouts ▸Manage Layouts…menu command (⇧⌘)).
To remove a layout youno longer need, select the layout and click the−button

along the bottom of the layout list on the left, or press Delete on your keyboard.
You will be warned that once it is deleted you’ll be unable to retrieve it. This
warning can be dismissed so that it no longer appears, if you wish.
To update an existing layout using the current project window, select that lay-

out in the list, and click on the button in the footer bar, choosing “Update
Selected Layout”. A new screenshot will be taken and the old settings will be
updated to reflect the current window layout.
Layouts can also be exported and installed into Scrivener8. For example you

could share your layouts with others by posting them online, or download lay-
outs and install them into your copy.

— Exporting: using the button, select the layout you wish to export, and
then choose “Export Selected Layout”. The layout will be saved as a file in

8 It is not possible to share Layouts between Windows and Mac versions of Scrivener, owing to
the many technical differences in how a window is set up.
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the location you provide.

— Importing: use the “Import Layout” command to import a layout file (.scr-
layout).

Layouts can be easily accessed on the disk as well. Use the Scrivener ▸Reveal
Support Folder in Finder menu command and drill down into the “Layouts” sub-
folder to find the .scrlayout files themselves.

12.3.6 The Built-In Layouts
Scrivener comes with several built-in layouts that demonstrate the various navi-
gational features of the project window. Some are intentionally quite simple, de-
signed to help you focus on a particular way of working, others gather a number
of individual settings into more complex workflows that may not be obviously
achieved.
Unlike regular layouts, these built-in layouts will in general not change your

window size or position, unless the layout causes any main editor splits to be-
come more narrow than your preferred editor width.9

Additionally, they will not change your underlying view settings in a perma-
nent fashion. For example if you have a lot of columns added to the outliner
and decide to make use of the “Three Pane (Outliner)” layout, which reduces the
complexity of the outliner to a very simple browser, upon selecting one of the
built-in layouts that leaves these settings alone (such as “Default”), you will find
your original column settings intact. If however you added the label column to
the outliner while using this layout, upon returning with “Default” you will find
the outliner settings stick to the new setup you customised.
Since the built-in layouts cannot be modified they will not appear within the

Window ▸Layouts ▸Manage Layouts… panel. They only appear in the main menu
and under the “View” button in the application toolbar.
The individual layouts are fully documented in Stock Window Layouts (Ap-

pendix E).

Return to chapter ⤴

12.4 ViewingOnly Compilable Items
One of the ways in which you can work in Scrivener is with interleaved notation
among the very pieces of text that comprise your work in progress. This is a
method that some prefer, as it keeps their notes and ideas immediately adjacent
with the text that readerswill see, and it supports aworkingmethodwhere notes

9 Set in the Appearance: Main Editor: Options Setting tab (subsection B.5.8), with the Default
editor width setting.
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can be more extensive or elaborate than what is easily put into annotations or
comments.
In Scrivener, you can place text documents right alongside the documents

used to contain portions of your Draft, and then instruct these documents to
not compile (subsection 13.5.1)—in other words when you turn the Draft folder
into one long file, these note files will be hidden from the exported material.
When viewing such a portion of the draft with Scrivenings view (section 15.5),

you will see all of your notes and draft text together. But there will be times
when you want to just see the compilable text that will become your book:

1. Select one or more containers to view.

2. Use the Navigate ▸Open ▸With Compilable Subdocumentsmenu item.10

3. The result of this action will be a flat multiple selection of items (sec-
tion 6.4) that you can peruse using any view mode you prefer.

Return to chapter ⤴

12.5 Clearing Navigation Settings
If for any reason you wish to clear all of the settings that impact how clicking
works in the project window, theNavigate ▸ClearAllNavigationOptions command
is a handy way to do so in one move. The following changes will be made:

— The Navigate ▸Binder SelectionAffectsmode will be set to “Current Editor”,
and the “Open Non-Group Items in Other” option disabled.

— The Navigate ▸Outliner Selection Affectsmode will be set to “None”.

— Navigate ▸Editor ▸Lock in Place will be disabled.

— Finally, the inspector will be unlocked from working with only one split
(this happens as a secondary effect of closing split views).

Return to chapter ⤴

12.6 Quick Reference
If you’ve been looking for a way to load a document into its own window, this
is the section for you. Quick Reference panels (sometimes shortened to “Quick
Ref”) are simplified editors andmedia viewers, and you can have asmany of them
open as you want.

10 The name of this menu item will change depending on whether the Include enclosing folder
text in Scrivenings mode checkbox in set, in the Behaviors: Folders & Files (subsection B.4.5)
Setting tab.
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Figure 12.6 WithQuickReference, open bits of your project into separatewin-
dows featuring for editing or simple reference.

The panel itself is composed of four major parts (excepting the main editor/
viewer in the middle), two of which are hidden by default.

a) The format bar and header bar along the top provide basic formatting tools
just like in the main project window; the header bar just below it supplies
the identity of what we are viewing.

b) Along the right-hand side of the header bar is a dropdownwhich reveals an
inspector split when used. This split can be either vertically or horizontally
oriented.

c) The bookmark button reveals the Project Bookmarks sidebar, turning this
window into a capable browser for your bookmarks. Refer toWorkingwith
Bookmarks in a Quick Reference Panel (subsection 10.3.3) for further de-
tail. Document statistics and scripting hints (in script writing mode) will
be displayed along the bottom.

d) On the bottom-right you have quick access to the Label and Status meta-
data fields, just like in the Inspector.

As for the thing in the middle of these points, the editor itself: this is a full-
power text editor when viewing standard file or folder documents, and a stan-
dard media viewer just like the main editor when viewing PDFs, images, or mul-
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timedia11. The main difference between a Quick Reference editor and those fea-
tured in the main project window is that it focusses on the content of one item.
It is not capable of showing group views or Scrivenings sessions.

12.6.1 Opening an Item inQuick Reference
There are five easy ways to open a document in Quick Reference mode:

1. Select one or more documents in the binder sidebar, or from a Bookmark
list, and tap the Spacebar. If more than one document is selected, multiple
Quick Reference panels will be opened at once.

When selected from one of the editor views (including the text editor),
use theNavigate ▸Open ▸asQuickReference instead. You can alsomake it so
Spacebarworks in the corkboard and outlinerwith the Space key opens se-
lected documents in… setting, in the Behaviors: Navigation settings pane.

2. Use the Navigate ▸OpenQuick Reference ▸ from the main application menu
to open a selected item from anywhere, without disturbing your existing
workspace in the project window or having to leave composition mode.
Thiswill also open the currently edited chunkof text from themain editor.

Each item in the binder will be organised into submenus based on the
project hierarchy. If you select one of the groupings itself, the command
will use that group. For example if you have a folder named “Chapter One”
and have typed some notes into it, you could target that folder specifically
with this command.

3. Use the “Look Up” trackpad gesture (three-finger tap, or Force Click) to
open anything in a Quick Reference panel from a group view or the binder
sidebar. This option requires the “Lookup&data detectors” option in your
System Settings: Trackpad pane to be enabled.12

4. When using the Quick Search tool (section 11.5), select a search result and
press ⇧Return to load the result as a Quick Reference, instead of into the
main editor.

5. Drag and drop the item from any binder sidebar or group viewmode onto
the “Quick Ref” toolbar icon.

You may have noticed that Quick Reference windows are used in a few con-
texts within Scrivener automatically, such as when double-clicking on book-

11 Unlike loading film and audio in a split, the remote pause and resume commandswill not work
in Quick Reference panes, as you can have many audio files open at once, and Scrivener would
not know which one to work with.
12 On older versions of macOS the menu command will be printed as “Preferences”, and refer-
ences to System Settings (“System Preferences”) locations may no longer be accurate.
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Figure 12.7

marks in the inspector, or clicking on hyperlinks in composition mode. Most
of these behaviours can be modified in the Behaviors: Document Links settings
pane (subsection B.4.2).

12.6.2 Quick ReferenceWindowSettings
Each Quick Reference panel you open will remember the settings you’ve used
within it, as well as the overall size of the window and split placement. If you
left the inspector open and dragged it down to the shortest possible height, and
you open that panel again in two years it will be just how you left it.
When you open a document in a Quick Reference panel for the first time

ever, it will adopt the window size and position used from the last window you
changed. It will not adopt inspector settings.
Once you have closed the window, for the remainder of your sessionwith that

project it will be remembered in theWindow ▸ClosedPanels ▸ submenu,much like
a modern web browser might save all of the tabs you have recently closed. Feel
free to closeQuick Referencewindowswhenever you are immediately donewith
them, as they will remain easily accessible to you from that menu.
You can also choose to have panels reopened for you the next time you return

to the project. Set Reopen Quick Reference panels when opening projects in
the General: Startup settings pane.

12.6.3 The Elements of the Panel
TheHeader Bar

Figure 12.8 The Quick Reference header bar.

Along the top of the window, below the Format Bar if you have displayed it,
you will find a simplified header bar (Figure 12.8).
The icon to the left of the title can be dragged, acting as a proxy for the file it

represents. It can be dragged to the binder to move the file to the location you
drop it, into a bookmarks inspector pane, etc. E.g. to “dock” a Quick Reference
panel back into the project window as a copyholder, try holding down theOption
key while dropping its icon onto an editor header bar.
As with the main header bar, this icon also has a contextual menu with a few

features:
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— Reveal in Binder (⌥⌘R): displays the location of the file this window is view-
ing in the main project window’s binder, opening it if necessary and un-
folding any levels of hierarchy to do so.

— Take Snapshot (⌘5): take a quick snapshot of the document’s text in its cur-
rent state. You will not be able to view snapshots from within the Quick
Ref window itself, but the Documents ▸Snapshots ▸SnapshotsManager tool
can help with this, while keeping the main project window focused on
other things.

As with the main editor header bars, you can edit the title of the document
right here by clicking into the title text (or using the ⌃⌥⌘T shortcut). Press Re-
turn to confirm and return your cursor to where it was in the editor previously.
If left blank, the title will show a little of the synopsis card text as a placeholder
title, or lacking that, the first few works from the top of the document itself.
See Titles and Adaptive Naming (section 7.2) for more information on how that
works.
Next along the top is a button for viewing information from the inspector. It

will be labelled “Editor Only” by default, and that is the choice you would make
to close the split when you are done with it. Read more about this feature in
Quick Reference Mini-Inspector (section 12.6.3).
Finally, when a split has been opened (such as in our example, where we are

viewing the Synopsis of the document), a final button will appear that flips the
orientation of the inspector split.

The Footer Bar
The footer bar, running along the bottom of the view, has three primary ele-
ments:

1. The “Project Bookmarks” button. This is described below (section 12.6.3).

2. This areawill display either statistics or scripting element dropdownmenu
(which can be called up with the⇧⌘Y shortcut, just as in the main editor),
depending upon the editor mode.

When viewing a multimedia file, the “Pause and Rewind” toggle button
(section 8.1.3) will be displayed.

3. Finally, along the right hand side are two dropdown menus for changing
the label and status metadata fields, in that order.

Quick ReferenceMini-Inspector
Quick Reference panels can display inspector metadata for the document you
are working with in the panel.
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Figure 12.9 A Quick Reference window can display a simplified inspector
along the bottom or to the right (as shown).

The panes you can make use of here are not organised in precisely the same
fashion as the inspector itself, on account of their being divided into specific ar-
eas of content. For example the “Notes” tab in the inspector is actually comprised
of three different pieces of information, each of which has its own panel here.
Available areas of content are as follows:

1. Editor Only: the default state, which removes the split and focusses purely
on the content. (You can also use the standard shortcut for “No Split”,⌘ ’).

2. Synopsis: the text content of the index card

3. Picture: the graphical content of the index card, if applicable.

4. Notes: document notes, from the first tab of the inspector.

5. Keywords: document keywords; this table also serves as a drop-target for
keyword drags from the Project Keywords window.

6. Bookmarks: the list of bookmarked items for this document. Double-click
to load them in their own Quick Reference panel. Refer to the following
section if you’re looking for project bookmarks.

7. Custom Metadata: the custom metadata fields in a linear list of editable
text fields.

8. Comments/Footnotes: where you can view the various linked footnotes and
comments within the text editor. This split will appear automatically if
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you create a note.

Refer to the Inspector (chapter 13) itself for greater detail on how these partic-
ular tools are used.
The orientation of the split can be toggled between horizontal and vertical.

The standard shortcuts for doing so, ⌥⌘= and ⌘", respectively, also apply here.

The Bookmark Sidebar
Any Quick Reference window can easily browse through project bookmarks (as-
suming it can display the type of bookmark in question). Click the bookmark
button,marked (c) in Figure 12.6 to toggle sidebar visibility, or use the⇧⌘B short-
cut. Click on the bookmarked document you wish to edit to view it in window.
For a detailed reference on the sidebar itself, refer toWorkingwith Bookmarks

in a Quick Reference Panel (subsection 10.3.3).
When using the bookmark sidebar, the earlier comments on Quick Ref win-

dows remembering their size and split settings will be not be applicable on ac-
count of their being displayed in a collective browser, sharing a window size and
settings with other documents.

12.6.4 Tips for UsingQuick Reference Panels
Floating Panels forMaximumVisibility
Quick Ref panels have an additional capability in the Window ▸Float Quick Ref-
erence Panels menu toggle (⌃⌘Q). When set, all of a project’s panels will “float”
over all other windows in Scrivener. Floating can be particularly useful when the
project window itself is as large as the entire screen, or in composition mode,
where the backdrop would ordinarily hide the panels. Consider toggling float
on and off as needed to bring the panel workspace to the front, and then disable
it and with a click dismiss them all and return to the work you are focusing on.

Displaying Research inQuick Reference
It’s not just about the text. These windows can also act as capable PDF and image
viewers, as well as working with other multimedia. For further information on
the particulars of how they work inside the editor area, refer to Viewing Media
in the Editor (subsection 8.1.3).
The Window ▸Zoom menu command, when use on a Quick Reference panel

that is viewing an image or PDF will expand or contract the size of the window to
fit the content. If you would prefer things work the other way around, double-
click on the image and click the Scale to fit option. With PDFs you can right-
click on the PDF and select “Automatically Resize”, or select the same from the
View ▸PDFDisplay ▸ submenu.
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Setting Text Zoom
Although there is no place for the visible zoom control like in the main editor
footer bar, you can independently zoom the text scale within each Quick Ref-
erence panel as needed, using the View ▸Zoom ▸ submenu, or the ⌘> and ⌘<
shortcuts to decrease and increase the magnification levels, respectively.

Return to chapter ⤴
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The Inspector is an optional sidebar on the right-hand side of the project win-
dow that displays all metadata, snapshots, cross-references, notes, compile set-
tings and other sundry associated with the selected binder item.
You can toggle whether the Inspector is visible with the View ▸Show|Hide In-

spectormenu command (⌥⌘ I), or by clicking the blue “i” button on the far right-
hand corner of the toolbar.
The panel is separated into three distinct parts, from top down:

— The tab row with the inspected document title right below it.



13.1. Inspecting Items

— The inspector panel itself occupies the middle area.

— At the very bottom we can see assigned label or status flags.

There are two other places where information from the inspector can be ex-
amined and edited. Quick Reference windows and Composition Mode, where
in the latter case a floating panel will be used instead of a sidebar. These two
areas contain a subset of the features available to the full inspector. The only tab
not available at all to either of these is the Snapshots tab.

13.1 Inspecting Items
Simply put, the inspector always examines the item that is selected in the active
editor view, which includes when a copyholder is active (subsection 8.1.5). In a
basic scenario where one selects a single text item, that text item in the editor
will be inspected. If we select a group instead, and a corkboard card is selected
within it, then that card will be inspected. With two splits and two copyholders,
there can be up to four possible areas available for individual inspection.1

There are some things that cannot be inspected normally. In these cases, the
inspector will fall back to showing the project bookmarks list:

— Collections and search results.

— Multiple selections of items.

— The root folders (draft, research and trash).

— Viewing a snapshot in an editor or copyholder is a special case: snapshots
don’t havemetadata themselves that can be edited, but any inspector com-
ments or footnotes that were in the text at the time of the snapshot can be
viewed (but not edited) with the inspector.

When I click on a folder something else gets inspected?

When it comes to groups, Scrivener will remember what you were doing
the last time you used that group, which often means it will remember
a selection within that group. In turn that means the items in the cork-
board, outliner, or the section of text you are editing within a Scriven-
ings session is what ends up being inspected, not the folder. If you’d like
to inspect just the group you clicked on, use the Edit ▸Deselect All menu
command on the editor, or simply click in the background to deselect all
cards or rows. In a Scrivenings session, you’ll need to dismiss the session
by turning off Scrivenings (⌘1).

1 Read more about editor focus in the section on the header bar (subsection 8.1.1).
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13.1.1 Locking the Inspector
In cases where you do not want the inspector to use the active split, it can be
locked to a specific split so that when the other editor becomes active, the in-
spector will continue to display information about the selection in the editor
you locked it to. Either use the Lock Inspector to Editor command from the split’s
header bar contextual menu (section 8.1.1) or right-click in the inspector header
bar itself to lock it to the current editor.

Figure 13.1 The “i” icon indicates the inspector has been locked to this split.

Once locked you can use either of these methods to relinquish the lock. You
can also click on the indication icon in the targeted split’s header bar (Figure 13.1)
to clear the lock. Naturally, if either split is closed the locked condition will be
removed.

Return to chapter ⤴

13.2 Using the Sidebar
Now that we’ve established how to use the inspector in general, let’s take a look
at the stuff it actually does—what these individual tabs represent, and how to
use the sections that appear within them.

13.2.1 The Inspector Tabs

Figure 13.2 The inspector header with the Bookmarks tab selected. The name
of the document will be printed below, on all tabs but the first,
which has a built-in index card.

In order of appearance, the tabs as shown in Figure 13.2 are:

1. Notes: the first tab, shaped like a notepad, contains the “index card” that
will represent this item on any corkboard viewing it, and below that a
scratchpad where you can jot down notes pertaining to the item.

2. Bookmarks: the second tab from the left contains listings for both project
and document bookmarks (section 10.3). Switch between the two by click-
ing on the header, or by pressing⌘6. Below the list is a preview and editing
area.
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3. Metadata: access to custom metadata, keywords, compile settings and
general information such as created and modified dates. For more infor-
mation onmetadata in general, check out Organising withMetadata (sec-
tion 10.4).

4. Snapshots: saved revisions of the text document can be created, man-
aged and reviewed from this tab. Read more about Using Snapshots (sec-
tion 15.8).

5. Comments & Footnotes: the last tab will list any linked footnotes and com-
ments (section 18.3) found within all the text currently being displayed in
the editor.

Here are a few guidelines and tips to using the tab buttons in the inspector:

— The selected tab will have a shaded background. In the figure, “Book-
marks” has been selected, which may show bookmarks added to this doc-
ument, or the global project list of bookmarks.

— Only those tabs that are relevant to the document you are inspecting will
be shown. You won’t be seeing footnotes while viewing a picture of a
mountain!

— If a particular tab has information entered into it, a dot will appear in the
upper-right corner of the button. In the reference figure, the dot above the
first tab, “Notes” indicates this document has notes added to it.

Figure 13.3 The label & status fields at the bottom of the inspector.
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Label and Status assignments At the very bottom of the inspector you’ll find
universal access to the “label” and “status” fields. In the example figure
(Figure 13.3), we’ve marked this document as having reached the first draft
point, but we clearly aren’t very happy with it and would like to rewrite it
at some point.

Figure 13.4 Appearance of a collapsed inspector section.

Collapsing sections within a tab Some sections within tabs can be collapsed;
therewill be an arrow icon to the left of such sections. Youmight never use
keywords in a particular project, but have a lot of custom metadata fields,
clicking the arrow to the left of the section’s label (Figure 13.4) will collapse
it, allowing custom metadata to use the space it was taking up.

Resizing sections All of the sections within an inspector tab can be resized ver-
tically to suit your usage and the demands of the content in these areas.
For example if you tend to use longer synopses and only a few notes now
and then, you could drag the synopsis card area in the notes tab downward,
giving you more space to work within it.

13.2.2 Inspector Keyboard Usage
Keyboard shortcuts can be used to access individual inspector tabs directly (Ta-
ble 13.1) without themouse. These shortcuts have twomodes of operation. If the
tab in question is not visible, the Inspector will open (if necessary) and switch to
that tab. If the keyboard shortcut is pressed while the particular tab is already
visible, it will be focused. This means you can always start typing in document
notes, even if the Inspector is hidden, by quickly tapping the corresponding key-
board shortcut twice.
These shortcuts can be used in the following places as well:

— Quick Reference panels: using one of these shortcuts will open the split
view to the inspector requested inspector information.

— Composition mode: likewise, when in composition view, these shortcuts
will call up and reveal the appropriate portion of the floating inspector.

Return to chapter ⤴
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Table 13.1 Inspector Keyboard Shortcuts

Shortcut First Use Second Use

⌃⌥⌘H Notes &
Synopsis tab

Reveals or switches focus to the notes tab. Use the Syn-
opsis command below to focus the upper “index card”
portion of this tab.

⌃⌥⌘N Bookmarks
tab

Reveals or switches focus to the bookmark list. Use ⌘6
to switch between viewing project and document book-
marks. Once you have selected a bookmark you wish to
edit in the preview area below, hit the Tab key to switch
panes. Double-clicking on a bookmark, or pressing the
Return keywill load the selected bookmark in accordance
with the settings in the Behaviors: Document Links set-
tings pane (subsection B.4.2).

⌃⌥⌘J Metadata
tab

Reveals the metadata tab, and switches focus to the Cus-
tom Metadata pane within it. Use Tab and ⇧Tab to nav-
igate between text and date fields. Use the Keywords
command below to switch focus to the lower third of this
tab.

⌃⌥⌘L Metadata
tab

Reveals the metadata tab, and switches focus to the Key-
words pane within it. Arrow keys can be used to navigate
amongst keywords; Return can be used to add new key-
words; Delete will remove selected keywords.

⌃⌥⌘M Snapshots
tab

Reveals or switches focus to the snapshot list. Use arrow
keys to flip between available snapshots and view their
contents in the preview area below. Press the Tab key to
switch keyboard focus into the snapshot viewer, where
you can use Select All and copy, or use the page up and
down keys to scroll the view.

⌃⌥⌘K Comments
& Footnotes
tab

Reveals or switches focus to the comments & footnotes
tab. The ↑ and ↓ keys can be used to navigate through the
list, and→ and← to expand and collapse selected notes.

⌃⌥⌘ I Notes &
Synopsis tab

Reveals the notes tab and switches focus to the synopsis
text area. Use the Notes command above to focus on the
lower portion of this tab. Use the⌘7 keyboard shortcut
to switch between viewing the synopsis as an image or
text.
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Figure 13.5 Inspector: Synopsis & Notes tab.

13.3 Notes Tab
Each and every binder item in Scrivener has its own separate scratchpad that you
can use to jot down notes. There are two types of notes you can use:

1. The summary, or “Synopsis” card, in the upper half of this tab (Figure 13.5),
will be visible throughout the project in the formof index cards, in the out-
liner and other areas. How you use it is up to you, but its public presence
in the project makes it great for summaries, longer descriptions than the
title affords, and structural notes you make in group views which you can
later focus on.

2. “Notes”, in the lower half, is a better tool for long-form note taking on the
item in question. You will only ever see these notes while working with
or selecting the item in the editor. You can use most formatting features
within this field, even styles, images, tables and lists.

Both of these panes can be collapsed, or the sized changed by dragging the
divider between them. To return to the default “index card” aspect ratio, double-
click on the spitter area.
The content indicator dot, in the top-right corner of the tab icon, will only

appear when an item has note content.

318



13.3. Notes Tab

13.3.1 Synopsis Card
The index card found in the inspector will be simpler than what you may see
on the corkboard. Special display features, such as the label strip, keywords and
status stamps, will not be rendered, as they can be readily viewed (and of course
modified) elsewhere in the inspector. However if you are using the View ▸Use
LabelColor In ▸ IndexCards option, the cardwill be likewise tinted in the inspector.
As with the corkboard, you can edit the title and synopsis right on the card.
To target this area of theNotes tab specificallywith the keyboard, use the⌃⌥⌘ I

shortcut once to reveal it and a second time to place the cursor within the syn-
opsis area.

Synopsis Images vs Text
In the “Synopsis” section header, along the right-hand side, is a button thatwhen
clicked will toggle between using a text or image synopsis for this item. (You
can also use the ⌘7 shortcut, or the matching button on the Touch Bar when
keyboard focus is in the inspector, if this tab is showing.) Graphics that have been
imported into the binder show a thumbnail of themselves on the corkboard and
inspector by default. Use this same button to disable that behaviour for an image
and use a text synopsis instead.

— With the synopsis area switched to image mode, drag and drop a graphic
from nearly any source (including the binder) to assign that image and use
it to represent this document on the corkboard.

— To change the image, simply drop a replacement into the synopsis area of
the inspector.

— This can also be done for files that are themselves graphics. It will replace
the thumbnail with a different image. To restore the original image: right-
click on it in the inspector and select Clear Image from the bottom of the
contextual menu.

— Drag the image out of the inspector to create a copy of it in the binder—it
will become a fully imported graphic at that point, with its own index card
and so forth.

— To instead merely view the synopsis image at full scale, drop the graphic
into an editor header bar, instead.

— To remove an image, right-click and select the “Clear Image” command at
the bottom of the contextual menu.

— Toggling between image and text synopsis in the inspector will change
how this item is represented on the corkboard.

The text synopsis will not be erased if you opt to use an image, and in fact
will still be used in the outliner, tool tips, search results and places where the
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synopsis might be exported as text. Likewise the image will remain stored even
if you switch back to text view.
The inspector can have its behaviour changed to always display the text syn-

opsis, by enabling the Always show synopsis rather than image by default in
inspector setting in the Appearance: Index Cards settings pane. When this op-
tion is set, youmay use the toggle to view the synopsis image, without impacting
whether it displays one way or another on the corkboard.

Adjust Synopsis ImageCropping and Size
You can adjust the size, placement and cropping of the image by right-clicking
on it within the inspector. These adjustments also impact theway the imagewill
be displayed on the corkboard:

Scale to Fit The longest edge of the image will be sized so that it fits within the
shape of the index card in the inspector, thus showing the entire image.

Fit Horizontally The width of the image is sized to fit the width of the synopsis
image area. This may mean portions of the image are cropped along the
height.

Fit Vertically Likewise as above, only the height of the image will take priority.

Align Top/Left When fitting the image horizontally or vertically, you can
choose to pin the image to the top edge of left and crop the bottom or
right.

Align Center This is the default setting, both the top and bottom or left and
right (depending upon cropping) will be trimmed.

Align Bottom/Right As with aligning top/left, this will crop the top or left of
the image off as need be.

Auto-Filling Synopsis Text
If youwould prefer to use an excerpt from themain text area, there are twoways
to go about doing so:

1. Select some text in the main editor and use the Documents ▸Auto-Fill ▸Set
Synopsis from Main Text menu command (⇧⌥⌘ I) to fill the synopsis with
that text.

2. Conversely, if you want to first block out some ideas on the corkboard and
then later dump those ideas into the main text editor for further develop-
ment, use the Documents ▸Auto-Fill ▸Send Synopsis to Main Text command
to append the synopses of all selected cards to their respective main text
content.
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3. Drag and drop text to or from the synopsis text area to add it at the drop
location—just as with any text editing area.

What if I simply want the first bit of text shown?

If no selection is made, a portion of the first line of the main text area
will be used to auto-fill the card. However, in most cases it will be more
efficient to just leave the index card blank if that is the desired result, as
the first few words will be printed automatically on the corkboard and
outline, and you won’t have to worry about keeping that text up to date.
See Titles and Adaptive Naming (section 7.2) for more information on
that behaviour.

See Also…
— SoWhat are Index Cards, Anyway? (subsection 8.2.1): introductory text on

the anatomy of an index card—primarily as it relates to the corkboard, but
since this copy in the inspector is your portal to that “same” card it’s good
to know what it represents.

— The Corkboard (section 8.2) & The Outliner (section 8.3): knowing where
this synopsis card shows up is essential to using it effectively.

— Appearance: Index Cards settings pane (subsection B.5.6): where much of
how an index card looks & feels will be configured.

13.3.2 Document Notes
The “Notes” section in the lower half of this tab (it has a yellow background by
default) is a small but near-fully capable rich text editor (much like themain text
editor you do your principal writing within). You can embed images, use lists,
tables and most other things you might need. It is thus a suitable place to copy
and paste text from the main editor, if you wish to set aside passages you aren’t
sure about.
Document notes are exclusively available to the current document in the sense

that you cannot view them unless you are inspecting their associated document.
They can be exported as an option when exporting binder items as files (sec-
tion 25.1), and as part of a compile format’s Section Layouts (section 24.2).
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Upgrading from Scrivener 2

Looking for Project Notes? In previous versions of Scrivener, project
notes were a special feature, but they have been converted to a more in-
tegrated synthesis of features—and specifically to the inspector, you will
not be editing project “notes” in the bookmarks tab. See What’s New:
Project Bookmarks (section F.4) for how the new system works, and the
documentation on the Bookmarks tab following this section.

See Also…
— Editing: Formatting: Notes (section B.3.2): select the default font and size

for all new document notes (also impacts scratchpad formatting).

— Appearance: Inspector & Notes (subsection B.5.7): adjust the text colour,
background colour and whether or not rules are added, for a “canary pad”
look.

Return to chapter ⤴

13.4 Bookmarks Tab

Figure 13.6 Inspector: Bookmarks tab.

Bookmarks are, much like the role they provide in a Web browser, a place to
store links. Where Scrivener goes a bit further than the bookmark system in
your browser is that in addition to URLs to the Web, you can also store links to
thingswithin the project itself—forminguseful cross-references between related
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material—and aswell to files on your hard drive or even to trigger events in other
software, if they support a URL scheme. Anything that works as a hyperlink can
be bookmarked.
Linking specifically from a piece of text, using the hyperlink, certainly has its

place (see LinkingDocuments Together (section 10.1) for that), but sometimes an
item only generally applies to another. Consider if a sub-section in your book has
several supporting articles that you’ve imported into the Research folder. You
reference these frequently when writing in this section of the book, but it’s a
pain to always have to look them up. Dropping these articles into the bookmark
inspector tab establishes a link between these items.

Upgrading from Scrivener 2

Sound familiar? If you’ve used References before in the past, you’re look-
ing at the evolution of them here. You should find that for the most
part, document and project bookmarks are very similar to their respec-
tive formof References in older versions of Scrivener—only now they can
be viewed and edited directly via the preview pane in this tab. Crucially,
this means bookmarks have now also assumed the role that project notes
had. Read more about this change in the appendix (section F.4).

Below the bookmark list is a preview area that will show you the thing you
have clicked on if it is able to do so. In the case of internal text items, this is in
fact an editable portal into the main editor content for that item—granting you
immediate access to related items throughout the project.
To target this tab with the keyboard, use the ⌃⌥⌘N shortcut once to reveal it

and twice to place the cursorwithin the bookmark list area. Once you’ve selected
a bookmark with the arrow keys, hit Tab to jump down into the preview area if
you wish.
Another thing bookmarks accomplish for you is the establishment of a low-

impact network of back-links throughout the project. Linking to things (in any
way) means those things link back, within this pane. Refer to Links are Circular
(section 10.1.1), for more information on that.
Beyond theDocument Bookmarks list, this tab is also a host to two other lists:

— Project Bookmarks (section 10.3), which are also available from the main
menus (wherever lists of the binder are generated, such as the Navi-
gate ▸Open Quick Reference ▸ submenu) and the application toolbar but-
ton. Click the header bar where it says “Document Bookmarks” to switch
to “Project Bookmarks” (or simply press⌘6).

— Matching Texts (subsection 13.4.4) is a tool for locating identical snippets
of sentences or paragraphs throughout your project, using the currently
inspected item as a source. Click the bookmark tabs header bar to switch
to “Matching Text”, or use the⌃⌘6 shortcut to switch directly to it, or back
from it to the previously used Bookmark list.
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13.4.1 Adding Bookmarks
There are several methods for adding new bookmarks:

— Drag items from any project binder…

— Drag hyperlinked text from within Scrivener…

— Drag files from the system or URLs from your browser…

— …and drop them into the list in the upper half of this tab.

— Bookmarks can be created from a URL held on the clipboard as well. E.g.
you can copy the URL out of a browser’s address field, click into any book-
mark tab, and paste with ⌘V to no further ado.

— Lastly you can also use the button in the bookmarks header bar (or right-
click into the bookmark list) to add new bookmarks using the following
tools.

Add Internal Bookmark Presents a binder item selection submenu. Click on
any item, even a folder, to create a bookmark to it. The name of the item
will be used for its description—unlike how bookmarks typically work, if
you edit the title here the original item will be renamed as well!

Add External Bookmark Creates a new row in which you can manually copy
and paste or type in a given description and valid URL or file path of the
resource you wish to link to. This is most useful for creating links to the
Internet, as you can just paste in the URL you have available, but all kinds
of URLs work here.

Use properly “percent-encoded” URLs for best results. If you acquired the
URL from a browser or most other places that produce one, then it prob-
ably already is. This is mainly a concern for hand-written URLs.

Add External File Bookmark Use this menu to load a file browser. Any file you
select in this browser will be added as a link to the bookmark list. The de-
fault description for it will be the file name, but this can be safely changed
if you prefer.

13.4.2 Opening andUsing Bookmarks
Double-clicking on a bookmark, or selecting it and hitting the Return key, will
open the document either inside Scrivener or in the default application or
browser depending on type of bookmark.
By default internal links are opened in their own Quick Reference Panel, but

this can be changed with the Open inspector bookmarks in setting in the Be-
haviors: Document Links settings pane (subsection B.4.2).
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To load a bookmark in a specific editor instead, drag and drop the bookmark
into the editor header bar. This can even be done for external files on your disk—
they will be previewed (if Scrivener or macOS’ Quick Look supports displaying
the file type) right in the editor without importing it. Further alternatives are
available by right-clicking on the bookmark to bring up the contextual menu:

— Open in Current Editor: Replaces the current editor (and consequently its
bookmark list), with the selected content.

— Open in Other Editor: Opens the selected bookmark into the inactive edi-
tor, opening a split view if necessary to do so.

— View on (Current Editor’s /Other Editor’s) Copyholder: The bookmark’s con-
tent will be viewed in the copyholder for the designated split, or into the
main editor’s copyholder if there is no split.

— Open as Quick Reference: A window will be opened, displaying the con-
tent of the bookmarked internal binder document.You can also press the
Spacebar to do this more quickly.

— Open Quick Look: Only provided to bookmarks pointing to files on your
disk, this command replaces the above, and makes use of macOS’ native
Quick Look feature, as though the file were examined from Finder using
this tool.

— Open with Finder: Available to non-text bookmarks of any kind, this com-
mandwill load the resource in the default external editor as established by
the system.

— Reveal in FinderExplorer: Displays the location of the file by opening a win-
dow in your file manager.

Figure 13.7 The types of bookmarks you’ll see are indicated by special icons.

External bookmarks to files and websites can be dragged into the binder, re-
sulting in the resource being imported into the project. If the bookmark is to
a web page, it will be downloaded and imported into the project in accordance
with your web page archival settings (subsection B.8.1).
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Viewing Bookmarked Folder Contents

Figure 13.8 Easily preview child items from bookmarked folders.

When bookmarking folders you will find a chevron button to the right of the
row (Figure 13.8). Click this button to choose from a menu displaying a list of
subdocuments from that folder. The chosen item will be displayed in the book-
mark preview area below the list. You can more easily include whole categories
of information in your inspectors with this capability.

Editing Bookmarks
Any existing bookmark’s title can be edited by pressing the Esc key with a single
bookmark selected. To finish editing, press Esc or click elsewhere to confirm.

Renaming Internal Bookmarks is Renaming Items

Be aware that if you rename an internal bookmark (one that is a link to
another item in the sameproject binder) youwill be renaming the original
item. This is in fact less like a “bookmark” in the traditional sense of the
word, and more a second place to access and modify that original item.

For external bookmarks (those pointing to any resource not located within
the current project’s binder) there is an additional editing method for when you
need access to or wish to modify the URL:

1. Select the item in the bookmark list.

2. From the button or the right-click contextual menu, select “Edit Book-
mark”.

3. Use Tab and ⇧Tab to alternate between the Title and URL field.

4. Click elsewhere to dismiss the panel.

You can use this to update broken links with the correct file path or URL, or
change their descriptive names in the list. For internal links to other Scrivener
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Figure 13.9 Sometimes giving a file a friendlier name is not only possible, it is
essential.

items in your project, you cannot edit the target, only the name. To replace it
with a new target, you’ll need to create a new bookmark and then remove the
old one.

Deleting Bookmarks
To delete bookmarks, select the ones youwish to remove and click the− button,
right-click and select “Delete Selected Bookmark”, or tap ⌘Delete.

Further BookmarkManagement Tips
For more bookmark management techniques that make use of addition tools
beyond the inspector tab, refer to Managing Bookmarks (subsection 10.3.5).

13.4.3 Bookmark Viewer
The lower portion of the bookmark inspector tab is a capable media viewer and
text editor. As you click on bookmarks in the upper half of the tab, they will
be examined—to the best of its ability—in the lower half. To view or edit the
bookmarked item in the larger main editor, use one of the techniques described
in Opening and Using Bookmarks].
For external file links, only those research files that Scrivener or Quick Look

itself can displaywill be previewed. You can always double-click the icons of such
bookmarks to load them in an their native software.
Web links by default will be loaded as click-on-demand to avoid accessing the

Internet directly without your permission. If you would prefer to have the soft-
ware download websites automatically, enable Automatically load web pages
in bookmarks preview, in the Behaviors: Navigation settings pane (subsec-
tion B.4.6). The Allow limited navigation in web pages setting, in that same
pane, will also apply to pages viewed in the preview area here.

See Also…
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— Behaviors: Navigation (subsectionB.4.6): adjustswhether links to theWeb
load immediately or not, and whether to allowminimal navigation within
the pane.

— Behaviors: Document Links (subsection B.4.2): adjusts whether back-link
bookmarks are created when new links are created pointing to an item, or
in graphics files when they are used in text. This pane also controls where
an internal bookmark will load when pressing Return to load it, or double-
clicking on the bookmark.

— Appearance: Inspector & Notes: Color (subsection B.5.7): adjustment for
the bookmark viewer’s background colour is found here.

— Appearance: Main Editor: Color (subsection B.5.8): the “Media Back-
ground” option here is used to draw the backdrop around PDF files, images
and document icons.

13.4.4 Matching Text Finder
Also hosted in this tab is a tool for finding matching bits of text throughout the
rest of the project. Using the currently inspected item as a source, any docu-
ments that contain one or more identical sentences or paragraphs will be listed.
For cases where you are solely looking to identify items that are whole du-

plicates of one another, refer to Finding Duplications (section 11.1.3), with the
Project Search tool.
To activate this view, open the Inspector to the Bookmarks tab, and click on

the header bar dropdown menu, to select “Matching Text”, below “Document
Bookmarks” and “Project Bookmarks”. Youmay also switch directly to thismode
when this tab is selected, by pressing the ⌃⌘6 shortcut.

Table 13.2 Matching Text Status Icons

Icon Description

This text is the same as the main editor text.

This document’s text is contained inside the main editor text.

The main editor text is contained inside this document’s text.

For all other cases, a pie chart will indicate the relative amount of matching text
found between the two samples. For the precise amount, hover your mouse over
the icon to read the tooltip.

Scrivener will order the list of matches based on several special criteria first,
and then sort the remaining items by howmuch of the text is identical between
each pair of documents (the one in themain editor you are comparing the rest of
the project with, and the individual items listed in this view). Consult Table 13.2
for a list of these conditions and the icons used to indicate them.
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— The status icon to the right of the header text area will indicate when the
feature is searching the text throughout your project for matches. This
process may take a while in larger projects, but it can be interrupted if you
need to move on.

— Click on an item to view its text in the Bookmark Viewer area, below. As
with Bookmarks, you can freely edit the item’s text right in this pane.

— Click the circular arrow button to force a refresh of the list.

— When using this mode, text that has been found in the source document
will be highlighted using the search highlight colour.

— Fragments of matching text may also be located within the document,
highlighted in a dimmer version of this highlight. These indicate parts
of phrases that wouldn’t be considered “matching text” on its own, but so
long as the document is being compared, all duplicationsworth notingwill
be highlighted.

— Items listed as containing matching text can be double-clicked to have
that text selected for you in the main editor. This will result in a text se-
lection that may exist throughout the text editor. Care should be taken
when overtyping, formatting or manipulating text, as there may be some
selected off-screen you have not seen.

This Feature May Cause Excess Battery Usage

If you are using Scrivener in a mobile context, you will want to leave this
list off unless using it, as it will incur a significant energy penalty, by hav-
ing to trawl through the entire project text every time you inspect a new
thing.

Return to chapter ⤴

13.5 Metadata Tab
This tab sports a collection of built-in fields such aswhen the itemwas created or
last modified, to a freeform list of keywords, to a middle section that is entirely
up to you. Need a checkbox on everything you do? No problem. Keeping track
of dates in a convoluted TV series narrative? We can help you with that too.
Arguably the entire inspector pane is about metadata—that which discusses

and describes the thing that is data—but the metadata tab itself is where that
concept is at its purest form. Read Organising with Metadata (section 10.4) for
further information on the different types of metadata.
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Figure 13.10 Inspector: Metadata Tab is packed with goodies.

Each of the three main sections, General, Custom and Keywords can be col-
lapsed to make room for the others as need be. By default the Custom section
will be collapsed in all new projects.

13.5.1 General Metadata
This section contains basic document metadata and provides controls for how
(or if) it will compile.

Created The point in time in which the binder item was created, or if it was an
imported file, the creation date on the original file. For your convenience,
both the Created and Modified date fields can have their date text copied.

Tomodify the creation date of an item, right-click in the date readout area
and select the “Change Date” command from the contextual menu. In-
structions for using the date picker tool can be found in the following sec-
tion (subsection 13.5.2).
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Modified Every time you adjust any part of an item (even the stuff in the in-
spector), the modification date will be incremented to reflect that change.
If you would prefer a more static date to be stored for an item, consider
creating a custom metadata date field.

Include in Compile A checkbox determining whether the document should be
included in the draft when exported or printed via the compile feature. If
checked, the document is eligible to be compiled; if not, it is excluded from
output by default, and is thus useful for documents in theDraft folder that
act as notes or old revisions that are never included in the final draft.

This setting really only has anymeaning for documents that are inside the
Draft folder, (though it can be toggled from anywhere), allowing you to
modify text documents outside of the draft in cases where they might at
some point end up being in the draft, or used by document templates in
setting up how they should work in the draft. The checkbox never has any
meaning for media entries, as these items can never be compiled, and will
thus be disabled for them.

Section Type Defines what type of binder item it is, with regards to how it will
compile. If the document is of the sort that will never be compiled, such
as something in a research folder, you can safely ignore this setting. It will
however be of some interest to you if it is in the draft folder. This setting
is disabled for media files, which are never compiled directly.

Refer to Section Types (section 7.6) for an overview on the topic and how
to use this setting in particular, and how these are set up or defined by the
template you are using in Project Settings (section C.2).

Upgrading from Scrivener 2

Looking for “Page Break Before” and “Compile As-Is”? The latter you’ll
find rolled into the Section Type dropdown, but the former concept no
longer exists. Items are nowassigned to types that by their very definition
may have page breaks, such as chapter headings or front matter sections.

13.5.2 CustomMetadata Pane
In most new projects, there will be no custom fields set up, and this pane will be
collapsed. To start adding your own fields, expand the pane and either click the

button that will appear, the large setup button in the empty area of the pane,
or at any time use the Project ▸ProjectSettings…menu command and click on the
“CustomMetadata” tab (section C.4).
Every custom field in the project will be displayed in this area, stacked in the

order they are established in settings. Their precise appearance and functioning
will differ according to their field type (Figure 13.11). You can use Tab and ⇧Tab

331



13.5. Metadata Tab

Figure 13.11 Custommetadata features a few different types of field.

to move between text and date fields. We’ll go into how to use each type of field
here. If you are unfamiliar with the feature in general, you can read more about
the overall philosophy and usage of CustomMetadata (subsection 10.4.4).

Text Fields These plain-text fields are very straightforward touse. They are sim-
ple places to jot down bits of arbitrary text. They won’t auto-complete
based on anything you’ve typed before, and can hold any amount of text.

TheWrap text option determines whether or not the text field displays all
of the text you put into the field. When enabled text will be wrapped to
the width of the inspector and will thus consume as much vertical space
as it needs to do so. It might consequently be best to position such fields
toward the bottom of the pane.

When disabled only the first line of text will be shown at all times.

Checkbox Fields Fewer things could be simpler than a checkbox. Click the
checkbox to mark an item, click it again to remove the mark. You can
also set whether or not items are marked by default in the respective area
of project settings.

List Fields These function similarly to any type of field where you click on a
dropdown and select a value from the available choices in the menu. All
list fields come with a default “none” state, which can be selected from the
top of the list (the default itself can be changed). Use the “Edit…” menu
choice at the bottom to be taken straight to the configuration panel for
this custom metadata’s field in your project settings.
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Date Fields This field is designed for the storage of dates using a conventional
calendar (if you wish to use a fictional or unorthodox calendar a text field
might do better). Dates can be entered using two different methods:

1. Type in the date using natural language into the field. You can use short-
hand relative notation like “today” or “yesterday”, andwe’ve added numer-
ous standard date formats as used around the world. You should find in
most cases that if you type in a date it should be recognised. You can also
copy and paste dates out of this field.2

2. If the above method isn’t working for how you record dates and times, or
if you would just prefer to use a calendar and clock tool, click the grey
calendar button to the right of the date field to bring up the date and time
chooser (Figure 13.12).

— Use the left and right arrow buttons along the top of the calendar
to flip between months, and click on a day to select the date. The
dot button in between themwill return the calendar view to the date
printed below.

— Supply the date into the given fields to set the date and time, or use
the clicker button to incrementally choose a number for the selected
date field. This will be the easiest way to jump between years.

— The time must be typed in, the clock is merely visual and cannot be
clicked on.

— Click the×button in theupper right-hand corner to clear the current
date assignment and reset the calendar to today.

— Click anywhere outside of the popover to confirm your selection.

13.5.3 Keywords Pane
Keywords function very similarly to what you might see referred to as “tags” in
some other programs. They are a way of adding short bits of information to
a particular item so that it can be cross-referenced with other items that have
those keywords assigned, and are particularly useful for finding intersections in
keyword assignments. For example we could search for all items that have the
keywords, “Lindsay”, “Paris” and “Rewrite” assigned to them.
Read more about using keywords (subsection 10.4.5) for general discussion on

their usage and the various tools available for working with and searching for
them.

2 Scrivener will attempt to use your current date format as a method for typing in dates as well.
The flexibility afforded by custom date formats is far greater than what could be easily “under-
stood” by the computer however, so it may not work with all formats.
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Figure 13.12 Use the date and time popover to insert custom dates.

Assigning Keywords
There are several ways to add new keywords to your document using the inspec-
tor:

— Click the+ button in the keywords table header bar, or click into the key-
word list and press the Return key, then type in a newkeyword. As you type,
any existing keywords that match what you are typing in will be suggested
as an auto-completion (this is case-sensitive). You can also use the Return
key in the table to add new keywords.

— Drag the keywords from the Project Keywords Panel (section 10.4.5) panel
to the document header bar, its name in the binder, corkboard or outliner
(this latter use allows you assign keywords to many selected documents at
once), and of course the keyword list itself in the inspector.

– When keywords have been categorised into groups in the Project
Keywords panel, you can drag it and all of its parent keywords in at
once by holding down the Option key when clicking to drag.

– You can also right-click on selected keywords in the panel to assign
them to all selected documents, using the “Add Keywords to Selected
Documents” contextual menu command.

— Click the button in the keywords table header bar to access the “Add
Keyword” submenu, which will contain a list of all keywords in the Project
Keywords panel.

Right-click anywhere in the keywords list itself for quick access to this
menu, as well.
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Managing Keywords
Keywords can be reordered within the list using drag and drop. The order will
impact the following areas of the project window and elsewhere:

— Index cards on the corkboard, when View ▸Corkboard Options ▸Show Key-
word Colors is enabled. Since only a few keywords can be shown in this
context, putting the most important keywords you track visually near the
top of the list will be beneficial.

— The order of display in the View ▸Outliner Options ▸Keywords listing of the
outliner view.

— When exporting files with metadata, printing with keywords or metadata,
or compiling with metadata or use of the <$keywords> placeholder.

To view a keyword in the Project Keywords panel: double-click on the key-
word’s colour chip in the inspector list. The panel will be opened if necessary
and the keyword will be selected.
To change an assignment from one keyword to another: double-click in the

text area of the keyword and type in the new keyword. This will create a new
keyword in the project list if necessary.

Removing Assignments
Keywords can be unassigned from an item by selecting them in the keywords list
of the inspector and clicking the − button above them, or pressing the Delete
key on your keyboard. You can also bulk remove multiple keywords from many
items at once using this panel (section 10.4.5).
This will not remove the keyword from the project, even if it is the last item

that was using it. To fully remove a keyword (and remove it from all items using
it), see Deleting a Keyword from the Project (section 10.4.5).

Return to chapter ⤴

13.6 Snapshots Tab
Available only to items with editable text, this tab of the inspector provides ac-
cess to any existing snapshots for the item, the ability to create new ones, load
up comparative displays between them and the current editor, and delete them
permanently. Read more about snapshots in Using Snapshots (section 15.8).
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Figure 13.13 Inspector: snapshots tab.

NeedMore Space to See the Snapshot?

Firstly, do note the inspector as a panel can be resized a great deal, and
the height of the snapshot list can be reduced greatly as well. However
in some cases it may not be practical to resize the inspector. The solu-
tion is to load a snapshot into the main editor or its copyholder. Read
more about this capability in Viewing Snapshots in the Editor (subsec-
tion 15.8.3).

The tab is divided into the following areas:

1. Along the top of the tab are a few buttons for managing snapshots and
displaying them, as well as handling roll-backs to the main editor.

All of the options and functions in this area aremirrored within the Docu-
ments ▸Snapshots ▸ submenu. If you use any of these options frequently,
you can attach custom keyboard shortcuts to these commands.

2. In themiddle of the tab is a list of each snapshot associated with this item,
sorted chronologically by default. Click on either of the heading columns
to change the sort order.
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3. And finally the remainder of the tab is where you view the text of the se-
lected snapshot from the above list. This area is not editable, naturally, but
you can copy and paste text from it.

13.6.1 Creating and Removing Snapshots
To snapshot the current state of the text editor, click the + button at the top of
the tab. You can also use the ⌘5 shortcut at any time, even with this tab closed.
To remove snapshot, select the snapshots you wish to remove in the list (you

can use the standard Ctrl+ and Shift+ keys to select multiple snapshots) and click
the− button, or use the ⌘Delete shortcut.
For larger scale deletions across multiple items, the Snapshots Manager (sub-

section 15.8.5) will be the best tool for the job.

13.6.2 Renaming Snapshots
Each snapshot can be optionally named either at the time of its creation, with the
Document ▸Snapshots/Take Titled Snapshots of Selected Documents menu com-
mand, or at any time after that point, here in the snapshot list. To rename an
existing snapshot double-click on its current name in the Title column of the
list. Click elsewhere or press Return to confirm the change. Snapshots can also
be renamed from within the Snapshots Manager.

13.6.3 Rolling the Text Back
If you’ve decided that the contents of a snapshot are preferable to what you cur-
rent have in the main editor, there are two ways you can roll back text from a
snapshot

1. Using the preview area, select the text youwish to restore, copy it and then
paste the text into the main editor.

2. A more thorough approach is to completely replace the text of the editor
with the contents of the snapshot—“rolling back the editor” to a previous
point in time (though as with Back to the Future, we can return to newer
edits too).

a) Select the snapshot you wish to revert to from the snapshot list and
click the Roll Back button, marked (b) in Figure 13.13.

b) Scrivener will request confirmation from you, and give you the op-
portunity to snapshot the current text if you wish.

This operation cannot be undone if you click No, so if you are unsure at all
as to whether you’d like to keep the text as it currently stands in the main
editor, click the Yes button in the dialogue, or Cancel to back out of the
roll-back process entirely.
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13.6.4 Comparing ChangeswithMain Text

Figure 13.14 Snapshot comparison mode shows additions and deletions.

Showing changes that have been made between the point in time where the
snapshot was taken and the present-tense state of the text is a secondary func-
tion of this panel, and also something you can do in the main editors as well. In
addition to this form of comparison, and exclusive to this tab, you can also show
the changes made between two selected snapshots.
To compare the text of a snapshot with the current text in the editor:

1. Select the single snapshot from the list you wish to compare with.

Alternatively, to compare two snapshots together, ignoring the main text:
select both of the snapshots you wish to compare in list, using the Com-
mandmodifier key while clicking.

2. Click the Compare button, marked (a) in Figure 13.13.
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It’s Not Showing Format Changes

Comparison mode strictly analyses the textual changes made between
two different sources of text. It deliberately strips formatting out inter-
nally when doing so, and thus any changes that are purely composed of
formatting modifications will not be marked in any way.

Whenever comparison mode is active in the inspector tab, a few changes will
be made to it (Figure 13.14):

— Twonewbuttonswill be added to the header bar area (marked (c) in the fig-
ure). Clicking these will jump from one change to the next, so you needn’t
scroll and hunt for changes yourself. If you don’t see these buttons then
that means no changes were found.

— The Compare button will turn into an Original button; clicking that will
turn off comparison mode (it will also be disabled if you click on another
snapshot, or navigate to another binder item).

— Copy and paste from the snapshot viewing area will include change mark-
ings in the text that is copied. If you so desire, this is a way of preserving
these markings as persistent text.

Comparison can also be done in the main editors and copyholders (subsec-
tion 15.8.4).

Browsing and Adjusting ChangeMarkings
When in comparison mode, two arrow buttons will appear to the right of the

button. With these you can jump from one change to the next within the
snapshot preview area. You can use ⌃⌘[ and ⌃⌘] to navigate between changes,
as well—and when viewing a comparison in the main editor or copyholder you
will always need to use these shortcuts.
As for how changes aremarked, in some cases the default settingsmay present

a confusing result. The method of analysis can be fine-tuned by clicking the
button beside the Compare|Original button at any time. In many cases, selecting
something broader thanword-level analysis will produce a cleaner (thoughmore
vague) result. These options work in a descending fashion, meaning that the
lowest selected option overrides the options above it. Thus, to switch to “By
Clause”, you need only disable “By Word”.

By Paragraph Any changesmadewithin a paragraphwill trigger the entire para-
graph as having been modified.

By Clause Any changes made within a clause (as in a sentence) will mark the
entire clause as having been modified.
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ByWord Individual wordswill bemarked, producing themost precise (and thus
“noisy”) results.

See Also…
There are a number of settings that impact snapshots, both in their automatic

production when certain actions are taken, and how they appear or behave in
use:

— Appearance: Snapshots settings pane (subsection B.5.14): adjust the snap-
shot background colour (used in both the inspector sidebar and the main
editors) and comparison changes.

— Behaviors: Snapshots settings pane (subsection B.4.10): disable the cam-
era snapshot noise and select whether you should get a visual Notification
feedback.

— General: Saving (subsection B.2.2): opt to have snapshots automatically
created for every document you’ve modified when you use File ▸Save, as
calculated from the last time you did so or when the project was opened,
whichever is more recent.

— Sharing: Sync (subsection B.8.3): set whether or not snapshots should be
taken prior to merging edits made with the mobile version of Scrivener.

Return to chapter ⤴

13.7 Comments & Footnotes Tab
The last tab in the inspector is also exclusively available to those items with ed-
itable text. All linked comments and footnotes assigned to text within the editor
will be listed in the order they are found.3 In Scrivenings mode, where multiple
documents are represented, this display will show a combined view of all notes
across the session. For further information on linked comments and footnotes
themselves, refer to Linked Notation (section 18.3).
Notes can be accessed from themain text editor by clicking on the highlighted

range associated with them, which will by default also open the inspector to this
tab if necessary.4

Along the top of the tab there are three buttons (marked above (a) in Fig-
ure 13.15); from left to right:

3 This list will not include inline annotations and footnotes.
4 If you get a popup box instead, youmay have disabled theOpen comments in inspector if pos-
sible setting, in the Editing: Options Setting tab; opening the inspector to this tab will override
that setting temporarily.
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Figure 13.15 Inspector: Comments & Footnotes tab.

1. Add a comment to the text at cursor or selection. You can also use the⇧⌘*
shortcut even when this tab is closed.

2. Add a footnote in the same fashion. The ⌃⌘8 shortcut is also available.

3. Delete the note(s) that have been selected in the list below.

13.7.1 Using LinkedNotes in the Inspector Pane
Each note will have its own box representing it. They act a bit like corkboard
index cards in that you can click once to select them and then a second time
to start editing the note (or a quick double-click to edit immediately). You can
also use the Return key to start editing a selected note. Interacting with a note in
any way, even to just passively select it, will automatically scroll the editor to the
note’s associated highlight.
There are two ways to stop editing a note:

1. Tap the Esc key to return the cursor to the main text editor, right where
you left it last.
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2. Tap the Enter key (as opposed to the Return key) to stop editing but leave
the focus in the inspector pane, leaving you free to navigate to other notes
with the ↑ and ↓ keys.

Using Notes As Bookmarks

Since selecting notes scrolls the editor to the position they appear within
in the text, they make for a handy form of “text bookmark” to quickly
jump through your text point-by-point to areas that need addressing. In
fact youmight even include some types of notes that exist purely for that
function—as a way of keeping your place or to mark significant chunks
of text (like figures or tables) for easy reference.

Refer to the green note in Figure 13.15; this is an example of a note that has the
mouse pointer hovering over it. In the upper right-hand corner you will find a×
button that deletes the associated note and removes the highlight from the text
editor. As this is a text editing command, it can be undone from either this pane
or in the main editor. When a note is merely selected (as opposed to having its
text edited) you can also delete it with the Delete key. Notes will also be deleted
if the highlighted text in the main editor is removed.
Select multiple notes in the same fashion you would select multiple docu-

ments with the Command and Shift keys. Multiple notes can be deleted, copied,
or collapsed and expanded in this fashion.

Hiding and Revealing Notes
Notes can be independently collapsed or revealed using a few differentmethods:

— Click on the triangle to the left of the heading of the note you wish to
expand or collapse.

— The ← and→ keys will expand or collapse all selected notes.

— Option-Click on any of the note disclosure arrows to expand or collapse all
notes in the direction taken for the note arrow you clicked on.

— TheView ▸Outline ▸ExpandAll (⌘9) and ExpandAll (⌘0) shortcutswork here.

Note Formatting
When working between multiple sources and programs, you may notice that
footnotes will take some rich text formatting, and may end up looking mis-
matched with the other footnotes you’ve created. You can revert footnote and
comment formatting to default settings:

1. Select the notes you wish to clean up.

342



13.7. Comments & Footnotes Tab

2. Right-click on the selected notes and select the “Convert to Default For-
matting” command.

The global default font for footnotes and comments can be modified in the
Editing: Formatting Setting tab (subsectionB.3.2), in theComments& Footnotes
section toward the bottom.

Setting Colours for LinkedComments
Linked comments, as with inline annotations, can be assigned a colour. By de-
fault, when you use one of the previously mentioned techniques for adding a
note, the highlighter anchor box in your text will be yellow, as will the corre-
sponding note in the inspector. These two colours will always match, making it
easier to see where you are in your text in relation with your notes.
To change the colour of a note, right-click on it in the inspector sidebar, or

in the shaded header bar area when using Popup Notes (subsection 18.3.6). Six
default colours have been provided for convenience, but you can also opt to use
the colour palette to change the colour to a custom selection (from the inspector
only), with the “Show Colors” contextual menu command.
You can also use the standard⇧⌘C on selected notes. Any colour you choose

from the system colour palettewill be implemented on the selection in real-time.
The last colour you chose will be automatically used the next new note that

you create. This is remembered across all projects, and will be persistent until
you choose a new colour.

Inspector Footnote Numbering The View ▸Text Editing ▸Show Compiled Foot-
noteNumbers in Inspector project setting will add a static footnote number
to the upper-right corner of each footnote, when compiling with this fea-
ture enabled. Refer to Compiled Footnote Numbering (section 18.3.7) for
further information on this capability.

Convert to Comment or Footnote Right-click on any selection of notes(or a
pop-over note’s header bar) to convert them between footnote and com-
ment types. This can be done freely at any time, and if a custom colour
has been applied to a comment it will be remembered in the background
in case you convert it back from a footnote in the future. For further infor-
mation, refer to Converting Notation Between Types (subsection 18.4.5).

13.7.2 Zooming Inspector Notes
As with the main text editor, inspector notation can be scaled with a zoom fea-
ture in a way that does not disturb the underlying formatting, in one of two
separate modes:

— Coupled with the editor zoom scale: this is the default setting. If you
change it from the default, right-click on any comment or footnote and se-
lect the Zoom ▸Use Editor Zoom contextual menu command to get it back.
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— In some cases this can produce undesirable results, such as when each ed-
itor split is using its own zoom setting. Select any fixed value from the
contextual menu to force the inspector to always use that level of magni-
fication.

Magnification can also be adjusted quickly with the ⌘> and ⌘< keystrokes,
when the keyboard focus is in this pane (naturally if it is linkedwith editor zoom,
the shortcut will impact both the editor and the inspector no matter where the
keyboard focus may be).

See Also…
— Editing: Formatting Setting tab (subsection B.3.2): adjust the default font

and font size used to create new footnotes and comments in the pane.
Note that in most cases compile settings will handle footnote formatting
for you, so this setting is more for your benefit rather than establishing
print settings.

— TheOpen comments in inspector if possible option, in the Editing: Op-
tions Setting tab, will cause notes to open in a pop-over bubble rather than
in the inspector.

— In Appearance: Main Editor: Colors (subsection B.5.8), the “Comments
area” setting will adjust the background behind the notes.

— In Appearance: Textual Marks: Colors (subsection B.5.16): the “Inspector
footnotes” setting changes all footnotes as well as their anchor highlights
in the editor. The Underline links option in the Options tab will affect
linked inspector notes, too.

Return to chapter ⤴
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It has become commonplace to make your work instantly available every-
where you go, no matter what device youmight currently be using. Sharing files
through the “cloud” among a circle of colleagues, proofers, and editors has also
become part of how we work. While Scrivener for iOS addresses many of those
scenarios, there may be situations where you need to use other technology or
methods, particularly whenworkingwith others. This chapter will cover the op-
tions available, and provide advice for how best to use general purpose systems
like Dropbox.
Synchronisation should always be donewith care, nomatterwhatmethod you

use. Computers will do exactly what we tell them to do, even if the outcome is
not what our original intention was. Whenever using automated syncing tools,
be sure to double-check your settings, and back up frequently.

14.1 Scrivener Everywhere
Placing your Scrivener project into a cloud folder, so that it is available to every
computer you own, is today a natural concept that by and large works well with
Scrivener. Without going into great technical detail: a Scrivener project is re-
ally a whole mass of files and folders, and since most cloud services are designed
around the concept of keeping folders and files together, there isn’t anything you
need to do other than designating that project as being synced in whateverman-
ner your service recommends (often as simple as saving it into the right folder).



14.1. Scrivener Everywhere

Test Before Trust
There are a few cloud services you should be wary of, in terms of how
well they handle a complex format like Scrivener’s. Visit our knowledge
base for up-to-date information on specific services, before settling on
one to use with your important work. It is always a good idea to test the
integrity of your systemwith sample content (such as the tutorial), before
fully committing to its use.

To avoid conflicts with synced projects:

1. Alwaysmake sure your syncing software is done syncing before youopen
a project. Research how your cloud software informs you of when it is
working and pay heed to it. Good syncing softwarewill let you knowwhen
it is moving data to or from the central server on the Internet. In the case
ofDropbox, a small iconwill be placed into the statusmenu bar area, in the
top-right portion of your screen, and iCloudwill indicate status directly on
the project icon itself in Finder. Keep an eye on this indicator and wait for
the “all done” checkmark to appear before you open the project.

2. Never open a project more than once. If all goes well, Scrivener will warn
you if you try to do this, but in some scenarios this warning might fail, so
try to always remember to close your project when you are done with it.
Ignoring this rule is a surefire way to cause major headaches.

3. Always wait for your syncing software to finish syncing before you shut
down your computer. This is of course a corollary to the first rule. Just as
you shouldwait for your computer to be updated before opening a project,
you need to make sure that all of your changes made to the project have
finished syncing back to the server (and thus made available to your other
computers), before you put it to sleep or shut it down.

If you follow these three simple rules, you will dramatically decrease the
chance of any strange conflicts arising due to working in a live syncing folder
with Scrivener. As with all synchronisation technology, it is inherently “less safe”
than working local and saving remote. It is possible to work safely for years in
this fashion, but extra vigilance will be required of you and everyone participat-
ing in the shared project.
If you do run into problems, refer to the guidance in our knowledge base for

tips on how to fix conflicted projects.
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Can This Be Used for Collaboration?
While it is possible for multiple parties to work off of a single .scriv file
hosted on a shared network folder, extra cautionwill need to be exercised
in order to keep the project data safe. At the very least, this section of
themanual should be distributed to all parties concerned, and good lines
of communication should be established so that everyone knows when
a person is actively working in a project. Guideline #2 above deserves
to be reiterated: never open a project for editing if another person is
currently editing the project.

Return to chapter ⤴

14.2 Workingwith Scrivener for iOS
This chapter will not go into how to use the iOS version of Scrivener, save for
where its usage intersects with themacOS orWindows versions. We’ve prepared
a tutorial/reference for you, built right into the iOS app. If you’d like to learn how
to use it, that’s the place to go!
Here we will dig into the ramifications of what iOS now means from the per-

spective of using your computer, whether you wish to use the mobile version
to edit your own projects, or if you intend to work with others who use it. You
should find things won’t have changed much when it comes to using Scrivener
on your laptop or desktop. We hope you find the transition to be easy to use and
liberating (that is, if you’re the onewalking aroundwith yourmanuscript in your
back pocket).

14.2.1 Basic Usage
The Scrivener project format has been designed to support seamless mobile us-
age between device and computer. The iOS app comeswithDropbox integration
built-in—which will make for the most convenient option—but the syncing sys-
tem was specifically built to withstand all forms of file transfer (seeing as how
Dropbox is a file-based system, this is no mere side-effect!). You can package the
project up by exporting it from the app, send it to yourself via email, AirDrop or
even copy the project to a thumb drive and send it to a colleague through the
post (yes, the one with envelopes involved). Syncing happens when projects are
opened, the rest is up to you.
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Upgrading from Scrivener 2

If you’ve just been faced with the question of updating your existing
Scrivener project to 3.0, and arewondering if the new format is supported
by your version of Scrivener for iOS: yes! It supports the new styles and
stylesheets (chapter 17) system aswell as project bookmarks (section 10.3).

When sync occurs, every change made with the mobile version will be in turn
made to themain project, effectivelymerging them together. From your point of
view, the effectwill be to simply pick up rightwhere you left offon your iPad,mo-
ments ago, right down to the last document you were working on being shown
in the main editor.
Meanwhile all iOS devices share the same mobile data within the project.

Keeping an iPhone and iPad synced together is easy, and for some people that
might be more common than syncing a laptop and iPhone together.
This does all mean that syncingmust be done whenever you switch devices. If

you edit the same project from two locations at once, or overlap editing sessions
without syncing intermediate changes, youwill most likely need to resolve some
conflicts. We’ll get in to that later, but don’t fret, it’s just a way of letting you
decide which copies to use, or which parts within those copies should bemerged
into the best version you meant to write.
First, we’ll discuss how to get projects from point A to point B, and then we’ll

talk about what happens once you’ve copied them (section 14.2.1).

Syncwith Dropbox
This should probably gowithout saying, but there are twobasic ingredients you’ll
need to get this all working:

— First thing youwillwant to do is set up Scrivener for iOS so that it is hooked
up to your Dropbox account. If you are unsure of how to do that, please
consult the built-in tutorial on your device, or tap on the circular arrow
icon in the main project screen and walk through the setup screens.

— On your computer, you’ll needDropbox installed and running in the back-
ground.1

In the process of setting up sync in mobile Scrivener, you will be asked where
you wish to save your projects. By default this will be to the Dropbox/Apps/
Scrivener folder (one will be created for you if it does not already exist). Where
this is relevant to your computer is that once you select or create that folder,

1 Technically you could dowithout, but you should only consider using thewebsite or third–party
tools if you know what you are doing. The client is what is going to make all of this automatic
from your perspective.
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you can simply navigate to it and open projects in Scrivener (subsection 5.1.3),
directly, as you would open any other file from your Dropbox folder. You can
also drag projects on your computer into this folder and then sync them to your
device once they have finished uploading to Dropbox. It is also possible to create
a folder on your computer first, somewhere within the Dropbox folder, and then
point the iOS app to that location, later.
While on your computer, you can organise your projects into subfolderswithin

this chosen sync folder. Thiswill change nothing on themobile side, there are no
“folders” in the projectmanagement screen, but if you’d like to keep your projects
organised you can safely do so.

The sync folder isn’t for general storage

Try to limit the files you put into this sync folder to the special settings
files listed in this chapter, and Scrivener projects. Although putting other
types of files into this folder will not harm anything, given how Drop-
box syncingworks, everythingwill be downloaded to yourmobile device,
even if it does not showup in the project list. Ifmany files are placed here,
it could significantly slow down sync, or even eat up your device’s storage
space or bandwidth allocation.

The basic ideas to employ here are:

— Projects you create and sync to Dropbox, from your devices, will appear
in the designated folder on your computer where they can be opened and
worked with like any other project.

— Projects you place into that folder can be synced and edited remotely, even
if you leave it open on your computer.

If that’s all you want to do, you could probably stop reading this chapter right
now! But before doing so, I’d urge you read up on Avoiding and Resolving Con-
flicts (subsection 14.2.2). If you are unwilling or unable to use Dropbox for full
syncing, continue reading at Managing Projects Directly with File Management
(section 14.2.1).

UsingMultiple Sync Folders

Althoughwe do not recommend switching sync folders frequently (youwill need
to download everything all over again every time you switch), but if you need to,
you’ve got it. Thismay be useful if you’re collaborating with another person over
Dropbox, or if you use your device for personal writings as well as using a shared
work folder, and wish to keep the two separate.

1. On your iOS device, return to the main project screen.

2. Tap the Edit button at the top of the project list (in the sidebar on an iPad).
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3. Tap the button at the bottom of the list.

4. Select “Dropbox Settings”. At this point you would select your preferred
sync folder.

At the conclusion of this process, you can choose to keep the projects you’ve
been syncing (they will be moved to the device, not uploaded to the new sync
folder), or to remove the local copies. Neither option will touch Dropbox. If
you keep local copies and later switch back to the first sync folder you may end
up with duplicate copies of the projects, those stored on your device and those
in the sync area. It will be up to you to sort out which to keep.

Where is iCloud Support?

If iCloud were compatible with the format we use to store your project,
we’d support it, that’s the simple fact. At this time, Apple’s interface for
working with iCloud on iOS is designed around amodel which presumes
one single file stores all of the information needed to open and save the
document. To be fair, in most cases this is a safe assumption! Scrivener’s
format, designed with the capacity to store gigabytes of research data,
uses a special folder-based format. A single project may require dozens,
maybe even thousands of files, to all be working together in unison as a
single “format”. Until such a time as iCloud for iOS supports this form
of working with data, we will be unable to provide that method for syn-
chronisation between these platforms. For syncing two or more Macs
together, iCloud Drive is another thing entirely, and as it is designed to
work with tens of thousands of files across your system, it is perfectly
capable of handling Scrivener’s format.

Managing Projects Directly with File Management
Dropbox may not work for all of your projects, or you might be unable or un-
willing to use it at all. No fear! You still get all of the goodies, but you’ll need
to handle copying projects to and fro. These alternative methods have grown
more mature and well-supported over the years, with some techniques now be-
ing so seamless that youmay find them to even be preferable to complex syncing
routines.

iTunes andOther File Managers

The easiest option will be with the iTunes software (or Finder, in macOS 10.15+)
itself, using its “File Sharing” feature to access documents stored by the vari-
ous apps on your device. With Scrivener’s document list loaded, you can copy
projects directly onto the device over WiFi or USB cable, and copy updated
projects down to your computer in the same way, with drag and drop to or from
the Finder.
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1. With your device plugged in or connected viaWiFi, open iTunes or Finder.

2. Select your device in the Finder sidebar, under “Locations”.

3. Select “File Sharing” in the sidebar.

4. Select Scrivener in the “Apps” list.

5. Click the Add… button and select your Scrivener project folder (ending in
“.scriv”) using the file dialog box. This will add the project to the “Docu-
ments” list in Scrivener. You can also drag and drop into the “Scrivener
Documents” list.

6. To copy a project from your device back to the computer, select it in the
“Scrivener Documents” list and click on Save…, selecting a folder to save
the project to. Drag and drop into a Finder window should also work.

Third-party iOS device managers may provide more features as well as better
ways of working with files. If you don’t like how iTunes or Finder works, there
are plenty of choices on both platforms.

Third-Party Sync

Youmay also find that other cloud services can beused, albeit in amanual fashion
(more like copying than syncing), as a way of transferring projects on or off the
device. Most sync services these days fully support Files.app, which means you
can freely copy projects from their sync areas into Scrivener’s document folder,
and vice versa. This includes the use of mainstream providers such as OneDrive
and iCloud Drive, all of which can be connected to your Mac or PC as well.
Some sync services support drag and drop of full folders into Scrivener’s stor-

age area in Files.app, and so it is a simple matter of opening two Files views and
dragging projects to or from the cloud. If you find your provider does not sup-
port drag and drop transfer,2 then using Files to create and copy .zip files around
and to decompress them, will always work safely.

Export as Zip

As for getting projects off of the device, you can export them as Zip files:

1. On the device, from Scrivener’s main project screen, tap the Edit button.

2. Select the project you wish to send.

3. Tap the Share icon at the bottom of the project list.

2 Projects that refuse to open after you copy them is the most common symptom, meaning the
contents of the project folder were not copied.
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At this point a number of services are available to you, depending upon what
you have installed on your device. At a basic level you’ll be able to email a copy
of the project. Other programs may allow you to store the .zip file locally, as a
backup, or sync it to another cloud service.

Using AirDrop to Transfer Projects

AirDrop can be used to easily copy projects between an iOS device and yourMac.

AirDrop to Mobile doesn’t work in iOS 13+

Unfortunately, Apple released iOS 13 in a broken state, where AirDrop
does not properly handle the sending of folders to individual apps. They
have failed to release a fixed version of the OS since. We hope that they
will correct this oversight in the future, but until such a time, you will
note that you can send your project to Files instead, in step (4) below.
When asked where to place the project in Files, select Scrivener’s docu-
ment folder as a target. Upon switching back to Scrivener, you will find
your project listed and ready to work with.

To copy a project to your mobile device:

1. Enable AirDrop on your iOS device (by default you can swipe up from the
bottom of the screen, tap and hold in the networking area, and then tap
the AirDrop button).

2. Open an AirDrop window on your Mac, using the Finder’s Go ▸AirDrop
menu command (⇧⌘R).

3. You should see your iOS device appear as an avatar, to send the project,
drag and drop it onto the avatar in the AirDrop window, then accept the
file transfer on your device.

4. Once it has transferred, youmay be asked which program youwish to load
the project in, choose Scrivener (naturally!).

5. If you are using Dropbox otherwise, you will be asked whether to import
the project into the cloud sync area or to the local device.

To copy a project from your device to your Mac:

1. Open the AirDrop window on your Mac, using the Finder’s Go ▸AirDrop
menu command (⇧⌘R), and ensure “Allow me to be discovered by:” is set
so that your Mac can be seen.

2. On the device, from Scrivener’s main project screen, tap the Edit button.

3. Select the project you wish to send.
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4. Tap the “Share” button at the bottom of the project list.

5. You should find your Mac’s avatar as an option in the share panel, tap on
it.

6. From the Mac, accept the file transfer.

7. The project will be saved to your Downloads folder, as a .zip file. Double-
click the .zip file to extract the project (you can discard the zip if you wish)
and then drag it wherever you’d like.

Updating Projects withMobile Changes
When you open a project that either originated from iOS or has been modified
by it, loading the project may take a little longer than it ordinarily would. This is
because Scrivener is going through all of the changes that have beenmade in both
directions, and doing its best to build a cohesive merged copy out of the two. At
that point, all necessary changes will bemade to the project, potentially building
out dozens of binder items andpopulating themwith thousands ofwords of text,
if you’ve been on the road for a while.
The first time this process concludes, you will be asked whether you’d like

to have changed documents listed in a yellow Collection (section 10.2) called
“Synced Documents”.3 The previous contents of this collection (in subsequent
syncs) will be replaced with the listed items from the latest sync, so if you plan
to review them, do so before the next sync, or change the name of this collection
so that Scrivener will create a new one instead of replacing it.
In most cases, at this point you’re all done! To sync a project you need only

open it.
If the project was already open on your computer, when you switch back to

the window, Scrivener will check for mobile changes and alert you if it needs to
sync before you can safely continue. Use this opportunity to double-check and
make sure Dropbox isn’t actively working, if it is, it may still be downloading
parts of your project and syncing right now would make a mess. Once Dropbox
has stopped working, click the button to update your project. It will need to
reload in order to do so, and by default a backup will be created before syncing.
Sometimes youmight leave the project open and its window active. Scrivener

won’t constantly check the disk to see if there are mobile changes available, it
only does so when loading or activating the project window. To initiate a sync
from an active project window you can add themobile sync button to yourmain
application toolbar and click it, or use the File ▸Sync ▸with Mobile Devices menu
command. You can also try using this if for any reason you think sync should be

3 If you change your mind later on, you can adjust whether this list is created with the “Place
documents affected by sync into a ”Synced Documents“ collection” checkbox, in the Sharing:
Sync settings pane (subsection B.8.3). Additionally you can choose whether or not this collection
is shown after syncing.
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happening but isn’t. If no mobile changes are found, nothing will be done, so it
is safe to try.

14.2.2 Avoiding and Resolving Conflicts
Although we’d like to say that sync is magic and never gets anything wrong (and
that we as humans nevermisuse it!), reality often sticks a wrench into the works.
A conflict is typically nothing to be too concerned with. All it means is that par-
ticular aspects of the project were edited in two ormore locations without keep-
ing them in sync, and in such a way that Scrivener can’t figure out which is best.
For example if you step away from your computer, sync properly to your iPhone
and make a change to a particular binder item, but forget to save your changes
from the phone back to Dropbox, then editing that same text file on the com-
puter later on would mean both machines might now have valuable work you
wouldn’t want to lose, once they finally do sync—and that is by definition a con-
flict.
We do our best to warn you when it looks like a sync really should happen be-

fore you start working, but not all situations can be detected automatically. Your
first warning will be when conflicts are detected. We give you a chance to wait
andmake sure Dropbox is done working. After proceeding past that checkpoint,
the project will be synced.
If any significant conflicts were found, a second copy of the item will be cre-

ated within a folder called “Conflicts”, added to the top level of the Binder. The
original binder title of the conflicted item will be used for each, with “(Con-
flicted Copy)” appended to their titles. Additionally a document bookmark (sec-
tion 10.3) will be added to the conflicted copy in the inspector, pointing back to
the original version in the binder that it conflicts with. To view the two copies
side-by-side for comparison, right-click on the bookmark to the original and se-
lect “Open in Other Editor”, or “View on Current Editor’s Copyholder”.4

Of course the best way to handle conflicts is to avoid getting into the situation
in the first place! These simple rules should help you stay out of trouble:

— Remember to sync your device when you’re done using it. Think of it like
saving, the more you do it, the safer you’ll be.

— Don’t edit your project from more than one device or computer at once.

— Pay attention to Dropbox status on your computer. Don’t start sync-
ing with iOS until your computer has stopped uploading the most recent
changes to the project.

In the other direction, even though you might have already synced the
iPhone to Dropbox, that doesn’t mean your computer is instantly up to

4 More options for quickly loading bookmarks are referenced in Opening and Using Bookmarks
(subsection 13.4.2).
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date. It may take a few seconds orminutes for your changes to fully down-
load. Don’t risk it! Wait until Dropbox has stopped working for several
seconds before syncing mobile changes into the project.

For additional protection against conflicts, consider enabling the “Take snap-
shots of updated documents” checkbox, in the Sharing: Sync Setting tab. Be
aware this option will, over a long period of time, generate quite a number
of snapshots, which can slow down sync—the Snapshots Manager (subsec-
tion 15.8.5) can help in clearing out old unwanted sync snapshots.

14.2.3 Storing Settings and Fonts onDropbox
You can store iOS compile appearance settings, formatting presets and custom
fonts in your Dropbox folder, making them automatically available to every de-
vice hooked up to this sync folder. Whenever changing or adding files, you
should sync your devices with the server, and to play it safe, restart Scrivener
for iOS (press the Home button twice quickly, then swipe the Scrivener tile up
to remove it from the running apps list, then tap on its icon to load it again).

— Fonts: instead of having to install your favourite writing fonts on each de-
vice, you can place them within a “Fonts” subfolder (create one if neces-
sary) of your main Dropbox sync folder. E.g. if you are using the default
sync folder location, you would place your fonts into:

∼/Dropbox/Apps/Scrivener/Fonts

Scrivener can read TrueType (TTF) and OpenType (OTF) font formats.
Not all fonts may work as expected (see the following). For alternative
methods of installing fonts that do not require a computer, refer to the
iOS tutorial.

— Compile Appearance: or Scomp files, are used to style your document when
compiling from iOS5. You can save custom Scomp files directly toDropbox
fromwithin the app, and of course you canwrite and save your ownScomp
files froma computer using a plain-text editor. These files should be placed
in a subfolder called “Compile” (if you save them from within the app, it
will create this folder for you). For more information on Scomp files, refer
to the in-app help, from the Appearance Editor screen.

14.2.4 Workingwith Fonts
Whenworking acrossmultiple platforms, fonts can sometimes be a problem (yes,
even between iOS and macOS), resulting in the font assignment being lost, and

5 You can not share compile settings between your Mac or PC and iOS, as the desktop version
uses distinctly different systems for compiling. The only compile settings you should put into
this folder are iOS .scomp files.
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typically dropping to some editor default, such as Helvetica or Arial. The prob-
lem originates with how each platform refers to fonts differently, and small vari-
ances such as these can cause one platform to not understand how another has
assigned fonts to your text.
In short it’s not a serious problem, you can select the text and apply the font

again (possibly using the Documents ▸Convert ▸Text to Default Formatting…menu
command (subsection 15.7.5)), but it is annoying, and so you may find using an-
other font for writing is more efficient, even if it isn’t your first choice. We’ve
done our best to make sure as many default system fonts, especially the com-
mon ones, work cross-platform, but the unfortunate fact is that it is not possible
to make all fonts work all of the time. If you find a font that isn’t working, your
best bet will be to find another.
Keep in mind that Scrivener can compile using a different font than what you

writewith. The font you usewhilewritingwith can be treatedmore as a personal
preference in many cases.

14.2.5 Limitations
Scrivener for iOS contains a much smaller feature set than is available in the
macOS and Windows versions. This is mainly on account of the limitations of
the operating system that runs on iPhones and iPads. The good news is that even
though you may not be able to see and work with some of the more advanced
aspects of Scrivener, they will be preserved. For example, if a binder item has
keywords assigned to it, you won’t be able to view or manage them, but if you
edit that item, upon syncing the changes back to your computer, the original
keywords will remain assigned.

14.2.6 Options
There are a few Settings pertaining to how syncing is handled. You can read
more about them in their respective appendix entries:

— Sharing: Sync: Mobile Sync (subsection B.8.3): settings to enable extra in-
formation and record-keeping when syncing.

— Backup (section B.9): whether a backup should be created directly prior to
merging mobile edits into the main project.

Return to chapter ⤴

14.3 Synchronised Folders
You may at times need to share bits of text from your document in such a way
that other people can edit themusing traditional text editors orword processors,
or even as a way of making your text available while on the go.
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Upgrading from Scrivener 2

If you’ve been using the File ▸Sync ▸with External Folder… feature in prior
versions of Scrivener, you should be aware that necessary internal
changes have made it so that an existing sync folder will need to be re-
built from scratch with the new version. The best result will be to sync
the project one last time to this folder so that it is fully up to date, before
upgrading, and then delete the folder and create a new one after you’ve
upgraded the project in the new version of Scrivener.

This technique uses simple files and folders on your disk, making the system
well-suited for a wide variety of uses, such as the following common examples:

— Integrating with various cloud sharing services such as Dropbox, Spi-
derOak, iCloud Drive, and so forth. It will be easy to share your work with
collaborators, agents, or editors, and later read back any changes they have
made directly into your project.

— Similarly, you could access these files from cloud folders using mobile de-
vices and later automatically merge those edits with your main project
when you get home.

— Any method of sharing the folder with someone, such as zipping and
emailing/FTP/file, sharing will work as the system is based on modifica-
tion dates.

The folder sync feature will create, maintain and synchronise a special folder
on your disk. This will be used to keep select text of a project up to date if (but
not when) changes are made to the contents of this folder. If you have ever used
software that featured a “watch folder” or inbox, where you could edit and cre-
ate documents in a special folder and have the software import or update itself
accordingly at a later time, then you’ll be at home with this feature.
Since this type of feature is somewhat unique, we have found some assump-

tions are made of it that are worth correcting right at the top. This feature is not
meant to be used, under any circumstances, for the following purposes:

— To syncwith the iOS version of Scrivener: there is no need to use this fea-
ture with our iOS app. It can open and edit full projects on its own. Refer
to Working with Scrivener for iOS (section 14.2) for further information.
This featuremerely generates some text files in a folder for you, a Scrivener
project consists of muchmore than a few text files; the iOS version needs
all of that to successfully edit your work on the go.

— Keeping two versions of the same project in sync: do not try to sync two
different projects with the same folder. Bad things could happen, and all
of Scrivener’s warnings when you attempt to do should be heeded. This is
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a broad statement; a good rule of thumb is that if you have more than one
copy of the project (such as a cloud synced copy, which exists on multiple
devices independently) then it is a different version of the same project.
For safest results, only sync with your external folder using one master
copy of the project.

14.3.1 Setting Up Folder Sync
To set up a new sync folder for your project, use the File ▸Sync ▸with External
Folder…menu command.

Figure 14.1 Sync Folder panel with default settings.

Preparing the Folder
The first thing you will need to do is select a new, empty folder on your disk.
Scrivener will manage all aspects of this folder from this point forward; it should
be used for no other purpose than to edit the files within it, or to create your own
files into the existing folder structure. Click the Choose… button, and point the
file browser at the location where you would like to host the sync folder. Keep in
mind that the folder you createwill need to be dedicated to this Scrivener project,
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and so must be initially empty. Never select a folder which has already been
used to synchronise another Scrivener project! In this case, “another project”
can very well mean the same exact same project you copied to another computer
but haven’t kept in sync using some other mechanism such as a cloud service or
mirroring tool.

Sync files in this project with external folder This checkbox is used to turn the
feature on or off without otherwise modifying the settings. Use the Clear
button below if youwish to permanently sever a link between a sync folder
and its project. (Refer to Disabling Synchronisation (section 14.3.2) for
more information.)

Options
Sync the contents of the Draft folder Enabled by default, the contents of the

“Draft” folder will be kept in sync with the folder when this is on.

Sync all other text documents in the project Keep the rest of the project’s text
files (only) up-to-date with this option. This also activates the settings in
the “Import” section, below.

Sync only documents in collection The project must have at least one collec-
tion (other than Search Results or automatically created collections) in or-
der to enable the option. When enabled, only documents that are con-
tained in the collection specified to the right will be kept in sync with the
folder.

This acts as a filter for the two sync source options above. For instance, if
“Sync the contents of the Draft folder” is selected but “Sync all other text
documents” is not, thenwith this option selected, only documents that are
contained in the draft folder and in the specified collection will be synced,
but if documents within the collection are not in the draft folder they will
not be synced.

Prefix file names with numbers Enabled by default. Causes the names of the
files in the sync folder to be prefixed with a numeral corresponding to its
position in the binder. Disabling this will remove the number and the con-
tents of the folder will be subject to ordinary alphanumeric sorting based
on the names of your binder items.

Take snapshots of affected documents before updating Enabled by default.
Automatically generate snapshots for all documents requiring an update.
If you prefer to handle snapshots manually, you may want to turn this off.
However be aware that leaving it on is the safest option, particularly when
both items have been inadvertently edited separately. Since Scrivener can-
not determine which is meant to be themost up-to-date other than by the
file modification date, having snapshots make it a simple matter to review
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the specific changes and decide how to manage conflicts should they oc-
cur.

For more information, refer to Working with Updated Documents (sec-
tion 14.3.2), below.

Check external folder on project open and automatically sync on close
Enabled by default. When the project is opened, it will briefly scan the con-
tents of the external sync folder and alert you if there are any changes de-
tected, offering you the ability to update your project immediately. When
closing, the same check will be performed. This option will ensure that
the sync folder and the project remain up to date, although they will differ
while editing, until you run sync again.

Import
This section will be disabled unless the Sync all other text documents in the
project option is enabled, above. The setting determines where new files you’ve
created within the “Notes” subfolder will be imported into the binder (the “Re-
search” folder by default).
The dropdownwill only display eligible folders and file groups, unless you dis-

able theOnly show containers in destination list option, below the dropdown.

Format
In the final section of the sync folder window, we can set up how the files them-
selves will be created and read from the sync subfolders. You could set the draft
folder to use Fountain format for screenplays, but leave your research and notes
as RTF files, for example.
There are four file formats available, anddepending on your intendedpurpose,

selecting the right option will be important:

— Plain text (TXT): The resulting files will be standard, plain-text files in the
UTF-8 encoding. If they are edited outside of Scrivener, then all custom
formatting in paragraphs that have been edited will be lost upon syncing.
If formatting is as important to your workflow as synchronising, then you
will either need to find a solution that can take advantage of RTF files, or
save formatting for the final stages in your writing project.

When plain text is selected, a second field will appear where you canmod-
ify the file extension used (with “txt” being the default). This can be handy
if you write using a system like Markdown and wish to have the sync files
recognised as such by other editors.

— Rich Text (RTF): This provides the cleanest transfer of information for rich
text users. Most formatting will be retained, especially when used in con-
junction with a word processor that handles all of Scrivener’s RTF features,

361



14.3. Synchronised Folders

such as Word, Nisus Writer or LibreOffice. This is the best option for col-
laborating with other individuals who do not have access to Scrivener, or
for working in a multi-platform setting yourself.

— Final Draft (FDX): Those working with Final Draft, version 8 or greater, and
scriptwritingmode should use this setting, as it will retain all special script
formatting.

— Fountain (.fountain): For use with screenplays, this popular plain-text
markup format can be edited anywhere plain-text files can be edited, and
so has a similar appeal to Markdown for its portability. For details on how
Fountain works, read more about Working with Fountain (section 19.6).

Automatically convert plain text paragraph spacing Only applicable to plain-
text file types. Empty lines will be added between paragraphs to set them
apart from one another visually. These lines will be removed when you
sync the changes back in.

Keep this setting turned off if you require a certain standard, one way or
the other, and do not want Scrivener to change them. In particular, those
working with plain-text formats such as Markdown will require double-
spaced paragraphs even in Scrivener, and so will not want them to be re-
moved or altered in any fashion.

Saving changes without syncing

If youmerely want to adjust your sync settings, hold down theOption key
to convert the Sync button and click the Save button. This will store your
settings without syncing and dismiss the dialogue box.

Additional settings that impact export and import can be found in the Sharing
settings pane, under the “Sync” tab (subsection B.8.3). If you prefer to work with
inline annotations and footnotes, make sure the default settings in the “Import”
tab have been changed, otherwise your RTF comments will all become inspector
notes after a sync cycle.

14.3.2 Usage
With the initial settings now established you will need to sync once to have the
software set up the necessary subfolder structure, and then populate these fold-
ers with the text content of the files from the binder.

First Run
Once the “Sync” button is clicked, Scrivener will export a file for every item set
to be synced. The feature will create one or more of the following three subdi-
rectories within the folder to store the synced files:
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1. Draft: stores documents contained inside the project’s Draft folder. New
files placed into this folder will be imported into the very bottom of the
draft folder in the binder when syncing them in.

2. Notes: stores text documents contained elsewhere throughout the project.
New files placed into this folder will be imported into the project using the
settings in the Import section of the pane.

3. Trashed Files: stores documents that had been synced but have since been
removed from Scrivener, or which had some sort of conflict. You should
occasionally review these files and trash them if they are no longer re-
quired.

Folders will appear as files

Since folders in Scrivener are capable of having text content, files will be
created for them in the sync folder. You can simply ignore these folder
files if you do not intend to put any text into them.

If you intend to start editing these files immediately, it would be a good idea to
close your Scrivener project at this point. While Scrivener will make scrupulous
copies of everything it changes (unless you’ve disabled snapshots), it is best to
work in an alternating pattern to reduce confusion between which file is the
most up to date.
In a collaboration environment, it may not be possible to wait until the other

person is finished. It is safe to work in both the project and the exported copies
at once, so long as changed files are looked over after syncing. In most cases
Scrivener will select the best option for you, but in cases where both you and
your colleague have changed the same content in between syncs, youmight need
to resolve the differences yourself.

Workingwith the Sync Folder
This is the most open-ended part of the process, given that we’re working with
regular old files and folders at this point. They can be edited using other soft-
ware, shared with colleagues or your editor, posted to a cloud share, or even
zipped up into an archive and sent via email. The important ingredients are the
modification dates on the files, the file names themselves and their organisation
into folders.
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Can I change the names of the files?

It is very important to never change or remove the number enclosed in
brackets at the end of the file name. This number is what Scrivener uses
to link the file back to a specific item in the binder. That caveat aside,
changes made to the names of files on the disk will update respective
binder titles if possible. The prefix number, if applicable, will be ignored.

New files can be created into the sync folder if needed. They should be named
on the disk however you would like them to be called in the binder, and placed
into the “Draft” or “Notes” subfolders. Once synced, binder files will be created
for each new file found in these folders, and on the disk the corresponding files
will be renamed to fit in with the rest.

Bringing Changes Back to the Project
The default setting, Check external folder on project open and automatically
sync on close, will keep the project and the disk up to date with each other auto-
matically whenever you open the project or close it. Beyond this, there are three
ways to ask the project to sync with its external folder immediately:

Figure 14.2 Add the “Folder Sync” button to the toolbar for one-click syncing.

— The File ▸Sync ▸with External Folder Nowmenu command.

— Click on the optional “Folder Sync” button in the main toolbar (Fig-
ure 14.2).

— Bring up the folder sync settings (File ▸Sync ▸with External Folder) and click
the Sync button.

The menu command and toolbar button will be disabled until you first set
up sync settings and run sync at least once, or if Scrivener detects that the sync
folder has become damaged or moved.

Using an external folder as an inbox
In addition to working with files that already exist in your binder, you can use
this feature to collect notes while you are away from Scrivener, and for some that
might be all theywish to use this feature for. If you intend to use this feature only
as an inbox, the following setup should work well:
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1. First, create a collection in your project, which will by and large be kept
empty (subsection 10.2.2). You may also wish to create a folder in the
binder that will serve as an inbox. We even provide a custom icon for such
a purpose.

2. Open File ▸Sync ▸with External Folder…, and set sync to work with “all other
text documents” rather than the draft folder.

3. Enable the Sync only documents in collection… setting, and select the
collection you created in step 1.

4. If you created an “inbox” folder, designate it with the Import new non-
Draft items into… setting.

The rest of the settings are up to you. When the project runs sync, it will
import the new files you’ve created, and it will add them to the collection you
set up in step 3. Thus they will continue syncing until you remove them from
the collection.

Workingwith UpdatedDocuments

Figure 14.3 Comparing synced changes using snapshots.

In Figure 14.3 we see a few different features coming together to create one
example workflow for reviewing changes:

a) Updated Documents list: this is a listing of every binder item that was
changed during the synchronisation (it will always appear automatically
after syncing, when necessary). It temporarily replaces the main binder
until you click the × button on the left side of the sidebar header. Read
more about what is going on here in Using Collections (section 10.2).

b) Updated text in the editor: we’ve clicked on the “Choosing a Font” item in
the sidebar; in the editor we can see the revised text that was synced in
from the disk.
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c) Original snapshot text with comparisons: on the right half of the editor we
have loaded the previous version of the text into a copyholder with com-
parisonmode enabled. Wedid this by right-clicking on the header bar (sec-
tion 8.1.1) and selecting the snapshot from the “View Snapshot on Copy-
holder” submenu, with the Option key held down. Read more about using
snapshots (section 15.8) and copyholders (subsection 8.1.5).

The contents of the “UpdatedDocuments” collection list will stick around un-
til sync updates it in the future. So if you don’t wish to go through everything
immediately, it is safe to close this list and return to it at a later time with the
Navigate ▸Collections ▸UpdatedDocumentsmenu command. Here are a few ways
to preserve that list indefinitely:

1. Change the name of the collection: Scrivener will only refresh the list on
sync for the collection named “Updated Documents”. If you’ve changed
the name to something else it will create a new collection for the next sync.

(To rename a collection, use the View ▸ShowCollectionsmenu command if
necessary, and then double-click on the “Updated Documents” title in the
collection tab list, revise the text and press Return to confirm the changes.)

2. Copy the list to another collection: to duplicate the current list, select all of
the entries within it and then use the Documents ▸Add to Collection ▸New
Collectionmenu command. You can also drag items from one collection to
another when the collection tabs are shown, appending them to the end
of the list in the tab you dropped them on.

3. Bookmark the items: if you keep revision notes as a separate file for each
major revision, you could bookmark the listed items for future use; for
details on how to do so, refer to Cloning and Backing Up Collections (sec-
tion 10.2.2).

Disabling Synchronisation
If you merely wish to disable syncing for a time, the entire feature can be ren-
dered temporarily inert by unchecking the Sync files in this project with exter-
nal folder option at the very top of the folder sync settings window.
To sever the connection between a project and its sync folder, click the Clear

button in the setup screen, alongside the area where you would choose where
the sync folder resides. You will be presented with two options:

Clear Only The folder that this project points to will be forgotten. The project
will no longer sync with the folder. This has no greater ramification than
that, you could at a later point choose to select the folder again and resume
syncing with it.

Clear and Disassociate The internal connections used to track which file cor-
relates to which binder itemwill be flushed from the project. This will free
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up space and keep the project cleaner, but it does mean that you will never
be able to link the sync folder back up to this project again.

Whichever choice youmake (other than cancelling of course!) the default but-
ton for the settings panel for syncing will be converted to a Save button. Click
this to confirm your changes and dismiss the dialogue.
Additionally, removing the sync folder from your drive, moving it to another

location, or changing its name will automatically cancel synchronisation the
next time synchronisation is attempted. This will not disassociate the project,
allowing you to reconnect it at a later time.

Using a sync folder with a project on the cloud

If you intend to use a sync folderwhile also keeping the project synced be-
tween multiple machines, you may note that whenever you switch com-
puters the sync folder will be cleared and youwill have tomanually link it
back up. This can be avoided by keeping the path to the sync folder iden-
tical on all machines (which is generally not possible between Mac and
PC), but even with identical paths the Mac App Store version will never
be able to reconnect automatically on account of it being sandboxed—it
needs permission to access a folder and changing computers effectively
erases that permission.

14.3.3 Tips forWorkingwith Synced Folders
Here are a few guidelines that should be followed to prevent problems in ev-
eryday use. If you are using this feature in conjunction with another author or
editor, make sure to communicate these ground rules with themwhere relevant:

— Alternate between external files and the project. This is a rule of thumb, not a
strict rule. Scrivener reads the modification date of each file, and uses the
latest one to determine which should be the binder copy. So by extension,
if each person is careful to work in different areas of the project, conflicts
can be avoided. Use of the collection filter to only provide parts of the
project they should work on, could help.

— Never try to sync one project’s folder with another. Even if those two
projects originally came from the same identical project, over time there
will be differences in each project that you cannot see, and these differ-
ences will lead to confusing results at best, and a loss of data at worst. A
sync folder is meant to allow you to work without Scrivener for a while,
and then come back later and update your project with those changes.

— Disable automatic sync on open and close before duplicating the project in
Finder. If you create a duplicate from within Scrivener (using the backup
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features, or File ▸Save As…), you do not need to worry about this as Scriv-
ener will clean up any automated settings for you. However if you intend
to duplicate the project outside of Scrivener using the Finder, make sure
to disable this option first, otherwise they will both end up using the same
folder automatically, and this can lead to damaging your project if you con-
tinueworking in both projects. Once you’ve created the duplicate, it is safe
to turn it back on in the original project, provided you either leave auto-
matic syncing off in the new project, or point it at another folder.

— When working from multiple computers sharing the same sync folder, always
make sure your project file is the most current. It is perfectly safe to use the
same project to sync to a shared folder frommultiple computers provided
you are always using the most recent version of the project and are not
trying to bend the feature to sync two different versions of the project (see
above).

— Session target goals will include synced changes. When updating project files
with external edits, the session target will be incremented by the amount
of text that has been added. If youwish to keep track of your session target
separately, youmightwish to reset the counter after updating your project.

Managing Automatic Snapshots
When Scrivener creates snapshots it will use standard naming conventions. If
Scrivenermakes amistake and syncs text in the wrong direction these snapshots
can be used to restore that text where needed:

— “Pre-Sync External File Version”: when the copy on the disk is scheduled
to be updated by revisions from the project, this snapshot will contain the
contents on the disk prior to doing so.

— “Pre-External File Sync Overwrite”: this snapshot records the state of the
text from the binder item before the disk was used to update that text.

Getting Rid of Old Snapshots

You canuse the SnapshotsManager (subsection 15.8.5) to periodically purge these
automatically generated snapshots out of the project once you are done with
them:

1. Use theDocuments ▸Snapshots ▸ShowSnapshotsManagermenu command.

2. Search for “Pre-Sync” or “Pre-External” in the upper left hand corner of the
snapshot manager.

3. Follow the provided instructions for deleting snapshots with the manager
(section 15.8.5).
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Limitations
There are a few general limitations that you should be aware of:

— This is a content based tool. It exports files with the text content of the
binder items you select for syncing. Only the main text area will be ex-
ported, nometadata such as notes, synopsis, keywords and so forth will be
included.

— In extension of that concept, this is not a tool for implementing binder-
level changes. The sync folder creates a flat list of files containing the con-
tent of those items, fromwherever theymay be located within the project.
Creating folders in the sync folder area or moving files around within it
will at best have no effect, and at worst break the sync.

— Since the system uses file modification dates to determine which copies
need to be updated in the project binder, any tools that youuse that change
those dateswithout actually editing the file,might produce unintended re-
sults. This will rarely happen, as most tools respect file modification dates
and will not change them unless the file itself has changed.

Rich Text Limitations

When using the RTF sync format, you can expect zero to minimal loss of for-
matting when used in conjunction with a good word processor. There are a few
features in Scrivener that have no comparison in RTF and will be lost when edit-
ing the file:

— Inline annotation and comment colour cannot be restored from external
files. If you use sequential annotations separated only by colour, it would
be a good idea to move them so that they have a word or two in between
them, or separate them by putting them on different lines.

— Expect the loss of some features when using RTF editors that do not fully
support the RTF specifications, such as TextEdit, Pages and similar. Foot-
notes, comments, lists, images, and tables are the most common items
which have limited to no support. Using fully-featured word processors
with good RTF support, such asWord, NisusWriter Pro or LibreOffice will
help you avoid this, and even be quite useful as comments can be used to
aid in the collaboration process.

— Linked images and MathType equations will become embedded graphics
on export, which in the latter case means the equations will no longer be
editable.

— If the only changesmade to a filewere formatting, theywill not be included
in the sync. This is down to a technical limitation of how these files must
be scanned and processed by their text content. If you have pure format-
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ting changes you’d like to make to a file, just add a temporary word at the
top of the file that you can remove later.

Plain Text Limitations

Since it is impossible to convey formatting in plain-text without some sort of
visible mark-up, Scrivener takes steps to protect as much of your formatting as
it possibly can by only swapping in edited paragraphs rather than the entire file.

— To avoid having inline notation become confused with standard text,
Scrivener will export inline annotations by wrapping them in double-
parentheses “((” and ”))”. Inline footnoteswill be similarly wrapped in curly
braces “{{” and ”}}”. These work in both directions. If you type them into a
paragraph using your text editor, they will be converted to their respective
type of notation upon syncing.

— Inspector comments and footnotes will not be exported. If the retention
of this information is important to you, it is recommended you use inline
notation with plain-text. You can easily convert your notes to inline with
tools found in the Edit ▸Transformations submenu.

— Embedded images will be stripped from documents that have been edited
outside of Scrivener.

14.3.4 Folder Sync Settings
Most of the settings pertinent to this feature are project-specific, and thus lo-
cated within the panel brought up by the File ▸Sync ▸with External Folder… menu
command.
There are also global Settings available that impact the basic functioning of

this tool. They are found within the Sharing settings pane, under the “Sync” tab
(subsection B.8.3). Whether to import comments and inline or inspector notes
is governed by the settings in the “Import” tab.

Return to chapter ⤴
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Part III

Writing

Writing is easy. All you do is stare at
a blank sheet of paper until drops of
blood form on your forehead.
Gene Fowler



When it comes to the process of writing, nobody can tell you how it should
be done. Each author has their own methods, their own rituals, and their own
favourite tactics. Scrivener was designed to recognise that everyone is different,
and as a result the program features an extraordinary amount of flexibility and
interface power. You will find workflows and tools for all manner of writing
projects, fromadoctoral thesis, the next blockbuster screenplay, to a novel, game
design, a collaborative scientific article, patent claims, biographies, and much
more. Because of this, there are many features you just won’t need! That is fine,
because Scrivener has also been designed to keep these features out of your way
unless you need them.
Consequently, this section contains chapters and sectionswhich could be con-

sidered optional. Screenwriting, technicalMarkdown-basedwork and bibliogra-
phies can be safely skipped unless your work requires these capabilities. There
are a few exceptions that cover tools that will be broadly useful to most disci-
plines:

— Writing and Editing (chapter 15) this will introduce the text editor, where
you will be doing most of your writing, and the tools available to it.

— The chapter on Annotations and Footnotes (chapter 18) will also be of in-
terest tomany, as it covers editorial tools formarking text, taking notes on
your own writing, and managing revisions—as well as of course creating
footnotes or endnotes for your readers.

— Page View (section 16.2) & Composition Mode (section 16.1) offer unique
ways to view your text as your work. The former will be welcome to those
that appreciate the aesthetics of “writing on a page”. The latter brings
“zen-like” focus to your writing environment, cutting out all of the user
interface and forcing you to work with the text alone.

— Lastly the Writing Tools (chapter 20) chapter goes over statistics, goal
tracking and using reference & dictionary tools.
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Scrivener uses the standard macOS text editor, and therefore all of the fea-
tures of its rich text editing system (which are showcased in Apple’s TextEdit
application) are available1. Scrivener also provides some extra word processing
features not found in most other implementations of this text engine. We will
be going over many of these in this chapter. For topics that are common to all
Mac software, we may not spend as much time documenting them, as they are
often suitably documented in TextEdit’s help files.

15.1 Rich Text Editing Philosophy
Scrivener supports a rich text editing environment, whichmeans that it is loosely
“what you see is what you get”. Unlike word processors or desktop layout appli-
cations, however, the precise formatting that you use when writing in Scrivener
may in fact (even intentionally so) look nothing at all like the final product. The
compiler will be covered in greater detail in a later section (chapter 23), but suf-
fice to say that you can work in one font, say the default Palatino, but publish
in an industry standard font like Times New Roman, without having to change
your source text.
What this means for you is that editing text in Scrivener can be used like a

typical word processor, but it could also be treated more like a plain-text editor,
where the paragraph settings, fonts, and every aspect of how it prints is some-
thing you decide for later. Scrivener is not intended to be a full-blown word
processor, rather a tool for cutting the text that will become your book in other
programs more dedicated to that purpose.
Youmight bewondering if Scrivener offers a plain-text editing environment as

well—after all it optionally supports markup-based writing methods like Mark-
down. There is no plain text option, as Scrivener is fundamentally a rich text-
based system, meaningmany of the tools that aremade available to you for writ-
ing rely upon rich text to function, such as highlights, marking revisions, and

1 The only exception to this is that in Scrivener, you are not allowed to paste media files, such
as video clips, into the text. This is because of a bug in macOS that can cause crashes or strange
behaviour when a media file is contained inside a single piece of text that is being viewed in two
panes, such as Scrivener’s split view.
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annotating. Even if you do not require formatting as formatting, you will prob-
ably find the formatting tools themselves useful for the writing process.

Return to chapter ⤴

15.2 Editing Basics
15.2.1 CaretMovement and Selection
Table 15.1 shows the shortcuts for changing the current selection. To simply in-
stead move the current insertion caret position, omit the shift key where appli-
cable.
An advanced method of selection can allow you to select more than one loca-

tion at once. By holding down the Command key and selecting using the mouse,
you can select several areas of non-consecutive text. TheOption key can be used
to select rectangular portions of text, which is mainly useful for trimming un-
wanted characters off of the beginnings of several lines, or selecting columns of
text in tables or tabular content.
Sentences can be selected with the Edit ▸Select ▸Select Sentence & Select Sen-

tence with Spaces menu commands. If you intend frequent use of these com-
mands, you might want to add a keyboard shortcut (section A.1).

15.2.2 Deletion
Simple character deletion can be performed with the delete key to delete the
character prior to the cursor. On some keyboards, an additional Del key, that
deletes the character after the caret position, is provided. Onmany compact and
laptop keyboards (which includes all Apple keyboards, even if it isn’t printed),
you may be able to use Fn-delete to delete the following character.
Refer to Table 15.2 for further shortcuts.

15.2.3 Marking Text for Deletion
If you want to simply mark text for deletion without fully deleting it from the
editor, there are a few ways to do so:

— Using Inline Annotations (subsection 18.2.1), you can select the text you
want to delete and mark it as annotated. This turns it into a “comment”
that will ordinarily be stripped out of the text when compiled.

At a later date, if you are sure you want to delete the text, you can use the
Edit ▸CopySpecial ▸CopywithoutComments andFootnotesmenu command,
and then paste over the text, effectively stripping out all annotations. Nat-
urally if you use annotations for other purposes as well, or footnotes, you
might not want to use this approach and remove the selections one by
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Table 15.1 Character Selection Shortcuts

Action Taken Keyboard Shortcut

Extend current selection in the direction of the arrow key that
is used.

⇧Arrow

Extend the selection by word. ⇧⌥← or→

Extend the selection by paragraphs. ⇧⌥↑ or ↓

Select from the caret position to the top or bottomof the editor,
respectively

⇧⌘↑ or ↓

Select from caret position to beginning or end of the soft-
wrapped line respectively.

⇧⌘← or→

Select from the caret position to the end of the paragraph.
(Omit Shift to move the cursor.)

⇧⌃E

Select from the caret position to the beginning of the para-
graph. (Omit Shift to move the cursor.)

⇧⌃A

Extend the current selection using the mouse. ⇧MouseDrag or Click
to select to a defined
point.

Select word. Can be used in conjunctionwith dragging to select
a range by words.

Double-click

Select paragraph. Can be used in conjunction with dragging to
select a range by paragraphs.

Triple-click

Scrolls the text up or downby the height of the viewing area, but
unlike PgUp and PgDn alone, will also move the cursor, keeping
it fixed to the middle of the view as you scroll.

⌥PgUp or PgDn

Table 15.2 Character Deletion Shortcuts

Action Taken Keyboard Shortcut

Delete to beginning of current word ⌥delete

Delete to end of current word ⌥Fn-delete or⌥Del

Alternate forward character delete ⌃D

Alternate backward character delete ⌃H

Delete to beginning of soft wrapped line ⌘delete

Delete to end of paragraph (not line) ⌃K

Transpose letters around caret ⌃T
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one instead, with the aid of the Find by Formatting command (subsec-
tion 11.6.3).

— Use the Format ▸Font ▸Strikethrough command (⇧⌘_). In addition to visu-
ally striking out the text (this will also use the current revision level colour
for the strikeout if applicable), theDelete struck-through text option can
be enabled in the General Settings (subsection 23.4.3) tab of the compile
overview screen.

When you get to the point of wanting to truly delete the text, select the
areas fromwhich you want to strip out all struck-through text and use the
Edit ▸Delete Struck-Through Textmenu command.

— Lastly, text you wish to delete can be moved elsewhere. The snapshot fea-
ture (section 15.8) is a great way of storing text in this fashion, but you can
also cut and paste text into the document notes tab of the inspector (sub-
section 13.3.2) for safe-keeping.

15.2.4 Sorting Paragraphs
Paragraphs can be sorted in ascending or descending order via the Edit ▸Sort ▸
submenu. This feature requires a text selection in the currently active editor of
more than one line.

15.2.5 Spell Checking
Spell checking in Scrivener can be accomplished either as you type or after you
are done writing a section. You can toggle this behaviour on and off with the
Edit ▸Spelling ▸Check SpellingWhile Typingmenu toggle (⌘\). The last setting you
made will determine whether newly created projects have spell check while typ-
ing enabled or not. For example, if you disable spell check in your current project
and then create a new one, spell check will be disabled in the new project as well.

Using the Spell CheckWindow
If you prefer to spell check in one go at the end of a writing session, use the
traditional window (Figure 15.1) for doing so, with the Edit ▸Spelling and Gram-
mar ▸Show Spelling and Grammar menu command (⌘ :). (You can also use the
Check Document Now command (⌘ ;), to jump from one misspelled word to the
next.)

— When you have the correct spelling selected from the list, click Change to
make the edit on the original text. Click on words in the list below the
editable field to automatically fill them in.

— If you want to skip over the current word or the spell check window needs
a jump start, click the FindNext button

378



15.2. Editing Basics

Figure 15.1 The traditional spell check window is useful if you prefer to check
spelling at the end of the session.

— The Ignore button will temporarily ignore the misspelled word for that
session, in all documents throughout the project.

— Learn will add the word to your permanent ignore list. This list, inciden-
tally, is shared by all native macOS software.

— Click Define on the selected term to the left if you are unsure of which
spelling is correct. This will load the word in Apple’s Dictionary.app.

— TheGuess button can come inhandy if none of the suggestions are correct.
Attempt to correct the word in the field at the top, then click the guess
button to try again.

Grammar checking can also be enabledwith the checkbox in the bottom right-
hand corner.

Spell Check Contextual Menu
With active spell check while typing enabled, misspelled words will be under-
scored with a red marking while writing. Whenever you see a word with this
marking, you can right-click on it and the contextual menu will contain best-
guess suggestions for which word you were aiming for.
When right-clicking on a misspelled word, a few convenience commands will

also be provided, for “Learn Spelling” and “Ignore Spelling”. These function the
same as the analogous buttons described in the previous section.
There is one additional command that will appear when right-clicking on a

word that isn’t marked as misspelled, but is a custom word you’ve added to the
macOS dictionary. “Unlearn Spelling” removes that word from the global dic-
tionary, and it will now be marked as a misspelling again.

Return to chapter ⤴
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15.3 Editingwith Scrivener
Beyond the basics of text editing, which are similar to many applications, Scriv-
ener provides further tools, specifically designed for writers, in its editor inter-
face. The rest of this chapter will focus on these tools in a comprehensive fash-
ion, where you can glance through the list of topics covered and pickwhich items
you feel are best suited to your writing style and the task at hand. You could read
this section from start to finish, but it is meant to be a collection of individual
nuggets that you can learn independently, as you gradually build up your knowl-
edge of the application.

15.3.1 Scaling Text
The text of the editor can be scaled up and down visually, without affecting the
underlying font size, making it easy to increase legibility or zoomout for a bigger
picture. Each split, as well composition mode, preserve their own independent
zoom setting.

Figure 15.2 The text zoommenu provides handy presets as well as precise con-
trol.

In the standard text editor, zoom can be set using the zoom tool (Figure 15.2)
in the footer bar. In composition mode, this same tool is located along the bot-
tom of the screen in the control strip (subsection 16.1.3). The Other… option
at the bottom of the menu makes it possible to insert your own zoom percent-
age, if your preference falls somewhere in between the convenience options we
provide.
When using Page Viewmode, two additional zoom commands will be present

in this menu. Fit Width will adjust the magnification so that the page width
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(including margins) fits the editor width. The Fit Page option sets the magnifi-
cation so that both the short and long edge of the page can be seen within the
editor.

Can’t Find a Zoom Button Below the Text?
Many of Scrivener’s text views are capable of being zoomed, thoughmost
do not have space for a visible button such as the main editor does.
Text in the inspector sidebar, footnotes and comments, Quick Reference
panels and copyholders are all capable of being zoomed. Use the main
View ▸Zoom ▸ submenu, or the supplied keyboard shortcuts to incremen-
tally zoom in ⌘> and out⌘<.

Youmight want to change the default zoom setting if you find yourself always
adjusting it for new projects. Almost every text view capable of being zoomed
will use the Default text zoom setting in the Editing: Options settings pane
(subsection B.3.1).

15.3.2 Contextual Menu for the Text Editor
The text view’s contextual menu contains many standard commands such as
Cut, Copy, Paste, Spelling and so forth, along with a number of commands spe-
cific to Scrivener. If a selection has not already been made, right-clicking will
select whatever word (or words connected by a hyperlink) is under the mouse
pointer.
The Scrivener-specific commands (the appearance of which will depend on

the selection) are listed below:

Text Editing Contextual Menu
Look Up ‘word’ When right-clicking on a word, or a selected phrase, this com-

mand will be made available. It will open the Dictionary and Thesaurus
pop-over that can otherwise be accessed with default system-wide short-
cut, ⌃⌘D when hovering the mouse over a word.

Open “Document name” When right-clicking on selected text that matches in
full or in part one ormore binder item titles, a special “Open” command (or
submenu, if multiple titles match) will appear at the top of the menu. Se-
lect one of these entries to navigate directly to the binder item in the same
editor. Read more about the potential uses for this capability in Linking
Without Linking (section 10.1.1).

Style Offers the same list of paragraph and character styles available from the
Format Bar, or main Format ▸Style ▸ submenu (excluding the management
functions found there). You can also pull up a special single-purposemenu
showing style selections alone, with the⇧⌘Y shortcut.
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Select Annotation/Footnote When right-clicking within an inline annotation
or footnote, this optionwill appear, making it easy to select the entire con-
tiguous range of text that has been marked as notation. When two inline
annotations of different colour fields are located adjacent to one another,
this command will only select up to the edge of the current colour right-
clicked upon.

Split at Selection Splits the current document into two documents at the selec-
tion point (the current blinking cursor point, or the initiating edge of the
selection, which will be on the left by default, or on the right when using
right-to-left languages). Also available as ⌥⌘K.

Split with Selection as Title Splits the current document into two documents
using the selected text as the title for the newly created document. The
selection will remain after splitting, making it easy to remove the redun-
dant title text if necessary, or style it like a header. For more details on
splitting documents, read Splitting andMergingDocuments (section 15.4).
Also available as ⇧⌥⌘K.

Append Selection to Document Provides a menu of all documents in the
binder. Selecting a document from this menu will cause the selected text
in the editor to be appended to the document selected from the menu.
Read Gathering Material (chapter 9) for more tips on moving text around
and organising information in the Binder.

Set Selected Text as Title Sets the title of the current document to the text se-
lected in the editor. Also available as⇧⌥⌘T.

Add Selection to Auto-Complete List Adds the selected text to the project’s
auto-complete list, which can be maintained in the Project ▸Project Set-
tings…Auto-Complete List tab (section C.6).

Text Color Provides the text colour menu, from which you can select from the
built-in colours, or those custom colours you have saved into your colour
palette. Readmore about this and the highlight feature in Text Colour and
Highlights (section 18.5).

Highlight Color Provides the text highlight menu, allowing you to select a
highlight colour for the selected text, or to clear it.

Spelling and Grammar Quick access to spell check tools.

Font Provides basic character attributes, such as bold and italic, as well as access
to the main font chooser.

Speech Quick access to the Edit ▸Speech ▸ submenu functions.
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Writing Tools This submenu contains links to a few handy web searches and
the system dictionary and thesaurus application. The current word, or
selected text, will be sent to the search engine or reference site of your
choice.

It also contains statistics entries at the bottom of the submenu, displaying
the word and character count when an active text selection exists in the
editor. If the footer bar is hidden, or you have statistics removed from it,
this is an alternative way of getting this information.

Hyperlink Selections
When the selection is entirely or partially within a hyperlink (not an internal
document link), then additional link management options will be provided for
at the top of the contextual menu:

Open Link The same action as left-clicking on the link with the mouse. This
method is here primarily for accessibility purposes.

Copy Link Copies the underlying URL of the link, as in many web browsers,
so that it can be pasted bare or used in other contexts such as the cre-
ation of new hyperlinks, or to import the web page into Scrivener using
File ▸ Import ▸Web Page….

Edit Link… With the cursor placed within a hyperlink, use this command to
bring up the URL edit panel, or if the link is an internal document link, a
browser so you can select a new target for the link. Be aware that if you
select only part of a hyperlink before using this command, only the selected
part will change, in effect creating two adjacent hyperlinks.

Remove Link This command will appear when one ore more hyperlinks are
found within the selection. Using it will strip the links, leaving only the
visible text behind. The command is also found in the Editmenu.

Document Link Selections
When right-clicking on document links (links pointing to another binder item
within the same project), a few additional commands will be added to themenu.

Open Document Link In ▸ Offers up to four choices for opening the link: “Cur-
rent Editor” replacing the currently viewed item with the linked resource,
“Other Editor” and “Copyholder” which opens a split/copyholder view as
necessary and loads the target there, and finally “Quick Reference panel”,
as a new window. Some options may be unavailable if they are contex-
tually inappropriate (such as opening in another split from Composition
Mode).
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If you find yourself consistently using this menu to bypass the default be-
haviour of loading links in the other editor, consider changing the de-
fault behaviour for clicked links in the Behaviors: Document Links set-
tings pane (subsection B.4.2), with theOpen clicked document links in…
setting.

Edit Link… With the cursor placed within a hyperlink, use this command to
bring up the URL edit panel, or if the link is an internal document link, a
browser so you can select a new target for the link. Be aware that if you
select only part of a hyperlink before using this command, only the selected
part will change, in effect creating two adjacent hyperlinks.

Remove Link This command will appear when one ore more hyperlinks are
found within the selection. Using it will strip the links, leaving only the
visible text behind. The command is also found in the Editmenu.

Link to Document Creates a hyperlink to another document in the project.
Read more about linking items together in Linking Documents Together
(section 10.1). When right-clicking on an existing document link, the ac-
tion will be to reassign the link to the selected target.

Update Links to Use Target Titles Only appears when one or more document
links are contained anywherewithin the current selection. This command
updates the link text to match the binder titles of the items they respec-
tively link to. Read more about the feature here (section 10.1.2).

Images Contextual Menu
These options appear when right-clicking on an image that has been placed in-
line in the text editor (section 15.6):

Reveal in… Depending on whether the image is linked to a file on the disk or an
item in the binder, this commandwill refer to “Reveal in Finder” or “Reveal
in Binder”.

Open in External Editor Availablewhen the image is linked to either the binder
or the disk, the original image file will be opened using the system’s default
image editor.

After editing an image, the changes will not immediately appear in the
editor (it refreshes cached thumbnail per session). If the size of the image
has changed you should use the “Reload from Original Image” command,
to reset the editor’s sizing information from the image.

Convert to Embedded Image Imports the graphic from either the binder or the
disk and fully embeds the graphic into the editor. Youwill no longer be able
to access it from these external resources, or load it directly into an editor
after doing so.
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Reload fromOriginal Image Reloads a linked image (subsection 15.6.4) from
the original on the disk, or in the binder. This will update the cached
thumbnail being used to present the image in the editor, but more im-
portantly it will also refresh Scrivener’s record of the image’s dimensions
and resolution.

Save As Picture… This command is available if you have right-clicked on an em-
bedded image. You will be provided with a file chooser to specify the loca-
tion and name of the graphic to save to the disk. You can also drag images
into the binder to create them as files in your project.

Scale Image… Available to all types of images. This brings up a tool for resizing
inline images and naming them (subsection 15.6.1), as well as locating their
position in the binder or on the disk, if applicable.

Tables Contextual Menu
When right-clicking within a table in the editor, additional options will be pro-
vided in a “Table” submenu:

Table… Accesses the table palette, which provides formatting, cell dimension,
and nesting, and cell split and merge features.

Add Row Above|Below Will insert a new table rowof empty cells above or below
the row in which you right-clicked.

Add Column Before|After Inserts a new table column of empty cells to the left
or right of the column in which you right-clicked.

Move Row|Column… Moves the current row or column in the describe direc-
tion. The precise direction availablewill alter depending upon the position
of the row or column. For example if it is at the top of the table, you will
only be able to move a row down.

Delete Row|Column Will delete the entire row or column in which the cell you
right-clicked upon is located.

Borders This submenu provides some tools for removing specific cell borders.

Distribute Rows|Columns Evenly Adjusts the height or width of all rows or
columns so that every cell has the same dimensions.

Remove Table Strips the table code out from the currently active table, leaving
all text behind as linearised.
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Lists Contextual Menu
Only one extra option over the base text system has been added for list manage-
ment:

Re-number List In rare cases, especially when pasting lists from other word
processors likeWord, list numbering will sometimes not register properly.
Use this command to attempt to repair these lists.

15.3.3 Moving andCopying Text Around
The simplest answer for copying ormoving text between sections of your binder
will often be the venerable Cut, Copy and Paste commands. However you may
find a few of Scrivener’s additional techniques and optional behaviours to be eas-
ier to use in some contexts:

— Text can be appended to other documents, as discussed in Text Appending
Tools (section 9.5).

— Within an editor context (including across section boundaries in a Scriven-
ings session) you can drag a selection of text to another location to move
it.

— Hold down the Option key when doing so to copy the text to the dropped
location instead.

— Dragging text selections into other contexts that accept dropped text will
also result inmoving the text to the dropped location. This includes drop-
ping text into the binder sidebar, corkboard or outliner to create a new
item with that text.

— You can adjust Scrivener to copy text when dragged in this fashion, by
disabling the Delete text dragged to other areas setting in the Behaviors:
Dragging & Dropping settings pane (subsection B.4.4).

Return to chapter ⤴

15.4 Splitting andMergingDocuments
For some authors, the ability to expand and contract the detailing of yourmaster
outline is important part of using one. To that end there two tools that make it
easy to fashion your outline into as broad or detailed a map as you require, by
systematically breaking down longer chunks of text into amore detailed outline,
or merging them back together in a less detailed outline chunk, as a seamless
block of words.
Before discussing how to split and merge it would be useful to also look at

when not to. Scrivener has two ways of effectively merging text without physi-
cally doing so:
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1. First, for temporarily visualising many smaller pieces of text as though
it were one long single document: select any container in the binder, a
selection of items using ⌘Click, or a group of items that is a product of
a search result or curated collection list and choose to view and use the
View ▸Scriveningsmenu command. You can read more about this capabil-
ity in Editing Multiple Documents with Scrivenings (section 15.5).

2. Second, the compilation (chapter 23) system enables you to publish your
final work as a single document, no matter how many individual pieces
it may be divided into within the Draft folder. Furthermore, the system
of designating chunks in your outline as having a “type” means you can
outline organically rather than structurally. A scene could be broken down
into a dozen small pieces in the outline, without there being any artefacts
of that granularity in what your readers will eventually see on the printed
page (or pixels, as the case may be!).

As a consequence, we more often speak of splitting long documents into
shorter ones, in Scrivener. Splitting almost never comes with drawbacks, and
the benefits of having an articulate and well defined outline are countless. Many
of Scrivener’s tools, such as metadata, links, bookmarks and even project search
and collections will become more powerful the more atomic a chunk of text is.
E.g. if you search for a topical keyword and the result is a 5,500 word essay that
goes over several topics, you’ll have to hunt andpoke through the file to findwhat
youwere really looking for. But if that essay is cut into a dozen smaller chunks of
text, each pertaining specifically to one or two topics, then your project search
efficiency goes through the roof.

15.4.1 Splitting theDocument
The File ▸ Import ▸ Import and Split… command can split incoming documents by
a variety of criteria worth investigating (subsection 9.1.6). For cases where an
automated split is not desired, this section describes a couple of tools that can
be used to quickly split a longer binder item into smaller chunks of text.

SplittingManually
To split a chunk of text in Scrivener into two pieces you will first need to place
the caret at the precise point in the document where you wish the split to occur.
If you select a range of text, the start of the selection will be considered the caret
point, for purposes of splitting. Once the selected location has been chosen you
can use one of two methods to split the document:

— Documents ▸Split ▸atSelection (⌥⌘K): Split the new document off from the
current one, using all text after the current caret position (this can even
split a paragraph in two). In cases where text has been selected, the caret
position will be considered as the start of the selection range. It can be
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useful to think of splitting in terms of “above” and “below” the selection.
Everything above the caret (and also to the left if in the middle of a line)
will remain in the original document, while everything to the right and
below of the caret will be moved to the new document.

— Documents/Split/withSelectionasTitle (⇧⌥⌘K): In all details this command
works identically as the above, but in this case the currently selected text
will be used to title the new document that is created, rather than leaving
the title empty. This alternative method is only available when a range of
text has been selected in the active editor.

This text will remain selected after you split, making it easy to remove it,
or style it as a header.

Youmight also find the ability to search by formatting (section 11.6) to be of use
as well, as often the places you will want to split the document by will coincide
with headers. While the formatting search tool is open, you can use the “Split
with Selection as Title” function without closing it, and then quickly go to the
next search result within the portion that has been split off. Or, if you wish to
use keyboard shortcuts: alternate between using ⇧⌥⌘K to split the found text,
and ⇧⌥⌘G to skip to the next search result (the search tool can be closed).

I did not mean to do that!
It is not possible to undo a split action, but you can use the Docu-
ments ▸Merge command (discussed next) to effectively undo any un-
wanted splits. Snapshots taken of the whole text will remain associated
with the first document split from, and so rolling back to an point before
the split will effectively undo it (subsection 13.6.3), though it will leave the
second split document in the binder.

What Splits Off
Splitting a document is considered to be a text-based operation. The text itself
will be split at the cursor or selection, and the Synopsis and Notes content will
remain in what becomes the first half. Snapshots, also being a component of the
document’s text, will remain.
As for the rest, you can think of splitting as being very similar to duplication.

Document attributes and metadata will all be copied into the second half. This
includes label colour, keywords, custom metadata, compile settings, its book-
marks and even attributes like the icon and writing goals.

15.4.2 MergingDocuments Together
In opposition to splitting, the ability to select two ormore documents andmerge
them together into a single document is done with the Documents ▸Merge com-
mand (⇧⌘M).
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— Merging requires a selection of two or more documents (this can be done
in the corkboard, outliner or binder sidebar).

— Documents donot have to be in consecutive order, they can be picked from
throughout the project. When selecting non-linear items, here are some
tips to determine ordering:

– If the view you are picking documents from is based on the binder
order, then the merged document will retain that order.2

– If using an outliner sorted by a column then the merge order will
conform to the sort order.

– When using a collection to select items, the collection order will be
used to established the structure of the merged document.

When it comes tometadata, mergingwill attempt to retain asmuch individual
itemdata as is possible. The synopses, notes, keywords, bookmarks and the list of
snapshots will be combined into one list.3 Metadata which cannot be combined
(such as titles, section type, labels, any custom metadata, compile option flags,
and so forth) will use the top-most item in the selection for these values.

Figure 15.3 Merging two documents: before (top) and after (bottom).

In Figure 15.3 we have two documents in the top half of the figure, “Document
A” and “Document B”, eachwith their own synopsis, status and keywording. The

2 For this purpose, a selection from a freeform corkboard is still considered to use the binder
order, even though the cards can be scattered all over.
3 Any bookmarks pointing to documentswithin the group beingmergedwill be destroyed as they
will of course no longer have any meaning.
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bottom half of the example shows the resulting singular document created by
combining these two with the Documents ▸Merge command. The synopses have
been merged, as well as the keywords, but the status and title are taken from the
first document in the list.
Main text content will be combined according to the settings in the Gen-

eral: Separators Settings tab, under “Merged documents” (subsection B.2.9)—an
empty line by default.

Return to chapter ⤴

15.5 EditingMultiple Documents with
Scrivenings

The “Scrivenings” view mode allows you to edit multiple text documents as
though theywere one long document. In this way, you canwrite in small chunks
and then combine them in any way you like to see how they work together. A
common usage is to write lots of small subsections within a folder, collectively
representing a chapter; by clicking on the folder they can then be edited all to-
gether in a Scrivenings session to see how the chapter fits together as a whole.
You can also form scrivenings sessions by selecting multiple items from the

binder sidebar.4 This can be a handy way to read segments of text that would
not otherwise appear together, like viewing various scenes from a plot thread
that stretches throughout the novel.

15.5.1 ViewingMultiple Texts asOneDocument
Scrivenings mode is, like its siblings the corkboard and outliner view modes, a
way of working with broader areas of the binder than just one item at a time.
Editing in this fashion can be as simple as clicking on a folder and using one of
the following methods to switch to Scrivenings view:

Figure 15.4 The Scrivenings group view mode button in the toolbar.

— Click the left-most icon in the Group View toolbar button set (Figure 15.4).

— Use the View ▸Scriveningsmenu command or ⌘1 shortcut.

4 Unlike corkboard and outliner, scrivenings can be taken into Composition mode (section 16.1).
Press the Compose button in the toolbar after setting up the session in the editor.

390



15.5. Editing Multiple Documents with Scrivenings

Figure 15.5 Scrivenings mode makes it possible to edit many files together at
once.

Depicted here is a basic Scrivenings session, using descriptive file names in the
header bar:

a) The grey text lets you know what group of things you are editing. In this
case it is a folder of documents named “Editing Multiple Files Together”.
The icon to the left is associated with the group, and as well right-clicking
in the header bar will work upon the group as a whole.

b) The text in black indicates which chunk of text within the session is be-
ing edited; in this case the first document is rather unimaginatively titled,
“First file”; this title can be edited normally (section 8.1.1).

The main editor itself will be divided by dashed lines, indicating where one
chunk of text stops and another begins. The divider itself cannot be moved or
edited directly, though you can cut and paste to move text across them.
Scrivenings sessions are one of the few areas in Scrivener works with a flat-

tened depiction of the outline hierarchy. A prologue at the very top will be
printed right along with items which are buried in subfolders. This is inten-
tional, so you can concentrate solely on the same flow of text that your readers
will be experiencing.

15.5.2 Editingwith Scrivenings
Since Scrivenings is a regular group viewmode, it fits in seamlesslywith the views
more oriented toward organisation and overview. Here are a few examples:

— While editing, new documents can be created using any method you pre-
fer. New itemswill be placedusing the same rules as if the initial document
were selected in the binder (section 6.3.1).

— Likewise you can split a document and see the new divider pop up imme-
diately.

— Moving documents around in the binder or another group view will auto-
matically update the order in which they appear in the session. Opening
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two splits so you can drag cards in one view and read the results in real-
time in the other split is a great way to playwith the narrative order of your
text.

— Trashed documents will be removed from the session.

Can’t edit some selected text?
Some editing commands are prohibited if your selection falls across file
boundaries. For example, you cannot overtype or delete such a selection,
or perform search and replace operations that would fall across them.

15.5.3 Quick Navigation Through Scrivenings
Scrivenings view affords you with some unique tools for jumping around within
large texts. Here are a few ideas for how itsmany tools can be combined to boost
your efficiency while writing in this view:

The outline navigation buttons If you click one of the outline navigation but-
tons (section 8.1.1) in the editor header bar (marked (d) in Figure 8.1), and
that action will result in movement within the boundaries of the active
session, you will be navigated from section to section without disturbing
the session.

If you leave the boundaries of the session, or if the binder sidebar is not
related to the text you are viewing, then you will leave the session.

Jump to Scrivening button You can access a miniature “table of contents” for
the current session with this handy button (section 8.1.1).

Using other group views seamlessly When the above “table of contents” isn’t
enough, don’t forget that the three group view modes are designed to
seamlessly display the same content between each other. If you are edit-
ing a long sequence of text and press the ⌘2 shortcut to switch to Cork-
board view, you’ll find the card representing the section you were editing
selected. If you select another card and jump back into Scrivenings (⌘1),
your session will have jumped to the card you selected.

Combine that concept with filter outliner & corkboard views (section 11.4)
and you can quickly leap through large chunks of text, by a variety of cri-
teria you can define.

Lock in Place navigation With the editor locked (Navigate ▸Editor ▸Lock inPlace,
or ⌥⌘L) clicking on documents that would ordinarily be ignored by the
lockwill instead navigate the session to the selected document, if that doc-
ument is found within it.
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15.5.4 Useful Tips
Statistics count the whole session The footer bar will display statistics for the

entire session, rather than individual sections you are working within. If
you want to get a quick word/character count for the individual section
you are writing in, use the next tip.

Selecting only the section you are editing Use the Edit ▸Select ▸Select Current
Text (⌥⌘A) command to select the text area for only the binder item you
are actively editing within the larger session.

Jumping to the end or beginning of a section In conjunction with the above
tip, a neat trick for jumping to the very beginning or end of the current
chunk of text is to select the section and then use the ← to jump to the
beginning, or the → to jump to the end.

Isolating the current document in the editor Use the Navigate ▸Go To ▸Selec-
tionmenu command (⌘4). Alternatively, us Navigate ▸Open ▸as Quick Ref-
erence, to view the current section in its own window.

Focusing on a smaller section At times youmight find yourself wanting to nar-
rowdown the amount of text you’reworkingwith. Say you’ve got an entire
Part loaded, with 15 chapters, and want to focus solely on chapter 12. Use
the content navigation button (section 8.1.1) to jump to the chapter 12 con-
tainer, then use the above tip to “isolate” it. If this loads one single empty
folder’s text into your editor then press ⌘1 to switch to Scrivenings view
for that container.

Broadening the scope of your session In inverse to the above trick, to expand
your session to show the context of text around it, use Navigate ▸Go
To ▸Enclosing Group (⌃⌘R) to in select the parent of the current session,
while keeping the current chunk of text in view.

Comments and footnotes as bookmarks Linked Notation (section 18.3) will be
displayed together in the inspector in a single large stack, making it easy to
see all notes fromconstituent text throughout the entire session. Selecting
notes in the inspector scrolls your view to that point, making this great for
bookmarking places.

E.g. if youwant tomark your place so you can go investigate other areas of
the text for a bit, put down a linked comment with Insert ▸Comment (⇧⌘*)
and click on it later to jump right back to where you were.

Vertically accurate scrivenings dividers If for reasons of taste, or formatting
necessity, you require a zero-height scrivenings divider, you can make use
of the “Corners” separator in the Formatting Setting tab (subsectionB.5.13).
This setting will have separation drawn as “crop marks” in the margins in-
stead of using a divider across the middle.
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15.5.5 Scrivenings Settings
As a mode intended to augment creative writing, there are many settings and
adjustments that can be made to this view mode:

— Add the binder names of items as titles to the text, with the View ▸Text
Editing ▸ShowTitles in Scriveningsmenu toggle.5

— The Appearance: Scrivenings settings pane (subsection B.5.13) has settings
for adjusting the font, size, alignment and whether titles have a shaded
highlight.

— By default, titles will decrease their font size depending upon how nested
the item is in the binder.

— By default the text content of the group itself will occupy the first chunk
at the top of the session. If you tend not to write into folders themselves,
you can switch this behaviour off.

— You can also change the style of divider used between sections, and
whether they will be used in addition to titles.

Return to chapter ⤴

15.6 Workingwith Images
While images themselves cannot be placed into the Draft folder as binder items,
there are several methods for placing them into your text, all involving inserting
the image into the text editor itself, like you would in a word processor:

— Dragging an image file in from the Finder.

— Dragging an image document in from the binder, outliner or corkboard.

— By using the Insert ▸ Image FromFile…menu command (or one of its sibling
commands, discussed in the following pages).

In all cases:

— Images will be placed at the current cursor position or drop location.

— Images placed into documents in this fashionwill create a new copy of that
image, even if it was dragged in from the binder.

This becomes important when working with placeholder images. If you
intend to later edit your images or replace themwith updated copies from

5 If you have a strong preference as to how future projects should have this aspect set up, consider
saving your settings into a project template (subsection 5.4.3).
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a graphic designer, you may wish to instead use Linked Images (subsec-
tion 15.6.4).

Viewing inline images full-size

To view an image in the editor on its own, you can drag the image from
the text into the header view of one of the editors. You can then double-
click on the image and zoom in or out on the image. Note that any
changes made here will not impact the original image in the text.

15.6.1 Resizing Inline Images andNaming Them
To resize the inline image, double-click on it. Use the controls to shrink the im-
age or increase its size, and then click on OK. Unchecking “Lock aspect ratio”
allows you to adjust the width and height independently and therefore distort
the image. Clicking Cancel restores the image to its former size and returns you
to the editor. Note that some images types (notably, vector PDF) cannot be re-
sized.
It is important to note that for images that will be compiled, resizing images

in the editor is an output, rather than an aesthetic, decision. When an image is
resized in the editor it will be directed to use that size in the final output as well.
If you find the graphics you are using are too large, and are getting in the way of
writing, you may consider using placeholder thumbnails instead. Using linked
images is ideal for working this way, as you can swap out the full-size images on
the disk prior to compiling.
For embedded graphics you will also note a Name field in the image editing

panel. For most ways of working this name will do very little, but if you use
a markup format like ePub, HTML or Markdown then the name of the image
can be important if you intend to work with the compiled output using other
programs—particularly if you’ve pastedmost of your graphics in and do notwish
to have to contend with hundreds of generically named files.

Embedded Images and Scrivener for iOS

If you intend to use the iOS version of Scrivener to edit your project, then
it will be best practice tomake use of one of the image linking techniques
described in the following sections. The text editing engine provided
by iOS is incapable of working with high-res graphics (greater than 72
DPI), andwill drop the resolution of themwhen editing text that contains
such images. Be aware that “resizing” images in Scrivener by definition
changes its DPI, and thus can result in the image size being reset back to
72 DPI when syncing back to your computer.
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15.6.2 Saving an ImageOut of the Editor
To save the image to the disk, right-click on the image and select “Save as Pic-
ture…” from the contextualmenu. This optionwill not be available with a linked
image, which naturally is already on the disk—instead a command to “Reveal in
Finder” will be provided.
You can also simply drag and drop an image from the editor into the binder to

create a copy of it in your project.

15.6.3 Embedding Inline PDFs
It is possible to drag PDF files into your editor to embed them. This feature is
meant to allow the usage of graphics saved in the PDF format. It will not allow
multi-page documents to be inserted into the final manuscript, and if the orig-
inal PDF is pre-formatted for print, you will very likely need to crop the result
down significantly so that it can fit within the page margins, using a PDF editor
such as Preview, or Acrobat Pro.
When compiling or exporting to formats that do not support embedded PDFs

(only a few of the text-based technical markup formats support native PDF), a
raster graphic will be automatically generated for you and embedded as a PNG
file, if the compile format allows embedded graphics. This will cause a loss of
vector data, and so the conversion uses a large PNG that is then shrunk down to
scale for high quality. You can adjust the DPI used for this in the Sharing: Export
settings pane (subsection B.8.2).

15.6.4 Linked Images
If you are familiar with desktop publishing tools like Adobe InDesign, then the
manner in which linked images work will be familiar to you. For those not
aware, linked images are the placement of graphics in your text in such a way
that the thumbnail in your editor is being generated by files outside of the docu-
ment, as opposed to being saved into the text of the file itself. This tactic keeps
the storage expensive image files outside of the text itself, keeping your project
text lightweight.
To create a linked image, use the Insert ▸ ImageLinked toFile…menu command.

Linked images will look and act like embedded images in every way. You can by
and large ignore the difference between them while working.
When compiling with linked images, the current version of those images on

disk will be used to create the embedded copies used in the compiled version.
Since nearly all of the compilation formats do not support active image linking,
Scrivener must take the current version and embed it in the final copy. So if you
are in a workflow that involves external help from designers, be sure to get your
external images up to date before producing final compiled copies.
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Resizing Linked Images
Just aswith embedded graphics, you can adjust the display size of the image (sub-
section 15.6.1). It is important to know that doing sowill alter the original image’s
metadata on the disk. The image will not have its pixels touched, but its print
size information will be altered. If it is important to you that Scrivener not ad-
just the original files then do not use the resize tool in the editor, or consider
using image placeholder tags (subsection 15.6.5), where sizes can be specified as
compile-time directives on the output images rather than the originals.
Linked images also have a few extra features in the image editing panel. The

full path to the image on the diskwill be printed for your reference. This text can
be copied and pasted as needed. For a friendly way to get to the image, click the
Reveal in Finder button. If you need to change the source file for whatever reason,
use the Change… button to select a new graphic.

Updating the Image from theDisk
Scrivener generates a thumbnail of your image when you first view it (or initially
link to it) in the editor, but for performance reasons it will not update it during
the session. Whenever you re-open the project, this thumbnail will be updated
from the disk.
To have an individual thumbnail updated immediately, right-click on the im-

age and select the “Reload from Original Image” menu command.
This will also reset Scrivener’s record of how large the image is and its pixel

resolution. So while reloading the image might be an aesthetic option if only
the pixels of it have changed on the disk, if the size has changed on the disk, it
can be important to reload it using this command, as Scrivener may otherwise
squash or display the image incorrectly when compiling.

Renaming an image on the disk
You can of course freely rename images whenever and however you like, but you
will find that upon reloading the project at a future point, the links will have
broken. A technique for safely renaming an image name while preserving the
link is to do so from within Scrivener:

1. Double-click the linked image to edit it.

2. Click the Change… button to bring up the file dialogue.

3. Right-click on the name of the image in the file browser and select the
“Rename” option.

4. Once you’ve renamed the file on the disk, click theOpen button to confirm
reassigning the link to the same file by its new name.
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Links onMultiple Devices
If you intend to use multiple devices, it is not uncommon for links to be tem-
porarily broken while away from your main computer. It is safe to work around
broken links; once you return to the machine that has those images in the de-
scribed locations, they will link back up.
You can also choose to store your images in a subfolder located by the project

itself. For example if you have a project on your Desktop, you could create a
folder called “Blog Images” and store your linked images in there. If Scrivener
cannot locate linked images upon loading the project, it will cast about looking
for them in the current location. In a way, they will work like relative links do.

Fixing Broken Links
Dynamically finding lost images is a process that must be very strict, so as to not
accidentally link to the wrong images, it will only work in straightforward cases.
Fortunately image links can be easily repaired by hand. A broken image will fall-
back to a warning message with a special token identifying it as an image link
and the expected path to the image:

MISSING_IMAGE:/path/to/image.png

The simplicity of this systemmeans that if youfix thepath to the image right in
the text editor and then reload the project it will link back up. This also means
that large-scale changes to paths can be made using the Edit ▸Find ▸Project Re-
place… tool.6

Images Linked to Binder Items
You may at times wish to use linked images to keep your text files trim rather
than bloated with large files—but at the same time not have any need for the
advantages using the file system gives you, and would prefer not to have to deal
with the disadvantages, such as fixing broken links or having to contend with
issues between synced systems across multiple platforms.
Linking to images in your binder is the solution to this problem. The graphic

is not placed into your text directly, just as with a file link, while the graphic
image itself will be managed by the project for you, available on every platform
you take the project to.
To link to a graphic in the binder:

6 When using Project Replace to fixmany broken links at once, you should rebuild your project’s
search index, by holding down the Option key on the File menu and selecting the File ▸Save and
RebuildSearch Indexesmenucommand. Thiswill remove any lingeringmissing imageplaceholder
references from the search index.
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1. Import the graphic into the binder if necessary. The name you give the file
in the binder will be used when compiling it, for those formats where it
matters.

2. From the text editor, use the Insert ▸ Image Linked to Document ▸ submenu
to select the graphic. Only graphics and PDFs will be listed in this menu.

3. Alternatively, if you intend to predominately link to images in the binder, it
will be far easier to visit the Behaviors: Dragging &Dropping settings pane
(subsection B.4.4) and setting the Link to images dragged from binder
into editor option. You may also want to visit the Behaviors: Document
Links pane and enable the Image links create back-link bookmarks op-
tion. With that enabled, you can click on the image in the binder and view
its bookmark list to see precisely where it is used within your draft folder.

When images have been edited out of the binder, you can have Scrivener
reload the changes by right-clicking on the image and selecting the “Reload from
Original Image” contextual menu command.

15.6.5 Image Placeholder Tags
Images can be referred to using plain-text placeholders (in a similar vein to how
HTML orMarkdownwould refer to an image), to address various cases where this
approach would be beneficial:

— Allows you to use graphics in the compile settings, in areas that otherwise
wouldn’t support them—on account of their being defined by plain-text
fields—such as custom separators, title prefix and suffix fields.

— Textual links to images afford you additional powers over typical images
displayed in the editor. Since they are text based, they can be easily modi-
fied by compile-time Replacements. A few examples:

– Different file types, such as ePub and RTF, could have the path to the
image altered, pulling high-resolution graphics for one format and
lower resolution, highly compressed images for the ebook.

– Image placeholders might be entirely removed, or removed based on
some criteria.

– As image placeholders can set the resolution of the image, this can
also be modified by replacements if different compile targets have
different paper sizes.

The basic syntax for the image tag is:

<$img:IMAGE_NAME;w=WIDTH;h=HEIGHT;ebook=WIDTH>

Everything after the image name is optional.
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Image Identification
The image must be specified either by its imported name, as displayed in the
binder, or by a valid system path to the image’s location on your computer. Path
names can be relative to the location of the Scrivener project, so if the graphics
and the project are stored in the same folder, you would only need to declare the
path as ‘image_name.png’ for it to work. You can also use the UNIX shortcut for
your home folder, the tilde. Full absolute paths are acceptable as well.

<$img:~/Dropbox/MyBookFolder/scene_break.png>

This also demonstrates a safe way to link to an image that will work from
multiple computers all using this Dropbox account, since the details of the user
folder name are represented by the tilde.
The following example references a graphic that has been stored in a subfolder

called Resources, which is a folder alongside the Scrivener project:

<$img:Resources/python_chart.jpg>

Here is an absolute link to an external hard drive called “Research”, where an
image in the subfolder “MyThesis” is referenced. As with all embedded PDFs, you
should ensure it is only one page in length and smaller than the text print block
(sans margins):

<$img:/Volumes/Research/MyThesis/some_data.pdf>

When using graphics that you have imported into the project binder, you can
refer to them by their binder title (you needn’t know the extension or type of
graphic it is). This will be used in precedence over any path names, and the first
matching title name (counting from the top of the binder) will be preferred over
any other images likewise named in the project. A simple example, specifying an
image that is called “Python Growth Rates in Everglades”:

<$img:Python Growth Rates in Everglades>

Specifying ImageWidth andHeight
The width and height of the image are optional values, declared in points. If
you have already sized the graphics correctly in accordance with your printer’s
specifications and output quality, then you will not need (or indeed want) to
change the image size using Scrivener. However if you are not concerned with
pre-sizing the images and just want to let Scrivener handle them for you, you can
specify the width and height of the image in the placeholder tag, to instruct the
compiler to resize it as necessary.
It is valid to give only the height or the width alone. The compiler will pre-

serve the original aspect ratio of the image, adjusting the othermeasurement for
you. If you declare both the width and height yourself, it is possible to squish or
squash the image however you please.
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<$img:Portrait of Dickens.jpg;w=468>

This will resize the portrait so that it is 468 points wide7, adjusting the height
of the image so that it remains proportional with the original in terms of aspect
ratio; no squished faces here!
For ebooks you can optionally declare an image to be set to a percentage of the

screen’s display, rather than a fixed size. This will be done by using a secondary
setting, which will override the fixed width setting if also given. The following
examplewill display the image at 468ptswide inmost compile formats, butwhen
compiling to ebooks, will instruct the image to be displayed at 50%of the reader’s
screen size (or the software’s reader window, et cetera):

<$img:Portait of Dickens.jpg;w=468;ebook=50%>

Tips for Usage
Here are some ideas for how this feature can be used, as well as some handy tips
for common uses.

— Using Replacements to Change Images: use of replacements in the compiler
(subsection 23.4.4) will be evaluated prior to any images being included.
That means you could use the feature to scan for the placeholder tag and
remove it from the document, or perhaps change the path of the image
to something else, which could be useful if you have two different groups
of images, one optimised for black & white printing, and the other for an
online full colour PDF or lower resolution ebook.

— Searching for images: since the image is defined as text, that means you can
search for it by name, or even search for all “<$img...” tags in the draft
to get a list of documents with figures, which could be saved as a search
collection (subsection 10.2.4).

— Using images as a compile-time prefix or suffix: when compiling, it is possible
to use an image in the prefix or suffix areas of the section layout compile
option pane (section 24.2) or in separators (section 24.4), to use graphics
between scenes, or below chapter headings.

— Specifying an image when two or more share the same name: in cases where
you havemultiple images with the same name in the Binder, if you need to
ensure that a certain one of these (rather than the first one in the list from
top-down) is used, select the image placeholder and create a document
link (subsection 10.1.1) from it pointing to the correct image.

7 As the width of a point is 1/72 of an inch, that will be 6.5 ′′, or just wide enough to extend to the
margins in a US Letter page with 1 ′′ margins all around.
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15.6.6 Images forOutput
Handling Print-Ready Images
In the case of print-ready images the text editor will display a rough approxima-
tion of the image’s final size, rather than its actual pixel size, when the DPI and
physical measurements are set to an appropriate value for printing. For instance
a 300 DPI image that is meant to be 2.5” wide on the printed page will appear
approximately 2.5” wide on your monitor, and so it will not dominate the editor.
Scrivener uses the publishing standard of points as a unit of measurement,

rather than pixels or other ruler-based measurements. Adjusting the scale of an
image in the text editor does not impact its literal pixels, but rather the point
value which will be used to determine how large it displays. Points are a fixed
unit of measurement (there are 72 of them per inch). If you are using a typical
US Letter with 1in margin document then the widest you would want an image
to be is 468 points. For A4 with 25mm margins you wouldn’t want an image
wider than 453.6 points.
If you’ve been provided full size, print-ready graphics for publication, it is of-

ten best to not embed them directly into your text. Embedding images in the
document is good for small placeholders, but since the images are saved into the
RTF file itself, adding very large high resolution graphics to your files may slow
down Scrivener’s ability to load and save your file while you work on it, and may
even cause instability when it comes time to combine everything together into
one large document. Do also consider common professional production tac-
tics of using linked images or placeholder tags instead of fully embedding large
graphics into your source files.

ReducingQuality for Proofing
If for some reason you cannot make use of the image linking capabilities to han-
dle multiple sets of graphics, you will most likely find that high-resolution print-
ready graphics make for a PDF file that is too large to comfortably send out to
proofers. The compiler can be set to crudely compress and downsize graphics
on the fly, leaving the originals unharmed, producing a smaller document. Refer
to the special PDF print options, in the General Options compile overview tab
(section 23.4.3).

Images andCompiling toMarkup
When using Web Page (HTML), or any of the MultiMarkdown and Pandoc com-
pile formats, images will be converted into appropriate syntax in the text and ex-
ported into the compile folder alongwith the text file itself. For formats that end
up combining the source files into a bundled format like WebArchive or DOCX
(via Pandoc), these intermediate files will be handled in temporary folders and
won’t appear in your output folder.

Return to chapter ⤴
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15.7 Formatting Tools
15.7.1 The Ruler
The text editor in Scrivener uses a traditional ruler, along the top of the text edi-
tor, for setting indents and tab stops. It can be shownor hidden via theView ▸Text
Editing ▸Show|Hide Ruler command (⌘R). The ruler provides a simple indenting
and tab stop interface (Figure 15.6).

Figure 15.6 Example ruler and paragraph indent settings.

— If you would prefer more precision with these settings, use the For-
mat ▸Paragraph ▸Tabs and Indents…menu command (section 15.7.1).

— Additionally there are menu commands for adjusting the various indent
settings dynamically, which can be bound to keyboard shortcuts if you
change them often. They are found in the Format ▸Paragraph ▸ Increase/
Decrease Indents ▸ submenu.

— For those with a Touch Bar equipped Mac, you can also add most of these
indent commands to your keyboard.

— Ruler settings are adjusted per-paragraph. To adjust the ruler settings for
many paragraphs at once, you will need to select them prior to using the
ruler.

— To apply ruler settings from one portion of text to another, it is possible
to copy paragraph settings by using Format ▸Paragraph ▸Copy ParagraphAt-
tributes and Format ▸Paragraph ▸Paste Paragraph Attributes.

Tab Stops
Tabs allow you to enter tabular information into a single line, without using ta-
bles, and as well to format some kinds of information horizontally along the
page. If you are looking for a way to indent your paragraphs, skip to the next
section—one should never use tabs to indent paragraphs.
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Left-aligned stops can be created by double-clicking anywhere in the ruler,
and additional types can be accessed by right-clicking in the ruler and selecting
one from themenu. Once placed, they can bemoved via click-and-drag, and the
numerical value of its position will be printed above the mouse pointer as you
drag. Tab stops will be depicted by type using icons. The four tab types available
are:

1. Left: This is the standard type. Textwill be left-aligned, with the first char-
acter indented to the position of the tab stop.

2. Center: Text will be centre-aligned, using the position of the tab stop as an
anchor point; this can be anywhere on the line and is thus distinguished
from centre-alignment, which uses the width of the indented line to cal-
culate the middle.

3. Right: Will right-align text with the right-indent set to the point of the tab
stop.

4. Decimal: Most often used for aligning rows of numbers, so that the system
decimal character is lined up vertically with integers before the decimal
being right-aligned, and any fractional values left-aligned.

To remove a tab stop, simply click and drag it down or up out of the ruler until
the icon disappears.

Left indents are not tab stops

Unlike some word processors, Scrivener will not treat the left block in-
dent as an implicit tab top, for the purposes of formatting the first line of
text. You will need to set a manual tab stop that matches the indent, for
the purposes of achieving designs that use a hanging indent combined
with a block left description.

Using tab stops while writing is as simple as pressing the Tab key to advance
to the next available stop. If there are no more tab stops available on that line,
the system will wrap around to the next line at the first tab stop, but no newline
will be added. To remove a tab from the line, simply delete it as you would any
other character. Tabs can be viewed as symbols with the View ▸TextEditing ▸Show
Invisiblesmenu command.

Indents
There are three indenting controls, not to be confused with margin controls
(which Scrivener’s ruler does not address). Indenting is the action of offsetting
text a defined distance from the margin. A left indent pushes the text bound-
ary toward the right, away from the left margin. A right indent pushes the text
boundary toward the left, away from the right margin.
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In addition to the two primary indent markers is the first-line indent marker.
This will only indent the first line of a paragraph. Using this control, it is possible
to set the first line to indent by half an inch, while the rest of the paragraph is set
to zero (or directly adjacent to the margin).

Hanging Indents These are produced using the same tools as ordinary first-line
indents, only to produce a hanging indent, you will need to inverse which
marker comes first. If the first-line indent marker is to the left of the left-
indent marker, then the body of the paragraph will be pushing inward,
while leaving the first line “hanging” over the blank space below it.

Right Indents These are rarely used, and theywill often restrict flexibility down
the road. Depending on your ultimate page size, it can be difficult to cal-
culate where they should be set to. For instance, if you prefer to proof with
a more generous page margin of 1.75” but need a 1” margin for submission,
an appropriate distance of right-indentation away from the left margin
would differ. However there are cases where it is necessary, of course, and
in such cases you will need to restrict yourself to using a more limited set
of paper and margin sizes.

Alternatively, if the width of the right indent is less important than there
simply being one, compiled styles can be set to Match right indent to
left in the compile Styles option pane (subsection 24.5.3), causing an equal
amount of indent to be used on both sides, nomatter howwide or narrow
the text block itself.

Sometimes, when importing material from word processors you may get
text which is already indented artificially, causing the text to be narrower
than it should be. You can either pull the right indent marker all the way
to the right to disable it altogether, or use the Documents ▸Convert ▸Text
to Default Formattingmenu command to clean up large amounts of text at
once.
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Ruler Conversions
When working with units in Scrivener, bear in mind that its ruler starts
at margin zero instead of paper zero. Since Scrivener is, by and large, not
“aware” of paper or margin settings in its editor, it considers “0” to be
where the text starts. This is in contrast to many word processors, which
start measuring at the paper’s left edge, and show the print margin as
blank space in the display of the page, with the ruler starting somewhere
along the lines of 25mm or 1′′.
Consequently, to calculate a right indent, which is measured from the

left side to useful values here, you will need to factor in the standard
amount of print margin into the numbers you see on the ruler. For ex-
ample, if you are using 1′′ margins and you need a right-indent that is 1”
deeper still offset from the right margin, the right-indent should be set
at 4.5′′ for US Letter, not the standard 5.5′′.

The Tabs and Indents Tool

Figure 15.7 The “Tabs and Indents” tool allows for precision adjustments.

If you find working with the ruler tool difficult in terms of getting precise
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placement, or areworkingwith closely spacedmarkers andhaving troubles click-
ing on the right one, the Format ▸Paragraph ▸Tabs and Indents… utility provides a
placewhere you can insertmeasurements directly and even create stock tab stops
on an interval.
All measurements aremade from the left edge of the ruler as shown in the edi-

tor. So if you call up this panel using Page Viewmode (section 16.2), the numbers
may be different than called up in standard fixed-width or wrap to editor mode
(the latter two do not add margins to the ruler).

Paragraph indents The first three settings adjust the amount of first-line in-
dent, left block indent and right (or trailing) indent. Use a smaller value
for “First line” than “Left” to achieve a hanging indent appearance.

Default tab spacing This setting makes it easy to insert tabs across a fixed mea-
surement, without having to key them all inmanually or having them clut-
ter up the tab stop list or ruler, below. To reiterate, this will not insert
markers that you can see, it will merely impact how far the cursor will
jump when pressing Tab on a line, so long as there is no manually placed
tab stop nearer to the cursor position than the next default tab stop.

Set this option to “0” to disable it and have tabs only placed with the man-
ually created stops you define.

Tab stops This section lists all tab stops in the current paragraph by their mea-
surement. Clicking on a stop in the list will display its Alignment setting
to the right. Double-click to changewhere the stop should be placed along
the ruler.

To create a new tab stop:

1. Click the + button below the list and type in the placement, as measured
from the left edge of the ruler.

2. Select an alignment option from the radio controls on the right (“Left” is
the default).

To delete selected tab stops, click the − button. Click the OK button to apply
all ruler adjustments to the current paragraph (or selection).

15.7.2 The Format Bar
The Format Bar provides quick access to common formatting features. Its visi-
bility is toggled with View ▸Text Editing ▸Show Format Bar (⇧⌘R).8

8 If you are looking for tab and margin controls, the Ruler is available per text editor with
View ▸Text Editing ▸ShowRuler.
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Designed to collapse when the editor width is too narrow for the full bar, the
first segments will become clickable icons that open up menus or palettes pro-
viding the same level of functionality (Figure 17.4).

Figure 15.8 Format Bar: displayed in sections

The first section (Figure 15.8) of controls handle font face, size, and variant. All
of these tools act immediately on the currently selected text. If no selection is
given, then they will alter how you type from the current caret position onward.

a) Styles: use this button to apply styles to selected text or the cursor. Also
displays the current style in use. For more information, refer to Styles and
Stylesheets (chapter 17).

b) The next set of buttons are for working with fonts manually, selecting the
font family, variant and size, in that order. Lastly are convenience but-
tons for selecting bold, italic variants, and underscoring text. All of these
functions are also available from the Font Panel (subsection 15.7.4).

c) Paragraph alignment can be set here. Choose from left, centre, right and
justified.

d) The text and highlight colours are selected from these two buttons, re-
spectively. They have two different modes of operation. Click with the
left mouse button to apply the active colour (as shown) to the text. Use
right-click to select a different colour, or to choose the “remove colour”
swatch (shown as a white box with a red slash through it). Refer to Text
Colour and Highlights (section 18.5) for more information.

e) The final section sets paragraph & line spacing, and lists. The spacing
dropdown provides some quick presets for line height multiples, but for
more complex settings, as well as paragraph spacing (above or below), se-
lect the “Other…” item at the bottom of this menu. Likewise lists can be
customised by selecting “Other…” from its respective menu.

15.7.3 Hyperlinks
Scrivener has broad support for creating hyperlinks in the text, either to other
areas within the project itself, or between projects (section 10.1), and of course
as external links to other software, files and websites. This section will concern
itself with the latter form of linking.
If you paste aURL into the text editor, inmost cases the editorwill recognise it

as aURL and automatically create a clickable link for you. If youwould prefer full
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control over when links are created, disable this behaviour with the Automati-
cally detectweb addresses setting in theCorrections settings pane (sectionB.6).9

Adding LinksManually
You can attach a link to any form of visible text or image in any area of Scrivener
that takes rich text formatting:

1. Select the text you wish to link from, in the editor, or place the cursor
where you would like the visible URL to be inserted.

2. Use the Edit ▸Add Link…menu command (⌘K).

3. Select the type of link to create (if you have the full URL ready to paste, use
theNo Prefix option).

4. Type or paste the URL into the text field and click OK.

If a valid URL is found on the clipboard, it will be automatically pasted into
the field for you, and if relevant, the prefix setting will be selected.

Editing Links
To edit an existing link, including those detected automatically by the software:

1. Place the cursor anywhere within the range of a link, or select it com-
pletely.10

2. Use the Edit ▸Edit Link…menu command (⌘K), or right-click and select the
command from the contextual menu.

3. Modify the link settings and click OK.

Removing Links
To get rid of a link, or maybemany links at once (perhaps to clean out links from
a web page pasted into the editor or imported as text):

1. Select the text from which you want to remove links, or right-click on the
link you want to remove.

2. Use the Edit ▸Remove Link menu command, or select the same command
from the contextual menu.

9 Despite the label of the setting suggesting otherwise, a wide variety of links conforming to the
URI specifications, including file links, FTP, email and so forth will be recognised.
10 If you select a portion of the link, only that portion will be changed.
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Links Aren’t Fully Removed?

Somebrowsers and text editorswill not only link text, but add formatting
to the text that looks like a link aswell. If you strip out the link youwill be
left with formatting that looks like a link—bright blue and underlined for
example—but in fact that’s all it is: bright blue text with underlining. If
when you click on the text nothing happens, it has successfully unlinked
and you’ll want to clean up the formatting as well.

15.7.4 Font Panel
The font palette is a standard tool provided by macOS, and can be toggled with
Format ▸Font ▸ShowFonts (⌘T). This palette provides full access to the font type-
setting engine, including many OpenType features and custom font effects. For
basic font changes, the Format Bar (subsection 15.7.2) will suffice.
The precise appearance of the palette will change depending how large you

make it. As the size of the palette increases, more options will be made avail-
able to you. Since this palette is provided by Apple, please refer to the help files
provided by TextEdit, for details in using it.
To use the font palette to change the appearance of your text, you will need to

first select the text youwish to change, and thenuse the palette. Any changes you
make will be immediately reflected in the editor. You can change your selection
while leaving the palette open to work with one bit of text after another.

Managing Font Sizes in the List
If you would like to add or remove font sizes from the format bar, you would do
so to the entire macOS via the system palette:

Figure 15.9 Adding “16pt” as a new font size to the system.

1. Bring up the Format ▸Font ▸Show Fonts panel (⌘T).

2. Click the button and select “Edit Sizes…”
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3. Type in a new font size in points in theNew Size field, and click the+.

4. When finished, click Done.

You should now see 16pt (or whatever changes you made) in Scrivener’s font
size dropdown in the format bar.

15.7.5 Resetting Formatting
After you’ve gatheredmaterial from theWeb, or imported documents that you’ve
written in another word processor, the formatting of the imported material will
not match the default font in Scrivener for new documents—or maybe you just
do not like our defaults and want to update your text. While you can change this
default at any time with Editing: Formatting Settings tab (subsection B.3.2), this
will not impact the text of items you’ve already created, what you paste or files
you import.
The first approach is to be “preemptive”, and do just that: tell Scrivener what

you want. If you know for a fact you have no need at all for the formatting you
are pasting in, you can use the special Edit ▸Paste andMatch Style command to do
so (⇧⌥⌘V). This will treat the text as though it were plain-text, and as such it will
take on all of the characteristics of the text around the cursor positionwhere it is
pasted. This necessarily means losing all inline formatting and function, such as
hyperlinks and italics. If you intend to keep this level of formatting, the following
approach will suit you better.
The Documents ▸Convert ▸Text to Default Formatting…menu command is pro-

vided as a way of retrofitting existing text to your current defaults. Since this
command works at the document level, you can select as many cards, outliner
rows, or binder sidebar items as you please and convert them all in one go.
After clicking the menu command, a window will pop up asking how much

formatting you wish to apply to the selected document(s). Most of these options
work in a negative fashion. By example: if you select “Preserve alignment” and
the document is left-aligned, even if your preferences are for full justification, it
will not be applied because you have elected to preserve the original alignment.
The only exceptions are the Convert font only and Remove all styles options.
Once you’ve used this window to set up how deeply this commandwill impact

a document, you canwaive it in the future by holding down theOption key when
selecting themenu item. Be wary of destructive settings, such as those that strip
out all styles, when using this bypass.
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Double-check your settings and back up!

Please note that because this command impacts broad changes in po-
tentially many dozens or more of documents at once, there is no undo.
The procedure only impacts formatting, but if you are unsure of whether
or not the result will be favourable, either snapshot the documents first
(section 15.8), or perform the conversion one-by-one and proof the re-
sults. Once you are confident you have the right settings engaged, you
can proceed at a more rapid pace.

Ranges of text that have been blocked out with Preserve Formatting (subsec-
tion 15.7.6) will never be altered by this tool, much in the sameway that the com-
piler will leave them alone.

15.7.6 Preserve Formatting
If you are planning on letting Scrivener’s compiler do all or most of the final
formatting for you, it can sometimes be useful to protect arbitrary ranges of text
from the conversion engine. In most cases it will be easier and better to use
styles for this purpose, which have the inherent capability of preserving their
formatting (chapter 17), but there are a few niche and legacy cases where this
tool is used to achieve some effect.
To specify a range of text for preservation, select the text in the editor, and

then invoke the Format ▸Preserve Formatting menu command. This will draw a
blue dashed box around the text, which can be worked around and within like
any other type of formatting range, such as italics. The range can be removed by
selecting the preserved text and using the command a second time.
Of its special-purpose uses:

— In Markdown-based formats, when rich text to MultiMarkdown conver-
sion is enabled, “preserve formatting” can be used to pass through raw
Markdown syntax. Styles (which have an optional “raw markup” setting)
are the preferred tool for this job, though this approach does have some
appeal to those using iOS, which has a similar bypass option for Preserve
Formatting.

— In scriptwriting, preserve formatting is used to indicate Dual Dialogue
(subsection 19.1.4).

Return to chapter ⤴

15.8 Using Snapshots
The theory behind the Snapshot is very simple, and similar in principle to how
you might use the “save as” feature in a traditional text editing program.
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As with many modern programs, Scrivener saves automatically as you work,
whenever you pause for a couple of seconds. In comparison to the oldermethod,
where one loads a file and saves periodically, you lose the benefit of being able
to work “off the disk” for a while, choosing when to save and when to revert to
what has been saved.
Snapshots help you bridge the gap between these two different ways of work-

ing. Taking a snapshot is like saving your document, the only difference is, you
get a record of each save point in a tidy list, stored in the document’s inspector
pane (rather than littering your Documents folder with “Save As” copies, for ex-
ample!).
Taking a “snapshot” of a document copies the text of it at that exact moment

in time and stores it so that you can return to it, or restore it, at a later date.
With habitual usage, you need never need worry about making major edits to
a document, because you can take a snapshot of it before you begin editing and
then restore the older version later if you change your mind about the edits you
have made.

What About Milestones
In addition to periodically saving the evolution of a chunk of text, some
people like to use snapshots to set important editing “milestones” they
might one day wish to return to. Scrivener accommodates both styles
of working. You can take “Untitled” Snapshots with a single keystroke, or
give themamemorable title to refer to later onwith a different command.

Figure 15.10 Three different document types displaying “dog-ears”.

You can tell if a text document has any associated snapshots by its icon. Doc-
uments that have had snapshots taken of them have the top-right of the paper
icon folded down in a “dog-ear” (Figure 15.10). You can also tell by looking for
a dot beside the camera icon along the top of the inspector pane if it is open
(Figure 15.11).

Figure 15.11 The dot in the upper-right corner of the snapshot icon indicates
this document has snapshots.

The key thing to understand about snapshots is that they provide a way to
set save points for individual text items in the binder.11 They are not a tool for

11 Snapshots only store themain text content (not notes, synopses ormetadata), and are therefore
only available for documents that contain text.
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providing an overall snapshot of the entire project, structurally speaking, and
are probably not the best tool for taking a quick snapshot of your entire draft. In
most cases, large scale backups like thiswould be best created using the File ▸Back
Up ▸Back Up To… menu item, or by duplicating large portions of the Binder and
stashing them elsewhere for future reference.

How to snapshot an entire folder

Selections are explicit, but you can easily select a folder and all of its
subdocuments with a single command, Edit ▸Select ▸Select with Subdoc-
uments (⌥⌘A), from an outliner or binder view, and then take the snap-
shots.

15.8.1 Creating Snapshots
There are a few different methods for taking snapshots:

1. Select the documents you wish to snapshot in the binder sidebar, cork-
board, or outliner. If you are editing the item in the editor, a Copyholder,
Composition mode or a Quick Reference panel, then that is all you need
to do; it is implicitly selected.

2. Use one of the following commands from the Documents ▸Snapshots ▸
submenu:

— Take Snapshots of SelectedDocuments (⌘5)

— Take Titled Snapshots of Selected Documents (⌃⌘5): to supply them
with a title as they are created. The title you provide will be added
to each document in the selection. Snapshots can also be titled at a
later time using the inspector.

The third method for creating snapshots is from the Snapshot pane itself in
the Inspector. Click the+ button in the header area of this pane to create a new
snapshot.

Saying More About a Snapshot

If the title field isn’t enough, a trick for more thoroughly commenting on
the purpose or state of a snapshot is to combine it with the use of inline
annotations. Consider writing a short synopsis of what the snapshot was
taken for into the top of the document before taking a snapshot, and then
remove it afterward. Now that statementwill always be clearly presented
to you at the top of the snapshot text preview.
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15.8.2 Managing Individual Snapshots
Existing snapshots are all managed in the inspector pane on a per document
basis. To jump to snapshots, click the button with the camera in the inspector
tab list or use theNavigate ▸ Inspect ▸Snapshotsmenu command. More details on
the functions available in the inspector can be found in the documentation on
the Snapshots Tab (section 13.6).

15.8.3 Viewing Snapshots in the Editor
It is possible to load snapshots as read-only text into themain editor splits. There
are a few ways of doing so:

— Drag the snapshot you wish to view into the header bar for the editor split
or copyholder you wish to load it in.

— Right-click on the header bar icon menu for the item whose snapshot you
wish to view, and use one of the “View Snapshot in Other Editor” or “View
Snapshot onCopyholder” commands. The submenus for thesewill display
a list of available snapshots to load.

When you’re done, use the history feature to return the editor or copyholder
to what you were looking at before. Snapshots themselves do not occupy a slot
in history, so you will be unable to return to them (save for to load it once again)
once you leave. Consider Locking the Editor (subsection 12.2.1) if you are inad-
vertently losing your snapshot view.

15.8.4 Comparing Changes in the Editors
The comparison feature lets you analyse the differences between versions of your
text. There are several places that allow for comparison. Chief among them is
within the inspector’s Snapshots Tab itself (subsection 13.6.4), wheremost of this
capability and adjustments to its behaviour will be documented.
As noted previously, you can load snapshots straight into one of the split ed-

itors, or one of their copyholders. It is also possible to use these locations for
comparison, meaning you aren’t stuck to reviewing changes in a narrow sidebar.
There are a few ways of doing so:

— When dragging and dropping the snapshot into a header bar, hold down
the Option key.

— Right-click on the snapshot in the inspector list to load it on the copy-
holder for that editor, using the “ViewChanges onCopyholder” command.

— When using either “View Snapshot in Other Editor” or “View Snapshot in
Copyholder” from the header bar contextual menu, hold down the Option
key when selecting the menu command to enable change tracking in the
selected view.
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When viewing comparisons in the editor it is only possible to show markings
between the selected snapshot with the current text, not another snapshot.

15.8.5 The SnapshotsManager
While being able to click on any chunk of text in the binder to examine its history
is undeniably useful, a tool that can examine snapshots themselves, across all files
within the project, can greatly enhance your overall sense of how the text as a
larger whole has evolved, and can make pruning old and unwanted snapshots a
snap.

Figure 15.12 The Snapshots Manager makes it easy to browse versions across
documents.

To bring up the manager, use the Documents ▸Snapshots ▸Snapshots Manager
menu command. In projects with a large quantity of snapshots, it make take a
few seconds to load them all up.12

The window is divided into two panes. The sidebar on the left contains an al-
phabetically sorted list of every document in the binder that has a snapshot, and
then grouped within each, a list of all respective snapshots in reverse chronolog-
ical order.
In the provided example (Figure 15.12), we can see a document called “Cooking

withBasmati Rice”, whichhas three snapshots taken: “Roughdraft”, “Notes from

12 You can leave the window open in the background, but in order to save resources and battery
time it won‘t be kept up to date. Thus it will need to rescan the project if snapshots have changed,
whenever bringing the manager to the forefront. If for some reason it doesn’t seem to have
updated itself correctly, click the “Refresh” button, located in the lower right–hand corner of the
sidebar footer.
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editor” and “Revised”. We’ve clicked on “Notes from editor” and can see that it
is being displayed on the right-hand side. Only one snapshot can be displayed in
this area at a time.

Renaming Snapshots
You can easily rename snapshots right in the Snapshot Manager. Double-click
on the name of the snapshot, or press Esc to toggle editing mode. When you
have finished editing the name, click elsewhere to confirm or press Return.

Comparing and Rolling Back Changes
All of the capabilities available to you in the Snapshots tab of the inspector are in
the manager as well, along the footer area of the snapshot content viewer itself.
For documentation on how to use these specific features and settings, refer to
the following:

— Rolling the Text Back (subsection 13.6.3): for setting the selected snapshot
to be the text used for the main item in the binder.

— Comparing Changes with Main Text (subsection 13.6.4): for comparing
two snapshots together, or one snapshot with the current state of the text
in the binder.

Searching for Snapshots
Above the snapshot list sidebar is a search tool that you can use to quickly locate
snapshots by their snapshot name, the name of the binder item they are asso-
ciated with or even by fragments of text within the snapshot itself. The search
tool is fairly simple, and has a few rules and capabilities to be aware of:

— The basic mode of this form of search will always be “exact phrase”, mean-
ing the text you type in must be found in the order you type it in, case-
insensitive.

— You do not need to specify which type of content you want to search
through. All matches will be returned, wherever they are found as text.

— You can search using dates to isolate snapshots by a particular day, month
or year, or even by all dates before or after a certain time. The date search
syntax is almost identical to the one used in the main project search tool
(section 11.1.3), whose search codes are detailed in Table 11.1. The only dif-
ference is that since snapshots cannot bemodified, there is no need to stip-
ulate the ‘cdate:’ prefix. You can type the date search syntax in directly.

— If nothing is found using the text you have typed in, Scrivener will attempt
to use the regular expression syntax to parse your term. Since regular ex-
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pressions are very unlikely to be found as text you’ve written, this should
always be a safe assumption.

FindingWhere Snapshots Came From
If you locate a snapshot you are interested in, but aren’t sure where its parent
item came from in the binder:

1. Select either the snapshot in question or its associated parent in the side-
bar.

2. Right-click, or use the button in the sidebar footer.

3. Select the “Reveal in Binder” option, or use the standard shortcut.

The result of this behaviour is identical to how “Reveal in Binder” works in
general, though leaving the project window in the background—meaning if it is
not presently visible the command may not appear to have done anything until
you switch back to the project window.

Exporting Snapshots to Files
To save your snapshots as individual files to the disk:

1. Select all of the snapshots you wish to export using the sidebar.

2. Click the button in the sidebar footer.

3. Select the “Export Snapshots…” command.

4. If more than one snapshot has been chosen, youwill be asked for the name
of the folder you would like to insert them within, and the location for
where that folder should be saved.

Otherwise, you will be asked to name the snapshot itself that you selected.

5. Choose a file type at the bottom of the file dialogue that best represents
or preserves the content of the snapshot. You can select from RTF (best
for most purposes), DOCX if you use software that can only read .docx files
(slower), TXT for maximum compatibility but no formatting, and finally
.fdx for scriptwriting files.

Deleting Snapshots with theManager
In addition to deleting individual snapshots (which you can also do right in the
inspector), one very useful capability of the snapshot manager is to purge many
snapshots from across multiple documents at once. This becomes particularly
powerful when combined with searching—for example locating and deleting all
snapshots from a year ago or earlier.
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1. To selectmultiple snapshots, you canuse the traditionalCmd andShiftkeys
to add or remove from the selection individually or by range, respectively.
The Edit ▸Select All (⌘A) command is also available for selecting the entire
visible list. It is okay for your selection to include document groupings in
addition to snapshots—they will be ignored by any commands you use.

2. Use one of the following methods to request the deletion of the selected
snapshots:

— Click the − button in the sidebar footer to delete the selected snap-
shots.

— Right-click on the selection or use the button to use the “Delete”
command.

— Use the ⌘Delete keyboard shortcut.

3. As there is no way to undo the deletion of snapshots, you will be asked to
confirm your request.

You are encouraged to back up your project (which will of course include
all current snapshots) prior to making sweeping deletions. The File ▸Back
Up ▸Back Up To… command makes a good choice for this. You can also of
course export your snapshots to files, using the aforementioned instruc-
tions, prior to deleting them from the project.

15.8.6 Automatically Created Snapshots
There are a few conditions, mostly optional, where snapshots can be automati-
cally created for you. These snapshots will name themselves logically, to indicate
why theywere created. This kind of consistent naming scheme alsomakes it eas-
ier to clean them up later, using the snapshots manager.

— Synchronisation: Synchronised folders (section 14.3) are set by default to
take snapshots of any documents that are changed (either on the disk or
in Scrivener). When this sort of action is taken, the snapshot will be titled
appropriately with a descriptive parenthetical regarding why the snapshot
was taken.

Syncing with iOS will not take snapshots by default, but they can be op-
tionally enabled with Take snapshots before updating documents in the
Sharing: Sync Setting tab (subsection B.8.3).

— Automatic Snapshots on Manual Save: the Take snapshots of changed text
documents on manual save setting, in the General: Saving Setting tab
(subsection B.2.2) will create a snapshot of each item altered during the
current session, whenever forcing a save with File ▸Save (⌘S).

Return to chapter ⤴
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Just as you might have a favourite place to write, the digital environment we
write within can be equally impactful. Scrivener provides a few major editor
modes that can substantially alter the writing experience, up to and including
the removal of all visible interface.

16.1 CompositionMode
Made popular by a plethora of “zenware” applications, the ability to remove all
visible computing interface and work solely with your words brings back the era
of the pen and typewriter. You can view any text document (or Scrivenings ses-
sion) in composition mode, with a virtual page treatment on an opaque back-
ground that blocks out the rest of your computer.
Unlike most zenware, Scrivener’s composition mode is of course built within

its powerful organisation system, and does not restrict you from tapping into
that as you wish. Although you can keep things dirt simple, if that is what you
are looking for, you will also enjoy full access to your document’s metadata in a
low-impact Inspector panel, as well as keeping research close at hand with float-
ingQuick Reference panels (section 12.6.4) and quick navigation to any text doc-
ument in the project.

16.1.1 Entering CompositionMode
To determine what will be loaded into composition mode, Scrivener uses the
active selection. This selection can be made either in the binder sidebar, in an



16.1. Composition Mode

Figure 16.1 Eschew interface! Even the control strip shown along the bottom
here is optional.

outliner or corkboard view and of course from the main editor. This works by
implication as well: when no cards are selected in a corkboard, technically the
container is selected, as can be witnessed in the inspector, and so it is the con-
tainer’s text itself thatwill be loaded in composition, whichmight often be blank.

Figure 16.2 Toolbar button for entering composition mode.

Launch composition mode by clicking the toolbar button (Figure 16.2), using
the View ▸Enter CompositionModemenu command, or the ⌥⌘F keyboard short-
cut.
When you first enter composition mode, you will see your document in the

middle of the screen with nothing else around it. You will also briefly see the
Control Strip (as shown in Figure 16.1). To retrieve it after it has disappeared,
slide the mouse pointer down to the bottom of the screen and let it sit for a mo-
ment. So long as the mouse remains within the control strip, it will stay visible
even while typing.
The menu bar can be accessed by similarly sliding the mouse pointer to the

top of the screen. After a momentary pause, the menu will appear. This is a use-
ful way to access advanced formatting tools, open windows with Navigate ▸Open
Quick Reference ▸ and so forth.
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16.1.2 LoadingMultiple Documents
Just as with in the main text editor, navigation within composition mode is re-
membered, and you will be able to flip between documents using the history
shortcuts (⌘[ and⌘]). It is also possible to initiate a new session with multiple
documents in one of two ways:

1. View as Scrivenings: If you are viewing a group of documents in Scrivenings
mode, then compositionmodewill use that samemode. This is the easiest
way to load an entire container’s text into compositionmode, as it requires
no further selection.

2. Pre-load documents into history: If multiple items are selected and Scriven-
ingsmode is not enabled in the active editor, then each itemwill be loaded
into the composition mode’s history queue.

16.1.3 TheControl Strip
The control strip is a slide-away panel along the bottom of the screen that ap-
pears when you move the mouse pointer into it (leave the mouse at the bottom
to keep it open while you write). It contains various controls for changing visual
settings, and providing navigation & reference tools without having to leave the
comfort of composition mode.1

The controls, in order from left to right:

Text scale This operates in an identical fashion to the text scale zoom in the
standard editor. The only difference is that composition mode stores its
own scale setting, independent of the editor splits.

Paper Position Use the slider to adjust where the column of text should be hor-
izontally placed on the screen.

Paper Width Use this slider to change the width of the text, with the widest
setting filling the entire screen.2

Paper Height To access this optional slider, hold down theOption key. This set-
ting can shorten the paper height down to one line, so if you want to only
focus on a few lines at a time, this is a good way to do it.

Inspector Brings up the floating Inspector panel (subsection 16.1.4). As with in
themain project window, you can use the⌥⌘ I keyboard shortcut to toggle
its visibility.

1 All of these settings operate on a project–by–project basis, though you can choose to save most
of the appearance adjustments you make as your defaults for new projects, in the Appearance:
Composition Mode: Options tab (section B.5.3).
2Margin settings (fromAppearance: CompositionMode: Options Setting tab) offsetting the text
column from the edge of the paper will still apply (section B.5.3).
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Go To Operates as a handy navigation tool, and functions similarly to the main
Navigate ▸Go To ▸ submenu. The main difference between the two is that
whenusing Scriveningsmode towork on several sections at once, this but-
ton will switch to showing only the items within the current session.

Once you have navigated to other sections, you can use the standard his-
tory shortcuts (⌘[ and⌘]) to navigate to and from documents you’ve vis-
itedwhile in compositionmode. Composition history is separate from the
main editor history—it will not add to it, and when you first start compo-
sition mode, history will be empty (unless you select several documents
before entering it).

Focus Provides access to settings for controlling focus mode. From here you
can set the scope of how much content should be focused, or switch the
feature off entirely for the current view. Refer to FocusMode (section 16.4)
for more information on how this feature works.

Typewriter Scrolling Toggles a feature that keeps the currently edited line of
text at a set position on the screen, much like typing on a physical type-
writer. This setting is specific to each split editor, as well as to composition
mode (the latter has the feature enabled by default).

Keywords Brings up the project keywords panel (section 10.4.5) (the standard
⇧⌘K shortcut also works). This can be used in conjunction with the float-
ing inspector to assign keywords to the current document.

Statistics & Scripting Controls Themiddle portion of the control strip changes
depending upon your editing mode. In standard editing mode, this will
display the word and character count for the document. As with the stan-
dard editor, this will also display the counts for any selected text, using a
blue label.

In scripting mode, this area will display Return/Tab hints as well as the el-
ement selection menu (you can also use the standard keyboard shortcut,
⇧⌘Y, as well).

Background Fade Adjusts the opacity of the background area beyond the “pa-
per” column. Useful if you want to refer to material in other applications
(or the main project window) in the background whilst remaining in com-
position mode.

Paper Fade When a backdrop image is in use, the “Background Fade” slider will
be replaced by this one. Adjust this to blend the paper colour with the
backdrop, or reduce its visibility entirely.

When both a background texture or backdrop and a paper texture are in
use, this slider will be entirely removed.
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Exit Composition Mode The button along the right edge will exit composition
mode. Youmay also press the Esc key, or⌥⌘F to return to themain project
window.

16.1.4 Floating Inspector Panel
The composition mode version of the inspector gives you near full access to in-
spector data. Use the top dropdown menu to access the different data panes.
Label and Status will always be visible at the bottom of this window. For a full
discussion on these views and what they represent, read Organising with Meta-
data (section 10.4), and the Inspector (chapter 13).
The top selection dropdown will provide you with the following options:

— Synopsis & Notes

— Picture: If a photograph has been attached to the index card, you can view
it with this option.

— Keywords

— Bookmarks: both this and the following feature a compact editor view so
you can not only browse bookmarks but access and edit their content di-
rectly, just like in the main inspector.

— Project Bookmarks

— CustomMetadata

— Comments & Footnotes

Eachof the individual paneswill be providedwith a full complement of editing
controls, so you can add and remove items from these lists, just as you would
with the standard inspector.

16.1.5 WorkingwithMultiple Displays
When using multiple monitors, you can configure Scrivener to target specific
displays with the composition view instead of the primary display. This can be
adjusted with theOpen compositionmode on… setting in the Behaviors: Com-
position Mode settings pane (subsection B.4.1).
If you don’t mind taking a performance hit, you can choose to leave the main

Scrivener interface visible on another display. Disable the Hide main window
in composition mode setting to keep it from disappearing.

16.1.6 Customising Appearance
There are a greatmany colour settings available for adjusting compositionmode.
You will find them all located in the Appearance: Composition Mode settings
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pane (subsection B.5.3).

— The default solid background colour can be replacedwith an image of your
choosing, using the Composition Mode Backdrop setting in the Project
Settings: Background Images tab (section C.8).

— Alternatively, textures can be assigned to the backgrounds, with theEditor
and Screen Background colour settings in the Appearance: Composition
Mode: Colors tab (section B.5.3).

— The colour of the Text can be overridden, making it possible to achieve
such effects as a nostalgic monochromatic green text monitor. There are
multiple methods of how natural text colour (such as highlights and re-
vision markings) should be handled when overriding text. Although dis-
cussed in relation to Dark Mode, How Colour Works in the Editors (sub-
section 4.3.1) goes over the colour filtering options that apply to composi-
tion mode as well.

Return to chapter ⤴

16.2 Page View
By selecting View ▸Text Editing ▸Show Page View while editing a text document,
you can transform the visual presentation of the editor to using a virtual page,
which can optionally show two opposing pages at once, with View ▸Text Edit-
ing ▸Two Pages Across. Since Scrivener does not keep track of actual post-print
layout pages, this should not be relied upon as a full-spread layout preview, as
the even/odd arrangement you see in the editor might very well end up being
swapped in the final product.
For most uses, page view is for simulating the look and feel of writing on real

pages, and is thus an aesthetic preference, not a print preview tool. In some cases,
especially where the compiled product will look identical to the formatting you
see in the editor, it can be used as a fairly accurate gauge of writing progress in
terms of literal pages. Read on for tips on the best ways to set up this feature for
this style of working.
Editing features in page view are identical to using the standard drafting style

editor with two exceptions: typewriter scrolling (section 16.3) and line number-
ing will be unavailable in page view mode.

16.2.1 Page ViewDimensions
Page View will by default place your text in a to-scale representation of your
project’s print and margin settings, found in the File ▸Page Setup… dialogue—
which is incidentally what most applicable compile formats will defer to.
It is possible for compile settings to override page setup (for example, the built-

in preset designed to emulate a standard paperback novel), so if youwould prefer
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Figure 16.3 Page View provides a simple text-on-paper look for those that pre-
fer the aesthetic.

page view always use your compile settings, use the Base page view size on…
setting, in the Appearance: Page View: Options Setting tab (subsection B.5.10).
In the case where your compile type doesn’t use paper, like web pages, ebooks

and theMarkdown-based choices, the last used relevant compile settings will be
used, and failing that, your page setup settings.

16.2.2 Tips for Accuracy
When used in conjunction with precise export fonts, formatting and accurate
page dimensions, the resulting page estimate (which will be calculated in the
footer bar statistics area) can be quite close to the actual end product, and thus
will be of considerable use to anyone who requires pages as a metric, such as
scriptwriters. Do note however that page numbering will always be relative to
the section of text you are viewing. It is not intended to be a method of finding
“page 83” from a stack of printed out papers by your desk. It would be compu-
tationally prohibitive to provide this information in real-time, based on the fact
that Scrivener is fundamentally not a “What You See is What You Get” editor,
like a word processor.
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For best results:

— To increase page count accuracy in a scrivenings session, you should use
the “Corners” setting for the Scrivenings Separator option in the Appear-
ance: Scrivenings: Options tab. This alternate method for showing the
boundaries of documents in scrivenings mode uses no height, and so will
not vertically distort the size of the session.

— The use of the titling feature in scrivenings (View ▸Text Editing ▸ShowTitles
in Scrivenings) should be disabled as titles will add extra overall height to
the editor that most certainly will not be in the final composite.

— The compiler must be used at a basic as-is level and avoiding content that
does not require any compile-time or post-compile layout, such as foot-
notes, columns, excessive use of placeholders, the insertion or removal of
text, such as chapter headings and section headers, etc.

— Finally, you should ensure that your File/Page Setup… settings match your
compile settings, so that what you see in the editor matches the shape of
the document that will eventually be compiled.

Return to chapter ⤴

16.3 Typewriter Scrolling
You can turn “typewriter scrolling” on for the main editors, Quick Reference
panes, and for the composition mode editor independently via the View ▸Text
Editing ▸Typewriter Scrollingmenu command (⌃⌘T).3 When enabled, the line you
are typing on in the editor will advance only down to the middle of the screen
(by default), where it will remain in a fixed position thereafter, rather than ad-
vancing all the way to the bottom of the screen, where your eyes will then be
inevitably glued for the remainder of the writing session.
If you move your cursor out of the current line by using the mouse, or more

than one line away from where you were by using the keyboard, then the fixed
scroll position will switch to using that point on the screen instead of the de-
fault. This way, if you switch to editing text the screen won’t jump around in a
distracting fashion.
If you wish to at any point bring the editing line back to the default spot on

the screen, simply hit the Edit ▸Find ▸Jump to Selection shortcut key,⌘J.
The Typewriter Scrolling feature is not available in Page View, given how this

feature lays out the pages in a simulacrum of the printed page, which will of
course not contain any of the dummy lines added to keep the entry position in
the middle of the screen.

3 Typewriter scrolling was originally an innovation of The Soulmen’s Ulysses.
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16.3.1 Typewriter Scrolling Settings
There are a couple of settings that adjust how typewriter scrolling works, both
found in the Editing: Options Setting tab (subsection B.3.1):

— It is possible to adjust vertical position of the typing line if you’d rather
something other than the middle. Use the Typewriter scroll line option
to select from quarters, thirds or the middle.

This will also adjust the scroll point used by the Edit ▸Find ▸Jump to Selec-
tionmenu command (⌘J).

— If you would rather typewriter scrolling rigidly adhere to the scroll line
rather than adaptingwhatever line you position the cursor on, then enable
the Typewriter scrolling always jumps to scroll line setting.

Return to chapter ⤴

16.4 FocusMode

Figure 16.4 Focus Mode can help you zero in on the present text alone.

Sometimes you may want to focus on only the words that are nearby where
you are writing or editing, fading the rest of the text to a level that makes it
difficult, but not impossible, to read. “Focus Mode” makes it possible to do just
that, in nearly any editing context provided by Scrivener.4 To get started:

4 Focus mode was originally an innovation of iA Writer.
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1. Place your cursor into the editor you wish to enable Focus on.

2. Use the View ▸Text Editing ▸Focus ▸ submenu to select one of the following
focus models:

— None: focus will be disabled.

— Line: only the current line will remain fully visible.

— Sentence: the current sentence will remain visible.

— Paragraph: the current paragraph will remain visible.

3. Focus mode can also be added as a button to the main application toolbar,
with View ▸Customize Toolbar… (Figure 16.5).

4. In Composition Mode, a focus mode icon will be present in the Control
Strip (subsection 16.1.3).

Figure 16.5 Focus mode is available as an optional main toolbar button.

Focus mode will temporarily disable itself when you use the mouse or key-
board to scroll (without moving the cursor) to another point in the editor. In
this way you can easily reference the full text or find another spot to narrow in
on and edit. Focus will return as soon as you click to move the cursor to a new
point, or if you type or move the cursor using the keyboard.
Focus mode can be enabled in any of the main text editing views, with the

following behavioural notes:

— All focus settings are project specific.

— The main editors in the project window, their copyholders and Composi-
tion Mode will remember the setting you apply to them persistently and
specifically. E.g. the left editor is focused to paragraph, the right editor to
line, and will go on doing so until you turn them both off yourself.

— Focus settings for Quick Reference panels must be set per binder item, and
will be persistently remembered for that item, even through a restart.

Return to chapter ⤴
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You might say it was only a matter of time before you found Scrivener and
styles sittin’ in a tree together. Scrivener has always been about separating the
way we write from how text is formatted when we print. Much of the design
is premised on the notion that a creative writing space shouldn’t be difficult to
modify or forced to look a certain way because of howwe need things to look for
our editors, publication guidelines and so on. Stylesheets are a way of making
that nebulous goal a little more detailed and practical.

Upgrading from Scrivener 2

In the past, Scrivener used a simpler system referred to as “formatting
presets”. These simply rubber-stamped text with a predetermined look,
and that was that. Consequently there was one preset list shared by all
projects. The first difference you’ll need to be aware is that styles are per
project (and thus can travel to iOS or be used in project templates). For-
matting presets will not be updated to styles, given fundamental differ-
ences between them. If you have presets you would like to use as styles,
refer to Converting Formatting Presets to Styles (subsection F.3.1) in the
What’s New appendix.



If you have used stylesheets in a word processor before, then you could prob-
ably skip to the following section, Think Different (section 17.1), as we will first
briefly cover what they mean in terms of text editing. If you haven’t, you can
think of styles as being a slightly more complicated way of formatting text. Why
would you want something slightly more complicated? Well in this case, it is a
matter of a little extra effort up front quite possibly going a long way in saving
you a lot of manual labour down the way.
Perhaps you’ve come across a situation in the past where you’ve been asked to

change the indent level for every block quote in your book, or something along
those lines. Without styles, you might get lucky if a tool likeWord’s “Select Sim-
ilar Style” manages to catch a good majority of the texts that need to be fixed,
but even so you’re still faced with a lot of proofing and fixing.
Styles have a very simple concept behind them. Instead of saying “this is a

thing because it looks like that thing”, it is saying, “this is a thing and thus it
should look this way”. The crucial distinction between these two slightly dif-
ferent statements is that when a bit of text is tagged as being a thing, such as a
block quote, if we later change what block quotes look like, all we have to change
is the latter part of that clause: “…thus it should look this way”. In a system us-
ing stylesheets, your block quotes look the way they do because of the stylesheet,
and thus changing the stylesheet changes the way they all look, at once.
In Scrivener we can take this concept a little further than most programs can:

the way you compile (exporting or printing, if you haven’t gone that far yet in
your use of the software) your work can differ from the stylesheets you use in
your editor.

Figure 17.1 Styles can be kept distinct and easy to read in the editor (left), and
exported to a variety of possible formats and uses (right).

Our system was designed expressly to fit within the overriding theory that
your creative writing environment should be a comfortable place to work rather
than looking theway other people (ormaybe even yourself) want it to look in the
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final copies. With styles, you can use whatever suits you for particular texts and
then have the compiler convert those to more conventional formatting in the
end. E.g. one style to express three different versions of a text to: (a) standard
submission format, (b) formatted traditionally to ebook for proofing or (c) as a
custom technical format for publication (Figure 17.1).

Do you write using a plain-text format rather thanWYSIWYG?

If your preferred or intendedmode of writing is with a plain-textmarkup
system such as Markdown, LaTeX, HTML or DocBook you might reflex-
ively dismiss styles as an aspect of Scrivener you have no use for. How-
ever, styles in Scrivener were designed in part to be an integral tool in
workflows such as these—demonstrated in the previous figure, where
styled text becomes functional XML on output. For a summary of how
you can think about using styles in your project, refer to Styles for Au-
thors Using Markup (subsection 17.4.3).

17.1 Think Different
If you are familiar with styles in other word processors, you may have a few
habits to unlearn. If you’re new, you should read this anyway because you’ll
want to know how this system was designed to be used, even if this is all new
to you. Scrivener’s styles have a very similar concept to what you’ll find every-
where else—you tag some text with a named format like “emphasis”, later decide
emphasis should be green, and all the emphasised text turns green—but one very
crucial difference between our system and the rest is that Scrivener does not re-
quire you to pervasively tag every shred of text in your document; what is com-
monly known as “body” or “normal” styling.
We have always had a very basic concept of stylesheets in the software:

— Stuff inserted by the compiler could have a unified look to it since you only
set it up in one place—a chapter title for example, contained a numbering
schema, font and spacing settings.

— The text you write into the editor is considered working copy, meant to be
transformed by the compiler into the final output. You could say it always
had an implied “Body” or “Default” style applied to it—and going forward
that is precisely how you should continue thinking of it.

You might be wondering why? What’s the deal with flagging some text as
“Body” and making it easy to keep the format up to date? Mainly, Scrivener al-
ready does this and has for years. It has ample tools for keeping body text in
parity with your defaults (subsection 15.7.5). In fact the way that tool now works
is to convert all un-styled text to default formatting. So if you used “Body” ev-
erywhere the command would no longer work as expected.
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Similarly, the compiler still goes on treating unstyled text for conversion if
applicable. A submission manuscript format might use 12pt Times New Roman
on all unstyled text, but if you have a “Body” style applied to everything using
your favourite 16pt sans writing font—guess what, the compiler is going to defer
to your demands and you’ll never see Times New Roman.
So that is the first principle to understand: with Scrivener, styles are for excep-

tional cases in which we definitely want the text to look a certain way. In most
cases you should see scattered uses of it in your work, rather than hundreds of
contiguous words assigned to one style after another. If you’re a style purist and
coming at this from a semantic text standpoint, think of it this way: all text in
Scrivener is inherently styled as “default” until we declare it as different. Given
all text can bemodified dynamicallywith settings (compile or in the editing area),
it already meets the definition of being semantically normal.
Of course you can work in a way more familiar to word processing—just bear

in mind that much of what Scrivener does out of the box will be hampered by
what it sees as explicit demands to format the text a certain way.

Return to chapter ⤴

17.2 The Basics of Styles
Each new project you create will have its own stylesheet set up for it. If you are
starting fromone of our built-in templates or the “Blank” starter, this willmean a
stock set of basic styles intended to get you startedwith the concept (Figure 17.3).
You might want to use your growing collection of styles in future projects.

That’s no problem either, this is what project templates (subsection 5.4.3) are
good at conveying setup details such as this into new projects you create, but
you can also import styles directly between projects or establish your stylesheet
as the global default for all new projects (at least those that do not come from
templates that come with their own). We’ll get into the details of these things in
this section—for now it is merely good enough to know that while each project
has its own stylesheet, it won’t be locked away or difficult to use in other works.

17.2.1 Paragraph andCharacter Styles
As in many programs with stylesheets, there are two fundamentally different
types of style available, one of which that can have attributes of both:

— Paragraph styles: chiefly concerned with the overall shape and size of a
paragraph, as it sits on a page. The first-line indent, block indent, right
indent, tab stops, alignment, leading, spacing before and after, line-height
and even HTML header levels are all governed here.

When applied to text, they alter the selected paragraphs but do not change
any of the character level attributes such as bold or italics. If no selection
exists, only the current paragraph will be altered.
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Figure 17.2 The two style types and their combinations, as they would appear
in the Format Bar.

Paragraph styles are indicated with a pilcrow symbol, marked (a) in Fig-
ure 17.2.

— Character Styles: without any regard for the presentation of text across
multiple lines, character styles are all about letter variants (like italics),
weight (bold vs light vs regular), typography, kerning, and adornments
such as strike-through and underlining and baselines.

When applied to selected text, it will have all aspects of its formatting al-
tered to match the style, removing any existing character formatting such
as bold and italics. When applied without a selection the effect will be to
change how text is typed from that point.

Character styles are indicated with an underlined ‘a’ character, marked (c)
in the figure, as “Emphasis”.

— Paragraph & characters styles: these represent a blend of the two concepts.
A paragraph style can also define character styles as part of its definition,
but we lump them all together as paragraph styles because of how they
are applied. A paragraph style of this kind applies all stored character at-
tributes to all text in the paragraph. A character style might only apply
bold and bright red colouring to a couple of words in a line, but with a
paragraph style makes the whole line bright red and bold. If that’s what
your headings are supposed to look like, then that is what you want.

When applied to selected paragraphs, all formatting will be modified by
the stored settings in the style, unless ranges of text within the paragraph
have character styles already applied to them.

Paragraph + character styles are indicated with both symbols combined,
marked (b) in the figure. “Code block” not only block indents the text
but sets the character style to a smaller monospace font more suitable for
printing source code

The last demonstration of what you will see in Scrivener, marked (a+c), is not
strictly speaking a fourth type of style, but rather what will happen if you apply a
character style to text within a paragraph that has a paragraph style applied to it.
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In this example we are working within an attribution line and have switched on
emphasis as well—likely to enter the name of some published work or job title.
With combined styles like this it is good to know where one ends and the

other begins. Paragraph styles will always work “underneath” character styles.
In the previous example, if I changed the attribution style so that it also applied
the character formatting attribute of dark red text, the text marked as “Empha-
sis” wouldn’t be touched by that change. It has its own character style (black
text) that supersedes whatever paragraph formatting happens beneath it. If I
were to at that point select the range of text marked “Emphasis” and use the
Format ▸Styles ▸NoStyle command, it would become dark red like the rest of the
line, along with losing any other characteristics that made it special.

17.2.2 What About Fonts?
With the exception of the code blockmention above, youmay have noticed that I
haven’t used theword font yet, whichmight seemapeculiar omission in a section
about styles. Fact is, in Scrivener, fonts (and font size for that matter) can be
treated as separate from styles. Most of our built-in styles in fact do not mess
with fonts at all, leaving that part of the equation up to you. They might change
the size of the text, or howmuch space falls around it, but the font family will be
left alone.
It is also possible to have a style change the font as well. After all there is the

aforementioned code block (and code span for thatmatter). Whether you choose
to change the font or font size in your own styles is up to you—but know that if
you want to keep your styles flexible, you can leave that information out of the
definition. A heading style without font information may be equally applicable
to both sans serif and serif style documents.

17.2.3 The Styles Panel
The styles panel (Figure 17.3) is a convenient floating tool that can be used to
apply styles to your text as you write (as well as serving as a shortcut cheatsheet
for those styles you’ve added shortcuts to), inform you ofwhich styles are applied
to the text you are working on andmanage the styles as you go. Open this panel
using the Format ▸Styles ▸ShowStyles Panel (⌃S).

1. In the upper portion of the pane are “Paragraph Styles”, showing both
paragraph and paragraph+character styles. Character styles are listed be-
low. These are used on selected ranges of text, within or spanning through
paragraphs.

— Click on a style to assign it to the selected text in the active editor or
Quick Reference panel.

— Right-click on a style to open its contextual menu:
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Figure 17.3 The stock starting kit provided to you in every new project—
including those upgraded from older projects.

– “Select All Text with Paragraph|Character Style”: selects all non-
contiguous text within the active editor that is assigned to the
selected style.

– Refer to Deleting a Style (subsection 17.3.4) and Redefining a
Style (subsection 17.3.3).

– “Change Keyboard Shortcut”: reassigns the styles shortcut with-
out having to go through the “redefine” panel.

2. The first button in the lower left is a + button, used to create a new style
of any type from the current cursor position or selected text. This button
will be disabled (as shown) if there is no valid text currently active. Refer
to Creating New Styles (subsection 17.3.2) for further information.

3. The button gathers a few useful commands together from themain ap-
plication menu, as well as providing some functions that are also available
by right-clicking on the styles themselves.

— The first three commands relating to selection are documented in
Selecting and Searching for Styles (subsection 17.4.1).
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— The next two pairs of commands will become operational only when
the selection encompasses or begins within a paragraph or character
style, respectively. Refer to Redefining a Style (subsection 17.3.3) and
Deleting a Style (subsection 17.3.4).

— Lastly, you can “Import…” a stylesheet from another Scrivener
project, merging it with the current one. Refer to Copying Style-
sheets Between Projects (section 17.5).

4. Continuing to the right on the same row you will find two buttons: ⮃ and
⮁. Use these to jump to the previous or next instance of the style that is
currently highlighted in the panel. They will prefer character styles over
paragraph styles, so if you intend towalk through paragraph stylematches,
you will need to move the cursor out of text with a character style applied
to it, first.

When no style is highlighted in the list, the action will be to jump from
one contiguous range of unstyled paragraph text to the next. Character
style ranges will be ignored (and thus selected) in this scenario.

5. Lastly we have the Remove Style button. Use this to strip the styles from
the selected text. Refer to Removing Styles from Text (subsection 17.3.5)
for further information.

All projects share the same panel, meaning that if you are working in two dif-
ferent projects, you can keep this panel in one spot and as you switch between
them, it will update automatically to show you the styles associated with the
current active project.

Return to chapter ⤴

17.3 Using andManaging Styles
In this section we will discuss the application, creation, deletion and modifica-
tion of styles to text, and within your project in general.

17.3.1 Applying Styles
When you come across a phrase that needs to be styled, either while editing or
writing, your usage of the style tools will be similar—and familiar from how you
might use something simpler like toggling italics:

— While typing: styles will change the way you type at the cursor from that
point forward. As with bold or italics, use of the style a second time will
revert to typing in “no style”, removing all formatting they applied from
the cursor.
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— Upon a selection: will only apply the style within the selected range of text.
If the selected text is already assigned to the designated style, the com-
mand will remove that assignment.

Figure 17.4 The style (leftmost button) and font controls in the format bar col-
lapse when less space is available.

Whether applying styles while typing or retroactively, there are several ap-
proaches available:

1. In the The Format Bar (subsection 15.7.2), the leftmost button is dedicated
to styles. If the window is wide enough, the name of the style you are
currently working with will be printed. Otherwise the button will be as
collapsed down, as shown in the second two examples in Figure 17.4.

2. The main Format ▸Style ▸ submenu lists all styles in your project for easy
selection. This command is also available from the text editor contextual
menu.

3. The main menu also serves as a reference for any keyboard shortcuts you
have assigned to styles. For example, by default the stock “Block Quote”
style can be applied to the current paragraph with⌥⌘2.

4. And of course the Style Panel itself is a great way to work with styles if you
prefer a single-click visual approach. This tool also serves as a reference
for assigned shortcuts. To change a shortcut, use the Format ▸Style ▸Show
Style Panel command and then right-click on the style you wish to adjust,
using the “Change Keyboard Shortcut” contextual menu.

5. The Format ▸Style ▸Show Styles Menu (⇧⌘Y) is a convenient way to switch
to a style. Just as with all menus, you can use the keyboard to type in the
first few letters from the name of a style to jump straight to it, and Return
to select.

6. If youhave aMacwith aTouchBar, youwill find a stylemenu in the default
set. Itwill print the nameof the style you are currently typing in (“No Style”
otherwise), and when you tap on it you can select a style to apply, from a
scrolling view.

If your intention is to type in the selected style for a bit, eventually you’ll prob-
ably be looking for away to stop typing in that style and return tonormal unstyled
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text. Use the same style command to toggle typing off for that style (character
styles only). By default, paragraph styles will automatically disable when you
move on to the next paragraph.
Additionally, all of the methods listed above provide a “No Style” or “Remove

Style” choice among their options. For example, you can use the ⌥⌘0 keyboard
shortcut, as provided by the Format ▸Style ▸NoStylemenu command. This action
works contextually in that it terminates character styles, returning cursor input
to the underlying paragraph style formatting (if applicable) or unstyled text. If
there is no character formatting directly behind the cursor, then the action will
be to strip all attributes from the current paragraph and return it to default for-
matting.

Styles, Tables and Lists

Owing to technical conflicts that exist between the style system and how
lists (using bullets or numbering) and tables are constructed, paragraph
styles should not be expected towork properly within them, or tomodify
how they work. Character styles will work as expected within table cells
and list lines, so if the intention is to modify the character formatting
for an entire cell, you would be better off using character styles for such
things as table headings or key bullet points.

17.3.2 Creating NewStyles
Creating a new style is done by first formatting text in an editor using the stan-
dard formatting tools (use dummy text if you do not have an example yet). Next,
select the entirety of the text that you want styled, or merely position the cursor
within the paragraph for paragraph styles, and then using one of the following
methods to create a new style from it:

— The Format ▸Style ▸NewStyle FromSelection…menu command.

— Click the + button in the footer area of the style panel, which can be
opened via the Format ▸Style ▸Styles Panelmenu command (⌃S).

Using either method, you will be taken to the New Style panel (Figure 17.5).
Once filled out to your specifications, click the OK button to confirm and add
the style to your project. This will also apply the style to the text you used to
create it.

Name This is the title by which the style will appear in all menus and the Style
Panel. The name of a style can be important when it comes to copying
and pasting between projects, as well as when compiling. Scrivener relies
upon names to look for matching styles in these contexts. You can for ex-
ample cause text tagged as “Glossary Entry” to have its appearance altered
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Figure 17.5 TheNewStyle panel is also used for redefining styles in the project.

by compile settings that modify all text tagged as “Glossary Entry”, regard-
less of the project they came from or the formatting in that project.

Most often thiswill be of importance if youwish tomakeuse of our built-in
compile formats. We assume styles will be named in accordance with the
example stock styles added to new projects. If a compile format overrides
how, say a block quote, looks then it will be looking for “Block Quote”.
This of course can all be changed to suit your working habits. Refer to the
Compile Format: Styles pane for further information on that topic (sec-
tion 24.5).

Shortcut Select a key to associatewith your style. All shortcutswill use the same
modifier keystrokes, so all you have to choose is a number. Any numbers
already assigned to other styles will be marked as such. You can overwrite
an assignment from here, and will be warned when doing so.

Formatting Here is where you set the type of style (subsection 17.2.1) and the
scope of what formatting it will store and apply to future text:

— Save character attributes: the type of style will be Character. Only
those settings that impact the letters and words themselves will be
saved.
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— Save paragraph style: the type of style will be Paragraph. Only the
settings that impact the “shape” of a paragraph will be saved.

— Save all formatting: the type of style will be Paragraph+Character. All
formatting will be saved, and when applied, the entire paragraph will
be formatted uniformly.

Below the type selection are two additional options forwhether to Include
font family and Include font size. These can be useful when creating gen-
eral purpose styles. For example a heading style would often change the
font size, but it might not bother with changing the font family, if heading
fonts are meant to be the same as that used by body text.

Highlight Box In some cases it might be advantageous to draw visual attention
to a style, either as embellishment or to act as a crucial signifier in cases
where the actual formatting of the style itself doesn’t matter or isn’t meant
to be visible to the reader. Enable the Draw highlight box around text
checkbox, and then click on the colour chip to select what will be used as
a background fill behind the text.

Figure 17.6 Highlight boxes can visually accentuate styles in the editor, and
are particularly useful if the style is being used for something other
than visible formatting.

Next Style This final option is available to Paragraph styles, and determines
which paragraph style will be automatically selected, when ending the cur-
rent paragraph with the Return key. The default is “None”, which will re-
turn you to default unstyled text. You could create a “Figure” style which
automatically select “Caption” for you when moving to the next line, and
then finally Caption could go back to unstyled text.

It is also possible to select the same style you are creating with the “This
Style” option, at the top of the dropdown menu. This will be useful for
styles that tend to span more than one paragraph or line, such as code
blocks.

17.3.3 Redefining a Style
Modifying a style followsmuch the sameprocedure that creating a newone does.
Text is formatted the way youwould like the style to look (use dummy text if you
do not have an example yet) using the standard formatting tools. Fully select the
example text (or merely position the cursor within the paragraph for paragraph
styles) and then using one of the following methods to update an existing style:
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— Use the Format ▸Style ▸RedefineStyleFromSelection ▸ submenu to select the
style you wish to overwrite.

— From the style panel, right-click on the style you wish to overwrite, and
select “Redefine Paragraph Style From Selection…”.

The same dialogue you used to create the style will appear. In most cases you
will not need to change anything here, and can just submit the form to apply
the updates. However if you do wish to change the parameters of the style, you
can change every aspect of it save for its type. With paragraph styles, you can
retroactively change whether or not character attributes are included with the
style.
Styles cannot be duplicated directly. If you are looking to create a derivative,

use the original to style your text, modify its formatting in the editor, and then
use your preferred method for creating a new style.
Lastly, if all you wish to change is the keyboard shortcut, right-click on the

style you wish to alter in the Styles panel, and select the desired shortcut from
the “Change Keyboard Shortcut” submenu.

17.3.4 Deleting a Style
Deleting a style can be done at any time by using the Format ▸Style ▸DeleteStyle ▸
submenu. This command cannot be undone, but since it does not actually re-
move formatting from the text, if you do accidentally delete an important style
you can re-create it by finding an example in your text, and creating a new one
from scratch from its formatting.

17.3.5 Removing Styles fromText
Styles can be removed by using the matching style command on the selected
text (the floating styles panel does not offer this feature). The Format ▸Style ▸No
Stylemenu command (⌥⌘0) also strips out the style from the selected text or the
paragraph.

— For character styles, you must always select the entire range of text you
wish to remove the style from (just like how you would need to select an
entire range of italic text to remove italics from it). If you use this com-
mand by placing the cursor somewhere within the range, all that will hap-
pen is you will insert a “no style” declaration at the cursor, meaning that if
you start typing it will not be typed in that character style and the original
range will be broken in two.

— When character styles are removed from paragraphs that have a Para-
graph+Character style applied to them, the text will revert to the format-
ting established by the paragraph style. For example, if the paragraph as-
signs a dark red colour to text but our character style is light blue, when
we strip out the character style from that paragraph it will turn dark red.
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When removing character styles from paragraphs that are unstyled, the
text will merely become unstyled as well.

— To remove a paragraph style, even if it supplies character formatting, place
the cursor anywhere within the paragraph not otherwise occupied by a
character style and use the “No Style” command. Any direct character
formatting and styles found within the paragraph will be retained, but all
other text and the paragraph settings themselves will be converted to de-
fault formatting.

Get rid of them all!
To strip all styles from selected documents, use the special option pro-
vided in the Documents ▸Convert ▸Text toDefault Formatting…menu com-
mand: Remove all styles. This will clean out all style information and
remove related formatting, within the design limits of this tool (e.g. if a
style provides inline formatting such as italics, they will not be stripped
out but the style will be).
If you want to go even further and get rid of all formatting, try cutting

the text (⌘X) and then using Edit ▸Paste andMatch Style.

Return to chapter ⤴

17.4 Workingwith Styled Text
17.4.1 Selecting and Searching for Styles
Marking text as styled is useful for many reasons, chief among them the abil-
ity to locate bits of text that have been tagged under a particular style. There
is of course great appeal in easily walking through every figure caption in your
dissertation or every block quote in a biography.
There are two placeswhere youwill find tools for finding text by style use. The

Edit ▸Select ▸ submenu contains these three commands:

— Select Style Range: expands the current selection, or select from the around
the cursor position, to encompass the styled text around it. This command
works under the following logic:

– If a character style is found, the contiguous range of text around the
cursor using that style will be selected.

– If a paragraph style is found around the selection, then all contiguous
paragraphs using that style will be selected. This includes conditions
caused by the above, meaning we can first select a character range,
and then use the command a second time to select at the paragraph
scope.
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– When there is no style in use around the cursor, then all contiguous
paragraphs that also have no style applied to them will be selected.
This state ignore character styles, so they will be selected along with
the unstyled paragraphs they are found within.

— Select All Style: Selects all non-contiguous text within the same text view
using the current style beneath the cursor, or as found beneath the left-
most edge of the selected text. As with the previous command, character
style ranges will take precedence over paragraph styles. Also as with the
prior command, if the cursor or selection encompasses text with no style
applied to it, the command will select all other unstyled text.

— Select Next in Same Style: Using the same criteria as “Select All Style”, this
command will select the next phrase of text found within the current edi-
tor using the same style. If the cursor is within block quote, then the next
block quote will be selected. This form of selection will wrap around from
the bottom of the document back to the top if necessary, which means if
only one example of the style exists, the very context the cursor currently
sits in may be the “next” available example of text using this style.

The floating styles panel (subsection 17.2.3) has two dedicated buttons (⮃ and
⮁) in the lower right, which perform the same function as the latter menu com-
mand listed above, although in either direction. You will also find tools by right-
clicking on the styles themselves, or by clicking on the button, below the style
list.
While these commands provide a good amount of flexibility and searching

power within the active text editing session (and do consider that Scrivenings
sessions can broaden the amount of text you are working with at once), some-
times you want to navigate through however many chunks of text it takes to
get from one instance of styled text to another—or maybe you want to only find
styled text that contains a certain bit of text, like “figure” vs “table”. This is where
the Find by Formatting Tool (subsection 11.6.6) comes in, with Edit ▸Find ▸Find by
Formatting… (⌃⌥⌘F).

17.4.2 Copying and Pasting Styled Text
When copying text between projects the first thing to know about this process
is that Scrivener will use name matching, not formatting, to look for style as-
signments within the same type (paragraph vs character). If you have a style
called “Character Name” in both projects, then you will be able to freely copy
and paste between those projects without fear of losing style assignments, and
doing sowill automatically update the pasted text’s formatting so that itmatches
the stylesheet in the project you are pasting into.
In cases where the pasted text contains paragraph styles not named in the tar-

get project, those styles will be stripped from the text and any attributes they
were contributing to the formatting of that text will not be applied. For example
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if we paste a “block quote” into a project that has no block quote style the para-
graph will end up looking like a normal paragraph. If retaining the formatting
that styles provides is important to you, always make sure the target project ad-
dress those styles in its stylesheet (and refer to the following section for tips on
merging or importing stylesheets).

17.4.3 Styles for Authors UsingMarkup
Scrivener has always been a tool that containsmethods for thosewhowork using
markup systems, such as Markdown (chiefly with its variants MultiMarkdown
and Pandoc), XML, HTML, LaTeX, DocBook and so forth. Of particular use in
technicalwriting, Scrivener’s style feature has been carefully designed tonot only
provide a traditional look and feel for those coming from word processors, but
a powerful platform for defining ad hoc semantic types into the editor and then
exporting those types into meaningful plain-text variants in the compile phase.
The heavy lifting is entirely done in the compiler, leaving the particular style
system itself largely to the domain of aesthetics, while writing.
By way of a very simple example, one could create a style called “HTML Com-

ment”. The look of the style in the text editor would be arbitrary—what really
matters is what happens when the compiler is set up to look for ranges of text
tagged with “HTML Comment” and wraps those ranges of text in a <!--` prefix
followed by a `--> suffix. Scrivener supports both inline prefix and suffix as
well as multi-paragraph enclosure.
If you are a plain-text author, consider using the styles feature to your advan-

tage. A real-word example of how this can be done is provided in the user man-
ual you are reading right now. It makes heavy use of the stylesheet system to
implement custom LaTeX control in the output document. Wemake the source
project available on our web site.

17.4.4 Styles That DoNothing
Styles do not necessarily have to perform a formatting function in Scrivener.
When compiled they can have their assigned text stripped from the output con-
ditionally, used to pass through instructions to the output format (raw HTML to
ePub for example) and a few other tasks—but even beyond that they can in effect
become invisible, leaving the text in a state where your readers will never know
it was tagged in the first place.
Consider that marking a text with a named style is a way of tagging text with

meaning. You can use formatting for this purpose if you wish, or purely visual
highlighting fills (Figure 17.6), but set the formatting to match body text com-
piled.
A practical example of where this might be useful is in tagging all text relating

to a certain character’s inner monologue. This could be expressed as simply as
italics in the editor—but having done so with styles you’ll be able to select by,
search for and walk through examples of monologue text throughout the entire
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book. If you’ve ever wanted to mark text as being “something” so you can easily
find it later with other similar texts, styles may be what you are looking for.
Refer to the Styles compile format pane for details on how styles can be mod-

ified during export (section 24.5).

17.4.5 Importing fromOtherWord Processors
Importing documents with stylesheets from other word processors will follow
the same rules for copying data between Scrivener projects: the software will be
looking for styles by their names, and thus you will need to have styles already
created in the project’s stylesheet by those names in order for them to import.
Not every document formatmay have the same results. If you find some styles

are not importing as expected, try another format like RTF, ODT or DOCX.

Return to chapter ⤴

17.5 Copying Stylesheets Between
Projects

When you need to copy a stylesheet from one project to another, the For-
mat ▸Style ▸ Import Styles… menu command (also accessible from the button
in the floating styles panel) will be your way of doing so.

— Styles that are identical in both name and formatting will be ignored.

— If the project you are importing from contains styles that have the same
namebut different formatting, youwill be askedhow tohandle the import:

– Keep Existing Styles: no styles as defined in the current project will be
modified. Only new styles will be imported.

– Replace Existing Styles: the formatting for existing styles will be up-
dated to match the project you are importing from. This can be use-
ful if youwant to bring two different projects into parity with one an-
other, or to update an older project with refinements made to newer
ones.

– Add Imported Styles: this is the safest option. The conflicting styles
will be imported as new styles (Scrivener will add a number to the
name to keep them separate). You can then choose to keep them or
discard them, or manually merge select styles while leaving others
alone.

In some cases you might need to manually shift assignments of text from an
old style to a new one, such as when using the “Add Imported Styles” button,
above:
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1. Open the Format ▸Styles ▸ShowStyles Panel pane.

2. For each document that needs to have its styled text shifted over to a new
style, right-click on the old style in the Styles Pane, and use the “Select All
Text with Paragraph|Character Style” command.

3. With all of the desired text now selected in the editor, simply click on the
new style to re-assign the text to the new one.

4. Repeat as needed for each document (and keep in mind that Scrivenings
mode can be used to fix large quantities of text).

5. Once all of the text has been shifted to the new style, you can delete the
old style from the Styles Pane via the contextual menu.

Do I need to do this for every new project?

You can also establish a global default stylesheet for all new projects, us-
ing the Set StylesDefaults… button, in the Formatting settings pane (sub-
section B.3.2).

Return to chapter ⤴
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18.1. Inline vs Linked

As a tool designed for the production of texts, there are many methods for fa-
cilitating not only the writing, but the editing and “public” notation processes
which are typically expressed via some form of page or section footnote, or end-
note at the conclusion of the work. This chapter will cover all of the various
methods that Scrivener provides. We will cover:

— Internal commentary: the ability to place production notes within the
document, making it easy to communicate changes or needs to yourself,
collaborators, your editor, or to receive the communications from others.
Scrivener’s inline annotations and comments are compatible with most
word processors and editors. If your editor or collaborators do not use
Scrivener, you will be able to export and import simple notes to them. If
they do use Scrivener, then you will have even more tools at your disposal,
as Scrivener’s internal commenting features are considerablymore diverse
than those found in most writing packages and word processors.

— Footnotes and/or Endnotes: being a drafting tool, Scrivener makes no at-
tempt to typeset and number either of these as you write, however it is
easy to insert notes precisely where you need them, and when you com-
pile theywill presented according to your exacting demands. Aswith com-
ments, RTF standards are supported and incoming notes will be converted
to your preferred notation style. Scrivener supports two note streams, al-
lowing you to output both footnotes and endnotes, if required. In the case
where specific formatting is required, it may be advantageous to use a ci-
tation manager that can scan an RTF and produce a bibliography for you
(section 20.5).

— Text colours and Highlighters: to aid in increasing the visibility of pas-
sages, you are provided with an extensive complement of tools for high-
lighting and marking your text in colour.

— Revision markings: the automatic application of text colour, as you edit
and write, can be assigned individual colours for up to five revisions, mak-
ing it easy to make sure your colleagues (or yourself) know what you have
changed and vice versa.

Marking your text is one thing, finding those markings amongst a 100,000
word draft is another. The robust Find by Formatting Tool (section 11.6) makes
it easy to quickly step through your draft, point by point, isolating and addressing
issues or reviewing changes that you’ve made.

18.1 Inline vs Linked
Annotations and footnotes (this document will refer to all reader notes as foot-
notes, even if their intended result will be endnotes) come in two different
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flavours. Inline notation, which are added directly to your text, and linked nota-
tion, where the content is displayed in a box along the side of the editor, linked to
highlighted fields of textwithin it (this is the type of comment used bymostword
processors). Which of these to use will remain up to you and your preferences in
most cases. You might even find that a mixture of methods will suit you, using
inline notation for short comments to yourself about prose, and linked notes for
other types of comments.
There are a few advantages and disadvantages to each method:

— Inlinenotes are always visible in your text; there is noway to diminish their
prominence. So for some forms of notation, this can be an advantage in
that you cannot defer or easily ignore them. This also makes it easier to
see your notes and your book at the same reading speed—there is no need
to look off to the side to get a feel for the “meta” book.

— Linked notes do not disturb the flow of text, nomatter how large theymay
be. This means even the lengthiest of notes can be placed into your text
without having to scan fromword to word in order to read the underlying
book text.

— Inline notes, being within the text itself, do not require any additional in-
terface to use and never require the mouse to read. They thus work well
with a slim workflow, or in situations where screen space is at a premium.

— Linked notes can act like bookmarks. Clicking on them in the inspector
will whisk you right to the spot in the text where they are anchored.

— Inline notes can be placed anywhere you like (especially annotations), even
in betweenparagraphs or at the very beginning or endof a section, whereas
linked notes require something to “anchor to”. This makes inline nota-
tion more useful when jotting down notes in sections before you’ve even
started to write.

— Linked notes can be easily viewed together in a collected interface nomat-
ter how far they are spread apart in the document. This becomes especially
advantageous in a Scrivenings session. A note on page 10 has the same
prominence as a note on page 1.

— It follows then that inline notes are only visible in the current contextual
surroundings. Notes that are pages away, and do not presently concern
you in your writing and editing, are hidden by the same virtue that hides
these irrelevant texts from you: the sheer bulk of your words.

— Inline notes exist around your text and do not depend upon it to exist. This
means you can edit the text that the note refers to freely, withoutworrying
about losing your comments. This is in opposition to linked notes, which
are anchored to the text—if the text is removed or entirely altered, the note
will be deleted.
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By corollary, inline note quantities can exceed the textual capacity of the
base text. For most authors this will not become an issue, but in some
fields, such as qualitative data analysis, where the amount of annotation
can exceed the original text, running out of suitable anchor text could be-
come a problem with linked notes. Inline notes, being unanchored, have
no limits.

These are just a few examples, and hopefully that gives you an idea of the in-
dividual unique merits in these approaches. The next few sections will address
each of these types in more depth.
One last thing worthy of mention here is that you can freely convert between

inline and linked notes as needed, either en masse or one by one. The commands
are found in the Edit ▸Transformations ▸ submenu. Refer to Converting Notation
Between Types (subsection 18.4.5) for further information.

Return to chapter ⤴

18.2 Inline Notation
Scrivener sports an unusual method for taking notes and indicating footnotes,
by placing them directly into the main text stream itself.1 It mimics the natural
annotation process that one applies when working with paper and the prover-
bial red pen, where notes are scribbled below the problem lines themselves, into
margins, or anywhere else theywill fit in. It means your notes remain prominent
and easy to find so long as they remain issues worthy of attention.
The same treatment can be given to footnotes as well, and by keeping the ac-

tual text of the footnote directly inlinewith the text itmay augment and increase
productivity, as well as help keep your meta-book relevant and cohesive.
Further advantages are in entry speed: since notation is done directly in the

text while you are typing or editing, it is easy to flow from “editor” to “writer”
without disrupting the process with floating windows, margin bubbles, or the
many other mechanisms that applications use to attach notes to text.
How you interface with inline annotations and footnotes is identical. Since

inline notation works just like ordinary formatting, creating a note or footnote
from existing text is as easy as selecting the range of text you wish to adjust and
clicking on the appropriate menu command or toolbar icon.
To convert some existing text to an annotation (a great way to “soft” delete it):

1. Select the text you wish to turn into notation.

2. Use the Insert ▸ Inline Annotationmenu command (⇧⌘A).

1 If you ever used the LyX document processor you may recognise the concept, as this was the
source of inspiration for Scrivener’s inline notation features.
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3. For inline footnotes, use Insert ▸ Inline Footnote (⌃⌥F) instead.

4. As with other formatting tools, this works as a toggle. If you select some
text that is already set to be an annotation and use this command, it will
be returned to regular text.

Also as with formatting you can toggle the typing mode of the cursor to no-
tation mode. Using the aforementioned commands without any selection will
cause the cursor to use that formatting as you type. If you use the command
while typing in a range that is an annotation or footnote, the effect is to toggle
the formatting off. Thus you can easily jot down a note while in the midst of
writing a sentence.
Moving notes around is a simple matter of cutting and pasting the text itself.

Since notations are formatting, they will move along with the text no matter
where you take them, unless you use Paste and Match Style:

1. Place the cursor in the annotation or footnote you wish to move or copy.

2. Select the entire note with the Edit ▸Select ▸Select Annotation (or Select
Footnote) menu command (also available from the right-click contextual
menu).2

3. Use the Cut or Copy command, place the cursor where you wish to place
the note and Paste (remember to use Paste and Match Style if you do not
intend to paste the text as notation). You can also drag and drop selected
text to move it.

18.2.1 Inline Annotations
Inline annotations are away ofmarking text so that it will not appear (by default)
when you compile.
To ensure your text exports as expected, you must check that the text sur-

rounding your annotation would make sense were the annotation not present,
including how you set out your whitespace (spaces, newlines etc). The provided
example (Figure 18.1) exhibits a few key points:

— We’ve used an orange highlight to indicate the text immediately surround-
ing the inline annotation. As you can see, with the annotation removed,
the two highlighted fields join up perfectly.

— The second highlight includes the space between these two sentences.
Without that, they would run together.

2 If you do this a lot, consider adding your own keyboard shortcut (section A.1).
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Figure 18.1 Annotated text will appear red with a “bubble” around it (upper),
and not at all when compiled (lower).

— Inside the annotationwe have additional spaces—these don’t reallymatter
and you can use spaces as you like to pad the content of the annotation
from the text around it.

This demonstration also shows how annotations can be useful to “soft delete”
ranges of text. In this example here, we could select the annotation and tog-
gle that formatting off, converting it back into text the reader will see. In that
case we probably wouldn’t want to leave an extra space on the end of the anno-
tation, so that it fits seamlessly together when reintegrated with the text. You
can choose to include or exclude inline annotations from the compile overview
screen, within the compile - general options (subsection 23.4.3) tab, withRemove
annotations setting.

Tables and Lists Don’t Mix
Although you can create tables and bulleted lists inside annotations and
footnotes in Scrivener, they are not supported inside annotations and
footnotes in the RTF, RTFD and Word exporter. This means that if you
place tables or bulleted lists inside annotations or footnotes in Scrivener,
when you export these elements will be stripped out.

Changing Annotation Colours
Inline annotations can have their colours changed independently. This makes
for an easy way to create “types” of notes that you can spot at a glance. High
priority notes might use bright red, while deleted text could use light grey. To
change the colour of annotation:

1. Placing the cursor anywhere within the annotation you wish to colour,
or select only a portion of the annotation to effectively split it into two
adjacent differently coloured annotations.
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2. Use the Format ▸Color…menu command (⇧⌘C) and select a colour.

On a per project basis, Scrivener will remember the last colour you chose and
use it for the next annotation you create.

Want to get back to default red?

In the direct-sale version of Scrivener (sorry, the Mac App Store doesn’t
allow software to install colour palettes), bring up the system color tool
with Format ▸Color… and click on the “Color Palettes” tab. From the drop-
down menu at the top, select the “Scrivener” set. You will find an “Red
Annotation” swatch in this palette.

18.2.2 Inline Footnotes
Working with inline footnotes is quite similar to annotations, and really in
most ways, footnotes act identically to annotations. The main difference lies
in the fact that annotations aremeant to be omitted when compiling or printing
(though do not have to be) whilst footnotes are typically placed somewhere on
the page or at the end of the document or ebook (though they can be omitted
like annotations, too). Visually in the editor, the difference is that footnotes are
not coloured but are surrounded with a black line and have a grey background.

Formatting Footnotes

Unlike annotations, any whitespace on the front or back of the text will
be stripped out when you compile. This allows you to insert “buffer
space” around the footnote and help set it apart from the regular text.
As with annotations, the placement of the bubble is important in that
the text around it should flow sensibly, but with footnotes you also need
to take into account that if the bubble were collapsed, that is where the
footnote reference mark would be. Try to visualise the entire bubble as a
single number, and this will help you with placement.

Referenced Inline Footnotes
For those that prefer the concept of keeping footnote content within the main
editor, where it can be easily searched for and edited without mouse clicking,
but would still like to keep the bulk of the notes outside of the main text body
area, there is amethod you can employ that works in a cross-referencingmanner
(similar to howMarkdown-based footnotes work, if you are familiar). To use this
method:

1. Create an inline footnote in the intended location of themarkerwithin the
text body, and type in a unique reference keyword surrounded by square
brackets (Figure 18.2).
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An example of this might look like this: “[Reference]”.

2. Now elsewhere (anywhere in the Draft folder that will be included in com-
pile), place the full content of the footnote and make sure to prefix the
content with same bracketed reference.

For the above example, this could look like: “[Reference] Here is the text
of the footnote as it will appear in the final manuscript.”

3. When compiled, Scrivener will match the two footnote ranges together by
their bracket reference and remove the bracketed segment entirely from
the output.

Figure 18.2 Referenced inline footnotes keep the source text cleaner without
sacrificing the concept of keeping footnote text in themain editor.

18.2.3 Finding Inline Notation
Scrivener provides tools for stepping through your entire project, searching for
annotations and footnotes. Read more about this feature in Find by Formatting
Tool (subsection 11.6.3).

Return to chapter ⤴

18.3 LinkedNotation
Creating and reviewing linkednotation ismade very simplewith Scrivener’s side-
bar approach. Thismethodmakes it easy for you to see all of your notes through-
out the text at once3, and jump directly to their location by clicking on these
notes in the stack, no matter how far apart they may be, when printed.

3 If the editor contains multiple text entries in a Scrivenings session, all of the notes will be com-
bined together.
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Figure 18.3 Comments throughout the edited text are displayed in one conve-
nient stack.

18.3.1 Creating LinkedNotes
To create a new note, either:

— Select the text to notate and then invoke the appropriate menu command
or keyboard shortcut.

– To make a comment, use Insert ▸Comment (⇧⌘*).

– To create a footnote, use Insert ▸Footnote (⌃⌘8).

This approach is quite useful for comments. If you intend to address a
piece of prose in your text, the highlighted text is immediately obvious as
the problem area.
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In addition to the menu and shortcut commands, you can also click either
the new comment or footnote button in the header bar of the Comments
& Footnotes inspector to add them (marked (a) in Figure 13.15.

— Place the insertion point in or after the word you wish to notate and use
one of the above commands or shortcuts.4

New comments will use your name, as given in the Author Information set-
tings pane (subsectionB.2.3), andwill fall back to the systemuser name if nothing
is provided there.

Getting Back to the Text

Once you have finished typing in the content of the note, you can swiftly
return to where you were typing by hitting the Esc key. In the case where
you have pre-selected text to be notated, the cursor will be returned to
the end of the prior selection.

Limitations
To create a linked note you must have text to attach the note to. If you wish
to jot down scattered notes in a blank document, or discuss the text in vague
terms without referring to specific texts within it, it might be easier to use inline
annotations or the document notes sidebar in the Inspector (subsection 13.3.2),
instead.
Since linked notes are a type of link, they cannot be placed atop a range of

text that is already linked to something else, without removing one of them. To
annotate a link, consider using inline notes, or place the link anchor before or
after the linked text, rather than on it.

18.3.2 Reviewing and ReadingNotes
The “anchor point” in the text, where the note is attached, will be drawn using
one of three methods:

1. For comments a prominent highlight, coloured to match the comment, is
placed around the phrase.

2. For footnotes, a grey highlight around the word or phrase, giving a dis-
tinctive advantage over hunting for small superscript numbers in a word
processor.

3. Alternatively, for footnotes, affixed after the word or phrase as a symbol
or marker. This approach more closely mimics how a word processor

4 For those that need it, refer to Placing Footnote Markers After Punctuation (section 18.3.7).
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presents footnotes and endnotes. It can be a useful alternative when the
original text is densely covered with references.

Clicking on any anchor highlight will select that comment in the inspector,
opening it if necessary to do so. You can also hover over a highlight, and the
note text will appear in a tooltip without opening the Inspector.
There are four other places notes will be positioned:

1. In Quick Reference panels, comments and footnotes will be placed into a
split view below the main text editor within the panel.

2. In composition mode, comments and footnotes have a dedicated pane in
the floating inspector.

3. Snapshots will save their notes when you take the snapshot, and you’ll be
able to see the anchors in the snapshot viewer, but only view them one at
a time.

4. If you prefer popups to having the inspector open, you canuse popupnotes
instead (subsection 18.3.6).

See Also…
Refer to the documentation on the inspector’s Comments & Footnotes Tab

(section 13.7), for further information on working with the notes themselves in
this area of project window.

18.3.3 Deleting LinkedNotes
Deleting notes can be accomplished by selecting the note(s) in the inspector and
then using one of the following methods:

— Click the− button in the header bar.

— Click the small× button in the top-right of each note you wish to delete.

— Use the Delete key on your keyboard.

18.3.4 Hiding LongNotes
Individual notes can be collapsed, so if one note is quite long, it needn’t mo-
nopolise the space (in Figure 18.3 the first yellow comment has been collapsed).
Collapsed notes will show the first few words of the first line of the note, as well
as an icon to indicate their type (comment or footnote). You can read the whole
note by hovering over it with the mouse.

— Click on the disclosure arrow to collapse or expands selected notes, or use
the Left and Right arrow keys on the keyboard.

— To collapse or expand all notes, use⌘0 and ⌘9 respectively.
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18.3.5 ChangingWhat a Note is Linked To
There are three ways to move a note from one text anchor to another:

1. Select the text in the main text editor that you wish to re-anchor the note
to, and then right-click on the note itself in the inspector. Youwill find the
menu command: “Move to Selection”.

2. Alternatively, drag and drop the note from the Inspector pane into the text
where you wish it to appear. When using this method, the same logic will
be applied as when creating a newnotewithout first selecting a range. The
nearest word (and its adjoining punctuation, if relevant) will be set as the
new target. The exception to this is when using Footnote Markers instead
of standard range-based footnotes, themarker will always be dropped pre-
cisely where you let go of the mouse button.

3. In a slight variation of the above, if you pre-select text in the editor and
drop the note on the selection, the selected range will be used to anchor
the note.

These techniques can also be a useful way of temporarily setting aside a note
so you can edit a paragraph freely. When used in a scrivenings session, this tech-
nique also allows notes to be moved from document to document.

18.3.6 PopupNotes
An alternative method for working with your notes is in a popup, right over the
highlighted text you clicked on (Figure 18.4). Disable the Open comments in
Inspector if possible setting, in the Editing: Options settings pane, to enable
this behaviour (subsection B.3.1). The inspector will still be used if it is open to
the Comments & Footnotes tab, but in all other cases, the popup will be used
instead.
Thismethod can also be used atwill, rather than as a global setting: hold down

the Command key when clicking on a note highlight to use the popup format at
any time.

a) The type, comment vs footnote, will be printed in the header area, and
can be right-clicked on to access a few of the contextual menu functions
that are documented in the Comments & Footnotes tab of the inspector
(section 13.7).

b) Click the Delete button to remove the note you are working with in the
popup. Since this is considered an editing command, you can Undo it if
you make a mistake.

c) The ⮃ and ⮁ buttons will jump from one footnote or comment to the
next within the current editor. If you would like to jump from one to the
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Figure 18.4 Popup notes display their content right in the text, rather than in
the inspector.

next even if that means navigating to a new document, try the Find by
Formatting tool, instead (subsection 11.6.2).

To dismiss a popup note, click anywhere outside of it, or press the Esc key.

18.3.7 Linked Footnotes
Aswith inline footnotes, linked footnoteswill by default appearwith a grey back-
ground, and will likewise appear grey in the inspector and in popup form. Foot-
note colours cannot be individually changed, though you can adjust the global
colour used by the software with the Inspector footnotes setting in the Appear-
ance: Textual Marks: Colors Setting tab (subsection B.5.16).

Figure 18.5 Where the grey highlight terminates determines the reference
mark position in the output text.
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Since footnotes will ultimately generate amarker in your text, the positioning
of the anchor point in the text is important, it will be used to place the reference
mark in your final text once you compile (Figure 18.5). As shown, the highlight
terminates after the terminal punctuation following thewords, “…to produce it.”
In the output, the superscripted “1” is placed where the grey highlight ends.

FootnoteHighlight Style
If you require adjacent sequences of footnotes, then you will need to use one of
two alternative methods for handling them:

1. Inline footnotes are not attached to visible words, and as such can be
placed in a sequence, with some kind of separator between them.

2. The alternative highlight style documented in this section can be used to
similarly as inline footnotes, and may work better for those that prefer to
keep footnote content out of the main editor.

Using footnote markers will also reduce the overall visual impact of them, by
placing a simple marker after the current selection, or current word, rather than
highlighting the relevant phrase (Figure 18.6).

Figure 18.6 Footnote markers demand less visual attention, which might be
desirable if there aremany of thempacked closely together in your
work.

You can switch to this way of working at any time, even if you have already
committed considerable time toward the standardmethod of highlighting noted
text—existing footnote highlights will go onworking as they always have. To get
started:

1. Enable the Use footnote marker setting in the Project Settings: Format-
ting pane (section C.5).

2. Optionally select a marker style. What you use here has no bearing on the
output—these will be stripped out when you compile the document and
so your only goal is to pick something recognisable and useful to yourself
while writing.
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3. Click the OK button to confirm your settings.

4. To create a footnote using themarker style, do not preselect the phrase you
are adding a note to; merely place the cursor where the marker should be
inserted, and use you preferred method to create a footnote.

If you preselect text, then the marker style notation will not be used for
that footnote—and this is perfectly fine to do for those cases where a high-
lighted phrase is more meaningful and desirable.

The Make Default button in Project Settings can be used make Scrivener use
your preferred marker, and the preference to use this mode, in all new projects.
Existing projects will not be altered.

CanMarker Styles be Switched or Disabled?

Take care to use one marker style consistently from that point hence. If you
switch marker styles halfway through your project, or turn this feature off, the
mismatchingmarkers will appear in your final draft as visible text. The following
tip can be used to “upgrade” from one marker to another, by first removing all
existing markers during conversion to inline, then changing the marker style in
settings, and finally converting footnotes back to the inspector, where they will
pick up using the new marker.

How can I get back to using regular footnotes?

If you change your mind about the feature and want to go back to using
the default behaviour, you will need to convert the marker-based foot-
notes back into regular footnotes. The easiestway to do thiswill be to use
the Edit ▸Transformations ▸Convert Inspector Footnotes to Inline Footnotes
menu command on all sections of text that are marked this way. It is im-
portant you do so with the marker setting enabled, so that they will be
detected and deleted by the software in the conversion. Once you have
converted the footnotes to inline, disable the Use footnote marker op-
tion in Project Settings, and convert them all back to inspector footnotes
using the opposing menu command in that same submenu.

Placing FootnoteMarkers After Punctuation
Some style guides prefer to place the footnote marker before the terminal punc-
tuation mark of a sentence, especially if the footnote pertains to a clause within
the sentence rather than the sentence as a whole. If you are writing in a lan-
guage or style guide that calls for this, you can adjust whether the automatic
consideration of a “word” includes any following punctuation mark in the Edit-
ing: Options settings pane (subsection B.3.1), with the Terminate footnotes and
comments before punctuation option. If you require a mix of styles, then it
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is always under your control to highlight terms specifically, and ensure proper
placement of the marker.

Compiled FootnoteNumbering

Figure 18.7 Footnote numbering in the inspector is based upon the previous
compiled order.

Since footnotes can be scattered across hundreds of files throughout the draft,
they will not be numbered as you create them. Instead, they will be tallied up
when compiling the draft, which you can choose to display in the stack of notes,
as depicted in Figure 18.7. To enable footnote numbering:

1. Use the View ▸Text Editing ▸Show Compiled Footnote Numbers in Inspector
menu command.5

2. Compile the full draft to have Scrivener count up the footnotes and assign
them numbers.

3. Upon returning to the project window, you will find your footnotes num-
bered in the inspector sidebar.

There are a few things worth noting in this illustration:

— Since numbering is only calculated during compile, these numbers will be
static as you edit around them. In our example here, we moved the text
that the last note (32) was attached to, so it is now out of order with the
rest. When we compile again, it will be note 28.

— Hovering yourmouse over a notewillmove thenumber over tomake room
for the× button.

5 Use of this command will set your preference for all future projects, but will not change any
existing projects you’ve created.
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— Although inline footnotes will not be numbered or displayed in the foot-
note list, they will be numbered. Here we can see a jump between number
29 and 31 where note 30 is an inline footnote in the editor.

— Although not depicted here, it is important to note that footnote number-
ing is a feature of that note. If you drag and drop or copy and paste text
between projects, any numbered footnotes within the copiedmaterial will
be translated over to the other project.

This alsomeans that snapshots (section 15.8) of the documentwill preserve
footnote numbering as it was at the time of the snapshot.

To increase compile speeds, when footnote numbering is toggled off then the
compiler will no longer tally up footnotes. Consequently, if you reveal number-
ing again the footnotes will be using whichever numbers they were assigned the
last time this feature was enabled.
The View ▸Text Editing ▸Prompt Before Updating Footnote Numbers command

will be useful in keeping numbers static in between compiles. This can be of
considerable use if you have copies of your work out to proofers and wish to not
have the footnote numbers they are using be out of syncwith your internal num-
bers. You can also hide numbering to achieve this effect, without the prompts,
as described above.
As footnote numbers are saved into the footnote rather than being numbered

dynamically, snapshots of the text will remember the numbering at the time of
taking the snapshot. This can be used to help reference proofing notes sent in
from people a few revisions behind you.

18.3.8 Finding LinkedNotations
Scrivener provides tools for stepping through your entire project, searching for
inspector comments and footnotes, either in general or to find only those with
specified text within them. Read more about this feature in Find by Format and
Text (subsection 11.6.2).
It is also possible to use the standard text search tool (section 11.2) with sidebar

notes. With the inspector open, searches will be highlighted in the sidebar for
you, and the replace function will also search and replace matched text in any
applicable inspector notes.

Return to chapter ⤴

18.4 General Usage Tips for Notation
These tips apply to both inline and linked notes, whether they be for your own
internal commentary or for the reader, in the form of footnotes or endnotes.
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18.4.1 StrippingOut All Notation
To clean out all notation from the text you are working with:

1. Select the text you wish to clean out notes from.

2. Use the Edit ▸Copy Special ▸Copy without Comments and Footnotes menu
command.

3. This will leave the original text selected in the editor, so if you wished to
replace it you could paste immediately following the above command. The
cleaned text can of course be pasted anywhere you like.

18.4.2 Resetting LinkedNote Formatting
Adjusting the Editing: Formatting Settings tab (subsection B.3.2) to modify the
Notes font, will not immediately impact all existing notes, as that might wipe
out intentional formatting. You can however, just as when changing main text
formatting, reset the notes to the new default by right-clicking on selected notes
and choosing “Convert to Default Formatting”.

18.4.3 Exporting Annotations andComments
You can export all inline annotations and linked comments in your project into
an RTF file with File ▸Export ▸Comments & Annotations. There are a few options
available:

— Selected documents only: constrain the text exported bywhat is currently
selected in the binder, or active corkboard/outliner view. All comments
and annotations throughout the entire binder will be exported otherwise.

— Include titles: without this option, all notes will be written one after the
other in a flat list. If it is important to know what sections of the outline
they are associated with, enable this setting.

— Insert links back to Scrivener sections: special hyperlinks will be added to
the document, which link directly to the items in the project they were
exported from. For personal referencing this will be the best option if you
need to know where notes came from. These links however will do noth-
ing (expect perhaps produce errors) on other machines.

18.4.4 Notationwith Copy and Paste
Within Scrivener, you can copy or cut, and paste ranges of text that contain any
style of notation. This can even be done in between projects. However when
pasting into other programs, notation may be converted to a form suitable to
the context:
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— For most word processors you will get real footnotes that show up at the
bottom of the page with numbers linked to them within the text. Inline
annotations and inspector comments will use colour-coded bracketed no-
tation.

— Pasting into other types of software will produce a different result if they
do not support either footnotes or comments. In this case notes will use a
“flattened” version that looks like footnotes (or endnotes to be more pre-
cise), with annotations and comments denoted by square brackets.

If you wish to copy and paste text without any notation at all, use Edit ▸Copy
Special ▸Copywithout Comments and Footnotes.

Pasting IntoWord 2011

If you use Word 2011 or greater, and when you paste footnotes and com-
ments find you get the flattened form, you’ll want to enable the Use
Word-2011 compatible copy setting in the Sharing: Conversion Settings
tab (subsection B.8.4). Do note that when this option is enabled, it will
cause native macOS software which would ordinarily use flattened for-
matted text (like Mail) to omit all formatting entirely, as that flattened
version will no longer be provided.

18.4.5 Converting Notation Between Types
Both inline and linked notation can be freely converted between footnote and
comment/annotation forms. This can be used to “soft delete” notes you may
not need the reader to see, but haven’t decided on yet—or to make a note you
originally meant for yourself something that annotates the finished copy.
To convert inline notation:

1. Select the full range of inline notation you wish to convert in the edi-
tor. This can be most easily done by right-clicking on the note and using
“Select Annotation|Footnote” from the contextual menu, or by using the
Edit ▸Select ▸Select Annotation|Footnotemenu command.

2. Use the command you would use to create an inline footnote or annota-
tion to convert the type. For example if you select an inline footnote, then
⇧⌘A will turn it into an annotation, using current preferred annotation
colour.

Converting linked notation will retain its metadata in the background. Com-
ments converted to footnotes will not lose their colour assigned (though of
course it will not be used until converted back into a comment), and likewise
footnotes will remember their compiled reference number:

469



18.5. Text Colour and Highlights

1. In either the Comments & Footnotes inspector tab (where you can select
many notes at once) or the individual note’s popup window, right-click on
the header area for that note.

2. Select “Convert to Comment|Footnote”, as desired.

It is also possible to convert between inline and linked form. The Edit ▸Trans-
formations ▸ submenu contains four commands for converting between inline
footnote, annotation, linked footnote and comment format. These commands
either operate on the entire editing session in the editor at once, or within the
span of a selection of text if applicable.

18.4.6 Document links in notation
Owing to technical limitations in how inspector notes work, it is not possible to
create or store hyperlinks within them. Consequently, if you convert your inline
notes to linked notes, you will lose any internal links that had been set within
them. If you want to use links inside notes, inline notation supports the ability
to create document links within them. This is also a handy way to “hide” link
text from the final manuscript, keeping these links purely for your own benefit.

Return to chapter ⤴

18.5 Text Colour andHighlights
Arbitrary text colour can be applied to your document in a fashion similar to
any other formatting. Select the text you wish to change the colour for, and
either use Format ▸Color… (⇧⌘C), or use the text colour selector in the Format
Bar (subsection 15.7.2) to set the colour.

— The format bar will remember the last colour you have used, so it is easy
to rapidly apply the same colour to multiple text selections with a single
click.

— It will also pick up a colour when you click on text that has already been
coloured.

— If the selected text is already coloured or highlighted identically to what
the tool is set to apply, then the effect upon clicking the buttons will be to
remove the text colour or highlight.

To change the current colour in the Format Bar tool, right-click on the colour
tool or click and hold. A pop-over will appear (Figure 18.8) with the following
contents:

— Some built-in presets (black, red, etc.)
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Figure 18.8 The colour selection pop-over, showing options for the text high-
lighter button.

— Common swatches (the first swatch with a red line drawn through is “re-
move colour” choosing this one will erase any colour in the selection and
return the text to default)

— Show Colors (access to the colour window)

Setting a highlight to a range of text is quite similar, only you will use the sec-
ond colour tool on the format bar. Aswith the text colour control, single-clicking
once will re-use the last highlighter colour, and right-clicking (or holding the
button down) will access the colour pop-over.
Text highlights can also be applied with the Format ▸Highlight ▸ submenu. The

initial entry in this menu indicates the last highlight colour, giving it a shortcut,
⇧⌘H, for your convenience. The highlight menu contains the following:

— Highlight Text: applies the most recently used highlight colour again.

— Remove Color: destroys any highlighting within the selected area of text.

— The five built-in “Markers”.

— Any custom swatches you’ve saved to your system colour palette.

— Show Colors: reveal the standard colour window.
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Colours and Compiling

By default, text colours and highlights will be compiled into your final
manuscript. If you use these features for internal editing, you will find
options for disabling them in compile settings, under the gear tab (sub-
section 23.4.3). Not all word processors support text colour andhighlight-
ing features.

Scrivener provides tools for stepping through your entire project, searching
for text colour and highlighters. Read more about the Find by Formatting Tool
(section 11.6).

18.5.1 Naming Text Highlights
The default text highlight marker names can be changed to something less
generic, on a universal level, by using colour palette swatch groups. Swatch
groups are macOS’ way of letting you create selections of colours and giving
them useful names. To change the highlighter colours, show the Color Palette
(⇧⌘C), and select the third icon from the left.

Upgrading from Scrivener 2

If you have used this feature in the past to give your highlights custom
names in Scrivener 2, you will find that your associations no longer work
because Scrivener 3 has refreshed the colour palette used for highlights.
Since the capability requires precise colour matches, your references to
the old Scrivener 2 colours will need updating. You will want to remove
or rename the old “Scrivener” swatch set, using the button to the right
of the set selection dropdown, and then restart Scrivener to have it create
a fresh new set to work from.

Next, from the “Palettes” dropdownmenu, select the group titled, “Scrivener”.
You should now see something resembling the above screenshot.
Double-click on any of the provided highlights to rename it. Your changes

should be visible immediately in the Scrivener interface, where applicable.
Your own colours can be added to any of Scrivener’s various colour selection

menus, as well. If necessary, click and drag downward in the location marked
above, “Custom colour shelf”. You should see a row of white squares appear.
You can drag out as many rows as you like.
The easiest way to create new custom colours is to use either the colour wheel

(first icon) or the sliders (second icon). When you find a hue that you’d like to
use as a highlight, text colour, or annotation colour, drag from the large colour
preview area at the top of the pane, and drop into one of the empty slots in the
custom shelf.
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Figure 18.9 Scrivener’s custom swatch set

If you check one of Scrivener’s colour menus right now, you’ll see that it has
already been added below the base sets. To change the name of your custom
colour, click on the swatches icon again, make sure the Scrivener set is active,
and drag the colour from the custom shelf into the list. Now that it is there, you
can double-click to rename it.
Note that due to the way colours are estimated, if you have several subtle vari-

ations they will all get the same name. To avoid this, create a new named colour
swatch for each variation. This is a purely aesthetic feature though. Names are
not used for anything, except for your own reference.

macOS Tip

If you wish to share your colour sets with other users, or transfer them to
another computer, you will find a file in your user Library folder, under
Colors, named Scrivener.clr. Place this file into the same folder on the
second computer and it should become instantly available.

Return to chapter ⤴
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Figure 18.10 Creating custom swatches in the Scrivener set.

18.6 Marking Revisions
Scrivener uses a basic technique for marking text revisions you make, so that
they can be visibly distinctive from one another and the base text. It does so by
setting the text colour of typed text, as well as colouring editorial markings such
as over-strike and underscore.
Whenever revision mode has been enabled in a project, it will impact all areas

where formatted text editing is possible (the Scratch Pad is a notable exception,
as it is not tied to any particular project). This includes text in the Inspector,
where it can be formatted, too.
To remind you of its status, the cursor colour will be set to match the revision

level’s colour so long as it is active.

Limitations
Revision levels are not to be considered equivalent to “track changes”, as
seen in version controlled software, or Microsoft Word. They are very
simple, low bandwidth tools, that only mark modified or new text. Re-
moved text will not be marked in any way (although there are ways to
effectively do so (subsection 15.2.3). For a tool that can mark all changes
retrospectively, have a look at the Snapshot comparison tool (subsec-
tion 13.6.4).
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18.6.1 Setting a Revision Level
There are five revision levels available, in the Format ▸Revision Mode ▸ submenu.
Simply click on the coloured menu command you wish to use as your revision
mode, and begin editing the document. As you type in new text, it will be au-
tomatically coloured with the revision level. Paste text into the editor using the
revision colour with the Edit/Paste andMatch Style command (⇧⌥⌘V).
Selecting the same colour from this menu again will toggle the revisionmark-

ing systemoff. This can be especially useful if you bind these colours to keyboard
shortcuts (section A.1). E.g. if you bind ⌃2 to level two, then you could tap that
shortcut once to insert a revision, and again to return to standard editing.

18.6.2 Marking Existing Text
There are times when you may wish to mark existing text with a revision level.
The Format ▸RevisionMode ▸MarkRevisedmenu commandwill mark selected text
using the current revision level. Thismenu commandwill only appearwhen text
has been selected in the active editor.
This can also be done by clicking on the text colour tool in the Format Bar,

which will always store the current revision colour.

18.6.3 RemovingMarkings by Level
Once you have reviewed a revision pass you may want to remove the markings:

— To strip revision markings from the whole section:

1. Select the revision level to remove.

2. Without selecting any text, use the Format ▸Revision Mode ▸Remove
Current Revision Colormenu command.

This command will work on the entire text session that is in the active ed-
itor, so take caution when editing multiple documents in Scrivenings as
this command will remove them all (you can use ⌘4 to isolate one docu-
ment from the session, if need be).

— To strip out markings from a selected area of the text:

1. Select the revision level to remove.

2. Select the text in the editor that you wish to remove the markings
from.

3. Use the Format ▸RevisionMode ▸RemoveCurrent Revision Color.

If you do not see the command, ensure that the selection only contains
text marked with that revision.
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Since revision levels are nothing more than coloured text, if you happen to
have other text in your document that is coloured identically, this commandwill
strip out those colours too. In general, it is a good idea to reserve these colours
for revisions only, if you intend to use the feature heavily.

18.6.4 Removing all RevisionMarkings
When you’ve reviewed all revisions and are ready to return the document to a
default colour state, you can use Format ▸Revision Mode ▸Remove All Revisions to
strip out all revision level markings in the active text session.
The same warning from above applies: this will impact all documents in a

Scrivenings session, and any overlapping colour usage will be impacted by the
command.

18.6.5 Changing the Revision Colours
It is possible to change the colours used by the different revision levels, in the
Editing: Revision Colors settings pane (subsection B.3.3).
It is important to bear inmind that these settings definewhat colour Scrivener

uses to consider a particular range of text as marked by a revision. If the precise
shade of red is changed, then oldermarkings using the previous shade of red will
no longer be considered revision markings.

18.6.6 Finding RevisionMarkings
Scrivener provides tools for stepping through your entire project, searching for
revision levels. Read more about this feature in Find by Format and Text (sub-
section 11.6.4).

Return to chapter ⤴
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Although Scrivener is not intended to be a dedicated scriptwriting program
(for such a program you might want to try Final Draft, Fade In Pro, or Writer-
Duet, if you have not done so already), it does allow for basic script formatting
and export to formats that most scriptwriting software can read, making Scriv-
ener suitable for first drafts.

Default Scriptwriting Font

By default Scrivener will use the Courier Prime font for all scriptwriting
modes that wouldmake use of Courier as a font. Courier Prime is specifi-
cally designed for scriptwriting, using the same fontmetrics as FinalDraft
Courier and standard Courier, meaning you can rely upon using it for ac-
curate page counts. If you do not like Courier Prime, or would like to use
Final Draft Courier if you have it installed with Final Draft, then you can
create your own scriptwriting preset (section 19.7).

http://quoteunquoteapps.com/courierprime/
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19.1 Formatting a Script in Scrivener
To format a script in Scrivener, select the format you want to use from the For-
mat ▸Scriptwriting ▸ submenu, or create a new project using one of the pre-built
project templates in the “Scriptwriting” category. When in scriptwriting mode,
the top item in the Scriptwriting submenu will be checked and will display the
name of the format you are using. This preferred format can be toggled on indi-
vidual documents with ⌘8.
By default, the standard “Screenplay” format is selected and Scrivener is in

scriptwritingmode. If “ScriptMode - Screenplay” did not have the tick next to it,
then we would know that the current editor was not in scriptwriting mode (that
is, it would be in normal prosemode for general writing). You canmore easily tell
whether or not you are in scriptwritingmode by looking at the footer bar, which
will display various scriptwriting tools and hints, rather than the standard word
and character statistics display. Additionally, the binder icon for that item will
be tinted yellow, with three-hole punches on the side.
Scriptwriting mode is a setting which is individual to each document. Once a

document has been toggled to scriptwriting mode, it will remain that way until
you change it. Thus it is possible to have a standard document in one split for
your notes, while using scriptwritingmode in the second split to draft yourwork.
However, it is not possible to use more than one type of script formatting in
the same project. This is a project level setting, and so if you need to create a
stage play and screenplay at the same time, you will need to do the adaption in a
tandem project.
At the bottom of the scriptwriting menu you can see a list of all the different

script formats that are available. Scrivener comes with the following formats
built-in:

— Screenplay: The default scriptwriting format, based on a Hollywood stan-
dard.

— BBC Radio Scene Style

— BBC Taped Drama

— Comic Book (Antony Johnston)

— Comic Book (Alternative)

— Interview (a simple question and answer format)

— Stage Play (UK)

— Stage Play (US)

— Transcript (contains useful formatting for the transcription of audio/
visual material, including automated timestamp insertion, when used in
conjunction with Scrivener’s media player, in the opposing split)

479



19.1. Formatting a Script in Scrivener

You can mix up different text modes in the same document or draft, so that
parts of a documentmay be written as a script and other parts written as general
text. This makes it very easy to write treatments in Scrivener, or to intersperse
general notes with the script.
Functionally, writing with scriptwriting mode works similarly to other

scriptwriting programs (primarily, Final Draft). On the right end of the footer
bar is a dropdown menu containing the various elements for the selected for-
mat. Clicking on an element will reformat the current line to the format of the
selected element. So, for instance, if you clicked on “Character”, the current line
will be capitalised and offset from the left.
If for some reason you need to change the element type for text you’ve al-

ready entered, you can place the caret anywhere within the text you want
to change, and invoke the element menu in the footer bar, or use the For-
mat ▸Scriptwriting ▸Change Element To ▸ submenu to select a different element.
Note that when moving from an element that uses all-caps to an element that
does not, youwill need to adjust the capitalisationmanually, as Scrivenerwill not
try to guess what is appropriate. The Edit ▸Text Tidying ▸ submenu has a number
of conversion routines to aid in this.

19.1.1 Selecting the Current Element with the
Keyboard

The element selection menu has full keyboard access, allowing you to change
modes swiftly andwithout the use of themouse. Themenu itself is invokedwith
the⇧⌘Y shortcut, fromwithin a scriptwriting document. To select an individual
element style, tap the associated letter for it, printed to the right of each element.
You can also select an element directly, as each (up to the 9th)will be assigned a

number in the order that they appear in the elementmenu—the respective num-
ber is then combined with the Option and Command keys. Using the Screenplay
settings as an example, the Parenthetical format is the fourth available element,
and so it can be invoked with ⌥⌘4; a Transition is the 6th element, and so can
be invoked with ⌥⌘6 and so on.

19.1.2 Using Tab and Return to Select Elements
The footer bar tells you which element will be created next when pressing Tab
or Return. Depending on which you use, line formatting will be changed to that
of the next set element. E.g. when pressing Return after having typed in a Scene
Heading, by default the software will begin a new line set to Action formatting.
At this point, you could easily change the current element to a common alternate
(Character in this case) by pressing the Tab key. Thus the latter keywill effectively
cycle through different commonly used elements.
Once youbegin typing in text, theTabbehaviourwill often change. Withnoth-

ing typed in on a Character line, it is assumed that Transition will be the next
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most common element youmightwant on this line. But once you’ve started typ-
ing in a Character name, the next most common alternate will be Parenthetical.
These settings can all be adjusted if youfind they donot suit theway youwrite,

by default. Refer to the documentation on the Tab/Return Tab (section 19.7.2)
for further information.

How can I insert empty lines in my script?

As per standard behaviour in scriptwriting software, when you press the
Return key on an empty line a list of available elements will be provided
for you to choose from to format the current line. This use of the return
key of course conflicts with the desire to insert empty lines into a script.
The behaviour can be disabled in the Behaviors: ReturnKey settings pane
(subsection B.4.9) with Show elements list on double return in script
mode.

19.1.3 Auto-Completion
Using the built-in script settings, auto-completion is available for some ele-
ments, as is appropriate for their context. Upon choosing Scene Heading, for
instance, you can start typing with “E” and you will be presented with a options
like “EXT.” and “EVENING”. You may disable or enable (or add your own) addi-
tional items from this list by editing your script settings (section 19.7.2).1 Some
elements have been configured to do this automatically. Scene headings are a
good example. They will add anything you type in between a ‘.’ and a ‘-’ in a
scene heading line. In practice this means the part marked in bold in this exam-
ple would be added to the project auto-complete list: “EXT. THE RED LION -
NIGHT”.Whenwords and phrases are added to the project auto-complete list in
this fashion, they will be assigned a scope (subsection C.6.1) which restricts their
eligibility to only when you are typing within that element. A character name
will not suddenly pop up in the slugline, for instance. You can adjust the scope
of automatically added phrases using the main project auto-complete list.

19.1.4 Dual Dialogue
When compiling scripts to Final Draft (.fdx) format, or Scrivener’s own Print and
PDF output, you can designate text as being dual dialogue by fully surrounding
both bits of dialogue (including the character names) in a Format ▸Preserve For-
matting block. Refer to Figure 19.1 for a before and after example.
Refer to the Text Layout compile format pane for further options relating to

PDF and print output (subsection 24.6.5).

1 You should in general not use this list to assign project specific completions like named loca-
tions. It is best to use the Auto–Complete tab in Project Settings for this (section C.6).
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Figure 19.1 Use Preserve Formatting to mark dual dialogue, as shown when
printed from Scrivener.

Return to chapter ⤴

19.2 Using Page View to Estimate Page
Counts

While the point should remained stressed that Scrivener is not designed at any
level to provide a completely accurate pagination solution—with rigid format-
ting, such as that used bymost scriptwriting formats, and a fewoptional settings,
it is possible to get closer to an accurate page count, when using Page View (sec-
tion 16.2) mode.
The first thing you will need to do is switch Scrivener’s default Scrivenings

separator from a divider line to “Minimal”, which can be set in the Appearance:
Scrivenings settings pane (subsection B.5.13) via the Scrivenings Separator set-
ting. This version uses a “zero-height” display model which will not introduce
page inflation over long documents, like the standard divider will. You will also
want to disable the usage of Scrivenings titles for your project, with View ▸Text
Editing ▸Show Titles in Scrivenings, as it will likewise expand the overall height of
the document over large sections.
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Scrivenings View and Scriptwriting

When creating a scrivenings session, if the session includes amix of script
formatting documents and regular documents, Scrivener will determine
which mode to use based on the type which has the most entries in the
session. This means, if you create a scrivenings session with 4 standard
documents and 2 script documents, scriptmodewill not be on by default.
In the other direction, if there aremore scripts that standard documents,
scriptwriting toolswill be enabled in those standard documents. You can
switch modes while in scrivenings with the ⌘8 shortcut. This will only
impact (globally) the scrivenings session, and not any of the underlying
files.

Finally, you will need to ensure that the paper size is set up correctly in the
File ▸Page Setup… dialogue.
If you work with scripting formats quite a lot, you might wish to ensure that

Show page view in new projects is enabled in the Appearance: Page View set-
tings pane as well.

Return to chapter ⤴

19.3 Workingwith Final Draft
Scrivener supports Final Draft 8 or greater. Older versions cannot work with the
.fdx files Scrivener can import or export.

19.3.1 Importing Formatting from a Final Draft
Document

Optional Step

For basic scripts or those that will use Final Draft’s standard screenplay
formatting—indeed, for most screenplays—this step can be omitted, as
it is mainly concerned with setting up the formatting for custom scripts.
Proceed to the next section if this is the case.

Whenever you import a script from Final Draft into Scrivener, all of its ele-
ments will use the formatting specified in Scrivener’s script settings. These can
be set up by selecting “Script Settings…” from the Scriptwriting submenu of the
Text menu. The Script Settings panel should be familiar to anyone who uses
Final Draft.
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Given how Scrivener works with scripts, it is important that the script settings
are set up before importing or creating any script documents in the project, so
that element name can be properly matched with the imported .fdx file.2

Fortunately, this is very easy to do, as Scrivener can read the formatting di-
rectly from an FDX file:

1. Open the Script Settings panel by using the Format ▸Scriptwriting ▸Script
Settings…menu command.

2. Click on the “Manage…” dropdown in the bottom left corner of the panel.

3. Select “Load from Final Draft .fdx or .fdxt…”

4. In the open panel that appears, select the FDX file to import the settings
from.

This will not import the actual script found in that file, only its elements
and formatting for use in the current project.

5. Click OK to save the changes into the project. At this point you may be
asked to confirm conversion of any existing documents in the project.
Briefly make sure the conversions from one element to another are in or-
der.

To test the new format, create a new document, choose the new scriptwriting
format and start typing (changing elements using tab and enter or using the pop-
up menu in the footer view beneath the editor). You will see that the script uses
the formatting of the FDX file. Now that this is set up, you are ready to import
the .fdx file as a script, as described in the following section.
To save the format for future use in other projects, use the same Manage…

dropdown menu in the Script Settings panel and select “Save for use with other
projects”. The imported script format will now appear in the main scriptwriting
menu for all projects. The name that you choose for this script, given at the top
of the panel, will be used in the menu.

19.3.2 Importing FDX Files
You can import FDXfiles into Scrivener in oneof twoways. Both are fully featured
but the second option can cut up the script file into smaller scenes automatically,
creating a more detailed outline in your Draft folder:

1. Using the standard file import methods; drag and drop into the project
binder, or use File ▸ Import ▸Files….

2 Scrivener can hold many different script documents but can only use one script format in a
project at a time; this is why setting up the format must be done separately from importing a
script.
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2. With the File ▸ Import ▸ Import and Split… command, select the FDX file that
you want to import. See Import and Split (subsection 9.1.6) for further
details.

Many features will be retained: script notes become Scrivener notes, revisions
are marked up in red (level 1), highlighting is retained and so on.
If you wish the FDX file to be part of the script that will eventually be exported,

be sure to import it into the “Draft” folder, or drag it there after importing.

19.3.3 Exporting Individual Documents to FDX
To export individual scripting documents to Final Draft, select the documents
you want to export in the binder and then go to File ▸Export ▸Files… Select “Final
Draft (.fdx)” as the export format.
The exported file should open in Final Draft with all features intact.
More commonly you will want to combine all of the scripting documents in

the Draft folder of your project into one FDX file:

1. Use the File/Compile…menu command.

2. Select Compile for: “Final Draft (.fdx)” at the top of the window.

3. Select “Script or Screenplay” in the left sidebar.

4. Assign section layouts if necessary (subsection 23.3.3), and check through
the various option panes on the right-hand side.

5. Click on Compile… and choose a filename.

You should find that some formatting will be converted—footnotes & com-
ments become script notes, revisions in Scrivener carry over, and so on.

Return to chapter ⤴

19.4 Importing a Script fromOther
Programs

Because Scrivener is not a dedicated scriptwriting program, the way it han-
dles script elements is different from Final Draft or Movie Magic Screenwriter.
Scrivener recognises elements by their paragraph formatting, more like how you
might format a script in a traditional word processor. For instance, if a para-
graph has a three-inch left indent and single line spacing, Scrivener will look up
this formatting in the list of script elements, and if an element is found with
matching formatting its name will be selected in the elements pop-up button in
the footer view. If no elements match, “General Text” will be selected.
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This means that if you import a script into Scrivener from another program
andwant to continueworking on it, the script formatmode selected in Scrivener
must exactly match the formatting of the script you have imported.

Importing old Final Draft documents

Refer to the section on exchanging files with Final Draft, version 8 and
greater (section 19.3). For users of FinalDraft 7 and earlier, you can import
scripts created in Final Draft by using “Save As” in Final Draft to save your
script in “File Converter” (FCF) format, then import the resulting .fcf file.
Scrivener will try tomatch the elements in the FCF script to the elements
in the current script format. For projects that use the basic screenplay
formats, this should be all you need to do to import a script with all of its
elements recognised.

19.4.1 ImportingOther Scripts as RTF
If your script formatting was not recognised, or if you imported a script that has
no matching script mode in Scrivener, you will need to create your own format
mode that matches the script using the Format ▸Scriptwriting ▸Script Settings…
panel.
This method can also be used to recover Scrivener formatted script files, if the

original scripting settings have been lost for one reason or another.
Here’s how:

1. Export the script from your scriptwriting program as an RTF file.

2. Import the script either by dragging the RTF file from the Finder into Scriv-
ener’s binder or by using File ▸ Import ▸Files…

3. Ensuring that the script is visible in the editor, click into a line of text that
represents one of the elements you want to be recognised (for instance, by
clicking into a line of text that should be a scene heading).

4. Open the Script Settings panelwith Format ▸Scriptwriting ▸ScriptSettings….

5. Enter a title for your new format in the “Format Title” text field.

6. Select the first element in the list and give it the name you require (i.e. the
name of the element in which you placed the cursor in step 3) by double-
clicking into it and editing it if necessary.

7. From the Manage… dropdown menu in the Script Settings panel, select
“Use current font & paragraph settings”. This will copy the font and para-
graph information from the line of text inwhich the cursor has beenplaced
in the editor into the Font and Paragraph panes of the Script Settings
panel.
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Repeat this process, matching the settings for the elements in the Script Set-
tings panel with the text in the editor for each element in your script.
Be sure to save your script format for use with other projects using the Man-

age… pop-up button at the bottom of the Script Settings panel.
You can then use your new formatwith all projects in the future for any scripts

you import. Once you have successfully created your own script format mode,
all of the elements in your imported script should be recognised in the pop-up
button in the footer view of the editor, and you should be able to use the script
mode to continue editing your script. Note thatmore complicated script formats
may require a littlemore tweaking to be recognised, but the above process should
work for most.
If you do create a script format mode that recognises elements from an im-

ported script, please use “Save to file…” in the Manage… pop-up menu from the
Script Settings panel to save your format as an XML file somewhere safe on your
hard drive so that you can back it up and load it on other machines or following
a hard drive reformat if necessary. Also, please feel free to upload such format
files on the forums, where other Scrivener users may find them useful—or from
where you can always download them again should you lose them.

19.4.2 Importing Plain Text Formatted Screenplays
A number of screenplay-oriented programs (such as Movie Magic Screenwriter)
support what is known as a plain-text formatted screenplay. Since the roots of
this format come from the days of the typewriter, everything about the format
can be reproduced with plain-text spaces and characters.

Looking for Fountain Support?

Plain text screenplays are not Fountain files. They in fact look just like the
screenplays you’ll be printing from software like Scrivener or Final Draft.
Refer to Working with Fountain (section 19.6) for tips on importing files
in this unique form of markup.

Scrivener is capable of both creating (subsection D.5.4) and importing these
simple files:

1. In the binder, select the location to import the screenplay.

2. Use the File ▸ Import ▸Plain Text Formatted Screenplay… menu command to
bring up the file selection dialogue.

3. Navigate to and select your .txt file on the disk and click the Open button.

By clicking the Options button in the lower left of the import dialogue,
you can choose to have the imported script split by scene, into individual
binder items, rather than as one log file.
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An alternative method is to paste plain text screenplays into Scrivener, with
the Edit ▸Paste Plain Text as Screenplaymenu command. This must be done into a
document that is using script mode (⌘8).

Return to chapter ⤴

19.5 Printing or Exporting a Script
You can use the compiler to print your script (or to turn it into a PDF file). For
examples of how to do this, take a look at one of the scriptwriting project tem-
plates by going to File ▸NewProject… and selecting a project template such as the
Screenplay template. Read the instructions that come with the template to see
how to set up your project so that it is formatted properly when printed (or ex-
ported).
In the majority of cases, just as you would with many other types of writing in

Scrivener, you will want to export your script from Scrivener so that you can do
all the final formatting in a dedicated formatting program such as FinalDraft, see
Exporting Scripts (subsection 23.5.2) for information on how to use the Compiler
to export to many popular scriptwriting programs.

Return to chapter ⤴

19.6 Workingwith Fountain
Fountain is a simple markup language (based loosely uponMarkdown) designed
for screenwriters who need or prefer to work in a plain-text environment. Foun-
tain makes composing and editing easier, without losing the individual mean-
ings behind the elements (character name, action, transition, etc.). From the
Fountain website:

Fountain is a simple markup syntax for writing, editing and sharing
screenplays in plain, human-readable text. Fountain allows you to
work on your screenplay anywhere, on any computer or tablet, using
any software that edits text files.

Taking its cues from John Gruber’s Markdown, Fountain files are
eminently readable. When special syntax is required, it is straight-
forward and intuitive.

Even when viewed as plain text, your screenplay feels like a screen-
play.

Fountain supports everything a screenwriter is likely to need in the
early, creative phases of writing….
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Fountain is for Screenwriters
One important detail to remember is that Fountain has been designed for
screenplays. Using it with other scriptwriting formats is not supported as
it may work unreliably or not at all. If you do wish to try using Fountain
with another scriptwriting format, all you need to do is make sure that
the elements (section 19.7) are named precisely as they would be in the
standard screenplay format.

When importing or syncing Fountain files, they will be processed and con-
verted to Scrivener’s internal scriptwriting system. There is no need to use the
markup conventions while writing within Scrivener. The following additional
conventions will be converted to Scrivener features:

— Boneyard markers: text found between /* boneyard markers */ will be
imported into Scrivener as struck-through text (and struck-through text
will be exported in boneyards).

— Dual dialogue: when using the syntax for dual dialogue it will be con-
verted to Scrivener’s convention of placing the characters and dialogue in
question in a Preserve Formatting block (subsection 19.1.4). Likewise adja-
cent dialoguemarkedwithPreserve Formattingwill bemarked in exported
Fountain files.

— Script notes: when importing, text marked as a script note that appears en-
tirely on its own line(s) will be placed as an inline annotation. Otherwise,
when script notes are added to text that is otherwise an element, they will
be anchored to the nearest word and linked as comments in the Inspector.3

Scrivener uses inline annotations in cases where script notes are on their
own paragraph to avoid potential problems with removing the text and
causing elements around that text to lose their syntax. For export, all an-
notations and inspector comments will be converted to script notes, if you
opted to include them in your settings.

Scrivener can import the Fountain format using two different methods:

— As a whole script: merely drop the Fountain file into the binder. Scrivener
looks for the ‘.fountain’ extension, so make sure the file has had its exten-
sion changed accordingly, otherwise the file will be handled as plain-text.
When properly handled, all elements should be imported and formatted
automatically to the screenplay script format.

3 If you prefer one form of annotation over another, you can use the Edit ▸Transformations ▸ sub-
menu to switch between styles.
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— Split up into scenes: as with Final Draft files, use File ▸ Import ▸ Import and
Split… to select the file. Again, itwill need a ‘.fountain’ extension to be prop-
erly recognised and imported. This will result in a new binder item being
created for each discovered slug-line. If a section header has been typed in
immediately prior to the slug-line, it will be used to populate the binder
item title4. Fountain synopses texts will be gathered from throughout the
scene and combined into Scrivener’s own synopsis index card. Read more
about Import and Split (subsection 9.1.6).

For integrating with a mobile device, Fountain is a selectable format in the
folder synchronisation feature (section 14.3).
In addition to syncing and exporting, projects can be compiled to the Fountain

format.

Return to chapter ⤴

19.7 Creating YourOwn Script Formats
Scrivener comes with a number of script formats built in. You can also create
your own script formats tailored to your own requirements; as well as export
and import script modes for sharing on the Internet.
To create your own script format mode, use the Format/Scriptwriting/Script

Settings… menu command to bring up the script editing interface. At the top
of the panel is the Format Title text field (Figure 19.2), marked (a). Enter the
name of your format, as it will be displayed in the main menu, should you save
these settings for future use beyond the current project.
On the left side of the panel is the Elements list, marked (b). Here you define

the parts that make up your script, such as “Scene Heading”, “Dialogue” and so
on.

— You can add new elements and delete existing ones using the + and −
buttons beneath the list, and you can rename elements by double-clicking
them.

— Reorder elements by dragging and dropping them; this will change their
numerically based keyboard shortcut assignment.

— The “General Text” and “General Text (Centered)” elements are displayed
while working on the script in Scrivener, but will not appear here as they
have no special properties by definition—they merely represent text not
assigned to an element in this list.

4 Note that while Fountain has support for multiple levels of depth with its header syntax, Scriv-
ener’s scene import will produce a flat list.
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Figure 19.2 All aspects of script formatting and behaviour are established in
the Script Settings window.

The large tabbed areamarked (c) is where the settings for the current element,
selected in the sidebar, can be viewed and modified. We will cover each tab of
settings in this area of the manual.
If you need to use a system of measurement other than inches, use the drop-

down menu in the lower right-hand corner to change the Units.
Clicking OK saves the script format into the current project package only. This

means that if you share your .scriv project with someone else, they will be able
to use these settings without having to install anything. No further actions are
necessary unless you wish to export your script to other projects or machines.

19.7.1 Managing Scripts
In the bottom left-hand corner of the script settings panel is a dropdown menu
entitledManage…. Themenu provides several management functions not found
elsewhere:

Reset to defaults Reverts all customisations that you have made to the Script
Settings panel to the Screenplay default. If you wish to revert to a saved
script setting, simply select that script from the Format ▸Scriptwriting ▸ sub-
menu, instead of using this tool.
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Use current font & paragraph settings Attempts to import all available charac-
ter and paragraph level formatting attributes from the editor into the cur-
rently selected element in the above element table. This can be quite useful
when you have imported a script from another program andwish to create
a script format from the existing text. Simple click through the document,
locating element types, and use this tool to import the correct formatting
into each element type.

If you have a file in Final Draft 8 format or above, you will want to use the
“Load from Final Draft” tool, mentioned below, for scanning .fdx files for
types, rather than doing all of this by hand.

Load from file… Loads a Scrivener script format file from the disk. Use this if
you have downloaded a script from the Internet, or are in the process of
transferring formats from one computer to another.

This will not install the saved script into your Scrivener support folder,
it will merely import the settings into this one project. Use the “Save for
use with other projects” command, following this one, to install it system-
wide.

Load from Final Draft .fdx or .fdxt file… Scrivener can examine an existing Fi-
nal Draft or Final Draft Template file for formatting rules and names, and
attempt to convert them to Scrivener’s internal script formatting.

Save to file… Saves your current settings to an external file that you can eas-
ily backup, upload to the Internet for sharing, or send to another of your
computers.

Save for use with other projects Installs the project’s current script settings to
your system for usage in all of your projects. If you wish to share the file
with others, or transfer them to another computer, use the “Save to file…”
option to more easily create an accessible file for sharing.

19.7.2 Format Tabs
On the right of the panel is a tabbed view containing all of the options used to
configure each element. Select the element from the list on the left, and then
select the appropriate tabs needed to make your adjustments. This section will
describe the settings available in each of these tabs.

Font Tab
The Font tab provides options for setting the character appearance for the se-
lected element, as follows:

Font Set the font family for the current element, and the size of the font (in
points) to the right. Scrivener does not use the font to identify elements, so
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you can change the font here without messing up Scrivener’s recognition
of script elements. This also holds true for font changesmade in the editor.

Scrivener comes with Courier Prime installed within it, and will use it by
default over the standard system Courier. If you have Courier Final Draft
installed on your machine, it will however prefer that font.

Style Provides a number of options for determining the appearance of the cur-
rent element, mostly self-explanatory. The All caps style option will con-
vert the literal text case to all caps, rather than simply displaying it that
way. Be careful when experimenting with this setting on existing text, as
it is not possible to convert capital letters back to whatever they were be-
fore conversion.

Style to Defines how much of the line to apply these settings to:

— End of line: the default setting; styles the entire paragraph from start
to finish.

— First tab: the elementwill be styled up until pressing the Tab key. This
accommodates formats such as the UK stage play format, which has
character names anddialogue on the same line, with character names
in capital letters followed by a tab and dialogue in normal case.

— Character delimiter: provide the characters in the text field to the
right. For instance, if you entered a colon in the text field, the ele-
ment would only be capitalised up to the first colon.

Italicize text after style delimiter When Style to is set to anything other than
“End of line”, the remainder of the text on the line will be italicised.

Colour and Adornment Two further options can change the appearance of el-
ements:

— Color: The text of this element will use the specified colour. Click on
the colour chip to select a colour using the palette.

— Parenthetical: automatically encloses the current element in paren-
theses.

Menu shortcut Enter the single letter or number that will be used within the
script elements menu (⇧⌘Y) as a shortcut key.

Paragraph Tab
The paragraph tab provides paragraph formatting for the selected element:

Alignment Sets the current paragraph alignment (left, centred, right or justi-
fied).
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Spacing Sets the line-height multiplier (single, 1.2, 1.5 or double). Some script
formats (such as Screenplay) will have a Fixed Line Height setting, behind
the Options button in the lower right-hand corner of this pane. You will
need to set the fixed line height to 0pt to disable that feature, before seeing
any effect on this setting.

Spacing Before Sets the number of blank lines to appear between the current
and previous line.

Ruler Conversions
When working with units in Scrivener, bear in mind that its ruler starts
at margin zero instead of paper zero. Since Scrivener is, by and large, not
“aware” of paper settings and page layout, it counts its ruler settings from
the beginning of the text on the left end of the page, not the beginning
of the paper itself.
Consequently, to convert most standard measurements to useful val-

ues, you will need to factor in the standard amount of print margin used
to print the script. For example, if the SceneHeading is specified to begin
at 1.5ins from the edge of the paper, you will need to subtract the margin
of 1in from that to get 0.5ins.

Indent and Tabs Allows simple customisation of the ruler settings for each ele-
ment.

— First Line Indent sets the offset of the first line the paragraph.

— Left Indent: sets the left indent of all lines following the first. To
create a uniform “block indent” look, set this value identical to the
First Line Indent.

— Right Indent: sets the right indent of the paragraph (as measured
from the left margin, so 6.5ins will fall at 7.5ins when printed, or one
inch away from the right edge of the paper on US Letter).

— First Tab: sets the first tab stop of the paragraph.

Options

Further options for advanced paragraph settings and compile output options for
this element are accessible by clicking on the Options… button in the lower-left
corner of the tab:

Writing direction Set right-to-left, left-to-right or “natural” (detect based on
the system language input settings).
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Fixed Line Height In most cases this should be set to the font size in use (12pt
by default), to keep lines absolutely consistent, as is expected in most
scriptwriting standards.

This should be disabled if you need to use the Spacing setting in the
main Paragraph tab—but do note this comes at a risk of line-heights being
slightly different from Final Draft measurements. You will also want to
disable this feature if you intend to use a font that deviates from Courier
12pt, as font clipping can occur with larger fonts.

Default Tab Interval Similar to theDefault tab spacing setting in The Tabs and
Indents Tool (section 15.7.1). This sets the default tab spacing, rather than
inserting physical stops you can see and move around on the ruler. Set to
“0” to disable.

Minimum number of tabs Ensures that therewill always be the indicated num-
ber of tab stops on a line, if less than that amount are created manually.
This helps to avoid cases where long character names in stageplay format-
ted scripts could cause Tab to advance to the next line.

Keep with next paragraph Strive to keep this element bound to the following
paragraph in cases where the twomight become separated by a page break.

Add prefix when compiling Inserts text in front of anything else you type in
yourself. This will most often be useful in conjunction with a placeholder
counter that numbers elements, but the choice is yours. In particular, take
a look at the <$np> tag, which counts by numeral (1, 2, 3…) and resets itself
automatically on each page (when using print/PDF).

Only add prefix when compiling to print/PDF Mainly useful when using the
aforementioned placeholder counter, which only works with these two
compile types.

Sequential numbering This is the option you are looking for if you need a way
to number your scene sluglines, using the standard method of placing the
number along the very outside edge of the typing area. This can be an oth-
erwise difficult look to achieve with Scrivener, since you ordinarily cannot
place text outside the physical margin area of the page.

Numbering can be done “against left margin”, “against right margin” or
“against both margins”. Set to “None” to disable this feature.

Tab/Return Tab
The Tab/Return pane provides control over Tab and Return key behaviour for the
selected element, which can be used to aid in the flow of writing. If you are
creating a scripting environment from scratch, you might wish to save this step
for last, since you will need to reference other elements (which may not exist
while you are going through the list, initially).
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On return Sets which element formatting the text will use when you hit the
Return key. Using Screenplay as an example, the “Scene Heading” element
will advance to the next line and select “Action” as the active element for
it.

Use the Add colon before return option if the script format dictates sepa-
rating these two elements with that character.

The options in the “Tab behavior” section concern how that key will behave
when used in lines of this element:

Allow tabs If this is checked, the tab key works as it would normally, that is, it
inserts tabs. With this checked, noneof the other options for tab behaviour
are available.

Tabbing on an empty line Choose an element from the Go to dropdown to set
which element will be selected when you hit Tab on an empty line. This
facilitates switching to a common alternate element. For instance, in the
Screenplay format, if you are at the beginning of the line using Dialogue,
you can hit the tab key to switch to Parenthetical instead.

Tabbing after typing Selects which element to jump to next from the Go to
dropdown (inserting a new line automatically). Use this to provide a con-
venient secondary behaviour, where the primary behaviour is usually as-
signed to the Return key.

Insert Both of the tab options here provide for an alternate behaviour of insert-
ing text when pressing Tab. By providing text in either of the Insert fields,
the Go To behaviour will be disabled. E.g. hitting Tab after typing some-
thing in a Scene Heading element automatically inserts a hyphen so you
can enter a chronological marker.

This field accepts the placeholder tag, <$mediaPlaybackTime>, which will
insert the current playback time for the active media player in the other
split. If no media player is currently available then the placeholder will
print question marks instead. The “Transcript” script format, meant to be
used for transcribing interviews, makes use of this placeholder.

By default the placeholder will use the time format specified in the Behav-
iors: Playback settings pane (subsection B.4.8), under Media time stamp
format.

Auto-Complete Tab
The Auto-Complete tab allows you to set a custom list of words that will appear
for auto-completion while typing in the current element.
These entries are intended for generic or broadly used phrases that are specific

to each element type (such as “V.O.” in a character line). If you’re looking for a
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way to add names and phrases specific to a particular script, the project’s own
auto-complete list is a better place for them (section C.6).
By default, these phrases will be suggested automatically as you begin typing

in matching letters. For each entry, you can check the “Go to Next Line” box,
whichwill force the editor tomove to the next element (as it would if you pressed
Return) once it has been entered.

— Add a new entry to the list: select where you would like to insert the new
entry, then click the+ button, or press the Return key.

— Removing entries: select the row to remove and click the− button or press
the Delete key on your keyboard.

— Editing entries:

– Start editing a selected row by double-clicking on it.

– Confirm editing by clicking outside of the field or pressing the Return
or Esc key.

Include project completions for this element Automatically include a project’s
auto-complete words when providing suggestions. When disabled, this
element will only offer completions from the list above.

Automatically add phrases to project list that occur… In the following fields
provide two characters to help in isolating useful part of a phrase (such as
locations and character names) from the text surrounding them. If a field
is left blank, then anything on the line will be used, up to any character
defined in the opposing field.

An example for the Character element would be to add anything typed
into the character field prior to an open parentheses, and thus avoiding
such common markers as “(O.C.)”.

After project list completions When a project list auto-completion has been
used, you can set up the scripting system to do nothing, go to the next
line, or insert a tab.

To againuse theCharacter element, if you select a character name from the
project list it will automatically advance to next line (Dialogue by default).

Return to chapter ⤴

19.8 Using Script Formatting forOther
Purposes

While the Scriptwriting mode was originally designed for scriptwriting, it de-
serves mention that it is at its heart nothing more than an automated styling
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engine. This means it can be used for a variety of purposes having nothing to do
with scriptwriting.
We have included two such examples in the software:

— Interview: a simpleQ&A format using alternating boldface and normal for-
matting, as is common for indicating dialogue between an interviewer and
interviewee.

— Transcript: if you are transcribing from an audio or video file and need
to make notation of the timestamps at each point of dialogue, this script
format will make that easy.

To use this script mode, you will need to have a media file loaded in a sec-
ond editor split. Pressing Tab on a new “Time & Text” or “Speaker, Time
& Text” line will insert the current media time stamp. Refer to Viewing
Multimedia Documents (section 8.1.3) for further transcription tips.

If you need to create a procedurally formatted document where cascading and
switching between structural types would be of benefit, then consider using the
Scriptwriting engine to create you own format from scratch.

Return to chapter ⤴
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20.1 Goals and Statistics Tracking Tools
At some point, most writers will need to get some idea of the progress of their
work by checking the word, page count or characters. There are several ways of
doing this in Scrivener, depending upon the scope you require:

— To get detailed statistics and word frequency tabulation for the whole of
the draft (that is, the contents of the Draft folder as it will compile given
the current settings) use Project ▸Statistics… and click on the “Compiled”
tab.

— For stats on the current document or selected items, click the “Selected
Documents” tab from the same Project ▸Statistics… panel.
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— To set a target word or character count and track your progress for the
entire draft or the current writing session, use the Project ▸Show Project
Targets menu command, or hold down the Option key and click on the
Quick Search field in the main application toolbar.

— To set a target word or character count and track your progress for a sin-
gle document, click on the target button in the bottom-right of the footer
view (this is not available in scriptwriting mode, where word and charac-
ter counts are rarely useful anyway). See information on the footer bar for
more information (subsection 20.1.2).

— Tracking a group of documents together as a cohesive unit, like say a se-
quence of sections and sub-sections within a folder, where the important
detail is the word count of the entire folder is possible.

– You can use the Outliner to view the Total Progress and Total Goal
columns, to aggregate statistics for group of documents.

– Setting a target on the chapter folder will, even if it has no text itself,
work as an aggregate in Scrivenings mode, since child items will be
included in the totals. Thus all words written to any subdocuments
of it will count toward that aggregate goal, even if they themselves
do not have individual goals. Targets for folders can be easily set by
using the Target column in the Outliner, or by selecting the folder in
the Binder, switching off the current group viewmode, and using the
target button as per normal in the text editor footer bar.

— To get the word or character count for a selection of text, select some text
in a document and examine the footer bar of the editor. The word and
character count will appear in blue text. When there is no selection, this
area will be used to count the entire document or Scrivenings session.

— To view a combined word and character count of an arbitrary selection of
documents, use the outliner or corkboard to select several documents, and
then right-click on the selection. The combinedword and character count
for those documents will appear greyed-out at the bottom of the contex-
tual menu. Note this method only counts texts within the actual selec-
tion, not the implied selection in the case of children beneath the selected
items. To count them as well, use the Edit ▸Select ▸Select with Subgroups
menu command.

20.1.1 Project Targets
The project targets panel allows you to set goals for your writing—either for the
Draft as awhole or for the number of words youwant towrite during the current
session—and to check on your progress as you work, whether to grow the word
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count or trim it down. To bring it up, select Project ▸ShowProjectTargets or press
⇧⌘T to toggle its display.

Figure 20.1 The blue progress bar shows overall progress for the project, while
the green progress bar indicates the writer has achieved their ses-
sion goal and is now writing in surplus.

The targets panel displays two progress bars: one showing the progress of the
draft and the other showing the progress of the current session.1 Using this panel
you can set a target word count for the draft, or presumably your current work-
in-progress, and independent goals for the current session.
To set up targets:

1. Click in the appropriate text field—marked above or below (a) in Fig-
ure 20.1—and enter your target.

2. Set whether the target should be in words, characters or pages by clicking
on “words”, to the right of the number fields.

This panel will float over your project if you leave it open, and update itself in
real-time as you write and edit. By default, the Quick Search tool in the toolbar
(subsection 11.5.3) will also display small progress bars correlating to this informa-
tion, so you needn’t keep this panel open if all youwant is a small visual reminder
of how far you have yet to go.2

1 By default it will automatically reset shortly after midnight, but there are options available if
you find this inconvenient, discussed in the following section.
2 If you want to track a goal for an individual document, rather than the entire project, use the
Document Goals (subsection 20.1.2) tool in the footer bar.
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Using targets to hit an editing goal

The targets tool needn’t only be aboutwritingmorewords to reach a goal,
it can also be used to establish aword count you’d like to cut down to. Use
the Show overrun setting, discussed in the following section, to make it
so a secondary progress bar will inform you as to how far over the target
you are.

The following describe what constitutes “writing activity”, for the purposes of
what the session tracking tool monitors:

— If you delete lots of text, session statistics will not start showing any
progress until you have written as much again—it is perfectly possible to
have a negative session word or character count! In other words, it shows
your net gain during the session.

— Additionally, the session target only counts text that has been typed or
pasted into a main text area, it does not count imported documents, du-
plicated sections, appended text and so forth.

— The basic rule of thumb is that if what you did to add or remove text was
done inside of the text editor, then it will be added or subtracted from the
count. If you used menu commands to move, generate, duplicate or copy
text then it will not be counted.

If you find yourself in a situation where you want to start fresh, because the
counter is off, you can use the Reset button above the Session Target progress
bar to reset the counter to zero.

Project TargetsOptions
Click the Options… button in the Project Targets panel to configure how these
progress bars are calculated, andwhat Scrivener should do if youmeet your goals.
There are a few common options available at the bottom of the pane, below the
tabbed areas:

Show target notifications System notifications will be posted when the status
of your targets change. For example if you achieve thewriting goal for your
current session. Notifications will be posted for the following conditions:

— The draft or session goal has been achieved.

— Editing you have done has cause the count to dip back under the re-
spective goal.

— When Show overrun is enabled in the “Draft Target” tab, if you go
over the allowed amount you will be alerted.
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— Likewise youwill be alertedwhen you edit back downunder themax-
imum allowed amount.

Show Twitter button If you do not use Twitter you can remove the button.3

Draft Target

Count current compile group only When enabled, only those files descending
from the “Compile” group selection, designated in the contents tab of the
compile settings area (subsection 23.4.1), will be counted. By default this
will be the entire “Draft” folder, but it can be set to any subfolder, or even
to dynamic sets of files such as the results of the last project search you
ran, or your current binder selection.4

This setting only pertains to the compile group selection itself. Filters that
subtract from the group or the front and back matter features, which add
to the group, will not be considered by the Targets tool.

Only count documents set to be included in Compile Exclude any texts that
do not have the “Include in Compile” checkbox set (subsection 13.5.1).

Show overrun Modifies the behaviour of the progress bar so that once you
achieve your goal, a second progress bar (in bright red by default) will begin
to advance from left to write, depicting how many words over your target
you are. This can be a great tool when editing, and looking to trim the
overall word count down by a certain amount.

Overrun allowance This subsidiary option to the above provides a threshold by
which you can exceed your stated goal before triggering the overrun con-
dition and seeing the red progress bar appear. This value subtracts from
the overrun amount—in effect once an overrun condition is reached, then
the progress bar starts counting from one on up. Thus a goal of 100,000
words with a threshold of 1,000 will consider your overrun amount as be-
ing only “10”, if your draft has 101,010 words.

Deadline When active, adds a countdown toward the days you have left at the
bottom of the target window. This can also be used to calculate howmany
words youneed to continuewriting per session in order tomeet your dead-
line, in the Session Target tab.

3 This option will not be available in macOS 10.14+, as Apple removed Twitter integration.
4 In the case of collections and search results, the list of items designated to be counted will only
be refreshed after visiting the compile overview, even if only to load the pane and then cancel it.
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Session Target

Reset session count There are four available options for how the session
counter should behave. The counter can be reset every time a project is
closed, you can have it track the time of day and reset it for you, or turn off
automatic reset entirely and handle it manually with the reset button.

— At set time each day: the default behaviour is to reset the session target
at 1:00 in the morning. This will occur even if you are writing mid-
sentence, so if you’re a night owl youmight want to change when the
reset happens, or use one of the other options.

— On project close: if you prefer to consider a session concluded when-
ever you close down a project then this will be the best option. If
you prefer multi-day sessions or perhaps prefer short writing bursts
throughout the day, this will be a good option for you.

— On next day opened: with unusual schedules, such as those whowrite
well after midnight and unpredictably so, this alternate method of
reset may work better. It will check against the last time you opened
the project, and if the calendar day has incremented since then it will
reset. Thus, if you open the project at 22:00 and work until 03:00,
when you open the project later on that day at 13:00, it will reset since
you last opened the project on the prior day at 22:00. If you start an-
other session that night, however, it will not reset, since the last time
you opened it was at 13:00 on that same day.

— Never: Scrivener will never alter the session progress counter for you.
You will need to use the Reset button to start a new session. This is
the best mode if you tend to work sporadically all around the clock
in short bursts, or tend to set aside a “session” for a few days to deal
with other tasks.

Count text written anywhere in the project Turning this on will count any-
thing you type or paste into the any document in the project binder, even
if it is a character sheet or a grocery list.

This setting also impacts whether documents that are not marked as “In-
clude in Compile” in the inspector are counted. When this setting is off,
such documents will not be counted even if they are in the draft folder. If
the option is enabled, even those documents marked as excluded will be
monitored as you write.

Allow negatives When disabled, the session counter will never drop below zero.
Leave this on to get an accurate net total of your writing session. When
disabled, deletions will still be counted, but only until the counter reaches
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zero, so some deletions would no longer be counted after that point, mak-
ing it less accurate for calculating the true net.

Automatically calculate from draft deadline Requires the Deadline option to
be enabled in the “Draft Target” tab, and the countingmethod to be either
Words or Characters (set in the main Targets panel itself).5 When a dead-
line has been set, you can have Scrivener handle the calculation required
to meet your deadline given the amount of time left. For example, if you
are at 85k words in a 100k draft and have 10 days left to finish, then Scriv-
ener will set your daily session goal to 1,500 words per day. If you come
in under or over that goal, Scrivener will adjust the daily session target
whenever the session count for any reason.

Writing Days By default, all days are considered eligible for writing, for the pur-
pose of calculating your daily goal against the deadline. If you cannotwrite
every single day of theweek, simply click on the days you canwrite, and the
feature will adjust the calculation so that you don’t end up writing below
the curve.

Allow writing on day of deadline The calculator typically will not schedule you
to bewriting on the actual deadline day. If youwant the system to give you
up until the last minute, check off this box.

20.1.2 Document Goals
Each document in your binder is capable of storing its own independent goal,
which can be a great tool if you’re trying to ration out how many words the dif-
ferent sections of your draft should have. To set a goal for a document, click the
target icon on the right hand side of the footer bar (Figure 20.2).

Figure 20.2 Click the “bull’s eye” target icon to set a goal for this document.

When a goal has been set the target button will turn into a small progress bar
that will fill up as you type, turning green, by default, once you exceed the goal.
Trimming sections down in the editing phase instead? You can also set an

overrunwarning, whichwill use a different colour to showhow far over the target
you are.

5 This is down to technical limitations in howpages are calculated in Scrivener rather than some-
thing that can be easily quantified as you type in snippets of text here, there and everywhere
throughout the binder or draft folder. This is why session counts cannot be calculated by page
either.
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Target for this document Sets the goal for the current document, as either
words or character counts. If you select a different unit of measurement
than what is being displayed in the footer bar, no x/y information will be
shown, but the progress bar will still show your relative progress.6

Minimum target This alternate mode of usage will draw a small indicator on
the progress bar at the declared minimum, and until you reach that point
the progress bar will use the Overflow Color (red), switching to the Start
Color (blue) as soon as you reach your minimum goal.7

Show overrun With this enabled, instead of the progress bar merely switching
to the End Color (green) once you exceed the goal, it will start filling up
again from the left, this time using the Overflow Color, thus indicating
the relative amount of text in excess of the goal. This can also be a useful
editing tool for trimming down the word count.

Overrun allowance Rather than going into overrun mode immediately, this
sets a threshold before the warning bar kicks in. For example if you set
a goal of 600 and an overrun allowance of 50, the bar will remain green
from 600 to 650, but as soon as you hit 651 the overrun state will kick in.

Show allowance in progress bar If an overrun allowancehas been set, a tickwill
be added to the visual progress bar that marks the actual target of the doc-
ument, with the remainder of the progress bar showing how far you can
continue writing before going into the red. As you write into this thresh-
old, it will fill up until the document goal plus the overrun allowance has
been exceeded.

Show target notifications Show notifications when you reach different states
in your progress. The various options above all add additional notification
states. With everything enabled, you will be alerted when you reach your
minimum goal, when you reach the overall goal, when you go over your
goal—and then all in reverse as well as you edit back down through the
different stages.

6 You can change the footer bar to show the stats relevant to your work, with the Live counts
show option in the Editing: Options settings pane (subsection B.3.1).
7 These progress bar colours can be changed in the Appearance: Targets: Colors settings pane
(subsection B.5.15).
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Need a bigger picture?

You may also monitor and set goals using the Outliner, by revealing the
“Target”, “Target Type”, and/or “Progress” columns, with the “Total Goal”
and “Total Progress” columns showing an aggregated goal count and total
progress by level, adding up all child items. In this way, you can easily
work toward chapter or other larger section goals, while still maintaining
a fine-grained approach to cutting up the section into smaller pieces.

To disable goals for a document, enter a value of “0” into the Target for this
document field for the document.

TrackingGoals for Groups
When using Scrivenings mode, a progress bar will show the sum of all goals set
by individual documents within the session. The progress bar then becomes a
“total progress” tracker, adding all of the goals and various settings together and
using the grand total in the editor against that goal.
Anotherway ofmaking use of this capability is to set a single goal on the group

that contains the files as awhole. For example if you load the chapter folder itself
into the text editor you can set a goal for the entire chapter and not worry about
having to set individual goals for each section of text within the chapter. Now
whenusing Scriveningsmodeon the chapter, youwill be providedwith a sensible
goal with all of the constituent parts of the chapter.

20.1.3 Statistics
Project and text statistics canbe calledup at any timewith the Project ▸Statistics…
menu command (⇧⌥⌘S). This pane has two info tabs and some options:

1. Compiled: this will list statistics for a total reckoning of all documents in
the Draft, modified by any compile filters that have been applied to it (sec-
tion 23.4.1). By default, this does not include setting the compile group to
only a subset of the Draft. Thus youmay compile one chapter for proofing
while still using this tool to keep track of the larger work.

2. Selection: a count of those documents you have selected in the binder or
any group view, including the current and active Scrivenings session. This
accounting by default also includes subdocuments of the selected items.

508



20.1. Goals and Statistics Tracking Tools

Upgrading from Scrivener 2

Looking for “Text Statistics” pane from previous versions of Scrivener?
The “Project Statistics” and “Text Statistics” panes have been combined
into a single feature, Project ▸Statistics… (⇧⌥⌘S), with two tabs. The lat-
ter now has every feature the former once had exclusively, and vice versa.
To get statistics on a single text document, view it in the editor alone and
then use the “Selected Documents” tab. You can click on statistics in the
footer bar of the editor and get much of the same information provided
here.

Eachof these sections have identical statistics available to them,most ofwhich
are self-explanatory and will not be documented here:

— Documents: lists the total number of binder items being used to generate
the statistics. This includes items that are not contributing to the count,
such as empty files.

— Pages (Paperback): this is an estimate, using an industry standard formula
(for English language publishing) of taking the average number of words
per page and multiplying it by the average number of characters per word
(five including a space, for six total), the product of which is then used to
divide against the total character count of the project. By example, a book
with 714,000 characters with an estimate set to 350 words per page will
produce a result of:

714000

(350× 6)
= 340

pages.

Options for tweaking the algorithmare located in the “Options” tab, under
Page count options.

— Pages Printed: this counter will be more accurate as it will compile your
draft in the background, using the specified formatting and other content
settings, and then count the total pages resulting from that. It requires the
accuracy model be set to “Accurate (Slower)”, as described below.

— Reading Time: this is a simple calculation based on an average 250 words
per minute.

The Word frequency section at the bottom will provide a complete concor-
dance of every word found within the relevant texts being counted, along with
how often the word has been used. By default the list is sorted alphabetically,
but by clicking in the column headers you can sort by “Count” in ascending or
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descending order.8 Words from this chart can be selected (using Cmd and Shift
clicking to select individual words and ranges of words, respectively;⌘Awill se-
lect all) and copied and pasted as tab-delineated text, suitable for use in a spread-
sheet for more thorough analysis.
At very the bottomof the pane, alongside theOKbutton, is a dropdown that se-

lects between two different accuracymodels. Accuracy pertains to how all statis-
tics are gathered:

— Accurate (Slower): to accurately count all relevant text, and particularly to
paginate properly, Scrivenermust internally generate a compile document
based upon your compile settings. In large projects, the panel will auto-
matically switch to Estimate, to avoid long waits when checking statistics.

— Estimated (Fast): thismodel uses the fast internal search index to count the
relevant text. This means all alterations made to the text during the com-
pile process will be disregarded, and a true page count will be unknown,
but in larger projects this will be the only viable option, and is thus the
default setting.

Project StatisticsOptions
To access options for how project and selection statistics are calculated, click the
“Options” tab in the window. The first group of settings, under the “Compiled
Statistics Options” heading, impact how the statistics in the first tab of this pane
are calculated:

Count current compile group only Only calculates from documents that have
been selected via the compile group dropdown in the Content pane of the
Compile interface. This is the only compile-time option that can be dis-
abled. All other compile options that restrict or modify output quantity
will still be factored into the count.

Count footnotes Footnotes are by default included in the count. If your pub-
lishing environment demands these be considered separate, here is where
you can disable them in the total count.

The second group of options, “Selection Statistics Options”, impact how
statistics for the second tab in this pane are calculated:

Count all documents In this context, “all documents” refers to whether the in-
spector option, “Include in Compile” should be ignored.

Count only documents marked for inclusion Only those documents that have
“Include in Compile” checked will be counted.

8 You can technically sort by “Frequency” as well, but this will provide an identical list as sorting
by “Count”.
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Count only documents not marked for inclusion As above, only with the in-
verse logic.

Exclude comments and annotations The running commentary for a piece, its
inline annotations and comments, will be counted by default. Check this
box to only count text that would generally be exported or printed.

Exclude footnotes Footnotes are by default included in the count.

Count subdocuments By default the selected items and all of their childrenwill
be counted, all the way down to the bottom of the outline. When disabled,
only the explicit selection will be counted.

The remainder of the settings impact both statistics tabs.

Page Count Options Set the counting algorithm used to estimate paperback
page counting. The default presumes a “word” to be an average of five
letters long plus a space, for six characters total—thus by default per page:

350× 6 = 2100

per page. This is a fairly safe estimate (and an industry standard) in English
publishing.

If you’re writing in a language where word length differs substantially, it
might be better to switch this to “characters per page” mode so you can
more directly fine-tune its result.

Word Frequency Options This is a global option for all projects. Click the Set
List ofWords to Ignore… button to bring up a text field where you can insert
words that the word usage frequency tables should leave out. In English
for example, it could be useful to leave out common articles such as “a”,
“the”, “at” and so forth.

20.1.4 Writing History
This feature, accessed via the Project ▸Writing History…menu command, offers a
thorough reckoning of the daily word count progression (or trimming, as the
case may be) on a daily, monthly or combined basis. Even if you do not make use
of the session tracking feature, Scrivener will dutifully record your net increase
or decrease in word and character counts (both in and out of the draft folder) on
a daily basis. This information is then used to provide monthly summaries and
produce overall averages.
As this tool is designed to track your writing activity, it will follow the same

rules for considering what “writing activity” constitutes, as described in Project
Targets (subsection 20.1.1). While both tools work similarly, writing history does
not record the session tool itself. Resetting the session, or selecting options for
how it works, will by and large have no impact on the overall writing history.
The top portion of the pane features these overall statistics:
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— Writing days: the total number of days in which the project was opened
and some change as made to the count—even if only to add or delete one
word.

— Average words written per day: is broken down by those words written in
the “Draft” vs everywhere else, and a total of these two.9

The central and largest portion of this window displays detailed statistics to a
resolution determined by the dropdown setting in the upper right-hand corner
(set to “Months and Days” by default):

— Months and Days: all recorded information will be shown, with each day
you have written grouped together into monthly sections. The monthly
rows will contain a sum of all the day counts within them.

— Months Only: only the monthly summary rows will be displayed. If you’ve
been working on a project for a long time, it might be more useful to see
the bigger picture this mode affords.

— Days Only: if it doesn’t really matter how many words you write in a
month, use this mode to display a simple list of every day committed to
the project.

The list will be sorted in reverse-chronological order by default. You can click
on any of the column headers to sort by a different value. You could for example
click on the Total column to see which days or months of the year were your
weakest and which were the strongest. Negative numbers indicate that on that
day you cut more words than you wrote.
The individual rows in this table can be selected, and when doing so some

calculations will be performed for you, displayed in the area below. This infor-
mation will be identical in format to the overall summaries provided at the top
of the window, only focusing specifically on the month or day you’ve selected in
the list, plus a few extras:

— When selecting a day, if a session target was set for that day it will be
recorded.

— When selecting amonth, the number of days youwrote in thatmonth will
be printed under “Writing days”. In addition to the monthly summation,
you can choose to view:

– Average per day: your averages within the confines of that month.

9 For the purposes of this calculation, the Draft counter will only count words written into docu-
ments included in the draft, also found within the Draft folder. Excluded documents will count
as “Other”.
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– Minimum in a day: the count for the lowest session count (by total)
that month.

– Maximum in a day: the count for the greatest number of words writ-
ten (by total) in a session during that month.

— The total draft amount for each day will also be printed in the information
area below the table.10

Lastly, the Export… button brings you to a save panel, where you can dump
the full writing history to a CSV file, suitable for further analysis in a spreadsheet
program or similar. There are a few options available for how this file should be
formatted.

— You can choose to “export days” or “export months”, to set the granularity
of the data.

— Select which columns should be exported. While ordinarily you can only
view statistics in Scrivener as either words or characters, with the raw out-
put you can export both types of data.

Return to chapter ⤴

20.2 Auto-Completion
There are three forms of correction and auto-completion in Scrivener:

Character substitution Adjustments made to the characters as you type them
in, such as setting keyboard quotes to typographer’s “curly” or “smart”
quotes, as they are alternatively called, or adjusting stand-alone i’s at the
start of a sentence to capital form.

Word and phrase completion As you type, you can have Scrivener suggest
words for you either automatically, orwith a shortcut (the default); custom
phrases can be added to each project, such as proper nouns or frequently
used scientific terms. Separate from the project phrase list, you can also
auto-complete based on existing title names from the binder.

Scriptwriting abbreviations Scriptwriting abbreviations, such as “EXT.” or
“V.O.”, can be suggested as you type. These are defined in the script for-
matting definitions Format ▸Scriptwriting ▸ScriptSettings…, but the settings
in this area can also instruct the software on how to automatically gather
new terms into the project auto-complete list. For example every time you

10 Added in version 3.1, older entries in your projects will of course lack any record of the total
draft count.
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type in a new character name it will be remembered and suggested when
typing into a Character element in the future.

20.2.1 Character Substitutions
With character substitutions, you can set which characters will be replaced as
you type. Scrivener uses a combination of built-in enhancements, plus macOS’
built-in substitution engine. Most of these can be set in the Corrections settings
pane (section B.6).
These adjustments always happen automatically as you type, but some require

you to terminate the word you are typing in, before they will take action.

20.2.2 CustomAuto-completion
Completions can be requested by typing in a little bit of the word and then using
the keyboard shortcut, ⌥Esc, to trigger the Edit ▸Completions ▸Complete menu
command. If you would prefer Scrivener present completions automatically as
you type, set the Suggest completions as you typeoption andmake sure In script
mode only is disabled, in the Corrections settings pane (section B.6).
Each project has its own custom auto-completion list. There are two ways to

add items to this list:

1. Beforehand: with the Project ▸Project Settings… command (⌥⌘ ,), use the
Project Settings: Auto-Complete list pane (section C.6) to manage the list
of terms in your project.

2. As you write: select the word or phrase you want to add and use the
Edit ▸Completions ▸Add Selection to Auto-Complete List menu command;
also available from the right-click contextual menu. If you are using
scriptwriting mode, some elements will automatically capture what you
type into the auto-complete list, such as character names and locations.

Copying completions between projects

To transfer completion lists from one project to another: open both
projects simultaneously, access their respective auto-complete lists, and
drag and drop the terms from one panel to another.

20.2.3 Binder Title Completion
If you have started typing in the name of a title that is found in your binder, you
can request a list of completions from Scrivener by pressing a different short-
cut,⌃Esc, or by using the Edit ▸Completions ▸CompleteDocumentTitlemenu com-
mand. A list of all the titles that start with what you have typed in so far will be
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presented.11 You can use the arrow keys to select an item and press Return or Tab
to insert the full title, or continue typing in letters to further narrow down the
list.

Creating Linked Titles

This feature is particularly useful in conjunction with the “wiki style”
document link option. Type in “[[”, start typing in the title name, hit the
shortcut, select a title, and then close with ”]]”. A document link will be
automatically created for you. Another approach, if you aren’t positive
of the precise title, is to use the Quick Search tool (use ⌃⌥G to get the
cursor there), type in any part of a document’s name until you have it in
the list then drag it from the search result list into your text editor.

20.2.4 Scriptwriting Auto-Completion
Scriptwriting mode, by default, engages a more aggressive auto-completion
method that scans as you type and looks for completions, matching the be-
haviour of most scriptwriting programs on the market. Most of the script for-
mats that are shipped with Scrivener come stocked with many common phrases
and abbreviations, which will be contextually suggested within the element you
are currently typing within. For example, “MOMENTS LATER” will appear
whilst typing in a Scene Heading element, but will not appear in a Dialogue ele-
ment.
Most script formatting settingswill also automatically add anything typed into

certain key areas of some elements into the project’smaster auto-completion list.
Character names, locations, and soonwill be checked for and added,making rote
data entry more efficient as you write.
Since auto-completion cannot reliably determine appropriate letter case,

sometimes it may produce results that are undesirable, such as a mixed case lo-
cation name in a slugline. To remedy this, when selecting the auto-completion
you wish to use, hold down the Shift key. Any word or phrase selected with the
Shift key held down will complete using uppercase letters.

Return to chapter ⤴

20.3 Proofreading Tools
Scrivener has a few tools available tomake the process of proofreading yourwork
a little easier. Whether you prefer to generate a static copy of your text, so that
it can be read in a different context than where you write, or if you prefer to

11 Only text up to the first space will be considered, so you must select a completion within the
first word of the title alone.
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proofread and edit directly in the same text editor you use to write, we have a
few tools that can help.

20.3.1 Cleaning the Editor View
Being able to proofread and edit in the same environment is convenient, but de-
pending onhowyouwork, youmayfind someof the tools Scrivener uses to aid in
the writing process to be a distraction. There are rulers and toolbars, hyperlinks
in the text, comments, style markers and so on.

1. Firstly, the traditional and longstanding tool available for paring down the
interface is CompositionMode (section 16.1). With a simple command you
can be whisked away into an environment where all you see by default is
your text, not even the rest of the computer that is typically around your
project window.

2. 2. For some that may be too much however. After all split views are a
fantastic editing tool. Being able to compare older revisions via snap-
shots with the current text, jumping around using all of the navigation
tools the main project window affords you is too much to give up. You
could consider using the built-in “Editor Only” layout, with the Win-
dow ▸Layouts ▸Editor Only menu command (or from the “Layouts” sub-
menu of the View button on the toolbar. This removes the inspector and
binder, and reduces your layout to one simple editor (the active one at the
time of invoking this command). You can further hide the Format Bar and
main application toolbar for an even cleaner interface.

3. 3. Proofing and editing can often by aided by blocking out as much of
the text on the screen as possible. The Focus feature, which fades all text
save for the context around the cursor. Readmore about FocusMode (sec-
tion 16.4).

4. Now for the text itself, the View ▸TextEditing ▸HideMarkupmenu command
will by default hide the following elements:12

— Comment highlights

— Footnote highlights

— Highlight boxes around styled text

— Preserve Formatting markup

The scope of what it hides can be configured in the Appearance: Textual
Marks: Options Setting tab. Caution should be taken in being aware that

12 No, this feature doesn’t have anything to do with the sort of markup you type in yourself, such
as with Markdown.
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thesemarkingswillmerely be hidden. Theywill go on being functional de-
spite your being unable to see them, and typing in and around them will
follow all of the same rules that would apply if they were visible. For exam-
ple, if youput your cursor at the endof a styled phrase that is only indicated
as being styled by its highlight box, and proceed to type several hundred
words, all of thosewordswill be assigned to that style unbeknownst—until
you toggle markup back on.

20.3.2 Linguistic Focus
The Linguistic Focus panel can be brought up with the Edit ▸Spelling and Gram-
mar ▸Linguistic Focus…menu command (⌃⌘L). This tool will fade out the text in
the main editor, leaving only the selected part of speech highlighted. In this way
you can highlight all adjectives, adverbs, pronouns or whatever else you wish to
focus on, and freely edit the text while in this focused state.
Adjust the amount of fade used to dim out unmatched text with the Fade

slider, at the bottom of the Linguistic Focus panel.
For performance reasons, all edits will remain fully visible, rather than being

evaluated for their parts of speech while you write. To update the display with
your newly added text, click the circular arrow button in the lower right corner
to refresh the filter.
The “Direct Speech” option will attempt to find and highlight any text found

within quotemarks. Themarking punctuation usedwill match those selected as
smart quotes, in the System Settings: Keyboard pane, by clicking the Edit button
alongside your input sources.13 If youmake use of amarking system that denotes
dialogue with an em-dash at the beginning of the paragraph, you will need to
enable Linguistic focus uses Spanish-style dialogue, in the General: Language
settings pane (subsection B.2.5).
When you are done analysing your text, close the panel to return the editor to

its normal display.

20.3.3 Inserting Section Links Into ProofingCopies
For those that prefer a “hard copy” (even if entirely dealt with digitally), you can
have the compiler insert a link pointing back to every section of the binder that
was used to compose that copy. If for example you are proofing chapter 18 and it
is comprised of 30 some subdocuments, this option would insert 30 hyperlinks
into the compiled file, each pointing back to the specific chunk of text following
the link. Here is a simple way to test the feature and see if it is right for you:

1. Use the File ▸Compile…menu command.

13 On older versions of macOS the menu command will be printed as “Preferences”, and refer-
ences to System Settings (“System Preferences”) locations may no longer be accurate.
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2. Click on the General Options compile settings tab (subsection 23.4.3) (gear
button).

3. Enable the Insert links back to Scrivener in each section checkbox.

4. With Compile for “PDF” set at the very top of the compile pane, click the
Compile button and select a convenient location to save the proof copy.

5. 5. Once compile completes, split the editor using View ▸Editor Layout ▸Split
Vertically (or use whichever method you prefer).

6. Drag the proofing PDF into either editor’s header bar to load it directly into
the split (no need to import it first!).

7. Now you can proofread the “hard copy” in one split, and if you spot an
error, click the “Open in Scrivener” link located at the top of the section
you’re currently reading within.

With default settings you will find the section loads in the other split.

That is of course only one way in which to use these links. You do not have
to use PDF, nor do you have to load the file into a split—these links work from
anywhere on the same machine—so feel free to use your favourite PDF reader,
or an ebook reading program with ePub, a web browser with HTML files, a word
processor, Markdown previewer, etc.
This method can be used too distribute proofing copies to readers. When im-

porting their annotated copy of the draft back into your binder, you’ll be able to
jump directly to the section their notes pertain to via these links.
In some case you might need to use a format that doesn’t support hyperlinks

(such as various plain-text formats), or you may find that the special hyper-
links Scrivener inserts are being damaged by whatever software your proofers
are using. In that case, the Insert unique document identifiers only option (di-
rectly below the aforementioned compile setting in step 3) will insert a plain-text
marker that Scrivener will scan for and convert back into a document link when
the file is imported into the binder. You will need to communicate the impor-
tance of these markers to your proofers, so that they can work around them.

20.3.4 Converting Document Links to External
Links

In a similar vein, you can have all document links in the text converted to ex-
ternal links. When clicking on the link it will load that section of text in your
original project. This options allows you to carry over your internal link usage
to proofing copies, though of course since it relies upon the original project be-
ing where it was when you compiled, the method will likely not work once you
take the proofing copy off of the original computer.
E.g. a cross-reference from a scene in chapter 8 pointing to a character sheet

elsewhere in your binder will be retained (ordinarily links to items not found in

518



20.3. Proofreading Tools

the draft itself would be removed from the output), and clicking the link will
load that character sheet in your project.
To enable such links:

1. Use the File ▸Compile…menu command.

2. Select PDF or one of the word processing formats.

3. Click on the General Options compile settings tab (subsection 23.4.3) (gear
button).

4. Enable the Convert document links to link back to Scrivener checkbox.

5. Click theCompile button and load the file in your preferred editing or read-
ing program.

20.3.5 Editingwith Apple’s AI Tools
⟨macOS15.1+⟩ Selected text from anywhere within the project window, Scratch-
pad orQuick Reference panels, can be submitted to Apple Intelligence’s “Writing
Tools” feature, on supported systems, where it has been enabled on the Mac.

1. Select the text you would like to submit for analysis.

2. Use the Edit ▸Writing Tools ▸ submenu to select a tool, or use the main
“Show Writing Tools” entry at the top to open the interactive interface.
(This menu is also available in the contextual menu.)

You will be presented with a preview of the modified text, and from there you
can have it overwrite the original text, or copy it for further editing elsewhere.

Figure 20.3 Click on the “bug” to bring up the Writing Tools.

If you pause over a selection of text, the OSmay place a “bug” to the left of the
text that you can click on (Figure 20.3) that will also bring up the main Writing
Tools interface.
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When selecting text from a Scrivenings session, that includes text from more
than one binder item, the ability to overwrite the original will fail for the same
reason you cannot edit such selections yourself. Use the Copy button to paste
the text somewhere temporary, and integrate the edits by hand.
Refer to Apple’s online documentation for further instruction on the various

tools available for text analysis.

Are my writings being sent to AI servers?

Scrivener itself contains no “AI”, nor does it passively do anything with
your text that would cause it to be sent anywhere from your machine to
another server (at all). If you elect to enable Apple Intelligence on your
system, then further choose tohave itworkwith selectedportions of your
text, and are concerned with how Apple use that data, you will need to
consult their privacy statements on thematter. Scrivenermerely acts as a
host for these services on your Mac, in a similar fashion to how it allows
the spell check engine to work on your text. If any of this makes you
uneasy, the simplest approach is to disable Apple Intelligence in System
Settings: Apple Intelligence & Siri panel. Apple’s privacy notices, policies
and further documentation can all be accessed via a link at the top of this
panel.

Return to chapter ⤴

20.4 TheNameGenerator
Scrivener comes with a simple name generator that includes many thousands
of common names, as well as selections such as dictionary words that sounds
like names, literary names from classics. Its proper name lists include a broad
selection of regional names in several languages. It also includes a number of
features for selecting the types of names you will see generated.
To bring up the name generator use the Edit ▸Reference Tools ▸Name Genera-

tor… menu command and click the Generate Names button to get started. The
left side of this window is a text list (empty initially) where the nameswill be gen-
erated. You can select and copy names out of this list to store your favourites.
You can also right-click on selected names to run quick searches for them on the
Web, to check for existing uses of them.
On the left side of the window you will find options for adjusting how names

are generated:

Gender Select one option here. The default is either gender.

Attempt alliteration The generator will attempt to produce names with an al-
literative effect, like “Jeromy Jin”. This option will work best with Latin
based languages.
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Figure 20.4 The name generator: for when Joe Sixpack needs an upgrade.

Double-barrelled surnames Produces names like, “Otis Cowie-Milburn”.

Forenames use initials only Reduces the forename to an initial. If more than
one forename has been selected in the option below, multiple initials will
be generated, like, “N. J. Pettersen”.

Number of forenames/initials Produces multiple forenames. You can select
from 1 (default) to 3.

Set or search forename and surname The next two fields are multi-purpose
tools where you can either set part of the name yourself, or search the
database for a name by providing a part of it. For each part of the name:

— Set: forces the respective name to bewhat you type into the text field;
useful if you alreadyhave aname inmindbut are having troubleswith
the rest of it.

— Starts with: will only return names from the database that start with
the characters you type into the field.

— Ends with: likewise, but for characters at the end of the name.

— Contains: the characters need only be found anywhere within the
name.

Obscurity Level This slider adjusts how obscure the names should be on aver-
age. Moving the slider all the way to the left might produce a result like,
“Scott Young”, while sliding it all the way to the right, “Chauncey Noach”
(no offence to all the Chaunceys out there).
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The bottom of the configuration area is where you will select from the many
lists provided as sources for thenamegenerator. You canhave asmany lists active
at once as you like, but you will always need at least one Surname list selected
(indicated by the neutral grey circle icon), and at least one gender list which is
compatible with the gender option set above.

20.4.1 Managing YourOwnName Lists
You can add your own custom name lists to the generator. They should be for-
matted so that all names are on a single line, and each name is separated by a
comma, like so:

name1,name2,name3,name4,name5,...

1. It might be easiest to produce these lists in a spreadsheet on a single row,
and export as a CSV file. If you use a regular text editor, make sure to save
as plain text, and name the file with a “.csv” extension.

2. Click the+ button, below the name list area of the Name Generator win-
dow.

3. Locate the file in the chooser dialogue and click Open.

4. Give the list a descriptive name in the Title field, and select whether it is a
list of female names, male names, or surnames.

5. Finally, if you have ordered your list from most common to most obscure
(at the end of the list), check this box to enable the Obscurity Level slider
for that list.14

To delete one of your custom lists: select it from the name list area and click
the− button. You will be asked to confirm your decision.
To update a list you’ve imported in the past, delete the custom list, and then

add your modified CSV file again.

Return to chapter ⤴

20.5 BibliographyManagement
Scrivener offers simple integration with your favourite bibliography or citation
manager (such as EndNote, Bookends, Sente or Zotero) for academic work. To
set it up:

1. Open the General: Citations settings pane (subsection B.2.8).

14 In small lists, the obscurity slider may not have much impact, depending upon how many
names are being generated.
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2. Click on the Choose… button and use the file chooser to locate the appli-
cation you use for citation management.

With the citationmanager set up, use the Insert ▸Bibliography/Citations…menu
command (⌘Y) to bring your chosen software to the front, launching it automat-
ically if necessary.
The steps you take next will depend upon your citation manager, so you will

need to consult their documentation on how to use their software with third-
party word processors. Typically, you would copy and paste a citation place-
holder into Scrivener, in the location where the reference mark should appear.
After compiling to RTF, you would then use the citation manager to scan these
placeholders into final print form. Not every program or service provides RTF
scanning, however. You should research the software you intend to use and
make certain it designed to work with software other than Microsoft Word.

Return to chapter ⤴

20.6 Using EquationswithMathType
⟨macOS10.13–14⟩ If part of yourwriting involves the addition or construction of
equations, one alternative is to make use of Scrivener’s MathType integration to
insert editable equation objects into the draft, much like you would an ordinary
figure. As MathType is a 32-bit application, this integration is only available on
older systems.
To create a new equation, position your cursor where you wish to have it ap-

pear, and use Insert ▸MathType Equation.15 If you have MathType correctly in-
stalled on your machine, you will see the equation entry window pop up over
the Scrivener window. Any changes made within this windowwill be saved back
into the Scrivener project when you close the window (by default it will ask for
confirmation when closing the window) or use File ▸Close andReturn toScrivener.
Equations can be inserted either on their own lines, as figures, or directly in-

line within a paragraph. In the latter case, attempts will be made to keep the
equation correctly aligned with the text baseline.
To edit an equation double-click on the equation in the Scrivener editor. The

MathType interface will pop up again, this time with the equation loaded, and
any changes you make will be saved back into the file when you close it.
Otherwise, equations act much like ordinary images. They can be aligned or

have paragraph formatting (such as spacing) applied in the editor, andwhen they
are compiled they will be converted to images and handled as they ordinarily
would be for the particular format in use.

15 You can also add an optional “Equation” button to the main application toolbar if you use this
feature a lot.
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Using MathType equations beyond Scrivener

Given unfortunate technical limitations in how the MathType engine
handles equations in export, when compiling a document containing
them, they will be converted to raster images at that time. This means
they will not be scalable without quality loss and can no longer be edited.
They are thus not suitable for round-trip workflows where one imports
edited documents from collaborators, or for taking your work into other
word processors for additional formatting with the equations in an ed-
itable form. If you require equations to be editable throughout the life of
the document then it would be best to defer the insertion of equations
until they can be brought into an environment where they will remain
until publication, or to use another technology, such as LaTeX.

Return to chapter ⤴
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For those who prefer structural or semantic writing methods to rich text,
Scrivener allows you to import and export using two different Markdown di-
alects: Fletcher T. Penney’s MultiMarkdown (MMD) and John MacFarlane’s Pan-
doc. These systems make it easy to generate documents in any number of for-
mats, from clean and modern HTML5 to LaTeX to DocBook to standard word
processing files like Word’s DOCX or ODT—all while using a simple and easy to
type in markup.
If you are curious about the process andwould like to consider adopting it, you

should read the following sections for an overview of its philosophy, limitations
and capabilities. If you’re already familiar with Markdown, you may prefer to
skip toMarkdown and Scrivener (section 21.4), where we get into the specifics of
how these tools can be used within, and are supported by, the software.



21.1. What is Markdown?

21.1 What is Markdown?
“Markdown” is an easy to learn syntax created by JohnGruber; a gooddescription
of what Markdown is comes from his site, Daring Fireball:

Markdown is a text-to-HTML conversion tool for web writers. Mark-
down allows you to write using an easy-to-read, easy-to-write plain
text format, then convert it to structurally valid XHTML (or HTML).

Thus, “Markdown” is two things: (1) a plain text formatting syntax;
and (2) a software tool, written in Perl, that converts the plain text
formatting to HTML. See the Syntax page for details pertaining to
Markdown’s formatting syntax. You can try it out, right now, using
the online Dingus.

The overriding design goal for Markdown’s formatting syntax is
to make it as readable as possible. The idea is that a Markdown-
formatted document should be publishable as-is, as plain text, with-
out looking like it’s beenmarked up with tags or formatting instruc-
tions. While Markdown’s syntax has been influenced by several ex-
isting text-to-HTML filters, the single biggest source of inspiration
for Markdown’s syntax is the format of plain text email.

Can I use Scrivener to create basic Markdown?
You may not need all of the frills provided by the integrated systems, or
are publishing to a system that has its own dialect, such as Github. In
most cases, the Markdown that Scrivener generates is done at your re-
quest: it will only generate image syntax if you put images in the editor
for example. If the dialect you are using does not use footnote syntax,
then you should avoid using the footnote feature in Scrivener. A com-
mon need is to remove the special documentmetadata features that both
MMD and Pandoc make use of (section 21.6).

Return to chapter ⤴

21.2 What areMultiMarkdown and Pandoc?
Markdown’s goal is primarily toward Web publishing and similar uses. Systems
like MultiMarkdown and Pandoc arose out of a desire to use a similarly simple
syntax for the production of formats more suitable to traditional and electronic
publishing. The syntax was extended to include constructions desirable to au-
thors, such as footnotes, tables and better cross-referencing. Of the many for-
mats these systems provide, Scrivener supports:
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— LATEX viaMultiMarkdown: awell establisheddocument typesetting engine
primarily used in the sciences and academia for its high-quality rendering
of formulae. Beyond that it is a capable engine for any number of purposes,
especially technical formats. In fact, the PDF you’re reading right now was
built using this system.

— HTML5 via MMD: is capable of producing syntactically clean, modern HTML.
It is suitable for the production of ebooks and web pages—in fact we drive
our own ebook generator using MMD’s output, after internally converting
Scrivener’s rich text to MMD syntax.

— ODT via MMD: The OpenDocument format can be opened by many word
processors and office suites (OpenOffice and LibreOffice being the two
most popular). From there it can be converted to any format you need.
This is a high quality word processing document, with figure captions,
stylesheets and everything else you’d need to take your work into a pro-
duction environment.

— DOCX via Pandoc: this high-quality word processing output is better if you
know Word is the primary target. This will be the ideal format to use if
you need to continue your project beyond Scrivener in a traditional word
processing environment.

— DocBook via Pandoc: this format is sometimes used in technical publish-
ing.

— ePub via Pandoc: capable of producing both ePub version 2 and 3 for-
mats. As can be expected from generators based on Markdown, the in-
ternal HTML quality is clean and easy to modify and style.

One of the things that attracts people to Markdown is that it focusses solely
upon the structural aspects of a text. Formatting is not something one can
bother with, instead text is marked as being a “kind of thing” using simple to
type and easy-to-read text markers. Scrivener’s approach to working withMark-
down is thoroughly in line with that ethos. You will find ways to insert CSS, La-
TeX preamble and other ways to influence formatting, but Scrivener itself will
chiefly avoid formatting and focus purely on generating the Markdown syntax
itself.
This chapter will not attempt to teach you Markdown or any of the more ad-

vanced dialects of it. There are excellent resources available on the Internet for
this, including the links at the top of this section. Instead we will cover the in-
tegration itself, and will assume a basic working knowledge of the underlying
markup systems.

Return to chapter ⤴
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21.3 Getting Startedwith the Tools
⟨Direct-sale only⟩ There is very little you need to do to prepare for using Multi-
Markdown with Scrivener. It comes pre-loaded with a recent version of it, in-
cluding some of its support files for creating ready-to typeset LATEX documents.
You are of course free to install your own version of MMD, and Scrivener will
cross-check your system for you. If it detects installed components, it will grace-
fully switch to using them behind the scenes.1

For Pandoc support, youwill need to install your own copy of the engine itself.
Refer to Setting up MultiMarkdown or Pandoc (subsection 3.3.3).

⟨MASonly⟩The version sold through Apple’s storemust adhere to Apple’s sand-
boxing guidelines, which means no utilities can be executed unless they are lo-
cated inside the /Applications folder. Thus the Apple version of Scrivener can-
not integrate with Pandoc, pdflatex, support external support files or a custom
MultiMarkdown installation. It only supports the built-in distribution of Mul-
tiMarkdown.
If such customisations are important ingredients in how you intend to use

Scrivener, you are advised to either purchase the direct-sale version instead, or if
you’ve already bought and run the Apple version, you may be able to migrate to
the direct-sale version by downloading it from our site and replacing your MAS
copy. Further instructions are provided in our knowledge base.

Return to chapter ⤴

21.4 Markdown and Scrivener
Scrivener’s support of this writing method is built with three different ap-
proaches in mind:

1. Purist: those that enjoy using the format itself and plan to not make much
use of Scrivener’s rich text editing features—or intend to use those in an
editorial fashion rather than for the purposes of formatting.

— Using this method, you would treat Scrivener like a plain-text editor
with benefits: you get things like inline highlights, revision modes,
annotations, comments and other affordances uncommon in plain-
text editors.

— This is a good approach to take if you prefer writing or editing in
plain-text editors, as you can freely rotate text out and back into the
Scrivener editor without fear of losing functional formatting.

1 Recent versions ofMultiMarkdown, which are embedded in Scrivener, are not compatible with
macOS 10.13. You will need to install your own copy in order to regain access to the conversion
options in the compiler.
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2. Hybrid: those that intend to blend various rich-text oriented tools—
with the intention of having them converted to Markdown syntax during
compile—with standard typed-in Markdown.

— Scrivener’s powerful stylesheet system is a natural augment toMark-
down style writing (subsection 21.4.8).

— In addition to styles, Scrivener can handle numerous tasks that are
otherwise labour intensive, such as: heading hashes by level, foot-
note markings, table generation, simple lists, cross-reference & gen-
eral hyperlinking and image handling.

— The syntax that Scrivener generates is additive to the document you
key in yourself. What you type will not be changed, but objects like
images will be added to it as you use these features.

3. Incidental: those that really aren’t interested in usingMarkdown at all, but
would like to take advantage of some of the higher quality or exclusive
formats it provides.

— Select any Markdown-based file type and enable the Convert rich
text to MultiMarkdown option in the compile overview’s General
Options tab (subsection 23.4.3).

— All of the conversion options described in this chapter, unless other-
wise noted, will be handled automatically for you. As much as Scriv-
ener is able to do so, your rich text source material will be converted
to MultiMarkdown or Pandoc syntax.

— For those that require an amount of Markdown syntax in their work,
such as the use of citation markings, there are multiple options for
doing so (subsection 21.4.9).

With any of the above methods, most forms of rich text formatting will
be ignored, by virtue of being exported into a plain-text workflow. Further-
more, many types of formatting, such as highlighting, typographic adjustments,
the specifics of paragraph formatting and so forth, have no equivalents in
Markdown-based systems. For the remainder of this chapter, we will focus on
precisely what Scrivener does address, as well as what tools can be used to extend
into areas where it does not.
For the most part you will be using Scrivener like everyone else does. It is

fundamentally a rich text editor, and as such many of the tools you would use
to affect varying degrees of a hybrid approach will simply be what everyone else
uses.
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21.4.1 ImportingMarkdown Files
You can import any existingMarkdown documents into Scrivener using the typ-
ical methods for importing files—they are simply text files and so there is really
nothing special required to get that text into Scrivener.
But if you would like to have the document split by headings instead of as one

long file, use the File ▸ Import ▸ Import andSplit…menu command. This command
can break up the document so that it is imported into the binderwith its heading
hierarchy converted to nested documents in the binder. Refer to the Import and
Split documentation for further details (section 9.1.6).2

When importing a documentwith aMultiMarkdownorYAMLmetadata block
via Import and Split, Scrivener will create a file containing just the metadata, at
the top of the list. The compiler is designed to integrate any metadata found in
such a file automatically, so you may just be able to leave it alone (section 21.7).
But, if you wish to move these values to the compiler, or indeed if you wish to
move any set of properly formatting metadata values into the compiler, you can
simply copy and paste into the compile pane metadata table.

21.4.2 Images
As shown in Figure 21.1, placing an image in the editor (using any of themethods
Scrivener provides for doing so (section 15.6)) is a simpleway of generatingMark-
down image syntax when compiling. What you cannot see from the screenshot
itself is that the compiler also produced the image itself into a folder, such that
the reference to “bair_island-wetlands.jpg” would link up and be available for
any further post-processing. Image syntax has the following characteristics:

— An image identifier is created using its original file name (in the example,
“barisland-wetlands”). Knowing that, you can cross-reference to this im-
age using the MultiMarkdown or Pandoc syntax for doing so.

— The effective size of the image will be provided in points, rather than using
its raw physical pixel dimensions. This will produce a result in keeping
with its original print resolution, and allow one to supply high-resolution
graphics in their ebooks and Web pages.

Referencing Imageswith Document Links
There may be cases where you might not want the image to be in the editor,
or maybe you prefer using text syntax to refer to images rather than working
around them as visual objects in your text—but you would still like to take ad-
vantage of the automation that produces images on output into a folder. While

2Unless you intend to abandon theMarkdownapproach towriting, you should leave theConvert
Markdown option disabled.

531

http://yaml.org/


21.4. Markdown and Scrivener

Figure 21.1 Above the dotted line is what we see while writing. Below the dot-
ted line is what Scrivener converts the image and styled caption
line to, upon compilation to a Markdown-based format (caption
text coloured for emphasis).

you could use the image placeholder tag that is available to rich text authors (sub-
section 15.6.5), you might as well use native Markdown for its extended syntax:

1. Write out the image syntax as you normally would in the text editor.

2. Where you would place the image’s path and filename, create a document
link (subsection 10.1.1) pointing to that image in the binder.

When compiled, the text of the hyperlink will be altered to the image’s file
name, so you needn’t even be aware of the image’s name to use this method, but
will need to take care and keep the hyperlink itself limited to that area of the
syntax where the image name should be produced, as the entire range of text
will be replaced with the image name (Figure 21.2).
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Figure 21.2 An example of custom Pandoc image syntax (top) being used to
generate classed figures in HTML.

Cross-referencing Images
Themethod Scrivener uses to generate image syntax is conducive toMultiMark-
down cross-referencing.3 It will use the image filename for the Markdown ref-
erence handle (or ID), which in turn can be used as an anchor link. All figures
with a generated handle will be placed in a list at the bottom of the compiled
document for easy reference, along with any footnotes.

Upgrading from Scrivener 2

Projects updated from prior versions of Scrivener will need to be ad-
justed if this form of image cross-referencing was in use. In previ-
ous versions, Scrivener included the file extension as part of its han-
dle, but now it only uses the root name of the file. Thus a ref-
erence such as [this](#filename.jpg) would need to be changed
to [this](#filename) in order to continue working. The RegEx
\(#(.*?)\.\w{3}\) replaced with (#$1) might suffice to help convert
these older references.

For example, if you drag a graphic called ‘analysis_of_derivatives-2008.png’
into the editor, Scrivener will export that graphic into the compile folder (sub-
section 21.5.1) and generate syntax where the position was located, like so:

![][analysis_of_derivatives-2008]

[analysis_of_derivatives-2008]: analysis_of_derivatives-2008.png

3 At the time of this writing, Pandoc does not have an automatic method for cross–referencing
images. Youwould need to use the referenced image technique described in the previous section
to create the necessary Pandoc syntax to create an HTML ID that can be linked to.
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You can thus refer to this figure in another portion of the document with the
standard MMD syntax:

[see chart](#analysis_of_derivatives-2008)

Need to get the name of your image for cross-referencing?

Double-click on inline images in the editor to gain access to its name. For
fully embedded images you can even edit its handle right in the window,
as well as copy it for later pasting. Images linked to files on the disk will
print their full path. All you will need to copy is the name itself sans
file extension. For images linked to the binder, click the Reveal in Binder
button, where you can of course copy the name from.

Captions
When images fall upon their own line, you can supply a caption to them using
one of the following techniques:

— Place the caption within straight (not typographic) "double-quotes", or in
paired [square brackets], on the same line after the image, separating the
image from the caption text with a space.

— Alternatively, place the square bracketed caption on the line directly fol-
lowing or proceeding the graphic.

— Use a designed caption style on the line directly preceding or following
the image. Refer to MultiMarkdown and Pandoc Options (section 24.14)
for further information on mapping styles to functions.

In order for a style to be considered a functional caption, your compile Format
must also contain a style of the same name used by the project, which will then
need be indicated in theMultiMarkdown and Pandoc Options (section 24.14), as
the Captions style.4

21.4.3 Lists and Tables
This is an optional compile behaviour, set with the Convert tables and lists to
MultiMarkdown setting in the compile options for Markdown-based formats
(section 23.4.3). If you use tables or lists at all in your document, youwill probably
want to enable this option, as the plain-text output of these two constructs by
themselves will not produce desirable results for Markdown-based conversions.

4 The built–in compile formats that come with Scrivener have been set to use a style named
“Caption”.
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List Support
The compiler can generate Markdown style bullet and enumeration lists based
on lists found in the text, when the option is applied to do so.

Figure 21.3 Example list formatting converted to Markdown text (invisible
characters shown for clarity).

— All list types found in Scrivener will be expressed as either bullets (using
asterisks) or enumeration (using digit + dot formation). For example, a list
type in Scrivener using “a. b. c.” formatting will generate “1. 2. 3.” on
output.

— You can mix list types per level. A list can be bullets on level one, enumer-
ation on level two and back to bullets on level three.

— Multi-paragraph list items are allowed, however you will have to use a dif-
ferent whitespace approach in Scrivener, since its own list formatting fea-
ture does not allow for paragraph breaks or tabs (how one would do so us-
ing Markdown syntax directly). Use Insert ▸Break ▸Line Break (⌥⌘Return)
to insert new lines within a single bullet line. Scrivener will handle the
whitespace conversion for you.

As shown in Figure 21.3, you can insert multiple line breaks to space out
the paragraphs in the editor aesthetically—Scrivener will clean them up
for you if necessary.
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Table Support
Table conversion is relatively simple, and like most aspects of conversion to
Markdown, disregards the particulars of formatting, converting the basic struc-
tural data expressed by the table. In Figure 21.4, we see a table with a grey fill
being used to indicate the header row. It is a header row merely by being the
first row, and requires no styling to become that way in the output. The follow-
ing lists exceptions where formatting can modify table output:

1. Cell alignment can be expressed, with the first row establishing the align-
ment for the entire column (Figure 21.5).

2. Text styled as a caption found on the line directly preceding or following
the table, will be converted to the proper syntax for a table caption (Fig-
ure 21.5).

In order for a style to be considered a functional caption, your compile For-
mat must also contain a style of the same name used by the project, which
will then need be indicated in the MultiMarkdown and Pandoc Options
(section 24.14), as the Captions style.5

3. Merging cells within a row will use the appropriate syntax for doing so in
the output.

21.4.4 Footnotes
You needn’t worry about footnote syntax when using Scrivener to compose MMD
or Pandoc Markdown documents. When using the built-in tools for handling
notes (chapter 18), the compiler will automatically generate sequenced identi-
fiers for you and place the markers and references where they should go.
Whether they will ultimately become footnotes or endnotes is not dependent

upon anything Scrivener can do. However, when using inline and linked foot-
notes, the compiler will use two different naming conventions for the handles:

[^fn1]: This came from an inline footnote.
[^cf1]: This came from a linked footnote.

This distinction, if going straight to one of the basic output formats, will be of
no concern to you. However, if you intend to post-process the results using your
own scripts or stylesheets, having two naming schemeswill enable you to handle
these as separate streams of notes in your document. You could for instance use
inline footnotes as footnotes, and linked as endnotes.

5 The built–in compile formats that come with Scrivener have been set to use a style named
“Caption”.
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Figure 21.4 Table conversion supports merging cells (plain-text formatting
optimised for clarity).

Figure 21.5 Alignment works by column, not by cell, with the first row estab-
lishing alignment (plain-text formatting optimised for clarity).
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21.4.5 Heading Styles
Available onlywhen theConvert rich text toMultiMarkdown option is enabled,
in the General Options tab of the compile overview screen (subsection 23.4.3).
Text functioning has sectional headings in your editor can be given Markdown-
style hashmark headings. In most cases you would want to use the compiler’s
ability to generate headings with Section Layouts, but if as a matter of taste or
practicality you prefer headings in the editor, using specially formatted headings
can pick up where the compiler leaves off.
You will need to set your heading text to use the appropriate level of heading,

from the Format ▸Paragraph ▸HTML Header Level submenu. As a type of format-
ting, the setting will be saved into any Styles you create, and as well the compiler
can add this formatting to your styles on the fly. E.g. a paragraph style with the
“H3” header level applied to it will compile as:

### Text Assigned to the Style ###

Some Markdown engines require a clear line of space around a heading line,
such as Pandoc. That detail will be left up to you and how you compose the text
in the editor.
If you require more direct control over how the syntax is applied to a heading

style, you should not use the HTML Header Level setting, and instead use the
prefix/suffix style tools described in the previous section.

21.4.6 Hyperlinks andCross-References
This is an optional compile behaviour, toggled with the Convert links to Mul-
tiMarkdown setting, in the compile options for Markdown-based formats (sec-
tion 23.4.3). Regular hyperlinks to URLs will be converted to equivalent Mark-
down links, and internal document links to other titled items in the draft will
useMultiMarkdown/Pandoc style cross-referencing (Figure 21.6). Duplicate title
nameswill be resolved automatically by the compiler, by giving duplicate section
names a serialised internal label.

Keeping Cross-References in Parity

One of the things that Scrivener can help you with, that otherwise re-
quires manual labour, is keeping cross-references to headings correct,
even if heading names change. For example if you change the name of a
heading from “Browsing theWeb with Lynx” to “Browsing theWeb from
the Command Line”, you’d have to go back and fix every case in the text
where you used [Browsing the Web with Lynx]. With the built-in hyper-
link feature, not only do you get a handy clickable link much like your
readers will, but if you change the title in the binder you can make use of
the ability to update link text (section 10.1.2).
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Figure 21.6 Links can be optionally converted to Markdown syntax.

21.4.7 Annotations andComments
Formost uses, inline annotations and linked commentswill servemuch the same
purpose when using MMD as they would otherwise. They are a convenient way
for you to apply notes to your document, or to share and receive thoughts from
those who are editing your work.
If you wish to insert these comments into your compiled document, Mark-

down itself does not have a convention for inserting comments into a document,
but there are a few approaches you can take, using the Annotations compile for-
mat pane (section 24.19.2). Scrivener’s provided Markdown-based formats will
for the most part use CriticMarkup for comments and annotations.

Upgrading from Scrivener 2

In previous versions of Scrivener, inline annotations were—given their
ability to be prefixed and suffixed by text—a convenient way to insert
HTML comments and other codes around marked text. Consider using
styles in Scrivener 3. There are more prefix/suffix options available in the
Styles compile format pane (section 24.5), and the type of code they insert
around themarked text can differ per compile format, as well as per style.
Styled text can even be set to be omitted on a per format basis. All in all
there are few reasons to use comments and annotations for anything but
comments and annotations, these days.

21.4.8 General Styled Text Support
You are not limited to the types of conversion we’ve discussed in this section.
Styles offer a form of freeform capability that opens up the realm of possibilities
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far beyond what we could anticipate ourselves. Although wemight traditionally
think of styles, and stylesheets, as beingwithin the domain of desktop publishing
and word processors, Scrivener’s approach to styles was designed not only for
rich text use, but for plain-text writing methods as well.
Styles can considerably extend the reach ofMarkdown—either to address syn-

tax we do not ourselves provide interfaces for, or to go even beyond what Mark-
down converters can do (such as the injection of LATEX or DOCX code directly into
the output).
They can also be an optional approach to inserting markupmore directly into

the editor. Perhaps one does not prefer the aesthetic of asterisks to mark em-
phasis. The use of a style can be employed to insert these asterisks for you upon
compiling the document.

Before you build a custom style…

Some styles can be handled internally to generate syntax for you (block
quotes, code blocks& spans and captions). Compile-time styles can be as-
signed in theMultiMarkdown and Pandoc Options compile format pane
(section 24.14). But by default we’ve set up sensible defaults that should
work for you out of the box.

Using Styles forMarkup
There are two ingredients involved in using styles to design your own markup:

1. The application of paragraph or character styles to text in the editor. Refer
to Styles and Stylesheets (chapter 17) for general instructions onhow to use
styles in the text editor and project.

The use of styles as amarkup tool is very similar to how they would be em-
ployed as a traditional formatting tool—only as writers using markup, we
don’t have to worry at all about the formatting. Formattingwill be ignored
entirely, and can thus be used purely as a visual aid.

2. Your goal will be havingMarkdown or bespoke syntax placed around these
marked ranges with the compiler. This is what makes them functional,
rather than purely aesthetic markings that get stripped out when compil-
ing.

That styles by default do nothing, without compile settings, is what sets
them apart from traditional usage, turning them into a two-pronged tool.
We can use them to generate structure and markup, or we can not use
them at all, leaving them as pure writing tools in the editing environment.
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These are not word processing styles

If you are using aMarkdown-based approach to create a word processing
file via .docx, .odt or similar, do not expect the styles you use in Scrivener
to translate somehow through to the final output, as styles in the word
processor. Keep inmind that what Scrivener compiles in this workflow is
a plain-text file. If the format or converter you are using supports a syntax
for conveying text tagged as styled then you would be using Scrivener
to generate that syntax—potentially through its stylesheet system, but
always in concert with the conversion tool’s own native capabilities.

Let’s take a look at a couple of practical examples of how styles can be used to
create structured markup in the compiled text.

Inlinemarkup using character styles
The Styles compile format pane (section 24.5) is where you will handling the sec-
ond ingredient, via prefixes and suffixes—both around the entire range or per
individual paragraphs within that range. Here is a simple example of this in ac-
tion:

1. Bring up the Compile interface with File ▸Compile…

2. With Compile for: “MultiMarkdown” chosen at the top of the window,
double-click on the “Basic MultiMarkdown” format in the left sidebar to
duplicate and edit the copy. (You can cancel later to discard it.)

3. Select the Styles format pane.

4. Examine the “Addition”, “Deletion” and “Highlight” styles in turn, check-
ing out the Prefix/Suffix fields on the right hand side of this pane.

These are set up to produce CriticMarkup syntax6 around marked ranges.
If you select some text in the editor andmark it as “Deletion”, then the text
will be wrapped with the following prefix and suffix:

{--This is the deleted text.--}

Blockmarkup using paragraph styles
The previously examined Prefix/Suffix fields transform, when used with para-
graph styles, to enclosing an entire block of text. If we select three paragraphs
and apply a style to them, they would be placed around the entire selection of
three paragraphs.

6 CriticMarkup is a simple markup system for indicating revisions that is complementary to the
Markdown ethos. It is also recognised and made use of by the MultiMarkdown workflows.
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An example of how this could be useful is with Pandoc’s fenced div syntax,
where the prefix and suffixwould insert the ::: markers around thewhole block.

::: Callout Box
This is the first styled paragraph.

This is the second styled paragraph.
:::

The secondary Paragraph prefix/suffix fields insert the supplied text on each
line within the selected style range.7 For example the prefix could insert ”: ” in
front of each line, for a Markdown-style definition list (we would omit a suffix in
such a case).
For the details on how these and other style options work in the compiler,

refer to Compile Style Options (subsection 24.5.3).

21.4.9 Preserve Formatting
In the past, the Format ▸PreserveFormatting featurewould have been used to gen-
erate code spans and code blocks with Markdown-based output. This capability
has been removed, as it is now served by styles. Use the “Code Block” and “Code
Span” styles provided in the stock set, or if you create your own, set them up
in your compile settings using the MultiMarkdown and Pandoc Options (sec-
tion 24.14) compile format pane.
The Treat “Preserve Formatting” as raw markup option, (used in conjunc-

tion with the Convert rich text to MultiMarkdown setting both in the compile
options for Markdown-based formats (section 23.4.3)), will cause marked text to
pass through the compiler untouched. This option will mainly be of interest to
those that use the iOS version of Scrivener, with its equivalent capability. If you
are only using a Mac or PC to compile, it is usually best to use a dedicated style
instead (with theTreat as rawmarkup option enabled for it in the Styles compile
format pane).
If one has a lot of Markdown blended into their document, it first might be

worthwhile to consider whether the full rich-text conversion system is the right
tool for the job. If it is, and you still need lots ofMarkdown, the secondary option
to Escape special characters can be disabled. This is a “riskier” setting that may
require additional proofing, as accidental usage of Markdown may occur where
punctuation is used in ways that match its syntax (for example, an asterisk after
a word to mark a casual footnote might confuse a Markdown converter, which
uses asterisks to denote emphatic text).

7 For the purposes of what constitutes a line in Markdown, the empty literal lines between text
elements are considered syntax, not paragraphs. The prefix and suffix will ignore these empty
lines, as in most cases inserting syntax within them would break the document.
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Return to chapter ⤴

21.5 Compiling
This section of the documentation will not cover compilation in detail. You
should consult the chapter on Compiling the Draft (chapter 23) for detailed in-
formation on the various options that will pertain to you. This section will in-
stead focus particular features of interest toMarkdownusers, andwhich compile
panes to check for best harnessing Scrivener’s compile automation.

Not seeing MultiMarkdown conversion options on macOS 10.13?

Recent versions of MultiMarkdown, which are embedded in Scrivener,
are not compatible with macOS 10.13. You will need to install your own
copy in order to regain access to the conversion options in the compiler.

21.5.1 Compile Folder
If the compile process will generate more than one file, a compile folder will be
created, containing the document itself along with any support files it needs.
This will most often be graphics, or supporting .tex documents for typesetting.
The folder namewillmatch the output filename, such as novel.md, or novel.tex.
Not only does this policy keep your output folder tidy, once this folder has

been created, Scrivener will reuse it for subsequent compiles. This means you
can assemble supporting material into this folder, such as CSS or scripting files,
and compile directly into the production area, rather than compiling andmoving
things around into the final support folder each time. Scrivener will handle this
gracefully for the following cases:

— If the target compile folder ends with an extension that matches the file
type you are producing, or if instead of a dot a hyphen or underscore is
used. E.g. compiling “snippet.html” into a folder named “specs.html”,
“specs-html” or “specs_html”.

— For amore generic approach, wheremultiple file typesmight be produced,
youmay use “-mmd” or “_mmd” as a folder name suffix to trigger the same
behaviour.

E.g. let’s say we compile to “my_novel.tex” and that creates a like-named
folder. The next time we compile to that folder, what is already in the folder
will be left alone, unless it is a file that Scrivener is scheduled to produce. This
way compiled graphics will be updated as well as content files, but any support-
ing elements you’ve placed into the folder yourself will be preserved.
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The “Overwrite preserves other existing files” Checkbox

In the compile file save dialogue box which appears after clicking the
Compile button—for MMD formats which have the potential to produce
folders instead of singular files—you will find a checkbox labelled “Over-
write preserves other existing files”. This option accomplishes the same
as above with one slightly different variation in that you use it to compile
to the parent folder containing the compile folder, not to the file within
the compile folder. Thus, if your “my_novel.tex” folder is in Documents,
you would compile to Documents, opting to overwrite the folder. With
the checkbox on, anything in that folder not otherwise slated to be pro-
duced by Scrivener will be preserved. With the checkbox disabled, the
folder will be completely refreshed.
Users of the Mac App Store version will need to use this feature ex-

clusively, as Sandboxing does not allow the dynamic folder preservation
technique.

21.5.2 PlainMultiMarkdown
Of course for some things, a plain .md file is just what you need, such as when
pasting into blogs that take Markdown, and so forth. There are other good rea-
sons to consider using this option as well, for any workflow:

— Archival: a plain-text copy of the final product is something that can be
easily archived in multiple places for many years to come. Archiving the
Markdown instead of the productmeans being able to benefit from refine-
ments in conversion engines over the years.

— Troubleshooting: the second reason to use this setting, by compiling to
MultiMarkdown without conversion, we are able to see precisely what
Scrivener itself generates, versus what is converted or generated by the
Markdown process itself. This can be valuable as a form of troubleshoot-
ing, by determining which process is causing the problem.

— Flexibility: lastly, the Processing pane is made available to this file type set-
ting, which opens the door wide to full customisation.

Post-Processing andCustomFormats
A significant advantage of the plain “MultiMarkdown” approach8 is its post-
processing capabilities. This won’t be something you find in the compile
overview screen, but instead when modifying or creating your own compile for-

8 We call the compile file type “MultiMarkdown” for simplicity, but it’s also capable of producing
Pandoc Markdown.
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mats. Refer to the Processing compile format pane (section 24.22) for a full run-
down on how to use its various options specifically.

— If youwish to adjust how Pandoc orMultiMarkdown output syntax to tar-
get file types—e.g. to change how figures or tables are put together at the
code level—then this is how you would hook up the necessary scripts for
doing so (using whatever technology you prefer).

— And by extension, with direct access to these conversion engines, you can
export to formats we do not have support for in the front-end, such as
mediawiki, rtf and the dozens of other formats Pandoc supports.

— Using a custom shell script, you can automate repetitive post-compile
tasks, such as assembling bibliography materials, and even generating PDF
files from LaTeX.

— You can use your own preferred markup language in Scrivener and then
make use of whatever post-processing tools are necessary.

The Processing pane is also available to the Plain Text compile file type. If
you’re looking to generate output that isn’t Markdown-based (such as ASCIIdoc
or ReStructuredText), you may find that a better starting point as you will have
better control over all output syntax. Refer to the documentation on theMarkup
compile format pane (section 24.10) for further information.

21.5.3 LaTeX
MultiMarkdown’s LaTeX support is premised by the concept of using boilerplate
.tex files, rather than describing the document as a single large file. This leaves
the base document, the part you’ve written and what Scrivener will be compil-
ing, clean and focused on the content. Ordinarily you would need to install and
manage these boilerplate files yourself, but Scrivener can manage such details
for you. It will set up the LaTeX-related metadata and handle the gathering of
any necessary support files into the compile folder for one-click typesetting.
To view the metadata keys that Scrivener will be inserting:

1. Open File ▸Compile… and select Compile for: “MultiMarkdown → LaTeX”
at the top, and then a suitable Format from the left sidebar.

2. Click on the Metadata options tab on the right hand side of the compile
overview screen (subsection 23.4.2).

3. Click the Preview button along the bottom of the metadata configuration
area.

The set of document class boilerplates will be referred to by a keyword. For
example, if the “LaTeX Config” metadata key is set to “memoir-book”, then all of
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the necessary .tex files to produce aMemoir Book style PDF will be assembled for
you when you compile.
A number of stock compile Formats have been provided that make it easy to

switch from one document class to another (section D.6). If you would like to
modify the document class for an existing Format that you are working on, use
the LaTeX Options compile format pane (section 24.12).
In addition to the provided default classes, you can write your own in such a

way that they are saved into the compile format itself, rather than .tex files on the
disk, by selecting “Custom” in the LaTeXOptions compile format pane andwrit-
ing your boilerplate preamble and footer into the provided tabs. The “Modern
(Custom LaTeX)” compile format is an example of just such an approach.

⟨Direct-saleonly⟩ If you already haveMultiMarkdown’s LaTeX support files in-
stalled into your system’s texmf folder,9 then Scrivener will not duplicate them
into the compile folder, and all you will see are the .tex files the compiler itself
produces.

21.5.4 HTML
If you are blogging, or using a CMS to publish your work online, this is a great
option to use (if the system doesn’t takeMarkdown itself) as the result makes no
assumptions on formatting, allowing the site stylesheets to handle that part of
the job. The clean HTML5 output will also be of use to those building their own
sites by hand.
To supply stylesheets to your HTML output, you can set the appropriate meta-

data keys for doing so in either the Metadata compile format pane, as part of
the format’s settings (section 23.4.2), or to the project specifically in the com-
pile overview’s metadata options areas (section 13.5). Consult Pandoc andMulti-
Markdown documentation for how to supply CSS, either in the metadata itself
or as included files.

21.5.5 Flat XML (.fodt)
This format can be opened by LibreOffice, and from there converted into any
other word processor format you desire. For most word processing workflows,
youwill be better served by theOpenOffice (ODT) format forMultiMarkdown, or
Pandoc’s MS Word (DOCX) format. The Flat XML file approach provides a better
route for those looking to further automate the output with post-processing,
given the format’s open XML file architecture.

9 If you have installed MultiMarkdown stand–alone, then this may have been done for you.
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21.5.6 PDF (via LaTeX)
⟨Direct-sale only⟩With LaTeX installed, theCompile For dropdownmenu in the
compile overview screen will list an additional entry: “MultiMarkdown→ PDF”
This output choice makes use of the LATEX typesetting engine, and simply of-

fers a streamlined way of going from Scrivener to a printable PDF in a single step.
It is fundamentally identical to compiling as a .tex document, and then opening
that document in a TeX editor and typesetting it with no alterations.
If the document has no extra requirements, and typesets cleanly otherwise,

you will find it to be a most convenient way of distributing and archiving great
looking printable documents. There are a few caveats to be aware of:

— This method requires a full .tex document to be compiled, not a partial, or
“snippet” content-only output (subsection 21.5.7).

— When troubleshooting or performing initial typesetting it will often be
beneficial to enable the Show PDF Log setting in the General Options area
of compile overview (section 23.4.3). This will produce the full .tex log file,
and so reveal any warnings that might otherwise be ignored.

— Since this method combines a full compile with full MMD post-processing
and three pdflatex executions, large documents may take a while to fully
complete.

Where is it?
If you do not have a LATEX distribution with pdflatex installed on your
computer in an executable path, then this option will not appear in the
compile format dropdown. Scrivener looks for pdflatex in /Library/TeX/
texbin and /usr/texbin, and if it isn’t found in either of those places,
it will use the which command-line tool to try and locate a copy in the
executable path. If nothing is found in any of those places, the file type
will be removed as a compile option.

21.5.7 Exporting in SnippetMode
MultiMarkdown offers the possibility of compiling what is referred to as a “snip-
pet”, as opposed to a full document. A full HTML document is one that includes a
header and body tags around the content you compile; a full LATEX document is
ready to typeset. Snippets on the other hand only contain the content and as such
are invalid syntax all by themselves. They are however useful for post-processing
and pasting (or in the case of LATEX , including) into pre-existing boilerplates.
To create a snippet instead of a full document, remove all forms of metadata

from the Metadata Options area of the compile overview screen (section 13.5)
that would be used to classify a document, such as “Title” and “Author”. In gen-
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eral these are intuitive, but refer to the MultiMarkdown documentation for full
details on which metadata fields trigger full document mode.

Return to chapter ⤴

21.6 MMD&PandocMetadata
Both MultiMarkdown and Pandoc support freeform metadata for document
classification, with some metadata being used functionally by them. You should
read their respective documentation about these fields. Beyond that you are free
to add your own without detrimental effect.
There are three possible sources of metadata in Scrivener, all of which will be

combined into one metadata block at the top of the compiled output:

1. Project specific: this is where you would set such things as the author
name, copyright information and so forth. To set up project-level meta-
data, which will be attached to every document you produce with it, use
the Metadata Options tab of the compile overview screen (section 23.4.3).

2. Compile group specific: if you place a document called “Metadata” at the
very top of the selected documents you will be compiling, Scrivener will
append the text in that file to the metadata block. Refer to the following
section for details.

3. Compile format: the chosen “look” of a document, or the format, is
where you would typically make such declarations as stylesheets, docu-
ment classes and so forth—depending on the target file type. This is done
in the Metadata compile format pane (section 23.4.2).

Figure 21.7 Metadata can come from three sources, colour coded for your con-
venience.
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In Figure 21.7 we can see an example using all three methods described here.
The green text is metadata coming from the project’s compile settings. The au-
thor’s name and copyright declarations aremadehere. Below that, in purple text,
we have formatting decisions made by the chosen compile format. In this case
we can imagine Ralph is using HTML, and has chosen a favicon and stylesheet
for publishing documents of this style with. They might apply these settings
to multiple projects over the years. Lastly, in blue, we have information being
supplied by the compiled documents themselves—namely the “Metadata” file in
their draft or front matter folder. This might change from one day to the next,
depending on which article they are compiling.

Return to chapter ⤴

21.7 Using aMetadata Document in the
Draft

Supplying metadata from a document in the binder provides a way of establish-
ing information specific to the compile group. Let’s say you are publishing a
series of articles out of a single project. The “Title” and “Date” metadata fields
would make good candidates for this method as these would change from one
article to the next, while the “Author” field would probably not change and be
better suited for the project’s global compile settings.
The contents of this file should be properly formed for the system you are

using. With Pandoc you should use YAML formatting and lowercase metadata
keys. MultiMarkdown can use either YAML or freeform “Key: Value” lines, and
is case-insensitive. Refer to their latest respective documentation for further
details on their metadata handling.
The only requirement for the metadata document is that it be the very first

item in the list of things to be processed during compile. Any of the various
features of the Contents tab can be used to achieve this. A few examples include:

— Selecting a subfolder of the draft to compile, and ensuring each such folder
has a “Metadata” file at the top.10

— Using Collections as your compile group (where themetadata file could be
added to the top of the Collection).

— Using the Front Matter feature to swap out metadata sets.

— Setting filters to selectively use the appropriate metadata file for the con-
tent being delivered.

10 For backwards compatibility, the file can be named “Meta–data” or “Meta data” as well.
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Limited compile processing will be applied to the content of this document,
chiefly including Replacements and placeholder evaluation (such as the <$year>
placeholder). It will otherwise be inserted verbatim into the metadata block for
theMarkdownfile, within any othermetadata generated by the compile settings.

Return to chapter ⤴
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Part IV

Final Phases

Nothing stinks like a pile of
unpublished writing.
Sylvia Plath



Distilling your work into a final product is an essential task for any writing
application. Scrivener approaches this problem frommultiple fronts, giving you
plenty of options for producing a manuscript, web pages, printouts, ebooks, and
quite a bitmore. Most of thesemethods are functions of the compiler, a powerful
export feature which will take the contents of your draft folder and produce a
single document from the many pieces that comprise it.
At a basic level this is done by choosing a basic look, and then selecting from

different template layouts to represent the types of documents in your draft
(should folders have numbered chapter headings, or just print the folder name—
should files print a title or have scene separators between them, etc.). At its more
complex, you can design your own formats, create new layouts and even create
your own file types (going beyond .docx and the many types we already supply,
that is).
If you are accustomed toworking in a word processor, youmight want to start

with the “default” format, letting the formatting you do in your editor as you
write be the basis for how a document will look, leaving the compiler to mainly
just sew up all of the files into one document. If you are used toworking in plain-
text, or anotherworkflow that does not regard formatting as part ofwriting, then
you might be interested in trying one of the presets that formats your work for
you, such as the submission manuscript format. You might even try your hand
at book design, getting a good start on the project with one of Scrivener’s ebook
formats.
The compiler can also be a tool for producing specialised reports, by selecting

only portions of each item in theDraft to be included, such as just the title and its
synopsis and metadata. The enumerated outline preset demonstrates one such
strategy, where an indented outline of all your draft titles will be exported as a
file.
Many authors will be taking their finished drafts to a word processor, desktop

publishing, or scriptwriting application for final post-production work. We will
discuss several common applications on the market and how best to work with
them in Scrivener.
Finally, we will also discuss more traditional methods of printing and export-

ing, aswell as a few techniques you canuse to addfinal polish to yourmanuscript.
If you’re proofing, sometimes the easiest thing to do is simply print the file you
want to take a red pen to.
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Creating a Table
of Contents



22.1. Creating a Contents Page

With the notable exception of ebooks and Pandoc’s DOCX export, there is no sup-
port for inserting a dynamic table of contents into your draft—that is, one that
will update itself as you change the names of items in your draft or move them
around. By and large, the necessity for having such a tool in the writing space is
made absent by the fact that your binder is an effective table of contents.
But for output, there are tools to produce a static list that is cross-referenced

to page numbers. This feature is mainly useful in conjunction with the PDF/
Printing workflow, though it will work with most file types Scrivener supports.
PDFs are more portable than word processor files, since page numbers are

baked into the file and do not rely on dynamic features that only some word
processors support. If you intend to distribute the file to a number of people,
and are unsure of what word processor everyone uses, PDF will provide the most
consistent result between all platforms.
For word processing or design workflows, where you intend to take what is

compiled from Scrivener and develop it further in other software (such asWord,
LibreOffice or InDesign), it is almost always best to leave the creation of a table
of contents to these programs.1

22.1 Creating a Contents Page
Creating a table of contents is a simple process, but because it is a static list, you
will probably want to save it for one of your final steps before compiling, as any
subsequent changes in outline order or the addition or removal of sections will
not be reflected in the list:

1. Select all of the items that you wish to have included in the ToC. It may be
easiest to do this in outliner view mode, so you can collapse and expand
the various containers until the outliner looks roughly like what you want
the ToC to look like (speaking from a standpoint of content).

2. No matter which view you are working from, once all of the appropriate
items are selected together, use one of the following menu commands:

— For word processing and print: Edit ▸Copy Special ▸Copy Documents
as ToC

— For ebooks2 and web pages: Edit ▸Copy Special ▸Copy Documents as
Structured Link List

1 To read a small tutorial and demonstration project describing this process, refer to this forum
post.
2 Note that ebooks will by default generate a table of contents for you. You would only need to
create your own if you wish to override this. Refer to the following section for details.
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3. Create, if necessary, an empty file in the draft (or appropriate frontmatter)
folder and paste the ToC list into this document. When pasting a contents
list for print or word processing, the software will ask what amount of in-
dent you would like to use to represent each level of hierarchy in the out-
line. A level 1 item will never indent, under default settings a level 2 item
will have 36 points (or half an inch), a level 3 item 72 points (one inch), and
so forth.

Your settings will be remembered for this project.

Creating Sectional Contents

If you need to create a mini-ToC in the preface for each part of a book,
such as is the ones you see in this verymanual for larger chapters, you can
follow the above instructions to produce a smaller scale list of sections.
Youwill just want to select the relevant section instead of the entire draft
and paste the ToC copy into the preface area for each part.

22.2 ForWord Processing and Print
22.2.1 How the ToC FeatureWorks
The resulting list will be formatted with the hyperlinked binder title followed
by a special placeholder on the right, also linked. The amount of indent you
specified when pasting will be applied to each line in accordance with its relative
outline depth. This linked text will be converted by the compiler in the following
ways:

— The <$p> placeholder, will be replaced with a page number reference.

— The title will also be examined and updated to match the visible name of
the sections as they will be compiled.

For example, if the compile format you are using replaces binder titleswith
the word “Chapter” followed by a sequential number, then the Table of
Contents link text will be changed to this, rather than displaying the in-
ternal binder title.

You also can create your own table of contents by hand. There is nothing spe-
cial about the “Copy Documents as ToC” command that cannot be replicated
manually. So if you do not like the default look, you can either adjust the for-
matting after pasting or generate your own ToC from scratch by using the <$p>
placeholder and linking it to the section it should reference the page number
from. The title should be linked as well, if you wish it to acquire any prefix or
suffix information. Read Linking Documents Together (section 10.1) for more
information on creating links.
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22.2.2 Things toWatchOut For
— Word processing files: as noted above, it is usually best to use styled headings

and the word processors native table of contents feature. But if you would
prefer to use Scrivener’s tool, be aware that when opening the file for the
first time, some word processors will require you to regenerate the page
numbers tokens by running a test print preview once; they will appear as
question marks until you have done so.

— Compatibility: this feature requires word processors capable of under-
standing bookmarks and cross-references. Page numbers may appear as
question marks if the software does not.

— Using headings in the text: if you are not using title generation in compile,
and are instead relying on a styled title within the draft text itself, you will
find the “Copy Documents as ToC” feature less useful and might wish to
create your own from scratch.

— Truncated titles in ToC: some built-in Compile Formats might truncate
document title links to the prefix alone, rather than the full title. E.g. you
might have “Part II” on one line and the name of the part on the second
line, but only “Part II” shows up in the ToC. Adjustments to how linked ti-
tleswork can be found in theDocumentTitle Links compile format option
pane (section 24.8).

— Missing page numbers: if some items come outwith no page number, check
to make sure those items are included in the compile settings, and are set
to output text. An example of how this might occur is if you intend to use
faolder names as chapter headings, but then never assign the Section Type
that folders use to a Layout that prints anything (by default all Types print
“as-is”, which for a folder would likely be nothing).

— Missing leader lines: the dashed rule used between the title and the page
number is a macOS text engine underlining feature which may not be vis-
ible in all word processors.

22.3 Contents in Ebooks
When compiling for Mobi and ePub ebooks, an integrated table of contents will
be generated for you.3 This creates both the software contents (whatmany ebook
programs will present as a navigation menu) and a so-called HTML table of con-
tents page, that your readers will be able to flip through, using links to jump to
different areas of your book. Most of the options pertaining to the generation

3 Pandoc ePub books can also have aToC created for them, though in that case it is driven entirely
by the Markdown heading structure; there is no way to create a custom listing, as described in
this section.
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of these contents will be found in the Table of Contents compile settings tab
(subsection 23.4.6).
In some cases you may need to override or modify how the automatic ToC

works:

— Tomove the automatic ToC fromone location to another in the ebook, use
the <$toc> placeholder tag in an otherwise empty document in the draft
folder. When compiled, this document should be assigned to a Layout that
inserts a section break and no title.

Remember that many people get to this page via a menu in their ebook
reading software or devices, so where it appears is often not important.
Placing the ToC at the end of the book is a common tactic as it keeps it out
of the way, but is discouraged by Amazon as navigating the reader to the
end of the book can disrupt the cloud sync system which keeps multiple
devices updated to the furthest point in the book one has read to. It is
likely other systems use similar mechanisms.

— To omit a type of document from the automatic ToC, your best optionwill
be to create a Section Type (section 7.6) to define the type of item (such
as a figure that should appear on a new page but not in its own section),
and then create a Section Layout in your compile Format (section 24.2) for
such unlisted book sections. Set theHide entry in HTML table of contents
option in the “Settings” tab for that Layout. This method is only available
to ePub and Mobi.

— For somebooks, the automaticToCwill not be sufficient. To replace itwith
your own custom ToC page follow the previously described procedure for
generating a static ToC (section 22.1).

Properly Formatting an Ebook ToC Page

The guidelines for creating a valid ePub or Mobi book are strict, and as
such one needs to follow these rules when constructing a custom ToC
page within Scrivener: (a) the section must have a heading that is styled
using one of the numbered heading styles, such as “Heading 1” (either in
the text itself, or generated by the Layout the section uses in compile),
and (b) the rest of the content must consist exclusively of links pointing
to other sections of the ebook, one link per line. Indent levels for each
line will be scanned, and produce a “folder” style navigation in some de-
vices, where one can drill down from “Part I” to “Chapter 23” to “Section
23.8”. Deviating from these guidelines may result in a book that does not
validate.

See Also…
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— Compiling the Draft (chapter 23)

— Linking Documents Together (section 10.1): the crucial glue used to make
contents interactive, so readers can jump straight to the listed sections.

— Table of Contents compile option tab (subsection 23.4.6): for setting up
ebooks.

— Compiling Document Links (subsection 10.1.4): describes how links are
compiled, which is pertinent to how the table of contents feature works in
Scrivener. Note that the Remove all hyperlinks compile option will never
strip out the links applied to <$p> placeholders.

— Document Title Links (section 24.8): the compile format pane that sets up
how internal document links will be converted (such as adding the “Chap-
ter n” prefix, or even substituting for it entirely).
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The main purpose of Scrivener is to provide a place that will help you write
a long work—whether that be a novel, thesis, screenplay, non-fiction book or a



23.1. Compile Overview Screen

series of technical manuals. This work will nearly always be structured as indi-
vidual pieces in the binder, sometimes a great many, but no matter how many,
they can easily be saved as one large file for working with “the rest of the world”.1

It all begins with the File ▸Compile… (⌥⌘E) menu command.
At its most basic, the compiler takes the contents of the “Draft” folder, for-

mats it as you specify, and outputs (or prints) it as a single document. Using
the various settings available, you can export or print your texts however you
like—even regardless of how the files are formatted in Scrivener itself. Consid-
ering the many types of things one might use Scrivener for, we support a diverse
array of workflows, from as basic as printing paper out of your printer to link-
ing Scrivener together with established programmable interfaces for automated
post-processing.2

Compile settings are an intrinsic part of your project; they’re just as much a
part of it as any folder or file in your binder. They will be saved with the project
and travel with it if you move from one computer to another or share it with a
collaborator.
Going deeper, you can create your own formats, either fromscratch or tomod-

ify existing settings. These can then be saved for use in other projects, shared
with others—and of course, you can import formats others have designed.

I don’t need all of this; just print my words!

Aren’t too worried about the specifics and just want to get all of the text
you wrote out into a single file? You’ll probably find that most of our
built-in templates work out of the boxwithout adjustment beyond filling
in your name and giving the book a title and maybe a cover. And if even
that is toomuch, you can just click the “Default” format in the left sidebar
of the compile window, leave theCompile for setting to “Print” ormaybe
“PDF” and click the Compile button in the lower right corner.

23.1 CompileOverview Screen
Formost projects youwill rarely need to go anydeeper thanwhat you candowith
the compile overview screen. It has everything you need to change the file type—
such as word processing files for programs likeWord and LibreOffice,Web, ePub
andmore (section 23.5)—the basic look of the document, how those looks will be
applied to your work, and then a number of options for how the file should be
created, from its title or whether to include annotations and comments.

1 If you’re looking for a way of exporting individual files from your binder rather than turning
them into one document, check out the documentation on Exporting (chapter 25).
2 And if none of that made sense, don‘t worry about it. If it did make sense, rejoice: you can use
Scrivener to create XML files using your own hand–brewed schema and pipe them to a server’s
API automatically, if you really want to.
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Figure 23.1 A set of short stories being prepared for compilation to a blogging
site.

The compile overview screen is split into three columns (Figure 23.1), meant
to be used in a left to right fashion:

1. Compile Formats (section 23.2): listed in the left sidebar, the availability of
these are determined by the type of file you select with the Compile for…
dropdown at the very top of the overview screen.

2. Layout Preview (section 23.3): themiddle column displays a categorised pre-
view of the appearance of your document, based on what layouts the For-
mat has to offer, and which of these are in use by your settings.

In the illustration we have “Short Story” and “Scene” documents in the
draft. Each short story will have a page break with the name of the story
printed in a decorative heading. Following that we can see what a scene
will look like. If you change the compile format in the left pane, you will
often see different looking preview tiles.

3. Compile Options (section 23.4): on the right hand side is a tabbed option
view. Chiefly, and visible in the figure, is the Contents list, where you can
get an overview of what will be included in the output, make large-scale
adjustments to that and as well you can change individual document types
(printed to the right of each title) on the fly if you spot a mistake.

The other tabs provide options based on the type of file you have chosen to
compile, as well as a number of settings common to most file types. Most
of these settings are global to how your project will compile.
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Let’s take at a look at each of these columns in greater detail.

Return to chapter ⤴

Upgrading from Scrivener 2

You might be asking at this point, where are my project’s compile set-
tings? We have done what we can to make the transition as smooth as
possible, but it would be impossible for us to provide a completely seam-
less conversion, given how different the new compiler is from the old. If
you are a facing a rapidly approaching deadline, it might be a better idea
to hold off on using v3 initially, until you have some room to breathe
and can explore the new system without external pressure. But if you do
want to dive in, or have the time to learn it, a good way to get started
will be by importing your old project’s compile settings as a new format
(subsection F.1.6).

23.2 Compile Formats
The left sidebar contains a list of formats applicable to the current file type you
have chosen along the top of the compile overview screen. For example, if you
select “Plain Text (.txt)”, then you will only see those formats that are useful to
this file type (e.g. without a concept of formatting or fonts, the “Modern” format
paired with a .txt file would be largely meaningless). This list is broken up into
three sections—not all of which may be visible:

1. Project Formats: compile formats that have been saved into the specific
project you are working with. Some built-in templates come with their
own project templates set up for you. If you’d like to make those available
to other projects, refer to Project vs My Formats (subsection 24.1.1).

2. My Formats: any formats you have installed or created that are saved to the
computer. All of your projects can make use of these formats, and so long
as they are configured for the file type you are using, they will always be
shown.

3. Scrivener Formats: we ship a few example formats that you are free to use
for your own work, or more ideally, as starting points for your own de-
signs. They have all been built especially to work with our built-in project
templates and the default style list. These formats cannot be deleted or
modified directly (you can duplicate and refine them for your own pur-
poses of course).

At the very top of the list you will always find the “panic button”, the Default
setting. Use this whenever you aren’t too bothered by getting things looking
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pretty, or justwant Scrivener to sew together your documents as youwrote them.
It’s also, given its simplicity, a great starting point for your own custom Formats.

23.2.1 Selecting a Format
Applying a format to your project will usually be as simple as clicking on it in the
sidebar. If you started with one of our built-in templates, you may only need to
attend to a few “author” and “title” sorts of details over in the Compile Options
(section 23.4) area, before calling it a day.
If you get a yellowwarning in themiddle preview column, thatmeans youhave

not yet selected any layouts to use for the binder items in your project; they will
simply print their associated documents verbatim rather than be styled. Proceed
to the Layout Preview (section 23.3) section for details on how to get that set up.
Once you’ve set up a Format to work with your project, those settings will be

stored for all time. Feel free to switch between formats and experiment. The
software is designed around the concept that one project may often require sev-
eral different outputs, and as such doesn’t penalise you for having multiple se-
tups all ready to go with a few clicks.3

23.2.2 Built-In Formats
If you started your project using one of our built-in templates, it may already
have special compile settings designed for it, but beyond that, Scrivener comes
with a number of useful built-in formats. Some of these have been designed to
conform to common industry standards in terms of manuscript submission and
working with agents and editors; others have been designed as useful working
tools, such as the ability to export an indented outline, or the distribution of
proofreading copies. Others are intended to produce high-quality ebooks suit-
able for self-publication, or to formats suitable for further refinement in book
design software for that purpose.
Our formats have all been designed to work seamlessly with the project tem-

plates that are built into Scrivener, and the default stylesheet that is provided
with all new projects. For example, the “Modern” format will convert text styled
with “Block Quote” to a suitable font and indent layout to fit with its design, and
will likewise adjust captions and headings that use these styles, from whatever
fonts, paragraph spacing and other formatting attributes you see while working
with the styles in the editor.4

3 If you have a strong preference as to how future projects should have this aspect set up, consider
saving your settings into a project template (subsection 5.4.3).
4 We’ll of course get into how styles work in detail within the documentation for designing for-
mats themselves (section 24.5), but it would be good to know at the top that if you make your
own stylesheets, the only thing you need to do to get them working with our built–in templates
is to use the same names as we do—or modify the names the format itself looks for.
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23.2.3 Creating a New Format
Wewon’t go into all of the sordid details involved in designing a format right here
and now. Refer to The Compile Format Designer (chapter 24) for all of that. We
will however go over the creation andmanagement of formats themselveswithin
this sidebar. To create a new format:

1. Optionally, first select a format you want to use as a basis for your own.

2. Click the + in the footer bar, and select “Duplicate & Edit Format…” if
starting from another, or “New Format…”, to begin a new format from a
clean slate.

You can also double-click any built-in format to automatically duplicate
and edit it.

23.2.4 Editing Formats
To edit a custom format you’ve made in the past, simple double-click on the for-
mat in the sidebar to open the format designer. You cannot edit built-in formats
directly, so use the previous instructions to duplicate and then edit the new for-
mat.

23.2.5 Importing and Exporting Compile Formats
Formats (even the built-in examples) can be exported from the sidebar and im-
ported into other projects, or other computers entirely. If you have downloaded
a “.scrformat” file from the Internet for example, you could import it using the
following procedure:

1. If you have the file right in front of you in your file manager, simply drag
and drop it into the Format sidebar.

2. Alternatively:

a) Click the button (or right-click anywhere in the sidebar) and select
the “Import Formats…” option.

b) Navigate to the .scrformat file(s) on the disk and select them, clicking
Open to continue.

3. Finally, choose whether to import the files into the current project by
clicking the Project Formats button, or instead make them available to all
projects with the My Formats button.

Exporting a formatwill create a “.scrformat” file on the disk. This is a goodway
of backing up the hard work put into making these formats, for sharing them
with others or transferring settings from one computer to another:
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1. Select the format to export and click the button, or right-click on the
format, and select the “Export format…” command.

2. Choose a folder to save into, provide a file name if necessary, and click Save.

23.2.6 Deleting a Format
You can remove formats from the sidebar that you no longer need:

1. Select the format to remove, in the sidebar itself.

2. Either right-click and select “Delete Format” from the contextual menu,
or click the button and select it from there.

This will only delete the copy for the format that you select. Any other copies
that have been saved individually into projects, or into the “My Formats” global
list will remain.

23.2.7 ResolvingDuplicate IDs

Figure 23.2 Duplicated formats will be indicated as needing resolution with
this icon.

Duplicating Formats from within Scrivener is safe and often useful to do.
Problems can arise if the files used to store these formats are duplicated outside
of Scrivener. This could happen if the associated file is restored from a backup
and one chooses to keep both copies, as a result of sync conflicts, or just dupli-
cating the files yourself, in the Finder.
When two ormore formats are using the same internal ID, Scrivenerwill place

an “alert” icon beside the affected formats (Figure 23.2). You should resolve the
ID clash sooner than later:

1. Right-click on the Format with an alert icon, or with any format selected
use the button in the format sidebar footer area, and select the “Fix Du-
plicate IDs…” menu option.

2. The following dialogue will show you which formats are currently dupli-
cated. When you click the Fix button, the listed formats will have their
internal IDs reset.
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This may cause projects that were using those formats to lose their Section
Layout assignments. This can be easily resolved by Assigning Section Layouts
(subsection 23.3.3) again.
If that may prove too much of a hassle, you might prefer to resolve this prob-

lem back where it began, on the disk. Dragging the duplicate format file (.scr-
format) to the Desktop and then using the import feature (subsection 23.2.5) will
automatically assign a new internal ID to the imported format, leaving any exist-
ing associations between the original format and the projects that use it intact.

23.2.8 Importing Legacy Presets
You can import old compile presets you created in the past, and even compile
settings from upgraded projects, into the new v3 compile system:

1. Click the button in Formats footer bar.

2. Select the “Import Scrivener 2 Preset…” command.

3. Choose from one of the three possible options:

a) Select a saved preset from the “Shared Scrivener 2 Presets” list.

b) Click the ImportOther… button if the presetwas stored as an exported
file, navigate to the file on the disk and select it.

c) If the project you are working from has been upgraded from the pre-
vious version, then its compile settings will be provided for your con-
venience as “Last Settings Used”.

4. Click the Import button (or the Open button if you’ve selected an external
file).

The format designer will be opened with the imported settings all ready for
inspection and adjustment. Once you are done confirming the settings, click
the Save button. The format will now appear in the “Formats” sidebar, ready for
use.

Cleaning UpOld Presets
Here are some tips for tidying up the format to best practices in v3:

— If you intend these settings to only be available to the current project, use
the Save to dropdown at the top of thewindow to select “Project Formats”.

— If the preset depended upon the “Quick Font Override” setting in the
legacy version, this is no longer done at the format level, but rather as a
per-project choice in the compile overview screen.
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— The legacy version of Scrivener had no concept of named section layouts,
rather strictly using folder, file and file groups along with their indent lev-
els to achieve a similar effect. If you click on the Section Layouts compile
format pane you could go in and rename these generated layouts to some-
thing more meaningful, such as “Chapter Heading”, instead of “Folders
(Level 1+)” and so forth.

— While there, it is also worth noting thatOverride text and notes format-
ting is now an option available to each section layout individually, rather
than a global setting. If you used this checkbox in v2 then all section lay-
outs will have the checkbox enabled, causing the compile settings to act as
they did before. However many of the additional options that were used
to include/exclude particular types of formatting have been removed; they
are now much more efficiently handled by the stylesheet system. Instead
of preserving alignment so as to keep figure captions centre-aligned, you
can now use a dedicated “Caption” style.

— Imported formats will by default be available to all file types (such as PDF,
ePub and so forth), since that is how presets worked in older versions. If
you intend to use the format with only certain types (like PDF or ePub), you
could click the button in the format pane header bar to narrow its scope.
This will limit the choices available in the dropdown menu to its left, and
whether this format will appear at all when selecting file types back in the
compile overview screen.

— For amore detailed guide, we have prepared a tutorial project that you can
download from our website.

You should find many of these panes will be familiar from the old compiler’s
option panes, but should you require assistance with any of them, refer to the
The Compile Format Designer (chapter 24).

Return to chapter ⤴

23.3 Layout Preview
The next major component falls within the centre column of the compile
overview screen. It contains a stack of tiles depicting how the various differ-
ent types (section 7.6) of document in your draft—what you can see listed in the
Contents list to the right—will be formatted.5

You can think of what happens within this middle column as how your con-
tent will be formatted into various roles. Where the compile Format states in

5 You can click on any preview tile in this column to highlight which sections will be impacted
in the contents list to the right, and hover the mouse over the tile to read its name in a tooltip.
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general terms what these roles should look like, Section Layouts provide the spe-
cific choices for what such things as a chapter heading should look like—its font
design and numbering style—and most importantly, which types of content in
your project should use that look.

Figure 23.3 Section Layouts are how you choose the appearance and function
of your document.

In Figure 23.3 we can see several types of major section headings presented by
the format, and have chosen one suitable for numbering and printing the name
of each short story, as well as inserting a customary page break.
Let’s take a look at the various settings that will influence how your document

looks:

a) At the very top of the preview column is the Font chooser. Use this to glob-
ally override the font for the selected format (including even such things as
page headers and footers), or instead to let each individual section layout
determine font settings.

b) The Assign Section Layouts… button is what brings up the interface shown
on the right side of the figure. Use this to change how the components
of your project will look when compiled. If you have a Touch Bar, this
function is also featured as a convenient button from the overview screen.

c) Click the page layout preview button to view a preview of how this Format
will lay out the headers, footers and margins. You can change paper size
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and margins in the File ▸Page Setup… tool, so if you have to leave compile
for amoment to change that, youmight want to hold down theOption key
and click on the Save button so as to not lose your settings.

d) Within the “Assign Section Layouts” interface, we can select section types
from the sidebar and then click on preview tiles on the right hand side to
choose a look for that particular type of document. In this case we have
chosen to print our “Short Story” type documents with a page break, an
automatically generated number and finally the name of the short story
on a second line.

23.3.1 Choosing theGlobal Font
Many formats will include their own font choices for the text, headings and so
forth. Thesewill be used so long as the Font setting along the top is “Determined
by Section Layout”.
When selecting a specific font, the scope of this setting is quite simple: it im-

pacts everything, from the page number on down to section types that would or-
dinarily leave the text formatting alone—even styles from the editor that would
otherwise declare a font family will be overridden by this setting. If you need a
finer level of control (perhaps you want chapter headings to use a different font
than body text for example) then you will need to edit the format itself.

23.3.2 Editing Section Layouts from theOverview
If this is your first time coming to grips with the compiler, you may want to
bookmark this spot for later. The preview tiles that you see in the column rep-
resent Section Layouts, which are themselves completely configurable, and can
be edited straight out of the preview list.

Figure 23.4 Click the “pencil” icon to edit this layout, or double-click anywhere
on the tile.

1. Hover the mouse over the preview you’d like to adjust.

2. Click the “pencil” icon in the upper right corner of the tile (Figure 23.4), or
double-click anywhere within the preview tile.
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3. The format will be duplicated if necessary, and you will be taken to the
SectionLayouts tab of theCompile FormatDesignerwindow (section 24.2)
with this specific layout selected for you.

4. When you’ve finished making your adjustments, click the Save button to
be returned to where you were in the compile overview screen.

23.3.3 Assigning Section Layouts
When switching to a format not yet set up toworkwith your project, youmay get
a yellow warning above the preview tiles (Figure 23.3). This merely means that
none of the section types in your project have been connected with a particular
look in the Layouts section.
It is perfectly fine to compile in that state; the look of the format will not be

used but other aspects of it may be, such as paper size, footnote settings and so
forth. Tomore fully take advantage of a format youwill want to tell the compiler
what the components of your draft should look like. Click the Assign Section
Layouts… button along the bottom of the column to get started.
The left side of the layout assignment window lists all of the Section Types

you are currently making use of, in the order they are defined within the Project
Settings: Section Types tab (section C.2).

— Click on a Type in this list to see which Layout it is assigned to. You can
change the assignment or make a new one by scrolling to different tiles in
the right column and clicking on the desired look.

— To make batch assignments, select all of the types you want to assign in
the left list using Shift and Cmd clicking to add to the select, and then click
on the tile these types should all be formatted like.

— If you know the name of the layout you want, you can also right-click on
a selection of types and select the layout to be used.

— The special “As-Is” layout at the bottom of the list is a way of saying a type
of document shouldn’t use any special formatting. The contents of it will
be passed directly through to the compiler, with no additions, embellish-
ments or adjustments (though separators, like page breaks or other mark-
ers, may still be inserted around the items).

— Section Types that are not in use by any binder items will be unlisted by
default. To access them, click the ShowUnused Section Types button in the
footer bar of the left sidebar.

— If you don’t find quite what you are looking for in the list of available Lay-
outs, you can edit them from this screen as well, using the same procedure
described before (subsection 23.3.2).

571



23.4. Compile Options

Once you have everything “wired up” the way it should be, click theOK button
to return to the compile overview screen. Your updated preview tiles should now
be listed in the centre column.

Keeping Preview Tiles Tidy

In projects that feature a large number of section types and layouts, you
might be able to trim down how many preview tiles you have to scroll
through in order to get an overview of the document look. Adjacent
Types that use the same Layout will be grouped together as one tile in-
stead of each having their own individual preview tiles. E.g. with three
section types called “Definition”, “Glossary Entry” and “Figure Reference”
all using the same section format called “HangingTitle Block”, youwould
see that layout preview tile only once in the overview screen. You can
change the order of types in the Section Layouts tab, in Project ▸Project
Settings….

Return to chapter ⤴

23.4 CompileOptions
Returning to the main compile overview screen, the right-hand column is sepa-
rated into several different tabs that will change depending on what type of file
you are compiling. With only a few exceptions, the settings contained within
them apply globally to your project, rather than being specific to a file type or
Compile Format:

1. The first tab, starting from the left, is the Contents tab (subsection 23.4.1).
Here is where you adjust which pieces of the binder to include in your
compiled document.

2. The second tab is where you will set up metadata (section 13.5), such the
title of the work, the author(s) and so on.

3. TheGeneral Options tab (subsection 23.4.3) contains all of those fiddly set-
tings youmight need—such as whether footnotes should be at the bottom
of each page or gathered together as endnotes, if proofingmarkings should
be included or stripped out, and so on.

4. The Project Replacements tab (subsection 23.4.4) can be thought of as a list
of search and replace commands that run whenever you compile, without
modifying the original text.

5. The Cover tab (subsection 23.4.5) is where you can set up the cover image
and catalogue thumbnail used by ebook and PDF formats.
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6. Ebook and Pandoc generated DOCX files also come with an automatically
generated table of contents page by default. The Table of Contents tab
(subsection 23.4.6) is where you can adjust whether and how this element
should put together.

All of the options in these tabs are saved into the project automatically when-
ever you compile or if you save your settings. They cannot be transferred to
other projects, so if you strike upon a combination of settings you would like to
use as a starting point in the future, consider creating a project template (sub-
section 5.4.3).

23.4.1 Contents Tab

Figure 23.5 The “Contents” compile settings tab.

The Contents pane is used to establish which parts of the project will be used
to create the compiled document. The componentwith themost immediate im-
pact is theCompile dropdown at the very top of the list, marked (a) in Figure 23.6.
This sets the compile group, fromwhich all of the other options operate as a ba-
sis.6 By default the “Draft” folder selected, and all material found within that
folder will be compiled.
In cases where you want to export only a portion of the book, or are working

in a project that includes several editions or articles located in the draft folder,
you can use this dropdown to select only a portion of the draft. The list will be
shortened to only showing the selected item’s descendants.
In addition to selecting a subgroupof the draft folder, there a few special utility

selections at the bottom of the dropdown menu that are worth noting:

— Current Selection: the selection from the active group view you were using
prior to entering compile will be used. E.g. if two cards are selected on
a corkboard or outliner when you enter compile, those two cards will be
provided as the compile group with this setting.

In all other cases the binder selection will be used, even if it is not focused.

— Search Results & Collections: the contents of the selected collection or the
current search results list will be used to populate the compile group be-
low. This will always result in a flat list, since these are flat lists themselves.
As with selections, collections can also be filtered.

6 This is also used to determine targets and statistics in the main project, in most cases.
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Figure 23.6 The compile contents list is used to establish thematerial that will
comprise the final document.

Compile GroupOptions
Depending upon the type of choice made with the Compile dropdown menu,
secondary options may appear at the top of the content list.
Two additional settings will be provided whenever an individual container

from the “Draft” folder is selected:

1. Treat compile group as complete manuscript: ordinarily when a portion
of the draft folder is selected for compile, counter numbering will be dis-
played as though the rest of themanuscript existed; chapter 13 will remain
13. When this option is enabled, the smaller portion you selected will be
treated as though it were the entire manuscript. All counters (either in
compile settings or in the draft itself) will start at 1.

This is thus useful when hosting several complete and self-contained
works in the same draft folder, and using this setting to switch between
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them.

2. Include text of containing group: enabling this adds the selected con-
tainer to the compile group. This can be useful if the container itself is
meant to generate meaningful information, like a chapter heading, page
break or introductory text.

3. When using the “Current Selection” compile group, you will be provided
with an option to Include subdocuments. With this, adjust whether your
selection should automatically include everything beneath the selected
items, too. This is especially useful if you wish to compile two folders with
many subdocuments. You can just select the two containers, open Com-
pile, tick this option and be done with it.

Content Item List
The item list is the large table in the middle, marked (c) in Figure 23.6, displaying
the contents of the current compile group. In the provided example the “Draft”
folder has been selected, and so the entire Draft contents are revealed in the list
below it. The items in this list will be indented just as they are in the binder,
hierarchically.
There are three columns within the table. It is usually a good idea to initially

scan these columns to make sure everything will act in the manner you expect it
to:

Include The first column contains checkboxes that correlate to the inspector
option, Include in Compile. When an item is unchecked it will not be
used in the final product unless settings are altered in the filter popup
(section 23.4.1). This is generally used to create static exceptions for items
which will rarely or never be a part of the compiled product. For quickly
filtering or selecting the scope of a compile to for example print out one or
two chapters, it will most often be more efficient to use the compile group
selector or filters.

Title The visible name of the item in the Binder. This may be used in the com-
piled output depending upon the format settings for its corresponding sec-
tion type. For example, it might be that folder names are included as part
of a chapter or part break.

Section Type Displays the type of document the associated item is, and allows
you to change that association right in the contents list—as described
in Applying Section Types Manually (subsection 7.6.2). This often deter-
mines how the item will be formatted, as previewed in the centre column
of the compile overview screen.

If you find yourself changing many of these by rote, it might be a good
idea to adjust how these are automatically assigned in the Project Settings:
Section Types tab (section C.2).
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Bulk changes can be made within this list:

— Hold down the Opt key when clicking on an “include” checkbox to toggle
all boxes in the same manner (on or off). When done within a selection,
only the items within the selection will be toggled.

— Individually or with multiple items selected, right-click to change either
the inclusion or section type assignment.

Upgrading from Scrivener 2

Looking for the oldPageBreakBeforeorAs-Is checkboxes? These option
have been removed from the software entirely, as what they provided is
now served by assigning types of documents to section formats that gen-
erate page breaks on their own, or display content as-is, as part of their
design. This is a logical change in that if something should be generating
a page break, it probably ought to have a section type appropriately set
for it, like “Chapter” or “Front Matter”. Meanwhile whether a section of
text should print as-is, like an interlude between chapters, should per-
haps be referred to as an “Interlude” and be set to format “as-is” in the
centre section layouts column.

Filtering
Filtering makes it possible to supply certain criteria by which the compile con-
tents list will be modified. E.g. you can have it only include those items which
have the “Red” label set to them, or conversely, remove all items from the list
marked with “Red”. Start by clicking the filter button, marked (b) in Figure 23.6,
alongside the main Compile group dropdown.

Figure 23.7 The “Filter” button reveals options for further refining the compile
contents list.
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If when you first load up compile and are puzzled by an empty list or one that
appears to be missing chunks of text, check the Filter options and make sure
nothing has been left set there from a prior session.
At the top of the popover you will be provided with a choice for how to treat

the Include in Compile checkboxes, controlled either by checking items off in
the Contents list right here, or in the inspector and outliner in the main project
window. There are three choices available:

— Included Documents: this is the default and logical behaviour. If something
is checked it will be included in the compiled document, if not it will be
excluded.

— Excluded Documents: all documents ordinarily set to be included will be
left out, and only those excluded documents will be compiled. If you use
this feature to keep notes alongside yourmain text this can be a useful way
to only export those notes.

— All: the checkbox will be disregarded outright and all documents shown in
the compile contents list will be included.

To enable further filtering, first tick the Apply filter checkbox. Filters can be
defined as either “including” or “excluding”matches, set with the first dropdown
menu, the effects ofwhich canbe seen illustrated in Figure 23.8, with the leftmost
frame showing the unfiltered contents list:

— Include: Everything matching the filter settings will be included in com-
pile, non-matching items will be removed. Refer to the middle frame in
the figure to see what this setting looks like, when choosing the “Red” la-
bel to filter by.

— Exclude: Everything matching will be removed from the list. The right
frame in the figure demonstrates a list with all “Red” items excluded.

The second dropdown specifies which type of attribute or metadata to filter
by. There are four core options always available:

— Documents with Label: documents matching the specified label will be
matched and handled according to the logic in the first dropdown menu.

— Documents with Status: as above, only using the status metadata field.

— Documents in Collection: items found in the specified collection will be fil-
tered.

— Documents in Current Selection: as with the main compile group setting,
this will use the current selection that has been made in the project win-
dow, prior to opening the compile interface. Since this method has no
optional behaviour, the third selection dropdown will be removed.
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Figure 23.8 Filtering by “Red” produces either a list of only red marked items
(centre) or a list with no red marked items (right).

— Below these core choices, any custom metadata found within the project
that is of either a List of Checkbox type will be provided for you.

Lastly, a third dropdownmenu will appear at the bottom of the filter popup if
relevant. The contents of this will vary depending on the choice made above:

— Labels, list-style custom metadata and Status will provide you with all of
the possible assignments that can be made with these fields. For exam-
ple, with default settings the “Label” choice would include selections like
“Red”, “Orange” or “No Label”. The “Status” choice would provide options
such as “First Draft” and so on.

— Checkbox-style custom metadata will give you a “Yes” or “No” choice.

— When filtering by collection, a list of every collection in the project,
whether they be standard or generated by search results. The basic Search
Results list is also available from this menu. When using these dynamic
settings, one could see a different result every time they compile.

Front & BackMatter
Mainmatter (or bodymatter) is a publishing term for the core content of a book,
from the first chapter to the last. Front and back matter are defined as the ma-
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terial preceding and following the main content of a book. Front matter (also
known as preliminaries or just prelims) will typically include everything from
the title page and copyright page to the preface and introductions. In print pub-
lishing, this often includes a different header and footer style, such as Roman
numerals for the page numbering. Backmatter (also known as endmatter) tradi-
tionally includes such things as epilogues, glossaries, appendices, bibliographies,
author bios and advertisements.
As it becomes increasingly important to be able to deliver material in multi-

ple formats, swapping out these peripheral materials dynamically, depending on
your compile target may be necessary. You could need, from one single project,
a PDF delivered to a Print on Demand service, an ebook published to Amazon or
Kobo or even a proofing instruction page for your editing and proofing team.
The specifics of these can vary in that with print formats, you might want a

table of contents that uses page numbers, but in the ebook you won’t have page
numbers, or youmight not evenwant a table of contents at all. With backmatter,
different sets of links to store pages for buying additional novels from the author
might be needed depending on whether the book is being uploaded to Amazon
or Kobo.
The front/back matter features only work when the following conditions are

set in the Contents tab of compile overview. In all other cases the output will be
presumed as only a partialmanuscript, and thus adding full bookmaterial would
be undesirable:

— The entire draft folder is selected as the compile group in the dropdown
at the top of the contents list.

— If a subfolder of the draft is selected and the Treat compile group as com-
plete manuscript option is enabled.

Additional Formatting Impacts

Besides swapping out sets for different output purposes, these features will also
commonly be used to impact other compile settings:

— When creating a Mobi file the compiler will set the point where the
book first opens to the first section following any front matter material—
traditionally at chapter one. This can be altered in the General options tab
of the compile overview screen (section 23.4.3).

— For formats with a page header or footer, different settings can be applied
to front and back matter independently, in the Page Settings compile for-
mat pane (section 24.20).

— Placeholders that print statistics, such as word and character counts, will
by default exclude material found in the front or back matter. This can be
changed in the Statistics compile format pane (section 24.16).
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— TheDocument suffix, an option of the compile format, in the Text Layout
format pane (section 24.6), which can be used to insert phrases like “The
End”, can be optionally inserted before the back matter begins.

Setting Up the Folders

The Front & Back Matter features, marked (d) in Figure 23.6, make it a simple
task to swap out sets of files depending on what your current compile file type
is. To get started:

1. Create a folder in your binder that will contain different sets of front or
back matter. In some cases you’ll want to put separate subfolders within
this, one for each type of front matter you’ll need, such as “Amazon”, “PDF”
and so forth.

2. Move your title pages and other materials into these folders. Each folder
needs to be a self-contained set of front and back matter. If you want to
use the same title page for multiple formats, consider making use of the
<$include> placeholder (subsection 10.1.5).

Want to see front matter in action?
The “Novel” project template provided with Scrivener demonstrates a
possible setupwith a group of individual frontmatter folders for usewith
corresponding publication outputs, such as standard submission or self-
publication with ebook and PDF.

Selecting a folder as a front/back matter folder will transpose all of the con-
tained items (and descendants) to the very top or bottomof the compile contents
list respectively, without altering the actual order of these items in the binder.
This will happen no matter where the source folder is located (to avoid confu-
sion, you shouldn’t place these folders inside the draft folder itself).

Locking Settings to File Type

As noted above, it will often be desirable to have different sets of front and back
matter depending on which type of file you are creating. By default, when you
set the contents pane to use a particular front/back matter folder it will stick no
matter which choice youmake with theCompile for dropdown at the top of the
overview screen.
To lock a front/back matter folder to the current file type:

1. Set the folder(s) you want to use with this file type (TXT, DOCX, ePub, etc.).
You can also choose to not use one of these settings, by disabling the check-
box to the left.
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Figure 23.9 The “ebook” frontmatter folderwill always beused for the selected
file type.

2. Click the lock icon to the right of the folder selection dropdown, as indi-
cated in Figure 23.9.

File types that have not been locked to a particular front/back matter folder
will always go on using the same common setting from whatever you used last.

Linking Front/BackMatter to Compile Groups

You can set the compiler to automatically select a frontmatter folder based upon
the current compile group, so long as the group is itself set to function as a com-
plete manuscript (section 23.4.1). This can be useful if you use Scrivener to write
multiple works into one project, where eachwork is its own compile group, with
its own front/back matter.

Figure 23.10 Matching front/back matter folder names will promote auto-
matic selection when switching compile groups.

1. In the binder, create a set of subfolders beneath themain front/backmatter
folder that match the name of the main folder used to designate the work
being compiled.
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E.g. In Figure 23.10, we have a trilogy in the Draft folder, with the Paper-
back front matter files sorted into matching subfolders.

2. In the compile overview screen, designate the main front/back matter
folder that contains the paired subfolders. In our example, wewould select
the “Paperback” folder.

3. From the compile group selection dropdown, select one of the novels. If
“Petal’s Boy” is selected as our compile group, and Treat compile group as
complete manuscript is enabled, then Scrivener will automatically select
the “Petal’s Boy” front matter subfolder for you.

This capability can be combined with locking front/back matter folders to file
types. Continuing on in our example, we could lock the PDF type to the “Pa-
perback” front matter folder, having it automatically switch between the three
subfolders depending upon which novel we compile. When we switch to ePub3,
the compiler first switches to the “Ebook” group and then checks within that
group for a “Petal’s Boy” subfolder, ultimately selecting it for the ePub.

23.4.2 Metadata Tab

Figure 23.11 The “Metadata” compile settings tab.

Metadata in this context refers to information that will be embedded in the
file that is compiled, using whatever properties or fields the selected file type has
at its disposal for recording metadata. This information can sometimes be used
by file managers and to enhance search tools like Spotlight.
This pane also sets information that will be used by placeholders that insert

the author name and book title into various places, such as the page headers,
with some formats. The contents of this panewill change a good deal depending
on the file type chosen, but the basic placeholder settings are available to all file
types.
When creating a new project, most or all of these fields will be filled in for you,

using what information Scrivener has at its disposal. If the fields are left empty,
they will become “automatic”, and the information used will be printed in light
grey placeholder text.

Book and Author Information
Title Use this to set the formal title of your work; it will be used wherever the

<$projecttitle> placeholder has been typed in. If no title is supplied, the
software will use the filename of the project, on the disk.
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Abbreviated Title Especially useful in headers, long titles often need to be
shortened to fit in the header area, so you can optionally use the place-
holder, <$abbr_projecttitle>, to display a shortened version of it. If
nothing is supplied here, it will use the Title, above.

Author’s Full Name, Forename and Surname The first field can be used to add
multiple authors if necessary. Separate each author name with a semi-
colon. The <$fullname> (or <$author>) placeholder will insert this infor-
mation into the book, and the <$forename> and <$surname> (<$firstname>
and <$lastname> can also be used if you find those more comfortable)
placeholders will be used elsewhere. If nothing is supplied here, either
your system user name or the information provided in the General: Au-
thor Information settings pane will be used (subsection B.2.3).

Word Processing andWebMetadata
The RTF, RTFD, DOC, DOCX and ODT formats all support additional fields that can
be saved into the properties of the file (accessible from most word processors).
You may need to consult guidelines for how they should be used if submitting
documents to a central repository.
WhenusedwithHTMLfiles, the information supplied herewill be inserted into

the document header, whichwill be used by search engines to optimise discovery
of the page.
The Keywords and Subjects fields should have each value separated by a

comma. Otherwise all fields are freeform.

EbookMetadata
The additional fields provided to ebooks will be inserted into appropriate book
descriptionfields, often available to e-readers to display inwhatevermanner they
provide, and used to automatically sort the book within electronic catalogues.
Most of the fields allow for freeform entry; you should consult with your pub-
lisher or distributor on best practices for using these fields.

Contributors Aswith theAuthorsfield, eachperson’s name should be separated
with a semicolon. Amazon’s conversion utility does not recognisemultiple
authors, so only the first name containedwithin a bubble will be applied to
the book. To ensure all authors are listed in the Kindle book, refrain from
using semi-colons to separate the names, or add them later with a tool that
is capable of adding multiple names to the .mobi file you’ve compiled.

Subjects A listing of topics or subjects the work covers. This is not commonly
used in fictional works. Each subject should be separated with a comma.

Description Typically used to store the marketing blurb, or a short description
of the work. You may make use of the “<$include>” placeholder in this
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field, to pull such material from where it might be printed otherwise in
the book]Including Text From Other Documents (subsection 10.1.5).

Date In most cases, to conform with standards, you should use YYYY (1914),
YYYY-MM (1914–06) or YYYY-MM-DD (1914–06–27) date formats.

Language Code Provide the standard ISO code of the language the book is pub-
lished in.

Use custom book ID A randomised unique number will be generated if you do
not provide one yourself. In most cases you will want to use some inter-
nationally recognised identified for your book, such as the ISBN.

If multiple authors or contributors have been accredited in the fields above,
the Author and Contributor Details… button can be clicked to assign roles (“aut”
stands for “author” and the rest are set to “default”), with freeform filing infor-
mation.

Fountain andMarkdown-basedMetadata
The Metadata pane for Fountain and the Markdown-based file types provides
a front-end to the preliminary metadata block found at the top of these kinds
of files.7 Pandoc format uses a YAML formatted block, which for the purposes
used in Scrivener matches the format used in MultiMarkdown and Fountain’s
metadata block. Each line in the block is prefaced by a metadata key, such as
“Title”, followed by a colon, some whitespace and the value.
By default, new projects will have both a Title and Author key added for

you, using placeholders to insert the actual information (taken from the general
metadata fields above). Thus the starter metadata for a new document, when
compiled to a Markdown or Fountain file, will look like the following (with the
placeholders evaluated to the project name and user account name by default):

Title: <$projecttitle>
Author: <$author>

What you type into the text area,marked (b) in Figure 23.12, will be printed into
the compiled document verbatim. All rules pertaining to the metadata syntax
should be followed. Empty lines in this area may cause the metadata block to
prematurely abort.
To create a new field:

1. Select the row you would like to insert the new key after.

7 Some software may refer to this block as the “frontmatter”, but we use that term by its literary
definition to refer to material, such as the table of contents and dedication page, that falls before
the main matter.
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Figure 23.12 The Fountain andMarkdown-basedmetadata panesmake it easy
to manage fields for these document types.

2. Click the+ button in the lower right-hand corner of the metadata area or
press the Return key.

3. A new row will be created in the area marked (a) in the figure. Type in the
name, whether it be to conform to a functional field or one of your own.

4. Click into the text area marked (b) to type in the value. You can use place-
holders here to extract information dynamically from the project, current
date and so on.

Individual fields can be arranged by dragging and dropping them in the key
list of the upper half of the metadata area.
For further information on howmetadata should be used, particularly for best

practices on where best to put different keys; into the compile format settings
(section 24.11), or as a “metadata” file in the binder itself, refer to MMD & Pandoc
Metadata (section 21.6).

Workingwith ExistingMetadata

If you already have a metadata block from an existing document, you can copy
and paste it into your settings in their entirety rather than creating each field by
hand and transferring the values over one by one:

1. Click into the Key area, marked (a) in the figure.
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2. Use the standard paste (⌘V) command to paste a properly formattedmeta-
data block into the compile settings, having them converted to individual
key rows.

Likewise, you can select metadata keys from this table and use the standard
copy command (⌘C) to place a valid metadata block on the clipboard.

23.4.3 General Options

Figure 23.13 The “Options” compile settings tab.

The third tab in the compile settings area contains settings for adjusting the
behaviour and appearance of text and its formatting, cleaning up the document
of struck-through text, hyperlinks, unnecessary whitespace or refitting images
to the paper size, inserting proofing aids and so forth. Many settings are only
relevant to certain types of files, and thus the options you find here will depend
greatly on the “Compile for” setting at the top of the compile overview screen.
If you do not find what you are looking for in this list (such as whether italics
should be underlined), chances are youwill find them in the compile format itself
(chapter 24).

Common Settings
There are a few options in this tab that pertain to all types of documents that can
be produced with Scrivener, or are used by a large majority of them.

Remove footnotes The exported manuscript will have all footnotes (inline or
linked) stripped out.

Remove comments All inspector comments will be stripped out. When dis-
abled, comments will be included in accordance with the current compile
format, or to a format most suitable for the type of document being ex-
ported (for example, with the rich text formats you might get a “margin
note” or comment box in your word processor when opening the file).

Remove annotations All inline annotations will be stripped out. As above,
when this option is disabled the annotationswill be formatted in amanner
suiting the type of document and the compile format settings.

Delete struck-through text Any text that has been struck-through in the out-
put will be stripped out of the compiled copy. If you use these marking
for editorial purposes, to “soft delete” text, this is the option to use to im-
plement those edits. When disabled (as it is by default), the text will be
formatted as struck-through text if the document type supports that form
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of formatting. They will otherwise look like ordinary text in formats like
plain-text.

Remove trailing whitespace from documents This option makes it viable to
not worry so much about whether or not there are empty lines at the bot-
tom of individual chunks of text in the binder. They will be stripped out,
so that only the separators inserted by the compile format will be present
between chunks of text. If you use empty lines for some important pur-
pose, you’ll probably want to leave this option off.

Insert links back to Scrivener in each section Using whatever mechanism is
most appropriate for displaying a hyperlink in the target file type, Scriv-
ener will insert a special link at the top of every chunk of text used to build
a compiled document, pointing back to that item in the project itself. This
link will work anywhere from the samemachine that project is located on.
You can for example compile to PDF and use your favourite PDF reader to
proof, clicking on these links to load sections up in Scrivenerwhen coming
across areas that need fixing. Read more about this capability, and other
Proofreading Tools (section 20.3).

This and the following options are not available to the ebook and Final
Draft document types.

Insert unique document identifiers only This subsidiary option to the prior
will not create a usable link in the exported file. However it will print
the internal identifier (in UUID format) for the binder items used to build
the compiled document. When importing such files back into Scrivener,
it will scan for text that matches this notation and build document links
based upon them. This is a safer approach to distributing proofing copies
to readers, as some software might disturb the hyperlinks inserted using
the option above—as well it will work even with formats that do not sup-
port hyperlinks natively, such as plain-text.

Rich TextOptions
Unless otherwise noted, in this case, “rich text” refers to not only the word pro-
cessing document formats (such as RTF, DOCX and ODT), but ebooks, HTML, PDF
and Print.

Export inspector/inline footnotes as endnotes These two checkboxes, one for
footnotes linked to the inspector and the other for footnotes typed directly
inline into the text, will toggle whether or not that particular style of foot-
note will be exported as endnotes instead. The manner and numbering
style in which this is done will be determined by the compile format in
use.
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Remove highlighting Text highlights will be stripped from the compiled docu-
ment, save for cases where they are used for dedicated purposes, like indi-
cating commented text.

Remove text color Likewise, this optionwill strip all customcolouring from the
compiled document and force all text to default (black inmost cases), with-
out exception. This will also remove any revisionmarkings that have been
made during drafting.

Remove all hyperlinks Strips out all hyperlinks from the produced document.
If you primarily use links as a form of internal referencing, rather than as
something you would like the reader to be able to jump from one section
of the book to another with, you will want to use this option. It will also
be useful when printing to paper, as you’d likely not want light grey under-
lined text wherever a link appears.

Convert Markdown to rich text in titles and synopses Simple Markdown for
**strong** and *emphasis* (or _emphasis_) found within titles or syn-
opses will be converted to bold and italics respectively. When using the
underscore formation with the Convert underscores to underlines when
convertingMarkdown setting in the Sharing: Export Setting tab (subsec-
tion B.8.2), then the end result will be formatted underlines rather than
italics.

Convert MultiMarkdown to rich text in notes and text That that write using
basic MultiMarkdown syntax (some Pandoc may also work, so long as it
overlaps with MMD), can tick this to use one of Scrivener’s own native for-
mats, rather than one of the dedicated Markdown compile file types.

Excepting those features Scrivener can convert to Markdown syntax (like
images), this option requires a project to be written with proper syntax
throughout. That includes avoiding rich text conventions as well, such as
not properly double-spacing between paragraphs, as Markdown requires.

Not all forms of Markdown syntax are supported, as the converter is not
a full Markdown processor. In most cases a far superior result will be
achieved using native Markdown conversion tools.

Scale images to fit page width Available to the word processing formats, im-
ages in your text editor will have their dimensions adjusted to fit within
the set paper and margin settings rather than overflowing the page. In
nearly every case it will be better to actually resize those images graphi-
cally, so that they print the way they are supposed to, as this will reduce
processing overhead and result in documents that are only as large as they
need to be.

Convert document links to link back to Scrivener Available to PDF and word
processing formats, all document links (those that point from one section
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of text to another within the binder) will be converted to links that point
back to that chunk of text in your project, rather than links that navigate
you around within the document you exported. Read more about this ca-
pability, and other Proofreading Tools (section 20.3).

Convert linked images to embedded images For the RTFD format alone, if you
have used linked images in your project text (subsection 15.6.4), this this
setting will cause the original resources to be embedded directly into the
compiled document. You will nearly always want to use this option when
producing a file that will be sent to other people or viewed frommore than
one computer.

PDF& Print Options
Several options are provided to facilitate creating PDF files for final printing, as
well as proofing.

Add printer marks Expands the physical page size so that crop marks can be
drawnaround the edge of the intendedpage. Most paper books are printed
to sheets of paper far larger than the paperback pages themselves. The
printer will trim the pages down to size, using the cropmarks as guides for
doing so. See also: setting a Bleed on the cover image (subsection 23.4.5).

Reduce file size Provides tools for potentially reducing the quality of a PDF file
at the expense of its image quality and compile speed. For quick & dirty
proofing copies, full high-resolution and ready-to-print graphics are rarely
necessary, and only bog down bandwidth requirements in sending out
these proofs.

Unless your material has a majority of files far larger than you’d ever need
for print (and if it does, you should look into fixing that, as Scrivener
shouldn’t be storing anything larger than what you need to print), default
settings will not compress or reduce your PDF size, but rather greatly bloat
it! Take care to tweak the provided settings for best results.

The following options in this section can be found by clicking on the
Compression Settings button.

Resolution Adjusts the ratio between raster size and physical output size, and
has the following modes of operation:

— Do not change: image resolution will be left alone. You should use
this option if you have already carefully sized your graphics.

— Set: determines themaximumDPI for images. Any images larger than
this will have theirmodified to the set amount, and any pixels unnec-
essary to display an image at that resolution will be discarded from
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the compiled image. In most cases 300 DPI be far too much for what
you need. A typical screen only has around half the DPI.

— Scale: provides access to Apple’s “scaling” feature. The effects of this
are undocumented by Apple.

Compression quality This slider impacts how much compression Scrivener
should use when saving image files to JPEG. Dragging the slider to the left
will lower the quality of your graphics, but potentially reduce the size of
the overall document.

Cover images will not be compressed

Owing to how cover images are added to the PDF, compression settings
will have no effect on them. If your book only has a cover image, it likely
will not need to be made any smaller than it is. If the cover image is so
large that it is a problem, then that problem itself should be fixed by using
a graphics editing program to reduce the size of the cover image to fit the
print specifications.

Max size (pts) Specify the maximum height or width of an image, in points. For
example, with a typical US Letter page, 1 inch margins all around, the
widest image you would ever want is 468pts, or 6.5 inch. Of course set-
ting this to “468” will mean you can have no images taller than that either.
Thus this tool will primarily be of use for quick and dirty scaling to make
proofing copies smaller.

MarkupOptions
These settings pertain to theMarkdown-based document types at the bottom of
the Compile for dropdown. Pandoc’s ePub setting also supports some options
described in the next section.

Convert rich text to MultiMarkdown If you use Scrivener as a rich text editor
but find yourself wishing you could make use of its technical formats, like
DocBook or LaTeX, this is the checkbox for you. It will enable a broad
spectrum of rich text to MMD conversions, with the intention of providing
as much conversion as there is overlap between these two systems.

This option will primarily be of use to those who do not use Markdown in
their writing. In fact, it strives to keep the text of the document you create
similar (in terms of content) to what you might get if you compiled the
same text to any non-Markdown file type. To that end it will escape punc-
tuation marks found within the text that might be used by Markdown, to
ensure they remain visible as they would in RTF, ePub and so forth.
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Escape special characters Although it is possible to use Markdown with the
previous option, you will need to specifically instruct Scrivener of your
intention to do so at each point of use in the text. Themost flexible way of
doing this will be to make use of styles to denote Markdown syntax, and
in the compile format designer’s Styles pane, set that style to Treat as raw
markup (section 24.5).

Disabling this option is not intended to allow a hybrid use of Markdown
and rich text conversion. It is primarily to allow for some characters to be
passed through for purposes such as clean transfer of citationplaceholders.

Since this may cause accidental conversion of certain types of text into
Markdown features, you are encouraged to carefully proof the results
where any such characters may be used.

Convert tables and lists to MultiMarkdown When enabled, converts rich text
tables and bullet/enumeration lists to MultiMarkdown and PandocMark-
down (lists will be Markdown compatible). For further information
on how this feature works, refer to Markdown and Scrivener (subsec-
tion 21.4.3).

Operating as a conversion subset, this will be disabled when the Convert
rich text toMultiMarkdown is enabled. This option otherwise treats your
text asMarkdown, unlike the previous option. You can freely use your own
markup, and thus it is meant to be complementary with a hybrid writing
method, as described in Markdown and Scrivener (section 21.4).

Convert links to MultiMarkdown Converts hyperlinks of all kinds into MMD—
or Pandoc, if Use Pandoc syntax has been enabled in the Processing com-
pile format pane (section 24.22). Links to files and Web resources will use
standard Markdown syntax for doing so. Links that point to other areas
of the binder, functioning as cross-references for the reader, will be con-
verted using MMD or Pandoc nomenclature for doing so. For more infor-
mation on how Scrivener converts links to MultiMarkdown syntax, refer
to Hyperlinks and Cross-References (subsection 21.4.6).

Treat “Preserve Formatting” as rawmarkup Requires theConvert rich text to
MultiMarkdown checkbox to be ticked. If now and then you need to do
something that Scrivener’s converter cannot handle, use this setting to in-
sert your own hand-typed markup into a document that is otherwise en-
tirely rich text. Mark such blocks of text with the Format ▸Preserve For-
mattingmenu command to cause the compiler to leave these spans of text
alone, rather than “escaping” the markup so that it prints verbatim.

Show PDF log ⟨Direct-sale only⟩When using the MMD→ PDF conversion option,
this option will print the LaTeX log file that is generated when typeset-
ting the document. Use this to help locate and fix problematic formatting,
figure out errors that block output and so forth.
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Ebook &HTMLOptions
With the exception of the first option in the following list, these settings are only
available for ebooks.

Convert document links to HTML links Internal references to other items also
located in the compiled output will be cross-references for the reader.
In web pages and ebooks, this means people will be able to tap on the
linked text and be taken to the section you refer to. This will even work if
the sections themselves have been glued together into one longer formal
section—like subsections within a chapter.

This option has no impact on the automatically generated table of con-
tents in ebooks, or a designated contents section in the draft, only the links
you create yourself in the text.

Downsize and resample inline images to visible size To cut down on the over-
all size of your ebook, youmay wish to have Scrivener resample the graph-
ics when compiling. This option will physically resize the graphics for the
compiled output. It is not destructive; the original images in the project
will remain untouched, as is the case for nearly every function in the com-
piler. Additional options are available:

— DPI: sets maximum target DPI for all images in book. Those images
with a higher resolution than this setting will be downsized.

— Max size: sets the absolute maximum height or width in points.

Use pop-up footnotes There is no reliable part of the ePub specification that
can be used to present footnotes in a pop-up bubble, as opposed to a link
that will take the reader to another point in the book. But there is a loose
convention that some readers will follow, and this option adds the neces-
sary syntax to the HTML to do so.

Optimize for Kindle conversion This option will enable additional tweaks to
the structure and formatting of an ePub that may produce a better result
when submitting your ebook to publishers, who will convert your book to
Kindle formats for you. Do not use this option if you are submitting your
ePub to Amazon’s KDP.

Save source files in a folder with exported Kindle or ePub file This is an ad-
vanced feature intended for those whowish to customise the look and feel
or structural layout of their ebook after compiling it. The actual files used
to create the ebook will be output as plain folders and files for you.

— For Kindle, the “.opf” file can be opened in Kindle Previewer to create
an ebook.
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— For ePub, read the “readme.txt” file for instructions on turning the
source file folder into an ebook file.

Save KindleGen log file with exported Kindle file If you are having difficulties
getting Kindle Previewer to produce a .mobi file, enabling this option can
help you determine what is going wrong. The .log file will be saved right
alongside the compiled .mobi, or where it would have been saved were it
not for the errors.

If no log file is created, theremay be a problemwith Kindle Previewer itself
and you should try reinstalling it.

Book begins after front matter For this feature to work, the Front Matter fea-
ture must be enabled (section 23.4.1). The book will initially open at the
first section that follows the material added as front matter. This can be
useful if the front matter you are inserting with the feature is not essential
for the reader to see, and you wish for them to start right at chapter one.
When unchecked, the book will open at the start of the entire book, and
so is thus useful when the front matter contains text that is important for
the reader to go through.

You can alsomanually supply a starting point by typing in the placeholder,
<$ebook_start> into the section you wish the reader to start at.8 The
placeholder will be ignored if this checkbox is active.

ScriptwritingOptions
The Fountain (.fountain) and Final Draft (FDX) formats offer some unique capa-
bilities that various components of your project can be converted to.

First document is title page If the first document in your current compile
group is a special title page with no script formatting, leave this option
enabled. It will be assigned to Final Draft’s title page window, and kept
separate from the script itself. If you’ve noticed the first page of your script
seems to bemissing, and you aren’t using a title page,make sure this option
is disabled.

Include document titles as scene titles (section headers) The names of draft
items, as listed in the binder, will be used as scene titles in Final Draft, or as
section headers in Fountain. When Scrivener imports an FDX or Fountain
file (via the File ▸ Import ▸ Import and Split… menu command), these will be
used to generate binder item names.

8 Some Kindle devices may have difficulties starting directly in the table of contents page. You
should place this marker on the page directly preceding the ToC if you want the reader to start
there.
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Section headers use binder indenting levels Fountain section headers can op-
tionally use outline depth, although this is not used in any way beyond the
purely visual.

Include document synopses as scene summaries The content of the synopsis
field will be used to populate information into the “scene summaries” fea-
ture in Final Draft, and using Fountain syntax for the same.

Include footnotes as script notes Footnotes will be removed from the com-
piled document if this option is disabled.

Include comments and annotations as script notes All comments will be re-
moved from the compiled document if this option is disabled.

23.4.4 Project Replacements

Figure 23.14 The “Replacements” compile settings tab.

The fourth common tab, available to all file types, provides a way for you to set
up your own text substitutions, which work in a manner very similar to search
and replace, though without changing the source text used to compile.
Some example usages would be to replace an abbreviated version with a full

proper name, to ease typing it in frequently, easier usage of placeholder tags or
inserting common editing notes (Figure 23.15).

Figure 23.15 Replacements can be used for a variety of purposes, from saving
time to keeping complex placeholders out of the editor.

The replacement table consists of several columns:

— A checkbox will appear before every replacement row in the table. This
can be used to temporarily disable a replacement you might not presently
need, but wish to keep around.

— Replace: the text which you wish to instruct the compiler to look for.
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— With: whatever has been supplied in the Replace column will be replaced
with what you type into this column.

— RegEx: enables the regular expression engine (section 11.7) for both the
Replace andWith columns. When referring to stored values in the initial
search pattern, use dollar-sign syntax, such as $1.

— Case-Sensitive: when checked, the letter case in the Replace columnmust
precisely match, otherwise it will be ignored by the compiler.

— Whole Word: restricts the match to only those cases where the text is
bounded by space or punctuation. “Sam” will not match “Sammy” when
this option is active.

Creating Replacements
To create a new replacement:

1. Click the+ button in the lower right-hand corner of the table, or click into
the table and use the Return key to create a new row.

2. Type in the text you want to changed from.

3. Click into theWith field (or press Tab to cycle between fields) and type in
what the provided text should be changed to.

4. Press Esc or click elsewhere to commit your changes, and tick any relevant
checkboxes to the right of the text columns.

Looking for what you cannot see?

If you need to include whitespace characters (such as carriage returns or
tabs) in your search or replacement field, it is possible to do so by holding
down the Option key and then press Return or Tab, and⌥⌘Return for line
feeds. You will not see the characters themselves, but it should impact
the contents of the field in an expected fashion.

Removing andDisabling Replacements
To delete a replacement permanently (if you merely wish to disable the replace-
ment, click the checkbox in the leftmost column of the corresponding row):

1. Select the row you wish to delete by clicking on it in the table, or using the
arrow keys on your keyboard.

2. Click the− button in the lower right-hand corner, or press the Delete key.
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Modifying ReplacementOrder
The order of replacements in the list can be significant as they will be evaluated
one after the other from the top of the list to the bottom. Thismeans you can use
earlier replacements in your subsequent replacements, if you are feeling brave.
Thus you can change the order of replacements by dragging and dropping them
in the table.

Copying Replacements Between Projects
You can copy and paste selected replacements (use the Shift and Cmd keys to
select with the mouse or keyboard arrows, or Cmd-A to select them all) between
projects using the ordinary methods for copy and paste. Just make sure to click
into the replacements table so that when you paste Scrivener knows where you
meant to paste the replacements.
If both projects have their compile overviews open at once and you have

enough screen space to do so, you can also drag and drop between tables.

Advanced Replacements Usage
Replacements can also take a special placeholder (or wildcard), “$@” whichwill be
used to match everything between the rest of what you type in the search field.
Thematching text will be inserted into theWith field at the place where you add
the wildcard.

— This wildcard only works in the Replace field when surrounded by text to
match with, it cannot be reliably used at the start or end of the Replace
field.

— On the other hand, the placeholder can be positioned anywhere you like
in theWith field, even if all by itself.

— It must be present somewhere in both fields for the replacement to work.

— It can only be used once in the Replace field, but you can use it as many
times as you like in theWith field.

This is probably much more easily explained with some examples. Let’s say
you have typed the following into the Replace field:

^$@^

If a caret symbol is encountered in the source text, it will seek forward from
that point looking for a second caret (on that same line) and if there is one, copy
everything between those two symbols. Now in the With field we supply the
following text:

<span class="index">$@</span>
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The carets, which were part of the replacement in this example, will be dis-
carded, replaced with the expanded HTML syntax found around the $@wildcard.
Let’s look at a before and after case. The following is an example of what you
would type into the editor while writing:

This is a ^test^ of advanced replacements.

When compiled using the described settings the end result will look like this:

This is a <span class="index">test</span> of advanced replacements.

In this next example we use the same replacement search pattern from before,
but with a different output in theWith field:

\index{$@}$@

With the same exact text typed into the editor, when compiling with this re-
placement, we would get:

This is a \index{test}test of advanced replacements.

Thus it is possible to produce entirely different technical formats from Scriv-
ener using the same written text in the editor. Granted, in this case, you should
look into how compile Formats themselves can define replacements, so that you
can switch these outputs with a single click (section 24.15).

Need more?
If you should require even more search and replace power, you might
consider using Regular Expressions (section 11.7). It will be a superior
option if you need to remove wildcard text entirely, capture multiple
chunks of text or deal in content where the pattern of the text is more
important than the precise letters and numbers used to create it.

23.4.5 CoverOptions

Figure 23.16 The “Cover” ebook compile settings tab.

Available to PDF, ePub and Mobi file types. A cover image can be placed at
the very beginning of the ebook, before any content in the Draft folder. Most
ebook readers automatically use the cover image itself to provide thumbnails in
the viewer, andmanywill also display this image at full resolutionwhen opening
the book.
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To begin, you will need to import the graphic for the cover image into your
project binder. If you place this file into the front matter folder (section 23.4.1),
used by your compile settings, then you might not require adjustments to any
settings in this tab, as the default setting uses the first graphic found within the
designated Front Matter folder as the cover image.

Cover image Click the dropdownmenu below this label to select an image from
your project anddesignate it as the cover image. The image you choosewill
be displayed in the preview area below.

When added to a PDF file, the dimensions of the paper settings will be
printed below the image for your reference, along with the size of the im-
age, and whether the image will require any cropping. Cropping will be
done from the outside in, meaning the edges on both sideswill be removed
first.

Add HTML cover page Some ePub book readers will not discover an image that
has beenmarked as a cover graphic in the book’s metadata. For these read-
ers you will need a literal page in your book that contains the graphic, like
a sort of title page. They will typically look for the first graphic in the book
and use that for the thumbnail, which this option will enable.

Cover page title This option is only available when the Add HTML cover page
option has been enabled. You should not supply the name of your book
here. This iswhatwill be used in the table of contents internally, to identify
the cover page in ebook readers that allow navigation to the cover page.
The standard “Cover” has been provided as a default.

SVG This is an advanced feature for ePub books which will allow you to insert
SVG code which can be used in conjunction with, or instead of, a bitmap
image. If you have been provided with SVG artwork by a designer, or have
created one yourself, use the SVG button to access the dialogue. The text
area labelled, SVG code is where you will paste the raw code for the image.

You will need to manually specify a default view box size. Get this infor-
mation from your designer, the graphics program you used to create the
SVG code, or from the XML itself. The actual size used is less important
than maintaining the original aspect ratio. Incorrect aspect ratio values
(the factor between height and width) will cause the graphic to become
squashed.

You will need to research which SVG standard your target readers will be
using. At the time of this writing, most readers are capable of understand-
ing SVG 1.0 and SVG 1.1 (including SVG 1.1 Basic). When copying the XML
code,make surenot to include the XMLdeclaration anddoctype lines. Only
paste the SVG element and its contents. This will be the line starting with
the following:

<svg version=“1.1” id=“Layer_1”…
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…and typically going to the very end of the XML file. Pasting the entire XML
file will likely produce an invalid ebook.

Bleed Available to PDF and Print. If you are responsible for producing a copy of
your book that will be sent directly to the printers, you may be asked for a
bleed on any images that touch the edges of the printed page.

A bleed is used in the printing industry to keep background colours even
all the way to the edge of the paper. This is accomplished by overflow-
ing the image, so that it is slightly larger than the physical intended page.
Then, when the printer trims the book along the trim lines, the cut will
fall into the image (and the image will generally be designed for that). This
avoids cases where if the image is precisely the right size, small errors in
the trimming process cause a sliver of white to appear around the finished
product.

Theprint shopor publication agencywill informyouof howwide the bleed
should be. After ticking the checkbox to enable this feature, type in the
provided value, selecting the appropriate unit of measure on the right.

E.g. for a classic 6 ′′× 9 ′′ paperbacknovel, using a typical eighth-inch bleed,
the cover image itself will be scaled to 6.25 ′′× 9.25 ′′ total. The image will
be stretched to fit if it has not already been designed with a built-in bleed
width.

You will also, in nearly every case, need to enable the Add printer marks
option, in the General Options tab (section 23.4.3), so that the printer
knows where the bleed ends and the intended page rectangle begins.

Tips for GoodCovers
For ebooks, graphics for cover art should be in a standardRGB raster format, such
as JPEG, and not a vector format, such as EPS, nor CMYK colour space which is
designed for printing. If you are unsure of how to make these adjustments to
the files you have been provided with, you should contact your graphic designer
with these specifications so that they can deliver a quality version to you at the
correct size, and let them knowwhich devices they should design for (iPad, etc.).
With PDF covers you have more flexibility, and can use CMYK images as

needed.

23.4.6 Table of Contents Tab

Figure 23.17 The “Table of Contents” ebook settings tab.

In ebooks, the table of contents is often handled by the device or reader soft-
ware using a special menu or list of links that lets the reader jump directly to
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a designated spot. Scrivener will generate the information necessary for these
systems to work based on sections of text that are assigned to layouts that have
a “section break” in their format preview to the left of this tabbed area. The sec-
ond function it will perform, by default, is the creation of a “Contents” page in
the ebook itself, as something the reader comes across as they flip through digital
pages.
This tab will concern itself with how the ToC is built, rather than what goes

into it. To modify which items will appear, you will need to work with the Con-
tents tab and perhaps adjust the assignments of section types to formats that use
section breaks. For more details, refer to Creating a Table of Contents (chap-
ter 22).

Generate HTML table of contents The compiler will automatically generate a
table of contents into the text of the book itself, typically somewhere near
the front of the book. For ebooks, it is a good idea to provide this in addi-
tion to the menu-based navigation, as older devices may lack a dedicated
navigation system, leaving your readers without anyway of getting around
otherwise. If you know your bookwill only be read onmodern devices and
want to clean up the front matter a bit, it is safe to disable this option.

For Pandoc’s use of this settingwith DOCX, the settings and commandswill
be added to your .docx file, but you will need to use your word processor
to calculate or rebuild the layout of the table of contents itself, once it is
opened.

If you’d rather construct your owncustomcontents page, refer toContents
in ebooks (section 22.3).

Contents Depth Applicable to the Pandoc ePub and DOCX output, this setting
refers to the header depth in the generated Markdown itself—whether
typed in by you or inserted by the compiler—rather than Scrivener’s in-
ternal hierarchical representation of depth in the binder, or by any section
breaks.

Center body text of HTML table of contents Centres all of the titles rather than
left aligning them.

Use flat table of contents This impacts both the internal menu-driven content
structure, as well as the indenting of the HTML formatted ToC. By default,
the listing will be nested according to the depth of the items in the binder,
whichmight either cause navigation to be presented as an indented list, or
involve the reader drilling down into subsections, depending on the device
or software. For shorter works, it may be desirable to have all points of
navigation in the book visible at once and in a simple flat list. Enable this
option to achieve that look.

Bold top-level items Within the HTML contents page, those items located at the
top of the current compile group will be emboldened. If the outline has
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several layers of depth, this can be a good way of visually distinguishing
the major sections of the work.

Omit “landmark” guides By default, Scrivener will use modern referencing for
various landmarks in the ebook, such as the contents, cover image and the
starting position that the reader will open a newly acquired book to. In
some cases, such as when displayed using Amazon’s “Look Inside” feature,
these markers will become visible. Disabling this option will use the older
markers for these sections.

Table of contents title Determines the title readers will see for the generated
HTML contents, as well as what it will be referred to in navigational menus
of some readers and ebook software. If you have created your own table
of contents page using the method described in Contents in ebooks (sec-
tion 22.3), you will need to ensure that the name of the item in the binder
used for that custom ToC matches what you provide here.

23.4.7 KindleGen
This isn’t a special tab in the options list somuch as a prompt youmay get thefirst
time you select “Kindle Ebook” from the Compile for dropdown menu. Scriv-
ener itself requires Kindle Previewer, from Amazon, to be installed in order to
create Kindle books suitable for previewing on your device (for publication to
KDP, it is advised to use ePub). If you made this choice in error, simply select
another file type to bypass the prompt.

Return to chapter ⤴

23.5 Supported File Types
TheText and ebookTypes (Table 23.1) alongwithMarkdownCompile Types (Ta-
ble 23.2) shows all the file types supported by Scrivener, with commentary on
their usage.
For most word processor-based workflows, including Microsoft Word, Rich

Text (RTF) is the best option. Nearly every word processor provides solid RTF
import and export capabilities, and some even use RTF as their native file format.

Files Missing Some Features?

With the default macOS configuration, when you double-click on RTF
files in the Finder, they will be opened in TextEdit, which doesn’t support
all RTF features. To open an RTF file in your desired word processor, you
should open the word processor first and use File ▸Open…. You can use
the “Get Info…” palette in Finder to change the software associationwith
RTF either for one or all files.
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Table 23.1 Text and ebook Types

Format Ext. Description

Print N/A Used to immediately print the compiled draft

PDF .pdf
The Portable Document Format can be opened on nearly
any platform and device with minimal to no loss of
display quality.

Rich Text .rtf
General purpose rich text format. The native format for
Scrivener, used for most conversions to other formats.

Rich Text with
Attachments

.rtfd
Useful mainly for exporting to other native macOS apps
such as TextEdit, especially if image support is needed.

Microsoft Word .docx
Microsoft’s modern Word document format; preferred
for usage with Word and compliant word processors.

Microsoft Word
97–2004

.doc
Legacy format for Word. Use this if the word processor
cannot read RTF or DOCX files.

OpenOffice .odt
The OpenDocument Format is supported by many word
processors, including LibreOffice and Google Docs.

Plain Text .txt
UTF–8 (Unicode) plain-text file. Plain text contains no
formatting but can be opened almost anywhere, on all
platforms and devices.

Web Page .html Creates a single HTML file suitable for web-publishing.

Scriptwriting Formats

Final Draft .fdx
For transferring scripts to Final Draft and programs that
support that format.

Fountain
.foun-
tain

A plain-text screenplay markup format ideal for working
on the go.

Ebook Formats

ePub Ebook .epub
For use in portable reading devices that support ePub,
such as the Sony Reader, Nook, Kobo, iBooks and many
more. Makes use of the ePub 3 specification.

ePub 2 Ebook .epub
This is a deprecated file type. It only appears for projects
that made use of it in the past.

Kindle Ebook .mobi
Produces an ebook suitable for previewing on your
devices. It is not intended for publication via KDP; use
ePub instead.

Kindle Mobi
Ebook

.mobi
This is a deprecated file type. It only appears for projects
that made use of it in the past.
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Table 23.2 Markdown Compile Types

Format Ext. Description

MultiMarkdown Conversiona

MultiMarkdown .md

Export a plain-text MultiMarkdown file, useful for
archival. In combination with post-processing, this file
type can be used to generate Pandoc flavour syntax as
well.

LaTeX .tex

Exports a LATEX format file with full MultiMarkdown
parsing. Note that if you are intending to export a LATEX
file that has been handwritten in Scrivener (without
MMD), you should use the plain-text format, above.

OpenOffice .odt
Exports an OpenOffice document, and is the best way
to bring a MultiMarkdown project into the word
processing realm.

Web Page .html
Generates a clean and semantic HTML5 file, suitable for
web-publishing or further XML post-processing.

Flat XML .fodt

This ODF compatible format uses an open XML format
with sidecar images. For most purposes, the ODT format
will be more useful. At the time of this writing,
LibreOffice is the main OpenOffice fork that can read
.fodt files without modification. Nisus Writer Pro can
read .fodt files, but only if the file extension has been
change to .odt.

PDF .pdf

Using the LATEX typesetting engine, produces a simple
ready-to-print PDF file. This option will not appear
unless pdflatex or xelatex has been installed on the
system. It will not appear at all if you purchased from
Apple’s Mac App Store.

Pandoc Conversionb

Microsoft Word .docx
Produces a high-quality .docx file ready for transitioning
your project into the word processing world.

Docbook .xml
Generate an XML file using the DocBook schema. This
format is used by a number of technical publishers.

ePub .epub
For those wishing to combine a Markdown-based
workflow with e-publishing, this method allows for
both ePub 2 and 3 forms.

aRecent versions of MultiMarkdown, which are embedded in Scrivener, are not compatible with
macOS 10.13. You will need to install your own copy in order to regain access to the conversion
options in the compiler.
bThe Pandoc export formats will only appear if Pandoc has been installed on your system. They
will not appear at all if you purchased from Apple’s Mac App Store.
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23.5.1 Support for ODT andDOC formats
Scrivener natively supports MS Word’s DOCX format. For high quality ODT and
DOC files, you will want to use the embedded Aspose document conversion en-
gine. This will require a Java installation on your system, and if one is not found,
you will be warned that quality loss is to be expected.
If you would prefer to use the Aspose converter for DOCX files as well, you will

need to enable support for it in the Sharing: Conversion Settings tab (subsec-
tion B.8.4), not the compiler. This switches the feature on for .docx globally,
meaning it will also be used for importing and exporting.

23.5.2 Exporting Scripts
Script FormatRecommendations (Table 23.3) showswhichfile format constitutes
the best option when exporting to several popular scriptwriting applications.
When exporting to a scriptwriting program that does not support a dedicated

scriptwriting format, you will often be able to use a plain-text formatted screen-
play:

1. Select Compile for: “Plain-text (.txt)”.

2. Choose the “Plain Text Screenplay” format in the compile overview side-
bar.

The screenplay standard is after all based uponmeasurements used when typ-
ing out 12pt fixed-width text on a typewriter. If a text document reproduces
those spaces then all we need to transfer a screenplay between software is to
follow these old conventions. The “Plain Text Screenplay” will set up everything
youneed to get a clean import intomost programs, but should youneed to create
your own format, the following guidelines should be taken into consideration:

— To avoid strange characters appearing in the export, enable the Convert
“smart” punctuation to "dumb" punctuation option, in the Transforma-
tions compile format pane.

— Also in that pane, use theConvert to plain text: “All whitespace (add a one
inch margin)” setting.

— Set all separator types to “Single return”, in the Separators compile format
pane.

The script format itself, in conjunction with that option to convert whites-
pace, will handle the remaining details for you.
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23.5.3 Using Post-Processing to Expand File Type
Support

⟨Direct-sale only⟩ Scrivener supports full command-line access, either through
embedded scripts or by calling upon external utilities. This is a special fea-
ture provided to compile Formats, via the Processing compile format pane (sec-
tion 24.22), which is itself available when using the Plain Text and MultiMark-
down compile file types. The former can be used to construct any type of syntax
conceivable.9 The latter will first generate a proper MultiMarkdown or Pandoc
specification file, suitable for post-processing in a wide variety of utilities that
recognise the Markdown format.

Table 23.3 Script Format Recommendations

Application Best Format Notes

Final Draft & compatible FDX Supports comments and footnotes (as script
notes), synopses (which become scene
summaries), titles, dual dialogue (dialogue
marked using “Preserve Style” in Scrivener
becomes dual dialogue in Final Draft),
revision marks, custom element formats. If
a program supports Final Draft format and
doesn’t have its own format, this will nearly
always be the best format to use.

Plain-text editors Fountain Fountain is a Markdown inspired plain-text
format, and is thus suitable for writing
screenplays on a wide variety of devices.
Scrivener will convert its built-in
scriptwriting format to Fountain’s markup
automatically.

Movie Magic Screenwriter TXT You should use the “Plain Text Screenplay”
compile format for best results.

Montage RTF or TXT Montage will do a decent job of importing
script files saved in RTF or TXT formats (if
you use TXT, follow the same rules as for
Movie Magic Screenwriter and CeltX).

Return to chapter ⤴

9 Refer to our built–in General Non–Fiction (LaTeX) project template for a live example of this.
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23.6 Compiling and Saving Settings
The act of compiling itself, by clicking the Compile button, will automatically
save all of your settings into the project, dismiss the window, and compile the
project in accordance with your specifications.
You can cancel any changes you’ve made within the compile overview area by

clicking the Cancel button at the bottom of the compile window. Changes made
to the Formats themselves, such as adjusting the font of a heading, will remain
as Formats are separate from your project. Cancelling only impacts the project’s
relationship with that format, as well as any other settings in overview.
To save changeswithout going through the potentially long process of compil-

ing, hold down the Option key in the compile screen. This will switch the Cancel
and Compile buttons to Reset and Save, respectively. The reset button will revert
all changes you have made back to when the panel was most recently opened.
The save button will dismiss the compile overview, but save your settings before
doing so. This is useful when youwant tomake a change to your export settings,
but do not want to actually compile the document yet. If you have a Touch Bar
keyboard you will find these alternate buttons provided as keys.

If no extension is provided, use “.ext” The precise extension listed will corre-
spond to the type of document you are creating. For example, ‘.txt’ or ‘.pdf’.
In general you should always use this option if you do not intend to type
it in yourself in the Save as field, above. Disable it if you need to use a
different extension than what is standard (“.xml” for instance).

Overwrite preserves other existing files This special option only appears for
those document types that potentially produce many files (often images)
when you compile—such as HTML or theMarkdown-based formats. When
doing so, Scrivener will create a folder to put these materials into, and if
that folder already exists it will by default erase it and then rebuild it from
scratch. If you want to put supporting materials into that folder (such as
CSS files) and have Scrivener leave them alone, only rebuilding the files it
generates on compile, then enable this option.

Open compiled document in This handy option will cause the compiled file to
be automatically opened in the viewer or editor of your choosing. A list
of applications that have declared themselves as capable of handling the
document type you are using will be provided. The choice you make will
be persistent across all projects using that type of document. For example,
if you select Adobe Reader to load the compiled PDF then all projects that
compile to PDF will send their output to Reader.

Return to chapter ⤴
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To open the format designer you will either need to create a new format (sub-
section 23.2.3), possibly duplicating an existing one, or edit a custom format
you’ve made or imported in the past by double-clicking on it in the Formats list.
You will be greeted by the compile format designer window (Figure 24.1).
The provided built-in formats (and those found in project templates) are all

well and good—and in many cases may be all you need to get your work out to
the rest of the world—but if you want to dig into what makes these settings tick,
perhaps to build your own unique document designs from scratch, or even just
change something as simple as the font used for chapter headings or add your
own heading style, then the format designer is where it all starts, and ends. Ev-
erything that we provide in our defaults can be done here, and thus every aspect
of them can be changed or reproduced whole cloth.
Themost important thing to keep inmindwhen designing ormodifying a for-

mat is that compile formats are completely separate fromprojects. Even if you create



Figure 24.1 The compile format designer window, showing the “Styles” pane.

a format that is saved into the project alone, the design intent doesn’t change,
and you could easily copy that format to another project ormake it globally avail-
able at any time. A good way of thinking about it is that you’re making a general
look for a class of documents. The tools you’ll have at your disposal are all de-
signed for influencing how such documents should be produced.
We’ll first go over the basics of setting up anew format ormodifying one you’ve

copied. Then we’ll go over each of the panes in the sidebar. You won’t ever see
all of the panes that are listed in this chapter, since many only pertain to one
format or another and the list, marked (b) in Figure 24.1, will only show those
panes relevant to the file type indicated in the header area above them (a).

Not every pane or option is showing up

If Java is not installed on the system, Scrivener will fall back to using the
more basicmacOS exporters for .doc and .odt files. Youwill notice a drop
in how many features exist in some key panels, notably those that influ-
ence layout and notation features. If you must use one of these formats,
you are strongly encouraged to install Java, as the default macOS con-
verters have very poor quality. Alternatively, most word processors read
RTF perfectly, including LibreOffice and Word.

610



24.1. Setting Up the Format

24.1 Setting Up the Format
Once you have created a new format (subsection 23.2.3), the first thing to do is
give it a name—how it will be shown in the “Formats” sidebar. Type the name
into the Format name field.
If you are building a format designed for plain-text output, you will notice an

Extension field in the upper-right corner of the designer window. This will set
the default file extension used when compiling. If your purpose is to create a
specific format such as XML, LaTeX, reStructured Text and so on, you will want
to set the extension appropriately.

24.1.1 Project vsMy Formats
At the top of the format designer, right beneath where the name of the format is
set, you can choose where the format itself should be saved, under Save to:

— Project Formats: the format will be saved directly into the project you are
working on, and will only be available to that project. This is best for for-
mats that are very specific to one project.

Since project formats can be saved into project templates (subsection 5.4.3),
thatmeans you canuse a format you’ve created inmultiple similar projects,
without cluttering up the format sidebar.

— My Formats: the format will be saved so that it is available to every project
you use. You can think of this as it being a format installed into the com-
puter itself. This choice will be best for general purpose formats you’ve
created that might be useful for many different types of projects.

All projects use this one central copy and when they are compiled will al-
ways use the latest version of the format. If a project needs special settings
in the format, you should duplicate a copy and save it into Project Projects,
as described below.

To modify a format that has already been created:

1. Double-click the format in the format sidebar. (If instead youwant to copy
the format to a different category, right-click on the format and select “Du-
plicate & Edit Format…”.)

2. Use the Save to… dropdown menu to select the designation you’d prefer
for this format.

3. Click the Save button.

You should see the format move to the appropriate category in the side-
bar. Formats can be freely moved between categories at any time in this
fashion.
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If you are looking for away to copy a format fromoneproject’s list into another
project, you could either:

— Duplicate the format to the global category, and then from the other
project edit that format and change its designation back to “Project For-
mats”.

— Use the instructions in the following section for import and exporting for-
mats, first exporting from the project with the format, and then importing
into the other project (subsection 23.2.5).

24.1.2 Switching Between File Types
Using the dropdown menu marked (a) in the figure will switch the compile de-
signer’s focus to the chosen file type (.txt, .rtf, .docx and so forth). When you
switch from one file type to another, particularly if they are quite different in
capabilities, you will notice the available panes will change in the list below
the dropdown, and certain options may appear or disappear from within those
panes. Some panes may look utterly different depending on which file type
you’ve selected.
Switching between file types is something you can freely do as you design your

format. Even if you can no longer see a setting ticked for plain text files while
viewing settings for printing, you canbe rest assured the setting itself is still saved
within the format, and will be made use of when compiling to .txt.
For those settings that are common between file types, they will all share the

same configuration. You cannot, for example, use a different font for PDF and
DOCX, they will both share the same font. It might be good to consider whether
changes ought to become a new format entirely, if there is a need for such dif-
ferences between file types.

24.1.3 Setting the Scope of the Format
Youwill typicallywant to adjust the scope ofwhat this format ismeant to address
in terms of file types (such as PDF, RTF and so on). You do not need to create a dif-
ferent format for every type of file, and in fact by default newly created formats
will be set up as relevant to all file types. An example of a common built-in for-
mat is “Enumerated Outline”. Printing headings in a list and numbering them
is something any type of file can do. On the other hand the format designed
for ebooks is, shockingly enough, really only pertinent to the ePub and Kindle
formats (Pandoc ePub files are a special case, as they use the Markdown process
exclusively).

1. Click the button in the header area of the sidebar.

2. Tick all of the boxes that are relevant to this format.
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— Tomake this process easier, you can hold down the Option key when
clicking on a checkbox to disable an entire category.

— You must have at least one type selected, so if you attempt to turn
off every checkbox you’ll find the last remaining checkbox cannot be
modified.

You may have noticed how switching to some file types with the Compile For
dropdown menu, back in the main compile overview screen, causes the list of
formats to change—this is where you determine that behaviour.
The choices youmake herewill also impactwhich types of files you can choose

from the format designer window. If you can’t find what you’re looking for in
that list, click the gear button and make sure the file type is enabled for this for-
mat.

24.1.4 Saving and Testing Your Designs
As you work on the format you may want to periodically test the results against
the current project you have open. The Test… button along the bottom left of
the format designer window lets you do precisely this. It will run a full compile,
and so ask you where files should be saved. The file type will be determined by
which selection you havemade in the header bar of the format pane list (marked
(a) in Figure 24.1)—if you choose “Print” the Test button will not ask for a file and
will instead go straight to a print preview.
When working with web pages (HTML) and the ebook formats, an alternate

mode of testing is available. Hold down the Option key, which will convert the
button to Test HTML…, the result of which will be to export all of the source files
that would be used to construct the web page or ebook. This can be useful if you
are more comfortable reviewing your settings in an HTML editor or browser. For
example, using the web development tools available in many browsers, you can
tweak formatting in a live fashion, and once you have the look just the way you
want, copy and paste the results back into the appropriate areas of the Format
Designer window.
It is important to keep in mind that testing your settings will not save them.

The purpose of this button is to show how your experimentations are going, not
to permanently commit those settings into the format. Youwill need to click the
Save button to do so. Click Cancel if you have not made any changes you would
like to keep.
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Do I need to update the projects that use this format?

In a word, no. Once the format is saved and you have returned to the
compile overview screen, those changes you made will be used for any
projectsmaking use of this formatwhennext they are compiled. Formats
you create and store in “My Formats” are separate from projects entirely
and they all use the same copy. However if you have added new Section
Layouts, may need to revise your layout assignments, from the compile
overview screen.

If you need to save your format to make an adjustment to your project’s com-
pile settings, remember to save your compile settings before returning to the
Format Designer screen: hold down the Option key and click the Save button.

Return to chapter ⤴

24.2 Section Layouts

Figure 24.2 The Section Layouts pane showing the “EnumeratedOutline” lay-
out list.

The Section Types pane (available to all but the scriptwriting document types)
is where youwill define the available parts of a document, what text if anywill be
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included within them and design how that text will be formatted or structured
(as in the case of file types that do not use direct formatting).
In Figure 24.2 we can see the list of layouts available from the “Enumerated

Outline” compile format. It offers four choices for different numbering styles,
listed in the upper half of the pane; we can see a preview of the “Decimal Outline
Item” layout in the lower half.
The pane is split into two main sections, one atop the other:

1. Section Layout List: for general layout management, this is also where you
will set what types of content a Layout should export, such as the Title or
Text of an item. Clicking on an entry in this list will load its settings into
the tabbed view in the lower half of the pane.

2. Layout Editor: everything about how a layout works is set in this lower
half of the pane. It is divided into several tabs which we will cover in the
following sections.

24.2.1 Section Layout List
Each of the entries in this list are what will be provided in the central Layout
Preview column of the compile overview screen (section 23.3) as “tiles”. This can
be seen most easily with a simple format, such as “Enumerated Outline” (Fig-
ure 24.3). The listed items in the pane (lower right overlay) determines the names
of the tiles and the order in which they appear in the assignment panel (in the
background).
Each row has a series of checkboxes on the right hand side, used to determine

what content should be included with the layout. In this simple example, where
the goal is to print an indented outline of the heading structure of the draft, we
are only including the Title for each layout. If we wanted to print a synopsis
below each title, we would tick the Synopsis column.
Layouts in use by the current project will be printed in bold face in this list.

When selected, the footer bar will indicate which Section Types are using this
Layout. In our example, the “Decimal Outline Item” Layout is in use by the
project (bold) and when we click on it, we can see the basic “Section” document
type is using it.

Layout Content Columns
The series of checkboxes to the right of each Layout name will determine
whether the associated content itself is in the layout. E.g. a layout that is meant
to print the text of a document along with its title as a heading will have both
the Title and Text checkboxes ticked.

Title Prints the binder title of each item assigned to use this layout. The title
will typically be placed on a line of its own at the very top of the section,
much like a heading or chapter breakwould be. This checkbox is only used
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Figure 24.3 Section layouts define the preview tiles available in the assignment
area of the compile overview screen.

to bring the binder title into the content—if you do not intend to do so,
perhaps only printing the word “Chapter” followed by a number, then the
checkbox is not necessary. An item can still have a heading without this
checkbox.

Refer to Global Section Layout Options (subsection 24.2.2) for further set-
tings that impact headings.

Metadata Includes a block of text below the title containing all metadata asso-
ciated with the items printed by this layout. In the preview area, you will
see a simple “Metadata: Listed Here” marker that can be used to format
metadata lines in general. The precise content will depend on each item—
for example every itemwill have creation andmodification dates, but only
some may have a line printing keywords.

All lines of metadata will use the paragraph and character formatting you
apply to the sample line.

Synopsis The synopsis for the item will be printed and can be formatted as a
paragraph in the preview area below.
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Notes Any inspector Document Notes associated with the item will be printed
before the main text.

Refer to Global Section Layout Options (subsection 24.2.2) for further set-
tings.

Text Themain text body of the item, such as the content of a section or chapter.
Some layouts may not use this option if they are intended to be used with
types of items that serve as headings, or in some cases theymay be omitted
to achieve an effect, such as in the “Enumerated Outline” format, where
the goal is to print an indented outline of topics rather than the entire
work.

If you include content, other thanTitle andText, subheadings will be inserted
automatically to announce them. E.g. ticking “Synopsis” and “Notes” will add
respective headings above the content. These headings can be formatted col-
lectively to taste in the Formatting tab, or removed entirely by clicking the
button and disabling the Insert subtitles between text elements option.

AddingNew Layouts
To create a new layout:

1. Select the layout that most closely resembles the new one you’d like to
create. You’ll be able to change everything about it, but it will be easiest to
start from something similar.

2. Click the+ button in the upper right-hand corner, or press the Return key.

3. Give the new layout a name and click elsewhere to confirm your change.

Renaming andManaging Layouts
The order of layouts in the list isn’t of great significance, but it will determine
how they are listed in the Assign Section Layouts tool. If you want to change
their order, just drag and drop.
To rename a layout, double-click on its name in the “Layout Name” column.

This will not affect any projects using that layout for their types, they will auto-
matically adjust to using the new name.

Deleting a Layout
To remove a layout you no longer want in the format, select the layout from the
listing and click the − button, or press the Delete key. This action cannot be
undone, but you can of course close the format editor without saving changes
by clicking the Cancel button along the bottom.
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Duplicating Settings Between Layouts
Say you’ve set up a meticulously designed layout for chapter breaks, and realise
that with the exception of the title prefix, you want everything else to be applied
to a variation use for interludes. You can use the following techniques for copy-
ing some or all settings (and remember that when creating new layouts you can
always select the one you’d like to copy as a basis, before clicking the+ button):

Copy and paste portions of formatting If all youwant to do is copy the format-
ting you’ve applied from one element to another in a different area (even
in a different row), click anywhere within the sample element you wish to
copy from and then use the standard formatting copy and paste tools for
doing so:

— Format ▸Paragraph ▸Copy Paragraph Attributes (⌃⌘C) and Paste Para-
graph Attributes (⌃⌘V).

— Format ▸Font ▸Copy Font (⌥⌘C) and Paste Font (⌥⌘V).

— Format ▸Copy Formatting (⌃⌥⌘C) and Paste Formatting (⌃⌥⌘V).

The following tools work on a selected layout row in the Section Layout list:

Copy and Paste All Settings Between Rows The standard commands for Copy
and Paste can be used to bulk transfer all settings for a layout. This action
will also copy any settings that are assigned to this Layout fromwithin the
Separators pane (section 24.4).

Setting the font for all elements To set the base font for all elementswithin the
formatting editor, select the row for the type and level you wish to edit
and use Format ▸Font ▸Show Fonts (⌘T) to bring up the font palette. Any
changesmade herewill impact every single element uniformly, so save this
method for the very beginning of the customisation process. You will lose
variant, size differences, and other characteristics that have already been
applied to various elements.1

This method will not work if elements of the formatting area cannot be
modified, such as when theOverride text and notes formatting checkbox
is disabled.

24.2.2 Global Section LayoutOptions
In the upper right-hand corner, by the buttons used to add and remove Layouts,
you will find a button with a few options that will impact how all section
layouts work.

1 Bear inmind that projects using a global font override (subsection 23.3.1) will ignore this setting,
as will all other areas of the format that stipulate the font family.
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Include placeholder titles for untitled items Binder items that have been left
untitled can optionally use the adaptive name generated from their con-
tent or synopses, as they are shown in the binder and outliner. The default
behaviour is for these items to never show titles, even if they are assigned
to a section layout that chiefly exists to generate a title.

Do not add prefix or suffix to placeholder titles Whenuntitled documents are
encountered, if the section layout they are assigned to generates a generic
title (such as a chapter number), then that part of the title will still be used.
Thus an untitled documentmay still have a structural presence in the final
result. If you would prefer untitled elements be entirely anonymous and
not contribute to the structure, then enable this option.

Insert subtitles between text elements Disables automatic subtitles between
different types of inserted content, such as Synopsis and Metadata.

Place notes after main text The default is to place any Inspector notes above
the main text for the item being compiled. When checked, notes will be
placed below the main text area instead.

Add closing hashes to titles This option only pertains to the Markdown-based
formats. When adding formal titles to the document, Scrivener will en-
close the title in hashes:

### This is a Third Level Document ###

Disable this option to use the following format:

### This is a Third Level Document

24.2.3 Formatting
The “Formatting” tab serves to format the various pieces of content that can be
included as part of a layout. It will also preview some the settings that are applied
from the other tabs to the right.
The text itself cannot be directly edited, itmerely serves as a template for what

will be inserted by each binder item assigned to use this Layout. Instead, the
preview comprises multiple elements that can be selected with the mouse, and
have their formatting adjusted with the toolbar. In Figure 24.4 we can see three
such elements:

1. The title prefix (“1.1”), formatted in red-brown text, inserted from the “Title
Options” tab.

2. The section title itself, being inserted by the Title checkbox in the layout
list above.

3. The main text body, inserted by the Text checkbox. In this case the text
cannot be formatted because the Override text and notes formatting

619



24.2. Section Layouts

Figure 24.4 The Section Layouts “Formatting” tab is where you will set up the
look of a layout.

checkbox below this preview area isn’t ticked. In this condition, the text
formatting from your project will be passed through.

Tools forModifying Formatting
Formattingwithin the preview area ismodified in a similar fashion to how text is
formatted in themain editor. Themain exception is that you only need position
the cursor anywhere within the element (such as “Section Title”) to fully style it,
whereas in the editor you would have to carefully select all of the text from edge
to edge.

— Formatting is only allowed on elements drawn in black. Grey elementswill
be acquiring their formatting from elsewhere (typically the original text
as you wrote it), unless you change the override setting for this Section
Layout (section 24.2.3).

— At the top of the pane is a standardised version of the Format Bar (subsec-
tion 15.7.2).

– An additional setting, alongside the style dropdown on the left, will
be present when working with formats for HTML and ebooks. This
dropdown allows you to set the heading level (from 1 to 6, such as
<h1>Chapter Heading</h1>) for the selected element in the format-
ting area. In this way you can establish hierarchical order in your
ebook or HTML page, an essential ingredient for accessible and easy
to navigate documents.

When set to “Body text” the element will be exported as a normal
<p>...</p> paragraph.
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— All of the standard formatting keyboard shortcuts can be used, and indeed
most of the commands in the Formatmenu itself can be used to adjust text
formatting.

— The Ruler is also available for adjusting indents and tab stops.

Using Styles with Layouts
The Styles button on the far left of the Format Bar will refer to styles provided by
the format itself, via the Styles format pane (section 24.5), rather than any styles
in the project.
Format styles function a little differently to styles in the main editor in that

if you modify the formatting of the text at all after applying a style, the assign-
ment to that style will be removed, and it will no longer update when making
adjustments to the Style format pane.

Override Text andNotes Formatting
This checkbox, along the bottom of the preview area, will toggle whether or not
you can format the main text element in the preview area (assuming you are
including eitherText orNotes via the checkboxes in the layout list above). There
are a few important things to be aware of with this feature:

— Text that is styled in the main text editor will ignore any settings made
here. Styles in Scrivener are a way of declaring a range of text as special, or
anything other than body text if you will.

— It is possible to style text here, and if you require a document that has all
text styled to “Normal” or “Body”, this would be the best way to do so. You
would want to create a style (subsection 24.5.1) named as needed and then
return to the layouts that will be generating body text and apply the style
to the main text element.2

— With the exception of styled text, all text found in the main text content
for those items using this layoutwill be converted to the format you supply
here. There are exceptions made for character formatting such as italics,
bold, text colour and so on. In most cases you will not want to lose text
that has been formatted this way in the editor.3

2 Most of our built–in Formats have a “Body” style provided for just this purpose.
3 Italics have a unique exception in that if you apply italic formatting to the Layout, then any
italicised text in the editor will be printed normally. This follows the convention of using upright
characters within an italic range to indicate emphasis or special nature. Consider using Styles,
when it matters that text always be printed one way or another.
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— If you’re looking for a way to adjust first-line indents on body text so they
are removed after breaks or headings, refer to the “Settings” tab (subsec-
tion 24.2.9).

On the right-hand side of the formatting pane you will find a “paintbrush”
icon. When formatting override is enabled, this button will bring up a popover
with a few exclusions that can be applied to the concept of what is overridden:

Preserve uncommon alignment Enabled by default, this option will cause any
paragraph alignment other thanLeft or Justified to be preserved, nomatter
the alignment of the formatting defined in the sample text above. Left
aligned text will always be transformed to match the look of the layout,
regardless of this setting.

In most cases you can use Styles to achieve this same effect.

Preserve tabs and indents Enable this option to have tab stops and paragraph
indents preserved on a per-paragraph basis. This can be useful in cases
where you want to generally override the formatting of a section, but the
content of that section uses a variety of different indent and tab settings
that wouldn’t otherwise be applicable to Styles usage. A common example
of this would be a table of contents section.

Ebook Formatting
For ePub and Kindle, three choices will be made available to each Layout, where
it comes to overriding formatting:

— Text and notes use default formatting: the default setting, where all Layouts
will print main text content using the formatting defined in the upper half
of the CSS compile format pane (section 24.7). (Use the “Edit default para-
graph formatting…” selection at the bottom of this dropdownmenu to get
there.)

— Text and notes use custom formatting: functionally equivalent to checking
Override Text and Notes Formatting in other compile file types. The
mock editor above can be used to establish base text formatting for this
Layout.

— Text and notes use editor formatting: functionally equivalent to disabling
Override Text and Notes Formatting in other compile file types or using
“as-is”, but with the natural limitation that not all editor formatting is rel-
evant to ebook publishing.

Plain-text
Youmay be wondering if you can skip this when working with plain-text. Natu-
rally in most cases if you were to set the title to 24pt bold it will not do anything
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to the compiled document. There are a few notable exceptions that could be of
use to you:

— If converting paragraph and indent formatting towhitespace in the Trans-
formations format pane (section 24.13).

— Where styles are applied to text in the preview area and those styles are set
to modify the text somehow, in the Styles format pane (section 24.5). For
example, if you were building an XML format you could create a style that
wraps text in a <para> element and then apply that style to body text in
the Formatting tab to wrap all body text in these tags.

— Lastly it is also possible for the Markdown-based formats to have rich text
converted to Markdown syntax, and thus changes made to the formatting
in this pane will have an impact on that conversion where applicable.

— In corollary, when converting from rich text one can insertMarkdown into
the output document directly, through the use of raw markup styles (sub-
section 24.5.3). The ability to apply such a style to the Formatting panemay
be essential in achieving more advanced designs.

24.2.4 Title Options
The second tab in the layout configuration area provides options for adding a
prefix or suffix around the title (or even instead of the title), adjusting the letter
case of these elements and other options specific to different file types.

The following examples are available in the Extras Pack

If you would like to install the format used to demonstrate the follow-
ing examples, import the “6-TitleOptions Examples.scrformat” into your
copy of Scrivener (or a test project) from the Extras Pack (Appendix G).

Figure 24.5 The title prefix and suffix as applied in the “Formatting” preview
tab.
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The first example (Figure 24.5) depicts a single-line title using both a prefix
and a suffix.4 The “Section Title” portion that is bold and underscored is being
inserted by the Title checkbox for this layout. The Title Prefix and Title Suffix
fields are inserting two different placeholders with some dynamic text:

— Theprefix is using the <$hn> auto-number placeholder to generate 1.1, 1.1.2,
1.2.4… style numbering to the title. It is surrounded in square brackets and
is followed by a tab character. We could use that tab to space the number
out from the title further if we wanted.

In the Formatting tab, the prefix has been independently styled to grey text
with no underscore.

— The suffix starts with a single space (the small blue dot) followed by the
<$status> placeholder in parentheses. If the document using the layout
has a status of “First Draft”, then we would see it printed as ” (First Draft)”.

The suffix has been formatted to red with no underscore.

— Thewhole title line—the prefix, title and suffix—has paragraph formatting
applied to space it out from the main text below it by 12pts.

Figure 24.6 The prefix and suffix can also insert carriage returns.

You can also insert carriage returns into the prefix and suffix fields (Fig-
ure 24.6), and when doing so the formatting controls will be slightly different.5

Instead of having the entire heading sharing the same paragraph settings as we
saw before, each line can have its own paragraph spacing, alignment and other
attributes:

4 If you’re following along with the Format provided in the extras pack, refer to the “Prefix &
Suffix Example” layout.
5 This example is provided as the “Two–line Prefix” layout.
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— The prefix is typed in normally, but we are using the Case: Uppercase set-
ting for the prefix to capitalise it in the preview.6

— We could have used the Title Case: Small Caps setting to achieve a small
caps look on the title, but in all cases it is better to format the text using
its native font features for printing small caps, or to use a dedicated small
caps font variant, as we have done in the formatting preview area here.

— Finally, the suffix inserts a carriage return and a symbol.

The title prefix and suffix entries will be printed even if the Title is disabled for
that row. This allows for generic headings like “Chapter 23”:

1. Set the layout so that its Title checkbox is disabled.

2. In the “Title Options” tab, add a prefix or suffix.

3. In the “Formatting” preview tab you’ll see whatever you added in the prior
step, ready to be formatted.

As you have seen from these demonstrations, many of Scrivener’s placehold-
ers (referenced in the Help ▸List of all Placeholders… guide) can be used to good
effect in these fields. Refer to Using Placeholders in the Prefix and Suffix (sub-
section 24.2.8) for further tips on what can be done.
Beyond the prefix and suffix fields themselves, the following settings are avail-

able formodifying the title as awhole, or how those prefix and suffixfields should
be handled.

Insert title as run-in head The last line of a title, when immediately followed by
a standard text block (Main text, Notes, or Synopsis), it will bemerged into
the first paragraph of that text. In the case of using a multi-line title, only
the last element (such as the suffix) will be moved into the first paragraph.

When using run-in headings, the font and character attributes of the title
will be used to style the title, but its ruler settings will be ignored in favour
of the following paragraph’s settings.

This option will not be previewed in the “Formatting” tab, but you will be
able to see the results in its respective preview tile, in the compile overview
screen.

Title Case This setting, along with the Case settings that appear below each of
the prefix and suffix text boxes, will dynamically adjust the letter case of
these title elements. The following options are available tomost file types:

6 We use a line feed to place the Title on a following line, while keeping both in the same para-
graph. This is a good technique when you want to have your table of contents read “Part I –
Section Title”.
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— Normal: letter case will not be adjusted. However the title elements
were typed in will be passed through.

— Uppercase: all letters will be converted to UPPERCASE.

— Small Caps: this uses faux small caps, by converting all letters to up-
percase and then changing the font size on those letters that had been
minuscules prior to conversion. The result of this will be visually in-
ferior to a font designed for small caps, so it should only be used if
you lack such a font (or one with the typographic features for doing
so), or when aiming for file types that cannot use expressive fonts,
such as ebook and web publishing.

This option is naturally only available to formats that use fonts. The
setting will render text in uppercase when used with formats like
plain-text or the Markdown-based formats.

— Lowercase: all letters will be converted to lowercase.

Title Prefix Anything typed into this box will be printed directly before either
the binder title, or the suffix when the title is omitted. If you intend to use
this to insert the first part of amulti-line title, insert at least one paragraph
break or line feed after text in this box.

Title Suffix The contents of this boxwill be printed directly after the binder title
or the prefix. Consequently if you intend for this to display information
on a line below the main title, insert at least one newline prior to typing
anything in.

Place prefix/suffix inside hashes Available only to the Markdown-based file
types. The title prefix and suffix will ordinarily be placed within the hash
marks that Scrivener generates to indicate title depth—thus as part of the
heading itself. If you prefer, you can disable the Place prefix/suffix inside
hashes options to allow text entry outside of the header line itself (Fig-
ure 24.7). Prefix and suffix placement remains literal and directly adjacent
to the title element. Thus for proper formatting you will most likely need
to insert newlines to avoid the prefix/suffix from ending up on the same
line as the heading and breaking syntax.

Figure 24.7 The placement of the prefix and suffix around automatically gen-
erated hashes with them inside and outside, respectively.

Number of hashes Available only to theMarkdown-based file types. Adjusts the
number of hashes to use for titles in this section layout. This can be a
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way of coercing a layout to always print a heading of a certain depth no
matter its literal depth in the binder outline. A “Part” sectionmight always
want to use a setting of “1”, for example. By default, the “By Level” setting
inserts a number of hashes indicating the depth of the item in the outline,
regardless of its layout type.

Setting this to “0” will remove the hashes entirely and additionally allow
title lines to be directly adjacent to the text output, allowing you to more
easily custom format the text for purposes other than standard headings.

24.2.5 NewPages
This pane contains settings for adjusting how this Layout will act when a new
page (or section break, for those file types that are not built around paper) is
generated for it by the Separators compile format pane (section 24.4).

Pad top of page with n blank lines Adds the defined quantity of empty lines
above the title and section prefix. This will have the effect of pushing the
title down into the page and leave an area at the top blank. Since the set-
ting uses literal lines, rather than formatted padding, this can be usedwith
any file type. This option will be previewed in the section layout’s tile, in
the compile overview screen.

Even though this option is available to the Markdown-based formats, it
should benoted that these systems generally disregard blank lines and they
will appear to have no effect in the files they ultimately convert to.

Number of opening words to make uppercase If your requirements are such
that the first few words of the paragraph following a title need to be up-
percase, then specify howmanywords should be set to uppercasewith this
setting.

Use small caps You can also opt to use faked small-caps instead of all upper case,
using the checkbox below this setting. This only works with file types that
can use font sizes.

Uppercase even when section is not after a page break This is the one setting
that will trigger even if the section does not generate a full break. Use this
if you need to capitalise words following a regular heading or soft break,
like a divider or empty line.

Add “first-letter” span style to the first letter For ePub and Kindle: this wraps
the very first letter (from any main text content) of the section in a span
with the “first-letter” class assigned to it. This can be used to style drop-
caps or other visual effects. You can either create the CSS yourself in the
CSS compile format pane (section 24.7), or you can create a style called
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“First Letter” and use the WYSIWYG formatting in the Styles pane (sec-
tion 24.5). For true drop-caps youwill need to use CSS directly as Scrivener
itself cannot create floating boxes.

Settingwhich page a section falls on
Using the next two options (available to Print, PDF and DOCX), you can set up
common typesetting techniques, such as setting a “part” page to be displayed all
by itself on the recto side, with the chapter page following it on the recto side as
well and a blank page in between them to do so.

Always start section on The new section can be forced to always start on the
verso (left) or recto (right) side of the book. This will in some cases cause
an empty page to be inserted, in order to keep the chapter on the chosen
side.

Start next section on If the following chunk of text also generates a page break,
this setting will control how it behaves if it otherwise doesn’t use the prior
setting itself.

24.2.6 Prefix
Use this area to add content to the beginning of the section, directly before the ti-
tle area (youwill need to insert carriage returns into this field if the prefix should
be on a separate line).

— The prefix can be independently formatted using the standard controls
provided.

— With plain text formats, this can be useful for inserting markup around
entire sections. The prefix will be previewed in the layout’s tile, in the
compile overview screen.

— You can optionally use the Place prefix after title checkbox to have the pre-
fix inserted directly after the title, starting on its own line. Again however,
it will run directly into the following text unless you leave your own car-
riage returns at the end of the prefix.

Many placeholders can be used in the Prefix and Suffix tabs. Refer to Using
Placeholders in the Prefix and Suffix (subsection 24.2.8) for further tips on doing
so.

Style prefixes and suffixes in prefixes and suffixes

Style prefixes and suffixes will not be applied to text when used in the
Section Prefix or Suffix. The style formatting itself will be applied to text
where applicable, and other relevant optionsmade in the Styles pane will
be adhered to.
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24.2.7 Suffix
The suffix tabworks similarly to the prefix tab, only inserting the text youprovide
here at the very end of the section. You will need to add your own separation at
the beginning of the suffix field if it should be on its own line. The suffix will be
previewed in the layout’s tile, in the compile overview screen.
Use the Place suffix after subdocuments setting to have the suffix placed af-

ter all descendent items in the binder have been printed. In other words, this
will place the text at the very end of that container’s section of text. A practi-
cal example of how this can be used is demonstrated in this user manual, where
the links that allow you to return to the nearest chapter break are inserted after
each major section. For those creating XML or similar, this is a great way to wrap
entire larger sections of text in container elements.

24.2.8 Using Placeholders in the Prefix and Suffix
Every placeholder (the full list is found in the Help ▸List ofAll Placeholders…menu
reference) that you can use in the main text area can also be used in the various
prefix and suffix fields found within this pane. Here are a few examples of how
that capability can be used:

— While most of the examples in this list are more advanced, it bears repeat-
ing that the use of simple auto-number placeholders in the prefix fields
are an ideal way to automatically number sections. Throw “Chapter <$n>”
into your title prefix field, and never worry about keeping the numbers
straight in the binder again.

— Those placeholders that pull information from the current document,
such as the <$label> placeholder, will do so for each document thatmakes
use of this Layout, individually.

— You can also reset auto-number placeholders. For example you might not
want a linear count of figures to beused, but rather for each chapter to have
its own figure count starting at one. Since each item in your draft assigned
to your chapter Layout will insert a prefix or suffix, that’s a great place to
put resets, like: <$rst_figure>, which would reset any placeholders using
<$n:figure> in the text.

— With the <$img...> placeholder you can insert graphics as part of your
heading. In a previous example we inserted a special symbol character to
print a stylised asterisk, but inserting graphics opens up a great amount
of flexibility in how you format your headings. While working within the
format designer, images will not be previewed. However image references
will show up in the layout tile area of the compile overview screen.

For full documentation on the image placeholder, refer to Image Place-
holder Tags (subsection 15.6.5).

629



24.2. Section Layouts

— Compound placeholders can be used. For example you could create a cus-
tom “List” type meta-data that provides a few different graphics as named
items. One item in that list might be called “Sprouting Seed”. You could
then for the chapter folders that should use the “Sprouting Seed” graphic
set that custom metadata option, and then use a placeholder like the fol-
lowing in your prefix or suffix field:

<$img:<$custom:ChapterGraphic>>

It’s worth noting that images inserted in this fashion will not be displayed
as images in the “Formatting” preview area.

— Making use of the <$include> placeholder, you can include the main text
content of a particular binder item into any of the prefix or suffix fields.

When used in this context, you will need to refer to the item by name,
like so: <$include:name of item>. However this raises a problem in that
compile Formats are deliberately separate from projects, meaning if you
refer to a document by name it is likely the layout will not work in other
projects as expected. A way around this is to have “name of item” inserted
via another placeholder, using the compound form described above.

For example, <$include:<$custom:Epigraph>>would insert the text in the
“Epigraph” custommetadata field for the item using this placeholder. Pre-
sumably, that fieldwould have the binder name of the particular quotation
youwished to insert into this location. This keeps the compile format suit-
ably separate from project data.

— Even the title itself can be inserted via the <$title> placeholder. This
might not seem useful since you can already insert the title with a check-
box, but it might come in handy if for some reason you need to print the
title twice. The following prefix and suffix would produce a LATEX code to
print the regular title as a chapter heading and then assign a bookmark
label for cross-referencing purposes (using a slightly different placeholder
that omits spaces):

Prefix: \chapter{

Suffix: } \label{<$title_no_spaces>}

24.2.9 Settings
This final tab will not appear for plain text or Markdown-based formats.

Paragraph first line indents Utilises the common typesetting practice of re-
moving the first-line indent for any paragraph following a headings and
other elements of unusual formatting. The calculation for this can be
tuned with a set of options below the main checkbox. In all cases, para-
graphs that already have a style applied to them will not be modified by
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these settings.7

— Do not change: paragraph formatting will be left alone. This is the
default setting for newly created formats.

— Remove from first paragraph: the first line indent will be removed
from the first paragraph found in the section. This works regardless
of whether the section generates a page break.

— Remove from first paragraph and after empty lines: in addition to
the above, the indent for the paragraph following an empty line (such
as used after a scene break) will be suppressed.

— Remove from all paragraphs following other elements: In addition
to all of the above conditions, any use of paragraph styles will cause
the following normal paragraph to have a suppressed indent. This
is more commonly done in books with figures, block quotes and so
forth.

Include in RTF bookmarks This option is used by all of theword processing for-
mats, which are derived from RTF initially. It is enabled by default for all
section layouts (the special “As-Is” fallback layout, lacking settings, will not
insert a bookmark).

These will create anchor points throughout the document inword proces-
sors, primarily used as targets for cross-reference hyperlinks. It may not
always be desirable to have bookmarks at every level of your outline, espe-
cially if you use Scrivener’s outline feature to break down your book into
small blocks. Simply uncheck this to remove the document type and level
from the bookmarking feature. Any links to items using layouts without
this setting will be automatically removed from the output.

CSS class name This and the following setting are available to ePub and Kindle.
When a class name (it is up to you to provide a valid HTML class identifier
here) is assigned to a section layout, a <div> element will enclose the en-
tire section (including its prefix, title and suffix, if the suffix is not set to
fall after subdocuments). This can be used to provide more specific CSS
instructions, in the CSS compile format pane (section 24.7).

Hide entry in HTML table of contents Available to ePub and Kindle. Useful for
cases where a Layout requires a section break, but should not be listed
in the table of contents. Epigraph pages, the dedication page, full-screen
figures and tables are all practical examples of where this setting might be

7 For ebooks, this adjustment is handled globally, rather than per specific section type, via the
Text Layout compile format pane. Read more about it if you need Layout–specific indenting
rules (subsection 24.6.4).
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useful. This will only remove the entry from the automatically generated
HTML table of contents, not the ebook’s internal table of contents.

Hide section in ebook Available to ePub alone. This setting will remove the
documents that use this Layout from all forms of navigation in the ebook,
including next/previous chapter functions, the internal table of contents,
and the automatically generated HTML contents if applicable. It will be
referred to as a “non-linear section” in ebook editing programs.

Support for this specification may vary between readers. Some may allow
the reader to page through through these “hidden” sections, but by and
large it will not be presented as part of what the reader can navigate to.
This can be a useful setting for those writing “choose your own adventure”
style stories, or to present extended annotation on a text through the use
of links.

Return to chapter ⤴

24.3 Script Settings
This pane is only available to the Final Draft (FDX) format. It provides options
for configuring a few details that impact how a few elements of a script should
be formatted.

Break dialogue and action at sentences Use this option to adhere to the stan-
dard of keeping action and dialogue sentences together, rather than break-
ing themup between pages. If a sentence would have ordinarily been split,
it will instead be moved entirely to the following page.

Include revision colors from Settings Your preferred revision colours,
which can be set in the Editing: Revisions Setting tab (subsection B.3.3),
will be supplied to Final Draft’s revision palette, maintaining a consistent
revision system between the two applications.

Return to chapter ⤴

24.4 Separators
In real-world terms, separators represent an easy and formulaic way of inserting
separation between important elements in your draft. A few common examples
would be a page break between chapters in a PDF, a section break in an ebook, or
even a simple “#” or “* * *” between scenes in a novel. Separators in Scrivener can
be inserted either broadly as a default (e.g. all folders should have a page break
inserted) or very specifically as part of the role or function of a section layout,
such as an asterism between texts for a layout intended to print one scene after
another.
The separators panel is broken up into three main parts (Figure 24.8):
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Figure 24.8 Separators can be defined by section layouts or as broad defaults.

a) Default Separators: these two settings broadly adjust how separators will
be inserted in the draft. They will be used for section types that are not
mapped to any layouts, and for all layouts by default. Defaults are how
we want to treat items in general, perhaps even regardless of what type of
item it is in the binder (chapter, scene, preface, etc.).

b) Section Layouts: each layout, as defined in the Section Layouts compile
format pane (section 24.2), can be set to override the defaults and do their
own thing. This capability is useful when the layout is meant to serve a
specific role that includes separation—like a Part break in a larger book.

c) Separation Settings: when clicking on any of the entries in the above two
lists, their applicable settings will be loaded into this area on the right.

A few good examples of where and why a Layout might override default sepa-
rators can be found in the default blank “NewFormat” settings, as depicted in the
figure. We have the “Text Section” layout selected, which acts in accordancewith
the global defaults—but youmay notice that if you disabled theUse default sep-
arators checkbox at the top, it would insert an empty line between other “Text
Section” items—in effect acting like a scene in a typical novel. The “New Page”
layout directly below that one in the list is set up to override defaults by default
(whew), in that its entire purpose is for inserting a page break separator.
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24.4.1 Separator Types
The simplest way to use and think of separators is of having them inserted above
the section layout that uses them, thus placing it in between the preceding chunk
of text and the current one. This is the usage we referred to before, where a
common (and default) behaviour is to insert a page break before all folders. If
you add a folder and put some files into it in your draft, it will automatically act
like a major section break when compiled.
There are three additional behaviours for handling how separation should

be handled. It would be easiest to describe how they work together with
a few examples. If you wish to play along with the what we will be look-
ing at in the screenshots, you will find a demonstration project called “8-
compile_separators_demonstration.scriv” in the Extras Pack (Appendix G), and
consult the help file at the top of the binder if you require any further explana-
tion of how the project is set up. For the sake of visual clarity, we’ll use custom
separators, which allow us to insert arbitrary text between sections.
In Figure 24.9we see two different forms of separation being employed, aswell

as a third option that transforms blank lines in the text editor to match the form
of separation we prefer between sections otherwise. The options that are in use:

Separator before sections As referred to before, this is the simplest form of sep-
aration to work with. The orange chunk of text has been set to “Page
break” as its separation type. We don’t see the effects of that here because
it is the very first item to be compiled. This is an important exception to
keep in mind for separators in general: they must be separating the item
from something in order to insert a separator.

The sections coloured in lavender also use a “before sections” setting, seen
here between the first of them and the orange item. Blocks of contiguous
items using the same layout are considered as such by settings. Only the
first item in such a range will use the Separator before sections setting.

Separator between sections When the section type of the item preceding the
current item is the same then this separator optionwill be used. We see the
asterism symbol inserted between the two lavender chunks of text because
they are of a like kind. If one of these chunks of text had been a different
type of document (like the orange chunk), then the “– Before Section –”
separator would have been used instead.

Our next example (Figure 24.10) adds a new option into the mix, and in doing
somodifies how these items in the draft work together. If you’re following along
with the demonstration project, open the compile overview screen and click the
AssignSectionLayouts… button, switching the “Section” type to the “Section Text
(After)” layout.

Override separator after This option not only inserts a separator after the sec-
tion, it will do so in all cases, overriding either of the above options if nec-
essary to do so. In our example here, the Separator between sections is
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Figure 24.9 Separators can change depending on the items around the chunk
of text that is inserting the separator. Compiled output colour-
coded for clarity.

overridden, but if the third chunk of text was orange, it would in that case
have suppressed the page break that otherwise would have been inserted
by the “Heading” layout.

Also of note, this settingdoesnot override theBlank line separatoroption,
which doesn’t formally insert separators between chunks of text, but rather
modifies ad hoc separators you type into the editor itself.

Blank line separator Available only to formal section types, rather than as a
global default to files or folders, this settingwill transformblank lines found
within individual chunks of text in the editor. The second lavender chunk
of text has such a blank line within it, and we can see it transformed to
match our preference of using an asterism between significant portions of
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Figure 24.10 Overriding the separator following an itemwillmodify any other
separators that might have appeared in that slot, rather than
adding an additional separator.

text. You can thusmix how you write and use the draft outline with Scriv-
ener. If it feels more appropriate to have a sequence of short scenes in one
single outline item, then you can feel free to do so.

Ignore blank lines using styles Working in conjunction with the previous set-
ting, if a blank line has a paragraph style applied to it, then the compiler
will presume you intend for this line to be blank on purpose, and not func-
tion as a separating element between chunks of text.8

8 For this feature to work properly, the line, or the styled range of text including the line, must
include some form of content (such as one single space).
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24.4.2 Separator Settings
Each type of separator will have the same four options available:

— Single return: a single paragraph break will be inserted, causing the final
appearance to run from one document to the next with no visible “seam”.
In essence this is the “no separator” option.

This can have an adverse effect inMarkdown-based and Fountain formats,
where a clear empty line is expected between all elements, including para-
graphs.

— Empty line: two paragraph breaks will be inserted, causing a visible space
between the items.

— Page break or Section break: for paginated file types, a page break will be
inserted, causing the following item’s text tomove to the next page. Those
formats that do not have a concept of paper, such as ebooks and web files,
will refer to them as “section breaks”, and use the following behaviours:

– Plain-text (TXT): the Unicode “Form Feed” character (U+000C) will
be inserted at the beginning of the line of the item that generated
the separator with no carriage returns around it. Some text editors
may handle this code in their display of the text (TextEdit in Page
Wrap mode for instance). If the intention is to use the output of this
document in processing this separator should in general not be used
unless the processing engine is capable of handing a Form Feed char-
acter in some intelligent manner (many will just throw errors).

– Web page (HTML): an <hr/> element will be inserted instead of a page
break.

– Fountain: the markup code for a page break (===) will be inserted.

– ebook formats: all ebook formats use a very formal method for sec-
tion breaking. This is a significant cut in that it will be the basis for
generating the internal table of contents (as well as the HTML con-
tents you can see in the reader). These cuts are also inserted into
the navigation index for forward/backward by chapter movement in
those readers that offer the capability. Most book readers will display
sections as a “page break” (or a screen break if you will), but it is not
mandatory that they do.

– Markdown-based formats: the markup code for a section break
(----) will be inserted.

A special exception exists for MMD → LaTeX (.tex) and PDF. The syn-
tax for a page break will be inserted (\pagebreak), in such a way that
MultiMarkdown will pass the code directly through to the final .tex
file.
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— Custom: Anything entered into the adjacent text field will be placed be-
tween the two items on its own line, using the paragraph attributes of the
line preceding it with centre-alignment added.

– Image Placeholder Tags (subsection 15.6.5) can be used here, provid-
ing a way of inserting custom separator graphics between sections.

– If you requiremore spacing, you can insert your own carriage returns
with the ⌥Return key combination.

There are a few additional options that may appear at the very bottom of this
pane, depending on the document type selected:

Ignore indents when centering custom separators Available to file types that
use formatting. Since separator lines inherit their base formatting from
the preceding paragraph, this can often mean the separator will have a
first-line indent like an ordinary block of text would. This indent pushes
the calculation of what is “centre” over by the width of that indent. Nor-
mally you will want a separator to be aligned to the middle of the page.

You may want indents to be factored in if the section of text being sepa-
rated is itself bulk-indented. For example, an extended block quote with
separators in between sections of that quote would arguably look better if
the visible separator between them were indented congruently.

Custom separator font Available to file types that use formatting and are capa-
ble of drawing upon system fonts (unlike ebooks). Tick the checkbox to
enable the font selection tool. This can be particularly useful if you have a
wing-ding style font that you want to make use of. This setting will not be
previewed in the settings above, so youwill need to knowwhich characters
to type in to make use of such symbols.

Need a less adaptive behaviour?

As you may have seen by now, separators are by their nature contex-
tual. They are meant to be inserted logically into your draft, and will not
blindly duplicate separation between items or insert separation where
there is nothing to separate. If you do need elements inserted around an
element no matter what, then the Section Layouts prefix and suffix set-
tings (subsection 24.2.6) settings will do just that. The provided demon-
stration project also includes a section layout called “Text Section (Prefix/
Suffix)” that shows the interaction between a section prefix & suffix with
the separators around them.
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24.4.3 Managing Layouts from the Separators Pane
Youmay at times find you need to create a new layout on the fly to accommodate
a special form of separation. In the lower left hand corner of the Section Layout
list are a pair of + and − buttons. Section Layouts can be managed from this
pane:

— When adding new layouts it works in the same fashion as the Section Lay-
outs pane would—select the layout you want to duplicate and then click
the +. You may of course need to further tweak it in the Section Layouts
panel after adjusting its separators.

— Use of the−will fully delete the layout from the compile format. Use with
care.

— Layouts can be renamed right in this list as well, by double-clicking on
their names. Click elsewhere, or press Return to confirmyour changes once
you’ve edited the title.

The Separators pane is available to all formats except FCF and FDX.

Return to chapter ⤴

24.5 Styles
Where it comes to compiling stylesheets from your project, Scrivener takes a
somewhat unique approach in that every compile format can potentially change
every aspect of the styles in your project as you see fit. Thus a normal looking
block quote in the text editor can end up double-spaced and in Courier for sub-
mission.
Another unique aspect of its stylesheet system is that this panel will be avail-

able to every file type in the list save for scriptwriting formats. That means even
plain text andMarkdown-based files can use stylesheets (although naturally they
will ignore those settings dedicated toward formatting).
The Styles panel is composed of a few simple areas:

a) The style list on the left, which may be empty when creating a new for-
mat, contains a list of styles that will be available for use within the for-
mat. Their names, if they match those used by the project, will modify
their behaviour and appearance.

b) Various style options will be provided to the right of this list, depending
upon the document type being worked on at the moment. These tend
to be advanced options that alter how the styled text will function or be
displayed.

c) Below the list is what should be a familiar interface for changing the for-
matting of the style. In this case we have the “Code Block” style selected,
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Figure 24.11 The Styles compile format pane (showing RTF options) is for cre-
ating special styles that can transform how a document looks.

and can see that it will print code using a monospace font when compiled.
If text using “Code Block” exists in the project, it will end up looking like
this example here, rather than how it looked in the editor.

There are a few key aspects of this system to keep inmind, with regards to how
styles work as a part of a compile format:

— It is not necessary to build out a list of every style you use in your project. Think
of a Format’s stylesheet as being a list of exceptions, or clarifications on
howyour styles should be exported. If the Styles panedoesnot list a project
style by name, then the compiler will protect the applied formatting from
most processes the compiler would otherwise use to reformat text. This
is a selective behaviour: a style that does not address font families could
have its font overridden by the compiler, but not its paragraph alignment.

— Names matter. The only tool Scrivener has at its disposal for matching
styles you use in your project is by name. Matching styles will have their
attributes modified as set up in this pane.
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If you require a different style name, as stored in the final document (say
to match with an import template in another program), you can use the
Override name option, for those formats that support named styles in the
output.

— Format-only styles: It is okay to have style names that don’t match styles
in one specific project. For example our built-in “Proof Copy” format has
styles for Captions, which youmight never use in your projects. But if you
do, the format is prepared to handle them.

— The styles that you create in this pane will be available to other panes in
this window that make use of styles. For example in the Section Layouts
pane you can assign styles to headings and body text—but they will be for-
mat styles, not project styles.

Considering that, if you do not intend for such “internal styles” to acciden-
tally format project text, it would be good to choose names for them that
are likely to be unique.

— Something to be aware of is that many of our built-in compile formats and
templates have been designed specifically to modify the stock stylesheet
that comes with every new project. If you use “Block Quote”, then expect
it to be transformed into a suitable format for Courier 12pt submission, or
whatever the case may be.

Conversely if you go your own way and create your own styles, you may
find that the default formats require modification to work as originally in-
tended.

24.5.1 Creating a NewCompile Style
To create a new style in the list:

1. Click the+ button in the upper right-hand corner of the pane.

2. You will be presented with a list of options divided into the following cat-
egories:

— Generic new styles for paragraph, paragraph+character and charac-
ter. For more information on the distinction between these types,
refer to Paragraph and Character Styles (subsection 17.2.1).

If applicable, the starting attributes and settings for the new style will
be determined by the selected style in the list. E.g. if you select a
paragraph + character style and create a new paragraph style, it will
inherit the paragraph formatting from the original.

— Next, all paragraph and paragraph+character styles found in the cur-
rent project will be listed for your convenience as a starting point.
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Use of these copies the style’s name, formatting and settings into the
compiler. The changes you thenmake will adjust how that particular
style (by name) compiles, but will have no bearing on the original.
It will also be ignored when compiling projects that do not use that
style.

— Lastly all character styles found in the project will be listed. They
function identically as the above.

3. If creating a generic style, type in a name for the style in the list, and click
elsewhere or press Return once done.

24.5.2 Renaming and Removing Compile Styles
Styles can be freely modified in the list once they have been created. To rename
a style:

1. Double-click on the name of the style in the style list.

2. Once the edit is complete, press Return or click elsewhere to confirm your
edit.

Removing a style from the list will in most cases simply remove the instruc-
tions provided to the compiler for handling a style by that name. In some cases,
if the style has been made use of in other compile format panes, the result will
be to reset those areas to default, or strip the style assignment from any text it
had been associated with:

1. Select the style you wish to remove.

2. Click the− button in the upper right-hand corner of the pane.

This cannot be undone, but you can always Cancel editing the compile format
if you make a mistake (just keep in mind that will cancel every change you’ve
made since opening the pane).

24.5.3 Compile StyleOptions
The sidebar to the right of the main style list contains a number of options that
can modify the behaviour of the text assigned to that style. To modify how a
style works, click on it in the list to load its settings into the sidebar.

Delete text of this style All text that has been associated with this style will be
removed from the output. A practical example of this feature is in use
with this user manual, where specific phrases of text relating to macOS or
Windows alone can be selectively omitted depending upon which format
it has been compiled with.
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Flatten first indent This and the following two settings are available to print,
PDF, the word processing formats and HTML. The first paragraph within
the assigned range of text will have any first-line indenting removed.

Looking to adjust indent settings globally?

These features are not intended to be used for handling large and dy-
namic amounts of text (such as all body text), but rather smaller ranges
such as individual block quotes, monologue formatting and so on. For
bulk indent management, you should use the Section Layout: Settings
tab (subsection 24.2.9), and for ePub and Kindle, the Text Layout pane
(section 24.6).

Single paragraphs only The first-line indent will only be removed from single-
line uses of this style.

Flatten next indent The paragraph of text following the paragraph using this
style will have its indent removed. A common use case for an ability like
this would be to suppress the indent of the paragraph of text following a
figure caption, meaning the “Caption” style itself would be responsible for
declaring that rule.

Match right indent to left Available to Print/PDF, theword processor based for-
mats, Kindle and ePub. Equalises the left and right indent amounts so that
the right indent will match the left. Since right indents aremeasured from
the left side, for documents where the size of the page or viewing screen is
unpredictable, this can mean the width of the text block changes depend-
ing upon paper settings or screen sizes. If any right indent is set in the
style, it will be ignored.

For ebooks, CSS will be used to apply an equal amount of indent offset to
each side of the paragraphs using this style.

Treat as rawmarkup Available to all file types that make use of or are capable
of generating markup: TXT, HTML, the ebook formats and the Markdown-
based file types. In all cases the effect of this option is to fully suppress any
compile behaviours that might modify the text as you typed it in, allowing
you to inject raw markup as intended to the final output.

To provide a very simple example, if youmanually type in <img src="..."
/> into your editor it would end up as visible text when you compiled,
rather than the HTML to insert an image into the web page you are writ-
ing. This happens because Scrivener converts the punctuation marks to
encoded entities to protect what you’ve written from being interpreted as
HTML. Wrapping the HTML in a style with Treat as raw markup enabled
for it, is the solution for making that text functional HTML. In this way we
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can both write about HTML by typing it in normally, and use HTML directly
with raw markup styles.

When used in conjunction with the ePub /Kindle compile file types, it is
good to know that these formats are ultimately generated by MultiMark-
down internally. The implication being that this checkbox passes the text
through to the MMD file itself, not directly into the final HTML output.
This distinctionmeans you canuse someMarkdown syntax directlywithin
such styled text. This includes raw HTML, since Markdown by its nature
will leave raw HTML untouched.

When using theConvert rich text toMultiMarkdown option in the com-
pile overview screen’s General Settings tab (subsection 23.4.3), this setting
can be used to have Scrivener leave the marked text alone, making it pos-
sible to use raw Markdown in the project—or even in the compile For-
mat, where styles can be applied to text in SectionLayouts—that otherwise
would convert the markup to visible punctuation.

Prefix/Suffix The start of the styled range will have the text of the Prefix field
added to it—styled in the same fashion as the text that generated it. Like-
wise the Suffixwill be added to the very end of the assigned range of text.9

For paragraph styles, if the styled range spans multiple paragraphs, there
will only be one prefix and suffix at the very beginning and end of the as-
signment. This (and the following) setting can be useful for a number of
different applications:

— When creating plain-text technical formats, such as XML, a range
of text can be surrounded in an element such as <attribution> or
<figcaption>.

— In all uses, the practical ability to insert stock generic text around
styled ranges is just as useful as it is to embellish folder names with
text like “Chapter” followed by a number. E.g. captions could be au-
tomatically labelled and numbered with a “Fig. <$n:figure>.” pre-
fix.

Paragraph prefix/suffix Operating in a similar fashion to the previous set of
options, this setting only applies to Paragraph and Paragraph+Character
styles, and it will insert a prefix or suffix around each line of text within a
styled range.

To use HTML as an example, you could wrap an entire block quote in
<blockquote> and </blockquote>, and then individual paragraphs within
that quote with the <p> and </p>.

9 Character styles cannot span across lines, and so consecutive paragraphs using one character
style will all be individually enclosed in the prefix/suffix.
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Override name Available to all of theword processing formats, except RTFD. For
cases where the style name used by compile settings (which in turn is how
it will be worked with in the project itself) must be presented differently
in the output document, use this field to overwrite the name of the style.
For example if you are working with aWord template that expects “Block-
quote” instead of Scrivener’s “Block Quote”, you could override its name
to that, here.

CSS class name Available to the ebook file types. This will be of considerable
use if you intend to write your own CSS. The ranges of text you assign
with a style will be classed (either as p or span elements accordingly) with
the name you provide here. If you do not provide a class name, Scrivener
will automatically generate one based upon the style’s name.

It is up to you to create a valid CSS class name. If you use invalid punc-
tuation or use spaces, then you will likely break your stylesheet and cause
validation errors in the ebook.10

24.5.4 Compile Style Formatting
Below the style list and options sidebar you will find a text formatting editor
with all of the various tools needed to fully format text. This works in the same
fashion as the Formatting control in the Section Layout tab (subsection 24.2.3),
with two exceptions:

1. Naturally, there is only one element to work with. So you need only worry
about clicking into the text area once to activate the formatting controls,
rather than clicking in a particular area like you might in the Formatting
tab.

2. For style types that exclude certain types of formatting, those formatting
options will be disabled. For example, if you create a Paragraph format
you will not be able to change the colour of the text. You will need a Para-
graph+Character style for that.

Aswith paragraph styles in general, font family and size can be altered even
for those styles that do not otherwise impact character attributes.

With TXT andMarkdown-basedfile types, the controls for formatting text here
will be in most cases useless, and can be ignored entirely. You will primarily be
interested in the options in the sidebar above. They are included in the event
that your compile format is meant to generate useful output to a text-based file
aswell as a formatted type of file, or for caseswhere formatting is being converted
to whitespace in some way.

10 To keep things simple: use no spaces, punctuation or numbers, unless the numbers follow
letters. In most cases, basic ASCII characters are the best to use.
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Below the formatting area, you may find additional options:

Include font family For cases where you merely wish to adjust some aspects of
the character formatting but leave the font family alone, disable this check-
box.11

Include font size Likewise, if the inherent font size should be left alone—either
to be established by the compile format or the underlying text in the
project—leave this checkbox disabled.

24.5.5 General Style Export Options
Available to the word processing based formats (excluding RTFD). These options
are found within the button, as shown in Figure 24.12.

Figure 24.12 Click the gear button for stylesheet export options.

Include styles information in exported file Enabled by default; the stylesheet
that is added to the exported file will contain all styles assigned to text,
whether by the compiler or in the original text. This will greatly enhance
the flexibility of your file after it has been compiled, and in someworkflows
will be a requirement for submission or collaboration.

Include scriptwriting elements as styles Dependent upon the prior setting be-
ing enabled; will insert additional styles from your project’s script settings
panel (section 24.3).

Return to chapter ⤴

24.6 Text Layout
This is where a few general decisions about the overall layout of the document
can be made, and as such it presents different options depending on the file type
you are working with. This panel is available to all file types except Final Draft
and Fountain.

11 Bear inmind that projects using a global font override (subsection 23.3.1) will ignore this setting,
as will all other areas of the format that stipulate the font family.
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Document suffix Available to all file types. It will place the provided text at the
very end of the compiled file, signifying the end of the document. Some
submission formats require a special punctuation sequence at the end, and
this option can be used to keep that sequence outside of themain working
area in the editor.

When using plain text to create markup based formats, such as XML, this
area can be used to insert a document footer, closing off any containing
elements or including final materials, such as bibliographies. Plain text
also has aDocument prefix field that can be used to open these containing
elements or otherwise manage the header area of the document.12

Before back matter All file types, save for plain text and Markdown-based, will
have this secondary option available. When enabled, theDocument suffix
will directly precede anymaterial added via the Backmatter setting in the
compile overview screen in the Contents tab (subsection 23.4.1).

Use hyphenation Available to all but the plain text, Markdown-based and HTML
file types. By default, hyphenationwill not be used. When full justification
is being used to format the text, this option can substantially improve the
readability and appearance of the compiled result. For Print/PDF, this set-
ting only functions correctly with select languages supported by macOS.

24.6.1 For PDF and Print
One extra option is available when printing or using the PDF file type:

Empty Lines Across Page Breaks Enable the following checkbox and then sup-
ply a custom separator to be used as a stand-in when an “Empty Line” Sep-
arator (section 24.4) is scheduled to be used, and that line would otherwise
be hidden by the page change. This is a common typesetting convention
for making sure that separations between scenes are indicated at all times.

PDF and Print also support avoiding widows and orphans, as documented in
the following section.

24.6.2 ForWord Processing
With the word processor formats, such as RTF, DOCX and ODT (excluding RTFD),
this pane allows for some advanced page layout options.

12 Refer to the “General Non–Fiction (LaTeX)” project template’s compile format settings for an
applied example of how these fields can be used for handling the overall structure of a document.
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Avoid widows and orphans When used with a compatible word processor (or
PDF/Print output), this will enable widow and orphan protection for your
paragraphs.13 This feature may not be supported by all word processors.

Use columns This option will reformat your exported manuscript into a speci-
fied number of vertical columns, where text will flow from the left column
to the right, before cutting to a new page.

Start columns Three choices are provided for where columnar format should
start in the document:

— On first page: start column layout immediately

— After first document: useful for title pages or the abstract block in
many style guides used by the sciences

— After front matter: front matter content will be entirely displayed in
single column mode, useful for the abstract and other introductory
material.14

Number of columns The number of columns on each page can be adjusted
here.

Space between columns Youmay also adjust howmuch padding will be used to
space the columns apart from one another, from 1/8th of an inch to 3/4.

24.6.3 ForWeb Pages
Web pages (.html) have two exclusive options available (refer to the ebook op-
tions section for documentationon theUse 100%width for imageswider than…
setting):

Use centered column to restrict body text width Instead of allowing text to
flow from one edge of the browser window to the other, this option will
enable the common tactic of constraining the text column to a maximum
width in the middle of the viewer.

Body text width You can set the width of that column with this setting, in pix-
els.

13 Widows are remnant lines where the paragraph breaks across the page, resulting in only a few
words after turning the page. Orphans are the opposite, where the paragraph begins so lowdown
on the page that only the first line can be read before a page flip is required.
14 Front matter is defined by the Front Matter dropdown in the project’s compile contents set-
tings (section 23.4.1).
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24.6.4 For ebooks
Use 100% width for images wider than… For images that are wider than the

width you set here (in points, not pixels), the compiler will set the re-
quested width to “100%” instead of giving it a static size. Most e-readers
will fill the available width of the screen with the image. Some readers
might always display images a certain way regardless of your settings here.

Include scriptwriting CSS ⟨Deprecated⟩ Available to ePub 2 and Legacy Mobi
formats. Use this setting when your ebook contains some script format-
ting. If the ebook is entirely a script, then you should use the “Ebook
Screenplay” compile format instead.

You can customise the precise formatting using Cascading Style Sheet
(CSS) syntax in the text area that will appear below this checkbox when
enabled. Each script element will be provided with a separate CSS class.
All classes should be assigned to the p element, if they require specificity.

EmbedMathType equations as MathML Available only to ePub.
AnyMathType images found in the compiled text will be inserted into the
ebook as a <math> element, conforming to the specifications for MathML
syntax. You should test your intended target readers for compliance with
this format. If they donot displayMathMLequations correctly, or satisfac-
torily, you might wish to turn this feature off and have Scrivener convert
equations to raster images (PNG) for maximum compatibility.

Remove first line indents Available to ePub and Kindle. This globally sets the
behaviour of first-line indents for paragraphs following different types of
elements in the book.

The effects of this setting are implemented in theCSS compile format pane
(section 24.7), and can be further tweaked there if necessary. If you are
looking tomodify indent policy on a Section Layout basis rather than glob-
ally, then consider adding a CSS class name to your Section Layout, in the
Settings tab, which will make it possible to add class-specific selectors to
your CSS stylesheet.

— From all paragraphs following other elements: anything other than an-
other a paragraph will cause the first-line indent to be removed. This
uses the HTML definition of the <p> element, which may not always
be a paragraph in the literary sense of the term. As this is an all-
inclusive setting, the following options will become redundant and
be disabled.

— From first regular paragraph in each chapter: whenever the compiler
splits your content to a new internal ePub HTML file, it will scan for
the first following body text paragraph and add an indent override to
it.

649

http://www.w3.org/TR/2011/REC-CSS2-20110607/
http://www.w3.org/TR/2011/REC-CSS2-20110607/
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— From paragraphs after headings: any paragraph following a numbered
“H” heading, such as <h1> or <h3> will have their indent removed.

— From paragraphs after separators: when Scrivener inserts a separator
via the Separators compile format pane (section 24.4), paragraphs fol-
lowing themwill have their indent removed. You can also create your
own separators with this function in your HTML by using the “sepa-
rators” class on paragraphs.

— From paragraphs after blank lines: where blank lines are inserted by
othermeans than the Separators pane (such as empty lines in the text
editor), indents following them will be suppressed.

24.6.5 For Scriptwriting
Provides additional layout features designed for compiling scripts to Print or PDF.

Convert Preserve Formatting blocks to dual dialogue tables By default, when
sequential pairs of character + dialogue elements are marked with the For-
mat ▸PreserveFormatting tool, theywill be grouped together in side-by-side
layout, commonly known as “dual dialogue” (subsection 19.1.4).

Fix script elements that flow across pages When using this option the com-
piler will insert “(MORE)” and “(CONT’D)” markers at the bottom and top
of pages, when dialogue must be split across breaks. Please note that we
consider this feature to be “proofing quality”, in the sense that it may not
match the layout (and thus total page count) of output created by programs
designed to create industry standard screenplays.

Avoid splitting sentences across pages Secondarily to the above, the compiler
will strive to avoid breaking the pagemid-sentence, within these elements.
Note that both this and the above option are incompatible with footnote
layout. If you require both scriptwriting layout and footnotes in the same
document, you could use endnotes instead (section 23.4.3).

FurtherOptions
These options may need to be adjusted when using a localised version of Scriv-
ener, or when composing a non-standard script.

Element names… Scrivener needs to be able to recognise the difference be-
tweenCHARACTER, PARENTHETICAL andDIALOGUEelements, in or-
der to detect and lay them out in side-by-side formation. If you are using
element names that differ from standard screenplays, provide the names
in the provided fields.

Character & dialogue appear on the same line Some scripting formats, such as
Stage Play (UK), place both the character name and their dialogue on the
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same line of text. If you intend to use dual dialogue with scripts that are
formatting in this way, be sure to check this box.

“More” and “Cont’d” text… Use these fields to adjust the marker text that the
compiler will use in the printed script.

Return to chapter ⤴

24.7 CSS
This pane is available to ePub and Kindle formats only. It provides complete
access to your book’s Cascading Style Sheet (CSS), which means you can make
minor modifications to Scrivener’s automatic output as you see fit, or even go so
far as to apply your own custom-designed look and feel, going well beyond what
Scrivener itself is programmed to handle in terms of design.
Whilemost of this pane requires a basic understanding of CSS, you don’t need

to be an ebook guru to set up Default paragraph formatting. The formatting
you set in the mock editor here will determine the baseline look of body text of
your book, and as well the base size to work from (even if none of your Layouts
actually use these settings directly).
Ebooks fonts do not use fixed point sizes like print does, rather all sizes will

be multipliers based on the size chosen here. In most cases the default 12pt is
best to use. E.g. with a standard 12pt setting here, a heading rendered at 16pts
in your settings will be expressed in CSS as being “1.33” units large, or 33% larger
than the base text size. The important implication is that what you set here will
not be used to change the overall size of text in your ebook, only how unusual
sizes, whether larger or smaller, are calculated.
Not every aspect of the formatting you designate will be used directly, so

only the parts that can be turned into useful CSS will be used in the “Default
Stylesheet” box below.

Include scriptwriting CSS Tick this checkbox if your book has been composed
using Scrivener’s scriptwriting feature to write a screenplay. Stock CSS
will be inserted, which will mimic the look of a standard screenplay in an
ebook.

Custom and Default Stylesheets Above the CSS text fields you will find a drop-
down for setting how CSS should be handled in your book:

— UseDefault CSS Stylesheet:15 this causes the book to only use theneces-
sary CSS that Scrivenerwill generate automatically, via settingsmade
in the format designer and so forth.

15 Yes, we are aware that this is a little bit like saying ATMMachine, or PIN Number, but as with
those phrases they tend to roll off the tongue a little easier than just barking out acronyms, so
bear with us.
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— Use Custom CSS Stylesheet: this option gives you full control over the
book design. TheDefault Stylesheet columnwill remain available for
you, strictly as a reference, and a source for copying and pasting for-
matting styles into your own stylesheet. None of it will be used how-
ever, and for themost part, the various format and style settings else-
where in the format designer will be ignored, unless you copy them
over from the Default column.

— Append Custom CSS Stylesheet: if you just want to make a few modi-
fications to the default style or add a few definitions for styles you’ve
created yourself, this will be the best option. Both stylesheets will
be used, with yours following the defaults (meaning you can override
the defaults by using identical selectors). We’ve provided a few fin-
ishing touches to our “Ebook” format as an example of how you can
do this.

Create styles for paragraphs using custom formatting Formatting that is the
result of direct formatting made to either compile settings, or passed
through from the original content in the editor, will have CSS classes cre-
ated for them. This default setting means Scrivener will strive to present
your text as you formatted it, rather than following only those strict rules
established by the use of Styles (either in the compiler or your text).

The downside in this approach is the generationof “clutter”CSS, as is often
seen in automated output from word processors. This can interfere with
carefully designed book formats, and can make it difficult to achieve your
own custom formatting, since the automatically generated class names
will necessarily be unpredictable. To force a strictly semantic interpreta-
tion of your material, leave this setting off.

Return to chapter ⤴

24.8 Document Title Links
This is a special option pane in that it will only appear if at least one Section
Layout requests the use of a title prefix or suffix in its settings (subsection 24.2.4).
The options in this pane refine how these titles should appear when referring to
the items via an internal document link—such as in a table of contents listing or
in general cross-references.
These settings will be useful in cases where what you are linking to is impor-

tant to identify by its full name. For example, if you set up folders to prefix their
title with “Chapter <$n>”, you can ensure that all cross-references pointing to
those folders use that numbered prefix alongwith, or perhaps entirely in replace-
ment of, the folder’s natural title.
For a full explanation on how to work with this feature from the editor side,

refer to Compiling Document Links (subsection 10.1.4).
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Update titles in document links with prefix and suffix settings Enables
the options in this panel. It defines the base behaviour described above,
where a hyperlink to “The Folder” may become “Chapter 21 - The Folder”.

Carriage returns will be combined into one space, as necessary, in order to
keep links from turning into multiple paragraphs of text.

Links use title prefixes only (exclude title and suffixes) With this option en-
abled, the title and suffix will be discarded from the link text. Using the
above example, our hyperlink would simply refer to “Chapter 21”, even
though the chapter heading itself will print “The Folder” on a second line.

Do not include title suffixes in updated links With this option enabled, the
suffix will always be dropped from the link. This will be of use if you use
the suffix to print some decorative elements below the titling.

Override title prefix separator in links This will insert the character provided
in the Prefix separator field below, between the prefix and the main title.
When this option is used without the following, all forms of punctuation
and whitespace between the prefix and the title will be replaced by the
separator. For example, “Chapter 21: The Folder” will become “Chapter 21
- The Folder”.

Only override prefixes containing return characters In some cases the prior
option by itself may be too aggressive as it will replace portions of the title
you wish to leave intact. This secondary option forces the definition of
“separator” to only those cases where the prefix terminates with a newline
character. All other characters will be left alone, meaning a prefix such
”Chapter <$n>: ” will end up in the hyperlink as “Chapter 21: The Folder”.

Suffix enclosing markers This option is available so long asDonot include title
suffixes in updated links is off, and will take effect on title suffixes used in
any active section layouts.

The enclosing markers will be placed around the content of the suffix,
excluding any leading or trailing whitespace. For example, we may type
“<$label>” into the suffix field, with a leading space so that it does not run
into the last word of the title. Then, when we use square brackets for our
enclosingmarkers, and compile a document assigned with the “Red” label,
the link text will be “Title of Section [Red]”.

Return to chapter ⤴

24.9 HTML Elements
This pane is available to ePub andKindle formats only. It is used tomapa compile
format’s styles to the sorts of HTML elements used in ebooks. Since Scrivener
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cannot guess what you mean by the name of a style or its formatting alone, it
needs a little help in getting them to look and work the way they should.
It is worth reiterating that compile formats are not “aware” of any particular

project’s settings, and as such you cannot use styles from the project’s stylesheet
directly. A style must be defined in the Styles compile format pane itself (sec-
tion 24.5), to be listed here as an option.

The “Ebook” Format
The built-in “Ebook” format that ships with Scrivener will have these set-
tings already wired up to named styles. If you use our default stylesheet
while writing, you won’t have to set these up! It’s also a good starting
point for your own formats.

— Page title style: this special style is only used for the automatically gener-
ated HTML table of contents and the endnotes page, if applicable. In most
cases you will want to set up the style used here to match the look of the
style used for your other headings, but if you wish you can use a separate
format for these two titles.

— Block quotes style: the styled range will be wrapped in the <blockquote>
element.

— Codeblocks style: eachparagraphor line of textmarkedwith this stylewill
be <pre><code> elements. As with code blocks in many contexts, you may
need to ensure the lines wrap at a reasonable width, as the pre-formatted
element does not by default use automatic word wrap.

— Code span style: text tagged with the chosen character style will be
wrapped in the <code> element, which by default will apply a monospace
font. Youmayonly select fromcharacter styles, as this is designed for spans
of text within paragraphs.

— Captions style: the chosen paragraph style will be used to generate image
and table captions, when used on the line directly preceding or following
these objects in the text editor. Genuine captions have an advantage over
formatted text in that they may be used intelligently by the reading soft-
ware to provide lists of figures and so forth.

If you do not use these settings, styled ranges will be inserted into the ebook
as classed paragraphs.16 For example if you use the “BlockQuote” style, the para-
graphs using that style would be classed as “block-quote”. So you could adjust
the CSS (section 24.7) in your compile format to style these paragraphs to look

16 If you want to specify the CSS class name itself, you can do so in the Styles compile format
pane (section 24.5), with the CSS Class Name style option.
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like block quotes… or you can just map that style to block quotes in this panel
and in most cases not even have to style it explicitly as many ebook readers will
handle semantic block quotes properly without further help.

Return to chapter ⤴

24.10 Markup
This pane is only available to the plain-text (.txt) file type. If you are looking
to use Scrivener to generate markup files, but aren’t a fan of using one of the
Markdown-based approaches for doing so, then youwill very likely find this pane
to be of considerable use to you.
This pane will nearly always be one of several you will want to use together in

concert to create your own file types from scratch:

— Section Layouts (section 24.2) serve as a nexus for how many of the other
features of the format will work together. They can assign styles to text,
which in turn can be used to mark up text with syntax. They can also be
used to wrap sections of text in prefixes and suffixes, which can be useful
in cases where syntax needs to be around blocks of text, such as in XML.

— Separators (section 24.4) provide the ability to insert snippets of text or
spacing in between binder items. Where the prefix and suffix fields in Sec-
tion Layouts are good for wrapping chunks of text in environment calls
(like \begin{quotation} and \end{quotation} in LaTeX), if you need in-
termediary breaks—or wish to suppress breaks between like items (perhaps
two back to back items marked as “Quotations”), then separators will be
another way of accomplishing that goal.

— Styles (section 24.5) in Scrivener aremost decidedly not just for those using
word processors! Our style configuration allows for block and line level
insertion of prefix and suffix code.

— Text Layout (section 24.6) when paired with plain-text can be used to in-
sert boilerplate content at the top and bottom of the file. For any format
that needs a bit of preamble before getting to the content, this will be an
invaluable tool for getting a complete source document built.

— Transformations (section 24.13) include useful tools for keeping the source
text clean, particularly one setting that makes text XML-friendly by escap-
ing special characters and so forth.

— Processing (section 24.22) provides a way to further automate compilation
through the use of shell scripts and external utilities. Using this capabil-
ity, you can generate what amounts to interim formats with the compiler,
which are further processed by other tools to generate the final output.
The concept is much the same as using Kindle Previewer to create a .mobi,
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or Pandoc to create a PDF. With the Processing pane you have full control
over the tool chain, including building your own from scratchwith custom
scripts.

Most of the settings in this panel allow for a prefix and suffix to be inserted
around a range of text, transforming it from rich text to marked up plain-text.

Curious to see all of this in action?
The built-in “General Non-Fiction (LaTeX)” project template is a working
example of a project capable of generating LaTeX syntax, without any
help from other conversion engines. It makes use of most of the features
in the previous list.

External link prefix and suffix The text of any hyperlink pointing to an exter-
nal resource will be surrounded by themarkup you add to these fields. You
can supply theURL itselfwithin thismarkupusing the <$url>placeholder.
An example prefix could be <link url="<$url>">with the suffix being </
link>.

Internal link prefix and suffix Working similarly to external links (above), you
can supply alternative markup around internal document links (those
pointing to other itemswithin the compiled draft). The \<$linkID>place-
holder is also valid for use in other contexts—for example in the title prefix
of a section layout, or even the main editor—making it possible to effec-
tively identify or label nodes of text and cross-reference to them from else-
where.

Enclosing markers for unstyled italics Raw italic text—not text made italic by
a semantic style, can be treated specially here with a prefix and suffix. This
will work better with simple ranges of text, naturally. Long blocks of italic
text spanning paragraphs or other elements may produce invalid syntax
depending on your target file type.

Replace images with text Images can be handled in two different fashions: you
can either embed the graphic directly into the output file as hexadecimal
($hex) or Base-64 ($base64).

The other method is to have the image exported as a file with the Export
images checkbox, and then refer to the exported image by name with the
$filename placeholder. When using this method, the compiler will create
a folder to contain both the generated .txt file and all of the images, so you
will be linking to images relatively from the same directory.

Thewidth andheight of images are accessible to you as $width and $height
respectively (in points).

Return to chapter ⤴
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24.11 Metadata
This pane is used by the Markdown-based formats. Both MultiMarkdown and
Pandoc are capable of defining format-specific information with their metadata
systems.
The functioning of this panel is identical to the Metadata tab in the compile

overview screen (section 23.4.2),including the ability to paste valid existingmeta-
data blocks into it, as well as selecting keys and copying a valid block out. The
principle exception is that this metadata table will have a special marker in the
upper list, labelled “Insert Project Metadata Here”. This can be freely dragged
among other metadata keys, and as you can guess, any metadata gathered from
the project’s compile settings or metadata documents in the binder will be gath-
ered and inserted at that point.

Where is the document’s metadata described?
The purpose of this panel is to accommodate the establishment of the
Format itself, rather than to define any particular aspect about the project
that is using the Format. You should in most cases use the Metadata tab
in the compile overview screen to describe the compiled document itself,
or use project templates to establish common details of metadata that
rarely change, such as copyright information.

Return to chapter ⤴

24.12 LaTeXOptions
This pane, available to the MMD (LaTeX) document type, is used for selecting
which of the three built-in document classes Scrivener has boilerplates for, along
with a few custom options. The settings for the LaTeX document class drop-
down are:

— None (Use Metadata): you will be in full control over the process when us-
ing this option. Use this option if you have your own boilerplate files, or
would rather use none at all.

— Article: the Memoir class, with tweaks to present text similarly to the
vanilla article document class.

— Memoir (Book): an extensive class that is capable of formatting a wide vari-
ety of books (not only memoirs). In fact, the user manual you are reading
uses a customised version of this class.

— Manuscript: the Memoir class, with tweaks to present text in a standard
12pt Courier style submission manuscript. This option requires a func-
tional XeLaTeX system, as it uses system fonts.
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— Tufte (Book): a document class for book-length works, with typesetting
inspired by designs by Edward Tufte.

— Custom: use this setting to supply your own preamble and footer, saving
them directly into the compile format itself. This is a great choice if you
wish to package your format up for others tomake use of, rather than hav-
ing it depend upon boilerplate files.

When you compile using one of the three built-in classes, and you do not have
MultiMarkdown or its LaTeX support files installed (subsection 21.5.3), the .tex
files necessary to typeset the document will be exported into the compile folder
alongwith your document. You couldmodify those files to taste, but a better ap-
proachwould be to either use that information to build your own “Custom” class,
or place those files in your texmf path andmodify them there (Scrivener will de-
fer to locally installed copies and produce duplicates into the compile folder).
With the “Custom” option selected, the following tabs are available:

Header The initial preamble should be placed here. Typically anything that
needs to be declared prior to establishing document variables, such as the
title and author, should be put in this field.

Begin Document This gives you a second preamble field for working with any-
thing that would require additional document metadata such as the title
or author. This field will traditionally end in \begin{document}.

Footer Anything that would need to be declared at the end of the main and
back matter. Commands to generate glossaries, indices and other footer
material can be placed here.

Return to chapter ⤴

24.13 Transformations
This format pane provides useful textual transformations that can alter text it-
self, or its formatting, according to simple rules you provide. A simple common
example is the choice to convert italicised text in your editor to underscored
text, used in some submission guidelines. An example where the text itself can
be altered is to make it safe for embedding into XML by converting ensuring all
characters are ASCII compatible, as some technical formatsmay require. Aswith
many of the other panes, only those options that are relevant to the file type be-
ing worked with will be presented.

Convert “Smart” punctuation to "dumb" punctuation The three forms of
punctuation that Scrivener can automatically generate as you type (and
will by default), can be converted to ASCII-safe equivalents. This will be
necessary for some programs like Final Draft, or for technical formats like
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LaTeX and XML. If you require different or more precise transformations,
consider using the Replacements compile format pane (section 24.15).

— Typographic, curly or smart quoteswill be straightened. The punctu-
ation marks that will be used to represent quotes will be determined
by your system localisation settings, in the SystemSettings: Keyboard
pane, by clicking the Edit button alongside your input source.17

— The ellipses character will be converted to three full stops.

— Em-dashes will be converted to double-hyphens (--) for most for-
mats. For theMarkdown-based formats, a triple-hyphenwill be used,
as these systems use double-hyphens for the shorter en-dash.

Convert to plain text This option is provided to plain-text and the Markdown-
based file types. It is used to convert visual spacing found in the source text
to literal whitespace characters, using approximation to add a number of
spaces or carriage returns to emulate that visual spacing.

This feature will make use of the formatting that results from other com-
pile settings. If the layouts you use to print text do not modify the for-
matting, then the original formatting in the text editor will be used for
conversion. Thus if you need your paragraphs to be double-spaced for
Markdown and didn’t write them that way, you should either have your
paragraphs formatted with visual spacing in the editor or you should use
a Layout that applies that formatting in the compile settings.

— Paragraph spacing: add spacing in conformance to any “before” or “af-
ter” paragraph spacing in styled text. This function determines spac-
ing by rounding up the supplied value. If the base font is 12pt, and
paragraph spacing is set to 28pt (factor of 2.3) then two carriage re-
turns will be inserted between paragraphs.

This will be the most useful choice for plain-text technical formats
that require an empty line between each paragraph or major block
element.

— Paragraph spacing and indents: in addition to the above, spaces will be
inserted wherever lines have been indented from the left. This works
in a similar fashion, where spacing is rounded up. If the indent is
roughly equivalent to three spaces, then three spaces will be inserted.
This only simulates first-line indenting. Block quotes and other ef-
fects such as hanging indents cannot be simulated in this mode; use
the following if you require that level of emulation.

17 On older versions of macOS the menu command will be printed as “Preferences”, and refer-
ences to System Settings (“System Preferences”) locations may no longer be accurate.
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Inmost cases youwill not want to use this or any of the following op-
tions with Markdown-based formats, which tend to interpret more
than four spaces of prefix on a line as a “code block”.

— All whitespace: with the exception of full justification, this mode will
attempt to faithfully preserve all whitespace, including alignment,
right-indent offsetting, block indentation, hanging indents, and so
forth.

— All whitespace (add a one inch margin): in addition to all of the above,
this mode also adds 10 spaces to the left of every line (in accordance
with 10 pitch fontmetrics). Naturally, the actual size of this spacewill
differ depending on the text editor you open the file in, and the font
being used to represent the plain-text document, but with standard
12pt Courier the result should be one inch.

This option can be used to create plain-text scriptwriting files, since
they are all based off of old typewriter measurements that convert
cleanly to literal spaces and empty lines.

Convert italics to underlines For all rich text document types. If the submis-
sion process requires underlines to be used instead of italics, this feature
will let youwrite in italics but produce a properly underscoredmanuscript.

Convert underlines to italics For all rich text document types. Use when you
have produced a document with underlines, but need an italic version for
compile.

Superscript ordinals in titles, synopses & metadata When enabled, ordinal in-
dicators (such as 1st and 2nd) will be detected andmade superscript in fields
that do not otherwise have formatting, such as titles, headers and footers.
This detection is tuned to English and French usage; you may find it has
no effect or disrupts formatting in other languages.

Underline hyperlinks This and the following option are only available to the
print and PDF file types. Hyperlinks pointing to external resources will be
underlined by default.18 Disable this to make links less obvious to the eye.

Color hyperlinks External hyperlinks will be coloured blue, as per standard be-
haviour. Disable this for documents you intend to print in black & white
format.

Make text XML friendly Available to the plain-text file type, this setting will
clean up any use of punctuation that would cause an XML file to break.

18 If you’re looking to customise internal cross–reference style links in PDF files, refer to the PDF
Settings compile format pane (section 24.23).
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This will be most useful if you are creating your own XML (or HTML) for-
mat using the features available in the Markup compile format pane, and
so forth (section 24.10).

Add indent per outline level This special setting adjusts the formatting of each
paragraph or line of text by increasing the base amount of indenting that
will be applied to it, as determined by how deep the document is in the
outline itself, relative the compile group selected. This offset impacts all
horizontal measurements on the ruler, including tab stops, in effect shift-
ing the whole formatted block of text over by the defined amount.

Thus if the “Draft” folder is selected for compile, a text file that is on level
three will have twice the amount of points requested by this setting (the
first level will not be indented). At the default setting of 18pts, that would
be 36pts of indent, or precisely half an inch.

Any existing indent formatting within the document will be retained, but
will be offset by the base indent added with this setting. Thus if in that
same file there is a block quote with 0.5in of indent applied to it, the para-
graphs of text around it would be 0.5in indented, and the block quote
would offset to 1in.

This feature is demonstrated by the “Enumerated Outline” and “Full In-
dented Outline” built-in compile formats, both of which provide a few
simple layouts and then achieve their indented look via this setting.

When used with plain text and Markdown-based formats, you will want
to enable theConvert to plain text option and set it to “Paragraph spacing
and indents”. Since Scrivener adds spaces using 10-pitch calculation, one
space is equal to 7.2 points. So for four spaces (what you would commonly
want for functional Markdown indents), a setting of 28pts would equal
four spaces.

Return to chapter ⤴

24.14 MultiMarkdown and PandocOptions
The name of this pane will differ depending on whether the Use Pandoc syntax
option is enabled in theProcessing compile format pane. Thedifference is largely
cosmetic, as the contents of this pane will be the same for either format.

The “Basic MultiMarkdown” Format
The built-in “Basic MultiMarkdown” format that ships with Scrivener
will have these settings already wired up to named styles. If you use our
default stylesheet while writing, you won’t have to set these up! It’s also
a good starting point for your own formats.
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The pane is used tomap compile styles (not project styles—youwill likely need
to create styles in the Styles compile format pane beforehand) to specific features
that generate Markdown syntax. Text found within the project that is assigned
to a style by the same name as the mapped style in this pane will be transformed
in some manner to proper syntax:

— Block quotes style: each paragraph or line of text marked with this style
will be prefaced by “>”.

— Code blocks style: each paragraph or line of text marked with this style
will be prefaced with a Tab character.

— Code span style: text tagged with the chosen character style will be
wrapped in backtick characters.

— Captions style: this paragraph style will be used to generate image cap-
tions (section 21.4.2) and table captions (section 21.4.3).

24.14.1 Pandoc ePubOptions
When using the Pandoc (ePub) file type, a few additional options will be available
from this panel:

Format Select between the older ePub 2 standard and the modern ePub 3 stan-
dard, as a basis for how the book should be constructed.

Custom CSS Optionally provide a stylesheet to alter the appearance of the
book, which will otherwise use native appearance entirely left up to the
e-reader device or software.

It should be noted that when using the Pandoc ePub generator, you will have
access to the Cover Options (subsection 23.4.5) and Table of Contents Tab (sub-
section 23.4.6) in the main compile overview screen, for adjusting book-specific
details and metadata.

Return to chapter ⤴

24.15 Replacements
Format replacements are fundamentally identical to those replacements you can
assign to your project’s compile settings. Refer to its documentation for com-
plete usage notes (subsection 23.4.4). That leaves the question as to why there
are two separate lists: you may find it better to use this list for the types of re-
placements that work in union with a specific formats functionality, rather than
how a specific project works. To provide a few examples:
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— Changing the abbreviation of a place noun to its full proper name is prob-
ably better done in the project, as the format may be applicable to many
projects that do not use that abbreviation.

— As demonstrated in some of our built-in formats, such as “Manuscript
(Times)”, a number of captioning shortcuts have been added, so that you
needn’t type in full auto-number codes every time you wish to caption or
refer to a figure or table. This kind of utility will be useful tomany projects.

— Replacements that convert shorthand syntax to full technical syntax, such
as the HTML and LaTeX examples given in Advanced Replacements Usage
(section 23.4.4), might be useful as part of the format, if the intention is
to compile both HTML and LaTeX documents from the very same source
material.

— A replacement that strips out all Tab characters from an old manuscript
that used tab indenting instead of formatting is probably better in the
project that has that problem—unless it is a common problem to many
projects.

In order of precedence, project replacements will be processed prior to the
format replacements in this list. You can thus override howa format replacement
works by copying a replacement from the format, pasting it into your project list
and adjusting its settings there.

Return to chapter ⤴

24.16 Statistics
The options in this pane fine-tune the working of those special placeholder tags
that expand to display various statistics about the compiled document. Word
and character counting tags can be inserted anywhere in your project, including
some of the compile pane fields, like headers and footers. For a complete list of
available codes, either view the help sheet for placeholder tags in theHelpmenu,
or experimentwith the various options available in the Insert ▸DraftWordCount ▸
and Insert ▸Draft Character Count ▸ submenus.
This option pane is a core feature available to all document types.

Exclude front and back matter These two checkboxes are enabled by default;
they exclude any material in the selected front matter folder from statis-
tics.19 Typically included would be items like the table of contents,
acknowledgements, preface, and other material which is not generally

19 Front matter is defined by the Front Matter dropdown in the project’s compile contents set-
tings (section 23.4.1).
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counted as being a part of the main book. If for some reason you are us-
ing front matter for material which should be counted, then disable these
options.

Include all text This is the default behaviour. Any text that is set to be compiled
as a part of your manuscript will be included in the word/character count.
This means that if you enable, for example, Notes or Synopsis export for a
section layout (section 24.2), the note text will be added to the global count
as well.

Only include… If instead you’d rather adjust the scope of what is counted, en-
able this option and then select from the following list of inclusive options.
A checkmark next to the type of content means that it will be included in
the total count. Counting filters will not impact what gets compiled, but
only what out of that compile gets counted.

— Main text. To adjust counting for footnote, endnote, or comment
text, see below.

— Notes

— Synopses

Count footnotes, comments and annotations Footnotes and endnotes will be
included in the total count; this is the default. Likewise if enabled, com-
ments and annotations will be included in the count.

Do not count spaces in character count Enable this option if you require strict
character counts. If you are unsure, check with your publisher for which
standard they use.

Return to chapter ⤴

24.17 Tables
Contains options pertaining to the adjustment or presentation of tables.

Stitch together adjacent tables if possible This option (and its subsidiary op-
tions) aremainly useful for formats that require a single table for thewhole
document (such as certain documentary script formats), and should oth-
erwise be left off. This capability will make it possible to use Scrivener’s
outline features freely, with numerous table based documents, and sew
them all back together in the final compile.

Causes any tables that are separated by only empty lines and blank spaces
to be merged into a single table, provided that they have the same number
of columns. For consistency, the merged table will use the column widths
of the first table throughout.
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Insert blank row between stitched-together tables A table rowwill be inserted
with its border cell highlights hidden.

Restrict width of stitched-together tables to page width Use this to cause the
table to resize itself if you change the page size.

Convert tables to images with maximumwidth Available to theword process-
ing formats (excluding RTFD). Tables can be converted to static graphics for
a more consistent display on older readers that otherwise cannot display
native tables properly. You can specify the maximum width, in effective
pixels, used to generate the graphic.

Return to chapter ⤴

24.18 Tables & Lists
This pane is only available to ePub and Kindle file types. You can set the style of
table and bullet formatting used in the ebook, here. TheCSS used to create these
lookswill be placed in theCSS compile format pane (section 24.7) (in the “Default
Stylesheet” section), where it can optionally also be tweaked, or replaced entirely
by your own style.
For each type of element in the ebook, choose from one of the choices in the

dropdown menu to the right of that element. The choice you make will be pre-
viewed in the scrollable area below the dropdown menus. In the case of Num-
bered Lists and Bullets, a choice of “None” means no styling will be applied to
these elements—the manner in which they are displayed will be left up to the
book reader itself—and as such they will be displayed in the preview area in ac-
cordance with how the HTML previewer works in Scrivener.

Return to chapter ⤴

24.19 Footnotes &Comments
The Footnotes & Comments pane is available to all file types save for the Final
Draft and Fountain. It controls how these different forms of notation will be
handled in the compile process. Which options it displays will differ consider-
ably, depending on the file type in use.
Whether footnotes or endnotes are used, if they even appear at all, or how

comments and inline annotations are included, are settings determined by the
project, not the Format, in the General Options tab of the compile overview
screen (subsection 23.4.3). The format itself only describes how these features
will be presented if they are presented.
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24.19.1 Footnote & EndnoteOptions
Some of the options in this pane will, if the file type allows for the distinction,
be used to set up endnote and footnote formatting separately.

CommonOptions
These settings impact footnotes specifically (not endnotes). Given how these
options are scattered around in different places, depending on which file type
you’re currently workingwith, the listing of options will be in alphabetical order.

Footnote numbering restarts after page breaks Available to PDF and Print. In-
stead of keeping a running tally throughout the manuscript, footnote
numbering will be restarted after each page break the compiler inserts via
Separators. Wordprocessing formats have additional options documented
below, underNumbering.

Footnotes/Endnotes use single line spacing Available to RTFD, print and PDF.
Ordinarily endnoteswill acquire paragraph spacing settings from the para-
graphs they are referenced from. Thus a double-spaced manuscript will
have double-spaced notes as well. Should you require single-spaced notes
in all cases, enable this option.

Footnote format Using the dropdown menu, select how footnotes should be
numbered, lettered or represented by symbols in the final manuscript.

Indent footnotes and endnotes to match text Footnotes will be first-line in-
dented to the same degree as the most common paragraph formatting in
the entire document. When disabled, footnotes will be flush left at the
margin, regardless of any contextual formatting settings.

Numbering Available to the word processing formats (except RTFD). Provides
three different numbering schemes:

— Continuous: numbers will continue to increment throughout the en-
tire work.

— Restarts each page: as described above, for Footnote numbering
restarts after page breaks.

— Restarts each section: whenever a page break is generated by the com-
piler, footnote numbering will be reset to “1”.

Override font A separate font and size can be used to print footnotes or end-
notes. Enable the checkbox and then click on the font button to bring up
the font selection tool.20

20 Bear in mind that projects using a global font override (subsection 23.3.1) will ignore this set-
ting, as will all other areas of the format that stipulate the font family.
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Separator Style For Print and PDF: lets you choose what form of separation you
would like between footnotes and the main text body (Figure 24.13).

Figure 24.13 Footnote separation as “None”, “Full Page”, “Centered” and “De-
fault”, from top down.

Use period and space style instead of superscript in markers This option con-
forms to the Chicago Style, where the foot or endnote is displayed full size.
The marker in the text itself will remain superscripted. When used with
the plain text format, the effect will be to use “42.” style numbering in the
endnote listing, instead of “[42]”.

Common EndnoteOptions
Aswith the previous section, the options here will be listed in alphabetical order.
Most of these settings are only applicable to PDF and Print outputs.

Center subheadings WhenGroupendnotes by sectionwith subheadings is en-
abled, centre alignment for the endnote subsection headings, instead of
ragged right.

Endnote format AswithFootnote format, endnote numbering is adjustedwith
the dropdownmenu. If a document is using both footnotes and endnotes,
they can be printed using their own numbering streams. Even if the for-
mat is the same, they will not share numbers and will both start at the
equivalent of “1”.

Endnote subheadings font When Group endnotes by section with subhead-
ings is enabled, this setting becomes available. Use it to adjust the font
and size of the text that will be used to subdivide endnotes into sections.

Endnotes placement Available to RTFD, print, PDF and plain text. This deter-
mines where endnotes will be gathered in the document:
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— End of document: the traditional setting, and default.

— Before page breaks: the endnotes for the current section of text,
counting from the last page break, will be gathered directly preced-
ing the next page break (what would typically be a chapter or other
major break in a longer work).

— Before last page break: this option will insert endnotes at the end of
the second to last major section in a work. Used by some academic
house styles.

If a document in the draft contains the placeholder <$--ENDNOTES-->
marker, then that will take precedence over any of the settings above, and
will always gather endnotes at that point in the output.

Group endnotes by section with subheadings Available to RTFD, print, PDF,
plain text and ebooks. Wherever the endnotes are gathered, their list-
ing will be subdivided by the section (as defined by section breaks or page
breaks, or lacking that, the last section that printed a title) they came from.
Without this option, all endnotes will be displayed together in one long
list.

Insert separator before endnotes Available to RTFD, print, PDF and plain text.
Inserts a separator between the endnote list and the final document in the
compile group list. This will be a series of hyphens when using the plain
text file type.

PDF and Print Options
Keep footnotes at bottom of page The footnote list for the current pagewill al-

ways be placed in the same position along the bottom, even if the content
of the page ends at a higher point on the page. If you require footnotes to
begin at the bottom of the current page’s text content, regardless of where
the content ends on that page, switch this setting off.

Center single-line footnotes When enabled, end-of-page footnotes that con-
tain only a single footnote of only a single line use centre alignment.

Footnotes can split across pages Ordinarily long footnotes will split across to
the next page if they would cause the footnote list to take up more than a
certain percentage of the current page. Enable this option to keep a foot-
note entirely on one page or another. This behaviour may greatly increase
empty space in your printed document.

Footnotes avoid widows and orphans When footnotesmust split across pages,
this feature will attempt to avoid cases where widows and orphans are
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caused by such a split. The setting operates independently from the gen-
eral option in Text Layout, save for when general widow and orphan pro-
tection is enabled (subsection 24.6.2) then this setting will be ignored, and
footnotes will always use avoidance.

Plain Text Endnotes
In plain text files, endnotes will be used by necessity as there are no pages to
place end of page notes. Footnote markers in the main text will be printed using
a conventional square bracket to denote them, such as [42].
Plain text endnotes can be gathered somewhere other than the end of the

document, with the Endnotes placement setting. Where these options refer to
“page breaks”, the meaning is where a page break would be, were the document
compiled to a file type that supported them.

Embed footnotes inline This checkbox broadly changes how Scrivener will ex-
port endnotes, by placing their content inline with the base text instead
of using a referencemarker with the content located elsewhere. While the
default behaviourwill be better for producing .txt filesmeant for reading or
long-term archival, this alternate method will allow for technical formats
that embed footnote syntax directly into the text (typically displaying it
more traditionally once the source files are typeset).

Enclosing markers for footnotes This is used to wrap the entire footnote text
in markers, to distinguish it from the main body text around it (Fig-
ure 24.14). Both fields are optional, and if left blank there simply will not
be a visible delimiter on that side of the range of text.

Carriage returns can be inserted (using the usual Opt-Return trick) into
these fields if needed, though it should be noted that with some formats
this may break the source paragraph it came from in two.

Figure 24.14 Footnotes are enclosed ASCIIdoc syntax, with the compiled re-
sults colour-coded for clarity.
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Enclosing paragraph markers for footnotes Some forms of syntax will require
paragraphs within footnotes to be marked in some fashion. Scrivener will
insert thesemarkers around every footnote line, even if a footnote does not
have multiple paragraphs. Figure 24.15 demonstrates the capability using
pseudo-XML.

Figure 24.15 Example multi-paragraph footnote formatting intended for an
XML-based file.

Ebook Endnotes
By and large ebooksmake use of endnotes, since they do not have literal pages to
draw footnotes upon. Endnotes are typically handled as cross-references using
hyperlinks to and from the note and original text. Scrivener will handle all of
the back and forth linkages for you. On some devices, such links will cause the
footnote to be displayed as a popup, depending on the length of the footnote
itself. This is largely left up to the device itself.

Reduce marker font size The reference marker in the main text will have its
font size made smaller than the body text when this option is enabled.

With CSS, you also have direct control over this via the .fn-marker class.

Endnotes page title The section name for the table of contents entry that will
contain the endnote list. By default this uses the conventional “Notes”.
The formatting for this heading will be determined by the Page title style
setting, in the compile format pane (section 24.9).

For this and the following two options, the CSS class used for these ele-
ments will match the name of the style you created and selected for them.
Refer to the “/* Styles */” section of the default stylesheet (section 24.7)

Endnotes style Select from the list of paragraph styles in the compile format to
use for formatting endnotes in the book. The default “Base text format-
ting” setting will use the default formatting defined in the CSS compile
format pane.
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Section subheadings style As above. When Group endnotes by section with
subheadings is enabled, use this dropdown to select a paragraph style to
format these headings by.

24.19.2 Comment &AnnotationOptions
If the project’s compile settings allow for inline annotation and comments to be
printed, this portion of the pane will establish how that will be done.

Export Comments and Annotations as… This dropdown menu is only avail-
able to the word processing file types.

— Margin comments: exports your notes into a format that most word
processorswill display as amargin comment or “speech balloon” style
comment. Formost workflows this will be themost desirable option,
and it is the default.

— Inline comments: if comments are not showing up for you using the
above option, this method will print them as inline text, and will
cause comments to use the Enclosing markers for annotations set-
ting. This method uses basic formatting and is thus broadly compat-
ible.

— Footnotes: all annotations and comments will bemixed into the foot-
note stream along with any other footnotes (if any exist).

— Endnotes: as above, only mixed into the endnote stream.

Enclosing markers for annotations Annotations will be enclosed in twomark-
ers that will be used to delineate them from the rest of the text. In con-
junction with a plain-text system, you could modify these to conform to
the target file type’s commenting conventions. Someone who is publish-
ing in HTML might for instance wish to use the open and close syntax for
HTML comments.

Most of the built-in compile formats use square brackets to denote annota-
tions. The “Basic MultiMarkdown” format, along with most of the LaTeX
formats, will use CriticMarkup syntax: {>>annotation content<<}

Use format for comments Available to plain-text as well as the Markdown-
based format. When ticked, linked comments will be formatted using the
following text field as a template. You can supply syntax to wrap around
the content of the comment, and even refer to the hyperlinked text in the
editor that has the comment highlight, as well as make use of a few place-
holder values for comments (Table 24.1).

A simple example would be for the generation of CriticMarkup syntax:
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{==<$lnk>==}{>><$cmt><<}

Amore complex usage of this featurewould be to construct Pandoc style com-
ments for its .docx export (showcased with the built-in “Pandoc Word Docu-
ment” compile format):

[<$cmt>]{.comment-start id="<$n>" author="<$author>"
date="<$date>"}
<$lnk>
[]{.comment-end id="<$n>"}

Table 24.1 Comment Syntax Placeholders

Placeholder Description

<$cmt> The content of the comment itself, as it appears in the in-
spector or popup bubble when clicked on.

<$lnk> The visible text that was highlighted as associated with the
comment in the main editor.

<$n> Although it resembles the main auto-number counter that
can be used elsewhere in the manuscript, when used in this
context it will automatically be scoped to comments alone
(similar to using <$n:comment> by hand), and it will only be
incremented once per comment instance. Thus you can use
the placeholdermultiple times within the format field to re-
fer to the same number. This will be useful for generating
ID numbers.

<$date> Today’s date in short format.

<$author> Your name, as defined by the compile format’smetadata set-
tings or as a fallback, the name you’ve provided in the Au-
thor Information (subsection B.2.3) fields.

Markdown-Based Annotations
When using the MultiMarkdown and Pandoc compile formats, the name of this
format panel will be indicated as “Annotations”, as it will only pertain to the
formatting of inline annotations and comments. In addition to the relevant op-
tions documented for plain-text, there is one exclusive option available to these
file types:

Convert annotations to HTML-style text Available for plain MultiMarkdown /
Pandoc, MMD (HTML) and Pandoc (ePub). This option will cause inline an-
notations and comments to be exported into the text as HTML, using either
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a span or div element depending on whether the annotation is embedded
within another line of text or if it embodies the entire paragraph, respec-
tively. The HTML elements will have an inline style applied to them, setting
their colour to match the annotation colour as seen in the editor, and will
be classed as “annotation”.

When this option is disabled, annotations and linked commentswill be ex-
ported in the same fashion they are for plain-text files; enclosed in mark-
ers.

Using Markdown inside HTML-style annotations

In cases where an annotation falls entirely on its own paragraph, Scriv-
ener will use a div instead of span elements to wrap the comment within.
This means you can use complex MultiMarkdown within annotations
that are on their own. Annotations embedded within a paragraph of
otherwise normal text, in any way, will use spans in order to preserve
the original document flow, and thus cannot contain complex syntax.
They can however utilise inline simple formatting such as bold, italic,
code spans and so forth.

Return to chapter ⤴

24.20 Page Settings
For file types thatworkwith a concept of physical paper, this is where youwill set
up that paper size itself (though letting the project settings handle this is usually
best) and the width of its margins.
The print, PDF and word processing formats (as usual, excluding RTFD) also

have page header and footer capabilities, as well as offset margin treatment for
facing pages, so that you can even have one header on the recto page and another
header on the verso page. Should you require them, the breadth of these settings
should get you well on your way to final formatting and publication.

24.20.1 Previewing your Settings
The Preview button on the right-hand side can be used to get a feel for the mar-
gin settings and paper shape (Figure 24.16). When using formats that allow for
header, footer and page layout options, the settings in the “Headers and Footers”
section can add additional variations to the preview, and the headers and footers
you design will be previewed in this tool as well. For example, if the Use facing
pages option is ticked, then the previewwill let you flip between a preview of the
recto page followed by the verso page, showing themargin offset and any header
or footer variations between them.
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24.20.2 Use project page settings
The project’s print settings (made in the File ▸PageSetup…menu, including those
under the “Scrivener” section at the top) will be used to determine the paper
size and margins. Disabling this option will enable the margin and page setup
buttons below and cause the format to enforce a fixed paper size. This can be
useful when creating formats for a specific purpose, such as printing a mass-
market paperback layout.

24.20.3 Choosing Paper Settings
Click the Page Setup… button to bring up a dialogue for setting paper size, scale,
other basic printer settings and orientation.
The Use default paper size checkbox can be used to selectively defer that op-

tion to the project, and ultimately the individual writer’s system printer settings.
Use this if paper size doesn’t matter to the format and all youwant to do is define
the layout and content of the margins, headers and footers.

24.20.4 SettingMargins
Click theMargins button to set how far from the edge of the paper stock the text
container will extend to.
For file types that support the Use facing pages option below, asymmetrical

margins can be set, and the labels for the left and right margins will be indicated
as “inner” and “outer” instead.
The current margin settings will be printed in lighter grey text alongside the

button for your reference.
There are additional options available when using the “Print” compile type:

Header & Footer margin Designate the distance of the header from the top or
bottom of the paper, for the header or footer respectively. If the distance
you supply is larger than the margin itself, then it will come to rest along
the very edge of the main text body.

To disable this feature, set the distance to “0”. The result will be to place
the header or footer within the top or bottom inch (regardless of unit pref-
erence) of the paper.

Confine to printable area of page With this option disabled, the non-printable
area of the paperwill be ignored,meaning you can place elements into that
zone. This may be of use if you are intending to create a digital-only copy
that will never be printed. When enabled, measurements will be adjusted
to keep all text within the printer’s ability to print it.

674



24.20. Page Settings

24.20.5 Header and FooterOptions
The first tab in the header and footer section governs broad settings for how
headers and footers should work, as well as enabling additional features in the
second tab. For example you won’t be able to set up where the page number is
located on facing pages, in the second tab, if you don’t first enable Use facing
pages here.

Different header and footer on first pages Enables the
“First Pages” header and footer configuration section in the second tab.
“First pages” generally refers to front matter, where typically pages will be
numbered using lowercase Roman numerals, or in simpler cases the head-
ers and footers can be entirely omitted.21

Page numbers count first pages This option will cause the page counter token
to start counting the first pages, rather than skipping them, even if they do
not display a page number. If you are using Roman numerals in the front
matter, then regular numberingwill beginwhere they left off. For example
if there are four pages of front matter the page numbering would go from
“IV” to “5”, instead of from “IV” to “1”, which would be more traditional.

Main body header and footer starts… This setting defines what is meant by
“first pages” elsewhere in the panel. You can choose to offset the alter-
nate header & footer settings by a strict number of pages (for example, “2”
to consider a coversheet and title page as separate from themain body), or
have the starting point determined automatically, using the “After front
matter” setting.

Front matter is defined by the Front Matter dropdown in the project’s
compile contents settings (section 23.4.1). If the project does not have front
matter set up, then the “first pages” settings will be ignored, and normal
headers and footers will be used from the very first page on.

Use facing pages Enables the “Facing Pages” header and footer configuration
section in the second tab. If your margin settings are asymmetrical, as
illustrated in Figure 24.16, this will also have the effect of mirroring those
settings fromone page to the next, creating a narrower inner or outermar-
gin (in the sense of how both pages would look in an opened book side by
side) as you require. If you require symmetrical margins, such as in PDFs
meant for digital use only, make sure to keep your settings uniform in the
Margins button above, and this feature will then only impact the header
and footer text that is used on facing pages.

21 Front matter is defined by the Front Matter dropdown in the project’s compile contents set-
tings (section 23.4.1).
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Figure 24.16 Margin settings, using the classic Van de Graaf Canon layout, as
demonstrated in Scrivener’s preview feature.

Different header and footer on pages following page breaks Enables the
“First Pages” header and footer configuration section in the second tab.
This will allow for a different header and footer configuration on new
pages—a common use here is to place the page number at the bottom of
the page instead of at the top, to keep the chapter heading clean but still
leave the page numbered.

Different header and footer for back matter Enables the “BackMatter” header
and footer configuration section in the second tab. All pages that have
been inserted using the Back Matter dropdown in the project’s compile
contents settings (section 23.4.1) will use these settings instead of themain
body settings.

No header on new pages following page breaks When enabled, the header
(not footer) will be disabled on any page following a page break. Most often
this will be used to keep the title area for part and chapter breaks clean; a
common typesetting technique, as shown in Figure 24.17.

No header or footer on… When these checkboxes are enabled, both the header
and footer will be removed from the pages that match their respective
checkboxes:
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Figure 24.17 The page header is suppressed (blue emphasis) on the chapter
break page, but otherwise displays the name of that chapter in
subsequent pages (tan emphasis).

— Single pages: when the amount of material between two page breaks
amounts to a single page; this would most often be seen in cases like
book or part level breaks, where a full page is dedicated to some sort
of title.

— Blank pages: available to PDF and Print, where blank pages are gener-
ated in the book, they can also have the header and footer removed
from them, as is typical. A common example of this would be a blank
page inserted to keep the part break on the recto side.

Header and footer fonts At the bottomof the “Headers andFooters” section are
two settings for controlling the font and text size of these respective fields.
The font family itself can be overridden by the project’s compile settings.22

Print and PDF Settings
Draw dividers for… A margin-width rule (similar to the appearance of the

header in this usermanual) will be inserted below the header text, or above
the footer text, when these respective checkboxes are enabled.

22 Bear inmind that projects using a global font override (subsection 23.3.1)will ignore this setting,
as will all other areas of the format that stipulate the font family.
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Use vertical headers and footers Both the header and footerwill be rotated ver-
tical, so that the header is along the left edge of the paper and the footer
is along the right. The text itself (with its divider, if applicable) will also be
rotated 90°.

24.20.6 Header and Footer Text

Figure 24.18 The header and footer fields are used to place information on six
predetermined points around the edge of the page.

The header and footer area is divided into categories, or types of header and
footer assignments, listed in a sidebar. The number of available categories will
be determined by which settings you have enabled in the Options tab. In Fig-
ure 24.18, we have selected theUse facing pages andDifferent header and footer
onpages following page breaks options, which has added the “Facing Pages” and
“New Pages” sections to this tab, respectively. Refer to the previous documenta-
tion by section name if you wish to look up how a particular type is meant to be
used, and also keep in mind that the Preview button at the top of this pane can
be used to preview header and footer arrangements by type as well.
Each category has an identical set of header and footer fields, giving you de-

tailed control over what information will be printed, where on the page, and on
what type of pages or contexts. For each category youwill find two rows of three
text fields for the header (top row) and footer (bottom row). You can use asmany
of these fields as you need.

678



24.20. Page Settings

In the illustrated example, we have designed a layout using classic golden ratio
margins in a mirrored layout design, with the title of the book printed in the
upper left-hand corner on the verso page, and the title of the current chapter in
the upper right-hand corner of the recto page. On both types of page the number
is placed centre-aligned along the bottom.
Simple formatting can be used in these fields using markup. You can choose

between BBCode ([i]Italic[/i] and [b]Bold[/b], or Markdown, to indicate
bold and italic ranges. Use _underscores_ to underline portions of text.
Unless the compile format is meant to only ever be used with this one project,

it will generally be a better idea to use placeholders (Table 24.2) in these fields
rather than typing in specific information like your name or the title of the book.

Using Special Characters

Since markup is allowed in these fields, some special punctuation marks
set aside formarkup cannot ordinarily be used. You can however instruct
the compiler to ignore special characters. If you need to print asterisks or
underscores, you can wrap the fields in double-curly-braces. The entire
row needs to be treated this way. So for example if you wished to turn
off markup for the header, you would type in “{{” in the beginning of the
left-aligned field, and ”}}” at the end of the right-aligned (third cell) field.
This would need to be repeated for the footer if desired.

Sectional PageHeaders
For use with print, PDF and the word processing formats (excluding RTFD), the
<$pageGroupTitle>placeholder tag canbe placed into theheader and footer field
to print out the title of the current section of the item which last caused a page
break. This header will be used for all subsequent pages until another page break
is generated.

Looking to get rid of section breaks?

Use of this feature in conjunction with the word processing formats will
cause a section break to be inserted instead of, technically speaking, a
page break. This is necessary to change document layout settings from
one page to the next. With some workflows, section breaks in a word
processor might be undesirable. You should avoid the use of this place-
holder, any checkboxes that cause headers/footers to change throughout
the document and also any section layouts in use by the project should
have their Include in RTF bookmarks checkbox disabled, in the Section
Layout: Settings tab.

Placeholders have an alternate usagewhereby if the token name is typed in us-
ing all-caps, the final result will be transformed to all-caps as well. For example,
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Table 24.2 Useful Header and Footer Placeholders

Placeholder Description

Available to Header and Footer fields

<$compilegroup> The current compile group. If you wish for this to be
more descriptive than “Draft”, you can change the name
of the Draft in the Binder to be the name of your book.

<$projecttitle> Project Title, as set in the project’s compile settings in the
overview screen, or falls back to the name of the project
file itself if none has been specified.

<$abbr_title> Also defined in the project’s metadata settings tab. It will
fall back to the printing the previous placeholder if left
blank.

<$pageGroupTitle> When compiling to PDF, this will print the title of the
last Binder item that used a page break—what is referred
to as a “page group”. All subsequent pages will con-
tinue printing that title until a newpage break is encoun-
tered. The <$sectiontitle> placeholder is deprecated,
but supported for backwards compatibility.

<$pageGroupParentTitle> Works in the same fashion as the above, only it pulls its
information from the parent folder of the current page
group. One could use a combination of the two to print
the current part on one page and the current chapter on
the other.

<$surname>, <$forename>,
<$fullname>

Uses author’s name information from the project’s meta-
data settings in the main compile overview screen.

Some useful global replacement tokens

<$p> Prints the current page number.

<$pagecount> The total page count for the entire manuscript. This
is a static number that is primarily useful in conjunc-
tion with the page number token. A value of <$p> /
<$pagecount>, will produce, “73 /258” on page 73 of a 258
page manuscript.

<$wc>, <$wc50>, … All of the word and character count tags can be used in
the header or footer.

<$shortdate>,
<$mediumdate>,
<$longdate>

Prints the current date using one of three formats.
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if the title of the Draft folder is “My Novel”, and the token MANUAL is used in the
header, it will be printed as, “MY NOVEL” in the manuscript.23

Return to chapter ⤴

24.21 Compatibility
Scrivener’s RTF engine supports features thatmaynot be supported in otherword
processors. In aworst case scenario, this can result in fileswhich do not correctly
load at all, display only a part of the content, or at the least omit the parts they
do not understand. The following options can fine-tune the RTF file you create,
so to better increase its compatibility at the expense of formatting. This option
pane is available to RTF, and those formats converted from it: DOCX, DOC and
ODT formats.

Flatten footnotes and comments into regular text Use this feature when the
targetwordprocessor fails to properly display footnotes and/or comments.
For example, Apple’s free TextEdit program cannot display these kinds of
notes at all, and if a file is opened with them, edited and then saved, they
will be lost.

When enabled, all footnotes and commentswill be converted to formatted
text instead of proper numbered notes. Since the notion of a footnote
requires pagination to place the footnote at the bottom of the page, the
end result is that all footnotes will be exported as endnotes. Reference
markers will be inserted into the text using standard punctuation to do
so. This feature modifies the existing behaviour of your compile settings.
If you have opted to strip out all comments, checking this box will not
override that, they will remain excluded. It only modifies how the feature
is exported, if it is scheduled to do so.

UseWord-compatible indents for bullets and numbered lists Available to RTF
alone: this option should be used when working with Microsoft Word.

Word uses a different mechanism for displaying indents in enumeration
and bullet style lists. This option will attempt to preserve as closely as
possible the look and feel of your original document. If you are not us-
ing Word, and you are getting erratically formatted lists, try disabling this
option.

Ensure hyperlinks are colored and underlined Most word processors will do
this for you, but Microsoft Word will not, resulting in links that cannot
be seen. Check this box to make hyperlinks visible in Word.

23 If you need to use small caps, then you should select a dedicated small caps font in theHeader
font or Footer font settings.
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Return to chapter ⤴

24.22 Processing
⟨Direct-saleonly⟩Available to the “MultiMarkdown” and “Plain Text” compile file
types, this pane extends Scrivener’s compile process into the realmof shell script-
ing and system integration, essentially opening the door to a limitless degree
of automation and making the compiler for all intents and purposes, fully pro-
grammable. Using the post-processing capability, you can have Scrivener send
the compiled source document to any utility capable of accepting data and ar-
guments from the command-line shell, including your own scripts.

Sharing Formats with Post-Processing

As youmight expect, assigning a script to be runwith this option will not
import whatever environment the script requires into the format. Af-
ter all, we might use something as complex and large-scale as the LaTeX
typesetting engine from here, and you wouldn’t want your compile for-
mat to weigh in at several gigabytes worth of processing environment!
So when sharing a scripted format with others, it would be a good idea
to document any dependencies and installation procedures.

You can opt to embed the script in the compile format itself. For simple au-
tomation, this may be all you need to provide to others, with little to no docu-
mentation of the process being necessary. To the end-user making use of your
Format, the result will be as seamless and automated as using any of Scrivener’s
other file type settings.

Use Pandoc syntax Available when using theMultiMarkdown compile file type.
Adjusts the syntax that Scrivener generates, where it does so, to produce
Pandoc compliant Markdown dialect.

Post-process on command-line Tick this checkbox to enable the remainder of
the options in this panel. This will alter Scrivener’s compile behaviour sig-
nificantly, in that it will no longer solely produce a text file where you
choose to compile. Instead that file will be further processed by the set-
tings you specify in the fields below.

The values you provide will be saved even if the checkbox is later disabled.
This can be useful if you wish to provide post-processing as an optional
behaviour in the compile Formats you distribute.

The designated compile folder will be used as the working path for the
scripts. It is even possible to have the temporary resource files Scrivener
generates discarded, leaving only the intended output—a great option if
you just want to create an ePub, PDF or other encapsulated format as a
single file.
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To provide a practical example: you could create a post-processing script
that takes aDocBook XML file, generated by Pandoc, and then uses another
utility to generate a PDF from it. The PDF is what would be ultimately com-
piled by the format, not the intermediary Markdown source or even the
XML. Consequently, when selecting a compile filename and location, the
sorts of applications listed in theOpen compiled document in option will
include those that claim to handle PDF files, notMarkdown TXT or XML.

Should I use pipes or files?

Scrivener will be expecting a file-based workflow, not piped, though you
can use STDOUT and STDERR within your scripts to generate status
and error logs. Scrivener will capture that information and present it in
a post-compile dialogue if the operation fails. So when writing your own
scripts, they should be capable of loading a specified file and upon con-
clusion produce a file for output, directly to the disk. A demonstration of
a script with simple status and error logging can be found in the Extras
Pack (Appendix G), under “7-example_postprocessing_script.rb”.

Script & Path This dropdown provides two selection options, “Script” and
“Path”, which determine whether to point Scrivener to an external utility
or script on the system, or use a script stored directly within its compile
settings:

— Path: The full path to the executable script or binary should be sup-
plied in the text field to the right. Shortcut notation will not be han-
dled as the execution environmentwill not be a full shell. An example
full-path would be /usr/local/bin/pandoc.

— Script: when this option is selected, an Edit Script button will appear
to the right. Click this button to input your script into the popover.

Edit Script

The Edit Script button, which will appear when Script is selected above, contains
an interface for you to input your custom script.

Shell bydefault Scrivenerwill pass the script to /bin/sh, so if you intend towrite
a simple shell script, you can leave this field blank. You may also leave this
field blank if you intend to provide a “hash-bang” line on the first line of
your script, such as #!/usr/bin/ruby -Uw.

Script Entry Area Input your script into the large text editing field provided.

Any arguments you pass to the script, using the Arguments field of the Pro-
cessing pane, will be accessible to your script using its mechanisms for working
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with command-line arguments. For all intents and purposes, your script will be
running as though it were a saved file on the disk, from the working compile
folder.
Since Scrivener will not perform any syntax checks, and all debugging would

have to be done at the tail end of the full compile process, you may find it more
expedient to first compile a source file with this pane disabled, and then develop
your script in a text editor, finally importing it into your compile settings once
it has been fully tested.

Arguments All necessary command-line arguments (or flags) should be supplied
in this field. In order to provide your script or utility with the necessary
input file to be processed, as well as the name of the output file chosen by
theuser, youmayneed touse a couple of placeholder tags that are exclusive
to the Arguments field:

— <$inputfile> will provide the full path to the file that Scrivener
would output normally. This will typically be the file that is used as
primary input for the script.

If omitted from the Arguments field, Scrivener will append the path
to the input file to the end of the command-line argument automat-
ically. Thus for many POSIX-compliant utilities youmay not need to
use this placeholder explicitly.

— <$outputname> will be the root path and filename (sans extension)
specified by the user in the compile save dialogue. You will typi-
cally need to type in the extension yourself in the command-line
arguments, which is what Scrivener uses to attempt and detect
what the ultimate file type will be when compiling. For instance,
when typing “MyNovel.md” into the compile Save as field, then a
command-line argument of <$outputname>.pdf would create a file
called “MyNovel.pdf” in the output folder, and meanwhile theOpen
compiled document in… setting would provide various installed PDF
readers for handling the document.

This placeholder can be omitted if the script otherwise handles out-
put entirely. Scrivener will no longer be involved in the handling of
the file post-compile.

Wemight for example use the following arguments, in conjunction with a
path to Pandoc:

-t opml -o <$outputname>.opml <$inputfile>

It is possible to use pipes and redirects to essentially delegate more than one
utility to a process, though in most cases it will be better to package a chain of
commands into a wrapper script.
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That said, as a proof of concept, here is a simple setting that will compile the
material to HTML, using a copy of MultiMarkdown installed to the system, and
instead of generating a file, placing that output directly on the clipboard for im-
mediately pasting into a web page or similar:

— Path: /usr/local/bin/multimarkdown

— Arguments: <$inputfile> | pbcopy

Environment As the script will be executed in a very limited non-interactive
shell, you may need to provide full paths, which will be added to the exist-
ing default PATH variable. For example:

/Users/myaccount/bin:/Library/TeX/texbin

If you need to set additional environment variables other than the PATH,
you should use a wrapper script instead.

Delete source file after processing The plain-text source file created by Scriv-
ener can be optionally removed after it has been processed. Ordinarily it
will be exported into the compile folder, but if all you want is the final
output result itself, enable this option.

Delete exported image files after processing If the output includes images, us-
ing one of the methods described in Markdown and Scrivener (subsec-
tion 21.4.2), or when exported via theMarkup (section 24.10) pane for Plain
Text, those images will be exported into the compile folder for optional
use by the source file. As with the source file itself, the presence of these
images may be undesirable if all you want when you compile is, for exam-
ple, an .epub file that already has those images included within it. Use this
checkbox to have all of these images excluded from the final compile target
folder.

Any other files created as a side-product of the post-processing script will
be left alone. If it is your wish to create a single packaged product, you will
need to program the script to clean up after itself.

Return to chapter ⤴

24.23 PDF Settings
These settings only appear for the PDF document type.

Optimize for print-on-demand services Various aspects of the PDF that may
cause it to be rejected from certain self-publishing services (such as KDP)
will be removed from the output. This checkbox will disable all of the fol-
lowing options.
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Generate PDF outline Assembles a nested list of items that will appear in many
PDF readers which support a content tree. Itwill not generate a visible table
of contents in the printable work itself, only in the menus and sidebars of
applications which utilise PDF content lists. For visual table of contents,
read the chapter on quickly making your own (chapter 22).

For an item to appear listed in the PDF contents, it must be assigned to a
section layout that generates a visible title. The layout needn’t generate a
section or page break, and can thus be a subsection of a larger section or
chapter.

Underline internal links If you intend to print the PDF at any point, you will
probably not want to colour or underline internal cross-reference style
links, so this feature has been disabled as a default. For PDFs which are
intended to be used purely digitally, underlining and/or colouring links
is an important and valuable way to communicate clickable links to the
reader.

Color internal links Enables internal link colouring. Hyperlinks to URLs will
always be coloured in blue, as is the standard. You can select a different
colour for internal cross-reference style links to set them apart. Click the
colour chip to select a colour.

Return to chapter ⤴

686



25
Exporting



In This Section…
25.1 Exporting Binder Files . . . . . . . . . . . . . . . . 688

25.2 Metadata and Options . . . . . . . . . . . . . . . . 689

25.3 Exporting to an Outliner with OPML . . . . . . . . 690

25.3.1 Usage . . . . . . . . . . . . . . . . . . . . . . . 691

25.4 Exporting Metadata to a Spreadsheet . . . . . . . . 691

You can export your work and research material from Scrivener, either as in-
dividual documents or by combining the draft into one longmanuscript and ex-
porting it in the file type of your choice, using compile. Since the latter is a large
topic in and of itself, it is covered in depth in its own chapter, Compiling the
Draft (chapter 23). Here we will look into the former task: exporting data piece-
meal from your project, either for backup purposes, or to facilitate collaboration
with authors who do not use Scrivener.

25.1 Exporting Binder Files
To export items of all kinds from the binder as individual files and folders on
your system, select the items you wish to export in the binder and then use the
File ▸Export ▸Files…menu command, or press (⇧⌘E). This will by default also ex-
port any descendants of the selected items aswell. You can change this behaviour
by enabling theDonot export subdocuments setting, found in the “Options” tab
of the Export panel itself.
When exporting more than one file, Scrivener creates a folder on the disk to

hold all of the exported files. Enter the name for this folder in the “Save as” text
field, and then choose where you would like the folder to be created. From the
Export text files as dropdown menu, you can choose to export text documents
as one of the following:

— Rich Text (.rtf)

— Rich Text with Attachments (.rtfd)

— Microsoft Word (.doc or. docx)

— Open Office (.odt)1

— Web Page (.html)

— Final Draft (.fdx)

1 For superior export and import quality, it is recommended you install Java for .doc and .odt
formats. Alternatively, RTF is often as good or better to use.
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— Fountain Screenplay (.fountain)

— Plain Text (.txt)

— MultiMarkdown (.md)

All media files will be exported as they are (and text file setting is irrelevant
to them). The structure of folders created on disk will reflect their structure in
the binder. There are a few caveats to watch for. Since traditional folders do
not support text material in a folder, Scrivener will need to create a separate
text file to hold whatever material had been typed into the folder in Scrivener,
if applicable. Likewise it will need to create a folder if you’ve nested files within
files.

Return to chapter ⤴

25.2 Metadata andOptions
The export panel features the following settings in two tabs. The Metadata tab
enables additionalmaterial to be exported, andwill be useful if you are preparing
an archival backup that can persist long beyond your use of Scrivener:

Notes Document notes will be exported as separate files using the text file for-
mat you chose above (RTF will be used instead, when any script formats are
chosen). The naming convention will be “(Binder Title) Notes”.

Metadata The creation & modification dates, label, status, keywords, custom
metadata and synopsis will be exported into a file with the naming con-
vention of “(Binder Title) MetaData.txt”. Plain-text will always be used for
this file.

Snapshots Each stored snapshot of the document will be exported into a sub-
folder with the naming convention of “(Binder Title) Snapshots”. The
snapshots themselves will be exported using the chosen text file format.
They will be named according to their snapshot title and date stamp.

The “Options” tab has a variety of settings, some of which are format depen-
dent:

Do not export subdocuments Only the literal selection in your binder will be
exported.

Number exported files The naming convention will be modified to “(Sibling
Order) (Binder Title)”, modifying any instances abovewheremerely binder
title is used. Sibling order is determined by folder. So if one folder has four
itemswithin it, those itemswill be numbered 1–4, andwith the next folder
(itself numbered “2”) would start over at 1 for the first child item within it.
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Remove comments and annotations All notes-to-self using these two features
will be stripped from the output. If youhave no intention of archiving your
work notes, or are intending to share these exported fileswith proofer, this
can be a useful option.

Append “.fountain”/“.txt”/“.mmd” extension Available when using any of the
plain-text formats.

Forces the file extension to be a specific standard extension instead of let-
ting you choose an extension in the Save As field above. This is also useful
if you’d rather not bother typing in an extension, as it is possible (and valid)
for text files to not have an extension.

Convert rich text to MultiMarkdown Available when using the “MultiMark-
down (.mmd)” format.

Uses the same rules described in theCompile settings general option pane,
in the option by the same name (subsection 23.4.3). Rich text formatting
such as lists, tables links and so forth will be converted toMultiMarkdown
syntax as best as possible.

Return to chapter ⤴

25.3 Exporting to anOutliner withOPML
Manyoutliners support a common format knownasOPML. It candescribe “head-
ings”which arewhat you see in the binder as names of items, and the relationship
between those headings in terms of order and depth.2 There is a loose conven-
tion followed by some outlining programs to attach plain-text “notes” to out-
liner headings. As this method is not standard, support for it may vary in terms
of quality and features.
To export an outline:

1. Select the items youwish to export—any selected containerswill automat-
ically include all descendent items.

2. Use the File ▸Export ▸OPML File…menu command.

3. Select your export options (refer to “Usage” for detailed descriptions of
them).

4. Select a folder and filename to export the OPML file to and click the Export
button.

2 This method is intended for exporting an indented outline, rather than exporting metadata. If
youwish to export tabularmetadata lists, try ExportingMetadata to a Spreadsheet (section 25.4).
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When you select a container to be exported, that container will be consid-
ered the “root” item. Depending on what outlining software you use, this item
may not be initially visible, as some default to hiding the root item. It is how-
ever stored safely in the OPML file. When exporting the entire binder, Scrivener
will create a new root item to represent what was the binder itself, and place all
folders within it, including even the “Trash” folder and its contents.

1.

25.3.1 Usage
The following options are available from within the export panel:

Export entire binder Rather than use the current selection, export the entire
Binder outliner from top to bottom. This will include everything; even
items you have currently in the Trash can.

Extended note options With the exception of the initial option, these settings
will attach the designated information to each heading as a “note”. If the
software you are using to read the OPML file supports notes, you should
see this information appear however it does so. If you are having troubles
importing the OPML, try leaving this set to “Titles Only”, whichwill use the
published standard for OPML files.

— Titles Only: only the names of binder items will be exported as a hi-
erarchical outline.

— Title and Synopses: contents of any index cards, or the synopsis field
will be attached to their respective headings in the outline.

— Title and Text: in this case, “text” refers to the main text from the
editor for that item. This only includes text from file or folder doc-
uments in the binder. The output will be converted to plain-text by
necessity.

— Title and Notes: any document notes will be attached to their respec-
tive items in the outline. The output will be converted to plain-text
by necessity.

Return to chapter ⤴

25.4 ExportingMetadata to a Spreadsheet
Outliner views can be exported to files suitable for loading in spreadsheet soft-
ware, like LibreOffice Spreadsheet orMicrosoft Excel; many databases and other
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miscellaneous programs that support tabular data, such as DEVONthink Pro,
may also read the file.3 To export spreadsheet information:

1. Select all of the containers or items you wish to export. For example, you
could click on the “Draft” folder to export themetadata for the entire work
in progress.

2. If necessary, switch your group view mode to Outliner, with the View ▸
Outlinermenu command, the group view toolbar button, or⌘3.

All of the items listed in the outliner will be exported, including any de-
scendent items of containers (even if the containers are collapsed).

3. Adjust the column order and which columns you would like to have ex-
ported. If you’d rather have all possible columns export you can choose
that as a setting in the subsequent dialogue.

4. Use the File ▸Export ▸Outliner Contents as CSV…menu command.

Formats The three formats below are all commonly accepted by most spread-
sheet applications. Check with your preferred software for details. Scriv-
ener will export the first row in the file as “headers”, so your software
should be instructed as such if applicable.

— Comma separated values (best for most spreadsheet software).

— Tab separated values.

— Semi-colon separated.

Only include columns visible in outliner When checked, the column list and
the order of those columns will be used to create the data file. When
disable, Scrivener will export all metadata columns (including any cus-
tom columns you might have added) in the order that they appear in the
View ▸Outliner Options ▸ submenu.

Return to chapter ⤴

3 Thismethod is primarily intended for tabularmetadata export. If youwould prefer a hierarchal
export—with options for full text content—more suitable for outlining, you might want to try
Exporting to an Outliner with OPML (section 25.3).
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Given how we can say there are two discrete functions of the binder—your
works in progress (typically in the Draft folder), and all of the support files and
notes around it—you may need two fundamentally different ways of printing
material. Since proof printing and final printing the draft are closely related to
the act of compilation itself, this function has been built into the compile in-
terface (select Compile for: “Print”, and you will note we even have an example
compile Format designed specifically for distributing proofing copies).
For all other forms of printing, either piecemeal or in groups, the standard

print command familiar to most applications will be available, including a few
special-purpose printing tools for the group views in the main editor.

Figure 26.1 Scrivener’s print settings are foundby switching to the “Scrivener”
section of the Page Setup panel, using the dropdown at the top of
the dialogue.

In most cases (compile, notably excluded) all you need to print a selection is
use the standard File ▸Print… command (⌘P), though domake sure that you click
into the editor you wish to print from first.
Continue reading for tips and features on how to control the appearance of

your print-outs. Many aspects of the printout can be adjusted in File ▸Page
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Setup… and will be covered in each relevant section. These settings are saved
into each project, not globally.1

Individual documents and supported media can be printed one by one, as you
would expect. When more than one text document is displayed in the editor
they will be printed together according to the current view mode:

— If you are viewing the selection as a corkboard, index card printing will be
used.

— When viewing them in Scrivenings, the overall text will be printed as a
longer document.

— Printing the outliner will produce a list with optional metadata.

26.1 Document Printing
When printing an individual text file, a series of text files with Scriveningsmode,
or individualmedia files (such as PDF or graphics), the following settings are avail-
able in the File ▸Page Setup… dialogue.

Printing with Placeholders and Number Tokens

The basic document print tool will not evaluate placeholder tags or the
more complicated uses of auto-number counters in your documents. If
you wish to print with these evaluated, you should select the documents
you wish to print, and then use File ▸Compile… with either the Contents
tab’s compile group set to “Current Selection”, or the use of “Current Se-
lection” as a filter (subsection 23.4.1).

26.1.1 Text Document Print Settings
Header
Page numbers Insert a page number in the top-right corner of each page in the

header area. This number will be relative to the selection you have chosen
to print, it will not reflect the actual page number of the complete draft (if
you are printing from within the draft).

File name and date Prints the selected binder item’s name next to the page
number in the header area. If more than one document has been selected
the project’s file name will be printed instead.

1 They will also be saved into project templates you create from projects with modified settings.
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Content
You can optionally add metadata to the printout for each document that is se-
lected. By default, only Text will be selected, or the main content body in the
editor. The available settings here are similar those found in the “layout content
columns” in the upper half of the Section Layouts compile format pane (sec-
tion 24.2.1).
Title formatting will be determined by your current Scrivenings title font set-

tings (even if youdonot display titles in Scrivenings), in theAppearance: Scriven-
ings settings pane (section B.5.13).
If you require more control over the formatting, presentation or ordering of

these various elements you should probably create your own compile format and
use the dedicated compile feature instead of this tool, which is mainly built for
expedience and simplicity.

Options
Remove annotations By default inline annotations will be included, using their

original colour, and enclosed in square brackets to help identify them
when using a black and white printer. Tick this option to remove them.

Insert linked comments Linked comments will be inserted beside the high-
lighted anchor range in a darker variation of the highlight’s colour. Disable
this to keep them out of the print job.

Print using font To override the font family of the documents temporarily, and
use a uniform font for all elements on the printed page, check this box and
then select the font and font size in the activated option menus, below.

Return to chapter ⤴

26.2 Printing Index Cards
When viewing a collection of items on a corkboard, you can print the content of
the corkboard into index card-sized rectangles. Here are a few things to know:

— The content of the card’s title and synopsis will be printed on however
many subsequent cards it takes to print the entire synopsis.

— Thismethod is solely designed for printing to standard 3 ′′× 5 ′′ index cards,
rather than a reproduction of what you see on the corkboard.2

— The formatting has been optimised to work with Avery™ Perforated Index
Card stock, but you can use any paper with a chopping block or scissors

2 In most cases such would not be desirable, as the background textures would be a waste of ink
and longer synopses would only show what can be seen before scrolling.
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to cut the cards apart desired, or even feed in regular index cards if your
printer supports front-loading paper feeds and heavy stock.

— For cards with visible images, the image thumbnail will be placed into the
card area, and tomake space for it, most optionalmetadata (see below) will
not be shown.

26.2.1 Index Card Print Settings
As with printing text documents, you can access options for corkboard printing
with the File ▸Page Setup… command, navigate to “Scrivener” settings from the
dropdown, and selecting the “Index Cards” tab.

Content
Include titles By default the title of each binder item will be printed at the top

of the card. Untick this option to focusmore on the synopsis content. The
following two options will have no effect when this is disabled.

Embolden titles The title of the card, printed at the top, will be emboldened
to set it apart from the rest of the card content. If your index card font
settings are such that titles are always bold anyway, this setting will have
no effect.

Highlight titles with label color The background of the title area will be high-
lighted with the card’s assigned label colour, if relevant.

Add card numbers This is similar to View ▸Corkboard Options ▸Show Card Num-
bers feature. Each cardwill be numbered relative to the visible cards, start-
ing at 1.

Include keywords When enabled, all keyword names will be printed out in a
comma-delineated list below the title.

Options
Ignore cards with titles only With this option enabled, if a card has no syn-

opsis, it will be ignored. This includes images that would otherwise be
printed out as image thumbnails.

Print cutting guides This option is most useful when using standard paper.
Each card will be outlined with dashed cutting guides, making it easier
to separate them into actual cards with a cutting block or scissors. If you
are using perforated card stock, it is best to leave this option off.

Force landscape orientation Maximises the number of cards you can fit onto
a single sheet of paper to four instead of three. If you are just printing to
regular paper and plan on cutting themapart, use this option to save paper.
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Print using font Override the default font with your preferred font family and
size.

26.2.2 Tips for Printing to Individual Cards
With some printers, it is possible to feed individual cards into the printer, which
makes for a cheap alternative to perforated cards. You will want to ensure that
your printer is capable of handling thicker paper in small sizes before attempting
this. Follow these steps to set up Scrivener:

1. Select the File ▸Page Setup…menu item.

2. Under Paper Size, select the menu choice, “Manage Custom Sizes…”.

3. Press the + button to create a new custom paper size and call it “Index
card”, or whatever you prefer.

4. Enter the height and width of your index cards. Use a ruler if you are un-
sure. Most cards come in 3 ′′× 5 ′′ and 4 ′′× 6 ′′ form.

5. For the non-printable area, you can select whatever you like here. A small
value of 0.25 inches is a good default, as the card will not be anywhere near
the edges of where the printer can print.

6. Click OK to confirm the new paper size and then make sure that is the
selected paper size before clicking OK again to confirm your page setup.

You will now need to follow the instructions provided to you by your printer
manufacturer to figure out how to feed the cards into the machine. Some print-
ers will let you place the cards in a stack, but with many printers you will need
to feed in a card one by one as it prints. Keep this in mind if you intend to print
out hundreds of cards!

Return to chapter ⤴

26.3 PrintingOutlines
As with corkboards, you can print a limited range of content from an outliner
view by simply viewing the material you wish to print in the outliner, and using
the File ▸Print… command. Also, as with corkboard printing, this will not attempt
to reproduce the precise appearance of an outliner. Instead, the outliner printing
tool generates an indented list with the title, synopsis and select metadata for
each item in the current outline view.
If you find the following settings for the outliner fails to provide the look you

desire, you might consider using the compiler instead. Try starting with one of
the provided built-in formats “Enumerated Outline” or “Full Indented Outline”,
and customising them to taste. Or, if you just want the data, try exporting the
outliner to a spreadsheet compatible file (section 25.4).
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File name The name of the container that is having its contents printed will be
placed in the header of the page. If the editor contents are from a selection
rather than a particular folder or other group, then file name of the project
will be printed.

Titles Each item’s binder title will be included in bold text. Tick the Prefix
titles with number checkbox to include a simple number count (non-
hierarchical) for each item in the outline.

Synopses The full synopsis will be printed for each item.

Label and status If the label and status have been set they will be added to the
title. Label will highlight the background of the title area with its associ-
ated colour, and will be inserted after the title (if present) in parentheses.
Status will be placed at the bottom of the entry in the metadata area.

Keywords Keywords will be added on the line below the title in a comma-
delineated list.

Custommetadata Any custom metadata assigned to the item will be added in
the metadata area, one field per line for each metadata field that has been
filed out for that row, or if it stores a value that may be meaningful (like an
unticked checkbox).

Word counts The word count for each item individually will be placed into the
metadata area. Optionally ticking the Include targets with counts check-
box will print the goal for each item individually following its word count.

Character counts As above, only printing the character count (and optionally
goals as well) instead.

Indent by level Indents each item relative to the current outliner view. So items
which are children of the root level items will be indented once, nomatter
how deeply nested they are within the binder. Disabling this produces a
flat list.

Font Select which font and text size youwould like used for the printout. By de-
fault the font used for your general outliner textwill be used by all projects,
until you change this setting.

Return to chapter ⤴

26.4 Printing theDraft
Printing the Draft folder, the dedicated area of your project that is intended for
your work in progress itself, is accomplished via the compiler—and is in fact its
default mode of operation. Functionally, printing is very similar to producing a
PDF file with the compiler.
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1. Open the compile interface with File ▸Compile… (⌥⌘E).

2. Using the Compile For dropdown menu at the very top, select “Print”.

3. For simple output of what you see in the editors, the “Default” compile
Format selection at the top of the left sidebar will often be sufficient.

4. Click the Compile button.

Once Scrivener has finished processing your draft, you will be presented with
the standard macOS print dialogue. From here, you can choose to save a PDF
from the dropdown menu on the left, or click the Print button to send the com-
piled document to your default printer. The first time you do this, you should
preview the print job, first. Click the PDF button in the lower left corner of the
print dialogue, and select “Open in Preview”. From there you can examine the
output at full scale, and if it looks good, print from Preview.app.

⟨Direct-sale only⟩Note that you can select Scrivener itself as a target. This will
send the printed document as a PDF to your project and import it. This can be a
handy approach to take when proofing; read more about Scrivener’s proofread-
ing tools (section 20.3).

See Also…
— Read Compiling the Draft (chapter 23) formore details on how to compile.

— If you want to print a script, read Printing or Exporting a Script (sec-
tion 19.5) for tips.

Return to chapter ⤴

26.5 Other Print Settings
Since scrivenings mode is not available to most media, your only options for
printing groups of them will be as an outline, where they will act just like text
items by printing their titles, text synopses if available and so forth. Images on
the corkboard are an exception, which will print within the index card space
where the synopsis would ordinarily be printed.
When printing items individually, research files will print out in a standard

fashion according to their type, and there are no options for adjusting how that
occurs. Images and web pages have a few options available in the same Page
Setup panel, under the “Other” tab.

Web Pages By default, background images and colours will not be sent to the
printer to save ink and increase clarity. However if the background image
is an integral part of the design, tick the Print backgrounds checkbox to
have them included.
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Images There are two scaling options to choose from: Print actual size and
Scale to fit page. If the image you are printing out is very large, you will
have better success with the latter option. In most cases actual size will
produce a better quality print as small images may become quite blurry
when blown up the size of a page.

Return to chapter ⤴
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Appendices

Nothing stinks like a pile of
unpublished writing.
Sylvia Plath
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This appendix will address each entry in every menu, and will display the key-
board shortcut for it where available. It is intended to be a quick, exhaustive
reference of the menus, and will attempt to point you in the right direction for
more thorough discussion and analysis of various features where necessary.
Themenus in Scrivener are divided into several domains, into eachwe attempt

to organise groups of functions respectively. If you are looking for a particular
feature and are not sure where it is located, the table describing the menu sec-
tions (Table A.1) will explain our understanding of the menu as a category for
features. If you happen to know the name of the feature you are looking for, and
have access to the software, the easiest way to find a menu command is to use
the search bar from the Help menu.
If a menu name changes its label depending on how you’ve used it, this will

often be indicated with the “|” symbol, separating the parts that change. For
example: View ▸Show|Hide Inspector, will either print “Show Inspector” or “Hide
Inspector”.

A.1 CustomKeyboard Shortcuts
There may be certain menu items that you find yourself using a lot that have no
keyboard shortcut, or maybe you find the assigned shortcut overly convoluted.
Scrivener also includes manymenu commands which are meant to be used with
custom shortcuts, that may not have one out of the box.
The ability to change or assign keyboard shortcuts tomenu items is built right

into macOS itself:



A.1. Custom Keyboard Shortcuts

Table A.1 Menu Organisation

Menu Title Purpose of Menu

Scrivener Themain applicationmenu is where overall application settings and in-
formation can be accessed. Changing Settings, setting up registration
information, and quitting the software can be done from here.

File Concerning the management of projects, including the transfer of in-
formation into and out of them, either manually with import, print &
export, or automatically with backups and synchronisation.

Edit If a function will work with the content of an editor window, either pas-
sively or to manipulate it directly, then chances are it will be located in
the Edit menu. Examples would be finding text, adding a link or check-
ing spelling.

Insert Commands for inserting things into your text, such as images, equa-
tions, placeholder tags, footnotes and comments.

View For adjusting how the project window looks and feels, as well as the ap-
pearance of contentwithinwindows, such as changing the zoom level of
a PDF, showing invisiblemarkings in the text or selectingwhich columns
are used in the outliner.

Navigate All about getting around inside the project window. Loading docu-
ments, opening them into splits, jumping between the window’s various
contexts and viewing collections are within the remit of this menu.

Project Settings and information, statistics and goals specific to the project itself
are gathered in thismenu. This is alsowherenewcontent canbe created,
and where the Trash can be emptied.

Documents This menu concerns the management of existing documents, including
the content within them, the metadata used to describe them and their
organisationwithin the project. Documents can bemoved to other fold-
ers, grouped into new ones, or even trashed from this menu.

Format This menu concerns itself with the presentation of content. If you want
to change the font or paragraph indents, this menu is what you’ll use.
Scriptwriting, styles and revisions are also managed from this menu.

Window The various windows themselves can be managed here, such as basic
commands for minimising or switching between open projects, select-
ing from predefined layouts to adjust how a project window looks and
feels or to reopen recently closed Quick Reference panels.

Help The Help menu provides access to theMac’s menu search utility, as well
as useful tools and links for learning Scrivener, registering the software
or getting in touch with us.
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1. Load System Settings (available from the Apple menu in any application).1

2. Load the “Keyboard” panel and click the Keyboard Shortcuts… button.

3. Select “App Shortcuts” in the list on the left.

4. Click on the “+” button. A dialogue will appear.

5. From the “Application” pop-up button, choose Scrivener.

6. In the “Menu Title” text field, enter the name of the command you want
to add.

This should exactly match the name of the menu item in Scrivener (capi-
talisation and punctuation matters). For instance, if you wanted to add a
keyboard shortcut to the Insert ▸ ImageLinkedtoFile… command, youwould
type Image Linked to File... in this text field (including the ellipses).

7. Click in the “Keyboard Shortcut” text field and then hold down the com-
bination of keys that you want for the new shortcut.

8. Click the Done button.

When you return to Scrivener, the new keyboard shortcut should be ready to
go.

Resolving Conflicts
Keyboard shortcuts on macOS work by scanning the menus from left-to-right
looking for a menu item matching the shortcut pressed. If you find that the
shortcut you assigned doesn’t work, or does something unexpected, it may be
that the keyboard shortcut you chose is already assigned to a different menu
item. In that case, you can either pick a different shortcut, or you can locate the
menu item that it clashes with and go through the above process again to as-
sign a different shortcut to the clashing menu item. If the shortcut still doesn’t
work, you should ensure that the shortcut you assigned isn’t one reserved by the
system.

Menu titles that change dynamically
Some menu items change name depending on the context; for such items, you
may need to assign the same keyboard shortcut for each of their possible names.
For instance, the Edit ▸Add Link… menu item can sometimes change its title to
become Edit ▸Edit Link… Therefore, to add a keyboard shortcut to that item that

1Onolder versions ofmacOS themenu commandwill be printed as “Preferences”, and references
to System Settings (“System Preferences”) locations may no longer be accurate.
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would work consistently you would need to add the same shortcut twice, once
for Add Link... and again for Edit Link....

Menu titles that are duplicated
Sometimes a menu title will be used more than once. This most often hap-
pens with titles that are created dynamically from your project information. A
good example of this is Navigate ▸Collections ▸NameOf Your Collection and Docu-
ments ▸Add toCollection ▸NameOfYourCollection. If you created a shortcut called
Name Of Your Collection alone, thiswould be bound to the initial shortcut that
shows the tab in your binder, not the command that files the current document
into that collection. To target a specific menu, you also need to type in its menu
hierarchy by inserting -> between each menu level (with no spaces around the
arrow), thus:

Documents->Add to Collection->Name of Your Collection

A.2 ScrivenerMenu
Much like the application menu in any other macOS program, this provides ac-
cess to application level information, features, and system integration, such as
Services.

About Scrivener Displays the credits and version number of the application.
If you are experiencing problems and wish to contact customer support
regarding them, you can provide version information using this dialogue.
Click on the version number to copy this information to the clipboard and
dismiss the window.

Settings…⌘ , Accesses global application Settings. For a complete list of all
available options, refer to Settings (Appendix B).

Appearance ▸ ⟨macOS 10.14+⟩ By default Scrivener will automatically adapt to
a dark or light appearance depending on your Mac’s global setting. With
this menu you can override the system and cause Scrivener to always use
Dark or Light Mode. The use of Themes that are designed for a specific
appearance mode will adjust this setting for you, if necessary.

KeepMain Editors Light⇧⌥⌘L Available for Dark Mode, this will keep
the two main editors using Light Mode settings. Read more about
the workings behind this setting in Keeping Text Editing Light (subsec-
tion 4.3.2).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
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Theme ▸ This submenu will list any preset themes that you have created or
installed into Scrivener. To switch appearance settings, select the de-
sired theme from this list. Refer to Settings Presets and Themes (subsec-
tion B.1.1) for further information on managing themes. If you do not see
thismenu, thenno themes are installed on this computer. Once you create
or install a theme, as described, it will appear.

⟨macOS10.14+⟩When selecting a theme designed for Dark or LightMode,
you will be asked if you wish to apply the theme and switch Scrivener to
that mode of appearance, if relevant. Dark Mode themes will be indicated
with a moon icon to the left of their name.

Reveal Support Folder in Finder Opens Scrivener’s “Application Support” fol-
der, where it stores your presets, custom project templates, custom icons,
and so on. Use this if you wish to transfer settings between machines, or
if asked to do so for troubleshooting reasons.

Authorize Folder Access… ⟨MAS only⟩Opens a window where you can manage
a list of folders to grant Scrivener additional privileges in accessing your
disk. If youmake use of file links, research aliases or image links, youmight
wish to authorise the folders they are in, or even your entire user folder so
that Scrivener can make use of these files without explicit permission per
session.

Enter|Deactivate Licence… ⟨Direct-sale only⟩When you purchase the applica-
tion, use the “Enter Licence”menu command to copy and paste your regis-
tration information from the email that you will receive from our vendor,
Paddle. In case you have lost the original email or never received the in-
voice, you can use the Retrieve Lost Serial… button which will take you to
our web page with further instructions on how to retrieve it.

After you have registered and activated the software, this command will
read “Deactivate Licence…”. Use this command if you will no longer be
using this computer, as it will reclaim one of your allowed installation to-
kens.

Check for Updates… ⟨Direct-sale only⟩ You can use the Check for Updates
menu command to see if there is a newer version of Scrivener available
for download (3.x updates are free). If any are found, you can update the
software conveniently from this tool. You can also choose to have updates
applied automatically in the future, and this check can be performed rou-
tinely as well, in the General: Startup Settings pane (subsection B.2.1).

Services The items in this menu are provided by the core system and other
third-party applications. They will let you perform various functions,
mostly based on selected text. Scrivener provides its own services which
are also available in this menu, and from other applications as well. See
Scrivener Services (section 9.3) for further documentation.
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Quit Scrivener⌘Q Leaves the program. Any projects that are left open will be
saved to the disk, and by default, backed up for you. Under the default
Settings, these projects will be remembered and opened automatically the
next time you run Scrivener.

Quit and Close/KeepWindows⌥⌘Q Whether this will “Close” or “Keep” open
projects upon next reload depends upon whether your Settings are set to
reopen projects that were open on quit (subsection B.2.1). Which is dis-
played will be the opposite of whatever your standard settings are. This
will not change your preference, it only influences how the softwareworks
this one time.

A.3 File Menu
The Filemenu contains everything that handles creating files on your computer,
including creating new projects, saving, backing up, importing and exporting. It
also deals with printing and project-specific settings.

New Project…⇧⌘N Brings up the Project Templates window, which will walk
you through creating a new project in the location you specify.

Open…⌘O Shows the file selection dialogue for opening an existing project off
of your hard disk. Full read-write permissions must be set for a project to
be opened successfully.

Recent Projects Here you can review a list of projects that have been recently
opened (you can also specify in the General Settings (subsection B.2.1)
whether Scrivener will reopen all projects that were open in a previous
session when it is launched).

The number of items listed in this submenu is governed by macOS in a
global fashion, and can bemodified in the SystemSettings: Control Center
pane.2

Favorite Projects Displays a listing of all the projects on this machine that have
been flagged as a “favourite”. Use this to load or activate the window of
the project you select. Read more about it in Setting Favourite Projects
(subsection 5.1.4).

Add|Remove Project from Favorites Adds or removes the active project to the
“Favorite Projects” list.

2Onolder versions ofmacOS themenu commandwill be printed as “Preferences”, and references
to System Settings (“System Preferences”) locations may no longer be accurate.
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Show Project in Finder The active project will be located and presented to you
in a new Finder window. This information can also be acquired from the
project window title bar, by right-clicking on the name of the project itself.

Find All Projects in Spotlight ⟨Direct-sale only⟩ Runs a Spotlight search, bring-
ing up a Finder window with the search results of all Scrivener projects
included within the remit of the Spotlight index. It is important to distin-
guish the difference between this and searching your entire computer for
projects. The Spotlight index may not include drives you have specifically
omitted, or external drives you have plugged into the computer. It will
also not locate zipped projects (usually a result of automatic backups).

Close Project⇧⌘W Closes the current project and all of its associatedwindows.
The project will be automatically saved upon close, and under default set-
tings will be backed up.

Close all open projects at once, by holding down the Option key to reveal
the command, or use the⌥⌘W.

Close Project and Clear Interface Settings⇧⌥⌘W By holding the Option key
down while viewing the File menu, you’ll see this troubleshooting com-
mand appear. This will safely close the project and as a final step, trash the
project’s display settings files. All options such as visible elements (rulers,
inspector, etc), splits, label tinting, columns, and other settings will be fac-
tory reset. Ordinarily, you’ll only ever need to do this to fix display glitches
or if you’ve been instructed to by tech support.

Close Window⌘W Closes the currently active window (e.g. Quick Reference,
or utility panel). However if the project window has focus or is the only
open window for the project, the entire project will be closed instead.
Composition mode must be exited explicitly, it does not respond to this
command.

Save⌘S Scrivener auto-saves your writings as you work, so that you never have
to worry about losing your efforts. Projects are also saved automatically
whenever they are closed. You can use the save command to force an im-
mediate save whenever you want, however since it will usually already be
saved, this command is more interesting for its optional ability to trigger
automatic backups and snapshots.

Save As…⇧⌘S Will prompt you for a new project name and/or location. When
you submit this dialogue box, Scrivener will immediately start working
with the new copy, closing the version you had been working on up un-
til that point. If instead you want to generate a backup copy and keep
working with the original project, use File ▸Back Up ▸Back Up To… instead.

For more information on managing projects, refer to All About Projects
(chapter 5).
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Save and Rebuild Search Indexes⌘⌥S You canmanually rebuild the search in-
dex while saving, by holding down the Option key when viewing the File
menu, and selecting this command. This is sometimes useful in cases
where you suspect the project has lost synchronisation with the search in-
dex. There is typically no need to do this as Scrivener will automatically
maintain the index, and it will rebuild it if something appears to have gone
awry since the last session.

Import ▸ Commands for importing a variety of existing information, from your
drive or even from the Internet, into your active project. For full docu-
mentation on importing information into Scrivener, refer to File Import
(section 9.1).

Files…⇧⌘ I Import files from the computer into your project. Only text-
based formats can be imported in the Draft folder. See the prior refer-
enced section for a full list of supported formats there, and elsewhere in
the Binder. This method is synonymous with dragging and dropping files
directly into the binder itself.

Web Page… Import a web page from the World Wide Web by supplying
Scrivener with its URL. By default it will be archived to an offline format,
retaining its look and feel using the WebArchive format (same as when
saving a page from Safari). You can optionally choose to import only the
text content of the page (subsection B.8.1).

Thismethodof importing is also available from theAddbutton in themain
application toolbar.

Research Files as Aliases… Rather than fully importing items into the
project, this command establishes a link between the original item and the
project. This link will automatically adjust if the original item is moved or
renamed. Read about Linking toResearchMaterial (section 9.2) for further
details.

Plain Text Formatted Screenplay… Import a plain text screenplay, op-
tionally splitting sections into separate binder documents. This works
best with scripts that have been exported from programs, like Movie
Magic Screenwriter, that work with plain-text files for import and export.
Read more about Importing Plain Text Formatted Screenplays (subsec-
tion 19.4.2).

Scrivener Project… Import a selected Scrivener project into the current
project’s binder. All binder items will be imported, as well as some meta-
data: keywords, references, and notes. If it is detected that the imported
project appears to be an older version of the same project you are import-
ing into, you will be offered a chance to merge the projects together. Refer
to Splitting & Merging Projects (subsection 5.3.2) for further information.
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Import and Split… This is a multi-use tool which can either takes a stan-
dard plain or rich text file and allows you to supply a character sequence
(such as “#”) which will be used to split the document into sections, or
for some formats, intelligently break the file up by logical sections based
upon the internal format of that file. For example a Word document with
a stylesheet based outline can be converted into a nested binder outline, a
Markdown file can be split into an outline via its heading structure, while
Final Draft and Fountain files will be split by sluglines.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Export ▸ Provides tools for exporting elements of the binder to the file system.
For more information on exporting your work, see Exporting (chapter 25).

Files…⇧⌘E For exporting selected contents of a project as individual files
and folders. This feature is mainly used to create a hard copy backup or to
share resources with someone not using Scrivener. Generally speaking,
you will want to use File ▸Compile… to export your book as a single file,
rather than many. Refer to Exporting Binder Files (section 25.1) for more
information.

OPML File… Exports the current binder selection as an Outline Processor
Markup Language file. OPML files are commonly read by applications that
work in outline oriented data, like Scrivener, and is thus a convenient way
of transferring hierarchal information (or the file tree) between such pro-
grams. Refer to Exporting to an Outliner with OPML (section 25.3).

Outliner Contents as CSV… Available only when an Outliner view is ac-
tive, this menu command will export the information from the outliner
into a spreadsheet file. See also: ExportingMetadata to a Spreadsheet (sec-
tion 25.4).

Comments and Annotations… Exports only the comments and annota-
tions from theproject into a single file. You canoptionally choose to export
only pre-selected binder items and select whether the list is organised by
binder titles.

as Scrivener 2 Project… Save a copy of your project in the legacy Scriv-
ener 2.x format, for when working with older versions of Scrivener, as well
as version 1.x for Windows. Refer to Saving Your Projects for Older Ver-
sions (subsection 3.2.4) for usage tips.

The older version of Scrivener must be at least version 2.7 on macOS, or
1.9.5 on Windows.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
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Sync ▸ Tools for linking parts of your project to external applications, mobile
devices or disk-based files and folders. Read more about syncing in Cloud
Integration and Sharing (chapter 14), and Working with Scrivener for iOS
(section 14.2)

with Mobile Devices Forces Scrivener to check the current project for
mobile changes. In ordinary usage this will not be necessary as these
checks are performed automatically when switching to the project from
another window and of course when loading the project. However it is
safe to use whenever you feel unsure about the sync state of the project.

with External Folder… Method for creating folders with plain-text, rich
text, Fountain or Final Draft files on your system. The folder can be
placed anywhere, includingnetworkmounted drives or synchronised fold-
ers such as provided by Dropbox, Google Drive, iCloud Drive and Spi-
derOak. It is thus useful for coordinating with collaborators or even just
working on pieces of your project while on the go. See also: Synchronised
Folders (section 14.3).

with External Folder Now If external folder sync is set up, syncs the
project with the folder immediately. Otherwise the configurationwindow
will be opened for you.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Back Up ▸ Functions for managing backup copies of the current project. For
more information on back up strategies, see Backing Up Your Work (sec-
tion 5.2).

Back Up To… Generates a complete backup copy of the project to a spec-
ified location. Backup copies, unlike “Save As”, will be created and then
ignored by Scrivener, you will keep working in the current version of
the project. Optionally, you can choose to compress the backup in a zip
archive, which takes longer, but is the recommended method for storage
of backups, particularly if you intend to copy the backups over the Internet
in one form or another.

Back Up Now Triggers the automatic backup system to produce a backup
immediately, using the established preferences for backup location and ro-
tation scheme. This will create a backup for the project even if it is set to
be excluded from automatic backups normally, or if automated backups are
in general disabled. Customise how this works in the Backup Settings tab
(section B.9).

Back Up All Projects Now Hold down the Option key to reveal this alter-
nate command. Scrivener will cycle through each project that is open and
create a backup for it, again using the established Settings for backups.
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This commandmay take some time to complete, particularly if you have a
few large projects open.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Save As Template… Saves the current project as a template. This will add it to
the New Project window for use as a basis for your future projects. Every
single aspect of the project will be saved, including any content you leave
in the binder. For more information on creating templates, read Project
Templates (section 5.4).

Page Setup…⇧⌘P Accesses the standard page layout setup dialogue (access
Scrivener-specific features from the Settings dropdown menu within this
sheet). Most compile formats will use these settings to determine paper
size and margins, as well as for regular printing. For full documentation
on the standard printing process, read Printing (chapter 26).

Print Current Document…⌘P Prints the current editor view. How this will be
printed depends on the view mode, with all of settings for this accessed
through the File ▸Page Setup… command, above.

Compile…⌥⌘E Compile is the standard method for producing a manuscript
out of all the individual pieces in the Draft. This feature provides an im-
mense degree of flexibility, and is fully documented inCompiling theDraft
(chapter 23).

A.4 Edit Menu
TheEditmenu contains options related to editing content. All of the typicalMac
Editmenu items can be foundhere, including cut, copy, paste and find, alongside
with a large complement of Scrivener-specific features.

Undo & Redo⌘Z &⇧⌘Z Undoes or redoes the last change. Undo and Redo
work mainly for edits made to text, but they do work for some basic out-
lining changes too, where that change does not cause the current docu-
ment to change in the editor. Each document has its own Undo history,
which means you can go back to documents you’ve edited previously and
undo changes made there without undoing changes made more recently
to other documents.

Cut, Copy, and Paste⌘X,⌘C &⌘V Cut, copy and paste act exactly as they do
in other applications. These commands will not act upon documents that
you have selected. They will work primarily with text, but can sometimes
also be used to copy and pastemetadata like bookmarks or keywords. This
manualwillmakenote ofwhere copy andpaste can beused for non-textual
edits. For editing documents, refer to the Documents Menu (section A.9).
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Copy Special ▸ This menu allows you to copy text or binder items using func-
tions to create specially formatted lists of items, remove markings from
the text or convert the text to different formats.

The first group of commands copy from selected items, from the corkboard,
outliner or from the binder sidebar.

Copy Document as External Link Copies a URL to the clipboard which
can be used to link to the selected item fromany other software supporting
links on your computer. E.g. pasting this URL into the hyperlink URL
field of your word processor would create a link from that document to a
specific item in your project binder.

These links are static references to the project’s locationon your disk. They
will likely not work from other computers, or if the project has been re-
named or moved from the location it was in when the link was generated.
Readmore about External Links (subsection 10.1.6). This command is also
available from the binder contextual menu as “Copy Document Link”.

Copy Text of Documents The text content of the selected documents
will be copied together into one continuous text in the clipboard using
the order they appear in at the time of copying. E.g. if copied from the
binder then that order will be used, but if copied from a sorted outliner
view or Collection then they would be copied in their sorted order.

Copy Documents as ToC Aids in the creation of a basic table of contents
(with pagenumbers for supported compile formats) using the selected doc-
uments. This list can be pasted into a file within the draft. See Creating a
Table of Contents (chapter 22) for further information.

Copy Documents as Structured Link List Creates a list of links pointing
back to the selected documents, formatted into an indented list. This form
of list can be used to create a basic table of contents in a digital book, where
hyperlinks are used instead of page numbers.

The remainder of the commands in this submenu operate upon the active text
selection in either the main editors, Document Notes or Bookmarks editor, in
the Inspector.

Copy without Comments and Footnotes Strips out inline and linked
notation, while retaining all other formatting. This will often be useful
for producing “clean” snapshots (section 15.8) after an editing session. This
command will remove all notation, including footnotes.

Copy as Markdown The selected text will be converted from rich text to
Markdown format (using the MultiMarkdown dialect), where possible to
do so. This command produces markup similarly to the compile conver-
sion option, described in Markup Options (section 23.4.3).
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Copy as HTML Reproduces most formatting as HTML codes using inline
CSS. The resulting HTML should look very similar to the text you copied in
Scrivener, including some ruler settings, colour, highlight, and so on.

Copy as HTML (Basic, using <p> and <span>) Provides for minimal inline
CSS formatting. Ruler styles and some types of formatting will be lost.
This is often the best choice for pasting into blogging and Content Man-
agement Systems, which provide their own stylesheets.

Copy as HTML (Basic, using <br>) Applies very basic, HTML 4.01 compli-
ant code. When constructing HTML emails, or working with an older web
site, this is what you will want to use.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Paste andMatch Style⇧⌥⌘V This pastes the contents of the clipboardwithout
any of its existing fonts, styles and other attributes such as links, tables and
lists; in essence, treating it like plain-text. Useful forwhen you have copied
a range of formatted text butwant to paste it using the style of the text into
which you are placing it, such as when gathering material from the Web.

Paste Plain Text as Screenplay When the active editor is showing a scriptwrit-
ing document, this menu command will become available. It can be used
to paste plain text formatted screenplays, from the likes of Movie Magic
Screenwriter, or even plain text screenplays you compiled from Scrivener
in the past. The pasted textwill be analysed and converted to the script for-
mat. It is only intended to work properly with standard screenplay scripts.

Delete In some contexts this command can be used to remove items from lists,
such as individual keywords in the inspector pane, and is usually passively
bound to the Delete key. In similar cases, such as the Bookmarks pane in
the inspector, where the removal cannot be undone, it is necessary to use
the ⇧⌘delete shortcut instead.

This menu command can also be used to permanently delete selected
binder items fromwithin theTrash folder, without emptying it completely
(use Project ▸Empty Trash… for that). This capability is also available to the
right-click contextual menu on items in the trash.

Select All⌘A Selects all of the content of the current text, outliner, corkboard
view and etc. This commandworks in every context where it is possible to
select multiple items, from footnotes in the inspector sidebar to keywords
to search results in the sidebar.

Select ▸ Contains several commands to aid in the selection of items and text.
In addition to these commands, in views where things are listed and it is
possible to select multiple items, such as the binder or a list of keywords,
there are a few modifier keys that can be added to mouse clicks to form
basic selections:
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— Command: toggles whether or not one item beneath the mouse
pointer is selected. This can be used to effectively deselect every-
thing, if the one and only selection is clicked. It can also be used to
add a second item to the selection, no matter how far away it may be
from the originally selected item.

— Shift: Selects all of the items in between the point where you click,
and the last itemyou clicked on as a selection action. This can include
Command clicks from above, as well as normal clicking to select one
item.

Select Word The next three commands will select the nearest word, sen-
tence or paragraph that the cursor or current selection is found within, or
when a selection exists, it will be expanded in both directions until reach-
ing the requested unit of measurement. E.g. if a few letters of two words
are selected, the SelectWord command would expand the selection left to
encompass the first word entirely, and rightward to encompass the second
word entirely (Figure A.1).

Figure A.1 Before and after usage of the Edit ▸Select ▸Select Word command.

Select Sentence Given the wide range of languages, writing styles and
methods, right, wrong or just creative—grammatical constructs such as
sentences can only be estimated.

Select Sentence with Spaces This alternative which will select one space
from around the sentence (whichever is most logical), so that it can be
more easily moved to a new position without clean-up.

Select Paragraph Selects the current paragraph, including the carriage
return on the end of it, unless of course the paragraph is at the end of
the file.

Select Style Range The current selection will be expanded to encompass
the style range around it in a contiguous fashion. This works locally first,
looking for character styles, and then expands to any paragraph styles that
exist around the selection. If no styled text exists around the cursor or
selection, then expansion will encompass the contiguous unstyled para-
graphs around it.
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For more documentation on this and the following two commands, refer
to Selecting and Searching for Styles (subsection 17.4.1).

Select All Style Selects all non-contiguous text within the same text view
using the current style beneath the cursor, or as found beneath the left-
most edge of the selected text. As with the previous command, character
style ranges will take precedence over paragraph styles. Also as with the
prior command, if the cursor or selection encompasses text with no style
applied to it, the command will select all other unstyled text.

Select Next in Same Style Using the same criteria as “Select All Style”,
this command will select the next phrase of text found within the cur-
rent editor using the same style. If the cursor is within block quote, then
the next block quote will be selected. This form of selection will wrap
around from the bottom of the document back to the top if necessary,
which means if only one example of the style exists, the very context the
cursor currently sits in may be the “next” available example of text using
this style.

Select Similar Formatting Using the same criteria as “Select All Style”,
this command checks for the type of formatting located beneath the cur-
sor and then scans the document for similar examples, selecting all such
non-contiguous text simultaneously. This command is handy for turning
simple formatted text into styled text. Given the wide variety of possibil-
ities that fall under “formatted text”, we cannot expect this command to
function flawlessly in all cases.

If the cursor or selection falls upon text that is styled, then the outcome of
this command is synonymous with Edit ▸Select ▸Select All Style.

Select Annotation/Footnote This command will alternate depending
upon whether the cursor or leftmost selection edge is located within an
inline annotation (of the same colour) or inline footnote. If so, the inline
note will be fully selected. The command will be disabled if no such inline
notation range can be found.

Select Subgroups Applicable only to the outliner and the binder when a
container of any type is selected. This command will add any descendant
container items that are currently visible and that contain subdocuments
(an empty container like a folder is not considered a group of items). This
command can come in handy when assembling corkboard stacks (subsec-
tion 8.2.8), which require a selection that consists purely of containers.

Figure A.2 demonstrates a few different outcomes based on this rule. We
can disregard anything that might be within the “Section A” folder since
it is collapsed, “Section B” contains one container (“File two”) which be-
comes selected as well, and finally “Section C” is disregarded because it is
an empty folder.
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Figure A.2 Before and after results of selecting the subgroups of the “Ap-
pendix” folder.

Select Current Text⌥⌘A When the current context is a text editor in-
stead of the binder or outliner, this command will appear in the menu. It
can be used to select only the text in the section you are currently editing
within a Scrivenings session, rather than the entire session.

Select with Subdocuments⌥⌘A This command will become available
when a container has been selected in either the binder or the outliner.
Use it to select all descendent items of that container, opening any nec-
essary levels of hierarchy downward in order to do so. This command is
useful for cases where explicit selection is required, such as keywording,
taking group snapshots, or assigning many items to a collection.

Select ‘Included’ Subdocuments As with the prior command, all subdoc-
uments of the currently selected container (to all depths) will be selected,
but in this case only if they have their respective “Include in Compile”
checkbox enabled. Easily filter out all notes, old revisions and other
nonessential items from your draft folder with this command.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Deselect All If possible, removes all active selections from the current view. In
some cases therewill always be a default selection that cannot be removed.
In a text editor, the cursor position takes on that role, and certain com-
mands and tools will use the cursor position as a form of implied selection.
In the corkboard and outliner views the underlying container that is be-
ing viewed will occupy the default selection, mainly for deciding what the
Inspector will examine.

Completions ▸ These commands can aid in the entry of text, by offering to
complete what you have typed in thus far in the current word.
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Complete⌥Esc Requests the auto-completion service for the text entered
thus far. Can optionally be invokedwith⌘ . or simply Esc by itself on some
keyboard layouts. If you would prefer suggestions to be offered immedi-
ately and without invocation, switch In script mode only off, in the Cor-
rections settings pane (section B.6).

Complete Document Title ⌃Esc With the first part of a document titled
already typed, use this command to cause Scrivener to search your project
for matching titles and suggest alternatives. This is useful in conjunction
with the Corrections setting to automatically detect internal links typed
in with [[Document Title]] wiki-style bracketing (section 10.1.1).

Add Selection to Auto-Complete List Adds the currently selected word
or phrase to the project’s auto-complete list. For more information, read
Auto-Completion (section 20.2).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Move ▸ Movement commands are applicable to text as well as items. Items will
move around within the current view, while text will either shift its para-
graph position or have its overall indent level adjusted. Text list lines and
table cells can also be moved up and down in this fashion. In all cases, text
or item alike, movement will be done one step at a time.

When moving selected items in the various group views and lists, non-
contiguous selections will maintain their original spatial distance from
one another, and the whole selection will move together as a single unit
through the other items around them. If any one component of the selec-
tion cannot be moved in the requested direction, the entire selection will
refuse to move.

If it is your intention to gather items together into a container, no matter
how far apart they started off, consider using the Documents ▸Move To ▸
submenu or simple drag-and-drop with the mouse.

Move Up ⌃⌘↑ The item will be moved upwards in a spatial sense. The
particulars of how this happens depends on the context:

— With text the selected lines will be transposed with the line directly
above them.

— On the corkboard, the card will be moved directly up, advancing all
cards between where it was and where it will bemoved, to fill the gap
it left behind.

— In both the binder & outliner views, the selected items will move up
within the current list of “siblings”, or within a folder and without
changing levels. They cannot be move “up” beyond the top of the
group they are within.
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— With label view the selected cards will advance up one label row, ter-
minating at the top (by default “NoLabel”). If label view is in a vertical
orientation, then moving a card upwill change its binder order to be
earlier in the section.

Move Down ⌃⌘↓ As with moving the selected items up, only in this case
all movement will be done downward.

Move Left ⌃⌘← The item will be moved upwards in a spatial sense. The
particulars of how this happens depends on the context:

— Text will have its block indent level shifted outward by 0.25” incre-
ments. Any amount of first-line or hanging indent will be respected
by this command. The levels of indent for all forms will be incre-
mented equally, and once the left margin is reached by the leftmost
portion of text, the command will be disabled.

— Items in the binder & outlinerwill be move out of their current con-
tainer to become a sibling to it, inserted between the group they came
from and the item that once fell directly below that group.

— On the corkboard, this command will move a card leftward, first
along its row, and then wrapping around to the right edge of the row
above, until reaching the position of the first card in the corkboard.

— With the label view the action is identical in that the card’s order will
be moved earlier in the group. In vertical orientation label view left
movement will change its label assignment.

— Collections do not allow left or right movement.

Move Right ⌃⌘→ As with moving the item left, only in this case all move-
ment will be done in the opposite direction. In the case of text, the indent
will be incremented 0.25” per usage and has no effective upper limit. The
action of moving an item right in the binder & outlinerwill be to nest the
selected items beneath the item directly preceding the topmost selected
item.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Sort ▸ Sorting can be done in the following cases: wherever there is a flat list of
adjacent items that can be arranged in a view, when a single item is selected
that is a container to other items orwhenmore thanone line of contiguous
text has been selected in an editor. Possible applications include items
in the binder, outliner or corkboard views, keywords, bookmarks and so
forth.
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Sort Ascending (A-Z) This command will sort eligible items in alphanu-
meric order (0–9a-z) with most punctuation and symbols falling before
numbers.

Sort Descending (Z-A) Sorting by descending order follows all of the
same rules, only sorts in (z-a9–0) order, with most punctuation and sym-
bols falling at the end of the list.

Collection into Binder Order Only available when working with a stan-
dard Collection list within the binder sidebar or main editors. Returns the
list to its original binder order in the project, permanently.
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Append Selection to Document ▸ This command presents a binder item selec-
tion submenu of everything capable of having text added to it. It requires
an active text selection, which will be added to the end of chosen docu-
ment selected through the submenu. This feature will keep track of its use
within the project, tagging frequently used targets in a “Favorites” section
at the top of the menu.

Use the “New…” command to create a new document containing the se-
lected text. You will be asked where to place this new document in a sub-
sequent dialogue.

Append Selection To “X” Again If the Append Selection command has been
used within the current session, this convenience menu item will appear,
to facilitate appending the current selection to the previously used target.

For links between internal project items, or between Scrivener projects, refer
to Linking Documents Together (section 10.1). For general hyperlinks to files,
web sites and so forth, refer to Hyperlinks (subsection 15.7.3).

Add|Edit Link…⌘K Add an external hyperlink of any types to the text. If the
cursor is not already placed within a link, you can use this command to
insert a new link at the cursor position. Alternatively, when text is se-
lected in the editor, the hyperlink will be applied to the text rather than
inserting the URL directly into the editor. The URL editing dialogue will
provide you with several common prefix options3, or optionally ”no prefix:
for custom protocols, like ftp: links.

If the cursor is currently placed inside of a link (including document links),
this commandwill bring the editing dialogue up for that link, allowing you
to change the URL, or select a different binder item to connect the link
with.

3 For the sake of simplicity, bothHTTP and secureHTTPS links are considered one and the same.
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Remove Link If you select a range of text, all link formatting within that range
will be removed. Links only partway selected will have the link removed
from the selection, leaving other bits of the link around it untouched.

Link to Document ▸ ⌘L Presents a binder item selection submenu for the cre-
ation of a hyperlink to a chosen document within the same project at the
current cursor position, using the target’s binder title, or if you have text
already selected, it will be turned into a hyperlink.

Using thismenu, you can also create a link to a document that doesn’t exist
yet, with theNewLink… command (⌘L). Youwill be asked for the title of the
new document, and where to place it. After providing this information, a
link to this document will be inserted in the current editor.

Find ▸ As a program designed for working with bulk text, Scrivener has many
tools in its chest for searching, collecting items, andorganising and review-
ing the results. For full documentation on how to use Scrivener’s extensive
searching facilities, refer to Searching and Replacing (chapter 11).

Quick Search ⌃⌥G Provides a shortcut for using the toolbar’s quick search
field, which otherwise prints the name of the binder item you are currently
viewing (Figure A.3).4 Read more in Quick Search Tool (section 11.5).

Figure A.3 The “Quick Search” tool displays the document title prior to being
clicked on.

Search in Project⇧⌘F Provides a shortcut for the project search tool,
which will appear as a text pane above the binder sidebar. Type text into
this field to search the project for matches, in accordance with the current
search settings, set in the magnifying glass icon menu to the left of where
you type. There is a lot to this tool! Read more about Project Search (sec-
tion 11.1).

Project Replace… Shows the Project Replace panel, for the bulk replace-
ment of text throughout the entire project or selected portions of it, even
including the otherwise immutable snapshots. This operation cannot be
undone; use with care. Read more about its usage in Project Replace (sec-
tion 11.3).

4 Or if the toolbar has been hidden, a pop–up search field will be opened.
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Find…⌘F Brings up a typical text find and replace tool. This panel works
within nearly every context where you can edit text, even within the in-
spector sidebar. In the main editors this often means only one document
at a time, but in the case of Scrivenings session it could mean many docu-
ments. Read more about Document Find and Replace (section 11.2).

Filter…⌘F When the active view is a corkboard or outliner, the “Find”
command will be replaced with the “Filter” command. This brings up a
panel at the top of the view that can be used to filter which index cards
or outliner rows you see, based on various criteria. Read more in Filter
Outliner & Corkboard Views (section 11.4).

Find Next/Previous⌘G &⇧⌘G Jumps to the next or last matching text
based on the criteria supplied in the Find panel. These can be used even
while the find panel is closed.

Use Selection for Find⌘E Sets the selected text as the current find term,
copying it into the “Find” text field even if the find panel is closed. It can
thus be combined with the previous commands to search for text without
using any interface.

Jump to Selection⌘J Scrolls the editor view so that your cursor position
is centred on the page. Useful if you have used the scrollbar, PageUp/
PageDown or the Home/End keys, to briefly check other areas of the text.

When typewriter scrolling (section 16.3) is enabled this command will use
the selected Typewriter scroll line, from the Editing settings pane, rather
than the centre of the view.

Find by Formatting… ⌃⌥⌘F Opens the Find by Formatting panel. This
tool is quite powerful and has a wide range of options documented in Find
by Formatting Tool (section 11.6).

Find Next/Previous Formatting⇧⌥⌘G & ⌃⌥⌘G As with Find Next and
Find Previous, this command will jump from match to match, even with-
out the “Find by Formatting” panel open.

Unlike standard Find, this command will by default seek matches from
adjacent documents once the end of the current document is reached. In
this way, you could step through the entire project looking for matching
formatting.
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Writing Tools ⟨macOS 15.1+⟩ For supported regions and languages, provides
access to Apple Intelligence (AI) features. Refer to Editing with Apple’s AI
Tools (subsection 20.3.5) and Apple’s documentation, for further informa-
tion.

For these commands to be available, some amount of textmust be selected.
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Spelling and Grammar ▸ Accesses the global macOS’ spelling and grammar
tools, as well as Scrivener’s Linguistic Focus tools (subsection 20.3.2).
These settings are stored on a per project basis, though their use will es-
tablish the settings used to set up the next project you create. Existing
projects will always store whatever setting you left them at.

Show Spelling and Grammar⌘ : Opens an interactive spell checking window.
This will be of most use if you prefer to spell check all at once. If you wish
to change the base language the spelling and grammar checker uses, you
can set that here.

Check Document Now⌘ ; Start checking for misspellings from the cur-
rent cursor position on downward. Once the bottom of the document is
reached, it will wrap around to the top.

Check Spelling While Typing⌘\ Toggles the automatic red underlines
that indicate unrecognised and misspelled words as you type.

Check GrammarWith Spelling Toggles the automatic green underlines
that indicate potential style or grammar errors as you type.

Linguistic Focus… Brings up a floating panel that provides access to sev-
eral macOS linguistic word highlighting features (subsection 20.3.2).
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Substitutions ▸ These options controlwhether or not typographic punctuation
will replace easier to type basic punctuation as you write. These settings
are stored per individual projects, and their defaults are established in the
Corrections settings pane, under “Punctuation”.

Smart Quotes If necessary, basic speech marks will be substituted for ty-
pographic punctuation as you type. In English for example, the " character
would be substituted with a matching pair of “curly” quotes. The quota-
tion style used is typically set by your macOS region settings, or quote set-
tings established in the System Settings: Keyboard pane, by clicking the
Edit button alongside your input source.5

Smart Dashes and Ellipses A typed sequence of twoor three hyphenswill
be substituted with an em-dash (—) character, and three full stops will be
converted to an ellipses (…) character.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

5Onolder versions ofmacOS themenu commandwill be printed as “Preferences”, and references
to System Settings (“System Preferences”) locations may no longer be accurate.
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Transformations ▸ For the transformation of text from one form to another in
a permanent fashion.6

Make Uppercase Converts the selected text to all uppercase characters.

Make Lowercase Converts the selected text to all lowercase characters.

Capitalize Useful for headings, this command capitalises each word
within the selected range.

Make Small Caps Creates fake small caps by capitalising all of the letters
in the selection and then using font sizes to produce the effect. If your
workflow requires true small caps you should use the typography features
of your font, or a dedicate font for doing so. This feature is not cross-
platform compatible.

Remove Small Caps In opposition to the previous command, removes
the faux caps effect, restoring the original letter case and normalising the
font size based on the larger letter found within the selection. Given how
this command requires precise expectedmeasurements between large and
small letters, it will only work on text that has not had its overall font size
modified after applying faux small caps.

Quotes to Smart/Straight Quotes Converts between typographic “curly”
quotes and straight speech marks and vice versa.

Inline to Inspector and Inspector to Inline Conversions
These four commands allow you to convert inline annotations to linked
Inspector comments, vice versa, and footnotes. These commands work on
the current editing session as awhole or the current selection if applicable.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Speech ▸ Access to macOS’ text-to-speech synthesis is provided through two
menu controls for starting and stopping speech. The active text editor
will be used as source text with these commands starting with the cursor
and reading downward, or if text is selected, only the selection will be read
aloud.

Settings pertaining to this feature, such as which voice to use and how
rapidly it should speak, are found in the System Settings: Accessibility:
Spoken Content pane.

Text Tidying ▸ A few useful tools for cleaning up text and fixing links.7

6Unless otherwisenoted, these commandswillmodify the entire editor sessionunless a selection
is made, and then only the contents of the selection will be modified.
7Unless otherwise noted, these commandswillmodify the entire editor sessionunless a selection
is made, and then only the contents of the selection will be modified.
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Delete Struck-Through Text Within a selected range, any text marked
with the Format ▸Font ▸Strikethrough command will be deleted. Struck-
through text can also be filtered out of compiled text as an option, without
removing the original text in the editor, making this command only nec-
essary if you desire to clean up the original.

Update Document Links to Use Target Titles When using links to gen-
erate cross-references in the output, this command can be used to fix the
visible text of any document links found within the selected text, updat-
ing them tomatch the names of the documents that they each point to re-
spectively.Broken links (those pointing to documents that no longer exist)
will be automatically cleaned up and removed, by this command, leaving
the text they were attached to unchanged. This command is also available
from the text editor contextual menu.

Readmore about keeping cross-references accurate, inUpdating LinkText
Automatically (section 10.1.2).

Renumber Paragraphs Scans the selected text (or all text in the view) for
numbered paragraphs, and renumbers them starting from 1, at the top.
This command will not renumber lists, if you need to repair a broken list
numbering sequence, right-click in the list and select “Re-number List”.

Replace Multiple Spaces with Single Spaces Useful for cleaning up a
document that has been typed up with multiple spaces in between sen-
tences and so forth.

Remove Empty Lines Between Paragraphs Deletes empty lines, such as
those often found in emails or plain-text documents.

Remove Page Breaks Like hyphen hinting, page breaks are used as a type-
setting tool in single-document word processors to force page flow in
places where natural or soft page breaking produces undesirable results.8

Texts imported into Scrivener will rarely benefit from these as the page
flow will undoubtedly change, and this command can help strip them out
in a bulk fashion.

Strip Leading Tabs If the original documentwas typed in the fashion one
might do when using a typewriter, with tabs in front of every paragraph,
this command can be used to strip them all out.

Zap Gremlins Strips Unicode and ASCII control characters from the text.
If you are having difficulties compiling, or have found areas in your text

8 They may also be used as a “sloppy” stand–in for stylesheet driven page flow, governing such
notions as a chapter heading break, but these uses are not beneficial to how Scrivener works,
either.
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where the cursor seems to get “stuck” when moving through ranges of
text, your text may have acquired these invisible control characters from
somewhere. This command will safely strip out all of the Unicode char-
acters falling within the range of #x00 to #x1F, except for the necessary
#x09, #x0A, #x0C and #X0D characters, which are used to print spaces, line
returns, page breaks and tabs in your text.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Reference Tools ▸ Provides access to fewmacOS language tools, aswell as some
common search utilities.

Look Up in Dictionary and Thesaurus Sends the currently selected
word, or the word that the cursor is currently located within, to Apple’s
Dictionary application. You can also use ⌃⌘D to do quick spot-checks, or
use a “force click” action on compatible hardware.

Search/Look Up in… Uses the currently selected text or active word to
search the selected resource for results. Your default browser will be used
to display the result page and, will require an active Internet connection
to make use of.

Name Generator… A tool which will generate names based on a wide va-
riety of criteria. Read more in The Name Generator (section 20.4).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Start Dictation… fn fn For computers capable of recording audio and making
use of the macOS speech-to-text dictation system, this can be used to
speak words aloud and have them turned into editable text in the current
editor. Settings pertaining to this feature are found in the System Settings:
Keyboard pane, under the “Dictation” subsection.9

Emoji & Symbols ⌃⌘Space Loads the macOS Unicode character browser. Use
this to insert characters and symbols that are not found on your keyboard.

A.5 Insert Menu
The Insert menu is concerned with the addition of images, equations, tables,
notation, special characters and placeholders into a valid text editor or field.
Some general rules of thumb can be applied for how inserted itemswill be placed
within the text:

9 On older versions of macOS the menu command will be printed as “Preferences”, and refer-
ences to System Settings (“System Preferences”) locations may no longer be accurate.
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— The cursor position or text selection will be used to place the selected ele-
ment from this menu.

— Commands that place objects or text snippets, such as images, lines or
breaks, will replace the selected text with that object.

— Those that modify formatting, such as the inline annotation feature, work
just like ordinary formatting commands like bold and italic do. Selected
text will have that formatting toggled, but otherwise the command modi-
fies how we type in new text.

— For commands, like inspector comments that attach objects to text, the
active selection will be adorned. When no selection is provided, the be-
haviour will be to use the nearest available word.

— Some commands insert invisible flow control characters, such as a non-
breaking space, or whitespace characters as they are sometimes referred
to. They will be inserted at the cursor, or replace the selected text.

Table Inserts a starter table (3 columns by 2 rows) into your document at the
cursor position unless the cursor is already within a table. In both cases
the command will also open a floating configuration palette containing
tools for adding and manipulating tabular data in the text editor. With a
preexisting text selection, the selected text will be placed within the first
and leftmost cell.

For further table manipulation commands, use the Format ▸Table ▸ sub-
menu, or right-click within an existing table.

Image From File… This brings up a file dialogue for selecting an image from
your computer to be inserted and storedwithin the current text document.
Images can also be dragged into the editor from nearly any source capable
of dragging images, such as Scrivener’s binder itself, the Finder and many
Web browsers. Read Working with Images (section 15.6) for more infor-
mation on working with images in your text.

Image Linked to File… As with the above, only the inserted image file will be
linked to the original file on your hard disk, rather than storing it as a new
copy in the text document. This allows you to keep image files easily ac-
cessible to other tools as well as keeping the file size of your project trim.
Refer to Linked Images (subsection 15.6.4) for further information.

Image Linked to Document ▸ This submenu presents a list of all images found
within the current project. As with the above command, the image will be
inserted into the editor as a link to the original image, only in this case to a
file within your project binder, rather than to an external location on your
disk.

It is also possible to adjust Scrivener’s settings so that any images dragged
fromwithin Scrivener into an editor will be linked, rather than embedded:
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with the Link to images dragged from binder into editor option, in the
“Dragging & Dropping” Behaviors tab. This may prove more convenient
in projects with many images.

Comment⇧⌘* Opens a new comment attached to the selected text (or nearest
word), which can be written to in either a popup box or the inspector, de-
pending upon your preference. For more information on annotating your
text, see Annotations and Footnotes (chapter 18).

Inline Annotation⇧⌘A Converts the selected text into an inline annotation,
or toggles the writing mode to annotation mode. Like using a proverbial
red pen, these are useful for placing notes right in the editor, alongside the
relevant text.

Footnote ⌃⌘8 This feature is functionally identical to attaching a Comment to
the text, although for the purposes of eventually exporting the content of
the note to the reader in the formof an end-of-page footnote or endnote of
some variety. How this will be done depends upon your compile settings
and the type of work being produced.

Inline Footnote ⌃⌥F Working similarly to inline annotations, this command
converts the selected text into a footnote, or toggles the writing mode to
footnote mode. Useful for keeping footnote content directly alongside re-
lated text.

Bibliography/Citations…⌘Y If a bibliography manager has been set up in the
General: Citations settings pane, this command will launch and bring the
chosen utility to the foreground, facilitating the process of selecting a ci-
tation and pasting it back into Scrivener using whatever system that appli-
cation provides.

MathType Equation ⟨macOS 10.13 – 14⟩ Create a MathType image equation at
the current cursor location. When inserting an equation inline, it will at-
tempt to match the baseline of the current text. If MathType is not prop-
erly installed, a window with a link to the download will be provided. See
also: Using Equations with MathType (section 20.6).

Break ▸ Invisible characters, or whitespace characters, that can be inserted into
the text to control the flow of it. The View ▸Text Editing ▸Show Invisibles
command will cause most them to be visible in the editor as special sym-
bols (Table A.2)

Line Break⌥⌘Return Inserts a soft-break instead of a full paragraph
break. Use this when you need to create a list within a single paragraph.

Page Break Inserts a page break within the current text. Page breaks can
be previewed with the View ▸Text Editing ▸Show Page View mode. In most
cases, Scrivener’s compile systemwill insert page breaks for you, relegating
use of inserting themmanually to niche cases.
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Non-Breaking Space⌥Space Inserts a special space character which will
prohibit word-wrap from dividing the words joining that space. I.e. for
the purposes of word-wrap, it will consider a sequence of words separated
with non-breaking spaces as a single word.

Word Joiner Inserts an invisibleUnicode characterwhichhas zero-width,
but otherwise acts just as a non-breaking space, ensuring the two charac-
ters to the left and right of it are never broken between lines by wordwrap.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Horizontal Line ▸ Provides a few rule lines that can be inserted at the cursor
position, replacing any selected text.

Centered Line Inserts a sequence of 100 underscored non-breaking
spaces with centre-alignment formatting applied to the line. You can in-
crease or decrease the size of the line by adding or deleting non-breaking
spaces.

Page-Spanning Line Uses an underlined tab stop, set to the width of the
page as it will be compiled, to draw a line across the page. Given how Scriv-
ener’s text editor may not depict the width of the page in terms with how
it will compile, the tab stopmay in some cases fall before or after the editor
width or simulated text block in Page View, causing the rendering of the
line to collapse and become invisible.

It is also important to note that since this uses a tab stop with a fixedmea-
surement, if the paper size for the project is changed at a later date, these
kinds of lines will break until their tab stops are fixed or they are regener-
ated with the menu command under the new paper settings.

Signature Line Inserts a sequence of 40 underscored non-breaking
spaces with left-alignment formatting applied to the line. As with cen-
tred lines, you can adjust the width by adding or removing non-breaking
spaces to the line.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Auto-number ▸ Inserts the selected placeholder that will be used to generate
numerical sequences in the chosen format when compiling. A sequence
such as <$n><$n><$n> will print as 123. For full documentation on how to
use the various placeholders, use the Help ▸List of All Placeholders… menu
command.

Draft Word Count ▸ Inserts a placeholder that indicates theword count for the
entire document as compiled10. There are a number of rounding options

10 The particulars for what constitutes the “entire document” are defined by the compile format.
Some may include footnotes or front matter in their counts where others may not.
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available, for cases where precise counts are less important.

Draft Character Count ▸ As with “Draft Word Count”, this command inserts
a token for the total character count with various rounding options avail-
able.

Endnote Marker For supported formats (print/PDF/RTFD/TXT/HTML), this spe-
cial placeholder will collect all of the endnotes in a project and place them
at the location of the marker during compile. This will be especially use-
ful for some academic formats, which do not place endnotes at the very
end of the text. If you are using inline and inspector notation to compile
both footnotes and endnotes simultaneously, this marker will not impact
footnotes.

Current Date & Time⇧⌥⌘D Inserts a plain-text date stamp based on your sys-
tem’s Long Date and Short Time format.

Media Time Stamp Inserts the current time stamp from the active media
player in the opposing split. This can be done while playback is in op-
eration, or while paused. The format for the time stamp can be modified
in the Behaviour: Playback settings pane (subsection B.4.8), underMedia
Time Stamp format.

A.6 ViewMenu
The Viewmenu contains commands related to changing the way documents are
viewed, allowing you to show and hide various elements, navigate between views
and customise the way information in the current project is displayed. A rule
of thumb is, if you want to change the way something in your project looks or
acts, and it’s not found in project settings (Appendix C) nor in themain Settings,
chances are it is in the View menu.
As with project settings, the options you select here will only impact the active

project. If you find you prefer a particular setting in general, you might want to
look into creating a starter template for yourself (section 5.4).

ViewModes
The three view mode selections at the top of this menu are different ways in
which to view the contents of the editor. Setting a view mode determines how
the active editor will view groups of items (such as when clicking on a folder or
selecting two or more items) going forward, until you change viewmodes again.
Within the menu, a checkmark will be placed beside the viewmode currently in
use.
When selecting a container and switching to corkboard or outline mode, the

child items of that container will be displayed in the view. If regular item is se-

732



A.6. View Menu

lected when switching to one of these modes, an empty viewwill be displayed so
you can easily add new child items beneath it (turning it into a file group).
These actions only pertains to the main editors (not Quick Reference panels

or Copyholders, which only view the document content) and is a separate set-
ting per split. You can thus keep one split in Scrivenings mode and the other
in Corkboard if you wish. For an overview of how view modes work, see View
Modes (section 4.2).

Document/Scrivenings⌘1 If multiple text documents are selected in the ed-
itor, this choice displays the current editor as a Scrivenings session (sec-
tion 15.5), showing the text of each document one after the other, viewable
and editable as if they were a single file. Any media or research files in-
cluded in the selection will be skipped over.

When a single non-group item has been selected in the editor this menu
item will be labeled “Document”, and switch the content to its text or me-
dia view.

Corkboard⌘2 Display the current editor as a corkboard (section 8.2).

Outline⌘3 Display the current editor as an outline (section 8.3).

Show|Hide Binder⌥⌘B Toggles whether or not the binder sidebar (subsec-
tion 4.1.3) is visible on the left of themainwindow. You can hide the binder
to concentrate on editing or composing the current document if you so
wish.

Show|Hide Collections Reveals or hides the collection tab list, which will ap-
pear above the binder sidebar, opening it if necessary.

Show|Hide Inspector⌥⌘ I Toggleswhether or not the inspector is visible on the
right of the main window. The inspector displays all metadata for the cur-
rent document, including synopsis and notes, and is hidden by default.
Read more about this sidebar (chapter 13).

Editor Layout ▸ These commands impact the overall layout of the editor space,
between the binder and inspector sidebars. Splitting the editor to show
more than one thing at a time, as well as attaching “copyholders” to clip
files to the editor splits and cleaning up the editor to provide a distraction-
free interface are all located here. For what goes on inside the text editor
specifically, you might be more interested in the following View ▸Text Edit-
ing ▸ submenu.

Show|Hide Header & Footer View Toggles the visibility of the header and
footer bar in the active editor.

No Split⌘ ’ Removes the current inactive split from the editor. For more
information onusing splits, see Splitting the Editor (subsection 8.1.4). This
command does not remove copyholders directly.
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Split Horizontally⌥⌘= Initiates a new horizontal split, or converts the
split orientation to horizontal. When creating a new split, the current con-
tent will be loaded into that split. If the editor is already split horizontally,
then use of this command is synonymous with “No Split”.

Split Vertically⌘” As with splitting horizontally, only vertically instead.

Swap Editors Only available when Split Horizontally or Split Vertically is
enabled. This command swaps the editors from one side to the other, so
that the view on the top/left will become the view on the bottom/right and
vice versa. This swaps the entire editor session, its history, settings and so
forth. What was the left editor will now be functioning on the right side
instead.

If you would instead prefer to merely mirror the content into the other
editor without swapping settings, use the “Match Split Documents” com-
mand in the header bar contextual menu (section 8.1.1).

Copyholder Position ▸ Also accessible by right-clicking on the copy-
holder’s header bar directly, you can set which side of the editor it favours
using the options in this submenu. A copyholder cannot be positioned
parallel with a split, so some options may not always be available, or be
swapped for you when the spit configuration changes.

Close Copyholder⌥⌘- Closes theCopyholder view attached to the active
editor split, falling back to closing from the inactive split, if necessary.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Table A.2 Supported Invisible Characters with Symbolic Depictions

Invisible Character Symbol

Space

Carriage Return

Line Feed

Tab

Non-breaking Space

Page Break

Word-Joiner (Not depicted.)

Text Editing ▸ Formatting tools for working with text can be toggled in this
submenu, as well as visualisation tools like page view, line numbers, verti-
cal writing mode and so forth.
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Show|Hide Format Bar⇧⌘R Toggles the visibility of the character and
paragraph formatting bar, which provides quick access to many of the
most common types of formatting tools. Refer to The Format Bar (sub-
section 15.7.2) for more information on this tool.

Show|Hide Ruler⌘R Toggles the visibility of the tab-stop and indent
ruler (subsection 15.7.1) for the active editor.

Show Titles in Scrivenings When enabled, editable titles of documents
will be placed between documents in a scrivenings session above their as-
sociated texts. Titles can be formatted, and the divider style changed, in
the Appearance: Scrivenings settings pane (subsection B.5.13).

Only Show Scrivenings Titles for Folders Titles added by the above tog-
gle will only appear on folders, while all other items will use a regular di-
vider.11

Show|Hide Invisibles Toggles visibility of hidden control characters,
such as paragraph breaks, table cells (when otherwise set to have no bor-
ders) tabs, spaces and page breaks (Table A.2). You can modify the colour
used to depict these symbols in the Appearance: Textual Marks (subsec-
tion B.5.16) pane.

Show|Hide Markup Toggles the display of textual markings, to produce
a cleaner copy suitable for proofreading. Themarkings that will be hidden
by default are hyperlinks and highlight boxes behind comments, styles and
Preserve Formatting. You can adjust which markings are hidden in the
Appearance: Textual Marks settings pane (subsection B.5.16).

Show|Hide Page View⇧⌥⌘P Toggles displaying the text editor as a vir-
tual page on and off, rather than text in a long column. It is not intended
to be used as a layout mechanism, though it can provide a reasonable esti-
mate of how your pages will look under certain conditions, once printed.
This setting is specific to each split editor, as well as composition mode.
Read more in Page View (section 16.2).

Two Pages Across When enabled, displays two pages side by side in a fa-
miliar book-style arrangement.

Use Vertical Layout This is a global setting that toggles the rotation of
the main editors (including compositionmode) to vertical alignment, as is
sometimes used in Eastern scripts like Japanese.

Show Line Numbers Adds a paragraph (soft and hard line breaks within a
paragraph will not be counted) numbering feature to the standard editor.

11 This behaviour is expanded to include all containers when Treat all documents with subdoc-
uments as folders is set to true, in the Behaviors: Folders & Files settings pane (subsection B.4.5).
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Only Count Every Fifth Line This secondary setting will cause every
fifth line to be numbered, though each line will still be counted. Thus the
second visible number will be “5”, then “10” and so on.

Show|Hide Compiled Footnote Numbers in Inspector
When enabled, after you compile and all footnotes have been counted,
their numbering will be printed in the Inspector alongside the footnote
itself (section 18.3.7). This option can slow down compile, and is thus off
by default.

Prompt Before Updating Footnote Numbers With numbering enabled
the compiler will always ask if they should be updated. This can be of use if
proofing copies have been sent out, and you do not want an intermediate
compile to change the reference numbering your proofers will be using in
their notes.

Focus ▸ Provides access to settings for controlling focusmode. Fromhere
you can set the scope of how much content should be focused, or switch
the feature off entirely for the current view. Refer to Focus Mode (sec-
tion 16.4) for more information on how this feature works.

Typewriter Scrolling ⌃⌘T Toggles a feature that keeps the currently
edited line of text at a set position on the screen, much like typing on a
physical typewriter. This setting is specific to each split editor, as well as
to composition mode (the latter has the feature enabled by default).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

PDF Display ▸ This submenu controls how PDFs are displayed in the editor.
Most of these options should be familiar as they are common tomany PDF
viewers.

Automatically Resize Keeps the PDF sized to the width of the editor win-
dow even when changed.

Actual Size Zooms the PDF to its native scale.

Size to Fit Like “Automatically Resize”, but only resizes the document
once. If you change the size of the editor view later, it will stay at the same
zoom level.

Single|Facing Pages In Single Pagemode, will show one page per row like
an ordinary digital file. In facing mode, two pages will be placed side-by-
side in a column, more like reading a book.

Continuous /Page Breaks These two scrollingmodes affect how the doc-
ument is handled when using the scroll wheel, arrow keys, or page up and
down keys. In Continuous mode, the pages flow by seamlessly; in page
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break mode, only one (or two, if facing pages is enabled) pages will be
showed at a time, and scrolling actions flip between pages.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Corkboard Options ▸ Provides features and visual options for the corkboard
(section 8.2). Most of the settings in this menu are specific to each split,
affording different view settings for each editor. Additional options are
available via the corkboard display options button, which is located on the
right-hand side of the footer bar for each corkboard.

Cards Across ▸ The Cards Across submenu allows you to define how
many index cards you would like to appear in each row of the corkboard.
Auto-fit will calculate how many cards to show, based on the size of the
editor and the size of the cards; similar to how word wrap works.

Arrange by Label Toggles a mode whereby index cards are arranged by
label on the corkboard (subsection 8.2.5). Each label forms a “rail” that
matching cards are placed upon in the order they appear within the cork-
board naturally. Themenu title will adjust depending on your Project Set-
tings (sectionC.3) for how you refer to labels generally. Whether these rails
form rows or columns can be adjusted with the following menu options.

Arrange by Label Layout ▸ These choices select between the rotation of
the corkboard layout or whether it wraps cards to the view, as described in
Stacked Corkboards (subsection 8.2.8). Grid orientation (or how the cork-
board behaves by default) is only available when stacking, never when Ar-
range by Label is enabled for the stacked view. These options are also avail-
able as buttons along the bottom right in the corkboard footer bar, and on
the Touch Bar with appropriate hardware.

The name of this menu will change depending upon the context. By de-
fault it will use the above title (or whatever you refer to as “label” in the
project settings), but if the corkboard is displaying multiple containers in
a “stack”, then the command will read “Stacked Groups Layout”.

Show|Hide Label Colors Along Edges ⌃⌘P A coloured strip, drawn down
the edge of index cards, will indicate the label colour assigned to it. When
no label has been assigned to a card no strip will be drawn on it.

Show|Hide Status Stamps ⌃⌘S Toggles whether stamps are displayed on
index cards. Stamps show the current status associatedwith the document
represented by the index card as though it has been stamped on the index
card. The appearance of stamps can be adjusted in the “Fonts” and “Colors”
tabs of the Appearance: Corkboard settings pane (subsection B.5.4).

Show|Hide Keyword Colors ⌃⌘K Keywords assigned to a document can
be visually indicated along the right-hand side of the index card as colour
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chips. The number of keywords that can be shown at once can be changed
using the corkboard display options button.

Show Card Numbers Cards will be numbered according to their se-
quence in the selection or container they are within. In Freeform mode
the numbers will not change according to where the card is positioned in
the view. This can be a valuable reference as the order of cards are likely
to become shuffled up. This option impacts both splits.

Number Per Section When this option is enabled, if the corkboard is dis-
playing multiple containers in a “stack”, card numbering will be restarted
for each new section. When disabled card numbering will be linear across
sections.

Show Blank Cards as Ghosts Any cards that lack a title, synopsis and
main text content (i.e. would appear as a completely empty index card)
will be hidden from the corkboard, leaving a blank space behind. The card
will still be present, and the empty area can be double-clicked on to edit
the card.

Freeform Activates Freeform Corkboard mode (subsection 8.2.4), allow-
ing unrestrictedmovement of cards around on the corkboard without any
immediate impact on their underlying order in the binder. This can also
be toggled in the footer bar, and on the Touch Bar with appropriate hard-
ware.

Snap to Grid Toggles whether or not cards in freeformmode will snap to
a background grid, rather than allowing for pure freeform placement.

Commit FreeformOrder Uses the current freeform layout to reorder the
actualmanuscript outline structure. Scrivenerwill provide several options
for how this can be done in a dialogue box (section 8.2.4). If card numbers
are enabled, they will be renumbered at this time to reflect the new under-
lying order. This command can also be invoked via the Commit button in
the corkboard footer bar.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Outliner Options ▸ Displays a list of toggle commands that reveal or hide
the corresponding columns in the active Outliner view (subsection 8.3.3).
These settings are stored per split, affording different view settings for
each editor. You can also manage columns using the › button above the
scrollbar area in the outliner itself.

Center Content Toggles whether the current outliner view will have its
content horizontally centred (much like the text editor centres the text
column by default). This will be more useful with a limited number of
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columns, andwill have no visible effect if the outliner is wider than the ed-
itor. This behaviour can also be toggled via a button in the outliner footer
bar (subsection 8.3.9).

Use Fixed RowHeight Toggles whether or not the current outliner view
will used a fixed height cell for each row, rather than an adaptive height
that conforms to the amount of content in various columns. For more
information, refer to Using a Fixed Row Height (subsection 8.3.8).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Use Label Colour In ▸ An item’s label colour can be applied as a tint to various
interface elements throughout the project window, toggled by the choices
in this menu, listed below. The intensity of most background tinting can
be adjusted in the Appearance: General Interface settings pane (subsec-
tion B.5.1). Read about the different options available in this menu in La-
bels & Status (subsection 10.4.3).

Show as Background Color in Binder This option will highlight the title
the label colour, rather than drawing a dot to the right of the name. This
option has no impact on the other sidebar views.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Zoom ▸ This all purpose tool zooms the display of a compatible view in or out,
and also allows for precise selection for text view types. Each split records
its own setting, as well as composition mode. The menu adds shortcuts
and extends access to this capability into areas that lack a visible zoom
control, such as Quick Reference panels and inspector panels with text.
Refer to Scaling Text (subsection 15.3.1) for more information.

The tool will also increase or decrease the size of viewed media, such as
PDF or images.

Zoom In⌘> Increases the magnification of the active view by a set
amount. In text views this amount correlates with the provided percent-
age values in this menu.

ZoomOut⌘< Decreases themagnification of the current view, using the
same rules as zooming in.

Zoom by percentage The middle portion of the menu lists a number of
convenient and popular zoom percentages.

Fit Width Adjusts the magnification so that the page width (including
margins) fits the current editor width. This and the following option are
available when using Page View mode in the text editor (section 16.2), or
when viewing PDF files.
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Fit Page Sets the magnification so that both the short and long edge of
the page can be seen within the editor.

Other… Provides a field where you can type in a precise magnification
amount yourself. If you’d prefer a number between 200% and 300% say,
this would give you the option for doing so.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Outline ▸ This submenu provides commands for working with groups in both
the outliner and binder, followed by settings and navigation commands
for the binder.

Expand All⌘9 Expands all collapsed items recursively within the current
view. When this command is used in the binder, it will expand the entire
binder. If you instead wish to only expand or collapse one single section of
the outline, you can use the Option key in conjunction with a mouse click
or the ← (to collapse) or → (to expand).

This command can also be used in the Footnotes & Comments inspector
pane to expand all collapsed notes to full height.

Collapse All⌘0 As with Expand All, this works the other way, closing all
visible open items recursively.

This command can also be used in the Footnotes & Comments inspector
pane to collapse all notes to single lines.

Collapse All to Current Level ⌃⌘0 Working in a similar fashion to Col-
lapse All, this commandwill collapse the entire outline below the currently
selected item’s level. Thus if you if have an outline that has six levels of
depth, and select a folder on level 3, using this command will completely
collapse all items except those at levels one, two and three, which will re-
main as they were.

When multiple items are selected, the least indented item in the selection
will be used to determine the level by which the tree will be collapsed.

Show Subdocument Counts in Binder Each container in the binder will
display a number to the right of it showing how many subdocuments it
contains. This number is a sum, meaning that it will not only count the
container’s immediate children but all descendants beneath those children
(and their children’s children, to get biblical) as well.

Hoist Binder Focus the binder sidebar on the selected container, and all
of its descendent items. While hoisted, or focused in this way, all changes
made to ordering and structure within that area will be made to the full
binder outline itself. This is merely a way of viewing only one part of the
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binder at a time.12 Read more about it in Hoisting the Binder Hoisting the
Binder (section 6.3.5).

Use this command again to return the binder to full display. You can also
click the× button in the binder sidebar header bar.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Enter|Exit Full Screen ⌃⌘F Utilises macOS’ full screen implementation, ex-
panding themain project window to occupy the entire screen, andmoving
it to its own virtual desktop (or “Space” as Apple refers to them), segregated
from the rest of the applications running on your system. The window
cannot be resized or moved until Exit Full Screen has been invoked.

Exiting Full Screen mode will return the project window to the original
position and size (and when using a default full screen layout (subsec-
tion 12.3.4), to its original layout as well) in use before moving the project
window to full screenmode. Readmore about it in Full ScreenMode (sec-
tion 4.1.6).

Enter|Exit Composition Mode⌥⌘F Toggles the distraction-free writing envi-
ronment (section 16.1). Being strictly for text, this option is not available
to research files or the corkboard and outliner group view modes (it will
switch to text editing in the latter two cases, whichmay result in an empty
editor if the container you were viewing is empty of text). There are three
methods of invocation:

1. In the simplest case, if you are editing a single document or have one
file selected in any context, it will be loaded in composition mode.

2. If the editor is displaying a Scrivenings session, the entire sessionwill
be opened in composition mode.

3. If multiple documents are selected in any context they will be loaded
into the composition mode’s history, so you can flip through them
using the keyboard shortcuts, ⌘[ and⌘].

Show|Hide Tab Bar Toggles the visibility of Apple’s Tab Bar interface, which
allows for the merging of similar windows together into a single tabbed
window. In Scrivener, this means you can combine projects into a single
window, and Quick Reference panels together into their own groupings.
TheWindow ▸MergeAllWindows command is used to combine two or more
alike windows together. For further information on how to use this fea-
ture, consult Apple’s documentation.

12 For a non–destructive way of working with a portion of the binder, where moving items
around can be done experimentally or for some workflow purpose, refer to Using Collections
(section 10.2).
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Show|Hide Toolbar Toggles the visibility of the main application toolbar.

Customize Toolbar… Opens the configuration panel for the main application
toolbar. This can also be done by right clicking on the toolbar itself.

Customize Touch Bar… Brings up the standard interface for customising key-
board buttons on Apple’s Touch Bar technology. As with most software,
youwill need to activate the area of the interface first in order to customise
the button set that is available to it. For example to adjust which buttons
are available in the binder, click in the binder first. Readmore about touch
bar (subsection 4.4.2).

This command will not be visible without the proper hardware.

A.7 NavigateMenu
The Navigate menu focusses on all aspects of getting around inside of a project,
from flipping between available binder sidebar tabs, to jumping from one place
to the next in the editors, controlling media playback to moving your cursor
around within the project window itself without the mouse. It also contains
a few project settings that impact how navigation works with the split editors
and copyholders.

Reveal in Binder⌥⌘R Displays the location of the currently edited file in the
binder, opening the sidebar and switching to the binder if necessary (you
can also use the⌥⌘R shortcut). It will also expand any containers to reveal
the position of the item if it is nested. When used from the icon header bar
menu with a multiple selection, all of the entries included in the selection
will be highlighted in the binder.

This is most useful when the method you used to arrive at the current
document did not involve clicking in the binder (such as using the history
navigation buttons or using a link), or if you are currently viewing a col-
lection and wish to find where the file is actually located in your project
outline. This command is also available from the binder contextual menu.

This command is available in a few different contexts, and is also available
from the header bar contextual menu (section 8.1.1):

— Editors

— Copyholders

— Quick Reference panels

— Binder sidebar views like Search Results, collections and hoisted con-
tainers.
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Reveal Draft Folder Opens the binder sidebar if necessary, switching the main
binder view out of any collections, search results or hoisted containers,
and selects the Draft folder. This can be useful if the Draft folder has been
renamed, and you are uncertain as to which of the folders in the binder
will be used by the compiler.

Go To ▸ The resulting action of this command will be similar to clicking on an
item in the binder: the active editor will go to the item you specify. If
the binder is hidden, a collection is selected, or a section is hoisted, for
instance, you can use this menu to navigate to other areas of the project
without having to alter your work environment.

Beyond the navigation commands documented below, the remainder of
this menu will give priority placement to any project bookmarks that are
defined, followed by a binder item selection submenu. This portion of the
menu can also be accessed from the header bar iconmenu and fromwithin
composition mode using the control strip along the bottom of the screen.

Previous Document⌥⌘↑ Jumps to the previous item in the binder side-
bar list. When used with the main binder view visible, this command ig-
nores hierarchy.

Next Document⌥⌘↓ As with Previous Document, but selects the next
document in the binder sidebar list.

Enclosing Group ⌃⌘R Will display the currently viewed item in context
with its siblings using the current view mode, and can be thought of as a
way ofmoving your editor “up” in the hierarchy one step at a time. Inmost
cases, this will select the immediate parent of the document, selecting the
document’s index card or outliner row that you came from, or expand your
current Scrivenings session to include the siblings and parent of the cur-
rent text item.

Selection⌘4 Causes the active editor to jump directly to the text/content
component of any selected item, disregarding all rules for how that item
would normally be opened. When more than one item is selected, they
will be loaded using Scrivenings mode as a multiple selection. When used
within a Scrivenings session the effect will be to “isolate” the currently
edited chunk of text and edit it alone.

The main difference between this and the Navigate ▸Open ▸ commands
(⌥⌘O or⇧⌘O) is that those will respect the current viewmode preference
(so if you select a folder card in a corkboard and use an “open” command
the result will be to load that folder as a corkboard). ⌘4 will always load
the selected item’s content (text or media)—without changing your cur-
rent view mode. Another distinguishing characteristic is that use of this
command will ignore any navigation rules supplied to the binder or splits.
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The content will always load in the active editor, even if clicking on items
in the binder would ordinarily load them in the other editor.

Collection ▸ This submenu contains a list of all available collections in
the project. Rather than loading the collection in the sidebar, as would
ordinarily be done, this command loads the contents of the collection into
the editor, where it can beworkedwith using any of the group viewmodes.

If the collection is already being displayed in the sidebar, you can also load
it into the editor by clicking on the↪ button in the sidebar header (beside
the × button). Read more about this capability in Viewing the Contents
of a Collection in the Editor (section 10.2.1).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Open Quick Reference ▸ This provides a similar list of project bookmarks and
binder items as the Navigate ▸Go To ▸ submenu, except that the selected
item will be opened in a Quick Reference panel, rather than replacing the
contents of the editor.

Collections ▸ Provides commands for navigating to collections in the binder
sidebar, as well as one conversion command. This menu will be populated
by a list of the collections in this project, in reverse order from how they
appear in the tab list. It will always include an entry for the “Binder” and
“Search Results”. Selecting an entry will switch the sidebar to viewing that
collection, making this menu useful when the collection tab list (subsec-
tion 10.2.1) is not visible, or for assigning keyboard shortcuts to oft-used
collections.

For documentation on how to use collections, see Using Collections (sec-
tion 10.2).

Convert to Standard Collection When a Search Result Collection is the
active tab, this command will “freeze” the results and turn it into a reg-
ular collection that is no longer dynamically updated. This is a one-way
process that cannot be undone, and the original stored search settings will
be discarded. Refer to Converting a Saved Search to a Standard Collection
(section 10.2.4).

Next Collection Select the next collection tab in the stack, as shown in
the tab list (even if it is hidden).

Previous Collection As above, only selecting the previous collection.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Open ▸ TheOpen submenu provides a number of ways to open a selected item.
Thesemenu items are relevant from the binder or collection views, as well
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as within the corkboard and outliner views, but note that in most cases,
a single click in the sidebar or double-click on the icon in the editor, will
open a file more directly. This command is also available from the binder
contextual menu.

In Current Editor⌥⌘O The actual labels of this and the next menu com-
mand will change depending upon the current editor that is active, and
whether or not split orientation is horizontal or vertical, to make it more
clear which editor the item will be loaded in.

Use this command to open the selected items in the current split, replacing
what you are currently working with.

in Other Editor⇧⌘O Open the selected items in the inactive split, open-
ing a new split if necessary to do so. For example you can select a card in
a corkboard and use this keyboard shortcut to open a split and load the
contents of that card into the split.

as Quick Reference Opens the selected document in a Quick Reference
panel (section 12.6). When in a Scrivenings session, the current segment
of the overall session that the cursor is within will be opened.

in Copyholder Opens the selected document in the copyholder for the
current split (subsection 8.1.5), opening a new one if necessary. When used
in a Scrivenings session, the currently active segment of text will be loaded
by itself.

in Quick Look This menu command is only available for types of files
that Scrivener does not support with its built-in viewer. It will make use
of your Mac’s native Quick Look viewer, similar to having selected a file of
that type in Finder and opening Quick Look from there.

With Compilable Subdocuments Similarly to “With All Subdocuments
as Flat List” (below), this loads into the view only those items that are set
to include in compile (subsection 13.5.1). Read more about filtering items
in group view (section 11.4).

With All Subdocuments as Flat List ▸ Useful for caseswhere you’d like to
see all of the cards in a particular section of your outline, even if they are
nested several layers deep. The result of this command is a multiple selec-
tion, which means the items cannot be reordered as all depth information
is lost by viewing cards this way.

— On Editor Corkboard: replaces the current editor view with the se-
lected item’s contents. This is similar to pressing ⌥⌘O to open se-
lected cards on the corkboard, only it also will add all of their de-
scendants to the corkboard as well.
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— On Other Editor Corkboard: as with above, but uses the inactive split
to open the item, instead of replacing the current view, creating a
split if necessary.

in External Editor ⌃⌘O This command will open a file using the default
editor for that type of file (for example, loading a PDF in Preview). This
command is available on any type of item that is not a text or folder docu-
ment. Opening items this way allows them to be viewed or edited in their
native applications. Any edits made externally will be saved back into the
project seamlessly. If Scrivener can display the type of file you edited, you
might need to refresh the viewer to see your changes (section 8.1.3).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Editor ▸ This submenu contains navigation commands that impact the editor
and any content that it is viewing. Whenmultiple splits are open, the com-
mands target the active split. Some of the commandsmay also be available
from Quick Reference and copyholder panes, and will be noted if so.

Lock in Place⌥⌘L Locks the editor (or split) so that no external naviga-
tion commands (such as clicking in the binder) will affect it, causing the
other editor split, if available, to load the request instead (this behaviour
can be adjusted in the Behaviors: Navigation settings pane, by setting
When focused editor is locked in place to “Binder selection does noth-
ing”). When an editor is locked, its header bar will turn a a different shade
of grey, and display a lock icon on the right. Read more in Locking the
Editor (subsection 12.2.1).

Lock Inspector to Editor Available when the editor is split, this com-
mand locks the inspector sidebar to the currently active split. Ordinarily
the inspector tracks the selection within whichever split you are currently
working in. When this is engaged, the inspector header bar will turn a
different shade of grey and the split it is locked to will be indicated by an
“inspector” icon in the header bar. You can now use the other split while
leaving inspector material alone and available for reference. Read more
about Locking the Inspector (subsection 13.1.1).

Lock Group ViewMode Available only when the active editor is display-
ing a group view, or if the selected item is a container (folder, or file group
acting as a folder). Any viewmode can be locked, including single text doc-
ument mode. Locking is a per-item setting, and is saved into the folder or
container itself. The viewmode will stick to what was in use at the time it
was locked. You can change its saved view mode by simply switching the
view mode while viewing the item. Read more about Locking the Group
View Mode (subsection 12.2.2).
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Scroll to Previous Page This and the following menu command are only
available when Page View is enabled in the active editor, or when viewing
a PDF. Scrolls the view so that the top of the previous page is flush with the
top of the viewer, keeping the reading area stable as you browse.

Scroll to Next Page Scrolls the view so that the top of the next page is
flush with the top of the viewer, keeping the reading area stable as you
browse.

Forward in Document History⌘] Much like a Web browser, the editor
keeps track of everything you’ve visited within the project. Using these
commands you can navigate back and forth in the history. You can also
use the Forward and Backward buttons in the header bar (right-click on
them to access the full history as a list). Each split keeps its own history.

This command visits the document you were looking at prior to having
gone back in history to the current document.

Backward in Document History⌘[ This command visits the document
you were looking at before you navigated to the current one, and if you
use it again, to the one you were visiting before that, and so on.

Other Editor ▸ There are a few commands designed for use while writing
in split view, that have an impact on the other editor without removing
your typing focus from the current editor. I.e. You can scroll the other
split and operate its history even while continuously writing in the main
split.

— Forward in History (⌥⌘]): activates the “Forward in Document His-
tory” behaviour for the other split.

— Backward in History (⌥⌘[): activates the “Backward in Document
History” behaviour for the other split.

— Scroll Up (⌃⌥⌘↑): scrolls the other editor back a page, similar to hav-
ing pressed the PgUp key with it active.

— Scroll Down (⌃⌥⌘↓): scrolls the other editor forward a page, similar
to having pressed the PgDn key with it active.

— Previous Page: scrolls the top of the previous page into view, when the
other editor is in Page View or displaying a PDF.

— Next Page: as above, only for the next page.

Clear Document History Use this command to wipe the document his-
tory (both forward and backward) for the active editor or copyholder.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
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Media ▸ Controls and options for various types of playable media. These com-
mands will only become available when viewing the appropriate type of
media. Read more in Viewing Multimedia Documents (section 8.1.3).

If the editor is split this shortcutwill start and stop themedia even fromthe
other split, allowing you to easily transcribe or reference the media while
working elsewhere. When two media files are open at once, the shortcut
will affect the active split.

Play Media File⌘Return Functionally, this acts like clicking the Play or
Pause button in the media viewer, for either audio or video files.

Fast Forward⇧⌥⌘] Jump playback forward by two seconds. This short-
cut works while playback is running or paused. In the latter case, it will
stay paused at the new position.

Rewind⇧⌥⌘[ Jump playback backward by two seconds, and otherwise
follows all of the rules outlined above.

Rewind on Pause This project setting toggles the behaviour whereby
whenever media playback is paused, upon resumption it will be rewound
by a determined number of seconds in the Behaviors: Playback settings
pane (subsection B.4.8).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Move Focus To ▸ Provides application focus navigation tools. Rather than nav-
igating around in your project, these commands will let you quickly select
different parts of the project window without using the mouse. The first
lets you cycle between common elements, while the rest will jump imme-
diately to that element of the interface, nomatter where focus is currently
placed. Note that in all cases, the elements you wish to cycle or jump to
must actually already be visible. These shortcuts will not automatically
reveal parts of the interface that are currently hidden.

Rotate through main views ⌃Tab Rotates through the three most com-
mon areas of desired focus: the two editor splits and the binder. It will
cycle between these three going left to right, and the label of this menu
item will be changed to indicate where the next target will be.

Binder ⌃⌥⌘B Moves focus to the binder sidebar from anywhere in the in-
terface, if visible.

Left|Bottom Editor ⌃⌥⌘E Moves focus to theLeft orBottomeditor, if the
editor has been split. When the view is not split, this command will be
named “Editor” and will select the main editor.
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Right|Top Editor ⌃⌥⌘R Moves focus to the Right or Top editor, if the edi-
tor has been split. When the view is not split, this commandwill be named
“Other Editor”, and will naturally be disabled.

Header Bar Title ⌃⌥⌘T Moves focus to the editor header bar title area
where you can edit the name of the item you are currently viewing in the
editor. If you are viewing something that cannot be renamed (such as a
multiple selection) then the command will be disabled. Use Return to con-
firm your changes and bring the typing focus back into the main viewing
area of the editor.

Copyholder ⌃⌥⌘D If only one copyholder is visible on the screen (or
none), then this command will be named “Copyholder”, and target it no
matterwhich split the focus is current in. Otherwise itwill target the copy-
holder that is attached to the editor that is currently active, and the menu
name will be altered accordingly.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Inspect ▸ In continuation of the keyboard focus functions, these deal solely
with the revealing and focusing of inspector tabs (chapter 13), and occa-
sionally sub-panes within them. The shortcuts work on the following
principles:

1. The inspector itself will be revealed if necessary when the command
is used.

2. If the keyboard shortcut causes the inspector to switch to its respec-
tive tab, then the action will simply reveal it without disturbing your
original typing focus. If the targeted pane within the tap has been
collapsed previously, then this shortcut will also expand it

3. If the tab is already visible, then the shortcut will switch keyboard fo-
cus to the associated metadata area within that tab, allowing you to
interact with its contents without having to use the mouse.

Notes ⌃⌥⌘H Reveals or switches focus to the notes tab. Use the Synopsis
command below to focus the upper “index card” portion of this tab.

Bookmarks ⌃⌥⌘N Reveals or switches focus to the bookmark list. Use⌘6
to switch between viewing project and document bookmarks. Once you
have selected a bookmark you wish to edit in the preview area below, hit
the Tab key to switch panes. Double-clicking on a bookmark, or pressing
the Return key will load the selected bookmark in accordance with the set-
tings in the Behaviors: Document Links settings pane (subsection B.4.2).

Metadata ⌃⌥⌘J Reveals the metadata tab, and switches focus to the Cus-
tom Metadata pane within it. Use Tab and ⇧Tab to navigate between text
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and date fields. Use the Keywords command below to switch focus to the
lower third of this tab.

Snapshots ⌃⌥⌘M Reveals or switches focus to the snapshot list. Use ar-
row keys to flip between available snapshots and view their contents in the
preview area below. Press the Tab key to switch keyboard focus into the
snapshot viewer, where you can use Select All and copy, or use the page up
and down keys to scroll the view.

Comments and Footnotes ⌃⌥⌘K Reveals or switches focus to the com-
ments & footnotes tab. The ↑ and ↓ keys can be used to navigate through
the list, and → and ← to expand and collapse selected notes.

Synopsis ⌃⌥⌘ I Reveals the notes tab and switches focus to the synopsis
text area. Use the Notes command above to focus on the lower portion
of this tab. Use the ⌘7 keyboard shortcut to switch between viewing the
synopsis as an image or text.

Keywords ⌃⌥⌘L Reveals themetadata tab, and switches focus to the Key-
words pane within it. Arrow keys can be used to navigate amongst key-
words; Return can be used to add new keywords; Delete will remove se-
lected keywords.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Outline Groups ▸ These commandsmake it easy to jump fromone group to the
next, where group is defined as any folder in the binder. This behaviour
can be altered to also include all containers with subdocuments, in the
Behaviors: Folders & Files settings pane (subsection B.4.5).

Previous Group ⌃⌥↑ Jumps the selection to the previous visible container
in the active outliner or binder, no matter what the depth. If a container
is currently hidden, it will be skipped. If you only wish to select the parent
container of a the current item, you can use the ← key.

Next Group ⌃⌥↓ Working in the same fashion as Previous Group, only se-
lecting the next visible container downward from the current position.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Binder Selection Affects ▸ These project settings toggle which split binder
sidebar clickswill be opened in. By default when you click on something in
the sidebar it will be sent to the targeted editor (so long as it is not locked).
This will adjust that behaviour so that the clicks go to a predetermined ed-
itor in all cases, depending on the choice made below. If the editor is not
split, this menuwill be deactivated as all clicks will naturally go to the only
available editor.
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When any of the following options besides “Current Editor” is selected,
the targeted header bar(s) will be accented to indicate where clicks will be
sent. Read more about the header bar (subsection 8.1.1).

This command is also available from the binder contextual menu.

Current Editor This is the default behaviour out of the box. Whichever
split you clicked in last will be targeted.

Other Editor Whichever split is not currently activewill be targeted. This
way your current work space is never disturbed by usage of the binder.

Top|Left Editor Only The top or left split (depending upon orientation)
will always take binder clicks no matter which split is active.

Bottom|Right Editor Only The bottom or right split (depending upon
orientation) will always take binder clicks no matter which split is active.

Both Editors In this special case, both editors will update whenever you
click on something in the binder. This will most often be useful when
using two different group view modes. You could have an outliner in the
left view and a Scrivenings session in the right, both showing the same area
of the binder in their own unique ways.

None Neither editor will update when using the binder. In this mode of
usage, youwill alwaysneed tomanually open items into an editor. This can
be done by using the Open commands in the right-click menu or Navigate
menu, or by drag and drop into the header bar.

Open Non-Group Items in Other This special additional option will be-
come available when the binder is set to affect one or the other editor, or
when it is set to affect both editors. When set, clicking on individual docu-
ments in the binder will send the click to the other editor. Details on how
this feature works are described in Making Splits Load by Type (subsec-
tion 12.2.4).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Outliner|Corkboard Selection Affects ▸ The project settings in this submenu
impact how splits interact with one another. When enabled, the effect is
to cause the active split to act a bit like the binder sidebar, in that whatever
you click on within it will automatically be loaded in the other split.

This behaviour can also be toggled in the footer bar with a toggle button
that rotates between the available modes in this menu (subsection 12.2.5),
and from the Touch Bar. If there is neither a split editor or a copyholder
then these optionswill be ignoreduntil they once again become applicable.
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None This is the default behaviour. Clicking on rows in the outliner or
cards in the corkboard will never automatically open those items in other
views.

Other Editor When selecting items in the corkboard or outliner view,
they will be automatically loaded into the other split view using its pre-
ferred view settings.

Copyholder If a copyholder has been attached to the current editor, you
can elect to have any individually selected items loaded within it automat-
ically, turning it into a viewer for the split.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Clear All Navigation Options Removes all settings from the active projectwin-
dow that impact navigation, as described in Clearing Navigation Settings
(section 12.5).

A.8 ProjectMenu
TheProjectmenu addresses commands and configuration options specific to the
active project, such as text formatting over-rides, custommetadata and statistics.
Ifmore than one project is open, thismenuwill make use of the foremost project
window.

New Text⌘N Creates a new text document below the current selection, or list
of documents, within the current view. When a folder is selected, the new
file will be created within the folder.13 Otherwise the new file will appear
as a sibling below the current selection, or the location of the current doc-
ument that is being edited.

When the current position for a new item is within a container that has a
default subdocument template (subsection 7.5.2) assigned to it, the menu
label will change to reflect that. E.g. if the current folder has a default
template of “InterviewTranscription”, then themenu label will read, “New
Interview Transcription”.

New Folder⌥⌘N Creates a new folder below the current selection or list of doc-
uments within the current view. Folders will always be created as a sibling
to the current selection, save for when that selection is either the Draft or
Research special root folders.

For more information on how items are placed when creating them, read
Figuring Out Where Things Will Go (section 6.3.1).

13 This behaviour is expanded to include all containers when Treat all documents with subdoc-
uments as folders is set to true, in the Behaviors: Folders & Files settings pane (subsection B.4.5).
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New From Template ▸ ⇧⌥⌘N This submenu displays all of the document tem-
plates found within the current project in hierarchical order. If no tem-
plate folder has been assigned, the menu will simply contain a message to
that effect. Read more about Document Templates (section 7.5) if you’d
like to create your own document types.

If you select a container from this menu, not only will that container be
created as a new document, but all of its child templates will be brought
along as well. You can thus easily create complex boilerplate structures of
files and folders.

Project Settings…⌥⌘ , If a setting isn’t established in the main application Set-
tings, or in one of Scrivener’s menus, then chances are it can be found
within the Project Settings panel. Section types, labels, status, custom
metadata, text formatting, auto-completion lists, the document template
folder, backdrop images and individual project backup settings and more
can all be set up here. For detailed documentation on the various tabs
within this panel, refer to Project Settings (Appendix C).

Show|Hide Project Targets⇧⌘T Toggles visibility of the floating project tar-
gets panel (subsection 20.1.1), for tracking a few simplemetrics in real-time
as you type and edit that can be left open while you work. These progress
bars themselves can also be found in the toolbar’s Quick Search tool (sec-
tion 11.5) by default.

Statistics…⇧⌥⌘S Opens a window displaying text statistics for the current
project, including the word, character and page counts for the draft, the
current binder selection or when called from a text editor, statistics for
that section of text you are editing. Refer to Statistics (subsection 20.1.3)
for more information.

Writing History… As you work in your project from one day to the next, Scriv-
ener will record your writing progress in the background and keep a num-
ber of statistics available to you within this panel. You can also export the
raw data to a CVS file, where you can then take the numbers into a spread-
sheet for further visualisation or analysis. Read more in Writing History
(subsection 20.1.4).

Show|Hide Project Keywords⇧⌘K Displays or closes the project keywords
panel (section 10.4.5); for managing all of the keywords in use by your
project or assigning them to items.

Show|Hide Project Bookmarks⇧⌘B This command has a few different results
based upon the context of its usage. Refer to Project andDocument Book-
marks (section 10.3) for full documentation on this feature.

— Project window is active: if not already shown, a list of bookmarks in a
floating window will be opened, where they can be managed or nav-
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igated to. If it is shown but you are working in the project window,
then this command brings the panel to focus. You can also open this
panel by clicking on the Bookmarks button in the toolbar and then
“tearing” the panel off by clicking and dragging from any of its bor-
ders.

— Bookmark list is active: when this command is invoked while the
bookmark list is open and active itwill have the same effect as clicking
the expansion button in the upper-right corner (marked (a) in Fig-
ure 10.9): converting the tool into a Quick Reference panel so you
can quickly review the contents of your bookmarks.

— Quick Reference panel is active: toggles whether or not the bookmarks
sidebar is visible on that window. This is the same as clicking the
bookmark icon in the window’s footer bar, marked (b) in the figure.

— Hold down the Option key when selecting this menu command, or
when using the shortcut, to go straight to a Quick Reference panel
with the bookmarks sidebar open.

Empty Trash… Permanently discards the current contents of the project Trash
folder. You will be warned before this is done, as once contents have been
deleted, there is no way to undo that action. This can also be done by
right-clicking on the trash folder itself in the binder.

If you instead wish to only delete some items from the trash, select them
from within the trash folder and use the Edit ▸Deletemenu command.

A.9 DocumentsMenu
Contains all commands relating directly to existing documents, such as duplicat-
ing and splitting, moving and copying them, converting between types, book-
marking, setting icons, cleaning up formatting, titles and synopsis, managing
snapshots of text milestones and so forth.

Snapshots ▸ This submenu provides commands tomanage a document’s snap-
shots, make new ones, and commit large-scale snapshot actions on se-
lected items. Some of these commands will be unavailable if the selection
includes items that are not text items. For more information on how to
use snapshots, see Using Snapshots (section 15.8).

Take Snapshots (of Selected Documents)⌘5 When viewing any text or
folder document, this command will take a snapshot of the current text
and store it for later use. When selecting multiple items, this command
will rename to indicate that all selected items will be independently snap-
shot.
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How to snapshot an entire folder

Selections are explicit, but you can easily select a folder and all of its
subdocuments with a single command, Edit ▸Select ▸Select with Subdoc-
uments (⌥⌘A), from an outliner or binder view, and then take the snap-
shots.

Take Titled Snapshots (of Selected Documents) ⌃⌘5 Youwill be asked to
provide a name for the snapshot before it is taken. This name will be dis-
played in the snapshot list in the inspector (section 13.6). Snapshots can be
renamed at any time.

Show Snapshots Reveals the snapshots tab in the inspector, opening the
inspector if necessary.

Show Changes ▸ When a snapshot is selected from the snapshot list, it is
possible to view the changes between that snapshot and the current docu-
ment. When two snapshots are selected, those two snapshots will be com-
pared between each other, using the older as the original. These features
are more conveniently available in the Snapshots inspector tab (subsec-
tion 13.6.4).

Comparisons can also be performed in the main editor or copyholders.
Refer to Comparing Changes in the Editors (subsection 15.8.4) for more
information.

— Compare: Toggles visibility of the change tracking mode.

— ComparisonGranularity: Use these settings to fine-tune themarkings
if what you are getting is too precise or vague to be useful. The set-
ting can be toggled on and off individually to determine how closely
changes will be tracked, with the finest level selected being the used
method. “By Paragraph” will only mark changes at the paragraph
level; “By Clause” only marks changes made at the phrase level; “By
Word” is the most detailed level of change tracking available.

— Next Change (⌃⌘]): Scrolls to the the next available difference in text.
This and the following command can also be used from the copy-
holder ormain editor, when viewing a snapshot in comparisonmode
within them.

— Previous Change (⌃⌘[): Scrolls to the previous available difference in
text.

Roll Back Rolls back to the selected snapshot, replacing the text in the
main editor. The option to snapshot the current state of the editor text,
before reverting it to the snapshot’s state, will be given in a dialogue box.
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Delete Permanently removes the selected snapshot from the disk. You
will be asked to confirm this action as it cannot be undone. You may also
delete snapshots with the Delete key, or by clicking the − button in the
Snapshots Inspector.

Show Snapshots Manager Opens the Snapshots Manager (subsec-
tion 15.8.5) window, where all snapshots in the project can be browsed
and managed from a convenient central location.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Duplicate ▸ These commands require an active selection in the binder sidebar,
corkboard or outliner view. There are two different methods you can use
to duplicate selected items.

with Subdocuments and Unique Title⌘D The item (including all of its
children if it has any) will be duplicated, and it will be provided with a
unique name automatically. If the current title ends in a hyphen + nu-
meral, Scrivener will use an incremented number in the copy. For exam-
ple is the document you are duplicating is called “scene-5”, duplicating it
would result in a file called “scene-6”. It will otherwise add “-1” to the end
of the duplicated item, starting a new sequence if further duplications are
made. This command is also available from the binder contextual menu.

without Subdocuments This is most useful when you only want to du-
plicate the container of an item by itself (such as a chapter folder), but not
all of the subdocuments within it. In this case, a unique name will not be
provided.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Split ▸ These commands require an active text editor. Provided are two meth-
ods for splitting the current document in two. In both cases, everything
below the current cursor position will be moved into a new binder item
following it. Everything above the cursor will remain unchanged in the
original item. This action cannot be undone (except via the Merge com-
mand, below). Refer to Splitting andMergingDocuments (section 15.4) for
more information.

at Selection⌥⌘K Split the new document off from the current one, us-
ing all text after the current caret position (this can even split a paragraph
in two). In cases where text has been selected, the caret position will be
considered as the start of the selection range.

with Selection as Title⇧⌥⌘K In all details this command works identi-
cally as the above, but in this case the currently selected text will be used to
title the new document that is created, rather than leaving the title empty.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Merge⇧⌘M This command requires a selection of two or more text or folder
items in the binder sidebar, corkboard or outliner. In opposition to split-
ting (above), merging will combine the selected text items together into a
single document. This action cannot be undone (except via the split com-
mand).

In those fields where combination makes sense, such as notes and key-
words, all of the documents will be used to create a combined result. Refer
to Splitting and Merging Documents (section 15.4) for more information.

New Folder From Selection⌥⌘G Takes one ormore selected items and groups
them into a new folder. Youwill be given the option to name that folder af-
ter invoking the command. When used from a selection of index cards on
the corkboard, the selected cards will “disappear” from the current cork-
board into the newly created folder card. You can double-click on the new
folder’s icon in its index card to visit them. This command is also available
from the binder contextual menu.

Ungroup⌥⌘U This command onlyworks when a single container is selected in
the binder sidebar, corkboard or outliner views. In opposition to grouping,
ungroup will move the contents of the selected container up one level so
that they become siblings of that container. This action will not change
or move the original container, allowing you to move the items back in,
if it was made in error. This command is also available from the binder
contextual menu.

The following movement, copying and collection assignment commands op-
erate on the document being edited in the active editor, the active subsection
within a Scrivenings session, or for bulk items, in the binder sidebar, corkboard
and outliner views.

Move To ▸ Will move the selected items into the target that you choose from
this binder item selection submenu.

The upper portion of this menu, labelled “Favorites”, will track the most
commonly and recently used targets in this project. When a new item
is used, it will be given a priority listing in this area, but will fall off the
list more quickly than other more frequently used targets, if seldom used
again. This command is also available from the binder contextual menu.

Move To “X” Again⌥⌘T This convenience command will appear if during the
current session you have moved an item using the “Move To” submenu
above it. It will target last location you used with this command, making
it easy to repeatedly send documents to the same location. This command
is also available from the binder contextual menu.
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Copy To ▸ Operating in a very similar fashion to theDocuments ▸MoveTo ▸ sub-
menu, the selected documents (and all child items beneath them) will be
copied to the target location, leaving the originals where they were. This
command is also available from the binder contextual menu.

If you would prefer to use drag and drop with the mouse to perform this
action, you will need to enable that behaviour in the Behaviors: Drag-
ging &Dropping settings pane (subsection B.4.4). You can then hold down
the Option key while dragging to create copies of the selected items in the
dropped location.

Copy To Project ▸ Selected items can be copied to other open Scrivener
projects. From this submenu, select the project you wish to copy to, and
then from within its menu, the location within its binder. This command
is also available from the binder contextual menu.

Copy To “X” Project Again⇧⌥⌘C This convenience command will appear if
during the current session you have copied an item using the “Copy to
Project” submenu above. The selected items will be copied to the same
binder locationwith the last project you targetedwith the command. This
command is also available from the binder contextual menu.

Add to Collection ▸ Themenuwill display a list of all standard collections (sub-
section 10.2.2) in the project.14 The currently selected items will all be
added to the collection you choose from this submenu. This command
is also available from the binder contextual menu.

At the top of this menu (or as a sole entry if there are no standard collec-
tions yet in the project) will be a “New Collection” command. Using this
option will reveal the collection tab list above the binder, where the name
of the new collection can be typed in. This can also be done by clicking the
+ button in the collection tab list header bar when it is open.

Add to|Remove from Project Bookmarks The selected items will be appended
to the project bookmarks (section 10.3) list if they are not already listed
within it. If the entire selection is already listed then the “Add to Project
Bookmarks” command will be disabled. Use the opposing command, “Re-
move from Project Bookmarks” to remove all selected items from the list.

When the selection is mixed, containing some items that are bookmarked
and some that are not, these commands will still be made available. This
way you needn’t know for sure if every time you selected is actually on
the list or not. This command is also available from the binder contextual
menu.

14 It is not possible to add itemsmanually to search collections, which are dynamically generated.
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Convert ▸ This submenu provides tools for converting the document’s type,
scriptwriting mode, or text formatting.

Text to Default Formatting… Resets the text of the selected files and
folders (or the text in the active editor session, including multiple docu-
ments in Scrivenings) to the default formatting used for new files. This
default is established either globally in the Editing: Formatting settings
pane (subsection B.3.2), or on a per-project basis in project settings (sec-
tion C.5). You may also wish to read more about Resetting Formatting
(subsection 15.7.5) in general.

Script Format… Usefulwhen youneed to switch fromone scripting stan-
dard to another. Note that if all you wish to do is change the current
documentwritingmode, you should use Format ▸Scriptwriting ▸ScriptMode
(⌘8) to do so. This function is strictly for converting between pre-existing
scripts to bring them up to spec. For more information on scriptwriting,
see Scriptwriting (chapter 19).

to File|Folder Converts the selected items to folders or files respectively.
Note that these two document types are very similar in Scrivener, so this
tool makes it easy to change your mind later about whether or not some-
thing should be a folder or a file. If the selection contains amix of types, or
items that are neither files nor folders, then the commandwill be disabled.
This command is also available from the binder contextual menu.

Web and PDF files to Text Activates when viewing a WebArchive or PDF
item. Scours the file for its text content and create a rich text file from it
that is editable and considered a text document from that point onward.
Note this cannot be undone. Create a duplicate of the original beforehand
if you wish to retain a copy with its full layout.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Auto-Fill ▸ These commands canbeuseful formanaging the titles and synopses
of files in conjunction with text found or selected in the main editor.

Set Selected Text as Title⇧⌥⌘T When text has been selected in themain
editor the title for the current documentwill be set to that selection. If you
are splitting up a longer document into a formatmore useful within Scriv-
ener, consider using the Documents ▸Split ▸with Selection as Title (⇧⌥⌘K)
menu command instead.

Clear Titles Removes the titles fromall selected documents, leaving them
blank. This has the effect of causing them to print the first fewwords from
either the synopsis or main text content (in that order of precedence) in
various contexts such as the binder sidebar.
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Set Synopsis fromMain Text|Selection⇧⌥⌘ I This command has two
modes of operation:

— Set Synopses from Main Text: when the active selection is a quantity
of files in a group view, such as the corkboard or binder, each item
will have its synopsis updated to use the first few lines of text in that
folder or file (it will be left blank if there is no text). This command
also works on the current document (or chunk within a Scrivening
session) if a text editor is active.

— Set Synopsis from Selection: if text has been selected within the main
editor, then this alternate menu command will appear. The synopsis
will be set to the selected text alone rather than using the first few
lines from the top of the section. In Scriveningsmode, if the selection
crosses the boundary of sections, the file the selection ends within
will be affected by the command, but the entire selection will be used
for the synopsis, even though it may come from several files.

Send Synopsis to Main Text Useful if you’ve done a little pre-
composition in Outliner or Corkboard mode, and now wish to push
those ideas into the manuscript text. When used, the contents of the
selected items’ synopses fields will be appended to the end of the main
text for each item, respectively.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Change Alias Source… If the selected binder item is an alias to some other file
on your disk, this command will allow you to point it to a different file on
the disk. This will most often be useful if the original file has gonemissing
and has been restored.

Replace Media File… When anything other than a native folder or file has been
selected in the binder, this command allows you to swap out the stored
data with another file on your hard drive. A practical example where this
could be useful is if you have a cover image for your book in the binder
and you receive an updated copy from the artist. The new cover would be
imported, replacing the old image within the project.

Default Template for Subdocuments ▸ Select any existing group in the binder
and use this command to make it so that new files created within that
group will use the selected document template instead of the default text
file type. To revert its behaviour to default, select the “Text” choice at the
top of this submenu. In projects lacking templates, this menu will simply
offer “Text” as the sole choice. Refer to Default Subdocument Template
(subsection 7.5.2) for further information.
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Change Icon ▸ This submenu displays all built-in and any custom icons added
to the project or installed on yourmachine. Select items in any group view
and then choose an icon from this menu to change their icons. When
used from the editor or copyholder, the active document will have its
icon changed. This command is also available from the binder contextual
menu.

Reset Icon to Default Select this option to remove a custom icon from
the selected documents, or the active document from the current editor
or copyholder.

Icon from Text… Using this tool, you can take any text and turn it into an
icon. This will work best with single characters, such as Unicode symbols
or Emoji. Refer to Icons fromOther Sources (section 7.4.1). This command
will automatically bring up the Mac’s Emoji & Symbols utility. If you need
to open it again, you can click the “smiley face” button (Figure A.4).

Figure A.4 Adding the “Paperclip” Emoji as an icon.

Manage Custom Icons… Opens the Manage Icons dialogue, where you
can add or remove your own custom icons. You can manage both icons
loaded into the project as well as those installed on the system from here.
Formore information onmanaging and creating icons, read Custom Icons
(section 7.4).

Text Based Icons ▸ This submenu will list any text-based (such as Emoji)
icons that have been found within the project, or that have been used in
the current session. As you add or remove such icons from the project, this
menu will list it so you can conveniently add them to new items, even in
other open projects.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Move to Trash⌘Delete Moves items selected in the binder sidebar, corkboard
or outliner to the project’s Trash folder. Scrivener works in the same fash-
ion that the Finder does, in that files are not deleted permanently until
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you empty the Trash. Periodically, you can review the contents of your
project’s Trash folder and empty it to clear up space, using the Projects/
Empty Trash… command. This command is also available from the binder
contextual menu.

A.10 FormatMenu
The Formatmenu contains all commands that deal with formatting text in views
where formatting is allowed. It contains all of the usual commands you would
expect to find for changing the font, setting line spacing, creating tables and lists
and controlling the ruler. Additional tools related to formatting will be found
here, such as revision markings, scriptwriting tools and style commands. Some
text contexts (such as theDocumentNotes sidebar) only use a subset of the com-
mands available in this menu.

Font ▸ All commands relating to direct character formatting will be found in
this section of the menu. This includes basic settings like bold, italics and
adjusting the size, as well asmore advanced kerning and other typographic
features. Use these settings to establish the formatting for styles ormodify
text on the fly. A portion of these tools can also be found in the Format Bar
(subsection 15.7.2).

Show Fonts⌘T Access the standard system font palette. Use this to
change the font settings you type in from that point forward, or alter the
existing font of a selected range of text.

Bold/Italic⌘B &⌘ I These basic formatting commands work by either
modifying the cursor attributes if there is no selection, or toggling the se-
lected text between the various styles. Note that not all fonts support bold
and italics. If it appears that one of these is not working, check your font
for the proper typefaces.

Underline ▸ ⌘U This submenu provides several underlining styles. The
default command with the shortcut is what most people will wish to use
when underscoring text. Use the “By Word” option to omit underscoring
across whitespace characters.

Strikethrough⇧⌘_ Crosses out the text you have selected. When used
in conjunction with marking revisions (section 18.6), the current revision
level colour will be used for the strikeout. Strikethrough can also be ap-
plied to text in PDF documents.

More than cosmetic, struck-through text can be easily deleted at a later
time via the Edit ▸TextTidying ▸DeleteStruck-ThroughTextmenu command,
and can be dynamically stricken from the output with the Delete struck-
through text setting in the compile overview screen, under general op-
tions (subsection 23.4.3).
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Outline Changes the style of the font to outlined instead of filled. This
will be more useful with larger, heading size fonts with heavier weights.

Bigger⌘+ Increases the size of the font by a small amount.

Smaller⌘- Decreases the size of the font by a small amount.

Character Spacing ▸ Adjust the kerning of the selected text, or between
the two characters around the cursor. The “Use Default” selection allows
the font to choose the kerning based on the designer’s metrics (this will
nearly always be the best choice), while “Use None” disables the font’s
built-in kerning. It would be advantageous to set keyboard shortcuts to the
“Tighten” and “Loosen” commands if you intend to use these frequently.

Ligature ▸ If the font family supports typographic ligatures, they can be
enabled or disabled here. Most fonts default to using standard ligatures (ff,
fl, fi and so on). Some include rare ligatures, which may be enabled by the
“All” setting. It will usually be better to use the Format ▸Show Fonts panel,
click on the button and open the “Typography” panel, for more precise
and extensive options.

Baseline ▸ Adjust the baseline height of the text, most commonly referred
to as superscripting and subscripting. In addition to jumping straight to
those presets with respective commands, you can also incrementally raise
and lower the baseline. “Use Default” will reset the baseline to the normal.

Character Shape ▸ If the font family supports typographic shape alter-
nates, such as old style numerals and traditional forms, they may be se-
lected here.

Copy Font⌥⌘C Copies the character attributes from the current cursor
position. This includes all forms of inline formatting (such as colour or
strikethrough).

Paste Font⌥⌘V Use this command to apply the character attributes from
a clipboard, copied from any of the copy formatting commands, to other
selections of text.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Paragraph ▸ Displays the standard macOS Text submenu, which contains use-
ful tools for controlling the paragraph-level formatting of your text. Para-
graph alignment and spacing can also be controlled with the the Format
Bar (subsection 15.7.2), and tab stops and indents with The Ruler (subsec-
tion 15.7.1).

Align Left⌘{ Sets alignment on the selected paragraphs to flush left (or
ragged right, as it is sometimes referred to).
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Center⌘ | Centres the alignment of the current paragraph to the current
left and right indent offsets.

Justify⇧⌥⌘\ Sets alignment on the selected paragraphs to fully justified,
or flush left and right.

Align Right⌘} Sets alignment on the selected paragraphs to flush right
(or ragged left).

Tabs and Indents… Brings up a panel that can be used tomanage tabs and
set paragraph indenting using precisemeasurements, rather thanwith the
visual ruler. For more information on using this panel, refer to The Tabs
and Indents Tool (section 15.7.1).

Increase/Decrease Indents ▸ The commands in this submenu all operate
on the currently selected paragraphs, and are provided primarily so that
you can supply custom keyboard shortcuts to the most frequently used
commands. They incrementally adjust the three different indent aspects
of a paragraph, which can all alternatively be adjusted using the sliders on
the ruler (⌘R).

The amount of increment used depends on the unit of measurement set
in the Editing: Options settings pane (subsection B.3.1), with the Ruler
Units setting. All methods will adjust indentation in increments of 0.5cm;
0.25in; 1.5 picas and 18 points, relative to any existing indent settings on
the paragraph.

— Indents ⌃⌘→ & ←: Works as a simple offset, where all left-side in-
dent settings aremoved left or right uniformly. E.g. a hanging indent
paragraph will remain hanging, but with both indent settings moved
one way or another.

This command is synonymous with the Edit ▸Move ▸Move Left and
Move Right commands.

— First Line Indent ⌃⌥⌘→&←: Only the first line will have its indent in-
creased or decreased. When the rest of the paragraph is indented it is
possible to decrease the first line indent beyond the rest of the para-
graph, forming a hanging indent (though in general it will be easier
to use the next command to create these).

— Hanging Indent: The main body of the paragraph will have its indent
level adjusted while leaving the first line indent alone. If the para-
graph is already indented then it may be possible to decrease the in-
dent level beyond the first line, resulting in a normal looking para-
graph.

— Right Indent: The right-hand indent of the paragraph will be in-
creased or decreased. It is important to be aware of the fact that a
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right indent is measured from the left of the page, not the right. In
other words if youmove the right indent inward 2cm, the indent set-
ting might be more like 16.5cm (from the left), which could have im-
plications if the margins or paper size change.

Remove All Tab Stops A convenience tool to delete all tab stops in the
current paragraph or selection.

Line and Paragraph Spacing… Brings up a handy tool for setting para-
graph and line spacing attributes in the selected or current paragraphs.
You can also access this tool from the Format Bar (subsection 15.7.2).

Writing Direction Toggle between Left-to-Right and Right-to-Left writ-
ing styles. This will usually be automatically done for you when changing
keyboard input modes.

Keep with Next Inserts formatting on the current paragraph that will at-
tempt to keep it glued with the next paragraph, so that they will not be-
come separated by a naturally occurring page break. Select Yes to enable
this characteristic for the selected paragraphs.

The Can Split Across Pages option is dependent upon Yes being selected.
This setting will allow the designated paragraph to itself be split across
pages, rather than moving the whole paragraph to the next page. Use
this setting for cases where the paragraphs you wish to keep together are
longer, such as a block quote and its attribution line.

HTMLHeader Level This will only be of interest in conjunction with
styles in ebook and Web publishing, as well as the Markdown-based for-
mats.15 Theywill set the heading level for the selected text in these outputs
when compiling, andwill be saved into any styles you create from that text.
Unless you intend to use headings directly in your text, you may not even
have use for these commands until you are actually setting up styles inos
the Styles compile format pane itself (section 24.5).

Use of these commands will have no visual effect on the text, they only
determine what HTML level the text will be set to.

Copy Paragraph Attributes ⌃⌘C Stores the ruler and paragraph format
settings from the current paragraph. These settings can be applied into
any rich text view, even compile settings panels that take formatted text.

Paste Paragraph Attributes ⌃⌘V Applies stored ruler and paragraph set-
tings to the selected or current paragraphs.

15 For the latter case, one must have the Convert rich text to MultiMarkdown option enabled,
in the General Options tab of the compile overview screen (subsection 23.4.3).
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Style ▸ Styles are a way of assigning meaning to your text, and optionally for-
matting or other visual cues. Once text has been assigned to a style it will
stay in sync with any future updates made to that style’s settings. Read
more about Styles and Stylesheets (chapter 17).

New Style From Selection… Starts the creation process for a new style,
using the formatting of the selected text, or from the paragraph the cursor
is located within. Read more on Creating New Styles (subsection 17.3.2).

Redefine Style From Selection ▸ Takes the formatting from the currently
selected text or paragraph and updates the designated style you choose
from this submenu. Read more on redefining a style (subsection 17.3.3).

Delete Style ▸ Deletes the style you choose from this submenu. The for-
matting applied to text that is assigned to this style will be left alone, but
the style assignment itself will be stripped from all text throughout the
project.

Show|Hide Styles Panel ⌃S Toggles thedisplay of thefloating styles panel.
If you use styles frequently you may wish to keep this open off to the side,
so you can see at a glance which styles are applied to the text you are work-
ing with, and apply styles to text with a single click. You can also easily
modify and manage your styles from within this pane. Refer to The Styles
Panel (subsection 17.2.3) for further documentation on this feature.

Show Styles Menu⇧⌘Y Reveals the “Apply Style” menu directly on your
screen without having to go to a separate menu or format bar to access
them. It is not accessible when the document is in script writing mode,
as the shortcut will be used for the Format ▸Scriptwriting ▸Show Script Ele-
mentsMenu command.

Set Default Formatting… Loads the Project Settings: Formatting pane
(section C.5), where you set what unstyled text should look like via the
Main text formatting area.

Import Styles… Brings up a file selection dialogue box. Use this to select
the Scrivener project from which you want to copy its stylesheet. Refer to
Copying Stylesheets Between Projects (section 17.5) for further detail on
how to manage merging when importing styles.

No Style⌥⌘0 Depending upon the context, this command has different
effects. When used upon selected text the styling from that selection will
be stripped out, returning it to either the look of the paragraph style be-
neath it, or to standard unstyled text. When used without a selection
within a paragraph that has a paragraph style applied to it, the paragraph
style will be simply removed from the entire line.
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When used while typing, the effect is to cease typing in the style that was
being used up until that point. If used at the conclusion of a range of text
in a character style, you will return to whatever paragraph style was in use
underneath that, or to no style at all, depending on which is applicable.

The remainder of this menu will list the paragraph and character styles available
in this project. Use of them will apply the chosen style to the selected text, or alter the
formatting of the cursor.
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Table ▸ Use the “Table…” command to insert a starter table (more easily ac-
cess with the Insert ▸Table… command). The remaining commands in this
menu are documented in the tables contextual menu (section 15.3.2) sec-
tion, and of course are also available when right-clicking directly inside of
a table in the editor.

Lists ▸ Supplies a few basic list formats, along with advanced controls for bul-
let and enumerated list management, with the “Custom List…” command.
The list creation aspects of this menu are also available when clicking on
the list button in the Format Bar (subsection 15.7.2). You can cycle through
the various list styles from any existing list in the editor with the following
commands:

— Next List Style (⌥⌘→): selects the next list style from the currently
selected style.

— Previous List Style (⌥⌘←): selects the previous list style from the cur-
rently selected style.

Scriptwriting ▸ Although Scrivener is not a dedicated script writing applica-
tion such as Final Draft, Fade In Pro orWriterDuet, the scriptwriting tools
make it relatively straightforward to create first drafts which can be later
fine-tuned in these and similar applications. For full documentation on
this feature, refer to Scriptwriting (chapter 19).

Script Mode (Format)⌘8 Toggles the current scriptingmode on or off for
the selected documents in any group viewor the binder sidebar, and for the
current document in themain editor—or all documentswithin the current
Scrivenings session. Toggling script mode on and off only changes text
input, not any aspects of text already been written. You can thus switch
to normal prose and then back again, making this a great shortcut to learn
when writing treatments.

Script Settings… Brings up the script settings window, where all aspects
of the project’s script settings can be modified, and new scripts and ele-
ments can be created from scratch. Read more about this tool in Creating
Your Own Script Formats (section 19.7).
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Re-capitalize Script Any elements defined by the current script settings
to be capitalised will be converted to all-cap text if they are not already.
This will mainly be of use when importing text that isn’t already capi-
talised.

Change Element To Converts the selected text to a different scripting el-
ement. If the previous element set the text to all-caps you will need to
fix the text yourself, making use of the tools in the Edit ▸Transformations ▸
submenu.

Show Script Elements Menu⇧⌘Y Reveals the script element selection
menu, also available by clicking in the lower right corner of the editor
footer bar. Single-letter shortcut keys can then be used to select an in-
dividual element, if the script settings have been configured to use them.
For example in our built-in screenplay script, the “C” key will switch the
line to Character mode.

This command will only be available when script writing mode is enabled
in the active editor. The shortcut will otherwise bring up the styles menu.

The remainder of this menu will list all of the scripting styles installed on your com-
puter, along with a number of built-in styles that ship with Scrivener. For further
information, refer to Formatting a Script in Scrivener (section 19.1).
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Color…⇧⌘C Toggles the visibility of the colour selection palette, which can be
used to set the colour of selected text. When no selection is found, it will
change the typing colour.

Note that Scrivener uses this palette for all cases where a custom colour
can be set by you, but when invoked with a text editor active, the effect
will be to colour the selected text or the cursor attributes.

Highlight ▸ The highlight menu lets you place a background highlight behind
the selected text, much like using a highlighter marker on paper. In ad-
dition to the five provided presets, this menu also displays any favourite
colours that have been set on your system. For more information on how
to use highlights, see Text Colour and Highlights (section 18.5).

Highlight Text⇧⌘H Highlights the selected text, or alters the cursor’s at-
tributes, using whatever colour you used last. If the text is already high-
lighted and you are using the same highlight colour then the effect will be
to remove highlighting from that text. Otherwise the text highlight will
be switched to the new colour. Highlighting (in basic yellow) can also be
applied to text in PDF files.

Remove Color Strips all highlighting that has been applied to the selected
text.
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Show Colors… This choice will appear at the very bottom of the list of
colours. Use this to select a custom colour using the standard colour
picker. If you right-click the highlight tool in the format bar, you will be
provided with a number of handy presets (subsection 15.7.2).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Revision Mode ▸ Revision modes force anything you type to be displayed in
a designated colour until you disable the revision mode (it also impacts
strike-outs). Select one of the five revision levels in this menu to enable
the mode, and again to toggle it off. For more information, refer to Mark-
ing Revisions (section 18.6).

Mark Revised With text selected and a revision level in use, this com-
mand will mark the selected text range with the current revision colour.

Remove Current Revision Color This command is only available when
one of the revision levels is active. It will strip the current level from the
active editing session, leaving the rest alone.

Remove (All) Revisions Indiscriminately removes all five revision level
colours from the active editing session. When text has been selected,
the command will read “Remove Revisions” and only strip markings from
within the selection.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Copy Formatting ⌃⌥⌘C Store both paragraph and character attributes of the
selected text’s formatting, for later application to other texts.

Paste Formatting ⌃⌥⌘V Pastes formatting stored with any of the following
copy commands:

— Format ▸Font ▸Copy Font

— Format ▸Paragraph ▸Copy Paragraph Attributes

— Format ▸Copy Formatting

The pasted formatting will apply to the selected text. Paragraph format-
ting alone will be pasted into the current paragraph when no text is se-
lected.

Preserve Formatting This is a legacy feature from older versions of Scrivener.
It will protect all formatting found within the range of text you apply it to,
when compiling through formats that would otherwise change that text.
Most of this capability is now provided through the stylesheet system, but
there are still a few niche special-purpose uses for this command. Read
more about them in Preserve Formatting (subsection 15.7.6).
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Make Formatting Default This will make the currently-selected formatting in
the editor the default formatting for all new documents, without other-
wise going through and changing these settings in the Editing: Format-
ting Setting tab (subsectionB.3.2) (or the Project Settings: Formatting pane
(section C.5) if the project is overriding the application defaults). Upon use
of the command you will be asked whether you want the attributes of the
selected text to be used in your global application Settings or the project
settings specifically. In the latter case, if you have not already enabled the
option to override formatting in this project it will be set for you.

As always, this command only impacts text typed into newly created doc-
uments. It will not destroy formatting in existing files and projects. If you
wish to do that yourself, you canwith theDocuments ▸Convert ▸Text toDe-
fault Formatting…menu command (subsection 15.7.5).

A.11 WindowMenu
TheWindowmenu contains some standard commands for controllingwindows,
tabs and panels. It concludes with a list of all open projects.

Minimize⌘M Minimises the window to the Dock. Hold down the Option key
to minimise all.

Zoom ⌃⌘- Zooms the window in or out (the same as the green button in the
top-left of the window). Scrivener will try to zoom intelligently to best
fit the contents of the window, taking into account your preferred editor
width.

Zoom to Fit Screen ⌃⌘= Zooms the window so that it fully fills the screen, ex-
cluding the Dock and menu bar, if visible.

Show Previous Tab⇧⌃Tab Scrivener supports macOS tabbed window features.
Projects can be combined into the same window as tabs, and Quick Refer-
ence panels can be combined into their own window. The following three
commandswill be disabled unless youhavemergedwindows andhave tabs
in that active view.

This command selects the previous (left) tab in the current window.

Show Next Tab Selects the next (right) tab in the current window.

Move Tab to NewWindow Separate the current tab back out to its own win-
dow.

Merge All Windows Merges all open windows of a like kind (project vs Quick
Reference) into a single window. If you wish to only merge select
project windows together, first open the tab bar for each project with the
View ▸ShowTab Barmenu command, and then drag and drop the tab from
one project into the other’s tab bar.
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Layouts ▸ This submenu is populated by the saved layouts you’ve created, along
with a few built-in layouts to get your started. Layouts provide an easy
mechanism for rapidly converting your project window to different work-
flows, depending onwhat you are currently doing. Readmore about Saved
Layouts (section 12.3).

Manage Layouts…⇧⌘) Opens or activates the Layouts panel, where you
can save, update, export/import or recall project window view settings.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Float Window Toggles whether or not the current project window should
“float” above all other windows. This will make it visible at all times, even
when switching to other programs.

Float Quick Reference Panels ⌃⌘Q Toggles whether or not Quick Reference
panels should float over all project windows for this specific project. This
setting impacts all Quick Reference panels associated with the current
project window. Panels from another open project will behave in accor-
dance with that project’s settings.

Show|Hide Scratchpad⇧⌘Return Displays or closes the floating Scratchpad
Panel (section 9.4), useful for collecting information while using other ap-
plications.

Bring All to Front Brings all Scrivener windows to the front of other applica-
tion windows. Hold down the Option key to change to Arrange in Front.

The next portion of the menu only appears if the currently active project has
open Quick Reference panels. They will each be listed in this section by name.

Close All Close all open Quick Reference panels for the current project.

Closed Quick Reference Panels During a single session, any Quick Reference
panels that have been closed will be saved into this submenu, giving you
quick access to them if you need to re-open them.

The rest of this menu will be populated by all of the windows (excluding pan-
els, like the Project Keywords window) that are currently open in Scrivener. Se-
lecting from this list will bring that window to the front.

A.12 HelpMenu
The Help menu provides access to a menu search capability (which can be
brought up from the keyboard with ⇧⌘?), as well as useful tools and links for
learning Scrivener or getting in touch with us if you require technical support.
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Scrivener Manual A quick link to the PDF that you are likely reading this from.
The version that ships with Scrivener will be kept as up to date as possible,
but newer revisions might also be available on the web site’s support page.

Interactive Tutorial… If you have not yet gone through the tutorial (you
should!) this menu command will create a project designed to walk you
through the process of learning the basics of Scrivener. You will be given
the option of where to save it, and from that point on you can load it like
an ordinary project. If you have already created the tutorial project, you
can use this menu command to quickly load it again, so long as it hasn’t
been deleted or moved.

Reset Tutorial Use this menu command to reset an existing tutorial project to
its factory state. It can be used while the tutorial is open or closed. In the
former case, the old tutorial project will be closed and trashed, and you
will then be guided through the process of creating a new one. If you use
this command while the tutorial project is closed, it will merely trash the
tutorial project and leave it up to you when to create a fresh copy.

Video Tutorials A handy link to our video web page.

List of All Placeholders… There aremany placeholders you can use with Scriv-
ener, and this will provide a full listing of them in a floating window. You
can copy and paste placeholders from this window into your project (or
compile settings) as needed.

Support Jump to our support web page. Here you can download the latest copy
of the PDF (as well as the project used to create it), find contact email ad-
dresses, links to our forums, video tutorials, webinars, and more.

User Forums Jump to the official Scrivener forums where you can meet other
authors around the world using Scrivener, share tips, report bugs, request
tech support, or have a cup of latte in our off topic section.

Release Notes Jump to the official release notes web page on the web site.

Literature & Latte Home Jump to our home page, where you will find access
to everything else we offer on our web site.

Scrivener Home Jump to themain Scrivenerweb page, where youwill find use-
ful download links for updates, links to share Scrivener with Twitter and
Facebook, and more.

Keep Up to Date… Presents a form which you can use to submit your email
address and name to subscribe to our newsletter. This is a low volume
list that we use to send out important updates and news. Please take care
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to whitelist “litereatureandlatte.com” in your spam filter, prior to submit-
ting this form, as you will be sent a confirmation email which must be re-
sponded to before youwill be subscribed. You can also click on the Twitter
and Facebook buttons to visit our official social pages.

Privacy Notice: Your email address will registered with Campaign Moni-
tor, whose services we use for sending out newsletters. Your address will
otherwise never be shared with third-parties or sold to marketing lists.

Purchase Scrivener… Jump to ourweb store, where you can purchase Scrivener
through our secure vendor (Paddle) and the other software ormaterials we
have for sale.
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macOS 12 and older refers to Settings as Preferences

WithmacOS 13.0, Apple changed the global menu command from “Pref-
erences” to “Settings”. Thismanual will now to refer to settings using the
current terminology. For older systems, the menu command for prefer-
ences is Scrivener ▸Preferences….

Like most applications, Scrivener installs in a “ready to use” state. The default
Settings have all been carefully selected to present a cohesive and useful writing
environment, and most of this manual will presume you are using them. That
said, we know that a creative environment should bend to your working habits
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as much as possible, and so there are a great many ways to tweak the look and
feel of the interface.
This appendix will go over every setting and point you to any further discus-

sions elsewhere in the manual if necessary.
Settings take effect as soon as you change them. If your screen is large enough,

you can leave the Settings open to the side and tweak things until you get them
looking and acting the way you want.
Beyond global application Settings, each project can be configured with fur-

ther settings, which will be documented in Project Settings (Appendix C). Many
project view settings are also exclusively set using the menus, or with buttons
located within the project window itself.1 These kinds of settings are rarely al-
tered globally, but you can always create or modify your own project templates
to achieve a preferred starting point for your new projects (section 5.4). Given
how these sorts of settings are by nature scattered about contextually, they will
be documented alongside the discussions on the features they pertain to, rather
than in one central area.

Get me back to the defaults!
Feel free to experiment. Along the bottom of the Setting window you’ll
find a button labelledDefaults. This will perform a “factory reset”, return-
ing all settings to their default states. This cannot be undone, but you
will be warned after clicking the button and given a chance to cancel—
you can also save your settings for later retrieval (subsection B.1.1). Most
tutorials, books on Scrivener and even areas of this manual will assume
default settings, so it can be a good idea to use themwhile you are follow-
ing a guide. Many Settings can fundamentally change how the software
works.

B.1 SettingsOrganisation and
Management

For ease in finding documentation on the setting you are looking for, this ap-
pendix will be organised in the same manner as the Settings panel itself. To get
started, use the Scrivener ▸Settings…menu command (⌘ ,).
Along the top of the window are the major categories of Settings (Figure B.1).

When we refer to settings panes by name, it will be by one of these sections,
which you can access by clicking on the icon. In the figure, the “Editing settings
pane” is selected. This is then broken down further into individual tabs—in this
case the “Options” tab is selected. Wewould refer to this as the “Editing: Options

1 A good example is whether or not label colours are displayed along the side of index cards on
the corkboard. By default they are, but you can turn them off for a project and it will remember
that setting.
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Figure B.1 The “Editing” category is divided into three sections as tabs.

tab”, wherein one can change such things as theDefault text zoom setting, used
in most places where text can be edited.

Figure B.2 The “Appearance” pane uses up to three levels of organisation.

In Figure B.2 we have a more complex layout, where the major section chosen
along the top (a) is “Appearance”, which has many subsections listed along the
left (b). The contents of these subsections will be displayed to the right, and can
sometimes be broken down further into tabs (c). We would refer to this as the
“Appearance: Outliner: Fonts” tab.
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B.1.1 Settings Presets and Themes
Along the bottom left edge of the Settingwindow youwill find aManage… button
with a dropdown menu containing several options available for organising or
backing up your settings, as well as access to any presets you have installed. This
can be particularly useful if you work on more than one computer, and in the
case of themes, to switch up your working environments between favourite sets
of colours and even fonts.

Load/Save Settings as Preset Presets are a convenient way to store different
Setting sets. In cases where you need to use varied settings for different
projects, this will make it easy to switch sets on the fly. Use the Save Set-
tings as Preset… option to save all current Settings into a preset under the
name you provide. Once saved, this preset will be available from the Load
Settings from Preset submenu.

If you wish to update an existing preset: make any changes you see fit,
then use the save command, specifying the name of the preset you wish to
overwrite. You will be asked for confirmation before the old preset file is
overwritten.

Delete Preset The Setting preset you choose from this submenu will be deleted
from your support folder. This cannot be undone, so you will need to con-
firm your decision.

Load/Save Settings from File… Save your Settings to an external file for either
backup purposes, or to synchronise your settings between multiple com-
puters. Settings can be loaded from these files, replacing all current set-
tings.

Load/Save Theme Themes differ fromSetting presets in that they only save and
load appearance settings, such as interface colours, corkboard and outliner
appearance and fonts. The types of settings that will be saved into the
theme can be chosen in the Save Theme dialogue.

⟨macOS10.14+⟩When selecting a theme designed for Dark or LightMode,
you will be asked if you wish to apply the theme and switch Scrivener to
that mode of appearance, if relevant. Dark Mode themes will be indicated
with a moon icon to the left of their name.

Themes can be most easily loaded from the main Scrivener ▸Theme ▸ sub-
menu.

Delete Theme The selected appearance theme will be deleted from your sup-
port folder. This cannot be undone, so you will need to confirm your de-
cision.

Load/Save Theme from File… Load a theme from a file you have stored on your
machine. This will not install the theme into the menus above, but rather
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simply apply its settings to your current Settings. Use the Save Theme…
command if you wish to save them for future use.

Themes as files can be useful for synchronising appearance settings be-
tween computers, without changing all of their Settings, sharing your
theme settings with others, or loading theme settings you’ve downloaded
from the Internet.

Return to chapter ⤴

B.2 General

Figure B.3 The General settings pane

General Settings govern the application’s basic behaviour; its integration with
other programs, whether it should check for updates, designating global fold-
ers (such as the scratchpad) and how appending or merging text with existing
documents should be performed.

B.2.1 Startup
Reopen projects that were open on quit When launched, projects that were

left open when you last quit will be automatically reopened, bringing you
straight back to what you were last working on. This behaviour does not
apply when launching the software by loading a specific project from your
file manager.

Hold down the Shift keywhile launching Scrivener to temporarily suppress
this behaviour and open the software without any projects opened.

Show template chooser when there are no projects open Toggles the au-
tomatic display of the start panel, for the creation of new projects
(subsection 5.1.1), when all project windows have been closed, or if the
software loads without any projects to open

Reopen Quick Reference panels when opening projects Ordinarily, Quick
Reference panels (section 12.6) are session based—when their related
project is closed they will not be reopened the next time you load the
project. While enabled, all projects will remember any Quick Reference
panels left open and reopen them automatically when the project is
loaded.
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Automatically check for updates If this is enabled the softwarewill periodically
check the website to see if there is a newer version available and, if so, will
ask you if you want to update. Note that if you do not have this enabled,
you can still check for updates yourself by using the Scrivener ▸Check for
Updates… menu command. The dropdown menu beside this option gov-
erns how frequently Scrivener will check for new versions.

B.2.2 Saving
Auto-save after n second(s) of inactivity Scrivener automatically saves changes

made to projects as you work, but so that it is not constantly saving—and
to avoid any slowdown and interruption to your work that might cause—
it will wait until you stop interacting with the program for more than two
seconds (by default). Adjust this if the two second default conflicts with
your natural rest-work cycle and causes halting when you try to resume
typing.

If you increase the period significantly, so that it rarely triggers, be sure
to use File ▸Save regularly to keep your work saved. Scrivener will always
auto-save when you close a project.

Take snapshots of changed text documents on manual save This option will
cause the project to snapshot all text items (section 15.8) that have had their
main text content altered since the last time you saved, with the File ▸Save
(⌘S) command, within the current session. Auto-save will never trigger
this behaviour, nor will closing the project.

Snapshots that have been automatically generated in this way will have
their name set to “Untitled (Save)” to differentiate them from any “Unti-
tled” snapshots you take yourselfmanually. They can consequently be eas-
ily searched for and periodically purged from the project using the Snap-
shots Manager (section 15.8.5).

Show notifications when saving in composition mode Register an alert
through Notification Center whenever you manually save the project in
Composition mode, as there would otherwise be no indication of when
save completes.

B.2.3 Author Information
This information will be used for filling in placeholders in project templates (for
example, some templates generate cover sheets for you) compile placeholders
such as <$author> as well as metadata fields, and when creating inspector com-
ments. Individual projects can also use specific pseudonyms or other details, set
up in the Metadata Options area of the compile overview screen (section 13.5).
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B.2.4 Services
Options for how Scrivener’s global clipping Services should work. For more in-
formationon available services, read Scrivener Services (section 9.3). For the least
amount of intervention, set both of these options to off.

Bring Scrivener to front when using Services Choose between active and pas-
sive clipping. When this is checked, clipping from other applications will
be active in that it brings you back to your project after you’ve clipped some
text from another application. When unchecked, it will work passively,
keeping the project in the background and allowing you to continue work
in other programs while you add material to the project.

Show title prompt when using clipping Services Normally, when you use a
service that requires the creation of a new item in the binder, you will be
askedwhat youwish to call it. When unchecked, this optionwill defer that
task until later, when you are ready to think about names.

B.2.5 Language
Interface Language By default, Scrivener will attempt to select the appropriate

interface language based upon your system settings. If this does not work,
or you would like to use another interface language directly, you can use
this setting to manually adjust the language. This setting has no impact
on the production of information that is controlled by system localisation,
such as date stamps and auto-number placeholders.

Use the “System Default” selection to return the interface to the macOS
system default.

Linguistic focus uses Spanish-style dialogue When using the Linguistic Focus
(subsection 20.3.2) feature to filter for direct speech, in addition to speech
mark punctuation detection (as set in the System Settings: Keyboard pane,
by clicking the Edit button alongside your input source), Scrivenerwill also
scan for lines that beginwith an em-dash—a formof dialoguemarking that
is common in Spanish-speaking regions.

This setting will also look for text found within angle-bracket style speech
marks, even if System Settings is not set to use that punctuation style for
typing. Even if you do not use em-dash style dialogue, this may be useful
if you use both angle-bracket notation andwhatever quotation is standard
to your smart quote settings.

B.2.6 Scratch Pad
Hot key Sets the global hot key for showing or hiding the Scratchpad Panel (sec-

tion 9.4). Since this key will be accessible from any application on your
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Mac, youmight need to change this setting if it is conflicting with another
application you use.

To clear the shortcut entirely, click the− button.

Notes location Your scratchpad notes are stored on the disk using normal text
files. This option lets you choose where those files will be automatically
saved and loaded from. By default, they will be stored in your Documents
folder.

If you select a synchronised folder, such as Dropbox or iCloud Drive, you
can effectively create a universal scratchpad that every machine you use
Scrivener with can access and share, or even jot down notes from amobile
device using other software entirely.

Default format This setting impacts which file format to use for new notes cre-
ated fromwithin the scratchpad. For the plain-text format, you can supply
a custom file extension in the ext field. This can be useful for Markdown-
based formats.

Files saved into the folder from external sources will be editable in the
scratchpad window and remain in their original format. You can thus mix
rich text with plain-text notes if you desire.

If you use Scrivener for both Windows and macOS, and intend to share
your notes cross-platform, do not use the Mac’s default RTFD option, as
this format cannot be read on other platforms.

B.2.7 Shared Templates
Shared templates folder Click the Choose… button to define the location on

your disk where Scrivener will check for files to be used as globally ac-
cessible document templates. For more information on the usage of this
feature, refer to Shared Templates on the Disk (subsection 7.5.3).

Click the Clear button to reset the folder, removing this feature from the soft-
ware. TheOpenshared templates folder… button will load the folder using Finder.

B.2.8 Citations
Bibliography Manager Scrivener can integrate with several popular bibliogra-

phy management programs. Click the Choose… button to select your pre-
ferred manager from the Applications folder. The Reset button will clear
your choice.
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General purpose usage

This merely links which application will launch with the In-
sert ▸Bibliography/Citations… menu command.. If you do not use a
citation manager, but frequently use another program along with
Scrivener, you could use this feature to quickly launch or switch to that
program.

B.2.9 Separators
Text Separators This table lets you adjust how Scrivener will combine individ-

ual texts when certain actions bring them together. In all cases, you have
three choices of divider available:

1. Single Return: inserts a single paragraph break between selections. If two
paragraphs appear together, there will be no whitespace between them,
save for any paragraph spacing in use.

2. Empty Line: a full empty space will be inserted between selections. If you
prefer or require working with double-spaced paragraphs, this is the op-
tion you will want to use.

3. Custom: lets you type in a custom separator. If you wish to insert carriage
returns along with the custom separator, use⌥Return to do so.

Separators are used in the following four cases:

1. Merged documents: determines howdocumentswill bemergedwhenusing
the Documents ▸Merge command. Note that this setting only affects the
main text. The inspector notes and synopses of merged documents will
always be separated by a double newline.

2. Append clippings service: when using the global “Scrivener: Append to X”
services, clippings will be separated from any existing text by your choice
here.

3. Append selection: when selecting text and using the Edit ▸Append Selection
to Document command, the selection will be separated from the existing
text by this option.

4. Scratchpad notes: when appending text to documents from the scratchpad,
incoming text will be separated from existing text by this option.

B.2.10 AutomaticQuit
Automatically quit after a period of inactivity If the software has been left

alone for a determined amount of time it will be shut down normally,
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meaning all open projects will be closed and backed up (by default). This
can be of use if you tend to leave the program running unintentionally,
and wish to access these projects from another machine using a cloud ser-
vice. Ordinarily if you accidentally leave a project open it would be unsafe
to open them a second time. This feature ensures that after a period of
time they will be closed, so long as the computer is still running during
that period of time.

Quit after inactive for nminute(s) Set how long to wait before shutting down
the software in minutes.

B.2.11 Warnings
Show internal error alerts If the software is crashing or odd behaviours have

been disrupting your work, you can tick this checkbox and restart the soft-
ware to enable debuggingmode. If during the course of using the software
an error is encountered, it will be displayed in a windowwhere you can de-
scribe what you were doing recently and send a report to us. At this point
it is generally a good idea to restart the software.

Reset All Warnings When you first start using Scrivener, actions which have a
destructive or unusual nature (such as importing in such a way that orig-
inal formatting might be lost) will produce a warning dialogue. You can
often choose to disable these as you see them from within the warnings
themselves. The Reset All Warnings button will clear all of these dis-
missals and make them appear again the next time it is appropriate.

Click this button to reset all of the various warnings that can be perma-
nently dismissed, throughout the software, so that they will be shown
again.

Return to chapter ⤴

B.3 Editing

Figure B.4 The Editing settings pane

The options for the main text editor control most aspects of how text is dis-
played, how the editors work, the default font and paragraph formatting for new
documents, footnotes and other notes and finally the colours used in revision
mode. For options pertaining to text input and typography, see the Corrections
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settings pane (section B.6). The Appearance settings pane will also contain nu-
merous options for how the editor itself looks, and some aspects of how textual
markings, such as how hyperlinks are formatted (section B.5).

B.3.1 Options
Default Text Zoom Dynamically scale the size of the text font in various text

views. As is typical for word processors, zooming will not impact the un-
derlying font settings. This setting impacts the main text editors, the in-
spector notes and bookmarks preview area, Quick Reference panels (and
the inspector panels within it), footnotes & comments and copyholders.2

The setting will not alter editing areas that you have already adjusted or
have established settings within. For example if you change the setting to
300% and then open an older project, the project will use go on using the
previous zoom setting, but if you open a Quick Reference panel from that
project it will use 300%, because these panels are created as needed. Fur-
thermore, most areas of the interface can be zoomed independently, and
will remember their individual settings.

Writing direction In most cases, you will want to use the “Natural” setting,
which is set up depending on your default system language. This should
go from right to left, or left to right, automatically. You can also manually
override individual paragraphs as well with the Format ▸Paragraph ▸Writing
Direction submenu. Authors working in both Arabic and German, for ex-
ample, will probably want to leave this setting at Natural and change indi-
vidual paragraphs as needed.

Ruler Units Choose between the common units of measurement (centimetres,
inches, picas, or points) used throughout the software.

Typewriter scroll line Typewriter scrolling mode keeps the line you are cur-
rently typing in fixed to a certain position on the screen. This setting lets
you adjust the vertical point where the line will be positioned, with the
default being in the middle of the screen.

Typewriter scrolling always jumps to scroll line By default, when typewriter
scrolling is enabled and you start typing in another line, it will adapt to
using the current line as the scroll point. With this option enabled type-
writer scrolling will become strict, and always reposition the current line
to a fixed point.

Read more about typewriter scrolling (section 16.3).

2 Compositionmode uses its own independent zoom setting, described in theAppearance: Com-
position Mode: Options pane (section B.5.3).
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Smart copy/paste When enabled, this cleans up the whitespace left behind
when cutting text, and when pasting text it will ensure that words have
a space on either side as appropriate. Disable this feature if you prefer cut-
ting and pasting to only use precisely what you selected.

Typing clears search highlights When the binder sidebar is displaying a search
result, text views will highlight any text matching the search term. When
this option is enabled, the highlights in the current editor will be tem-
porarily removed as soon as you start typing. They will be restored when
you revisit the document in the future.

Use hyphenation Enabling hyphenation when using full justification can in-
crease readability but at the expense of not being as “pure” to the actual
text you have keyed in (the hyphens will not be literally placed into the
text; they are only drawn on in real-time to improve word-spacing flow on
a line). Consequently this is off by default.

This feature uses your system localisation Settings to determine optimum
hyphen placement. If you are writing in another language and getting odd
results, make sure your OS is set up accordingly.

Avoid widows and orphans in page view Attempts to keep page breaks clear of
widows & orphans, when using Page View mode in the main editor. This
option may slow down Scrivener when editing large amounts of text.

Use fine kerning Uses a higher-quality text rendering model which reduces
known screen artefacts, such as “text wobble” while typing, and ugly kern-
ing at odd-number zoom settings. Disable this feature to marginally in-
crease performance, if necessary.

Live counts show… Determines which units of measurement to display in the
editor footer bars, where statistics about your text is printed as you write.
The “Pages” settingwill only take effectwhenView ▸TextEditing ▸ShowPage
View is enabled in the project.

If all checkboxes are disabled then no live statistics will be shown. You will
still be able to click in the middle of the footer bar area to bring up the
extended statistics popover.

Do not color the text of inline notes (faster) Inline annotations will be drawn
with a shaded background set to the colour of the annotation, rather than
changing the colour of the text. If you use a lot of annotations in your
text and find the text editing slows down, this optionmay increase perfor-
mance.

When this option is enabled, the effective tool for changing annotation
colours (section 18.2.1) will be the highlighter, instead of the text colour
tool. However Scrivener will intelligently set the highlight colour if you
use the shortcut to bring up the system colour palette (⇧⌘C).
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Terminate footnotes before punctuation Some typesetting styles call for foot-
note markers to be placed before the terminating punctuation for a sen-
tence, rather than after it, or for when individual words are referenced
rather than the entire sentence. Select this option if you require this for-
mat. You can always manually define where the marker will be placed by
selecting the range of text you wish to comment on, prior to making the
note. This only alters the behaviour usedwhen selection ismade automat-
ically in lieu of a selection.

Open comments in inspector if possible When this option is disabled, and the
inspector sidebar is hidden, notes will open in a popover right over the text
in the main editor. When enabled, the inspector will be revealed if neces-
sary and switched to the Footnotes & Comments pane to show the con-
tent of the note you clicked on. Refer to Popup Notes (subsection 18.3.6)
for more information.

Disable insertion point blinking When enabled, the cursor will be always visi-
ble on the screen rather than blinking on and off.3

Use block insertion point in… Set the width of the insertion point from its de-
fault of 1 pixel, increasing its visibility.

Block insertion point width Set the width of the cursor in pixels. With
variable-width fonts (like the default), this setting can produce odd re-
sults where the cursor sometimes overlaps thin characters like punctua-
tion marks. It is best used with a fixed-width font like Courier, or with a
narrower setting like two or three pixels.

B.3.2 Formatting
These settings determine how new documents and typed in text will format-
ted. They will not adjust the formatting of text you have already created, in any
projects, so you needn’t worry about these settings destroying your existing for-
matting.
Some of these settings can be adjusted per project (section C.5), in a way that

will override these settings.

Main text style for new documents
The top half of this pane (marked (a) in Figure B.5) is dedicated to setting up the
default font, character attributes and paragraph formatting for new text docu-
ments (files and folders). You will have access to the full standard ruler settings,
as well as font controls via the fonts button (the Aa button on the far left of the

3 This and the following two capabilities have been removed in macOS 13 & 14, on account of a
new system cursor that no longer supports customisation.
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Figure B.5 The Editing: Formatting settings pane is where you establish de-
fault fonts for your writings.

format bar). All changes you make here will be immediately previewed against
the provided sample quotation.
If you already have a paragraph set up the way you would like all future docu-

ments to appear:

1. Place the cursor in the sample paragraph.

2. Use the Format ▸Make FormattingDefaultmenu command.

3. Alternatively, open the Editing: Formatting settings pane and click theUse
Formatting in Current Editor button, marked (b) in the figure.

Notes font
Establishes the default font and font sized used by all newly created document
notes. As with the main text editor, if you change this setting later on old notes
will remain as they were formatted before.

Comments & Footnotes
Inspector comments font Sets the default font for inspector comments. Since

these fields are rich text, this setting will only impact newly comments.
This setting will also be used by inspector footnotes unless youmodify the
following setting. Inline annotations will always take on the styling of the
text around them.

To update existing comments and footnotes to the defaults established
here, refer to Resetting Linked Note Formatting (subsection 18.4.2).
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Different inline footnotes font When enabled, the font and font size within
newly created inline footnotes will use this setting.

Use inline footnotes font for inspector footnotes too To use this alternate
font for newly created inspector footnotes as well, enable this option.

Set Styles Defaults… Click this button to have the software use the current
project’s stylesheet (you can review that with the Format ▸Styles ▸Show
Styles Panelmenu command) for all newly created projects. Alternatively,
if you would prefer to return to the stock defaults that ship with the soft-
ware, then click the Reset to Defaults button in the subsequent dialogue
box. To take no action at this time, click the OK button in the dialogue.

B.3.3 Revisions
The colour choices made here establish how revision mode will appear when
typing in new text or using overstrike to schedule text for deletion. For each
level, click the colour tile to the right to open the colour palette.

Use revision colors in notes By default if you click into the inspector and add
notes to a document or folder, the current revision level will be respected.
Disable this option if you’d rather only track revisionmarkings in themain
editors (which includes the Bookmarks editor in the inspector).

Keep revision markings consistent

It is important to consider that the revision feature solely uses text colour
formatting (of the same sort you can apply yourself by hand) to establish
the revision level of text. Once changed from previous colours, Scrivener
will no longer recognise existing coloured text as being a part of a revision
level, even if the feature was used to key in that text in the past. It would
be best to pick a set of colours you prefer early on and then stick with
those colours, at least until you transition to a new project. This also
means that if you intend to collaborate with others and use this feature,
you will all need to being using the same set of colours.

Return to chapter ⤴

B.4 Behaviors
B.4.1 CompositionMode
These options affect the behaviour of the distraction-free Composition Mode
(section 16.1).
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Figure B.6 The Behaviors settings pane

Open composition mode on… If you have more than one monitor attached to
the computer, the composition writing interface can be opened on a des-
ignated screen. The default “Current Screen” option refers to whichever
screen the project window is located within. Scrivener supports configu-
rations with up to four physical screens.

Blank out other screens When using more than one display, select this option
to reduce distractions from the other monitors. This merely draws the
background colour over the screen, and thus the monitor’s energy saver
will not kick in, so this is only useful if you’d rather not turn off yourmon-
itor.

Open composition mode in its own Space Use macOS’ native full screen fea-
ture to isolate composition mode on its own Space. The advantage of
doing so is that Notifications can be displayed while you are writing,
whereas the standard “presentation mode” suppresses even those notifi-
cations coming from Scrivener, letting you knowwhen you have met your
daily writing goals and so forth. The disadvantage is being unable to mul-
titask, so using Dictionary to look up words will mean having to switch to
a different Space.

Fade between modes Gracefully fades the screen between composition mode
and regular editing mode.

Hide main window in composition mode Check this to hide themainwindow
during composition. If this is unchecked, you can see the main window
beneath the translucent areas of the composition background (which can
be controlled with the Background Fade slider). When using multiple
displays, you can also have the main window visible on another screen.
Checking this so that the window is hidden means that you could use the
translucent areas of the background to look at the contents of thewindows
of other applications.

In some circumstances, having the main window visible in composition
mode can slow down typing, so it is usually best to leave it hidden.

Escape key closes composition screen When disabled, you will need to use ei-
ther the View ▸Exit Composition Mode command or its keyboard shortcut
(⌥⌘F) to toggle between modes.

Dock Hiding By default, composition mode will force the Dock to be hidden
even if you move the mouse over to the edge of the screen where it would
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appear. Since the Dock ordinarily appears along the bottom of the screen,
it can get in the way of the control strip used to adjust composition set-
tings. However if you place the Dock along the left or right edges of the
screen, setting this to “Automatically hide and show Dock” will grant ac-
cess to it. You will need to re-enter to composition mode for this change
to take effect.

B.4.2 Document Links
This pane adjusts how internal document links and linked images function
within the software. You can change what happens when you click a link, and
whether or not back-links are created for you automatically. Read more about
Linking Documents Together (section 10.1).

Document links and bookmarks create back-link bookmarks When you cre-
ate document links or bookmarks to other items in the binder, Scrivener
will automatically place a “back-link” to the originating document in the
Bookmarks inspector tab for the target (section 13.4). For example, if you
link from “Scene 81” to a character sheet named “Maria”, then “Scene 81”
will be bookmarked from the “Maria” document. In this way, every cross-
reference you create will become a circular link. If you would prefer to
maintain all of your bookmark lists by hand, disable this option.

Image links create back-link bookmarks In the same fashion as the above, in-
serting a linked binder image into a text editor (section 15.6.4) within the
same project will establish a bookmark from the image to the document
that uses the image.

The following settings impact how links and bookmarks load their targets
within (or even outside of) the project window. The default settings strive to
preserve the content that is loaded into the text editor the link was activated
from (including from the inspector), by either using split views or Quick Refer-
ence panels. The three different link actions all feature the same core options to
choose from:

— Current Editor: loads the item into the active editor, actingmore like a web
browser—and aswith a browser you can get back towhere you linked from
with the Back button above the editor, or⌘[.

— Other Editor: the linked item will be loaded in the other split, splitting the
editor if necessary to do so.

— Quick Reference Panel: the clicked link will open in a new window, thus
preserving the current working environment in the project window.

— Copyholder: the linked item will load in the current editor’s Copyholder,
opening one if necessary to do so.
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Refer to Using and Managing Links (subsection 10.1.2), for more information
on how links can target different views on the fly.
Some contexts will always use Quick Reference panels when it is not logical

to follow your behaviour Settings. For example in Composition mode, there is
no “other editor”, and likewise if you click on a link to a picture it cannot edit or
view that picture.

Open clicked document links in… Linked items will be loaded as established
with this setting. It applies to all of the areas within a project window
that can store clickable hyperlinks in the text, as well as the behaviour for
external links that load individual binder items (subsection 10.1.6).

Open new document links in… Determines what will happen after a new doc-
ument is created as a result of inserting a hyperlink via the Edit ▸LinktoDoc-
ument ▸NewLink…menu command (⌘L) or the optionalwiki link style (sec-
tion 10.1.1). This behaviour does not impact the creation of hyperlinks to
existing binder items. It also has a special setting beyond the core choices:
“(Do not open)”, which causes links to new documents to behave just like
links created to existing documents: you will be able to continue writing
in the context where the link was created from without interruption.

Open Inspector bookmarks in… When pressing the Return key on a selected
bookmark in the inspector, or double-clicking on it, it will be loaded in ac-
cordance with your setting here. This only refers to the bookmarks them-
selves in the upper half of the bookmarks tab (section 13.4). The editable
preview area in the lower half will use your main setting for how clicked
document links should behave, above.

B.4.3 Double-Clicking
Double-clicking on the corkboard background A couple of optional actions

can be assigned to the background of the corkboard itself, when double-
clicking on it:

— Opens the parent corkboard: navigates the editor “upward” in the out-
line hierarchy to display the parent of the current corkboard. If the
corkboard you are viewing is already at the top level of the binder, it
has no parent and nothing will happen. This action can also be per-
formed with the Navigate ▸Go To ▸Enclosing Group (⌃⌘R) menu com-
mand.

— Creates a new card: follows a common behaviour amongst diagram-
ming and mind-mapping applications, where you can indicate the
position of a new card by double-clicking with the mouse.

— Does nothing: the default setting. Double-clicking will be ignored.
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Always creates a new card in freeformmode By default, when using the
freeform corkboard (subsection 8.2.4) mode double-clicking will always
create a new index card under the mouse pointer when double-clicked.
Uncheck this to have freeform corkboards follow the behaviour of the
above setting.

Always creates a new card when arranged by label As above, this default be-
haviour applies when using the Arrange by Label (subsection 8.2.5) cork-
board mode.

B.4.4 Dragging &Dropping
Option-dragging creates duplicates When enabled, hold down the Option key

while dragging items to create copies of those items to the location where
you drop them, rather than moving the items. This impacts any case
where you can drag and drop an item icon, or a selection of items, into
the binder sidebar, corkboard or outliner—thus it even applies to dragging
from bookmark lists, the editor header bar, QuickReference panels and so
forth.

Collapse auto-expanded outline items after drag and drop Dragging items in
the binder or outliner, and pausing over a collapsed container, will reveal
its contents so you can drop items several layers deeper than you could
initially see when you started dragging. This option will close containers
expanded this way, once you have dropped the item(s).

Allow drop ons in corkboard When enabled, allow the dropping of index cards
on top of other cards to move them as child cards beneath them. This
action is similar to dragging and dropping items on top of other items in
the binder or outliner.

Link to images dragged from binder into editor By default, images dragged
from the binder into a text editor will drop a link to the original image.
If the original image is modified the changes will show up in the editor af-
ter a reload of the project. This is synonymous with the the Insert ▸ Image
Linked toDocument ▸ submenu (section 15.6.4).

When disabled, images will be fully imported into the text itself, creating
a copy of the original image.

Delete text dragged to other areas By default, when dragging text from any of
the following editor contexts, the dragged text will be moved to the drop
point in the sameway text would bemovedwhen dragging it from one po-
sition to another within a single editor. With this option disabled, text will
be copied to the drop location instead, leaving the original text untouched.
This option has no affect on the behaviour of dragging text within a single
editor, but it will adjust the behaviour used when dropping text into the
binder sidebar, corkboard or outliner views.
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— The main text editor splits.

— The Document Notes inspector tab.

— The Bookmarks preview pane.

— Quick Reference panels (and their applicable inspector panes).

— Copyholders.

B.4.5 Folders & Files
Concerns the treatment of file and folder items in Scrivener, particularly in how
their behaviour in the project interface differs, including options for negating
these differences.

Treat all documents with subdocuments as folders When this is checked, any
document type at all that has subdocuments will act like a folder in all
ways. If this isn’t checked, normal text documents or media files that have
subdocuments (any type of document can act as a “container” for other
documents in Scrivener) will be opened in single text mode.

This setting has broad implications throughout the interface. For example
the following options that refer to modifying how folders work will now
also apply to file groups. It is a safe assumption that if a thing works a
certain way with folders, with this option enabled that thing will also hold
true for all containers. Consequentlywewill not list all of the ramifications
here, but will make note of where it does have an impact when discussing
the features themselves.

Include enclosing folder text in scrivenings mode When clicking on a con-
tainer, by default the text contents of that container will be included in
the Scrivenings session at the very top. If you never use folder text then
disabling this will remove the empty entry at the top of the Scrivenings
session.

Show folder text when selected from search results Enabled by default: when
clicking on folders in search results, the editor will display text content
for that folder, rather than revealing their children in accordance with the
preferred viewmode. Generally speaking, most search results are based on
the text of the matching item, not its descendent items, and so the reason
the item is in the search list at all might likely be in any text stored in the
folder, which a corkboard or outliner might obscure.

If desired, you can always switch back to a group viewmodemanually once
you’ve loaded the search result in the editor.

Always create new items as siblings This option overrides the default be-
haviour by causing all newly created items to be created at the same level
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as the selection. The only exception is when one of the three special root
folders are selected. By default, if you select a folder and create a new text
or media document, it will be placed inside that folder as a child item.

Refer to Figuring OutWhere ThingsWill Go (section 6.3.1) for more detail
on how Scrivener places new items.

Always set title of new items By default the software will attempt to respect
where your cursor is, when creating new items. If you are typing in the
editor, and press the shortcut (⌘N) to create a new text item, the result
will be you typing text into the new document immediately.

This settingwill cause Scrivener tomove your cursor into the binder when
you create a new item, so that you can type in a name for it right then and
there. If the item cannot be displayed in the binder, whether because it
is closed or the sidebar isn’t showing the location where it appeared, then
normal default behaviour will be used.

B.4.6 Navigation
When focused editor is locked in place… By default, if you have the editors

splits and lock one of them, the behaviour of Scrivener will change. Ordi-
narily the binder sidebar will only ever impact the targeted split, but when
the target split is locked the binder will load clicks into the other split.

Change this setting to Binder selection does nothing if you would prefer
split targeting to remain literal and simply do nothing when the targeted
split is locked.

Automatically load web pages in bookmarks preview Bookmarks to web sites
or other online resources will require you to click a button to load them
within the inspector pane. This way as you switch through documents in
your draft or browse through the bookmark list, you will not automati-
cally be downloading websites. If you would prefer otherwise, enable this
option.

Allow limited navigation in web pages Hyperlinks found within archivedWeb
files, as well as those displayed in the Bookmarks preview pane, will at-
tempt to navigate within the same view, rather than sending the URL to
your default browser.

Scrivener is not a dedicated browser, and will not have the same level of
protection and security that a browser does. Aswith the above option, take
care when using any feature that downloads raw data from the Internet.

Use the Option key to temporarily override this setting per click.

Space key opens selected document in… The Spacebar can be used to quickly
open selected items in the corkboard and outliner views. By default this
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opens the item in the editor, replacing the current view (synonymous with
the ⌥⌘O shortcut). If you would prefer it to match the binder behaviour,
change this to “Quick Reference Panel”.

B.4.7 Outliner
Disable live row resizing The height of the row will not be adjusted until af-

ter you have committed your edits. If the language you use in Scrivener’s
interface causes the outliner to malfunction, when the height of the row
changes, then enable this option.

B.4.8 Playback
Rewind when paused by… Use the slider to set how many seconds Scrivener

should rewind the media stream back, when using the Auto-Rewind (sec-
tion 8.1.3) feature.

Media time stamp format Establishes the time stamp format used by the In-
sert ▸Media Time Stamp menu command. If you are writing subtitles for
example, youmight wish to use HH:mm:ss.SSS. If you are looking for other
tokens to use than the few basic ones we have provided in the help text,
visit the datestamp format reference4 web page.

B.4.9 Return Key
Scrivener’s binder, outliner and corkboard views treat the Return key in a fashion
more like a dedicated outliner or mind-mapping tool might do. If you find this
gets in the way of how you work, these options can tune how it works.

Ends editing synopsis in corkboard and outliner By default, the Return key
will commit edits made to the synopsis in the corkboard and outliner. To
add carriage returns to the synopsis, use⌥Return. If this is unchecked, the
Return key will add carriage returns, and you will need to use Esc to submit
changes.

Creates new item in list, outline and corkboard views Pressing the Return key
(when not editing the title or synopsis) will create a new item in the out-
liner, binder and corkboard as well as in certain list views (such as the key-
words list). Disable this if you would prefer the creation of new items to
require specific commands or the clicking of buttons.

Show elements list on double !return in script mode Mirroring popular
scriptwriting software, if you press Return on an empty line then the

4 https://www.unicode.org/reports/tr35/tr35-dates.html\#Date_Format_Patterns
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software will provide a list of elements you can choose from, to format
the current line. Disable this option if you need to insert empty lines into
your script.

B.4.10 Snapshots
Play shutter sound when snapshots are taken Disable this setting to remove

the audible camera shutter cue that is played when you take a snapshot.
This sound will not be played when automated snapshots are taken (such
as when using folder sync).

Show notification when snapshots are taken Enable this option to display a
message on the screen when snapshots have been taken. Given how noti-
fications may also play a sound of their own, you may want to disable the
above option as well.

Return to chapter ⤴

B.5 Appearance

Figure B.7 The Appearance settings pane

Most Settings relating to the colours, fonts and how various parts of the pro-
gram react to view settings will be determined in this section. Each subsection
may contain options, fonts or colours, organised into tabswithin their respective
panes. We will break down these by section for your convenience.
There are many areas of the user interface that can have their colours mod-

ified, all organised into the sections of the Appearance panel most relevant to
them. If you want to change a particular area of the window, look for its rough
category in the left sidebar, click on the “Colors” tab, and then select the compo-
nent from the list within this tab. The colour swatch in themiddle of the setting
area should be clicked to bring up the colour chooser (Figure B.8). Individual
colours can be reset to default by clicking the UseDefault Color button below the
swatch.
Where fonts can be chosen, a rectangular button with the currently selected

font (and often the font size as a numeral as well) printed inside of it, with a spe-
cial “T” icon on the right-hand side to indicate this type of control (Figure B.9).
You can click anywhere within the rectangle to bring up the font chooser. Some
font settings allow access to the “System Font” type, even though Apple hides
this font from you in the chooser. Where applicable, you will find a dropdown
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Figure B.8 Click the colour swatch to change the “Index Card Background”
option.

menu added to the bottom of the font chooser. Once the base system font type
is chosen, you can use the font size controls, even though you will not be able to
see the font selected in the main area above.

Figure B.9 Click within the rectangular area where the font name is printed
to select a font.

Can I save themes?
Setting up colours can be a lot of work. If you’d like to save your settings
to share with others, or just to keep a copy in case you want to use an-
other theme for awhile, be sure to check out Settings Presets andThemes
(subsection B.1.1).

B.5.1 General Interface
These options affect the overall project window reacts to a few different appear-
ance settings.

Options
Adjust window size to accommodate binder and inspector The overall win-

dowwidthwill remain the samewhen toggling binder or inspector sidebar
visibility, causing internal elements of the project window to expand or
contract tomake space for the sidebars. The latter behaviour can be better
when the project window fills the screen.

In Figure B.10 we can see the two different settings in action. In the mid-
dle screenshot we have a fairly typical project windowwith a binder, cork-
board split, editor split and inspector open. The position indicated by (a)
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is where the binder would be if it were visible in the first screenshot. The
bottom example shows the behaviour with this option disabled, where (b)
indicates how the editor expands to fill up the space left behind by the
inspector.

Figure B.10 Example of difference between adjusting thewindow size for side-
bars or not.

Always resize editors proportionally when resizing window The ratio be-
tween the main editor splits will be preserved when changing the size of
the window or when changing the width of the inspector or binder. If you
prefer the more standard behaviour where the split position remains fixed
and the bottom or right elements within the window expand, then disable
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this option. The bottom framemarked (b) in Figure B.10 demonstrates the
behaviour as disabled. Note how the index cards and corkboard remain
the same size, but the width of the editor on the right is relatively wider
than it was initially.

When the editors are perfectly split 50/50 then this option will be ignored
and the behaviour will be to retain that 50/50 split as you resize the win-
dow.

Use monochrome toolbars ⟨macOS 11+⟩ Use monochromatic icons, instead of
colour, in the main application toolbar.

Smooth text and line art in PDF documents Anti-aliasing is used by default to
keep your PDF documents smoothly rendered at all levels ofmagnification.
If your computer runs slowly while viewing PDFs, disable this to increase
performance.

Draw border around current line highlights When the currently edited line is
highlighted5, you can opt between a line-width highlightwith a subtle bor-
der, or a full “page”-width highlight, as shown in Figure B.11.

Figure B.11 The currently edited line can be highlighted with a border or as a
simple full-width highlight.

Opacity of label colors when used in backgrounds This setting impacts most
cases where the label colour is can be used as a background colour (for ex-
ample, with View ▸Use Label Color In ▸ Index Cards). Moving the slider right
toward “High” will cause labels to be coloured more vividly; moving the
slider left toward “Low” will cause the effect to be more subtle. The de-
fault setting is tuned for the very pale label colour defaults. If you prefer
stronger label colours you may want to reduce the opacity.

5 Set in the Appearance: Main Editor, Quick Reference and Composition Mode settings panes,
with theHighlight current line setting
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Use dark appearance in main window editors Available for Dark Mode, this
will keep the twomain editors usingLightMode settings. Readmore about
the workings behind this setting in Keeping Text Editing Light (subsec-
tion 4.3.2).

Collections background darkness In Dark Mode, collections will continue to
display their set colour in the collection tab list (subsection 10.2.1) and the
binder sidebar header, and the background list area will be blended with
black to darken it.

This slider adjusts the amount of black to blendwith the original collection
colour. The left side of the slider represents the original collection colour
(no blending, effectively disabling this behaviour) and the right side black
(full blending).

B.5.2 Binder
The options in this section impact the display of the binder sidebar in general,
including search results and collections.

Options
Show current editor document indicator If the document you are viewing in

the currently active editor is visible within the binder, then a secondary
highlightwill be placed on the item (separate from the larger highlight that
indicates your last selection), making it easy to spot where you are in the
overall outline. If find this behaviour distracting, disable it here to only see
a highlight on the last thing you selected yourself.

Refer to Finding Where You Are in the Outline (subsection 6.3.3) for more
information on this concept.

Base selection color on background color The colour for both the selection
bar and current document indicator will be blended with the background
colour of binder sidebar. Disable this option to use your computer’s de-
fault selection highlight settings.6

Row spacing Fine-tune the amount of vertical spacing between lines of text in
the binder. This can be useful when using a custom font that uses more or
less leading than default.

Fonts
Binder font The font and text size used to display the binder hierarchy as well

as various collection lists and search results. As some fonts have a wider

6 This option has no effect for background colours that are white, black or somewhere in
between.

802



B.5. Appearance

line spread, you can fine tune the amount of spacing between rows as well,
with the Row Spacing setting in the “Options” tab.

Use bold font for… If the font you have chosen is capable of displaying bold-
face characters, the two provided checkboxes will have containers printed
in bold, making it easier to spot them in long lists as you scroll through.
These settings only impact themain binder view. In collection lists, where
hierarchy is not displayed, all items are considered equal.

Colors
Collections can be independently coloured according to taste, but for the sake
of familiarity and consistency, the binder and search result lists will display in a
unified colour across every project you use. You can adjust the colours used by
these two special tabs in this section.

B.5.3 CompositionMode
The distraction-free writing interface in Scrivener has a full set of appearance
options, even allowing you to temporarily override the colour of the text in the
main writing area.

Options
Highlight current line Enabling this will place a highlighter beneath the cur-

rent line of text being edited, making it easier to see where the cursor is
located on the screen, and easier to return to that point after scrolling else-
where momentarily. The colour itself can be set in the respective “Colors”
tab.

Scroller type Customise how the scroll bar looks and behaves in composition
mode.

— Regular scroller: the standard operating system default scroller will
be used and will follow macOS System Settings for whether it will
always be visible, or only appear when used.

— Full screen scroller: this scrollbar remains visible on the screen at all
times, providing a good alternative to those that like knowing where
they are in the editing session without scrolling.

— Auto-hiding scroller: remains hidden unless the mouse pointer is left
sitting on the left side of the editor. It will remain visible when you
resume typing, making it a good compromise between “Full screen
scroller” and “No scroller”. This scrollbar takes on the text colour if
applicable.

803



B.5. Appearance

— Minimalist scroller: similar in most respects with the “Auto-hiding
scroller”, it takes on a more diminished blend with the background.

— No scroller: there will never be a scrollbar in your way, even if you
move the mouse over the area where one would otherwise appear.

Editor margins Sets the margin spacing between the text and the “paper” edge.
You can select a different distance for horizontal and vertical margins. The
top and bottommarginwill only affect the very top and bottomof the doc-
ument on the page, and so will not be visible if you have scrolled into the
middle of the file. If you are looking for away to add a little vertical padding
that is always present, refer to the “Paper Height” setting in composition
mode’s Control Strip (subsection 16.1.3).

Use current composition settings for new projects

You can dynamically adjust most of the spatial options, such as with width of
the typing column or the opacity of the background, while in compositionmode
itself. Refer to using The Control Strip (subsection 16.1.3) for more information
on these various settings. If you achieve a look you would like to see in all new
project, click this button to save the current project’s composition view settings
into your defaults. The following options will be saved:

— Default text zoom: the dynamic amount of scaling used to display the text.

— Paper position: saves whether the paper position, or text column, is located
on the left, centre or right side of the screen.

— Paper width: the overall width of the virtual page, or how wide the text
column will appear.

— Paper height: brings the top and bottom of the page away from the edges
of the display, keeping the text block centred on the screen. To set the
paper height in the composition screen, with the Control Strip (subsec-
tion 16.1.3) visible, hold down the Option key and the “Paper width” slider
will be replaced by “Paper height”.

— Background fade: save the amount of opacity used to mix the background
colour with the windows behind Scrivener or your desktop background.
Paper fade, the alternate form of this slider that appears when a backdrop
is in use, will not be saved into Settings.

— Typewriter scrolling: establish whether or not this feature is on by de-
fault in new projects. It can be toggled on and off with View ▸Text Edit-
ing ▸Typewriter Scrolling (⌃⌘T) while in composition.

— Page View & Two Pages Across: also located in the View ▸Text Editing sub-
menu, these two options when applied to compositionmode will be saved
as defaults for future projects.
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Colors
Most aspects of what you can see in the composition view can be adjusted to
taste, including the colour of text, as an override to its natural text colour. Set-
tings are also available for altering some aspects of the floating inspector panel
(subsection 16.1.4), used exclusively in Composition mode to provide access to
all inspector tabs but snapshots.
Refer to Table B.1 for a list and description of settings.

B.5.4 Corkboard
Provides options and settings impacting the corkboard views (including freeform
and label view). Since index cards appear in a few other contexts as well (such as
the inspector), the settings governing their appearance specificallywill be located
in the Appearance: Index Cards (subsection B.5.6) pane.

Options
Allow two lines in title areas If you tend toward longer titles for your items, the

single-line presentation in index cards can get a little claustrophobic. This
option allows for an additional line of word-wrapping before truncation
occurs.

Automatically shrink titles to fit Enable this option to cause the index card ti-
tle text to shrink to a smaller font size if the title does not fit on one line.
This option can be combined with Allow two lines in title areas.

Minimum font size Sets a limiter on how small a font the above option should
use.

Arrange cards from right to left If you are accustomed to working in right-to-
left languages, this will make the corkboard more intuitive.

Display images as photographs Video, image files and documents using an syn-
opsis image are displayed by default as “Polaroid” thumbnails on the cork-
board. Disabling this option will always show the standard synopsis text
on the corkboard. This can improve performances on larger corkboards
with many graphics.

Compress threads when arranged by label Affects the corkboard’s Arrange by
Label view mode (subsection 8.2.5). When disabled, the label colour
“tracks” will be spread apart so that the height of each row includes the en-
tire index card, as well as any padding you’ve added with your corkboard
settings. By default, the rows will only be so tall as to create a “zipper”
effect between adjacent cards.
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Table B.1 Composition Mode Colour Settings

Interface Element Description

Editor The background colour of the “paper” area behind the text col-
umn. An image texture can be chosen, overriding any colour
choice made.

Text Enable theOverride text color with color checkbox to activate
the colour swatch. Disabling this feature will cause the natural
text colour to beused, just as itwould appear in themain text ed-
itor. This option also extends to highlights, revision markings,
annotations, hyperlinks. Refer to How ColourWorks in the Ed-
itors (subsection 4.3.1) for further information on these settings.

Scrivenings Titles Text Adjusts the text colour of item titles in the editor, when
View ▸Text Editor ▸Show Titles in Scrivenings is enabled. Refer to
the Appearance: Scrivenings settings pane for further settings
(subsection B.5.13).

Scrivenings Titles Back-
ground

WhenUse title background color is switched on in the Appear-
ance: Scrivenings pane, this sets the default background high-
light.

Screen Background The area around the Editor text column. An image texture can
be chosen, overriding any colour choice made.

Synopsis Background Adjusts the background colour for index cards in the floating in-
spector panel used in composition mode. This overrides the In-
dex Card Background setting applied in the Appearance: Index
Cards pane.

Notes Background Adjust the background for document notes in the floating in-
spector. This overrides theNotesBackground setting in theAp-
pearance: Inspector & Notes pane.

Comments Area Adjusts the background area behind footnotes and comments
in the floating inspector. This overrides the Comments Area
setting in the Appearance: Main Editor pane.

Text Selection The highlight colour used to indicate selected text.

Current Line Highlight Emphasis colour used to indicate the line of text the cursor is
currently within.
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Image cards use index card proportions When ticked, images will conform
their shape to the regular index cards on the corkboard, rather than pre-
senting themselves as square thumbnails. If having “gaps” in the corkboard
bothers you, this setting will make card layout uniform.

Freeform grid size Determines the grid resolution used by the View ▸Corkboard
Options ▸SnaptoGridoption. The opacity of the grid can be adjusted below.

Draw shadows around cards Toggles whether or not index cards use a 3D effect
on the corkboard. Disable this to achieve a more modern flat look.

Status stamp opacity Adjust the opacity of status stamps on the index cards
within the corkboard. The stamp, unlike a real one, is drawn beneath the
synopsis text, so even at full opacity it will not obscure what you’ve writ-
ten.

Freeform grid opacity Adjust the opacity of the displayed grid, when
View ▸Corkboard Options ▸Snap to Grid is enabled. Drag the slider all
the way to the left to disable grid display (it will still function as normal).

Fonts
Photograph titles For those items displaying themselves as an image thumbnail

on the corkboard, you can use a different font from the standard index
card title. To change the title font for normal index cards, refer to the
Appearance: Index Cards: Fonts tab (section B.5.6).

Status stamps The status text can optionally be printed on the face of the card,
with the View ▸Corkboard Options ▸Show Status Stamps menu option. Set
the font used for that “stamp”, here. The font size will be ignored, as Scriv-
ener automatically resizes the stamp to fit within the index card.

Colors
Corkboard, freeform and label view backgrounds

Each of the three different corkboard modes can have different background
colours, images or use the traditional corkboard texture:

— If “Color” is chosen then the swatch to the right of that row will be what is
used in the background for that particular mode.

— The “Corkboard Texture” option revives the classic Scrivener corkboard
look, if you are so inclined.

— If you have your own image you’d like to use for the background, select
the “Custom Background…” option and designate the image using the file
chooser. For best performance, use smaller, tiling textures rather than
large images.
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Freeform corkboards can also have project-specific background images cho-
sen, under Project Settings: Background Images (sectionC.8). This can be useful
if you have an image you’d like to use as a basis for sorting cards into piles, based
on status, plot points or other criteria.

Status Stamps Alter the colour used to print the “stamp” (View ▸Corkboard Op-
tions ▸ShowStatus Stamps) in diagonal fashion across index cards.

B.5.5 Full Screen
This section impacts options pertaining to the dedicated macOS full screen
mode, not Composition Mode (subsection B.5.3).

Options
Hide binder and inspector when entering full screen mode The binder and

inspector, if visible upon entering full screen mode, will be hidden, draw-
ing full attention to the content in the editors. Upon return to normal
windowing mode, the original state of the sidebars will be restored if
necessary. Access to the sidebars while hidden is a simple matter of
moving the mouse to the left or right edge of the screen, or by using the
keyboard shortcuts that would toggle the visibility of the Binder (⌥⌘B)
and Inspector (⌥⌘ I).

Slide in binder and inspector when hidden When these sidebars are hidden in
full screen, moving the mouse to the left or right edges of the screen will
cause them to appear temporarily as a slide-out panel. Read more about
this behaviour in Full ScreenMode (section 4.1.6). When disabled, the only
way to use these sidebars will be reveal themwith the ordinary commands
for doing so.

Always auto-hide toolbar in full screen mode You can opt to always hide the
toolbar strip at the top of the project window when placing it on a full
screen space. When hidden, the toolbar will be revealed along with the
main menu by moving the mouse to the top of the display. The default
behaviour is to display the toolbar at all times.

B.5.6 Index Cards
The appearance of index cards themselves are adjusted in this section. Since they
can also appear in the inspector these settings are separate from the corkboard
itself.
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Options
Index card theme Select froma variety of index card looks. This settingwill also

impact the index card in the inspector (though it will always have square
corners). The five variations are demonstrated in Figure B.12.

Figure B.12 The five index card appearance themes.

Always show synopsis rather than image by default in inspector While the
synopsis image will continue to be used in the corkboard with this option,
the version of the card in the Inspector will show the text synopsis
instead. This can be useful if you are still using the text synopses as well
as the image, as you can see both versions at once with a corkboard and
inspector arrangement.

Fonts
Index cards title Set the font and text size used in the title area of index cards.

Index cards text Set the font and text size used in the synopsis area of index
cards.
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Colors
The Index Card Background setting impacts the “paper” colour, if you will, of
index cards. This may be overridden by the label colour, when View ▸Use Label
Color In ▸ Index Cards has been enabled in the project on a per card basis, and by
composition mode colour settings in its floating inspector.

B.5.7 Inspector &Notes
These settings impact the appearance of the inspector sidebar, inspector split in
Quick Reference panels and the floating inspector panel in composition mode.

Options
Draw notepad lines in document notes Turns on notepad-style ruling for doc-

ument notes, giving it the appearance of a pad of paper. The rules will
adjust their height depending upon the height of the lines of text or im-
ages within them.

Colors
The following areas of the inspector and Quick Reference splits can have their
colours customised. Tomodify the appearance of the compositionmodefloating
inspector, use theAppearance: CompositionMode: Color Setting tab (Table B.1).

— RichText: if usingDarkMode, the text colour forDocumentNotes, Book-
marks, Snapshots and Footnotes & Comments will be displayed in the se-
lected colour, using the chosen saturation model (subsection 4.3.1).

When Override comments only is enabled, this will only impact the Foot-
notes & Comments pane content.

— Notes Background: the background colour of the notes pane in the in-
spector.

— Bookmarks Preview: the background colour of the bookmarks preview
area when editing text.

B.5.8 Main Editor
Provides controls for the basic default look of the text, background “paper”, mar-
gins and whether or not the text column should have a fixed width or expand to
fit the size of the window.
There are additional Appearance tabs involved in the matter of text editing:

1. Appearance: Page View (subsection B.5.10): Contains visual settings for
the optional Page View mode (View ▸Text Editing ▸Show Page View), such as
paper size, and whether to use this mode in new projects.
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2. Appearance: Scrivenings (subsection B.5.13): Adjust the separators drawn
between files as well as the font and appearance of section titles within a
Scrivenings session.

3. Appearance: Textual Marks (subsection B.5.16): Settings for how the text
will be marked up, including invisible characters, hyperlink appearance,
the cursor and so on.

Options

Figure B.13 The areas of the editor that can have their spacing adjusted.

Scrivener’s default settings use a simple white background for all of the zones
you can adjust in theMainEditor settings pane. For the sake of illustration, we’ve
adjusted the colour settings in the figure (Figure B.13). Ordinarily themarginwill
match the text background colour.

a) With default settings, the width of the text editing area (or the text col-
umn) is set byDefault editor width. Padding is added in themarked areas
to the left and right to keep the text centred to the middle of the editor.

b) The Left/Right editor margin pads the text within the text column so that
it does not brush up against the padding area marked (a). When the editor
itself is narrower than the fixed widthmaximum, this setting will keep the
text from brushing up against the window edge and scroll bar

c) The Top/Bottom editor margin keeps the very top and bottom of the text
file spaced from the edges of the editor view.
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Highlight current line Enabling this will place a highlighter beneath the cur-
rent line of text being edited, making it easier to see where the cursor is
located on the screen, and easier to return to that point after scrolling else-
where momentarily. The colour itself can be set in the respective “Colors”
tab.

Default editor width This setting affects two different behaviours. When using
the Window ▸Zoom command, the overall project window size will be ad-
justed so that the editor areas match this width. The value is also used to
set how wide the text column itself is within the editor, when the viewer
is wider than that, and Use fixed width editor is enabled.

Click theUseCurrent button to capture thewidth of the active editor in the
foremost project window. Setting this to “0” (zero) will cause the project
window to always maximise to fill the screen. If you merely wish to not
have text in a fixed-width column, you can disable that behaviour inde-
pendently, below.

Use fixed width editor By default Scrivener will restrict the width of the text
editing column no matter how wide you make the editor itself. If this op-
tion is disabled then text will start at the leftmost edge of the viewer and
continue all the way to the rightmost edge before wrapping. When en-
abled, the width of the text column will scale along with the text magnifi-
cation, in order to preserve your intended line width.

Center the editor when using a fixed width Keep the writing column centred
to the middle of the editor view, when it is wider than the preferred width
(set above). When this option is disabled, text will have a more traditional
look, flush along the left edge of the view.

Editor Margins Sets a visual margin or padding area between the text and the
edges of the text editing column (or the view itself if the Use fixed width
editor option is disabled). You can select a different distance for horizontal
and vertical margins.

The top and bottom margin will only pad the very top and bottom of the
document in the editor; itwill not be seen if youhave scrolled to themiddle
of a long document.

Fonts
Header bar The font used to print the name of the item you are currently view-

ing in the editor. Given how different fonts are drawn into the interface,
you may need to play with sizes and different font variants before finding
a combination that sits evenly with the icon.
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Colors
In addition to colour settings for the main editor, the background colour for the
footnotes and comments inspector sidebar is changed here.

— Editor: Main editing background, or “paper colour”. An image texture can
be chosen, overriding any colour choice made.

— Text: set an optional text colour override instead of showing natural for-
matting colours. This setting is only available in Dark Mode. Beneath the
colour override is a setting for adjusting how formatting colours will be
shown. Refer to How Colour Works in the Editors (subsection 4.3.1) for
further information on these settings.

— Fixed Width Background: Colour displayed around the pseudo-page in
fixed width mode. An image texture can be chosen, overriding any colour
choice made.

— Media Background: Colour displayed around images and PDFs when dis-
played in the main editor.

— Comments Area: Adjusts the background area behind footnotes and com-
ments in the inspector.

— Text Selection: The background colour used to highlight selected text in
the editor. The chosen colour will be blended with existing background
adornments on the text (such as comment highlights). The Use Default
Color button will cause the software to use theHighlight Color setting in
your Mac’s System Settings: Appearance pane.7

— Current Line Highlight: Colour of the highlight indicating the line the
cursor is currently placed within. This option requires theHighlight cur-
rent line option to be set, in the Options tab.

B.5.9 Outliner
A number of settings that impact the type of content shown in the outliner are
set to each split pane in a project, via the View ▸OutlinerOptions ▸ submenu. The
options listed here alter how the outliner looks in all projects.

Options
Outliner has horizontal grid lines Draws rules between rows in the outliner.

Only when using fixed row heights The prior settingwill only be applied to the
outline view when the View ▸Outliner Options ▸Use Fixed Row Height menu

7Onolder versions ofmacOS themenu commandwill be printed as “Preferences”, and references
to System Settings (“System Preferences”) locations may no longer be accurate.
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toggle is enabled. This particular look will match commonmobile design-
inspired lists, where all cells have a uniform height and are separated by a
rule.

Outliner has vertical grid lines Draws rules between columns in the outliner.

Outliner uses alternating row colors Draws alternating background colours
behind rows in the outliner. When this is turned off, the background will
be a solid shade. The shade used for alternating rows will be derived from
the Background colour setting, made in the respective “Colors” tab.

Alternating row colours and labels

If the project you are working with has the View ▸Use Label Color
In ▸Outliner Rowsmenu toggle enabled, then alternating rows will not be
visible in that project.

Always indent title column if available If a title column is present in the out-
liner then it will always have indents and disclosure arrows drawn in that
column, even if other columns precede it in the list. The default behaviour
is off, which will follow a more traditional approach of indenting the be-
ginning of the row, no matter what kind of content may be found there.
With some column layouts, it may be easier to see the outline if the initial
columns are flush (Figure B.14).

Figure B.14 Forcing the title column to indent can bring clarity in some lay-
outs.
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Total columns only count documents included in Compile The various “To-
tal” statistic columns, such as View ▸OutlinerOptions ▸TotalWordCount can
be set to ignore the counts for any subdocuments that have had their In-
clude in Compile checkbox disabled, in the Inspector metadata pane, or
right in the outliner itself if the appropriate column is added.

Row spacing Adjust the amount of vertical padding between rows with these
settings. A different amount of padding can be set, depending upon
whether or not synopsis text is included along with the title.

Fonts
There are three areas where fonts can be set within the outliner. The Titles and
Synopses settings configure the font and size used for these two elements of the
outline. TheOther selection sets the font for text in any other columns, such as
dates, labels, custom metadata and so forth.
By default, the Other font will be used for titles as well when synopses are

hidden, giving the outliner a uniform look.

Use bold font for… These options will cause the software to dynamically select
a bold version of the font selected above, when the following conditions
are met. The checkboxes will be disabled if you have chosen a font that
lacks a bold variant.

When synopses are hidden If the synopsis field has been hidden via the
View ▸Outliner Options ▸and Synopsis menu toggle, then titles will use the
Other font as stipulated above, providing a more uniform look to the out-
liner. The default settings are tuned to provide greater visual emphasis on
titles when synopsis text is embedded around them.

When synopses are shown By default, if an item has only a title supplied to it,
and titles are otherwise set up to display bold text, they will instead use
regular text. Disable this if youwould prefer titles to use amore consistent
format. This option is overridden by the Use bold font for… selections
above.

Colors
The following areas of the outliner can be coloured to taste:

— Background: the area behind the text and other content in the outliner.

— Grid: determines the shade used to draw grid rules between rows and/
or columns. These rules are disabled by default, and should be first en-
abled with at least one of the Outliner has horizontal|vertical grid lines
options.
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— Group Titles: folders (and optionally all containers, when the Treat all
documents with subdocuments as folders option is enabled in the Be-
haviors: Folders & Files settings pane (subsection B.4.5)) will use a different
colour text than the rest of the outline, drawing further attention to their
presence in long lists.

— Synopses: changes the colour of synopses text, further distinguishing it
from title text.

B.5.10 Page View
Contains visual settings for the optional Page View mode (View ▸Text Edit-
ing ▸Show Page View), such as paper size, and whether to use this mode in new
projects.
There are additional Appearance tabs involved in the matter of text editing:

1. Appearance: MainEditor (subsectionB.5.8): Provides controls for the basic
default look of the text, background “paper”, margins and whether or not
the text column should have a fixed width or expand to fit the size of the
window.

2. Appearance: Scrivenings (subsection B.5.13): Adjust the separators drawn
between files as well as the font and appearance of section titles within a
Scrivenings session.

3. Appearance: Textual Marks (subsection B.5.16): Settings for how the text
will be marked up, including invisible characters, hyperlink appearance,
the cursor and so on.

Options
Show page view in new projects When enabled, new projects you create will

have the View ▸Text Editing ▸ShowPage Viewmenu toggle enabled.

Use facing pages in new projects Activates the two-page spread as the default
for new projects. To enable this behaviour for existing projects, use the
View ▸Text Editing ▸Two Pages Acrossmenu toggle.

Center pages The page will be centred within the view. Disable this option to
pin the paper edge to the left side of the editor.

Showmargin guides Causes a border to be drawn around the printable area
within the virtual page.

Draw shadow around pages Adds a shadow around the virtual page, offsetting
it from the background colour.
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Spacing between pages Whenmore than one page of text is displayed (or more
than two, if using Two Pages Across), the number of pixels entered here
will buffer each page from the one above it. With Draw shadow around
pages enabled, using a value of “1” will place a thin border between pages,
and “0” will seamlessly flow from one page to the next.

Base page view size on… The shape of the page and margin areas are set using
either your project’s print settings (in File ▸Page Setup…), or the current
compile settings for the project. In most cases compile settings will defer
to the print settings meaning there will be no visual difference between
these options.

Colors
TheBackground colour is used to draw the padding area around the pages them-
selves. To adjust the page colour itself, use the Editor setting in the Appearance:
Main Editor: Colors tab.

B.5.11 Quick Reference
Quick Reference panels are stand-alone windows that feature a simple text edi-
tor or media viewer. There are a subset of options available to them, from both
of these elements, that override similar settingsmade in their respective settings
panes.

Options
Quick Reference panels will inherit basic settings from the Appearance: Main
Editor pane, as well as the Appearance: Page View pane. For example, if Use
fixed width editor is disabled in the Main Editor options tab, then new Quick
Ref panels will wrap to the width of the window. If Show page view in new
projects is enabled in the Page View options tab, newQuick Ref panels will come
up in page view (even for projects that have already been created).

Quick Reference settings are persistent through sessions

A crucial point to keep in mind is that any Quick Ref panels you have
opened within that current session will always go on using whatever set-
tings were applicable when they were first opened. If you wish to fully
reset a session so that panels use your new settings, reload the project.

Highlight current line Enabling this will place a highlighter beneath the cur-
rent line of text being edited, making it easier to see where the cursor is
located on the screen, and easier to return to that point after scrolling else-
where momentarily. The colour itself can be set in the respective “Colors”
tab.
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Text editor margins Sets a visual margin or padding area between the text and
the edges of the text editing column (or the view itself if the Use fixed
width editor option is disabled). You can select a different distance for
horizontal and vertical margins.

The top and bottom margin will only pad the very top and bottom of the
document in the editor; itwill not be seen if youhave scrolled to themiddle
of a long document.

Colors
As with options, there are a few colour choices here that override inspector and
editor settings:

— Page Background: used when View ▸Text Editing ▸Show Page View is en-
abled within a Quick Reference pane, and refers to the padding around
the edge of the virtual paper.

— Notes Background: the background colour of the notes pane in the in-
spector.

— The remainder of the settings are identical to those documented in the
Appearance: Main Editor: Colors tab (section B.5.8).

B.5.12 Scratchpad
Colors
The Scratchpad Notes Background setting adjusts the background colour for
the text editor in thisWindow ▸ShowScratch Pad utility.

B.5.13 Scrivenings
Adjust the separators drawn between files as well as the font and appearance of
section titles within a Scrivenings session.
There are additional Appearance tabs involved in the matter of text editing:

1. Appearance: MainEditor (subsectionB.5.8): Provides controls for the basic
default look of the text, background “paper”, margins and whether or not
the text column should have a fixed width or expand to fit the size of the
window.

2. Appearance: Page View (subsection B.5.10): Contains visual settings for
the optional Page View mode (View ▸Text Editing ▸Show Page View), such as
paper size, and whether to use this mode in new projects.

3. Appearance: Textual Marks (subsection B.5.16): Settings for how the text
will be marked up, including invisible characters, hyperlink appearance,
the cursor and so on.

818



B.5. Appearance

Options
Scrivenings Separator Within a Scrivenings session, individual binder items

will be separated using one of the global presets you select here (Fig-
ure B.15) depending on the type of documents in use within the session—
scriptwriting or normal prose documents. When both kinds of documents
are present in the same session, the scriptwriting divider will take prece-
dence.

The “Divider” and “Dashed Line” settings provide the greatest degree of
visual distinction between sections, while the “Corner” option inserts no
vertical spacing at all, and merely indicates section breaks with a small
“crop marks” in the margin. The latter setting can be more accurate, in
combination with Page View, if your compile settings will be stitching to-
gether text sections without any spacing or headings between them.

Figure B.15 Corner, Dashed Line and Divider separator styles for Scrivenings
mode.

The “Bookish” format is unlike the others in that it changes how it appears
when titles are includedwithin the Scrivenings session. In Figure B.16, we see an
example with the View ▸TextEditing ▸OnlyShowScriveningsTitles for Foldersmenu
toggle enabled. In this case the visible title that we can see at the top of the figure
is being printed by a folder, which contains two text items, each with one para-
graph. A rule is drawn between the folder’s title and the first paragraph because
the folder itself has no text content. Between the two text items (whether they
are titled or not is irrelevant with the aforementioned menu option) is a small
bullet point.
The bullet is what you will ordinarily see with this divider mode with all other

options turned off.

Use page break separators in page layout view… If you tend to use longer text
sections that represent logical chunks of structure in the final work (such
as a chapter or subsection), you might prefer the editor cut to a new vir-
tual page, when using the View ▸TextEditing ▸ShowPageView editingmode.
Select whether this should be doneBefore folders and/orBefore text doc-
uments. If a page break is inserted on account of this feature, no additional
divider will be used.
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Figure B.16 The “Bookish” Scrivenings divider mode.

Scrivenings Titles The settings in the remainder of this panel become relevant
when the View ▸Text Editing ▸Show Titles in Scrivenings menu toggle is en-
abled for a project. The font itself, as well as the text size, can be set in the
respective Fonts tab.

Use title background color When checked, a filled box will be drawn around
the title, accentuating it from regular text in the editor. The colour can be
changed in the respective Colors tab.

When View ▸Use Label Color In ▸Scrivenings Titles is set, this feature will au-
tomatically enable itself for those items in your session that have a title and
a label applied to them,with the label colour beingused for the background
fill. Items with a title but no label will use the normal look (Figure B.17),
and of course items without a title will print nothing at all.

Figure B.17 Label colours are being used in Scrivenings titles with title back-
grounds otherwise disabled.
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Do not show separators above titles Enabled by default, when the View ▸Text
Editing ▸ShowTitles in Scriveningsmenu toggle is enabled, those items with
assigned titles (not adaptive titles) will omit the divider to present a cleaner
overall look. Disable this if you find the result visually confusing or use a
title style that is very close in appearance to the main text.

Fonts
The Scrivening titles setting determines which font and font size will be used
for drawing titles in the editor, when View ▸Text Editing ▸ShowTitles in Scrivenings
is enabled.

Reduce font size per level by… This setting will reduce the font size by the
given amount (in points) for each level of nested hierarchy in the session.
This reduction is performed in an absolute sense rather than relative. If
you select a number of titled subdocuments at level four, they will use the
full reduction in font size even though no larger font sizes are in use.

Minimum font size Use this setting to keep the font size from becoming illeg-
ibly small when working in very deeply nested areas of the outline. This
means that at some levels there will no longer be a reduction in font size.

Colors
The two colour options here configure the appearance of titles when inserted
into the Scrivenings session:

— Scrivening Titles Text: the text colour itself can be adjusted. This has no
bearing on output.

— Scrivening Titles Background: when Use title background color is
switched on in the respective Options pane, this sets the default back-
ground highlight.

B.5.14 Snapshots
Colors
The Text Background colour is used to adjust the overall display of snapshots.
This adjusts their appearance in the Snapshots Manager, inspector pane, main
editors and copyholders.
The settings forDeleted Text&NewText adjust how revisions are marked up

when using comparison mode.
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Figure B.18 Example snapshot comparison view with customised colours.

B.5.15 Target Progress Bars
Progress bars are used in a few places: the Project ▸Show Project Targets… float-
ing panel, the Quick Search utility in the main application toolbar and in
View ▸Outliner Options ▸Progress & Total Progress.

Options
Target progress bars use smooth transition between colors By default, the

three colours you use for progress bar display (in the editor footer bar
and Project Targets window) will be gradually blended as you type. When
this feature is disabled, the progress bar will “snap” from one colour to
the next at the 50% and 100% marks. If you prefer a more noticeable
indication of when you’ve reached a goal, this can be a useful option.

Show progress bars in “Targets and Search” toolbar item By default, theDraft
Target and SessionTargetwill be displayed in themain application toolbar,
integrated into the Quick Search utility (Figure B.19). Disable this option
if you would prefer a cleaner look. You can hover the mouse over this tool
to bring up a numerical display of your progress.

Figure B.19 The Quick Search tool is capable of displaying project goals as
minimal progress bars.

Use custom colors in toolbar progress bars Instead of using the default colour
(the global system accent colour), have theQuick Search tool use your Set-
tings in the respective Colors tab.

Colors
These settings impact the appearance of progress bars in the outliner and Project
Targets panel. They can also optionally be used in the Quick Search tool, when
Use custom colors in toolbar progress bars is enabled in the respective Options
tab.
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Progress bars blend between three different colours. The Start Color is used
when the word count is at its lowest. As you write toward your goal, the bar will
gradually blend up to theMidway Color, finally moving toward the End Color
as the word count reaches the goal.
TheOverflowColor is usedwhen Showoverrun is enabledwithin the Project

Targets option area, as a per-project setting (section 20.1.1).

B.5.16 Textual Marks
Settings for how the text will be marked up, including invisible characters, hy-
perlink appearance, the cursor and so on.
There are three additional Appearance tabs involved in thematter of text edit-

ing:

1. Appearance: MainEditor (subsectionB.5.8): Provides controls for the basic
default look of the text, background “paper”, margins and whether or not
the text column should have a fixed width or expand to fit the size of the
window.

2. Appearance: Page View (subsection B.5.10): Contains visual settings for
the optional Page View mode (View ▸Text Editing ▸Show Page View), such as
paper size, and whether to use this mode in new projects.

3. Appearance: Scrivenings (subsection B.5.13): Adjust the separators drawn
between files as well as the font and appearance of section titles within a
Scrivenings session.

Options
Show invisible characters when selecting text By default, when select text in

the main editor views and Quick Reference panels, invisible whitespace
characters will be automatically highlighted for you. This will include
carriage returns, line breaks, page breaks and tabs—not spaces or non-
breaking spaces.

Underline links Whendisabled, document links, hyperlinks, and notation links
will not be underlined in the rich text editing areas.

“Hide Markup” hides… The View ▸Text Editing ▸HideMarkupmenu toggle is use-
ful for presenting a cleaner version of your text, sans editingmarkings and
digital markings. Disable any of the provided options if you would prefer
to have that type of marking visible in all cases.

Colors
A few types of textual markings can have their colours adjusted. Some of these
settings can be overridden by composition mode settings.

823



B.6. Corrections

— Insertion Point: the cursor, caret or insertion point can be changed to
tune its visibility. Also note you can disable blinking and set its thickness
in the Editing: Options settings pane (subsection B.3.1).

— Invisible Characters: displayed when the View ▸Text Editing ▸Show Invisi-
bles menu toggle is enabled. They are also by default displayed with se-
lected text ranges.

— Inspector Footnotes: the universal colour used for footnotes as highlight
markings in the text and the backgrounds in the inspector and popover, as
well as the bubble for inline footnotes.

— Links: all hyperlinks in text editors, those pointing to internal resources
within the project, as well as to files on your system or resources on the
Internet, will be printed in this colour.

— Search Results Highlights: the highlight colour used to emphasise search
terms found within the text.

— Search Results Underline: the underline adornment below the search re-
sult highlight.

B.5.17 Light Editors
This section will only appear when using Dark Mode with theUse dark appear-
ance inmain window editors setting disabled (or when themain editors are left
light), in the Appearance: General Interface settings pane. It merely provides ac-
cess to a select portion of standard Light Mode settings from the “Main Editor”
and “Textual Marks” sections. Please refer to the documentation on these sec-
tions for how to use the individual color settings. Changing these settings will
directly impact how text looks while in Light Mode.

Return to chapter ⤴

B.6 Corrections

Figure B.20 The Corrections settings pane

The Corrections tab contains optional typing aids, such as typographic substi-
tutions (superscripted ordinals, em dashes, smart quotes, etc), word completion,
and control of the spelling engine. Not all of the places you can type in Scriv-
ener will support these aids. For more information on corrections and auto-
completion, read Auto-Completion (section 20.2).
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Upgrading from Scrivener 2

Looking for the setting that changes whether or not spelling and gram-
mar check is enabled innewprojects? This behaviour is now learned from
your previous choice, via the Edit ▸Spelling and Grammar ▸Check Spelling
While Typingmenu toggle. In that sense it is similar to how the main ap-
plication toolbar works. If you turn it off, you’ll never see it in the future
projects you create. If you turn it back on, you’ll start seeing it again. As
before, projects remember their own settings once they have been cre-
ated.

B.6.1 Auto-Correction
Correct spelling errors as you type Causes the software to correct common

spelling errors and typos automatically. This feature can be trained with
new words you’ve added to the dictionary. As with the spell check feature
in general, it is maintained bymacOS across all applications. If you train it
to not correct the name of your protagonist to some random word, you’ll
find that training applies to Mail and other Mac software, and vice versa.

Fix capitalization of sentences Will fix letter case issues if a lowercase letter fol-
lows a period and a space. You may need to temporarily switch this off to
correctly key in some phrases, such as “10 a.m. to 12 p.m.”. In that case the
period after the “a.m.” would cause the word “to” to be capitalised incor-
rectly. Disable the option to key in the phrase, and then enable it again.

Capitalize ‘i’ Will automatically capitalise the letter ‘i’, if typed by itself.

Superscript ordinals (1st, 2nd, etc.) When numbers are typed with a following
ordinal, the ordinal text will be superscripted and set to a smaller font.
This setting is only available in English (1st, 2nd, etc.) and French (1er, 2e,
etc.).

Symbol and text substitution Enables the native macOS text substitution en-
gine. To configure your abbreviations and expanded text, click the System
Text Settings… button at the bottom of this settings pane (or load the Sys-
tem Settings: Keyboard pane and click the Text Replacements… button).8

B.6.2 Punctuation
Enables commonly used symbols and typographic conventions, by detecting
when their use is appropriate as you type. Not all text entry areas are capable
of using substitutions, but they will always be available in the main text editors.

8Onolder versions ofmacOS themenucommandwill be printed as “Preferences”, and references
to System Settings (“System Preferences”) locations may no longer be accurate.
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Use smart quotes (“ ”) in new projects Will convert inch and foot characters
into typographic quotes as you type, according toyour system’s keyboard
settings. To customise these, click the SystemText Settings… button that is
provided at the bottom of the window.

Use smart dashes and ellipses in new projects This uses theMac option to tog-
gle this behaviour, which also includes ellipses on 10.8 systems and above.
Subsequently, the following option, Replace Triple periods with ellipses,
is only of use to those using older versions of macOS.

Disable smart quote, dashes and ellipses in script mode The punctuation op-
tions above will be ignored while writing in script mode.

B.6.3 Data-Detection
Automatically detect web addresses When you conclude typing in text that

looks like a web address, Scrivener will automatically generate a web link
for it so you can click on it and open the link in your web browser.

Automatically detect [[document links]] Scrivener document titles can be
linked to by surrounding the title in double-brackets. If the text between
the brackets does not match any existing binder item, you will be taken to
an interface for creating a new linked document. For more information
on these feature, see Linking Documents Together (section 10.1).

Auto-detect dates, addresses, etc Switches on the operating system’s data de-
tection capabilities, which will attempt to scan for common text patterns
and treat them appropriately. For instance if it finds a sequence of text
that looks to be a postal address, it will give you the option to add it to
your Contacts list. Dates can be turned into events in Calendar.

B.6.4 Auto-Completion
Word completion is usually used to speed up the entry of places and names
and other common project specific terminology. Each project’s custom auto-
complete list can be accessed via Project ▸Project Settings…, within the Auto-
Complete list (section C.6). However, it can be set up to use the entire language
dictionary and attempt to complete every word you start typing.

Suggest completions as you type Enables word and phrase auto-completion in
general. When this is unchecked, no auto-completion will ever be dynam-
ically performed, but you can always manually request word-completion
with the Edit ▸Completions ▸Complete (⌥Esc) menu command.

Words will be presented to you in a list of narrowing specificity the more
you type. Once you’ve narrowed it down to the right word, or select one
from the short list, you can tap Return or Tab to select it and proceed on
with the next word.
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In script mode only Disable the auto-completion feature unless the editor has
been set to script mode. This is the default behaviour.

Only suggest completions from custom auto-complete lists Restricts the
auto-completion list to only those words that you have specified in the
Project Settings: Auto-Complete List pane (Appendix C). When this
option is disabled, the completion engine will attempt to find words using
the exhaustive built-in language dictionary.

Return to chapter ⤴

B.7 Keyboard
The Keyboard options tab is where you can create and modify shortcuts to vari-
ous commands in Scrivener. If youfind a built-in shortcut to be awkward to press
on your particular keyboard, or you just don’t like a particular arrangement, you
can modify them most shortcuts in the software with this tab.
To find a shortcut either navigate through the tree view to find the command,

or use the Filter search bar at the top to rapidly locate a command by part of its
name. You can search for any of the text that you see in the table, including the
descriptive name, actual menu name, or even its shortcut.

Limitations
At this time, not all of the menu commands have been supplied to you in
this list. Adding entries to this list requires individual care, and the list of
commands you can customise will continue to grow in future updates.

To change a shortcut, select its row in the table and note that the “Key Se-
quence” field toward the bottom will be filled with the currently assigned short-
cut:

— Click the Record button to capture keyboard input directly.

— If the shortcut you used conflicts with another one in the list, it will be
highlighted in red, and there will be a convenience button you can click to
run a search for that shortcut. If it is black, then you are good to go.

Not every conflict ismeaningful, as some commands are impossible to trig-
ger depending on the context. It is okay to leave commands with conflict-
ing shortcuts if only one command will be available at a time.

— The recording mechanism will only capture one key sequence and then
stop recording. To create “chords” as they are sometimes called, where one
uses a sequence of shortcut keys one after the other, you will need to type
the sequence by hand into the field, separating each part of the sequence
with a comma.
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— Clicking the Reset button to the right of the Record button will return the
selected shortcut to its default setting.

The Import… and Export… buttons at the bottom of the table let you manage
shortcut presets. You can load templates from a file, which is a useful way of
restoring your settings from a backup, or copying your favourite shortcuts from
one computer to another, without changing all of the application’s settings.
The export button has two options:

1. To File: exports a shortcut template for use with the aforementioned im-
port feature. Useful for backing up your settings to a file, or transferring
them between computers.

2. For Printing: Creates a human-readable text file, suitable for use as a refer-
ence.

Return to chapter ⤴

B.8 Sharing

Figure B.21 The Sharing settings pane

Scrivener supports a wide variety of file formats, both for import into a project
and for exporting or compiling. This pane has been separated into a few tabs,
which will be covered individually in the following sections. It mainly concerns
the file formats that Scrivener understands and can do things with. You can also
import any kind of file at all into the binder’s non-draft areas, but with limited
support for display and conversion.

B.8.1 Import
Adjusts how files are imported into Scrivener as binder items, and where appli-
cable, how their formatting will be converted to a format Scrivener can use.

Rich Text
The following settings will impact not only how documents are imported into
Scrivener, but howfileswill be synced into the projectwhenusing the RTF format
in conjunction with Synchronised Folders (section 14.3).
Owing to the fact that RTF does not have a separate way of addressing these,

there is no way for Scrivener to retain a mix of inline and inspector notes. When
importing or syncing, they will all be converted one way or the other.
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Import comments as inline annotations Any margin comments found within
the imported word processing file will be converted to inspector com-
ments by default. Enable this option if you prefer inline annotations.

Import footnotes and endnotes as inline footnotes When a document con-
tains footnotes or endnotes theywill be converted into inspector footnotes
by default, keeping their content out of the main text editor. Enable this
option if you prefer inline footnotes.

Ignore stylesheet information in imported documents When importing or
pasting rich text that has been styled, the style information itself will be
removed from the text. The formatting will remain intact in most cases,
but the link tying that formatting to a specific style will be severed.

Update styles in pasted text to match destination styles When pasting styled
text from one project into another, if styles with the same name are found
in the target project, the text assigned to those styles will have their for-
matting updated tomatch the stylesheet in the target project. Disable this
option to instead retain the original formatting from the source text and
strip stylesheets from the pasted text.

By example: some text is copied from Project A, which has a style called
“Block Quote” in it using a 3cm left indent. The text is pasted into a dif-
ferent project that also has a “Block Quote” style, but in this case with a
1.27cm left indent. The pasted text will have its formatting updated to
have a 1.27cm indent (and any other variations that are set by that style).
With this option disabled, the pasted text would retain its 3cm left indent
but no longer be considered a “Block Quote”.

Limitations
This capability only functions when pasting text from one project into
another, not from any other source of styled text. Further, an important
distinction to be aware of is that if you use the File ▸Save As… command,
use two projects derived from the same template, or any other form of
duplication with your file manager, then for the purposes of this feature
they will be considered the same project.

Plain Text
Plain text files are considered those that do not have some form of recognised
formatting typed into them. For example, .html, .opml and even .rtf files for that
matter are technically plain text files, but Scrivener will import them as format-
ted text rather than the raw codes used to mark the text as formatted.

Imported plain text files use font… When importing plain text files (usually
they have a .txt file extension, but Scrivener will assume any file without
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an extension is a plain-text file) you can have Scrivener either apply the
current default formatting, or optionally use a special font for these files.

Plain text import formats In addition to treating any file without an extension
as plain text, Scrivener defines a number of common file formats as plain
text out of the box: .markdown, .md, .mmd, .tex and .xml.

Use this table to add your own extensions to the recognised file list. There
is no need to specify the ‘dot’ in the extension list, just the letters (xml not
.xml). This option can be useful if a file is being converted to rich text
and you would rather it not be. For example, if you add ‘html’ to the list,
Scrivener will import the raw HTML code into the text editor rather than
handling it as awebpage. Theother effect is tohave the importer recognise
formats as plain text even if the operating system considers them special.
The default .log extension is one of these, whichwill import as a read-only
research document otherwise.

HTML
Convert HTML files to… Influences how .html (or .htm) files will be handled

when importing them into a project binder. The “WebArchives” option
will package the document into Apple’sWebArchive format, which is view-
able in many applications and will retain much of the document’s original
formatting.

The “Text” setting will preserve basic formatting and allow editing,
but complex page formatting will be lost. You can convert individ-
ually imported web documents to text at any time with the Docu-
ments ▸Convert ▸Web Page to Textmenu command.

Convert importedWebArchives and web pages to text You can also have im-
ported web pages (via the File ▸ Import ▸Web Page… command), or We-
bArchives files imported off of the disk, converted to rich text as well.

Cross-Platform Compatibility

If you plan to make project resources available cross-platform between
iOS,Windows or macOS, you should use the “Text” option in both cases.
Since this option coverts the web file to Scrivener’s internal rich format-
ting, it will at that point be the same as any other text document in your
binder. Another alternative is to save the page as a PDF from your web
browser.
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OPML
When OPML files are dropped into the binder, Scrivener will attempt to convert
these outlines into Scrivener outlines. This can be useful if you do your initial
brainstorming in a dedicated outliner application.

Import outline into main text For those outliners that treat the outline like a
folding text editor—where each paragraph is an outline node and there are
no formal headings separate from content—this optionwill cause the con-
tent of the outline to be imported into the main editor, leaving all binder
item headings empty.

This option will disable the folling setting. All notes, if any exist, will be
imported as document notes.

Import notes into… Some applications support adding notes to each outline
heading. If such notes exist, this setting will determine how these notes
will be inserted into the binder items: as the synopsis, main text, or the
document notes.

When converting OPML notes into main text, all imported item types will
use the document text type, so that you can more easily see the imported
main text. The other two options will use folders for parent items.

Create folder to hold imported OPML items Enable this option if you want
dropped OPML structures to be contained inside of a new folder, rather
than being generated directly into your existing Binder structure at the
selected point of import.

Scapple
Import first lines of notes as titles only In all cases, when dragging Scapple

notes into Scrivener the first line of each note will be used to establish the
binder title for each item created from the imported Scapple notes. With
this option enabled, that first line of text will also be removed from the
imported main text, as shown in the lower editor example in Figure B.22.
If the note consists of only one line then it will not be removed.

B.8.2 Export
Rich Text
Resolution for PDF images converted to PNG Since most word processing for-

mats do not support embedded PDF files, any PDF graphics that have been
embedded in Scrivener’s text editor will be converted to PNG raster graph-
ics upon compile.
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Figure B.22 Scapple notes can have the first line treated as a title upon import.

This option lets you determine what resolution the PNG should be set to.
The default of 150 dpi (dots per inch) is a common standard in the pub-
lishing industry for simple illustrations and will ensure a large enough in-
termediate format for converting vector graphics to raster graphics with a
balance between quality drop and file size. You can tune this upward if the
resulting graphics are still not to your requirements and appear blurry, or
if you have been instructed otherwise by the publisher.

Convert underscores to underlines when converting Markdown When com-
piling to a rich text format, it is possible to convert Markdown found
in titles or even text and notes. With these options enabled, Scrivener
will convert underscore formatting (_underline markers_ as opposed to
*asterisk markers*) to underlined text instead of italics. It is important
to note thatMultiMarkdown, Pandoc andmost other popularMarkdown-
based conversion systems will treat underline markers as synonymous
with asterisk and produce emphasis styling (commonly italics), so use of
this setting can produce different results between rich text output and
MMD-based output if one uses the same source document for multiple
compile formats.

Include image file names for Nisus Writer (RTF only) If your primary word
processor is Nisus Writer Pro, or you work with someone on a Mac who
uses it, this optionwill add the names of images to their internalmetadata.
This option has no impact in other word processors to date, so it is safe to
leave it on unless you encounter compatibility warnings with it.

Do not include stylesheet information By default, any styles you apply to text
either in the editor, or automatically as part of your compile settings, will
be defined in the output file if the format supports stylesheets. If you pri-
marily use stylesheets for your own purposes, or use a word processor that
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doesn’t support them cleanly, then enable this checkbox to strip them out
of the files.

HTML
These settings will affect the manner in which compile produces HTML andWe-
bArchive files, but not the MultiMarkdown HTML format, as that uses its own
system.

Document type Refers to the web standard, or DocType, that should be used
during export. If you are unfamiliar with web standards, chances are the
default setting of the older “HTML 4.01 Strict” will suffice. If you intend to
publish your writings within a modern blogging system, however, in most
cases using one of the modern XHTML formats will be more compatible. If
you require HTML5, consider using the MultiMarkdown workflow.

Styling Determines whether and how Cascading Style Sheets (CSS) should be
embedded into the compiled web file.

— Embedded CSS: declares CSS styles in the head of the exported file,
allowing you to easily adjust themwith your own custom stylesheets.

— Inline CSS: places styling directly into the HTML elements themselves,
and so is useful in situations where you wish to override default
stylesheets.

— No CSS: in many blogging and content management systems, all pre-
sentation formatting is already handled for you, and this will be the
best option. Text editor and compile formatting will be irrelevant.

Preserve white space Attempts to preserve tab characters by wrapping them in
a style that declares them to be “pre-formatted” (<pre>). Although this
technique may not work in all browsers, it is generally safe to leave it en-
abled. It has been known to cause some e-readers to break formatting.

MultiMarkdown export language TheMultiMarkdown engine will handle the
conversion of typography for you, which is particularly useful if you intend
to keep your source documents ASCII compatible. These are language spe-
cific, so choose the language converter most appropriate to what you are
writing in. This will insert a “Quotes Language” metadata key into the
MMD metadata block. If you supply your own such key by hand in your
compile settings then the compiler will defer to your request.

If you make use of Scrivener’s smart quote feature this setting will be of
no impact to you, as the form of punctuation will be hard-coded into the
text as Unicode characters. Formaximumflexibility you should straighten
quotes in your compile settings, or not use them in the first place when
working with Markdown-based systems.
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JPEG images compression Use the slider to adjust the amount of compression
used when either embedding images in the file (for rich text formats) or
compiling JPEGs as loose files with HTML and Markdown-based formats.
The “Min” (left) slider position will result in the best quality images, at the
expense of file size (better for print). The “Max” (right) slider position com-
presses images asmuch as possible, resulting in smaller file sizes (better for
online or e-publishing).

B.8.3 Sync
Concerns the automatic import/export and merging of documents when work-
ing with Scrivener for iOS (section 14.2) or using Synchronised Folders (sec-
tion 14.3).

Mobile Sync
These options pertain to how modifications, made with the mobile version of
Scrivener, will be will be merged into the project. “Sync” in this context refers to
the merging of changes made to a project, no matter how that project may have
arrived on your computer, not the process itself that would do so. These options
thus even have an impact when the project was zipped and emailed to you.

Place documents affected by sync into a “Synced Documents” collection
Created the first time you sync, this collection will continue to be re-
freshed every time the project is synced. If you would prefer this list not
be created or updated, disable this option. You can also “freeze” the list by
cloning a new collection (section 10.2.2).

Automatically show the “Synced Documents” collection after sync Enable
this option if you would prefer to address synced documents immediately
upon syncing, by having the binder sidebar replaced by this collection list.

Take snapshots of updated documents Documents that have beenmodified in
themobile versionwill have a snapshot takenof themdirectly beforemerg-
ing changes. Given that mobile Scrivener has no snapshot capability of its
own, this feature can stand in for that, ensuring a remote editing session
has dedicated snapshots on each edited item.

Be aware that every single sync will cause a snapshot to be created for each
edited binder item. Over time these can accumulate, bloating the size of
your project, and potentially slowing down sync from the device. It might
be a good idea to prune them every once in a while with the Snapshots
Manager (section 15.8.5).

Check for changes every… If a project is left open on your computer while you
take it mobile, this setting will cause the software to periodically check the
internal state of each open project for incomingmobile edits (whichwill of
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course arrive automatically if Dropbox is left running and you sync while
working on the go).

Lowering the check rate will decrease the odds of accidentally conflicting
the project, at the expense of using additional resources (andbattery power
if that is a concern) for each project you leave open. If you do not use
Scrivener for iOS or never sync directlywith it, preferring filemanagement
utilities, then you should switch this off to conserve power.

Projects will always be checked when their windows are brought to the
foreground. This check is mainly a protection for those cases where the
foremost window on your computer is the very same project you are edit-
ing with your mobile device.

External Folder Sync
Remove stylesheet information when syncing with a folder Given that this

option will inevitably destroy any stylesheet assignments you make using
Scrivener’s editor, it will mainly only be of interest to those who prefer
not to use stylesheets at all, and wish to ensure that any edits coming in
from the synced files are likewise cleaned of them.

Convert text inside (( )) and {{ }} to inline notes when syncing plain text
When syncing with plain text files, your inline annotation and footnotes
will be enclosed within special brackets. These brackets will be searched
for when you sync back, converting text found within them to notation
format again in Scrivener. The brackets used are:

((Text of inline annotation))
{{Text of inline footnote}}

You can type in these brackets in the external files to add new notes to
your text while on the go. Because this only works with inline notation,
you will need to convert your inspector comments and footnotes to inline
if you intend to take advantage of this feature.

B.8.4 Conversion
The settings in this tab alter how word processing documents will be converted
to and fromScrivener’s core internal format, RTF. You should not ordinarily need
to change these settings, but if you run into compatibility or performance issues
relating to conversion, check back here for a few troubleshooting options.

Use Java converters for .docx This checkbox sets the conversion engine used
for all forms of import and export activity, including drag & drop into the
binder, bulk file import, export, and compilation for the DOCX. In most
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cases youwill want to leave this option disabled, as Scrivener’s native DOCX
engine is much faster.

You will need to have a functional Java installation on your Mac to enable
this setting.

Microsoft .doc This setting is only available if Java cannot be found on your sys-
tem. Inmost cases, youwill want to leave this set to the default: RTF-based
.doc file. Scrivener’s RTF export engine supports a great many features that
macOS’ built-in exporter does not.

However, if you are working with an application that cannot read RTF files
at all, and cannot install Java to get a higher quality .doc file, you will want
to change this option touse the standardmacOSexporter. Thiswill reduce
the quality of the document.

UseWord-2011 compatible copy If checked, copying and pasting from Scriv-
ener into Word 2011+ will use true footnotes and comments. Having this
feature enabled can reduce the quality of copy andpaste between Scrivener
and other native macOS software.

Return to chapter ⤴

B.9 Backup

Figure B.23 The Backup settings pane

Scrivener has a fully automated backup system that keeps individual self-
contained mirror copies of your project, set aside in case you should ever need
to roll back to a previous version of the project. The options in this tab will con-
trol the various aspects of whether, and how these copies are created. Individual
projects can override some of these settings in the Project Settings: Backup pane
(section C.9).

Turn on automatic backups Enables the automated backup system. It is best to
leave this turned on, unless for performance or security reasons you wish
to control the process manually (subsection 5.2.2). Individual projects can
opt out of backups in Project Settings.

Back up on project open Whenever a project is opened, a backup will be cre-
ated before you can begin working. This can slow down load times with
large projects, but ensures you have a snapshot of how things were before
you started a session.
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Back up on project close Whenever a project is closed (either directly or via ap-
plication shutdown), a backup will be created. This can slow down close
times in large projects, but ensures you have a snapshot of how thingswere
when you concluded a session. When combined with the above option,
you will have a complete before/after pair for each session.9

Back up with each manual save Have the software create a backup copy when-
ever you manually save a project with File ▸Save (⌘S).

Back up before syncing with mobile devices When opening and syncing
changes made with Scrivener for iOS, a backup will be created directly
prior to sync. This backup will contain the project as it stood before
syncing the mobile change logs with the formal project. This option is
enabled by default, but will be of no impact to you unless you work with
Scrivener mobile.

Compress automatic backups as zip files (slower) If you are storing your back-
ups on a network drive, or Internet synchronised service likeDropBox, this
optionwill not only save space and reduce data usage when uploading, but
will protect the project format from the sorts of damages which can occur
when lots of files are transferred over the Internet. However, it will ad-
versely affect the performance of your backups, as Scrivener not only has
to collect and assemble a copy of the project, but compress it as well, be-
fore letting you return to yourwork. With very large projects, this can take
many minutes to complete, and turning it off can save a lot of time.

Use date in backup file names Causes backups to be saved with the current
date and time, making it easier to sort by recency in the Finder. It also
means each backup filename will be unique, which could be of use with
an external backup system. Be aware that with this setting off, Scrivener
will rotate through a set number of serialised file names, which means the
most recent copy may not be the one with the largest number.

Only keep nmost recent backups To avoid the proliferation of hundreds of
backups, a limiter is employed, which will restrict the number of back-
ups to five copies, by default. Once this amount is reached, it will remove
the oldest backup to make space for the new one. You may find this needs
adjusting if your work habits cause backups to overwrite each other too
quickly. As a rule of thumb, it is good idea to have at least three or four
days of backups available.

If you would rather Scrivener never delete old backups, disable the feature
with the checkbox.

9 And you should probably in that case consider saving more than five copies total, via theOnly
keep nmost recent backups setting.
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Backup location Determines the folder where automatic backups will bemain-
tained. If you would prefer these backups be kept somewhere more visi-
ble, or in a synchronised folder, external drive, or secured area, click the
Choose… button and use the folder navigator to select the destination
folder. If you choose a location that later becomes invalid (a common ex-
ample is external drives), Scrivener will immediately warn you as soon as
it tries to back anything up.

As a convenience, you can quickly access the backup folder by clicking the
Open backup folder… button.

Backups should never be mixed with working projects!

In recent years we have noted a growing trend of people storing their au-
tomatic backups in the same location where they keep their live projects.
This is an extremely risky way of working, and there is no advantage in
doing so. A warning has been added to the software when it detects this
is what you are doing. Ideally, your backup folder should be kept as far
out of harm’s way as possible. Our defaults place them in hidden folders
for this reason.

Return to chapter ⤴
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Where application Settings adjust how all projects and the software itself
functions, individual projects have their own settings as well, which can in some
cases override global settings. We carefully designed our built-in templates and
even the blank starter to be as broadly useful as possible out of the box as pos-
sible. You might never even need the stuff in this appendix! But if you like to
tinker, as usual, we’ve got you covered.



C.1. Copying Settings Between Projects

Project appearance and behaviour settings

In addition to the settings foundwithin this pane, most settings that per-
tain to how a project looks or in some cases behaves, are found in the
menus that have an impact on the appearance or functioning of a project
window, like View ▸Outline ▸ShowSubdocument Counts in Binder. If you’re
looking tomodify a particular aspect of how the project works, and don’t
find an option here, then consult the general documentation on the fea-
ture. Tips on configuration are often grouped together toward the bot-
tom of these sections.

To open the Project Settings panel:

1. Use the Project ▸Project Settings…menu command, or the⌥⌘ , shortcut.

2. Youmay also end up in this panel if you use the “Edit…” options from some
of the various inspector tools that tie back to a specific tab within it. For
example if you select “Edit…” from the bottom of the Label selector at the
bottom of the inspector, you’ll be taken to the Label List tab in project
settings.

Once you have made all of the changes you require, click the OK button (or
press Return) to save them into the project. Otherwise click Cancel (or press Esc)
to discard the changes you’ve made.

Save yourself setup time with project templates

If you find yourself changing a number of these to the same sorts of set-
tings every time you start a new project, you should consider creating a
starter project template, with your preferred settings already set up and
ready to go (subsection 5.4.3). Many of the built-in templates will have
some changes made to their settings for you, particularly in the Section
Types tab.

C.1 Copying Settings Between Projects
Several of the panels in the Project Settings window can share their settings with
other projects via drag and drop, or copy and paste. In most cases, all you need
to do is open settings for both projects at once, and drag and drop items between
respective panes. For example, you can use the ⌘A shortcut to select all of the
labels in a project and then drag those labels into another project’s label list.
Here are the panels that can share settings, and any notes pertaining to them

(if you do not see a section in the list then its settings cannot be transferred be-
tween projects):
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— Section Types: considering the complexity of the second pane, you can-
not drag and drop settings. You can export and import settings as files
however. Refer to Transferring Section Types Between Projects (subsec-
tion C.2.4) for tips.

— Label List: supports dragging and copy/paste. When importing duplicate
names, you will be asked if you wish to create new labels out of them, or
simply update the colour assignments in the target project.

— Status List: supports dragging and copy/paste.

— Custom Metadata: supports dragging. All settings associated with the
fields will be copied along to the target project. Duplicate field names are
allowed, so if you import fields with existing names they won’t update or
change existing fields, instead creating new fields.

— Auto-Complete List: supports dragging and copy/paste. Entries that have
both the same term and scope will be ignored as duplicates. If the same
phrase exists in a different scope from the target project, it will be added
under the dropped scope.

— While not related to project settings directly, a form of setting you will
probably be interested in copying as well is a project’s stylesheet. Doing
so before you copy text is essential to keeping its style assignments intact.
For further informatio, refer toCopying Stylesheets Between Projects (sec-
tion 17.5).

C.2 Section Types
This panel (Figure C.1) is the dictionary by which you’ll define items as having a
type, in the binder. When a particular folder is set to export a chapter heading—
perhaps using its name as the visible title of the chapter for the reader’s benefit—
it is in this panel that you’ll have a type listed as “Chapter”. This is also the place
where you will design how these types can be automatically applied to the fold-
ers, files and file groups in your binder; you needn’t remember to assign “Chap-
ter” to each and every folder you create, you can instead state that all folders
ought to act like chapters by default.

Types are not formatting, yet…

It is good to be aware of the differences between calling something a
thing, and then formatting that thing based on what it is. Everything
we do in this section has nothing directly to do with what your compiled
file will look like, and you’ll find not a single shred of formatting in this
pane. All we are doing is setting up a framework for how items can be re-
ferred to as we write. Later on we can get into what these types actually
look like.
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Figure C.1 The Section Type settings used by the “Novel (with Parts)” project
template.

If this is your first time playing with Section Type settings in this panel, you
might want to start with some very basic settings. I would recommend creating
a project using a blank starter to experiment with.1

See Also…
— Section Types (section 7.6): a basic introduction to the usage of section

types in a project.

— Project Settings (section C.2): how to set up section types in your project
settings, and optionally configure how they will be automatically assigned
to items in the outline structure.

— Section Layouts (section 23.3): how theywill end up being usedwhen com-
piling your draft to a final format.

— You can search the project for all documents of a particular type with
Project Search (section 11.1), and filter the outliner and corkboard likewise
(subsection 11.4.3).

— If you’d prefer a more hands-on approach, the Interactive Tutorial, avail-
able from the Helpmenu, also contains a step-by-step guide to building a
simple set of section types and then learning how to compile with them.
We also have video tutorials available on our site.

1 For things like this, I like to create “throwaway” projects on the Desktop. When I’m done ex-
perimenting, I can close it and delete it.
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C.2.1 What Are These Levels?
At the most basic level (pun intended), if you want all folders to print a certain
way when compiling then click in the “Section Type” column to the right of the
“All folders” listing and choose the desired type from the dropdownmenu (you’ll
find the Blank starter project already has a sensible assignment of “Heading” for
all folders). If you clickOK on the Project Settings panel now and examined a few
folders, you should find they are now assigned to the SectionType (assuming you
hadn’t manually set them to something else beforehand).

Upgrading from Scrivener 2

If you’re a veteran to Scrivener, you’re probably familiar with the “For-
matting compile option pane” in the previous version, and you might
already be seeing some similarities between how that pane worked and
what you’re seeing in the second tab. They in fact work very similarly
(and you can probably skip to the next section (subsection C.2.4) if you’re
a pro at it)—where in the Formatting pane you were assigning the for-
matting directly to levels as compile settings, now you will be assigning
abstract types to levels, and not worrying about the formatting until later
when you compile.
There are numerous advantages to this new method, and you should

find most of it works how you’ve grown used to using this kind of tool
in the past. The only important difference to be aware of is that there is
a new top level “root” that is higher than level 1. We’ll explain what that
means below, but be aware that a “Level 1 folder” still means what it did
before: the level of folders, files or file groups directly beneath the Draft
folder.

Figure C.2 The result of adding a new level to the folder row.

Some projects are going to need a little more than that however, so let’s take
a look at what levels add to the mix: select the folder row again and click on
the “Add Level” button beneath the point marked (b) in Figure C.1. The original
row will be renamed to “Root folders”, and a new row will be indented beneath
it, labelled “Level 1 folders and deeper”. If you have a little hierarchy in your
binder to play with, you will note that the top level folders in your binder (such
as “Draft” and “Research”) are no longer highlighted in yellow while this row is
selected. If you add another level, this row will be renamed to “Level 1 folders”,
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and the new row will be “Level 2 folders and deeper”. The most indented row
will always affect all of the indent levels beneath.

Figure C.3 How levels in the structure panel relate to indented items in the
binder.

In the upper section of our second example (Figure C.3)2 we have an excerpt of
the settings (file groups and files have the same assignments, so they are omitted
to save space) using some example section types literally named “Level 1”, “Level
2” and so forth, and have then applied these section types to their matching level
depths. Below the rule we have an outliner view set up to show the “Section
Type” column (View ▸OutlinerOptions ▸SectionType),3 and a few files, folders and
file groups at different levels to better demonstrate how indenting items in the

2 To play with this sample project, download the Extras Pack (Appendix G) from our website and
look for a project called: “2–sectiontypes–simpleexample.scriv”.
3 If you‘re curious as to how it got so colourful, we’re using the View ▸Use Label Color In ▸Outliner
Rows option along with some labels assigned to these items.
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outline means changing their level, and thus changing their corresponding sec-
tion type assignment.
These settings probably wouldn’t be very useful to any real-world projects, but

with each level assignment clearly labelled by its number, you can see how “Pink
page” being indented beneath the level 2 “Pink folder” makes it a level 3 file. The
“Blue page” on level 3 is a file group, indicated by the stack of paper icon, since
“Green page” on level 4 is indented beneath it. The two “Orange” items are on
level 4 and 5, but since we only defined up to four levels of depth, “Orange Page”
uses the same assignment.
If you have opened the sample project, take a moment to move items around

and add a few of your own; see how these section assignments change in real-
time within the “Section Type” column. You could also try clicking into the sec-
tion type cell for one of the items and setting it to something else manually. It
will be printed in regular full black text and no matter where you place the file,
it will always use the assignment you gave it.

C.2.2 Section Types Tab
Thefirst tab in this pane contains a simple list of every type defined in the project.
Some projects may only need a couple of types, others may require dozens. The
list of types is the “menu” from which we can describe how individual items are
to be thought of. Is it a “Chapter Heading”, or a “Short Story”? Or maybe it is
just an “Equation” or “Glossary Entry” in an “Appendix”. These are all examples
of Types.

— To create a type, click the+ button, marked beneath (a) in Figure C.1. Type
in the name of the type as you would like for it to appear throughout the
project, and press Return to commit the name.

— Change the order in which types will appear in various menus and the
compile interfacewith drag and drop. This has no consequence other than
how you will see them listed.

— To remove types, select them from the list and then click the− button, also
under (a). If any items in the binder have been assigned to the deleted type,
they will fall back to whatever automatic assignment they would have had
otherwise.

No warnings will be given when deleting types, but if you make a mistake
remember you can always click the Cancel button on the Project Settings
pane, and try again.

C.2.3 Default Types by Structure
Within the second tab is where we can optionally take the types created in the
first tab and assign them to icon types, so that we don’t have to do that manually
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ourselves as we develop the draft. At its most basic you’ll find three rows cor-
responding to the three core binder item types that can be found in the draft:
folders, file groups, and text files. If you leave it at that, you can have up to three
automatic assignments in your project based on these types. In fact the blank
starter only distinguishes between two types, treating file groups identically to
files. Here is how to use this tab:

— Select a row to make changes to a particular level and icon. Correspond-
ing levels that match this description will be highlighted in yellow in the
binder, making it easy to see what parts of the draft you’ll be impacting
with your settings. With a row selected:

– Click the “Add level” button, under the (b) marker, to create a new
row indented beneath the selected row. It will copy the selected type
assignment for your convenience.

– Click the − button to remove that row from the table. If there were
indented levels beneath the deleted row, their assignments will sim-
ply move “up” a level, rather than being deleted as well.

– The last row for a category of icon cannot be deleted. If you don’t
intend to use a particular category, like file groups, you can safely ig-
nore them in the pane.

— Click into any of the dropdown fields in the “Section Types” column to
change an assignment for that row.

— You can assign section types tomultiple rows, and indeed thatmight often
be exactly what you need. For example maybe you want file levels 2–3 to
act like normal scenes, but leave the 4th level to print without any scene
separators, thus making it possible to break your scenes down into even
smaller pieces than what the reader will be aware of as they read through
the text.

C.2.4 Transferring Section Types Between Projects
Owing to the potential complexity of the second tab, it is not possible to drag
and drop settings between projects. You can however save your settings into a
file which can be shared with others or transferred between your own projects.

— To export your settings to a file:

1. Click the “Export” button, on the left side under the (c) marker in
Figure C.1.

2. Choose a name and location to save the .scrtypes file to your disk.

3. Click Save.
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— Importing settings will replace all of the existing section types in the first
tab, and all of the section type assignments in the second tab. There is no
way to combine settings. To replace the settings in your project with those
found in a saved file:

1. Click the “Import” button, on the right side under the (c) marker.

2. Select the .scrtypes file from its location on your disk and click the
Open button.

3. Youwill receive a confirmation about this action replacing your exist-
ing settings completely. Click OK to proceed—and remember noth-
ing is truly set in stone until you click OK on the whole Project Set-
tings panel, too.

Lastly, if you are primarily interested in just using the same settings for every
new project you create, consider creating your own project template with the
settings already established. It’s easy to do, and will save you a lot of time for all
of the many other tweaks that can bemade to a project as well (subsection 5.4.3).

Return to chapter ⤴

C.3 Label List & Status List
The next two panes are similar enough in their usage and purpose that we can
take a look at their usage as one. The only difference between labels and status
is that the former also associates a colour with an item, and that can of course be
configured in its respective pane.

C.3.1 Managing Labels and Status
In the central portion of each pane (Figure C.4) we have a list of labels and status
entries for the project—these are what you will see in the selection menus for
items. We provide a few generic entries to get you started, but these can all be
changed or removed as you require.
Custom Title, marked (b) in the figure, is for modifying how this field is re-

ferred to throughoutmost areas of the project; your choice herewill even impact
how some menu names are printed. If you change “Label” to “PoV” as demon-
strated, then byway of example the submenu, “View ▸UseLabelColor in” becomes,
“View ▸Use PoVColor in”.

— To add or remove entries: you will find the traditional + and − buttons,
marked (a) in the figure.

— With an entry selected in the list, the Return key can also be used to create
new entries.
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Figure C.4 Status and Label List panes are where you modify available values.

— Entries can be removed with the Delete key.

— To edit an existing entry: double-click on the text of it, and use Return to
confirm the changes.

— To alter the colour of a label: double-click the colour disk alongside the
label you wish to modify (indicated by an arrow in the figure), and select a
colour using the palette.

— Drag and drop to move an entry from one place to another within the list.
This adjusts the order of the items as you see them in menus.

— Multiple entries can be selected at once, for bulk removal or drags, using
the typical mechanisms for doing so: Command and Shift click.

C.3.2 Defaults and Fallbacks
In both lists there is one entry (“No Label” and “No Status”) that cannot be re-
moved. This is a fallback, or what will be printed whenever an item doesn’t have
a label or status. You can change the name of this entry by double-clicking on
the text of it, just as with a normal label or status (in the example figure, we’ve
changed our example to “N/A”, for indicating that the item isn’t applicable to a
PoV assignment—maybe it is a page of research). For labels, this entry cannot
have a colour assigned to it, and so that space will otherwise display an “X”.
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You can also adjust the status or label to be assigned to newly created items as
defaults:4

1. Select the entry you wish to make a default (we selected “New” in our Sta-
tus example).

2. Click the MakeDefault button, marked (c).

The current default for this project will be displayed in boldface within the
list. So in our example here, all new items will have a status of “New”, and
a PoV of “N/A”.

Return to chapter ⤴

C.4 CustomMetadata
When Scrivener’s built-in metadata features aren’t enough, custom metadata is
the way to create your own new fields from a variety of types to choose from.
These fields aremost easily accessed through the inspector’smetadata tab, where
a panel presents your customfields in a form, and in the outliner, where they can
be added as columns. Custom fields can also be searched for in Project Search
(section 11.1), when filtering in the outliner and corkboard (section 11.4) and as
an optional way of filtering what will be compiled. All around you should find
they integrate fully with the project and enable you to add your own “features”
as need be.
The settings pane is divided into two basic components (Figure C.5). In our

example, we could imagine someone is storing a list of books they would like to
acquire:

— The metadata field list: the area marked (b) in the figure, is a list of fields
by title, this area of the pane works similar to the label and status areas in
how you can create, delete, reorganise and rename fields.

– Double-click the names of items to rename them, then press Return
to confirm.

– Drag and drop fields to change their ordering in the inspector, wher-
ever displayed in menu lists (for example in the View ▸Outliner Op-
tions ▸ submenu) and lastly the order used for exporting, printing or
compiling with metadata.

4 Theonly exceptions are those caseswhere thenew itemwas created fromanother (such aswhen
duplicating items, splitting the text in two or when importing items from another project); in
that case the original label or status values will be used.
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Figure C.5 CustomMetadata pane, showing an example “text” field.

— Field settings: the area marked (d), will change depending upon what type
of field you have selected at the time. When multiple fields have been se-
lected, only the settings for the first field will be displayed, but all selected
fields will be impacted by the settings you make.

C.4.1 Adding Fields
1. Optionally select an existing field to insert beneath, then click the+ under

the (a) marker, or press the Return key.

2. Type in the name of the field, and click anywhere else to confirm.

3. From the Type field, marked (c), select what type of field this should be:

— Text: a simple plain-text field, useful for storing information that
doesn’t often repeat, like descriptions or in the case of this example,
the authors of the material we are tracking.

— Checkbox: it works just like all of the other checkboxes you’ve ever
encountered. In this case we’re using one to track whether we own
the book yet.

— List: this functions similarly to how the Status field works: you can
create a simple list of choices to select from on a per-item basis. In
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this example, we’re using this to track “Research Type”; whether it is
a book, article, etc.

— Date: with this field you can type in date and time stamps, or select
dates from a handy calendar.

4. Finally, set up how the field should work, in the areamarked (d). Each type
of metadata field has its own settings, consult the following documenta-
tion for each.

C.4.2 Deleting Fields
1. Select the fields you wish to delete. As normal, you can use the Shift and

Cmd to select multiple items.

2. Click the− button marked under (a), or hit the Delete key.

3.

See Also…
— Overview: how custom metadata (subsection 10.4.4) can benefit your

work.

— Settings: adjusting the available fields and their settings, in project settings
(section C.4).

— Inspector: editing custom metadata on a per-item basis with a form built
into the inspector (subsection 13.5.2).

— You can use list and checkbox type fields to filter outliner & corkboard
views (section 11.4).

C.4.3 Text Fields
Text fields are very simple plain text, and will work best with information that
tends to vary from one item to the next. If you intend to use information that
repeats frequently, lists might make for a better type of field.
The text field type (Figure C.5) has the following settings available:

Wrap text When a text field is set to wrap, it will expand the height of the field
as necessary to display all of the text entered into it. In the inspector, this
will push down any form fields below it, and likewise in the outliner, the
height of the row will be increased to make space for the text (much like it
does for the synopsis).

When unwrapped, only the first line of text will be shown, after which you
will need to click into the field to view and edit the rest of it.
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Use Colored Text When checked, the Text Color selection tool below will be
enabled; click into the colour swatch to open the palette and select a
colour. The text you type into this field will be coloured in both the out-
liner and the inspector. The colourwill also be usedwhen printing or com-
piling with metadata visible, though in that case it will be used to colour
the field name, rather than the text itself.

C.4.4 Checkbox Fields
Checkboxes are simple on/off switches that you can add to your items. They will
be useful for cases where a condition is either true or false, and can be set to
either be ticked by default or not.

Tick by default Sets the default condition of the checkbox for all items which
haven’t at any point in the past been set one way or another. Whenever
you click a checkbox, the result will be to toggle whether it is on or off,
and doing so explicitly sets that condition to the item. It will no longer be
impacted by default settings. Items that have never been adjusted one way
or the other will dynamically change depending upon this setting, even
retroactively.

C.4.5 List Fields

Figure C.6 Custom list fields are best when the possible values tend to repeat,
and are of a limited set.

Lists are fields that will present a dropdown box when clicked upon, offering
you the choice between the different set values that you will define in this pane
(Figure C.6).
The “None” item title entry at the top of the list will set what will be printed if

an item has no assignmentmade to it yet. An empty value is permitted; be aware
this will cause the dropdown menu to contain an empty slot at the top of it. All
items, new and existing, will use this setting by default.
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— To add a new list item:

1. Optionally select the existing item you wish to insert the new entry
after, and click the+ button or press Return.

2. Type in the text as it will appear throughout the project.

3. Press Return to confirm.

— To remove selected items:

1. Select the items youwish to remove (you can use Cmd and Shift click-
ing to select multiple items).

2. Click the− to remove them from the list.

— To reorder items (you can select multiple items to drag them together) use
simple drag and drop. This will impact their position in the dropdown
menus.

— To rename an item, double-click the text field, type in the new text and
press Return. Any items using this assigned valuewill print the revised text.

C.4.6 Date Fields

Figure C.7 Custom date fields work best when you need to record a conven-
tional calendar date and time stamp.

For those cases where you need to record a conventional date in an item, the
date field should do. If you are looking to record highly customised, historic or
fictional dates, it might work best to use a regular text field instead, as this field
will presume a modern time reckoning.

854



C.4. CustomMetadata

When using the date field in your project, you’ll be able to type in dates using
natural language to have Scrivener convert the text you type into a proper date
and time stamp. It is not necessary to copy the format that is used to print the
date when doing so, and indeed with custom formats the software will likely not
recognise it unless it happens to be a fairly standard format. Refer to the Custom
Metadata Pane (subsection 13.5.2) for more information on how to input dates
into these fields.

Format From this dropdown you can select from your system’s standard date
and time formats. Choose between having a date (in a variety of forms), a
date plus a time, or just the time. Lastly, there is a “Custom” option at the
bottom which opens up the following option.

Custom Format Supply a text format using the provided tokens, which will ap-
pear when selecting the “Custom” setting in the Format dropdown (Fig-
ure C.7). In the provided example, the format string will result in a date
stamp like this: “1984–04–01”, or April the 1st of 1984.

If you are looking for other tokens to use than the few basic ones we have
provided in the help text, click the “?” button to the right of the Custom
format field. This will open a web page containing the complete list of
tokens that are recognised by the software. The page itself is very long and
technical, the only pertinent section is “Date Format Patterns”, which your
browser should load to automatically.

Date formats and cross-platform compatibility

Unfortunately it is not possible for us to support the full specification
used by the macOS version of Scrivener, on Windows, but rather only a
small subset of it. For most standard date formats you should find they
will work cross-platform, but more exotic codes (such as Era and day of
year) may not display properly when viewed onWindows.

Ignore time zone changes This option is always available, even when using a
built-in format. By default the software will store the date with your cur-
rent time zone embedded in the format. When you travel to another time
zone, or if you live in a region where summer time is used, you’ll find date
stamps adjust to provide the equivalent in local time.

For cases where you want to store time abstractly, such as in a timeline of
events, you might not want to have the dates and time shifting whenever
you go on trip! Use this checkbox to have dates you enter recordedwithout
time zone information. This checkbox only impacts how new dates are
recorded. If you change this setting after having already entered a bunch
of dates, the originals will go on acting as they have in the past.

Return to chapter ⤴
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C.5 Formatting

Figure C.8 The Formatting pane in Project Settings is used to apply special
settings to individual projects.

Projects all use a central set of preferences (established in the Editing: For-
matting Setting tab (subsection B.3.2)) for determining what formatting (font,
paragraph spacing and indenting, tab stops and so forth) will be used in new doc-
uments you create within them. For cases where you have a project that needs
its own settings, Project Settings gives you away to override these two global set-
tings, and meanwhile provides a few additional options not available elsewhere.

Scriptwriting and Fonts

When using Scrivener to compose scripts, the font for the script will be
selected for you based on the script settings, not the application settings
or this panel. See Scriptwriting (chapter 19) for further details.

Use footnote marker This alternative form of referencing linked footnotes
(subsection 18.3.7) will place a custommarker (as provided in the text field
to the right) at the cursor, rather than highlighting existing text with the
grey footnote link. Refer to Footnote Highlight Style (section 18.3.7) for
further information and advice on how to use this feature.

Main Text Formatting This is where you can choose distinct formatting
choices for this project, separate from those used by other projects glob-
ally. All aspects of text formatting will be overridden by the choices you
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make here. To enable the remainder of this panel, tick the Use different
default formatting for new documents in this project.

Use the mock editor to set up your preferred styling for this project. This
works just like the similar setting in the Editing: Formatting (section B.3.2)
settings pane.

The Use Current button provides a handy way of importing settings from
any background text selections in the active editor. So if you’ve already set
up a document to look the way you want it to, using this button can save
some time.

Different inline footnote font As a subsidiary function of the above, this set-
ting will additionally overrides the application setting for the inline foot-
note font. It will work even if you are not currently using custom font for
footnotes in themain application Settings, but itwill respect the secondary
option in that pane,Use inline footnotes font for inspector footnote too.
When that is enabled, the choice you make here will impact both types of
footnote.

As with the global setting, this is primarily for your own personal pref-
erence, as the compiler can adjust the fonts of all footnotes to a uniform
appearance. No need to squint at 9pt fonts in Scrivener, just because that’s
how they must print!

Return to chapter ⤴

C.6 Auto-Complete List
Every project has its own stash for custom auto-completion phrases that you
can make use of. By default these will never get in your way as you type (unless
you are scriptwriting, wherewe findmost scriptwriters prefer aggressive replace-
ment suggestions), but rather will be shown after typing in a few letters and then
pressing the completion shortcut, ⌥Esc.

— Add a new entry to the list: select where you would like to insert the new
entry, then click the+ button, or press the Return key.

— Removing entries: select the row to remove and click the− button or press
the Delete key on your keyboard.

— Editing entries:

– Start editing a selected row by double-clicking on it.

– Confirm editing by clicking outside of the field or pressing the Return
or Esc key.
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Figure C.9 A project’s auto-complete list can greatly aid keying in frequently
used phrases.

You’ll find an excerpt of some of the auto-completions that were used in the
project that drafted this user manual—specifically the names of the various “Be-
haviors” and “Appearance” Setting tabs (Figure C.9). As youmight expect, having
these around saved me a good amount of time!

See Also…
— Custom Auto-completion (subsection 20.2.2): details on how to trigger

completions and add new ones on the fly, while writing.

— Scriptwriting Auto-Completion (subsection 20.2.4): describes the auto-
completion behaviour when making use of the scriptwriting features.

C.6.1 Auto-Completion Scope
Scriptwriting has a concept of scope for elements that are used to format the text.
Wewill often want certain words, like the name of a character’s favourite pub, to
be completed while typing into a “Scene Heading” element, but not while we’re
typing in the character’s name. Scope helps the software distinguish between
these two typing contexts. By and large you will not have to bother with setting
anything up here. As you write, Scrivener learns about your script and becomes
better at making contextually appropriate suggestions.
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If you want to make changes to the scope of a completion, so that it is present
in different, or even all, element types, use the “Scope” column to change the
context within which it should be used. There are two special settings available:

— General: The defaultwhen adding your own to the list by hand, andused by
non-scripting documents as well. Those documents set to use scriptwrit-
ing will ignore entries of this scope (excepting text set to the special “Gen-
eral” or “General (Centered)” elements).

— All (Text & Scripts): Similar to “General”, only these entries will be available
everywhere, even in scripting elements that maintain their own lists.

However, if a script element has been configured to not use the project
auto-complete list in its script settings, then it will ignore the entry, no
matter what scope settings you use.

Return to chapter ⤴

C.7 Special Folders

Figure C.10 Configure which folders in your project should be used for tem-
plates and new bookmarks.

Scrivener has a couple of features that make use of a designated folder in your
binder:

Templates Folder The folders, files and other items you place into this folder
will be provided project-wide as boilerplates for creating new files
throughout the binder. A common example of this feature is the “Charac-
ter Sketch” file, made available in the built-in “Novel” template. The folder
and its contents are something you’ll need to create in the binder itself, but

859



C.8. Background Images

here is where you will designate that folder for being used by this feature.
If Scrivener finds a folder in your binder called “Templates”, then it will
provide it as an option at the top of the menu for convenient access. Read
more about setup (section 7.5.1).

Use the “No Templates Folder” selection at the top of the menu to disable
the feature.

Default New Bookmarks Folder By default, when you click the+ in the footer
of the Quick Reference bookmark sidebar (subsection 10.3.3), you will be
asked where the new file you are creating should be placed. If you would
instead prefer all new project bookmarks be created into a central folder,
you can designate a location in your binder for this.

Use the “Ask Every Time” selection at the top of the menu to disable the
feature.

See Also…
— Document Templates (section 7.5): everything you need to know about

how theywork, how to set themup andmake use of them in your projects.

— Project and Document Bookmarks (section 10.3): read more on the topic
of using project bookmarks in general.

Return to chapter ⤴

C.8 Background Images
Background graphics should be ideally sized to be no larger than the largest
screen that you intend to be using. Images must be stored in memory while the
project is open, so very large files can bog down the software and reduce stability.

Composition Mode Backdrop Choose a background image for your composi-
tion environment, rather than the plain background colour. The image
will be stretched to fit the screen as necessary, without distorting its shape.
This feature is not compatible with Page View mode.

— No backdrop: will use a solid colour as specified in the Appearance:
Composition Mode settings pane (Table B.1).

— Choose fromdisk: click the Choose… button to select an image from
your computer. This will import the image into your project settings,
leaving the original free to be moved or renamed.

— Use image from project: a list of image resources found within the
project will be listed in this dropdown.
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Figure C.11 Default Composition Mode settings (behind) vs settings with a
backdrop image.

To remove the backdrop image, select the No backdrop setting and click
the OK button.

Freeform Corkboard Mode Background For better performance, use smaller,
tiling textures rather than large images. If you intend to use a graphic that
is meant to be a structure to lay out your cards upon, you should leave a
small amount of padding above the functional part of the image, as the
image will start a bit above the viewable area of the corkboard. The image
will still tile, so you may also want to ensure there is enough padding to
the bottom and right of the functional area to push the tiling effect out of
view.

— Use default background: defers to the default setting in the Appear-
ance: Corkboard: Colors settings pane (section B.5.4), which can ei-
ther be a solid colour or a texture image.

— Choose fromdisk: click the Choose… button to select an image from
your computer. This will import the image into your project settings,
leaving the original free to be moved or renamed.
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C.9 Backup
In this pane you can override the global application backup settings for this
project. This panel will only be visible if the automatic backup system has been
enabled, in the global Backup settings pane (section B.9).

Exclude from automatic backups When enabled, this project will not be
backed up automatically under any circumstances. It can still be backed
up manually using the menu commands found within the File ▸Back Up ▸
submenu; take care to do so periodically, or have another backup routine
in place to keep the contents of this project protected. This option can be
useful for very large projects take a long time to back up.

Use custom backup folder for this project This can be useful for cases where
you want to keep the backups for this project separate from your other
projects. If you’re working in a secured environment, you could choose an
encrypted disk as the backup location. Once enabled, click the Choose…
button to select an alternate folder for backing up this project to.

The Open backup folder… button will reveal this project’s backup folder in
the Finder.

Click the Open Backup Settings… button at the bottom of this pane to load
global settings.
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D.1. Default

This appendix will document the built-in compile formats made available in the
Scrivener installation, as well as those formats that have been supplied within
a few of its project templates exclusively. We hope that by and large the use of
these formats is intuitive, but if you wish to modify them or better understand
how they work, this section will provide information on their use.
Given that not every format is available to every type of file you can export

with the compiler, the list has been broken up by rough category of file type.

D.1 Default
Meant as a very simple format, its layoutswill pass through editor formatting and
“glue together” the pieces in your draft folder with little alteration or complexity.

— Folders will still generate page breaks by default, and it comes with a few
layout choices for adding additional headings as need be.

— The current page number will be added centre-aligned to the page footer.
No other headers or footers will be applied.

This is a good starting point for your own formats, or as a basic way to export
projects that do not require any special compilation options. It’s also a good
option if you’d rather defer formatting for work in another word processor or
desktop publishing program.

D.2 Word processing andWeb
These formats pertain to the print, PDF, RTF, RTFD, DOC, DOCX, ODT and HTML
types.

D.2.1 EnumeratedOutline
If you need a basic outline of topics (taken from the binder titles) alone in an
indented list, this format is a good starting point. Unlike most formats, it will
not export any text, only the titles of documents. The four section layouts that
come with this format provide different spacing and numbering schemes for
your outline. You can use any mix of styles for different types of documents
in your project.
To create your own numbering schemes, duplicate the format and use one

of the existing Section Layouts as a starting point. The placeholders used to
generate numbering is set in the “Title Options” tab (subsection 24.2.4).
The amount of indent applied per level can be adjusted with the Add indent

per outline level setting, in the Transformations format option pane.
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D.2.2 Full IndentedOutline
Presents an indented, easy to read outline that includes titles and synopses for
all binder levels. The provided layouts provide a choice between alphanumeric
numbering, hierarchical or no numbering at all. Refer to “Enumerated Outline”
in the previous section for tips on adjusting the indent and numbering styles.

D.2.3 Manuscript (Courier)
Formats your book using standard Courier 12pt type and a number of common
conventions such as scene separators as hashmarks, double-spacing, underlined
emphasis (instead of italic), page numbers, standard page headers and so forth. It
has broad set of section layouts capable of handling a book with parts, chapters,
scenes and titled sections. It is thus equipped to work with all of our built-in
book generating project templates, fiction and non-fiction alike.

CommonAlterations
Empty lines instead of hashmark

By default, the stock compile formats considers empty lines that you create in the
editor to signify minor breaks in the text, such as scene transitions or changes
in topic. Some formats, such as submission manuscripts, require a more clear
signal of such a break than a mere empty line, and commonly use a single hash
mark (#) to do so. If you desire empty lines for such breaks instead, then use the
following steps to change how this works:

1. Open File ▸Compile… and double-click on the compile Format you want to
alter, such as Manuscript (Courier), in the left-most sidebar to edit it.

2. Select the Separators pane (section 24.4) in the left sidebar of the compile
Format Designer window.

3. Examine each of the Layouts in the list, and clear the text field for any that
have a hash or other symbol in Blank line separator field.

Optional: also set the Separator between sections dropdown to “Empty
line”, from “Custom”.

4. Give the format a better name at the top, and consider saving this to “My
Formats” so you can make use of it in other projects in the future.

5. Click the Save button to confirm your changes.

Italic emphasis instead of underscoring

If you require emphasis to be in italic instead of underscoring, edit the Format
(as described previously in step 1) and disable the Convert italics to underlines
setting, in the Transformations compile format pane (section 24.13).
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D.2.4 Manuscript (Times)
Functionally very similar to the Courier manuscript format, only using Times
New Roman, another commonly required typeface for submission manuscript.
Scene separators remain hashmarks, double-spacing, page headers and so forth.
Italics will be rendered as italic text rather than underscored. It provides the
same array of layouts as the Courier format.
The separator style of using hash marks can be altered using the same tech-

nique described previously, for the Courier variant.

D.2.5 Modern
Providing a fresh look, using the respectable Avenir Book typeface, coupled with
Helvetica Neue Bold heading and Light subheadings, this layout is designed
printing your own copies or generating PDFs for proofing. It includes a full com-
plement of layout designs, working with all of our book generating project tem-
plates.

CommonAlterations
Empty lines instead of symbol

Refer to the notes for the Courier (Manuscript) format (section D.2.3).

D.2.6 Outline Document
This layout is designed for printing full outline information (title and synopsis),
but in a standard document layout rather than an indented outline format. It
also has several layouts to choose from that only export the title, which could be
useful for some projects where larger categorical groupings like parts and chap-
tersmay not have any specific synopses of note and just need to insert a sectional
break. The page footer contains the title of the work, author’s name, date and
page number, separated from the page with a dividing line.

D.2.7 Paperback (6′′ x 9′′)
Functionally similar to the previous, this Format is optimised to work with stan-
dard paperback sizes in the U.S.1

CommonAlterations
Paragraph spacing instead of indents

Using empty lines to signify paragraph breaks, instead of indents, is a simple
adjustment tomake. This checklist will also demonstrate how styles can be used

1 Or should we say, “optimized”.
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within a compile format, a technique that will be useful if you require fully styled
output in your desktop publishing or word processing workflow:

1. Open File ▸Compile… and double-click on the compile Format you want to
alter, such as Paperback (6 ′′× 9 ′′), in the left-most sidebar to edit it.

2. Select the Styles pane (section 24.5) in the compile Format Designer win-
dow’s left sidebar, and then select the “Body” style within that pane.

3. Using the standard indent and tab stop ruler (subsection 15.7.1), drag the
first-line indent marker all the way to the left.

4. Click on the line-height dropdown button, and select “Other…” at the bot-
tom of the menu.

5. Set Paragraph spacing after to the desired amount, such as 6pts, and click
OK.

With your desired formatting now declared in one central location, you
need only apply that style to all of the cases where paragraph text would
be used.

6. Click on the Section Layouts pane in the left sidebar. For every Layout that
has a checkmark in the Text column:

a) Click into the sample text.

b) Use the styles dropdown on the far left to select the “Body” style
you’ve prepared. You should see the desired formatting appear.

Optional: you may want to set the various headings in the other Layouts
to styles as well, now that you are here and know how to do it.2

7. Give the format a better name at the top, and consider saving this to “My
Formats” so you can make use of it in other projects in the future.

8. Click the Save button to confirm your changes.

D.2.8 Paperback (5.06′′ x 7.81′′)
A format designed to produce a typographically pleasing layout that could be
taken into a word processor or desktop publishing program for self-publication
with little effort. As with the other book generating formats, it is designed to
provide a full spread of layouts to accommodate many different book styles and
structural setups.

2 By using logical “Heading 1”, “Heading 2” and so forth styles your documentwill have an outline
which some software may use for navigation aids, as well as facilitating the construction of a
dynamic table of contents.
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D.2.9 Proof Copy
A useful preset for internal proofing. It will reformat your script to double-
spacing so you can easily take notes, and prints a disclaimer after each section
heading as well as in the header, making it easy to send out “Not for distribution”
copies to your proofing team.

CommonAlterations
Empty lines instead of hashes

Refer to the notes for the Courier (Manuscript) format (section D.2.3).

D.2.10 Script or Screenplay
This format is also available to the scriptwriting formats, and is documented
there (subsection D.4.1).

D.2.11 Vellum Export
Available only to the DOCX file type, this Format is designed to convey your work
to the Vellum book creation tool, for macOS.
It is best usedwith styled text (chapter 17), whichVellumdepends heavily upon

to correctly format your work. For the most part, you may use Scrivener’s styles
intuitively and should find they all work as expectedwhen imported into Vellum.
This compile Format will check for the stock style names used by Scrivener and
convert them to style names that are expected by Vellum. If you use your own
style names, you may want to edit the Format’s list, in the Styles compile format
pane (section 24.5).
Additional style support is provided to (though not defined by default in stock

projects):

— Epigraph

— Dedication

— Book Title

— Book Subtitle

— Author

Simply create any style from this list in your project by name, to have the For-
mat pick it up and handle it appropriately.
Since this format produces a document tuned to work with one specific pro-

gram as a transfer medium, it is not expected for it to look “right” in other pro-
grams, or when viewed on its own.
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D.3 Ebook Publishing
Since most ebook readers will handle the majority of the typesetting, choosing
a format will be more about getting the basic building blocks together, than ex-
erting total control over the appearance.

D.3.1 Ebook
A suitable format for ebook design. Electronic books generally require basic and
flexible designs in order to be displayed on many devices, from cellular phones
to tablet computers to dedicated black & white e-ink displays. This is a good
starting point for your own formats when creating ebook formats.
If you have a lot of experience in ebook design, you may find starting from

a simpler default to be easier, as this format is built to be used with very little
customisation, and thus assumes a lot.

D.3.2 Ebook Screenplay
When publishing a screenplay intended for display on an ebook device or reader
software, you’ll want to use this format, which has a stylesheet designed to print
the various scripting elements in a format mimicking a screenplay. Since the av-
erage reader won’t have a screen large enough to truly display a standard screen-
play, some of these elements will be estimated, or designed to merely suggest
what they would look like on a typical printed page.

D.3.3 Outline Document
This format is also available to the general word processing and web formats,
and is documented there (subsection D.2.6).

D.4 Scriptwriting Formats
Available to Print, PDF, thewordprocessing formats, HTML, FinalDraft andFoun-
tain file types.

D.4.1 Script or Screenplay
Most of the formatting will already be done in place, from the scriptwriting set-
tings. The compile format itself is only concerned with page settings and con-
verting “smart” punctuation to “dumb”. Most of your script should be assigned
to the stock “Text Section” Layout.
When used with Print or PDF, the compiler will handle the page layout for

you. Aside from basic page layout, the compiler will also format dual dialogue
andmark dialogue broken by page breaks with “more” and “cont’d” markers. We
consider this to be “proofing/reading quality”, in the sense that it may notmatch
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the layout (and thus total page count) of output created by programs designed
to create industry standard screenplays.

D.5 Plain Text andMarkdown-Based
These formats are displayed when using the TXT, MultiMarkdown or Pandoc
based types.

D.5.1 EnumeratedOutline
This format is also available to the general word processing andweb formats, and
is documented there (subsectionD.2.1). Themain difference of note to plain-text
usage is that the indenting used to indicate hierarchy will be converted to literal
whitespace for plain-text. Those using aMarkdown-based format should use the
“Markdown Outline” format instead.

D.5.2 MarkdownOutline
If you are looking to convert the outline of your project into a Markdown-style
indented bullet or enumerated list, then this format will be preferable to the
standard “Enumerated Outline” format, in that it has been designed specifically
to generate valid Markdown lists. This format also has embedded within it a
simple LaTeX design.
You can either assign all of your project’s section types to one of the listing

types, ormix andmatch based on type—though keep inmind that the end result
must conform to what Markdown will expect: a strict use of bullets or enumer-
ation per list.
Be aware that when using some methods of filtering or narrowing down the

Draft folder, the result may not produce a valid Markdown list, as Scrivener may
insert indent whitespacing that in effect causes the list to become a code block.
This should be a simple matter to clean up in a text editor.

D.5.3 Plain TextManuscript
Designed to serve as a basic plain-text manuscript with emphasised headers, it
is a good format if you want a hard long-term backup of your manuscript. Since
it is formatted using plain-text conventions, it will last for many decades, if not
centuries, to come. It’s also a good format for sharing text through mechanisms
that better use plain-text for transmission, such as email, newsletters, readme
files and so forth.
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D.5.4 Plain Text Screenplay
For integration with software that can import plain-text formatted screenplays3.
This format will convert spacing and indents to literal whitespace, as well as
pad the text file with enough whitespace to print 1′′ margins when printed using
12pt Courier. The result will be identical to a formatted screenplay, or what one
would get when using a typewriter. Refer to Exporting Scripts (subsection 23.5.2)
if you want to modify the format or make your own.

D.5.5 BasicMultiMarkdown& Pandoc
The Markdown converters that the compiler integrates with will be doing the
bulk of the actual formatting itself, so the compile Formats designed for usewith
them will primarily be concerned with establishing the structure of your docu-
ment.
Through the three layouts provided, you can print sections as headings, head-

ings with text or text alone. The heading-based layouts will automatically insert
the appropriate number of hashes tomatch your outline hierarchy with heading
structure depth.
It is also convert the default project styles (where applicable) to logical syntax:

— Block quotes will have a > prefixing each paragraph.

— Code blocks will be tab-indented and code spans will have backticks sur-
rounding them.

— Captions, when properly placed adjacent to figures or tables, will be em-
bedded in the syntax.

The stylesheet also includes CriticMarkup support, if you create and use styles
by the names of “Addition”, “Deletion” and “Highlight” in your project. Inline
annotations will also export as CriticMarkup comments.
For those wishing to use Pandoc for conversion, a similar Format will be pro-

vided called “Basic Pandoc”.

D.5.6 MMDOpenOfficeDocument
A simple extension of the Basic format, this variant is available when usingMul-
tiMarkdown to OpenOffice (.odt) or Flat XML (.fodt) file types. This format pro-
vides indexing capabilities, where you canmark terms in your text to be indexed,
or supply hidden indexing keywords from the text editor.
To make use of this format’s capabilities, create two styles in your project:

3Not to be confusedwithFountain, which is a newer format that uses aMarkdown style approach
to writing screenplays.
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— Index Term: this Character style should be used to highlight printed words
or phrases that should also be present in the index.

— Index Key: this Character style is meant to insert invisible indexing keys
into the main text.

These styles will only insert the necessary indexing markings into the docu-
ment, they will not cause an actual index to be generated at the end of your file.
Use your word processor to insert an index using the formatting options you
require.

D.5.7 PandocWordDocument
This variant of the Basic Pandoc formatwill only be available when using Pandoc
toMicrosoftWord (.docx). It provides identical features as the “MMDOpenOffice
Document” Format, documented above.

D.6 MultiMarkdown LaTeX
When selecting “MultiMarkdown → LaTeX (.tex)” or “MultiMarkdown → PDF” as
the compile file type, the formats listed in this section will become available.
With the exception of the Modern (Custom LaTeX) format, the available docu-
ment classes use designs created by Fletcher Penny, the developer ofMultiMark-
down.

Looking for LaTeXWithout the Pain?

These formats can be made use of with very minimal, or even no Multi-
Markdown usage at all. With the Convert rich text to MultiMarkdown
option in the General options area of the compile overview screen (sec-
tion 23.4.3). A project that has been composed quite ordinarily, using
Scrivener’s rich text features, could take advantage of the high quality
typesetting that this workflow affords.

The LaTeX formats have a few common features available to them:

— In addition to the basic Section Layouts the “Basic MultiMarkdown” For-
mat uses, the LaTeX-oriented formats include the following:

– Text Section with Break: using a method suitable for each format that
supports this layout, a scene or section break of some sort will be
inserted between binder items that have been assigned to this layout.

– Unnumbered Chapter: the alternative syntax for a \chapter* com-
mand will be used, leaving the heading unnumbered and omitted
from the table of contents (where applicable).
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– Unnumbered Section: as above, only using the \section* command.

— Stylesheet support is expanded to include additional optional features. To
take advantage of these styles, you will need to create them in your project
(copying the name and type of style):

– Index Key (character style): use this style to mark text as being an in-
dex key. For example if “word” were marked with such a style, then
it would be compiled as \index{word}.

– Index Term (character style): similarly, this leaves the marked word
visible in the output, for those cases where the key and the phrase
are the same: word \index{word}.4

– Raw LaTeX (character style): use this tomark out any ranges of text in
your document that should be treated as raw LaTeX syntax, as Mul-
tiMarkdown will otherwise encode the special punctuation so that it
prints as visible text in the output.

– Attribution (paragraph style): with the memoir-based formats (which
include all but the “Book (Tufte)” format), the \sourceatright com-
mand will be used on the marked text.

Import Extended LaTeX Styles from the Extras Pack

If you would like to add the extended LaTeX and MultiMarkdown styles,
used by these compile formats, to your project, you will find an example
project containing them in the Extras Pack (Appendix G).
Using “9-extended_latex_stylesheet.scriv” as a source project, follow-

ing the instructions provided in Copying Stylesheets Between Projects
(section 17.5). Further tips and instructions can be found within that
project itself.

D.6.1 Article (Memoir)
Uses a layout of the expansive Memoir LaTeX document class that has been
tuned to mimic how the stock article class works. The benefit of using this
class is the wealth of customisation options available to Memoir in general.
The compile format adds a metadata setting for “Base Header Level” to 2,

which means the top level heading will be considered a chapter rather than a
part. Chapters will be formatted as major section headings rather than using
page breaks and special formatting. If youwould prefer a different top level head-
ing, adjust this setting in the Metadata compile format pane (section 24.11).

4 This style cannot be used in conjunction with full RTF to MultiMarkdown conversion.
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D.6.2 Book (Memoir)
A fairly stock implementationof theMemoir book class, which is generally useful
for non-fiction aswell. This is a great starting point if youwish to build your own
design from scratch (in fact this user manual you are reading made its humble
beginnings using this boilerplate).

D.6.3 Book (Tufte)
A document class with a design inspired by the books of Edward Tufte. This for-
mat supplies a few additional optional styles that you can make use of by adding
them to your project:

— Full Width Text (paragraph style): This will typeset the marked paragraphs
full-width, into the right margin area, using the fullwidth environment.

— Margin Note (character style): Places an unnumbered margin note along-
side the paragraph the marked text is within, much like a footnote, but
without the cross-reference markings.

Images will be placed in the main text block, and should be no wider than
310 points. If you wish to make use of this system’s margin figures or full-width
figures, you would need to create your own styles for doing so.
Section breaks will use the \newthought command, supplied by this package.

This has the effect of adding an empty line of space between sections, suppress-
ing the indent on the first paragraph of the next section, and setting the first
three words to all-capitals. If you would like to adjust how many words are cap-
italised, create a duplicate of this format, and edit the regular expression in its
Replacements compile format pane (section 24.15). For example, to select the
first four words (the number “3” is used, because the fourth word is selected af-
terward, without the space following that word):

^@@((?:\S+\s+){3}\S+)

It should be noted that at the time of this writing, this class cannot be typeset
using the XeLaTeX engine.

D.6.4 Manuscript (Courier)
Using a simple design put together by Fletcher Penney, this will typeset your
document using a traditional submission manuscript format: 12pt Courier will
be used for all text, with 1′′ margins and double-spaced lines. There are a few
peculiarities of this format to be aware of:

— This format does not handle parts, and so in most cases you should set
the Base Header Level to “2”, in your project’s compile metadata settings
(section 23.4.2).
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— Bold text has no treatment, you should use simple emphasis alone (which
will be underscored in the output).

— Chapter breaks will be untitled, and section breaks will simply insert a “#”
between scenes.

— Other non-fiction oriented commands, such as footnotes, tables and so
forth, should not be expected to work.

D.6.5 Modern (CustomLaTeX)
Unlike the other formats, this one has been designed by Literature & Latte, based
upon its “Modern” compile format for RTF and other traditional printing meth-
ods. That aside, it is a modified version of the Memoir system in article format.
All of the settings for it are stored directly within the compile format itself. You
can easily modify how it works from the LaTeX Options compile format pane
(section 24.12).

For Best Results, use XeLaTeX

This design makes use of system fonts, and as such it will look much
nicer when typeset using the XeLaTeX engine, rather than pdflatex Since
Scrivener uses the latter for its direct-to-PDF option, it has been set up to
handle non-system fonts as a fallback. It will also use a standard three-
asterisk section break instead of a Unicode glyph, in this fallback mode.
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E.1. Default

This section will document what each of the built-in layouts are meant to pro-
vide, and the mechanics of how they are set up. For more information on how
these work in general (and what they are as a tool), refer to The Built-In Layouts
(subsection 12.3.6).

E.1 Default

Figure E.1 The “Default” built-in layout.

The first and most important layout to be aware of is the one that gets things
back to ground zero. The “Default” layout is designed restore a project window
to a basic look, removing the non-active split view, closing ALL copyholders and
opening the inspector and binder. It will also clear those navigation settings that
modify how the project window behaves when you click on things—in the exact
same fashion as using the Navigate ▸Clear All NavigationOptionsmenu command
(section 12.5). (That commandmakes for a good alternative to “Default”, if you’d
rather leave the layout of the window alone but get the default behaviours back.)

E.2 Three-Pane (Outline)
Three-pane browsers are a popular way of navigating through large amounts of
information. They typically feature a sidebar (much like the binder) for select-
ing folders, then display the contents of that folder in a second view, and finally
clicking on things inside of that viewwill automatically load the contents ofwhat
you click on into the third pane. This and the following layout will convert a few
key aspects of how Scrivener works, to more closely emulate a three-pane tool.
Here are the settings it applies:

— Navigate ▸Binder Selection Affects ▸Both Editors: by itself, will cause what-
ever you click on in the binder to load into both splits at once. This be-
haviour is however slightly modified by the next option.
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Figure E.2 The “Three-Pane (Outline)” built-in layout.

— Within that same menu, the Open Non-Group Items in Other option has
been enabled. This redirects non-group items you click on in the binder
over to the right split no matter what, and such items will not load in the
left editor. Details on how this feature works are described in Making
Splits Load by Type (subsection 12.2.4).

— Navigate ▸Outliner Selection Affects ▸Other Editor: as indicated by the high-
lighted button in the outliner footer bar, any selection you make in the
outliner will automatically load in the other split.

All three of these options together greatly modify how Scrivener typically
works, going from a flexible two-pane design to something more like an
email browser or notebook program.

— Visually, the outliner will be using a fixed row height (subsection 8.3.8),
which keeps long synopses fromdominating the view, and the column set-
tings for it will be altered to only show “Title and Synopsis”.

— The right split, meant to focus on content, will switch to Scrivenings view
mode.

E.3 Three-Pane (Corkboard)
This layout is functionally identical to the “Three-Pane (Outliner)”, save for us-
ing a stylised corkboard view for primary navigation in the left split, rather than
an outliner. If you prefer the additional visual display of metadata that the cork-
board affords you, this can make a good alternative. It temporarily changes the
following aspects of the corkboard:

— View ▸CorkboardOptions ▸Cards Across will be set to “1”.

— The Size to fit editor setting will be enabled, from within the Corkboard
Options (subsection 8.2.6) panel.
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— The Spacing, from that same panel, will be adjusted to a small amount
(though it may in fact expand if you were using less spacing before).

E.4 Editor Only

Figure E.3 The “Editor Only” built-in layout.

Does what it says on the tin. This very simple layout simply removes both
sidebars, closes the split view and any copyholders. Which split it chooses will
depend on what you are currently working with. It will favour the split that is
showing a text editor or Scrivenings session. If both (or neither) splitsmatch that
description, then the active split will be used. Lastly it will set the group view
mode to Scrivenings. Thus if you have a split interface with two corkboards, the
active corkboard will become the editor view you focus on and its view will be
switched to Scrivenings so you can work with the text. The view will be scrolled
to the first selected card or outliner row from the previous view.
If you would prefer an even cleaner layout, with no ruler, format bar or header

and footer bars in the editor, you’ll find a custom layout called “Editor Only
(Clean)” in the Extras Pack (Appendix G).1

E.5 CorkboardOnly
Much like the “Editor Only” layout, but aiming to provide a clean view for fo-
cusing on structure, rather than content. If relevant, when choosing which split
to focus on, the layout will select the split with a corkboard. It will otherwise
use the active split, changing the view mode to Corkboard if necessary. If you
were editing a file then the layout will select the parent group, scrolling to and

1 If you need instructions for installing a layout, refer to Managing Layouts (subsection 12.3.5).
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E.6. Centered Outline

Figure E.4 The “Corkboard Only” built-in layout.

selecting the card for the item you had been editing.2

If would prefer an even cleaner corkboard with no toolbars, you’ll find a cus-
tom layout called “Corkboard Only (Clean)” in the Extras Pack (Appendix G).

E.6 CenteredOutline

Figure E.5 The “Centered Outline” built-in layout.

The main purpose of this layout is to quickly and simply display a very clean
outline viewwith only the Title (and optionally Synopsis) column visible and the
View ▸Outliner Options ▸Center Content menu toggle enabled. The editor space
will be cleaned up, closing splits if necessary and removing any copyholders.
As with the “Corkboard Only” layout, the split showing an outliner will be

preferred, otherwise using the active split, and the parent of the currently edited

2 If you‘re curious on how to do that yourself from time to time, the Navigate ▸Go To ▸Enclosing
Group menu command does the same thing, although in that case it will preserve the editor’s
current group view mode.
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text document will be navigated to if necessary. Unlike that layout, the binder
and inspector visibility will be left alone.

E.7 Dual Navigation

Figure E.6 The “Dual Navigation” built-in layout

If you’ve ever found yourself wishing that you could have a kind of second
binder, so that you could browse and edit more than one file at once, this layout
may do the trick. You can think of this layout as roughly dividing the project
window down the middle into two separate workflows:

— On the left side, the binder and the left split will be bound together exclu-
sively. You can use it for text editing, outlines, viewing PDFs or whatever
you need.

— On the right side things are a little more interesting. This side is isolated
from the binder and left editor, making it a more static place to work with
multiple items in a sort of “mini-binder” approach, where what you click
on in the top editor will be automatically loaded in its copyholder below.

If you want to change the group you are browsing in the right side of the
project window, you have every single means of navigation at your disposal save
for clicking on things in the binder:

— Option-Click on items in the binder.

— Drag and drop from the binder to the right editor’s header bar.

— Use the Navigate ▸GoTo ▸ submenu.

— From the left editor, when using a group view, Navigate ▸Open ▸ in Right Ed-
itor (⇧⌘O).

— Quick Search.
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— And of course the history back/forward and next/previous item buttons in
the editor’s header bar.

Here is a list of settings this layout applies, should you wish to tweak how it
works or create your own similar layout:

— Navigate ▸BinderSelectionAffects ▸LeftEditorOnly: this keeps the binder fo-
cused on the left side of the project window.

— In the right split, Navigate ▸Outliner Selection Affects ▸Copyholder has been
set, as indicated by the highlighted button in the outliner footer bar.

— The group view for the right side will switch to outline mode.

— The layout will try to use whatever content you were working on in the
editor(s) prior to using it, but if it cannot find a combination it likes, it will
just load the entire Draft folder into the right-hand browser split and the
first item with text content that it finds in the Draft into the left split. If
you want to get back to what you were doing before the application of this
layout, you can use the history buttons in each editor header bar.

E.8 Refining A Built-In Layout
You may very well find that you like the basic idea of one of our built-in lay-
outs, but would like to make adjustments to how it works. Although you cannot
modify the built-in layouts, for themost part this can be done simply by creating
your own layout after making the desired modifications to the project window,
as described earlier in this section.
Although they work similarly, built-in layouts are not the same as the layouts

you create, and they have some characteristics you won’t be able to replicate:

— The “Dual Navigation” layout opens a copyholder panel below the outliner
in the right-hand split. Layouts cannot open copyholder panels. However
the setting itself that causes selections to auto-load in the copyholder will
save, so as soon as you open a copyholder it will start working.

— Built-in layouts can temporarily override metadata settings like which
columns are showing in the outliner or how many cards across the cork-
board displays. When you return to “Default”, you will find your original
settings are intact. The layouts you create on the other hand can either
only permanently change those settings or disregard them entirely.

— The built-in layouts onlymake selective changes to settings, rather being a
full snapshot of all view settings, navigation options and optionally meta-
data display options. For instance, if you prefer not to use the footer bar
in your editors and have it switched off with the View ▸Editor Layout ▸Hide
Footer Viewmenu command, built-in layouts will not change that setting.
A custom layout absolutely will.
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— Some of the built-in snapshots are “aware” of what you’re working with
in the project window and optimise their behaviour based on that. For
example the “CorkboardOnly” layoutwill select the split using a corkboard
view even if a text editing split is currently active. Your own layouts will
more simply force the saved viewmode change upon the current editor(s).

E.9 Hiding the Built-In Layouts
Once you’ve established a number of your own layouts, you may want to hide
these starter layouts to clean up the menus:

1. Use the Window ▸Layouts ▸Manage Layouts… menu command (⇧⌘)) to
bring up the layout management window.

2. Click the button and select the “Hide Built-In Layouts in Menus” com-
mand.

You can always bring them back with the “Show Built-In Layouts in Menus”
command.
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F.1. Compile Overhauled

demo. It is safe to run this demo in parallel with Scrivener 2. You can play with
the new version and learn it while continuing to work without interruption.
Scrivener 3 is a significant release of the software, one that has been in the

making for nearly four years. Core aspects of the software have been thought
through with the intention of streamlining how we work without sacrificing
flexibility—indeed we wanted to make Scrivener even more flexible while also
striving to make routine tasks easier to accomplish. Above and beyond, we
wanted it to feel just like what you’ve become used to. Even though some of
the changes have been sweeping (watch out for compile!), we hope you find the
new landscape not only improved, but familiar as well.

Can’t Find a Feature from the Old Version?
If you’re looking for a particular feature by name that appears to have
been moved or maybe even removed, searching for its name in this sec-
tion may help you find it. Menu commands can also be searched for by
name, from the Help menu.

F.1 CompileOverhauled
The second version of Scrivener represented a complete overhaul of the compile
interface from version one, and we are pleased to present a third iteration of
the compile concept to you. Based on years of feedback with the system you’ve
grown accustomed to, we’ve designed a replacement which draws heavily upon
the strengths of the old system while using it as a skeleton to develop a more
intuitive and easy to use “front end”.
Given the scope of changes made to the compile system, it is not possible for

your existing projects to be upgraded automatically to the new system. For this
reason, if you have projects that depend upon complex compile settings, we en-
courage you to retain the backed up version thatwas created for you uponupdat-
ing, as well as an older copy of Scrivener 2, should you need to reference them.
It is possible to import and ugprade your old compile settings and presets (sub-
section F.1.6).
If you’d like to read a blog article on this topic, head on over to our site.

F.1.1 Separators by Type
Inserting separators into your document used to be a matter of ticking boxes
in the inspector, or trying to shoehorn your outline into a layout that worked
with the Separator’s compile option pane. If you wanted an empty line be-
tween scenes in a novel you could have Scrivener insert empty lines between
text chunks—but then you could only ever cut to a new chunk of text for the
purposes of creating a formal scene.
In Scrivener 3 you can still assign separators to broad categories (such as all

folders or files), but as well to specific types of items. Say you have folders in
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your project set up to be chapter breaks—it is then useful to say that all chapter
headings ought to have a page break before them. Instead of saying “folders have
breaks”, we are now saying only this kind of item in the binder has a break—and
if we use files for chapters instead, then it naturally inherits that same behaviour
without having to go in and change compile settings.
Since a chunk of text can now formally be a “scene” that means other chunks

of text can be “not scenes” and thus not have any separation between them, al-
lowing you to outline far deeper than your readers will ever be aware of.

F.1.2 Front and BackMatter Locking
For one thing there is now a concept of “back matter” to begin with, which will
be welcome news to those in need of such. Furthermore we’ve made it so you
can lock front and back matter folders to file types, meaning whenever you se-
lect between ePub, PDF and so forth, specific different groups of front and back
matter pages can be automatically applied to your compile settings. Read more
about locking settings to file type, in Front & Back Matter (section 23.4.1).

F.1.3 Preserve Formatting inMarkdownCompile
In the past, the Format ▸PreserveFormatting featurewould have been used to gen-
erate code spans and code blocks with Markdown-based output. This capability
has been removed, as it is now served by styles. Use the “Code Block” and “Code
Span” styles provided in the stock set, or if you create your own, set them up
in your compile settings using the MultiMarkdown and Pandoc Options (sec-
tion 24.14) compile format pane.
The Treat “Preserve Formatting” as raw markup option, (used in conjunc-

tion with the Convert rich text to MultiMarkdown setting both in the compile
options for Markdown-based formats (section 23.4.3)), will cause marked text to
pass through the compiler untouched. This option will mainly be of interest to
those that use the iOS version of Scrivener, with its equivalent capability. If you
are only using a Mac or PC to compile, it is usually best to use a dedicated style
instead (with theTreat as rawmarkup option enabled for it in the Styles compile
format pane).
If one has a lot of Markdown blended into their document, it first might be

worthwhile to consider whether the full rich-text conversion system is the right
tool for the job. If it is, and you still need lots ofMarkdown, the secondary option
to Escape special characters can be disabled. This is a “riskier” setting that may
require additional proofing, as accidental usage of Markdown may occur where
punctuation is used in ways that match its syntax (for example, an asterisk after
a word to mark a casual footnote might confuse a Markdown converter, which
uses asterisks to denote emphatic text).
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F.1.4 Print with Footnotes
In the past, if you wanted to print or generate a PDF out of Scrivener with proper
end of page footnotes, you either had to compile to another program that could
do this form of typesetting, or make use of the “Proofing” option in compile set-
tings. Scrivener now typesets its own footnotes for Print and PDF compiling. If
that’s all you were needing a word processor for, that’s hopefully one less tool
you need to get work done!

F.1.5 Markdown to RTFConversion
In the past, those using basic Markdown for italics and bold in their text could
make use of an option in the Transformations compile option pane to convert
these to rich text formatting, when using any of Scrivener’s native export for-
mats. This option has been replaced by the Convert MultiMarkdown to rich
text in notes and text compile option, in the compile overview screen under
General Options (subsection 23.4.3).
Of note, it now treats text and notes as properly formed Markdown, rather

than simply extracting asteriskmarkedphrases fromanotherwise rich text based
document. If your project is not properly formed, use of this checkbox may
produce undesirable results—such as paragraphs all being glued together, since
Markdown require a clear line of space between each paragraph.

F.1.6 Importing Legacy Compile Presets
We recognise that you may have invested a lot of time in your compile settings.
Should you choose to upgrade a project that is a work in progress, you will find
its compile settings will be reset to default. If you would like to carry over the
original settings into a new format, refer to the instructions for importing your
settings into a new version 3 format (subsection 23.2.8). For a more comprehen-
sive guide, we have prepared a tutorial project that goes over many details that
may be of interest to you in transitioning to the new system.

F.1.7 Post-Processing Scripts
Those advanced users looking to automate what Scrivener does after compiling,
or to tweak how it makes use of Pandoc and MultiMarkdown, will be interested
to know that you can now have the compiler set to trigger an executable upon
conclusion, passing along the finished document as an argument. Those adept
in scripting can even write their own extensive workflows to handle the docu-
ment before finalising it, and having Scrivener produce the finished file in the
intended save folder (for example, your LaTeX project can be compiled directly
to PDF by having Scrivener invoke latexmk or pdflatex). This capability is avail-
able to both plain-text and plain MultiMarkdown compile outputs. Read more
about the Processing compile format pane (section 24.22).
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F.2 Section Types, Page Breaks and As-Is
Any talk of the changes made to compile would not be complete without men-
tioning section types (section 7.6), a newway of assigningmeaning to the folders
and text items in your binder, such as “chapter”, “subsection” or even specific
types such as “table” or “figure”. By categorising items using natural terms, and
telling the compiler what those things should look like, you can do away with
the more abstract notion of formatting by levels and icon types.
All of this hasmade the concept of using individual checkboxes for page breaks

and such a bit obsolete. If a thing by its nature involves a page break, such as
chapter, then we don’t need a separate checkbox to click on.

— Page Break Before: page breaks are now a function of how a type is for-
matted by the compiler. By and large you should find the default settings
and templates provide a useful set of types to choose from, with useful set-
tings applied to them. To use the above example, if in the past you’ve used
this checkbox for frontmatter sections, you’ll findmost of the compile for-
mats contain a layout specifically designed for frontmatter which includes
a page break.

For those upgrading their projects from 2.x, be aware that items marked
with “Page Break Before” will be assigned to a special “Section Start” type,
created for upgraded projects alone. This should be considered a transi-
tional type, but it will allow your project to continue functioning roughly
as it was before.

— CompileAs-Is: this checkbox is aswell no longer in the inspector or specif-
ically assigned to items. The choice to print a section type “as-is” is some-
thing you now make when setting up your project’s compile settings. You
might for example want to create types for Tables and Equations, both of
which aremapped to compile as-is in the end, but remain distinct for their
purpose in the project itself.

Upgraded projects will be scanned for the use of “as-is”, and a special “N/
A” section type will be created for projects that made use of the checkbox,
with all items that used it assigned to that type and automatically mapped
to the special “As-Is” section format in the compiler. Thus they should
continue working as they did before.

F.3 Stylesheets
Yeolde formatting presets have becomeproper stylesheets. Youwill findmuchof
the toolset has a similar usage fromwhat you are accustomed to in older versions
of Scrivener. The dropdown button is in the same location on the Format Bar,
and for the most part you can use them in day to day writing, similarly to how
you used presets.
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The main difference will be when compiling: styles now operate on the as-
sumption that the formatting you use in the editor is intended to be printed
as-is in the output, to the best of the output format’s ability.
Styles are, as formatting presets were, strictly optional! If you never hadmuch

use for the preset feature in the past then don’t feel you have to learn anything
about styles going forward. If you’re interested in using styles as a pure writing
tool, refer to Styles That Do Nothing (subsection 17.4.4).
For all other questions, head on over to Styles and Stylesheets (chapter 17) to

see what’s new.

F.3.1 Converting Formatting Presets to Styles
Do you have a bunch of Formatting Presets from previous versions of Scrivener
that you’d like to convert to styles? We won’t do that for you because styles are
now project-specific, but it is easy to set up styles from a prepared sample:

1. Using the older version of Scrivener, create a new blank project.

2. For each Formatting Preset, type in the name of it into the editor, then
select the text and apply the preset.

3. Quit the older copy of Scrivener and open & upgrade this project in the
current version.

4. For each line of text you created to store the formatting of a preset, se-
lect the text and create a style from it using the procedures for doing so
(subsection 17.3.2).

Once you have your presets all copied over and working to your expectations
as styles in the sample project, you can make this stylesheet the global default
in the Editing: Formatting settings pane (subsection B.3.2), by clicking the Set
Styles Defaults… button. Existing projects will need to import this style list from
another project, with the Format ▸Style ▸ ImportStyles…menu command. So long
as you keep the sample project around for a bit, it will make a convenient target
for importing from.
Updating anolder project touse these styles canusually be easily donewith the

Edit ▸Select ▸Select Similar Formatting command. The style can now be applied to
the bulk selection of text.

F.3.2 Preserve Formatting is Deprecated
In the past, the “Preserve Formatting” tool was the go-to method for preserving
the look of specific pieces of text, when one was otherwise using the compiler to
normalise and clean up the formatting of the output. This capability still exists
for backwards compatibility, but you should use the new styles feature for this
specific purpose, going forward.
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A secondary use for this feature, in the past, was to pass through raw markup
to HTML-based formats (like ebooks and web pages). This is also now a task that
Styles should handle, going forward, and youwill find these old options removed
from Preserve Formatting. There are still a few odd uses for preserve formatting
(subsection 15.7.6).

F.4 Project Bookmarks
Project notes are dead, long live project notes! That’s right, the feature formerly
known as Project Notes, a core part of Scrivener since its early Mac-only beta
days, is no more. The good news is that if you’ve benefitted from using them
in the past, then you should find it possible to continue working in a familiar
fashion going forward, and in fact you may find yourself using the new features
in ways you hadn’t before.
When we took a look at this feature, and what we could do to improve the

Project Notes window, it became clear that the whole idea had outgrown itself a
little. You couldn’t link to them, export them or even search through them—and
making it possible to do these things felt like replicating what already exists: the
binder.
At the same timewe realised there were a number of features in Scrivener that

were all kind of offering the same thing, but in different and disconnected ways.
The result of their combination is something we can concisely refer to as a single
new feature, Project Bookmarks:

1. Project References in the inspector sidebar.

2. Favorites made it possible to place items in choice positions within any
menu that let you pick a binder item from it (such as the “Go To” menu).

3. And of course, Project Notes, both in the inspector sidebar and window,
themselves.

The combination of these features can be thought of very simply: if you want
tomake a particular document globally accessible, either as a reference or for the
purpose of taking down notes, then bookmark the item. The Inspector sidebar
for bookmarks was expanded to include a built-in editor below the list.
For those that preferred ProjectNotes in awindow, theQuick Reference panel

(also new toWindows) now sports a project bookmark sidebar, mimicking all of
what the old window could do.
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Reference Links are No Longer Named

In the past you could provide a description to a reference. This field has
been left out of the new design, with the only text in the bookmark list
being the name of the item being referred to. Thus any descriptions you
used in the past will be discarded when upgrading the project, and you
should be aware that changing the name of a bookmark will directly re-
name the item in the binder, not how you refer to it in the list.

A side-effect of this merger meant that what we referred to as document ref-
erences in older versions of Scrivener also now benefit from this expanded in-
spector pane. Now all of those cross-references between items in the binder are
instantly accessible without even going anywhere in the main editors. You can
of course still do that too—references are just as powerful as they always have
been.
For those upgrading Project Notes, you will be presented with a dialogue box

informing you of where these notes have been imported into the binder. All of
your old Favourites and References will be automatically upgraded to work with
the new system.

— Read more about the new features in Project and Document Bookmarks
(section 10.3).

— If you’d like to read further into the background of this design change,
we’ve posted an article to our blog on the topic.

F.5 Writing History
Your daily progress, whether it be in going from zero to a goal, or from a bloated
work that badly needs trimming down to size, can be tracked using a new tool:
Writing History (subsection 20.1.4). Accessed via the Project ▸Writing History…
menu command, it not only does some simple summation and calculation for
you, but allows for easy export to CSV format, where the raw data can be taken
into a spreadsheet.

F.6 CustomMetadataOverhauled
We’ve added new types of custom metadata that you can use to enhance your
record-keeping. In addition to the trusty old text field, there are now list drop-
downs, checkboxes and dedicated date & time fields.
Scrivener’s new date field takes natural language dates and converts them into

a proper date and timestamp for you. However, it won’t do this to existing text
that you’ve stored in a text type field as there are too many different ways of
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inputing dates, making such an automated procedure risky. Making this con-
version by hand will be slower, but you’ll be able to ensure the conversions are
accurate as you do them:

1. Create a new date type column alongside your original date column (sub-
section C.4.6).

2. Set up an outliner view so that both the original hand-typed date column
and the new date column are side-by-side.

3. Using Tab to alternate between fields, copy and paste the date from the
text field into the date column. So long as you used a fairly standard or
easily parsed date format in the past, you should find our date detection
code picks it up and converts it to a proper date in the new field.

F.7 SnapshotManager
If you’re anything like me, you take a lot of snapshots, and furthermore you ask
the software to take a lot of snapshots for you as well. This is great for keeping
a track record of your progress safe as it develops over time—but it can mean a
lot of clutter builds up, especially in those projects that end up being used for
years at a time. Eventually even the most ardent data hoarders might come to
admit that a bad revision of something that was written five years ago maybe
isn’t worth hanging on to.
The Documents ▸Snapshots ▸Snapshot Manager tool has been added to help

keep the clutter at bay, and to find those old odd snippets you lost to edits years
ago. You can not only specifically search for text through all snapshots, you can
search by date as well, and once you have a search result you can prune the re-
sults from the project with one easy click. For example, search for <2y to find all
snapshots created over two years ago and delete them all.
Read more about it in The Snapshots Manager (subsection 15.8.5).

F.8 EnhancedOutlining
The outliner has always been a place where you can pack a lot of information
into the view, and thus an integral component in getting that sense of overview
that Scrivener can provide, down to theword counts of individual chunks of text
or keyword listings.
We wanted to broaden what the outliner can be used for however, as many

people also prefer this kind of device as a creative tool. To that end we’ve added
a few aesthetic options that can be used to present the outline as amore content-
focused tool, and as well some settings to have it emulate the iOS style listings,
made popular on macOS by Mail and a few other programs.

— Centring Outliner Content (subsection 8.3.9): much like fixed-width text
editing (which is also now a default, rather than text that stretches across
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the entire screen), you can trim down your outliner to a basic text column
and keep it balanced in the middle of the view, rather than pinned to the
left. If you’re spending a lot of time developing the outline itself, working
in titles and synopses, you might want to take a look at this simple but
comfortable adjustment.

— Using a Fixed Row Height (subsection 8.3.8): the outliner has always ex-
panded the height of each row to match the amount of content you put
into it. This content-biased approach means you never miss a word, but it
can sometimes be more efficient if every row takes up the same amount of
height. Scrolling becomes more predictable and static, and content is eas-
ier to parcel out with the eye. If you want to give it a quick look, check out
the new built-in “Three Pane (Outline)” layout, in the Window ▸Layouts ▸
submenu (or from the new View button on the far left of your application
toolbar).

— A bounty of new options have been added for adjusting the look of the
outliner. Take a look in the Appearance: Outliner settings pane (subsec-
tion B.5.9).

F.9 TheDevil in theDetails
We’ve gone over most of the major differences between versions 2 and 3, what
remains are a few of the smaller changes that are worthmaking note of. It would
not be possible to list every single change in the software, so this list will con-
centrate on those changes that could impact how you’ve used version 2 in the
past.

Subdocument counts in binder If you used the global setting that prints the
subdocument counts as a numeral to the right of containers in the binder,
you will be interested to know where that feature has been moved to. It
is now a project-specific setting, toggled with the View/Outline/Show Sub-
document Counts in Bindermenu command.

Migrating Your Settings By default, Scrivener 3 will start you with a clean slate
for settings, giving you the default out of the box experience, even if you’ve
used Scrivener in the past. If you would prefer to migrate your settings to
the new format, then use the Manage… button in the lower left corner of
Scrivener 2.x’s Setting window to “Save Preferences to File…”. Now switch
over to Scrivener 3 and use its ownManage… button to “Load Settings from
File…”.

Not all Settingswill be identical between versions, andScrivener 3will have
many more Settings than 2, but those that do match between programs
will be set, giving you a head start in getting the new version set up the
way you like.
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Dragging Links into Documents One of the simplest methods for creating a
link to a document from the text you are currently working on is to drag
and drop the document you wish to link to into the text editor. In Scriv-
ener 2, you were required to hold down the Option key while doing so.
In Scrivener 3 you can just drag and drop the document straight in (sec-
tion 10.1). Meanwhile Option-dragging now pastes the content of the
dragged document into the editor where you drop.

Dragging Text Out of Documents While we’re on the subject of dragging, you
will want to know that dragging selected text out of an editor and into
another context (such as the binder or another editor) will now move the
text, just as it is the default behaviour to move text that has been dragged
within an editor. If you would prefer Scrivener worked as it used to and
copied text dragged out of the editor, disable the Delete text dragged to
other areas option, in the Behaviors: Dragging & Dropping settings pane
(subsection B.4.4).

Editor Header Bar IconMenu Since the very beginning, Scrivener has always
presented a few useful commands pertaining to the document you are
working on, in the header bar icon beside the title of the document you
are editing. All of that is still there in Scrivener 3 (and more besides), but
you no longer have to click on the icon. Instead you can now right-click
anywhere in the header bar (other than the history buttons).

As for the icon itself, that is now something you can drag, just like drag-
ging the document itself from the binder; this form of dragging is just as
powerful as that. You can move an item to a new location, assign it to a
collection, create a hyperlink to it from another text, drag it to a second
header bar to load the document twice, and so on. In fact, whenever you
see an item icon, try dragging it, chances are it will act as a proxy for the
item itself.

“Go To” Menu in Header IconMenu When viewing a Scrivenings session in
the past, the “Go To”menu, found when clicking upon the header bar icon
menu (which incidentally is now a right-click anywhere in the header bar),
you would be given a simplified table of contents for the current session.
This was nice, as you could easily jump around from one section to an-
other within the text you were currently working on—but it could also get
in the way if you’re used to the feature letting you go anywhere at all in the
binder.

When in a Scrivenings session, you will note a new button on the right
hand side of the header bar (Figure F.1). Click this to view a concise table
of contents for the current Scrivenings session. You can click on entries to
flip between them, and elsewhere once you’re done. You can also use the
arrow keys on your keyboard to move between sections.
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Figure F.1 The new “Navigate to Section” button, first in this series of buttons
found on the right side of the header bar.

Excluding a Project from Backups If you have updated a project that was ex-
cluded from automatic backups, it will go on as excluded. However you
should know that the option to toggle this setting has been moved from
the File menu into Project ▸Project Settings…, under the Backup tab. While
there, youmay also note it is now possible to select a custom backup folder
on a per project basis.

Changing Composition Backdrop If you’ve enjoyed the ability to set a photo-
graph or texture to the background of your full screen writing environ-
ment, you’ll want to know that option (along withmany other project spe-
cific options by the way) has been moved to the Project/Project Settings…
panel, under “Background Images” in the sidebar. Everything else about
the feature should be familiar.

Project Properties are Compile Settings Instead of setting up the title of your
work, author’s name and so forth in a project setting panel, this is now
done directly in the main compile interface, under the “metadata” dog tag
icon on the right hand side. For projects that have been upgraded from
the 2.x format, you should find the information from Project Properties
migrated over to the new location for you.

Modified Default Revision Colours If youhave projectswhich are currently us-
ing revisionmarkings, you should be aware that the default revisionmark-
ing colours have been modernised, meaning the new version of Scrivener
will not “see” your old markings, for purposes of features that search by
or strip out markings. If you require consistency with existing projects,
you should visit the Editing: Revisions settings pane (subsection B.3.3) and
adjust the five levels to their previous levels.

You will find two macOS colour file sets in the Extras Pack (Appendix G).
Place these files into your∼/Library/Colors folder, and now they will be
available from the third tab of the standard macOS colour picker tool.

Modified Default Highlight Colours The set of default highlight colours that
Scrivener makes available in the Format ▸Highlight ▸ submenu have been
modernised. If you have upgraded a project that made use of highlights
in the previous version, you will find that colours do not match the old
highlights. This will mainly be of impact if you use the Edit ▸Find ▸Find by
Formatting… tool to locate highlights of a specific colour. If you want to
“upgrade” your existing highlights, you could use that same tool to search
for the old colours, and simply set the highlight to the new colour (from
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that point on you could very easily alternate between ⇧⌥⌘G to find the
next old highlight and ⇧⌘H to apply the new colour.

This will also be of concern if you have used the Scrivener colour palette to
rename the highlight colours in the past, as documented in Naming Text
Highlights (subsection 18.5.1). The easiest way to address this will be to
remove the ∼/Library/Colors/Scrivener.clr file and relaunch Scrivener so
that it creates a fresh one with the new colours.

The Text Editor Uses FixedWidth by Default In the past, Scrivener’s default
text editing mode displayed text the full width of the editor, no matter
how wide it was. This meant that if the editor grew very wide, text lines
could become unreadably long (and in fact fixed-width editing was set as a
default for full screen mode to combat the worst cases of this). Scrivener’s
default way of presenting text is now to a fixed width column, one that
will respect the relative number of characters that can be seen on a sin-
gle line, no matter the zoom level—or what some might think of as “mar-
gins” (though they have nothing to do with how the document will print
or compile). If you do not like this new way of working as a default, you
can switch it off in the Appearance: Main Editor settings pane, under Use
fixed width editor (subsection B.5.8). You can also adjust the width of the
text column in this panel, and whether or not it should be left-aligned or
centred within the editor.

Custom Categories for Project Templates You can now organise your project
templates into custom categories in the new project template chooser. Re-
fer to Custom Categories (section 5.4.3) for more information.

Locked Editors Divert Navigation In the past, when you locked an editor you
could freely work in the sidebar without content loading in that editor or
the other split. Now, if the interface is split the other editor will receive
the navigation request instead. If you would prefer the older behaviour,
change theWhen focused editor is locked in place setting in the Behav-
iors: Navigation settings pane to “Binder selection does nothing”.

Text Bookmark Feature Removed The Text Bookmark feature, which allowed
one to create markings in the text and then later jump to those markings
from a menu, has been removed. The Comments & Footnotes inspector
tab is more than sufficient for placing markings in the text, and clicking
on these notes in the inspector scrolls the editor to that point in the text.

If you have bookmarks left over in your text from previous versions,
you will need to strip them out, to avoid them ending up as com-
ments when compiling with inline annotations included. Alterna-
tively you can convert them to the preferred modern method, using
the Edit ▸Transformations ▸Convert InlineAnnotations to InspectorComments
menu command.
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Footnote Numbering Off By Default In the past, when you compiled your doc-
ument, all inspector footnotes would be numbered in the order they ap-
peared in the compiled output, and this number would be printed in the
upper left-hand corner of each footnote in the inspector. This still hap-
pens in the background in Scrivener 3, but the display of the numbers
themselves has been disabled as a default. Youwill need tomanually turn it
on with the View ▸Text Editing ▸Show Compiled Footnote Numbers in Inspec-
tormenu toggle.

Sync Folders Will Need to be Updated If you’ve been using the File ▸Sync ▸with
External Folder… feature in prior versions of Scrivener, you should be aware
that necessary internal changes havemade it so that an existing sync folder
will need to be rebuilt from scratch with the new version. The best result
will be to sync the project one last time to this folder so that it is fully up
to date, before upgrading, and then delete the folder and create a new one
after you’ve upgraded the project in the new version of Scrivener.

External Document Links Will Need Updating The way in which documents
are referred to internally has fundamentally changed in Scrivener 3, and
as a result, links pointing to items within projects with the External Links
(subsection 10.1.6) feature will need to be updated by hand. We apologise
for the inconvenience, but given how these links are located outside of the
original project that has been updated, there is no way for Scrivener to
know where the original item went.

Typewriter Scrolling NowWeaker It is typical to boast of things growing
stronger, but in this case we’d like to mention a feature getting a little
weaker. Typewriter scrolling had one flaw with the idea: it wasn’t terribly
good for editing. If you were scrolling and clicking into places to fix bits
of text, the behaviour to snap the typing line into the middle of the screen
wasn’t worth leaving on, leaving one to awkwardly toggle the option on
and off.

So in Scrivener 3 the feature now stops forcing you to one line when you
do just that. If you scroll away from the point where you have beenwriting
to fix a typo, the editor will start using that line as the scroll point, instead.
If you prefer to resume writing in the middle of the screen, hit the ⌘J
shortcut (or use the Edit ▸Find ▸Jump to Selectionmenu command).

Don’t like it? No problem, you can get the old way back by disabling the
Typewriter scrolling always jumps to scroll line setting, in the Editing:
Options settings pane.

Project Settings Unified In the past, many of a project’s settings were scattered
throughout different dialogues and menu commands. While most of the
visual preferences that pertain to how a project looks are still located in the
standard Viewmenu, the rest have all been gathered into a single dialogue,
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accessed through Project ▸Project Settings… (Appendix C).1, the following
features have been folded into this pane:

— Setting the Document Templates folder, previously set with the
Project ▸Set Selection as Templates Folder menu command.

— Custom project formatting overrides, found in the old Project ▸Text
Preferences… pane.

— The auto-completion list, previously found in the Project ▸Auto-
Complete List… menu command.

— Composition mode’s backdrop, which was previously set with the
View ▸Composition Backtop ▸ submenu.

— Disabling automated project backups, previously toggled with
File ▸Back Up ▸Exclude From Automatic Backups.

Project and Text Statistics The “Project Statistics” and “Text Statistics” panes
have been combined into a single feature, Project ▸Statistics… (⇧⌥⌘S), with
two tabs. The latter nowhas every feature the former once had exclusively,
and vice versa. To get statistics on a single text document, view it in the
editor alone and then use the “Selected Documents” tab. You can click on
statistics in the footer bar of the editor and get much of the same informa-
tion provided here.

Compiled draft statistics may alter

While we’re on the topic, it’s worth mentioning that you might see a dif-
ference in your overall compiled draft count. This is most likely going
to be a side-effect of your compile settings having been reset to default
when the project was upgraded. If you were using options in version 2
that added a significant amount of text (like for example all of your doc-
ument notes) thenupon checking yourword count in version 3 that num-
ber will have dropped.

Return to chapter ⤴

F.10 Menu Reorganisation
The main menu, from File to Window, has been completely rethought. We’ve
also introduced two new major menus, “Navigate” and “Insert”, the former fo-

1 It is worth noting that a project’s global metadata, such as the author and title of the work, has
been moved into the File ▸Compile… pane, and generally you can now set that universally in the
new General: Author Information settings pane.
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cusing on project window navigation of all sorts, and the latter now lists all of
the various types of things that can be inserted into text, from images to the cur-
rent date and time. If you make heavy use of the menus in Scrivener, you may
notice more than a few things have been moved around, but hopefully you find
the changes to be logical and easy to adjust to. As before, the Menus & Keyboard
Shortcuts (Appendix A) appendix provides a complete reference on every menu
command.
You can also search for a menu command you recall by name, from the Help

menu.

F.11 Updates to Version 3
We are constantly looking to improve Scrivener. The remainder of this section
will document significant changes since its initial 3.0 release in the Autumn of
2017. For a complete list of all modifications and bug fixes, refer to the release
notes page on our website.

Version 3.3.7
Writing toolsmenu commandsmoved
WithmacOS 15.1+, Apple has taken over themenu name, “Writing Tools”, where
Scrivener previously provided such tools as linguistic focus, the name generator,
web searching and dictionary look-up. The majority of these tools have been
relocated to a new menu called Edit ▸Reference Tools. Linguistic Focus has been
moved to to the Edit ▸Spelling andGrammar submenu.

Terminology updated to “Settings”
The user manual and tutorial have been updated to now refer to “Settings” and
“System Settings” instead of “Preferences”. Where relevant, they have also been
updated to refer to system settings by their new locations. Those using versions
of macOS older than 13.0 will still see the word “Preferences” used in most areas
of the interface, and some system settings may be located in different tabs than
documented.

Version 3.3.0
Title spacingwith noMarkdown hashes adjusted
When compiling to any of the Markdown-based compile formats, the Number
of hashes setting, in the Section Layouts: Title Options compile format pane
(subsection 24.2.4) will now no longer force an empty line after the titling ele-
ments, increasing flexibility for how this setting can be used. It can now be used
to create Markdown syntax that requires adjacent lines (such as definition lists
or tables).
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For caseswhere itwas beingused to generate syntax that does require an empty
following line, your compile formats will require adjustment. Simply add a car-
riage return in the Title Suffix field to add an additional newline, forcing an
empty line between it and the following material generated by the layout.

Version 3.2.0
Java removed from installation
Java is no longer embedded in Scrivener itself, meaning if you require enhanced
conversion for ODT and DOC formats, youwill need to install it separately to your
system. If you do not have Java installed, you will most likely notice a drop in
document quality and formatting capabilities (such as missing images and foot-
notes). This change does not impact DOCX, which is now fully supported natively
by Scrivener.

Contacts integration removed
Seamless integration between software has long been an advantage of using a
Mac. However in recent years Apple has been taking steps to cast such integra-
tion in a negative light, unduly presentingwarningmessages thatwould lead one
to believe theremight be a privacy or security concernwith allowing integration.
As such, we are removing Contacts integration from Scrivener, meaning youwill
now need to fill in your author information by hand, via the General: Author In-
formation settings pane. We apologise for the inconvenience.

Import OPML as text
For those outlining tools that workmore like folding text editors, we have added
a new option to the Sharing: Import settings pane, Import outline into main
text, which imports all OPML content into the main editor, rather than as head-
lines (or binder titles, in Scrivener’s terminology).

Header bar status colours changed
The colours used to indicate header bar status have been changed. “Locked in
Place” is now indicated by changing the shade of grey (darker in LightMode, and
lighter in Dark Mode) and adding a small lock icon to the right hand side of the
header bar. When splitting the editor, the targeted split will now be accented
using your system accent colour (or blue on older operating systems that lack
this setting).

Monochrome toolbar option available
⟨macOS11+⟩For those usingmacOS 11 or greater, the option to usemonochrome
icons in the toolbar has been added. If you prefer this look, setUsemonochrome
toolbars, in the Appearance: General Interface settings pane (subsection B.5.1).
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Version 3.1.3
Matching Text Finder

A tool has been added to the Inspector that will make it easy to find when one
document quotes some text found within another document verbatim (up to
and including the entirety of the document as a full duplicate). This will primar-
ily be useful in ensuring you haven’t accidentally plagiarised any of your sources,
but you may find it be generally useful as a tool for finding items which contain
common snippets of text. Read more about the Matching Text Finder (subsec-
tion 13.4.4).

Version 3.1.2
Copy items between open projects

Binder items can now more easily be filed to other open projects, similarly to
how the Scratchpad can do. You will find a new submenu, Documents ▸Copy to
Project ▸ , which is organised by all open projects. Within each project submenu
you can target a specific item to file the selected items from this project, into.
As with the “Move To” command, your last target will be remembered,

and supplied to a convenience command, Documents ▸Copy To “X” Project Again
(⇧⌥⌘C).

Improved PDF and print
When producing PDFs for self-publication, you may sometimes be required to
submit a PDF file that has crop marks applied to it. A new option has been added
to the General Options tab of the compile overview screen (section 23.4.3) that
will expand the page slightly so that thesemarks can be added. They will be used
to trim the book back down to size at the printer.
Additionally it may be requested that your cover image have a bleed amount

added around it. Cover images should be designed with a bleed built into them,
ideally, but you can use any image and Scrivener will scale it appropriately to
fit within the larger bleed area around the printed page. You can set the bleed
amount in the Cover tab of the compile overview screen (subsection 23.4.5).
Lastly, for proofing copies you might wish to distribute a much smaller PDF

than is necessary for print. New options to reduce the PDF size by compressing
and resizing images have been added to the main General Options tab, with the
Reduce file size settings.

FindDuplicates

Project search has a new option, Find Duplicates, which when enabled will cull
the current search result list to only those items that have duplicate data within
the scope of the search. Full duplicates can be found by searching for All, or spe-
cific duplications can be found among Titles or any other search criteria. Read
more about it in Finding Duplications (section 11.1.3).
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Shortcuts changed

The shortcut for copying text without any notation has been moved to a transi-
tory command that may appear after you’ve used the “Copy to Project” feature
(section 6.3.4).

Table F.1 Keyboard shortcuts changed in 3.1.2

Menu Command Shortcut

Edit ▸Copy Special ▸Copywithout Comments and Footnotes Removed

Documents ▸Copy To X Project Again ⇧⌥⌘C

Version 3.1.0
Support forMojaveDarkMode

⟨macOS 10.14+⟩ We have added full support for macOS 10.14 “Mojave” Dark
Mode. Themain project window, all subsidiary windows and panels will now be
displayed in dark grey when this system setting is enabled. You can also switch
to Dark or Light mode regardless of the system setting.
Since Scrivener is a rich text based editor, making the main text editing areas

dark proved to be an interesting challenge in balance. One can easily use colours
(such as bright yellow highlighted text) that renders the result completely un-
readable with light grey text on a dark grey background. Extensive colour fil-
tering has been developed to provide a dark editor look that yet still provides a
sense of the original colour treatment.
Lastly, it wouldn’t be Scrivener if you couldn’t change most of the colours.

Most of the colour settings in the Appearance settings pane (section B.5) are now
contextual, changing the setting for Dark or Light mode, depending on which
you are currently using.
Read more about Dark Mode (section 4.3).

Focusmode, for zeroing in on text

Some find it useful to fade out all of the text in the editor, save for a narrow
amount around the point where they are writing. With Focus Mode, you can
choose between line, sentence and paragraph and have the rest dimmed beyond
distraction. Focus can be applied to the main text editors, copyholders, Com-
position Mode and Quick Reference panels. Read more about Focus Mode (sec-
tion 16.4).

ePub 2 and legacymobi deprecated

Support for older ePub 2 and Kindle MobiPocket formats will be phased out of
Scrivener over a period of time, starting with 3.1. Unless you have customised
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compile formats for these file types in the past, you will no longer see these op-
tions in the Compile for dropdown, at the top of the compile overview screen.
Where projects have at least one custom ebook compile format designed for

ePub 2 or legacyMobi, then the compiler will continue using those settings, and
grant access to the legacy export engine. These engines will also be generally
available if you have saved a global custom format for these older file types.
For all current and future projects you are encouraged tomigrate to the newer

formats, which from now on will simply be referred to as “ePub” and “Kindle”, in
this documentation and elsewhere. The new methods provide the same easy
to use approach the older methods use, while also providing cleaner and more
technical access to ebook formatting itself, for those that need it.

Improved PDF and print
Additional layout features have been added to the compiler, for PDF and Print
output:

— Widows & orphan protection: cases where one line of text from a paragraph
is left all alone on the wrong side of a page break, can now be avoided (and
will be by default) when printing or compiling PDFs from Scrivener. This
capability is extended to longer multi-paragraph footnotes, which might
become split across pages. If for some reason you find this option produces
undesirable results, it can be switched off in the Text Layout format pane
(section 24.6), with the Avoid widows and orphans setting.

— Add a cover image: when compiling to PDF format you can now insert a
cover page at the very beginning of the document. This will be done using
the same interface that ebook file formats have used for setting up their
covers, and indeed will share the same Settings. Refer to Cover Options
(subsection 23.4.5) for further information.

— Dual Dialogue support for scriptwriting: when compiling a script to PDF
or Print, there is now support for laying out dual dialogue that has been
marked using the Preserve Formatting feature (subsection 19.1.4).

— Dialogue continuation markers around page breaks: additionally, dialogue
that would extend over a page break will be marked with traditional
“MORE” and “CONT’D” markers. Although we do not expect Scrivener
to be used to deliver final quality screenplays, these new features should
dramatically improve handing out proofing copies to readers, and provide
a better feel for how you intend the script to be read.

Easier access to section layout editing

In the past, if you were setting up your project’s compile settings and spotted
one small tweak you’d like to make to one of the Section Layouts (like making
the chapter heading a little bigger), you’d have to take note of the name of the
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Layout, edit the Format you are using (perhaps even duplicating it tomake a new
one if it is built-in), located the specific layout by name in a long list of them—
well, no more! Now you can simply double-click right on the Layout preview
youwant to edit and you’ll be taken straight to the Section Layouts editing pane.
We’ve also made it so that when double-clicking on built-in formats in the

compile overview sidebar, duplication will be done automatically.

Shortcuts changed

To standardise Scrivener withwhat has since become a convention, the Edit ▸Add
Link… command will now use the ⌘K shortcut. The shortcuts for splitting doc-
uments required adjustment to make this change happen. Additionally, taking
snapshotswith a title has been changed, asmacOS 10.14 nowuses the⇧⌘5 short-
cut for screenshots (Table F.2).

Table F.2 Keyboard shortcuts changed in 3.1

Menu Command Shortcut

Edit ▸Add|Edit Link… ⌘K

Documents ▸Split ▸ at Selection ⌥⌘K

Documents ▸Split ▸with Selection as Title ⇧⌥⌘K

Documents ▸Snapshots ▸Take Snapshot with Title ⌃⌘5

Hide sections of theDraft from ebook table of contents

For those cases where you need to create a “page break” in your ebook without
having that section listed in the HTML table of contents, a new option is available
to Section Layouts, in the “Settings” tab,Hide entry in HTML table of contents.
Section Types that make use of this layout will not be listed in the ToC, but will
still remain as formal sections, in the ebook’s content list, as well as in the navi-
gation guide use for jumping between chapters and other major divisions.

Version 3.0.3
MultiMarkdown 6 Support

Scrivener now fully supports MultiMarkdown version 6, and integrates version
6.2.3 in the application. The most noticeable difference will be the removal of
the MMD to RTF compile format, which is no longer supported, and the addition
of a native OpenOffice ODT format. No longer will you need to compile to Flat
XML and use LibreOffice to make the final conversion.
The other notable difference betweenMMD 5 and 6 is how themetadata is han-

dled for LATEX documents. If you have been using your own custommetadata in
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your compile Formats, you will likely need to update the metadata keys you use
to work with MMD 6. Instead of using a general purpose “LaTeX Input” metadata
key to include boilerplate files, there are now dedicated “LaTeX Leader” and “La-
TeX Begin” keys. The former is used to establish the initial preamble, the latter
to provide any further preamble after the insertion of document-specific meta-
data keys such as the title and author. Scrivener will of course make use of the
new system with all of its built-in LATEX document class selections.
Lastly we have added support for the Tufte (Book) document class for MMD to

LATEX and PDF compile formats.

Default Paragraph Style Removed

The option to automatically apply a paragraph style to text as you write has been
removed from the Project Settings: Formatting pane. Scrivener is designed to
work around the concept of not styling body text, and rather leaving it flexible
to be transformed by the compiler when exporting. Refer to Think Different
(section 17.1) for further rationale on this decision.

LaTeXCompile Support Improved

For theMultiMarkdown to LATEX compile file type, we have added five new com-
pile formats, to make switching between common document classes simpler.
With one click you can go from formatting your work in a screen-friendly “Mod-
ern” look, to a formal article design. Further documentation on the formats is
provided in MultiMarkdown LaTeX and PDF (section D.6).
For those looking to print a simple outline of topics, the “MarkdownOutline”

compile format now has a better default look when used in conjunction with
MMD to TeX or PDF.
In addition to this, those looking to use Scrivener as a pure LaTeX editing plat-

form (with no Markdown-based conversion) now have a dedicated project tem-
plate they can start from, in the Non-Fiction category: “General Non-Fiction
(LaTeX)”. This project template is designed to be used for the composition of
LATEX directly, but as well it features partial support for generating LATEX syntax
from Scrivener’s built-in formatting features.

Bulk KeywordManagement Improved

In the past,managing keyword assignments at a large scalewas limited to bulk as-
signment, by dragging keywords from the Project Keywords pane (section 10.4.5)
onto selected items in the background window. It is now possible to right-click
(or use the button) on selected keywords to assign or remove keywords from
the selected documents in the background.

ePub for…Kindle?
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In some cases youmay find third-party publishing agencies will only accept ePub
files. We have added a new option to the general options tab within the compile
overview screen (section 23.4.3) to “optimize for Kindle conversion”. This will
include a few tweaks to the underlying HTML, as well as navigation hints that
will make the ePub file convert more cleanly to Amazon’s plethora of different
formats.
This option should not be used with KDP itself. You should use a standard

ePub file for publication with Amazon.

Create NewCompile File Typeswith Post-Processing

⟨Direct-sale only⟩ Scrivener can tap into the command-line capabilities of your
system through the use of scripts embedded directly into the compile Format,
making it possible to package automatedworkflows towider audiencewho need
not know how to set up scripting themselves. In addition, post-processing has
been added to the PlainText compile file type,making it possible to createwholly
new file types from scratch and processing them into end formats.
Refer to the Processing compile format pane (section 24.22) for further in-

structions, and the Plain Text’s Markup compile format pane (section 24.10) for
tips on creating your own custom file types.

VellumExport Support

For those that make use of Vellum for the final design and production of their
books, we have created a compile Format for the DOCX file type. The format has
been tuned specifically to produce optimum results when imported into Vellum.
More details can be found in the appendix listing of Scrivener’s compile formats
(subsection D.2.11).

BetterMultivolume Support for Front/BackMatter

For those who write more than one volume into a single project, the front/back
matter feature has beenmodified to allow for automatic selection of preliminary
and endingmaterial, depending onwhich volume you currently have selected for
compile. This can be combinedwith the already existing feature to automatically
switch between front/back matter sets based on the type of file being compiled.
Refer to Linking Front/Back Matter to Compile Groups (section 23.4.1) for tips
on setting up your projects to work this way.

Version 3.0.2
InsertingMedia Time Stamps

It is now possible to insert the current time stamp into the text editor, while run-
ning audio/visual media in the other split. The menu command (Insert ▸Media
TimeStamp) does not by default have a keyboard shortcut, but one can be added
if you anticipate making heavy use of this feature (section A.1).
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A new script format, Format ▸Scriptwriting ▸Transcript, designed especially for
the transcription of audio and video material, has been added to the software.
You can put a media file into one split and write in another. The current time
stamp will be inserted when you press the Tab key on a new line. In conjunction
with the ⌘Return shortcut to pause & play the media while you type, Scrivener
can be an effective subtitling and transcription tool.

Browse theWeb fromWithin Scrivener

It is now possible to, in a limited fashion, browse theWeb fromwithin Scrivener,
when starting from a page that is being viewed in the main editors or the Book-
marks preview tab. In the past, all links would load in your main browser. To
enable this capability, set the Allow limited navigation in web pages option, in
the Behaviors: Navigation settings pane (subsection B.4.6).

Linked inline images can be updated fromdisk

For those working with inline images in the text editor that have been linked,
either to the binder or thefile system (subsection 15.6.4), if oneupdated the image
data externally they would have to reload the project to have the corresponding
graphic updated in the editor. Additionally, images that had their size changed
on the disk would not update the editor’s concept of its size, causing them to
appear squashed on reload.
Both of these problems can now be solved on the fly by updating the image

from the disk (section 15.6.4).

Version 3.0.1
ImportedMarkdown documents can be converted to rich text

When importing Markdown files with the File ▸ Import ▸ Import and Split… menu
command, a new option has been provided to convert Markdown syntax into
rich text, removing all Markdown syntax in the process. Internally, Scrivener
will convert the text to HTML and then import the HTML to RTF format. For
simple documents this should suffice, but for more complex texts, using native
Markdown conversion engines (such as those provided by MultiMarkdown and
Pandoc) will obviously produce the best results, at the expense of taking an extra
step.

Appearance themes now easily accessible

Scrivener has supported appearance themes, the ability to change the colours,
fonts and other appearance settings throughout the software, for many years.
It is now much easier to switch between these themes from the main Scriv-
ener ▸Theme ▸ menu. Read more about creating themes in Settings Presets and
Themes (subsection B.1.1).
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Image size can be requested in percentages for e-books

When using the image link placeholder syntax (subsection 15.6.5), it is now possi-
ble to request the size of the image in percentage points, as relative to the size of
the screen it will be displayed upon, in addition to any point size measurement
used for print-based output. Specifying image size in such terms as “100%”, to
fill the width of the display, is often more useful than trying to find precisely the
right size to display it at, when the shape and scale of the display the ebook is
being read upon can so dramatically change from one reader to the next.
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Extras Pack



A number of examples throughout this manual have been provided for you to
work with in a hands-on fashion. There is a downloadable “extras pack” from
our website, that you can obtain using the following instructions:

1. Visit the User Guides download section on our web page.

2. Beneath “Scrivener” on the left, select the “Extras Pack” option from the
“Select Format” dropdown menu.

3. Click the red download button to the left.

4. If your browser has not already done so, extract the folder from the down-
loaded .zip file and place it somewhere convenient.

The files are all numbered so you can easily find them in the folder.
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