European stressed vowels problem

pe
pedrober
Posts: 31
Joined: Wed Oct 19, 2011 10:53 pm
Platform: Mac

Thu Jun 29, 2017 11:05 pm Post

I am a newcomer to Scrivener. I write in different European languages with stressed vowels (Portuguese, Spanish etc.). The system keyboard, at this moment, is the Spanish one. Then, for example, to get an acute a (á), I press the accent first (´), because it acts as a dead key, and, then, the vowel (a). In Scrivener, the result is "´a" instead of "á" a lot of times, but not always. Keep in mind that this problem doesn't appear with the other installed programs in my mac. Any suggestion?

User avatar
kewms
Posts: 3748
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Fri Jun 30, 2017 5:02 am Post

What other programs are you using?

Mac Scrivener uses the Mac OS text system, which it shares with TextEdit. Microsoft Word, on the other hand, uses a different system supplied by Microsoft.

Katherine
Scrivener Support Team

ma
matsgz
Posts: 307
Joined: Mon Feb 11, 2013 7:56 am
Platform: Mac + iOS

Fri Jun 30, 2017 8:32 am Post

There is a bug that I think that Keith et al. are conscious of and will solve one day. If it works like on my Mac, the bug pops up when I'm writing in Scrivening mode AND the Inspector is open. It might be the same on Windows.
Scribo ergo sum

pe
pedrober
Posts: 31
Joined: Wed Oct 19, 2011 10:53 pm
Platform: Mac

Fri Jun 30, 2017 8:41 am Post

Thank you very much for your answer. Before purchasing Scrivener, most of my writing was done with Aquamacs. Anyhow, no problem with Textedit or Libreoffice. I don't use Microsoft Word. In Scrivener, the only heavy customization I am using is a home made "dark" theme: turquoise text on black background. I believe it's a matter of time between the dead key and the vowel pressings but I don't know.
I am using an i7 Macbook Pro.

pe
pedrober
Posts: 31
Joined: Wed Oct 19, 2011 10:53 pm
Platform: Mac

Fri Jun 30, 2017 8:43 am Post

Yes, the inspector is open. I'll close the inspector and I'll report.

pe
pedrober
Posts: 31
Joined: Wed Oct 19, 2011 10:53 pm
Platform: Mac

Fri Jun 30, 2017 9:22 am Post

No relationship with the bug referred by Matsgz. Interesting discovering: if I slow down my typing speed (more, even a long time between both key pressings), no problem. Any suggestion?

pe
pedrober
Posts: 31
Joined: Wed Oct 19, 2011 10:53 pm
Platform: Mac

Fri Jun 30, 2017 2:53 pm Post

More information: when I press the "dead" key, Scrivener outputs a small yellow box waiting for the next key. This doesn't occur in any other installed program.
If it's impossible to solve this problem, Scrivener is not usable for me (or any other serious typist).

User avatar
kewms
Posts: 3748
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Fri Jun 30, 2017 4:36 pm Post

What version of OS X do you have?

Are you writing standard text, or in scriptwriting mode? Are you using any keystroke expanders? Automatic spellchecking? We've encountered a similar issue with some Asian languages, where the more different applications are "watching" the text, the more of a pause there can be in the generation of complex characters.

Katherine
Scrivener Support Team

pe
pedrober
Posts: 31
Joined: Wed Oct 19, 2011 10:53 pm
Platform: Mac

Fri Jun 30, 2017 4:48 pm Post

Thank you very much for your message.
I am using Mavericks. I started from a General Non Fiction template and, then, I am writing standard text. No keystroke expanders at all. I have switched automatic spellchecking off but it doesn't make any difference.
System input sources are set to Spanish-ISO, but the op sys language is English.
Are you able to reproduce the behaviour I have outlined? I really like Scrivener but it's impossible to work in European languages without solving this issue.

pe
pedrober
Posts: 31
Joined: Wed Oct 19, 2011 10:53 pm
Platform: Mac

Fri Jun 30, 2017 5:01 pm Post

I forgot to mention I have been playing with Key Repeat and Delay Key Repat params in System Preferences without success. I have also switched Scrivener language from English (my usual choice) to Spanish without any improvement.

Sc
ScriverTid
Posts: 319
Joined: Tue May 06, 2014 9:38 am
Platform: Mac

Fri Jun 30, 2017 5:58 pm Post

The yellow box you refer to is the standard Mac behaviour when you use 'Alt + a letter' to generate an accent. For example, to get á

1. I press "Alt e" - this generates a yellow box with the ´ accent inside it
Alt + e.png
Alt + e.png (10.61 KiB) Viewed 929 times

2. I then press "a" and this generates "á"

pe
pedrober
Posts: 31
Joined: Wed Oct 19, 2011 10:53 pm
Platform: Mac

Fri Jun 30, 2017 6:13 pm Post

I don't use the Alt key to generate an accent. I use the dead key available in Spanish ISO keyboard (´) and, afterwards, I press "a". So, the yellow box doesn't appear in other programs, only in Scrivener.

Sc
ScriverTid
Posts: 319
Joined: Tue May 06, 2014 9:38 am
Platform: Mac

Sat Jul 01, 2017 2:41 pm Post

Is it the same yellow box as shown above? If so, could Scrivener be treating your 'dead key' as if it's the Alt/Opt key?

pe
pedrober
Posts: 31
Joined: Wed Oct 19, 2011 10:53 pm
Platform: Mac

Sat Jul 01, 2017 7:19 pm Post

Yes, it is.

Sc
ScriverTid
Posts: 319
Joined: Tue May 06, 2014 9:38 am
Platform: Mac

Sun Jul 02, 2017 9:43 pm Post

I think that's what happening then. Someone with greater knowledge than I might be able to help with how to remap your keyboard in Scrivener (I know how to add menu shortcuts, but this is something different).