[LH2828] Style keyboard shortcuts conflict with special characters

Ma
Marshall
Posts: 2
Joined: Mon Oct 08, 2018 5:12 pm
Platform: Windows

Mon Oct 08, 2018 5:38 pm Post

On Windows, special characters can be entered into text by holding down Alt and typing a number on the numeric keypad. This is handy for quick access to certain characters without changing the keyboard layout. Scrivener allows Alt+1 to Alt+9 to be assigned to different styles – and those are the only keys that can be assigned to styles.

As a result, when pressing Alt+0252 to get the "ü" character, for example, Scrivener will change the current paragraph to whatever style is assigned to Alt+2, then the style assigned to Alt+5, and finally back to the style assigned to Alt+2. Then, it will insert the "ü" character in the document.

Expected result: The Scrivener style shortcuts should only be activated when Alt is pressed with a single number, not a string a numbers. Or, Scrivener style shortcuts should only apply to the numbers above the letters rather than numbers on the numeric keypad.

Beta 2.9.0.10
Windows 64-bit

jj
jje
Posts: 69
Joined: Sun Jul 06, 2014 5:57 pm
Platform: Windows
Location: Sussex, UK

Tue Oct 09, 2018 8:27 am Post

I was about to post the same thing. Please could the option to customise the style shortcuts be added to the final release to avoid this problem for those who are experiencing it? (Apart from anything else, I have been using the Ms Word style shortcuts for so many years that they're second nature and I would love to be able to set Scrivener to use the same ones.)

Thanks.

th
thePhilosoraptor
Posts: 434
Joined: Sat Feb 13, 2016 3:28 am
Platform: Windows

Tue Oct 09, 2018 8:22 pm Post

Thanks for posting. This bug has been filed.
Bryan Bender