Some Questions Scrivener 2.9.0.8 Beta

Ch
Chris1983
Posts: 4
Joined: Tue Sep 25, 2018 2:18 pm
Platform: Windows

Tue Sep 25, 2018 2:30 pm Post

Hey,
I wrote my whole new book with the new Windows Scrivener Beta Version.

I've got some question, that i cant answer by myself. Maybe you could help me?!

Where can i change how Headlines like "H1" look like? Actually in my Scrivener they are Calibri, Bold, 18. Where can i change them to Calibri, Bold, 14 for the whole document?

Are there any options in Scrivener to change hyphenation or does that work fine for german language?

I just exported my Document as .mobi to check how it looks for Kindle Readers. And there i just have seen, that all my umlauts (ä,ö,ü, etc.) are not shown. I choose "german" as Language but it doesnt work.

Thanks for your help!

User avatar
AmberV
Posts: 22179
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Wed Sep 26, 2018 12:30 pm Post

Where can i change how Headlines like “H1” look like? Actually in my Scrivener they are Calibri, Bold, 18. Where can i change them to Calibri, Bold, 14 for the whole document?


I presume you used a style to set this formatting at some point, like “Heading 1”, in the Format Bar. If so it’s a simple matter. You should go through the "Styles" document in the interactive tutorial from the Help menu, for the basics on how to work with styles. Toward the bottom you'll see a section on "Redefining Styles".

Are there any options in Scrivener to change hyphenation or does that work fine for german language?


It doesn’t look like there is any kind of hyphenation in the writing area itself, if that is what you mean. For compile, you will find an option in the Text Layout compile format pane, for those formats that support it. This doesn’t actually hyphenate to be clear, it just tells whatever opens this file that you would like to have hyphenation used. How that is used (with languages) and whether it is, is up to the software typesetting the document.

I just exported my Document as .mobi to check how it looks for Kindle Readers. And there i just have seen, that all my umlauts (ä,ö,ü, etc.) are not shown.


It would help to know which Mobi option you used, and I think you should also be seeing a Save source files in a folder with exported ePub file setting, in the general options tab on the right side of the compile overview screen. I’d turn that on and see what kind of HTML you’re getting.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Ch
Chris1983
Posts: 4
Joined: Tue Sep 25, 2018 2:18 pm
Platform: Windows

Sun Oct 07, 2018 5:45 pm Post

Thanks for your answer. That helped me a lot. :)

Now i got some further questions:

1. I just configured my own format in the compile options based on the kindle mobi format. It looks good so far, but instead of "Inhaltsverzeichnis" the headline for my Table of Contents is "Contents" - see Attachments. Can i change this?

2. If i open the book for the first time or if i click on Kindle or Kindle Reader App on "Start" or in german "Anfang", then i dont land at the beginning og the book ("Vorwort") but i land in "Vorsicht vor Überoptimierung". The 5th chapter. And i really donnow why. Any idea? (see attachments)

3. Actually i use the structure of content, you can see in the attachment 3.jpg. And i really would like to see "Start", "Morgenroutine", "Arbeitstechniken", etc. as a Big Headline OVER the H1 Headlines for "Vorwort", "Was genau ist Multiple Sklerose?" and so on. Is that possible. I activated "include text of containing group" and included "Start" but i can't see it in the outcome mobi. Any ideas?

Thanks, Chris
Attachments
2.2.jpg
2.2.jpg (233.35 KiB) Viewed 432 times
1.jpg
1.jpg (102.82 KiB) Viewed 432 times
1.2.jpg
1.2.jpg (165.44 KiB) Viewed 432 times

Ch
Chris1983
Posts: 4
Joined: Tue Sep 25, 2018 2:18 pm
Platform: Windows

Sun Oct 07, 2018 5:45 pm Post

the other attachements... :)
Attachments
3.jpg
3.jpg (58.45 KiB) Viewed 432 times
3.1.jpg
3.1.jpg (186.69 KiB) Viewed 432 times
2.jpg
2.jpg (24.26 KiB) Viewed 432 times

User avatar
AmberV
Posts: 22179
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Mon Oct 08, 2018 3:29 pm Post

  1. It looks like you’ve already found the place where this change would be made. It’s not impacting the HTML table of contents page though—since this area of the software is not yet complete, I wouldn’t expect everything to be perfect just yet. But your settings are correct, so as it does complete, it should start working better.
  2. I’m not sure about this one, but the regular reading program isn’t the best place for testing stuff like this, since it remembers books you’ve looked at before, even after you delete them.
  3. Not sure if it is working yet, but you can try putting a document in your binder that uses the same “Inhaltsverzeichnis” as its binder title. That file will then be used for the table of contents, giving you complete control over its presentation.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Ch
Chris1983
Posts: 4
Joined: Tue Sep 25, 2018 2:18 pm
Platform: Windows

Thu Oct 11, 2018 10:16 am Post

1. Thanks. By the way: Do you know, when the news scrivener is finished? i searched @ google for this problem and found some threads with the same problem. It seems, that it can be solved with the software sigil. but mabee just with epub, not mobi. I will check this.

2. No, i checked this in the kindle app AND on my original kindle and i still got this problem. It seems, that the Headline. In The attachement from my kindle you can see that "Vorsicht vor Optimierung" doesnt seem to be unter "Titelei" (TOC) and it appers, wenn i touch on "Start". Seems that the problem is in scrivener, but i have no idea :/

3. thanks. i will give it a try