[JH] Default fonts in Scrivener 3

User avatar
CWBillow
Posts: 27
Joined: Sat Jul 15, 2017 7:49 pm
Platform: Windows

Fri Mar 02, 2018 4:17 am Post

I cannot for the life of me get my default fonts to "stick."

If I open Scrivener, and I go to File / Options / Editing / Formatting, the fonts showing there are Segoe 12 Semibold. But in my project they are showing as Calibri Regular13.

What do I need to set the fonts "permanently" they way I will want them for most projects?

Ma
Major Major
Posts: 213
Joined: Tue Apr 30, 2013 7:52 pm
Platform: Windows
Location: Oakville, ON Canada

Fri Mar 02, 2018 3:51 pm Post

The Options setting will apply to new documents. To convert existing documents, go to Documents | Convert | Formatting to Default Text Style.

User avatar
CWBillow
Posts: 27
Joined: Sat Jul 15, 2017 7:49 pm
Platform: Windows

Fri Mar 02, 2018 6:25 pm Post

But it does not seem to do that. I just wen t into Scrivener, checked my settings, which were all set to Segoe 12, and then started a new document.

It came up Calibri 11.

Then I went to Documents | Convert | Formatting to Default Text Style.and wanted to convert the font over, but that didn't work either.

User avatar
rdale
Posts: 1330
Joined: Tue Jul 14, 2015 1:07 pm
Platform: Mac, Win + iOS
Location: St. Louis, MO
Contact:

Fri Mar 02, 2018 7:04 pm Post

It's possible that you have the setting under Project->Project Settings that's overriding the general purpose default. If so, you can either disable that override, or change the project's Formatting settings there.

If that's not it, then you've got a bug to report in the beta section.
FKA: robertdguthrie
AKA: R Dale Guthrie, Robert, Mr. Obscure, and "Oh, it's you again".

User avatar
CWBillow
Posts: 27
Joined: Sat Jul 15, 2017 7:49 pm
Platform: Windows

Fri Mar 02, 2018 8:43 pm Post

I looked there...nada.

Thanks though...

Chuck

Ji
JimRac
Posts: 784
Joined: Wed Aug 27, 2014 2:06 pm
Platform: Win + iOS

Fri Mar 02, 2018 8:53 pm Post

@CWBillow - You've been posting Windows Scrivener 3 questions to the Windows forum.

You'd possibly get a faster response and actually get on the Windows developer's radar if you posted these Win V3/Beta observations directly into the Beta Testing forum here:

http://www.literatureandlatte.com/forum/viewforum.php?f=57

Just saying, as you're going to the trouble of posting them, might as well put 'em in the right place, so the right people will read them. :)

Jim

User avatar
kewms
Posts: 4127
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Fri Mar 02, 2018 9:30 pm Post

JimRac wrote:@CWBillow - You've been posting Windows Scrivener 3 questions to the Windows forum.

You'd possibly get a faster response and actually get on the Windows developer's radar if you posted these Win V3/Beta observations directly into the Beta Testing forum here:

http://www.literatureandlatte.com/forum/viewforum.php?f=57

Just saying, as you're going to the trouble of posting them, might as well put 'em in the right place, so the right people will read them. :)

Jim


Moving the thread for that reason. -- Katherine
Scrivener Support Team

User avatar
MimeticMouton
Posts: 8680
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sat Mar 03, 2018 1:39 am Post

There are several different fonts you're setting in the Editor options, so first is just to double-check that you've set the main text formatting there as you want and that those settings are sticking in Options, even though they don't seem to be working in new projects. The main formatting is set using the editor within the Options > Editing > Formatting tab. Make sure the sample text is selected, then click the "Aa" button to open the font settings. Once you've closed the fonts dialogue, the sample text should show the new settings. Is that working, such that when you close and restart Scrivener, the settings are still correct in Options?
Jennifer Hughes
(MM for short)

User avatar
CWBillow
Posts: 27
Joined: Sat Jul 15, 2017 7:49 pm
Platform: Windows

Mon Mar 19, 2018 9:35 pm Post

MM, Now I feel foolish. I just went back and followed your post steps. It worked. Sigh... Thank you kindly.

Now, is that setting the one that also controls the default font for the the Outline and Corkboard? Because it doesn't seem to do that. I set the font in Settings for Segoe Semibold 12 pt. The Segoe carried over, but not the Semibold or the 2 point,

Is there another step I need to follow up with to make the font "project-wide"?

th
thePhilosoraptor
Posts: 510
Joined: Sat Feb 13, 2016 3:28 am
Platform: Windows

Mon Mar 19, 2018 9:44 pm Post

That is just to set the default text for your documents. To change the default fonts for menus, Outliner information, etc. you can go to File > Options and click on Appearance. It should open to the General tab, which has a Fonts pane near the bottom of the window.

Hope this helps!
Bryan Bender

User avatar
CWBillow
Posts: 27
Joined: Sat Jul 15, 2017 7:49 pm
Platform: Windows

Mon Mar 19, 2018 9:51 pm Post

It does, Bryan. I'll poke around there for a bit. Thanks