[LH2374] Dragging a Text File to Create Document Link inserts the Text instead of creating Link

Sh
Shipleyaust
Posts: 91
Joined: Wed Jul 10, 2013 5:15 am
Platform: Mac, Win + iOS
Location: Hunter Valley, NSW, Australia
Contact:

Tue Feb 20, 2018 8:07 am Post

I have been able to create a number of documents links and it all works quite well. And I can drag multiple links like the two audio and video files from the Research Folder to create the proper links.

But I tried dragging three text files from the Draft Folder and it actually placed the content of those three folders in, instead of three links, one for each folder. The three links you see encircled in purple box, were done on Mac and worked fine. When I tried same things on Windows, it brought in all the text (which I since deleted). Then I tried only dragging one text file, thinking doing multiple ones might associated with the Scrivenings bug, but even the one inserted all the text in that document. Of course, I was able to add to document links one at a time on Windows 2903 using the Link to Document command on the Edit menu.

I was also able to select the three documents and use Copy Special > Copy Documents as Structured Links List and then Paste them in.

So everything works fine except dragging a text document brings in the text instead of creating the Link.
Attachments
Scrivener 2903 Text Link Issue.png
Scrivener 2903 Text Link Issue.png (468.96 KiB) Viewed 474 times

User avatar
MimeticMouton
Posts: 8576
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Tue Feb 20, 2018 10:44 pm Post

Hold the Alt key while dragging to insert a link instead of the text. Windows hasn't yet switched this behaviour in 3.0 (in Mac 2.x, you likewise held the Option key while dragging to insert the link, as you still do for images--3.0 is just adjusting this slightly to make the simple drag what is typically the most common action for the different types).
Jennifer Hughes
(MM for short)

Sh
Shipleyaust
Posts: 91
Joined: Wed Jul 10, 2013 5:15 am
Platform: Mac, Win + iOS
Location: Hunter Valley, NSW, Australia
Contact:

Tue Feb 20, 2018 10:56 pm Post

Thanks for that Jennifer. I was not aware you needed to Alt+. I am pretty sure I did not use Opt+drag on Mac, but will go back and verify.

User avatar
MimeticMouton
Posts: 8576
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Tue Feb 20, 2018 11:01 pm Post

3.0 on Mac changed the behaviour so an unmodified drag of a text document to the editor drops the link, and Opt-drag drops the text. Previously it was the other way around, and Windows just hasn't been updated yet to make the unmodified drag drop the link.
Jennifer Hughes
(MM for short)

Sh
Shipleyaust
Posts: 91
Joined: Wed Jul 10, 2013 5:15 am
Platform: Mac, Win + iOS
Location: Hunter Valley, NSW, Australia
Contact:

Tue Feb 20, 2018 11:42 pm Post

Thanks - yes, that is what I experienced.