[JH] Bug: Scrivener issues "Scrivener is Not Responding."

dl
dlt123me
Posts: 4
Joined: Tue Dec 26, 2017 8:49 pm
Platform: Windows

Sun Dec 31, 2017 9:23 pm Post

I am running Version: 2.9.0.2 Beta (50498) 64-bit - 21 Dec 2017, on a Windows 7 64bit system running 32 GB ram.

When I run the tutorial or even if I create a new project, if I click on anything in the Application it causes W7 to display "Scrivener is Not Responding." Something is definitely not working. I cannot do anything in this Beta...

I am running Eset Security System Antivirus and Malwarebytes on my system... Both have been disabled and still am not able to do anything in the Beta of Scrivener...

I should also add... that at times it will finally respond, but the wait is unacceptable. Others have mentioned this as well.
Remember: What you believe does not change Reality!

se
setherd
Posts: 18
Joined: Tue Apr 08, 2014 7:00 am
Platform: Mac, Win + Linux

Mon Jan 01, 2018 7:59 pm Post

I had a similar issue and it was a bad hard drive

dl
dlt123me
Posts: 4
Joined: Tue Dec 26, 2017 8:49 pm
Platform: Windows

Tue Jan 02, 2018 3:06 am Post

setherd wrote:I had a similar issue and it was a bad hard drive


That would make sense since something must have been stored on a corrupted portion of your drive. As for my system, my drives are fine, but the software is very sluggish as others have mentioned in their posts.

I really look forward to V3 being released...
Remember: What you believe does not change Reality!

ja
jandrewnelson
Posts: 16
Joined: Tue Oct 27, 2015 11:27 pm
Platform: Windows

Tue Jan 02, 2018 3:58 pm Post

I've run into the same problem as well -- but no hard drive issues. New laptop and all my diagnostics say the HD is working great.

I did see a suggestion somewhere to change the frequency of auto-save/backup and it seemed to help, but not enough. The "Scrivener Not Responding" error is frustrating and may qualify my laptop for the first launched into space from South America.

Jerry Nelson
Buenos Aires

User avatar
MimeticMouton
Posts: 8395
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Fri Jan 12, 2018 5:52 am Post

If you boot Windows into Safe Mode with Networking, are you able to run Scrivener without the lag there? Given that this is occurring in a new blank project (if I understand correctly), it may be the delay is coming from interaction with other software installed on the system, and testing in Safe Mode will reduce a measure of that.
Jennifer Hughes
(MM for short)

ja
jandrewnelson
Posts: 16
Joined: Tue Oct 27, 2015 11:27 pm
Platform: Windows

Fri Jan 12, 2018 9:19 am Post

[quote="MimeticMouton" Given that this is occurring in a new blank project (if I understand correctly)[/quote]

I don't know about others, but in my case, you do not understand. I get the 'not responding error' frequently and randomly while I'm working on a project. Not just once. Not upon start-up, but many times WHILE I'M WRITING ON A PROJECT.

User avatar
MimeticMouton
Posts: 8395
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Fri Jan 12, 2018 4:55 pm Post

@jandrewnelson - You're right, I was responding to the OP's comment of the freezing happening even in a new project, and perhaps I was misremembering from another thread about clicking in the project. If your issue isn't the same, we could use more details on it. Does the hanging only happen in the one project? How large is the project where you're seeing the freezing and what's the average size of the documents you're working in when you get the freezing? What actions trigger the "not responding" message?
Jennifer Hughes
(MM for short)

ja
jandrewnelson
Posts: 16
Joined: Tue Oct 27, 2015 11:27 pm
Platform: Windows

Fri Jan 12, 2018 6:33 pm Post

Scrivener stops responding randomly with no duplicatable steps. It stops in different projects, but not all and when it stops responding, it may go into hibernation for an hour or just a few minutes.

I will say though that the non-responsiveness has decreased since I first noticed this thread. It's almost as if someone may have fixed the issue?

Thanks!
Jerry Nelson

User avatar
MimeticMouton
Posts: 8395
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Fri Jan 12, 2018 7:55 pm Post

jandrewnelson wrote:I will say though that the non-responsiveness has decreased since I first noticed this thread. It's almost as if someone may have fixed the issue?


Hmm, in that case you might take a look at what's changed or updated on your computer, as there's no change in Scrivener itself (assuming you've been running 2.9.0.2 the whole time)--we can't make remote changes or anything of that sort; the software is installed locally on your machine and must be manually updated. But there could be a difference in what other programs you have running in the background, or Windows may have performed an update at some point, which could certainly affect things.
Jennifer Hughes
(MM for short)

ja
jandrewnelson
Posts: 16
Joined: Tue Oct 27, 2015 11:27 pm
Platform: Windows

Fri Jan 12, 2018 9:40 pm Post

I'm not a computer guy at all, but I did hear something about Windows doing an update. I wonder if that may have caused something?

Thanks for the help though -- we'll get to the bottom of this! :D