[LH2828]: Style shortcuts interfere with Windows Alt codes.

Ty
Typoglyphic
Posts: 3
Joined: Tue Aug 16, 2016 1:54 am
Platform: Windows

Sat Dec 23, 2017 4:32 pm Post

Currently, in a default scrivener project, entering an alt code into the editor, such as Alt+0133 (for an ellipsis) or Alt+0151 (for an em-dash) will cause the text to rapidly change styles, completely disrupting text entry. As it is, I had to create five new styles, set them to Alt+1-5, then delete them, just to preserve both the style system and the use of alt codes.

I see a few solutions to this, the easiest being a way to quickly unset style shortcuts without having to assign them to a temporary style first. Better would be to add style shortcuts to the Keyboard section of the Options menu, so users can set custom key combinations to better suit their needs.

Observed on Windows 10 Home Edition, Scrivener Version: 2.9.0.2 Beta (50498) 64-bit - 21 Dec 2017

th
thePhilosoraptor
Posts: 110
Joined: Sat Feb 13, 2016 3:28 am
Platform: Windows

Mon Jan 08, 2018 10:15 pm Post

Thanks for this! This has been filed and we are looking into how best to correct this issue.

In the meantime this should save you a step when attempting to remove shortcuts:

Select some text with the style whose shortcut you want to remove, then choose Format > Style > Redefine Style from Selection and select the style name, and in the dialog that opens, select "None" for the shortcut, then OK to apply the changes.

Hope that helps!
Bryan Bender