Page 1 of 1

[LH2796] Process hangs when not following through tutorial on fresh install

Posted: Fri Dec 08, 2017 1:24 am
by Intimate
Doing the tutorial after a fresh install of the program and then hitting cancel when prompted to create a file name leaves you unable to use Scrivener. Reopening the program does nothing, and I had to force close it in the task manager. After doing that I could open the program, so I tried to recreate the events. This time the project templates box kept me from completely unable to use the program. It allowed me to pick what I want to do. Not something that is possible for the first run of Scrivener after installation.

Re: Process hangs when not following through tutorial on fresh install

Posted: Fri Dec 08, 2017 1:32 am
by AmberV
I don’t get a result like that myself on a fresh run:
  1. New install, launch the software.
  2. Press OK to confirm the default backup folder.
  3. Elect to take the tutorial.
  4. On the screen about saving it, click Cancel.
Result: the template chooser pops up, and I can do whatever I want. Maybe try reinstalling the software—sometimes things can get jammed up on install, and hangs on basic window loads is one common symptom of that.

Re: Process hangs when not following through tutorial on fresh install

Posted: Fri Dec 08, 2017 1:38 am
by Intimate
Well, I'm merely posting this so one doesn't have to resort reinstall the program if that is the fix. Not that they would need to if they knew how to kill the process. If anything, a reboot would work. But just wanted to mention as it is. To anyone not computer savvy, it would be quite confusing on where this new program went. I'm just here to mention it in case a fix can be made where it doesn't require the end user to do anything if this occurs on a fresh install. That being the templates box being there 100% of the time after the fresh install.

Re: Process hangs when not following through tutorial on fresh install

Posted: Fri Dec 08, 2017 3:01 am
by MimeticMouton
Thanks, I've filed this--cancelling the tutorial from the startup wizard should just open the Project Templates window but isn't currently doing so on Windows.