[LH2306] : Pasted text not responding to font size changes

lw
lwinger
Posts: 7
Joined: Wed Nov 22, 2017 7:11 pm
Platform: Windows

Sat Dec 02, 2017 9:02 pm Post

I copied five paragraphs of "Lorem Ipsum" from http://www.lipsum.com into a new project and document. I can change the type font but not the font size using any menus or shortcuts I am, however, able to adjust paragraph, line and indent characteristics.

th
thePhilosoraptor
Posts: 60
Joined: Sat Feb 13, 2016 3:28 am
Platform: Windows

Sat Dec 02, 2017 10:03 pm Post

Hello! I was not able to reproduce this. Can you walk me through the steps that caused this bug (what menus you tried, how you pasted the text, things like that)

Thank you!
Bryan Bender

lw
lwinger
Posts: 7
Joined: Wed Nov 22, 2017 7:11 pm
Platform: Windows

Sat Dec 02, 2017 11:11 pm Post

I pasted the text, highlighted it and it was correctly identified in the format tool bar as Arial with paragraph spacing of "1.0x 0.0/15.0." The format bar font size drop down only reads "-1" and when I drop down the font size choices, no other size selections work. I also tried Format/Fonts/Show Fonts with the same results.

I have no problem changing fonts sizes on text that I type in manually or copy from a Word document. This appears to be a problem unique to text that is pasted from websites. I have tried with text from several websites with the same results.

th
thePhilosoraptor
Posts: 60
Joined: Sat Feb 13, 2016 3:28 am
Platform: Windows

Sun Dec 03, 2017 1:50 am Post

Which web browser are you using? That may help me track down the interaction.
Bryan Bender

lw
lwinger
Posts: 7
Joined: Wed Nov 22, 2017 7:11 pm
Platform: Windows

Sun Dec 03, 2017 5:10 am Post

Chrome Version 62.0.3202.94 (Official Build) (64-bit)

User avatar
MimeticMouton
Posts: 8372
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Wed Dec 06, 2017 6:32 am Post

Thanks for the report. This is an issue particularly with pasting from Chrome (and probably all Chromium-based browsers). You can avoid the problem using Paste and Match Style (Ctrl-Shift-V) to paste as plain-text, matching the document formatting in Scrivener, or do a regular paste and then use Documents > Convert > Text to Default Formatting... which will retain pasted character formatting like bold and italic. (You can set a keyboard shortcut for this in the Keyboard tab of File > Options, which will simplify using it.)
Jennifer Hughes
(MM for short)