iOS unusable: changes all script element settings

2a
2albion
Posts: 31
Joined: Tue Aug 14, 2012 12:38 am
Platform: Mac + iOS

Thu Sep 14, 2017 6:16 pm Post

I formatted my script on Mac Scrivener, saved it, exited the program — but when I open it on my iPad running ios11 public beta GM, all the elements have changed. Almost everything is now general text, except for parentheticals that have stayed as the correct element but the font has changed (unlike the general text). This is a serious bug because when I exit iOS Scrivener it automatically updates to Dropbox and the entire long document needs to be manually reformatted all over again on the Mac. I did this a couple of times for many hours before realizing what was going on. This makes Scrivener unusable on iOS. Yikes!

2a
2albion
Posts: 31
Joined: Tue Aug 14, 2012 12:38 am
Platform: Mac + iOS

Thu Sep 14, 2017 9:12 pm Post

Update: on iOS, in the middle of a word the fonts changed and the rest of the sentence became bold. I deleted that and the sentence before (no bold elsewhere except in a scene heading at the top of the page), tried again and the font changes for the start of each line of dialogue and the second letter became all caps and bold. The element has changed to match the first element on the page: Scene Heading. It’s only dialogue that changes font, bold, caps and always on the second letter. If I delete the Scene Heading at the top of the page, yes the last line of new dialogue will change to whatever element is at the top — but only on the second and following letters. If I space down a line at the bottom, I can change the previous line back to dialogue and it sticks. You’re right, Keith, that the script attempts to use the page’s first element.

This is different from my previous post above, but I hope these clues help!

User avatar
AmberV
Posts: 20600
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Thu Sep 14, 2017 9:43 pm Post

Just to confirm, you are referring to newly typed in text or that all formatting is changed merely by looking at it?

There is a serious bug in the text engine that causes formatting from the first character in the document to be applied to the last character in the document no matter what—and that can cause scriptwriting to get “stuck” in one element, but that would only impact things as you type best I know. We have no reports of any other oddities. This particular bug will be fixed by a patch to the iOS version—unfortunately it was introduced only recently and Apple decided not to fix it before launching.

On update: yeah, what you are reporting there sounds more like what I was talking about above.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
KB
Site Admin
Posts: 19174
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Fri Sep 15, 2017 8:56 am Post

Hi,

This is the same bug I mentioned to you in the other thread (the one you reported to Apple in regard to the programs you could find it in). It's much more serious in scriptwriting because scriptwriting mode can only recognise elements from the current formatting - but when you type at the end of the text, all of the formatting is taken from the first letter in iOS 11!

For now, you can work around the bug by placing a return character at the end of the text and typing *before* the return character. The bug only affects typing at the very end of the text.

I have spoken to Apple and unfortunately it is *very* unlikely that there will be a fix for this in the iOS 11 release (which will most likely be the same as the GM build). I have therefore submitted a build of Scrivener to the iOS store that does its best to work around this bug. In my tests, in the new build, scriptwriting is working fine. The workaround is rather nasty and may cause glitches elsewhere, although I haven't found any problems with it yet. This build is currently awaiting review by Apple, so fingers crossed that it will be made available very soon.

Fingers crossed that Apple fixes the underlying bug in an early point update to iOS 11 - they are aware of the issue. Then I can remove the nasty workaround for subsequent versions. (The workaround has to check every time you type a letter at the end of the text and try to work out what formatting you intended to use and fix it up if necessary - not pretty.)

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

2a
2albion
Posts: 31
Joined: Tue Aug 14, 2012 12:38 am
Platform: Mac + iOS

Fri Sep 15, 2017 10:02 pm Post

UPDATE: The problem isn’t all due to the bug you identified that’s an Apple issue. There is a problem importing from Final Draft and another problem opening that project on iOS. Things change with no typing at all.

Hi, Keith & Amber—

I made a test project.

1. Final Draft 10 version that was correctly spaced and used Courier Final Draft.

2. After importing, Scrivener has kept the Courier Final Draft font for General Text, Stage Directions and Character List.
—Scene Headings, Character, Dialogue and Parentheticals have been changed to Courier Prime.
—Scrivener has changed the two lower stage directions to General Text.
—Scrivener has changed the margins for Stage Directions and added a bunch of tabs. All other margins are okay.

3. Finally, when I opened this untouched project in iOS, it changed General Text, Stage Directions and Character List from Courier Final Draft to Courier Prime.
—Scrivener changed Scene Headings, Character, Dialogue and Parentheticals from Courier Prime to Helvetica.

4. When I re-open the same project again on the Mac:
—General Text, Stage Directions and Character List have all changed to General Text.
—Scene Headings, Character, Dialogue and Parentheticals keep the changes made on iOS.

This is a different bug, I think. Screenshots available but can’t upload on this forum due to size. Files available as well, if you’d like.

Ah, app development!
Robert

User avatar
KB
Site Admin
Posts: 19174
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Sat Sep 16, 2017 2:23 pm Post

Hi Robert,

Can you please send the files to iOS.support AT literatureandlatte.com with a link to this thread and a request to pass the files to me? I'll take a look at them on Monday.

Thanks,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

2a
2albion
Posts: 31
Joined: Tue Aug 14, 2012 12:38 am
Platform: Mac + iOS

Tue Nov 21, 2017 9:57 pm Post

Hi, Keith-

I sent the files you requested via your minions a couple of months ago, but maybe you’ve been busy with launching the amazing Scrivener 3! Script elements still go crazy between iOS and Mac versions with S3. Also, tab/return behavior on iOS is not the same as what I’ve set or changed on the Mac.

Congratulations on S3!
Robert

User avatar
AmberV
Posts: 20600
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Tue Nov 21, 2017 10:05 pm Post

Just to pipe in, it doesn't look we ever got that message from you, searching through the system by your usual address. Do you have a copy of the message still so we can look it up by subject line?
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

2a
2albion
Posts: 31
Joined: Tue Aug 14, 2012 12:38 am
Platform: Mac + iOS

Tue Nov 21, 2017 10:11 pm Post

Wow! How can you reply within a minute or two when you must be inundated a day after a major launch?

I’ve just re-sent the email, originally sent on Sept. 18th to iOS.support@literatureandlatte.com — is that correct?
Subject: Files Keith requested.

2a
2albion
Posts: 31
Joined: Tue Aug 14, 2012 12:38 am
Platform: Mac + iOS

Wed Nov 22, 2017 7:10 pm Post

P.S. It’s not just the Scriptwriting Elements that change, it’s also the Tab/Return behavior. It worked on the Mac but when I open in iOS it’s all wrong.

User avatar
AmberV
Posts: 20600
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Wed Nov 22, 2017 7:19 pm Post

Well! Still nothing---I have checked the spam filter as well. Maybe the attachment is a little too much for the system to handle, though I would think you would get a message rather than silence. I think at this point you might as well just try sending it direct. Use webmaster AT literatureandlatte (etc).
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

2a
2albion
Posts: 31
Joined: Tue Aug 14, 2012 12:38 am
Platform: Mac + iOS

Wed Nov 22, 2017 7:33 pm Post

Okay, I just forwarded it again. 6.5 MB. Hoping that works...