Screenplay mode seems buggy and counter intuitive....

Rm
Rmcnairy
Posts: 2
Joined: Tue Jul 26, 2016 2:57 am
Platform: Win + iOS

Tue Jul 26, 2016 3:16 am Post

I was going to post some bugginess I had trying to work in screenplay mode where using tab and return keys seems counterintuitive and at times pressing tab once will (let's say) switch to character- then switch to transition. Another time pressing return kept dropping down to do a parenthetical. The process isn't as seemless and intuitive as I've known it to be with Windows Scriv., so perhaps it will get a little smoother with future updates.

I did find a post re: shortcuts which I think will help in this area. Still I wanted to mention it, if it's something that may have come up with others.

Thanks again for this killer product- I've been waiting for iOS release for a couple years now, and super appreciate all the hard work!!! (It's a gem!)

Online
User avatar
AmberV
Posts: 20573
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Tue Jul 26, 2016 5:41 am Post

If you can narrow down the inconsistencies into a sequence of steps we can follow, that would help iron out any problems with it. It may be you have to use elements in a particular order, or maybe do something in between writing, like using the find tool, stuff like that.

Glad to hear on the whole you're liking it!
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

ma
matthewjocasio
Posts: 22
Joined: Tue Jul 26, 2016 1:09 am
Platform: Mac + iOS

Mon Feb 13, 2017 8:20 pm Post

I have been having similar issues while scriptwriting. I was at first using the Comic Script Template that was included with the desktop version of Scrivener, but have been encountering similar issues using my own modified version of that same template.

The only issue I could discern the sequence of steps for was the unintentional underlining of text. The setup is when a Dialogue line is left empty (either by being created anew or by having its text deleted) when there are any lines after it (no matter what style). When you navigate the cursor off that empty dialogue and then move the cursor back, whatever dialogue is written will be underlined.

I had a new issue come up while changing up the tab/enter properties of my custom script settings. If I have it such that I hit enter to go into a parenthetical style from a normal style, when I exit the parenthetical style to go to another normal style, that normal style will be in parentheses. To put it another way, if I make it so that I hit enter to transition from the Character style to the Character Parenthetical style, and then I hit enter again to switch from Character Parenthetical to Dialogue, then that Dialogue line will start out in parentheses. If I switch between those styles with Tab, then I do not get the parenthetical bug.

I'm no developer by any means, but it seems that there is definitely something amiss with the scriptwriting settings on iOS. Probably one thing that is manifested in a bunch of different ways depending on our settings.

Thank you for looking into this and let me know if I can be of any more help!