Scapple high DPI support

tg
tg2k
Posts: 43
Joined: Sat Sep 08, 2012 6:11 pm
Platform: Windows

Thu Sep 17, 2015 12:25 am Post

I have a Surface Pro 3 as well as a laptop and desktop. The laptop and desktop machines have 1080p screens, whereas the Surface Pro 3 is 2160x1440.

Using this Scrivener thread, I've found that (under Windows 10) are with the manifest file (and registry setting) in place, as well as setting compatibility for Windows 8. (The compatibility setting allows 2-finger panning from the touchpad; the screen still doesn't work that way.)

If I fully follow the suggestions on the Scrivener forum and change the compatibility settings on the Scapple shortcut to "Disable display scaling on high DPI settings" then everything gets off and the notes appear in the wrong places, often overlapping.

I wanted to ask: since Scapple is a simpler program than Scrivener, can we expect an update with a newer framework any sooner than with Scrivener?

sp
spectrefish
Posts: 2
Joined: Mon May 16, 2016 6:13 pm
Platform: Windows

Mon May 16, 2016 6:25 pm Post

Bumping an 8 month old topic.

I purchased Scapple yesterday and began mapping some story ideas with glee. I love the software! I created my file with a windows desktop PC at home. Today when I opened the file on my high resolution laptop (3200x1800), I found the map was distorted and everything was overlapping. I had to reorganize everything. This was a bit frustrating since I work regularly between my home PC and my laptop.

This thread helped me by recommending changing the properties.

Steps include:

-right click on scapple shortcut and select properties
-click on compatibility tab
-check the box labeled "Disable display scaling on high DPI settings"

This helped solve my problem but I was hoping there would be an update that fixed this.

Thanks!

tg
tg2k
Posts: 43
Joined: Sat Sep 08, 2012 6:11 pm
Platform: Windows

Sat Nov 26, 2016 4:57 pm Post

FWIW, at this point--and possibly due to the Windows 10 anniversary update (https://blogs.technet.microsoft.com/askcore/2016/08/16/display-scaling-changes-for-the-windows-10-anniversary-update/), as far as I can tell, neither the PreferExternalManifest registry hack (+ the external manifest file), nor the compatibility settings on the shortcut, appear to help (useful reference for these is at https://appuals.com/best-fix-disable-display-scaling-on-high-dpi-devices-in-windows-10/).

I can open the same file on my 1080p monitor on one machine, and on my high-DPI Surface Pro 3 screen, and the SP3 the nodes appear closer together and text overlaps. This makes it near-unusable on the SP3 and may keep me from upgrading my desktop machine's monitor as well. Is there even a short-term hack fix coming, like what we saw with Scrivener?

Ni
Nick Smith
Posts: 23
Joined: Sun Nov 06, 2011 11:07 am
Platform: Windows

Wed Nov 30, 2016 7:36 pm Post

I have the same problem using my laptops (MS Surface Book and Dell 5510) with an external Hi Res monitor - http://www.literatureandlatte.com/forum/viewtopic.php?f=50&t=36668

tg
tg2k
Posts: 43
Joined: Sat Sep 08, 2012 6:11 pm
Platform: Windows

Sun Oct 08, 2017 9:56 pm Post

It looks like Windows addressed this sometime in the past several months. Per some more recent comments at one of the links I provided (https://blogs.technet.microsoft.com/askcore/2016/08/16/display-scaling-changes-for-the-windows-10-anniversary-update/), go into the shortcut's properties, select Compatibility, and check "Override high DPI scaling behavior. Scaling performed by:", then select from the dropdown box either "System" or "System (Enhanced)".

Doing this, Scapple scales properly for me again. Enormous improvement!