Using the trial: the only reason I won't purchase...

ta
tarzanofmars
Posts: 13
Joined: Wed Dec 20, 2017 11:49 pm
Platform: Mac + Windows

Thu Dec 21, 2017 12:02 am Post

I really like this program, it is intuitive, intelligent and not overwhelming, I can focus on writing and the composition feature is really nice.

However, as a great speller and a rapid and imprecise two finger typer, the fact that the autocorrect does not work is a deal breaker for me.

I didn't realize how much time it saves me now that it's gone. My mistakes are physical, my fingers get a letter ahead of my mind or visa versa and not having to stop to back up and manually correct is a must for me.
I have a 22,000 word novel in progress I want to finish in Scrivener, but I just won't make the purchase until the autocorrect is working.

I've read all the 'if you stand upside down and restart your laptop while singing Merry Christmas it works 66% of the time' tricks and tried them all and none of them have worked, but here's the thing- I don't care if one did. I want it to work without some hocus pocus.

Yes, I am running Sierra 10.12.5, I've seen it acknowledged as a known bug. Will it be patched soon?

I love the program, but won't purchase until this is solved.

Regards :)

br
brookter
Posts: 1547
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Thu Dec 21, 2017 7:29 am Post

When you say 'autocorrect doesn't work', what do you mean?

The feature does work for most of us, so please describe what:

1. which version you're using
2. what behaviour you're expecting
3. what you're seeing
4. any steps you've taken

Cheers.

mg
mgowin
Posts: 2
Joined: Thu Dec 21, 2017 4:50 pm
Platform: Mac

Thu Dec 21, 2017 5:00 pm Post

I'm having the same issue—autocorrect isn't working in 3.0.1 (neither was it working in 3.0).

In Preferences, the option to "Correct spelling errors as you type" is checked but misspelled words aren't highlighted or corrected.

By contrast, "Fix capitalization of sentences" and "Capitalize 'i'" both work.

I'm on MacOS 10.12.6. Autocorrect worked fine in Scrivener 2.

br
brookter
Posts: 1547
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Thu Dec 21, 2017 5:30 pm Post

OK.

Please confirm that:

1. Preferences > Corrections > Autocorrection > Correct spelling errors as you type is ticked

2. Edit > Spelling & Grammar > Check Spelling while Typing is ticked.

Both need to ticked -- the reason is that No 1. sets the default for projects. No 2. allows you to toggle the setting on and off quickly if you need to (cmd-\ is the shortcut), without changing the basic default. (I'm only a user -- I think that's the reason anyway.)

With both those ticked, does it work? It does for me.

HTH.

mg
mgowin
Posts: 2
Joined: Thu Dec 21, 2017 4:50 pm
Platform: Mac

Thu Dec 21, 2017 5:49 pm Post

brookter wrote:OK.

Please confirm that:

2. Edit > Spelling & Grammar > Check Spelling while Typing is ticked.



That does it—many thanks!

MG

br
brookter
Posts: 1547
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Thu Dec 21, 2017 6:08 pm Post

Glad it helped!

ta
tarzanofmars
Posts: 13
Joined: Wed Dec 20, 2017 11:49 pm
Platform: Mac + Windows

Fri Dec 22, 2017 4:19 am Post

Hi, none of those work for me. One of the 'tricks' I had referred to was to click and unclick that settings several times and it supposedly would start working, but it never did.

So there is no autocorrect function whatsoever, If I misspell a word it does not underline it in red, when I right click it offers no spelling options, and when I click to spellcheck the entire document it finds no errors.

I am using the version of the trial that I downloaded from this site just a few days ago.
Edit: it says 3.0 (75)

User avatar
kewms
Posts: 3385
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Fri Dec 22, 2017 6:04 am Post

I don't know that it will fix the issue, but version 3.0.1 was released a couple of days ago and includes fixes for a number of bugs.

Katherine
Scrivener Support Team

User avatar
lunk
Posts: 1910
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Fri Dec 22, 2017 8:12 am Post

Have you tried restarting your Mac?
And does the spell chech work outside Scrivener?