Forum software changes (I don't know where to put this)

User avatar
AmberV
Posts: 22158
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Mon Nov 20, 2017 11:18 pm Post

First things first, I’d nuke your browser cache and reload to make sure you aren’t getting stuff from the previous stylesheet mixed in. In particular the font size should be a lot bigger if anything, not smaller. And some of the stuff sounds like it might be related to a stylesheet issue as well. For example I see breadcrumb links just fine. From this post of yours I can jump to Bug Hunt (Mac), Scrivener for macOS, Scrivener or the board index in general.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
xiamenese
Posts: 3636
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Mon Nov 20, 2017 11:40 pm Post

AmberV wrote:First things first, I’d nuke your browser cache and reload to make sure you aren’t getting stuff from the previous stylesheet mixed in. In particular the font size should be a lot bigger if anything, not smaller. And some of the stuff sounds like it might be related to a stylesheet issue as well. For example I see breadcrumb links just fine. From this post of yours I can jump to Bug Hunt (Mac), Scrivener for macOS, Scrivener or the board index in general.

I'm with @ScriverTid on this.

Firstly the breadcrumb trail is at the top of the page and I can't find any way to return to the forum page having read through a long thread. Can we not have either a "Return to forum" button, or at least a "Return to top" button at the bottom of the page.

Secondly, I spent a long time trying to work out how to login as the button—along with "New Posts" etc.—is in an indeterminate dark greenish grey on a dark brown strip … virtually impossible to read.

Mark
The Scrivenato sometimes known as Mr X.
rMBP 13" (early 2015) 10.13.6, 8GB RAM, 512GB SSID
MBP17" (late 2011) 10.13.6, 8GB RAM, 512GB SSID
2017 iPad, iOS 12.01, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

User avatar
KB
Site Admin
Posts: 20208
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Nov 21, 2017 12:04 am Post

As Ioa says, clear your cache for L&L. I saw the same thing earlier - those aren't the intended colours, and it seems that an old CSS file has been cached on the system.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
AmberV
Posts: 22158
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Tue Nov 21, 2017 12:22 am Post

For reference, this is what it should be looking like (fonts aside):

Image

That’s with the mouse over “New Posts”.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
xiamenese
Posts: 3636
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Tue Nov 21, 2017 12:27 am Post

OK, I worked out how to clear the cache in Vivaldi and all's well with the font colour, but I'd still like a way to return to the forum without having to scroll all the way up each time.

:)

Mark

EDIT: Hah! I tried clicking the "GO" button and that did the trick ... not as transparent as on the old site, but it works. :)
The Scrivenato sometimes known as Mr X.
rMBP 13" (early 2015) 10.13.6, 8GB RAM, 512GB SSID
MBP17" (late 2011) 10.13.6, 8GB RAM, 512GB SSID
2017 iPad, iOS 12.01, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

User avatar
Silverdragon
Posts: 712
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Tue Nov 21, 2017 12:42 am Post

I am distressed that "mark all topics read" and "Mark subforums read" links are not available in subforums and forums respectively. Not to mention the painful absence of the "first unread post" link inside a topic. Yes, the forum looks prettier, but it's not nearly so usable.

It's also much more difficult to use on a mobile device. Seriously, Many of the links are hidden inside menus; others aren't available at all. In particular, the "breadcrumbs" menu across the top has disappeared from mobile views.

Please, please, re-clutter the design a bit. Please.
So you know where I'm coming from:
  • I'm a user, not an L&L employee.
  • Mac Scrivener 3.0.3, MacBook Air 11, MacOS 10.13.6 (High Sierra)
  • IOS Scrivener 1.1.5, iPhone 6s, iPad Air 2, iOS 12.0

User avatar
devinganger
Posts: 1131
Joined: Sat Nov 06, 2010 1:55 pm
Platform: Mac, Win + iOS
Location: Monroe, WA 98272 (CN97au)
Contact:

Tue Nov 21, 2017 1:00 am Post

Silverdragon wrote:I am distressed that "mark all topics read" and "Mark subforums read" links are not available in subforums and forums respectively. Not to mention the painful absence of the "first unread post" link inside a topic. Yes, the forum looks prettier, but it's not nearly so usable.

It's also much more difficult to use on a mobile device. Seriously, Many of the links are hidden inside menus; others aren't available at all. In particular, the "breadcrumbs" menu across the top has disappeared from mobile views.

Please, please, re-clutter the design a bit. Please.


Yes to this. First unread post is critical to bouncing quickly through the forums.
--
Devin L. Ganger, WA7DLG
Not a L&L employee; opinions are those of my cat
Winner "Best in Class", 2018 My First Supervillain Photo Shoot

ma
matsgz
Posts: 311
Joined: Mon Feb 11, 2013 7:56 am
Platform: Mac + iOS

Tue Nov 21, 2017 6:36 am Post

AmberV wrote:are you using Gravatar, matsgz?


Yes I am.
Scribo ergo sum

Fa
FadedStardust
Posts: 28
Joined: Fri Sep 13, 2013 9:54 pm
Platform: Windows

Tue Nov 21, 2017 7:21 am Post

Unrelated to previous posts here, but the new font is really a really bad design decision. When typing, I can't differentiate between commas and periods/full stops: , .
Also, it's incredibly hard on my eyes due to how faint the lines are. It honestly makes me not want to visit the forums, even though I want to participate in giving feedback for the Windows beta...

User avatar
devinganger
Posts: 1131
Joined: Sat Nov 06, 2010 1:55 pm
Platform: Mac, Win + iOS
Location: Monroe, WA 98272 (CN97au)
Contact:

Tue Nov 21, 2017 7:28 am Post

SarsenLintel wrote:Oh, one other small issue - the clickable hotspot only seems to half overlap the Unread Posts icon.

Screen Shot 2017-11-20 at 3.51.48 PM.png


I'm not even seeing the Unread Posts icon anymore. Does it only show up on threads where there is more than one page?

(Also, what happened to the item count in the upper right above a list of posts? We get the page count, but not the number of items.)
--
Devin L. Ganger, WA7DLG
Not a L&L employee; opinions are those of my cat
Winner "Best in Class", 2018 My First Supervillain Photo Shoot

User avatar
Silverdragon
Posts: 712
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Tue Nov 21, 2017 8:05 am Post

AmberV wrote:The little orange button the left of the thread title is what I’ve always used to jump to the first unread post, and that seems to still be working for me. Given you describe some layout issues though, I’d also try resetting browser cache. It could be the orange page icon is hidden or obscured.

Oh! And we should have BBCode fixed now. :) Yup!

I was completely unaware that the little orange icon did anything, or what its significance might be, despite multiple years in the forum. While I’m glad that this functionality is available, i’d prefer the explicit text link, please.
So you know where I'm coming from:
  • I'm a user, not an L&L employee.
  • Mac Scrivener 3.0.3, MacBook Air 11, MacOS 10.13.6 (High Sierra)
  • IOS Scrivener 1.1.5, iPhone 6s, iPad Air 2, iOS 12.0

User avatar
xiamenese
Posts: 3636
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Tue Nov 21, 2017 8:47 am Post

devinganger wrote:
SarsenLintel wrote:Oh, one other small issue - the clickable hotspot only seems to half overlap the Unread Posts icon.

Screen Shot 2017-11-20 at 3.51.48 PM.png


I'm not even seeing the Unread Posts icon anymore. Does it only show up on threads where there is more than one page

Reset your browser cache. Probably, like me (I use Vivaldi) there’s an inherited CSS that’s giving you dark text on a dark brown background.

Mark
The Scrivenato sometimes known as Mr X.
rMBP 13" (early 2015) 10.13.6, 8GB RAM, 512GB SSID
MBP17" (late 2011) 10.13.6, 8GB RAM, 512GB SSID
2017 iPad, iOS 12.01, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

User avatar
devinganger
Posts: 1131
Joined: Sat Nov 06, 2010 1:55 pm
Platform: Mac, Win + iOS
Location: Monroe, WA 98272 (CN97au)
Contact:

Tue Nov 21, 2017 9:56 am Post

I wish. I've tried it on multiple browsers, reset my cache on each of them, and was seeing the icon earlier. Nothing now. ;(
--
Devin L. Ganger, WA7DLG
Not a L&L employee; opinions are those of my cat
Winner "Best in Class", 2018 My First Supervillain Photo Shoot

Sc
ScriverTid
Posts: 319
Joined: Tue May 06, 2014 9:38 am
Platform: Mac

Tue Nov 21, 2017 10:20 am Post

Ok, my point 3 is now resolved - the top buttons are now functional. :)

However, the other two points are still outstanding - to show you what I mean about the small text, here are two screenshots:
- the first shows the size of font when composing (it's a bit faint, but at least it's large)
- the second shows the size of the text after posting - see how ridiculously small it is?

Also, a bottom button to return to the forum index seems to be a popular ask...

Image

Image

User avatar
AmberV
Posts: 22158
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Tue Nov 21, 2017 12:49 pm Post

Silverdragon wrote:While I’m glad that this functionality is available, i’d prefer the explicit text link, please.

I’m not sure what that is referring to or where it would fit. I never used a text link or had any awareness of one.

devinganger wrote:(Also, what happened to the item count in the upper right above a list of posts? We get the page count, but not the number of items.)

It’s on the upper left. :)

I wish. I’ve tried it on multiple browsers, reset my cache on each of them, and was seeing the icon earlier. Nothing now. ;(

From which URL are you seeing this, and so that I know what you mean, by “unread posts icon” do you mean the large circular thread status icon on the left?
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles