French accents sometimes not registering

User avatar
mtrahan
Posts: 81
Joined: Sun Feb 10, 2013 2:21 pm
Platform: Mac + Windows
Location: Montreal
Contact:

Wed Oct 02, 2013 4:18 pm Post

Hi,

I've tried Scapple for Mac when it was released but found my laptop screen too small. Now I'm really happy to be able to use it on my Windows PC with a decent monitor! It is very nice but let me get straight to the point: there is a bug that makes Scapple sometimes not register the French accents and I bet some other special characters. I ran into this exact problem in a previous version of Scrivener for Windows, I posted about it here: viewtopic.php?f=32&t=22001

It seemed to be related to the Qt Library Scrivener is using. I don't know if Scapple is using it too, but the problem is precisely the same.

Scrivener was temporarly fixed until the bug was corrected in the Qt Library—see this post by tiho_d. viewtopic.php?f=32&t=22001#p146988

Any chance this could be fixed in Scapple too? It is not as dramatic in Scapple as it was in Scrivener, but it still would be nice to be able to type French accents accurately.

Thanks in advance,

Michael

PS. It would also be nice to be able to choose which kind of smart quotes we want to use, like in the Windows version of Scrivener, where I can easily get the French smart quotes ('«' and '»') instead of the English curly ones.
English is not my first language.

User avatar
MimeticMouton
Posts: 8679
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Thu Oct 03, 2013 4:49 am Post

Thanks for the report. You're right; this is the same issue we had to work around in Scrivener. There's now an update to the Qt libraries which should resolve this issue, so we've got that in place for the next build. If you have a chance to test this now and verify it fixes the problem, we'd greatly appreciate it. To do so, download this zipped file of the updated libraries and then, when Scapple is not running, move these DLLs to your Scapple installation folder, replacing the ones already there. Then try launching Scapple and typing notes as normal and let us know if the accents are registering properly.

You can choose the type of smart quotes by going to Edit > Substitutions > Show Substitutions and picking from the drop-down menu.
Jennifer Hughes
(MM for short)

User avatar
mtrahan
Posts: 81
Joined: Sun Feb 10, 2013 2:21 pm
Platform: Mac + Windows
Location: Montreal
Contact:

Thu Oct 03, 2013 2:17 pm Post

MimeticMouton wrote:Thanks for the report. You're right; this is the same issue we had to work around in Scrivener. There's now an update to the Qt libraries which should resolve this issue, so we've got that in place for the next build. If you have a chance to test this now and verify it fixes the problem, we'd greatly appreciate it. To do so, download this zipped file of the updated libraries and then, when Scapple is not running, move these DLLs to your Scapple installation folder, replacing the ones already there. Then try launching Scapple and typing notes as normal and let us know if the accents are registering properly.


I tested the DLLs in your package: it works! The accents seems to be registering properly with this fix. I will report back here if I manage to get Scapple miss another accent with these DLLs—but so far so good.

MimeticMouton wrote:You can choose the type of smart quotes by going to Edit > Substitutions > Show Substitutions and picking from the drop-down menu.


Oh, nice. I did miss that. It seems a bit strange, though, that this is not in the general 'Options' menu. (Same for deactivating spell check.)

Thanks again for your help.
English is not my first language.

User avatar
MimeticMouton
Posts: 8679
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Thu Oct 03, 2013 9:23 pm Post

Great, thanks for testing that out!

Ah, you actually caught a bug with the spelling and substitutions, as these are supposed to be remembered per board (with new boards defaulting to the last state you set), but currently they're acting like a global toggle.
Jennifer Hughes
(MM for short)