[WORKAROUND] Can't get Bibliography Manager selection working

Posts: 12
Joined: Sat Jan 13, 2018 5:30 pm
Platform: Linux

Fri Feb 09, 2018 1:33 am Post

Every Zotero run file I have to point the Bibliography Manager to is a shell script. When I launch Bibliography from within Scrivener, it just opens up the shell script itself in an editor. I've made sure the scripts are all +X, and that makes no difference. Has anyone found a workaround for this?

I managed to get it working. From the Ubuntu Application Launcher I right-clicked my bibliography manager, Zotero, and selected th menu item Add to Desktop. I launched Scrivener's Tools/Options... menu and hit the Bibliography/Citation Manger Choose button. I then pasted the following line into the file manager edit box:


I put the "$USER" text in this forum post. When I copy and pasted it it was my actual username. Now Ctrl-g followed by ctrl-o launches Zotero for me.

Running Scrivener version beta (64-bit) on UbuntuStudio 1610, Asus laptop w/Intel Centrino 2 & nVidia.

Thanks, all!