Lubuntu 64 and Scrivener 1.9 EASY INSTALL

Sa
SageMichael
Posts: 9
Joined: Wed Jan 27, 2016 5:24 pm
Platform: Linux

Wed Jan 27, 2016 5:39 pm Post

Hello everyone,

As the title says, I have a 64bit system running Lubuntu and I wanted the 1.9 Scrivener package.

The following worked for me.

Code: Select all

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
sudo apt-get install libgstreamer-plugins-base0.10-0:i386

Then I went to the sticky post on the main page, where it said:
Download 1.9.0.1 here (32bit and 64bit versions available) and I chose:
http://www.literatureandlatte.com/scrivenerforlinux/scrivener-1.9.0.1-amd64.deb

After it downloaded, I then hit the windows-e (explorer shortcut) and went into my downloads.
From there I right-clicked on it and then clicked "Open"
Then I installed it with the GUI.

Afterwards, I just run it like normal. In other words I click on it in the list of programs.

Hope this helps

--Sage

Sa
SageMichael
Posts: 9
Joined: Wed Jan 27, 2016 5:24 pm
Platform: Linux

Mon Feb 08, 2016 1:14 am Post

Just wondering if this helped anyone.

User avatar
garpu
Posts: 1806
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Tue Feb 09, 2016 5:11 pm Post

I run Slackware. :D Thanks for posting it, though!
Slackware 64-bit 14.2, XFCE

Ki
KiwiChris
Posts: 2
Joined: Sun Jan 31, 2016 9:08 pm
Platform: Mac + Linux

Tue Feb 16, 2016 5:52 am Post

I was able to successfully install from Synaptic package manager. I am using Uberstudent. Thanks :)

JD
JDGreene
Posts: 1
Joined: Wed Feb 17, 2016 7:29 pm
Platform: Linux

Wed Feb 17, 2016 7:38 pm Post

Sage,

I tried this yesterday. I'm using Ubuntu. Your instructions are clear and direct; I had no trouble following them, and the code lines you indicated worked fine. But every time I try to run it from my list of programs, nothing happens, and when I try running it from terminal, it always comes up with the same missing libgst shared file. I updated 161 files and added 2 beyond your offerings. When I tried installing just the libgst file, it tells me it is already there and updated, but something, somehow is preventing it from being seen. After 5 1/2 hours of frustration, I finally gave up, If I get it figured out, I will update here in case anyone else has the same problem.

JD

Update 2/27 I got it installed using WINE and it works beautifully.
Ubuntu 15.10 and Scrivener 1.9
Last edited by JDGreene on Sun Feb 28, 2016 5:55 am, edited 2 times in total.

XS
XS-Nitrogen
Posts: 1
Joined: Sun Feb 28, 2016 2:17 am
Platform: Linux

Sun Feb 28, 2016 2:31 am Post

I'm not having the same issue, and I'm using a completely clean install of Xubuntu 14.04. Scrivener 1.9 installed and started up without any issues. What versions of Ubuntu and Scrivener are you using?

Sa
SageMichael
Posts: 9
Joined: Wed Jan 27, 2016 5:24 pm
Platform: Linux

Sun Feb 28, 2016 6:20 pm Post

Sorry for the late response. I must not be following the thread.
Glad to see it's working for you now. I'm WINE-phobic, though (which I guess is unrelated since that's exactly how you fixed it).

User avatar
Dagen
Posts: 1
Joined: Mon Mar 14, 2016 3:27 am
Platform: Mac, Win + Linux
Location: Albuquerque, NM, USA

Mon Mar 14, 2016 3:45 am Post

It installed on my Ubuntu 14.04 no problems. I created a nice desktop launcher using a Scrivener logo png.
Seems to work pretty well. It doesn't do spellcheck, but that could be due to something on my end.

I'd love to see work on Scrivener for Linux continue and I'd certainly contribute. I'm a software engineer/developer in Linux and Windows - let me know if I can help in any way with development.

~Don

jo
joshuakimba
Posts: 1
Joined: Fri Mar 11, 2016 6:30 pm
Platform: Linux + Windows

Sun Mar 20, 2016 12:25 am Post

Didn't work for me, I'm about to uninstall linux on this crappy laptop and go back to xp. Here's my code.

joshua@joshua-Presario-C700-Notebook-PC:~/scrivener/scrivener-1.9.0.1-amd64$ sudo dpkg --add-architecture i386
[sudo] password for joshua:
Sorry, try again.
[sudo] password for joshua:
heaSorry, try again.
[sudo] password for joshua:
joshua@joshua-Presario-C700-Notebook-PC:~/scrivener/scrivener-1.9.0.1-amd64$ sudo dpkg --add-architecture i386
joshua@joshua-Presario-C700-Notebook-PC:~/scrivener/scrivener-1.9.0.1-amd64$ sudo apt-get update
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1) utopic InRelease
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1) utopic Release.gpg
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1) utopic Release
Err cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1) utopic/main i386 Packages
Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Err cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1) utopic/restricted i386 Packages
Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1) utopic/main Translation-en_US
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1) utopic/main Translation-en
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1) utopic/restricted Translation-en_US
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1) utopic/restricted Translation-en
Hit http://security.ubuntu.com wily-security InRelease
Hit http://archive.canonical.com wily InRelease
Hit http://us.archive.ubuntu.com wily InRelease
Hit http://us.archive.ubuntu.com wily-updates InRelease
Hit http://us.archive.ubuntu.com wily-backports InRelease
Hit http://archive.canonical.com wily/partner Sources
Hit http://archive.canonical.com wily/partner i386 Packages
Hit http://archive.canonical.com wily/partner Translation-en
Hit http://security.ubuntu.com wily-security/main Sources
Hit http://security.ubuntu.com wily-security/restricted Sources
Hit http://security.ubuntu.com wily-security/universe Sources
Hit http://security.ubuntu.com wily-security/multiverse Sources
Hit http://security.ubuntu.com wily-security/main i386 Packages
Hit http://security.ubuntu.com wily-security/restricted i386 Packages
Hit http://security.ubuntu.com wily-security/universe i386 Packages
Hit http://security.ubuntu.com wily-security/multiverse i386 Packages
Hit http://security.ubuntu.com wily-security/main Translation-en
Hit http://security.ubuntu.com wily-security/multiverse Translation-en
Hit http://security.ubuntu.com wily-security/restricted Translation-en
Hit http://security.ubuntu.com wily-security/universe Translation-en
Hit http://us.archive.ubuntu.com wily/main Sources
Hit http://us.archive.ubuntu.com wily/restricted Sources
Hit http://us.archive.ubuntu.com wily/universe Sources
Hit http://us.archive.ubuntu.com wily/multiverse Sources
Hit http://us.archive.ubuntu.com wily/main i386 Packages
Hit http://us.archive.ubuntu.com wily/restricted i386 Packages
Hit http://us.archive.ubuntu.com wily/universe i386 Packages
Hit http://us.archive.ubuntu.com wily/multiverse i386 Packages
Hit http://us.archive.ubuntu.com wily/main Translation-en
Hit http://us.archive.ubuntu.com wily/multiverse Translation-en
Hit http://us.archive.ubuntu.com wily/restricted Translation-en
Hit http://us.archive.ubuntu.com wily/universe Translation-en
Hit http://us.archive.ubuntu.com wily-updates/main Sources
Hit http://us.archive.ubuntu.com wily-updates/restricted Sources
Hit http://us.archive.ubuntu.com wily-updates/universe Sources
Hit http://us.archive.ubuntu.com wily-updates/multiverse Sources
Hit http://us.archive.ubuntu.com wily-updates/main i386 Packages
Hit http://us.archive.ubuntu.com wily-updates/restricted i386 Packages
Hit http://us.archive.ubuntu.com wily-updates/universe i386 Packages
Hit http://us.archive.ubuntu.com wily-updates/multiverse i386 Packages
Hit http://us.archive.ubuntu.com wily-updates/main Translation-en
Hit http://us.archive.ubuntu.com wily-updates/multiverse Translation-en
Hit http://us.archive.ubuntu.com wily-updates/restricted Translation-en
Hit http://us.archive.ubuntu.com wily-updates/universe Translation-en
Hit http://us.archive.ubuntu.com wily-backports/main Sources
Hit http://us.archive.ubuntu.com wily-backports/restricted Sources
Hit http://us.archive.ubuntu.com wily-backports/universe Sources
Hit http://us.archive.ubuntu.com wily-backports/multiverse Sources
Hit http://us.archive.ubuntu.com wily-backports/main i386 Packages
Hit http://us.archive.ubuntu.com wily-backports/restricted i386 Packages
Hit http://us.archive.ubuntu.com wily-backports/universe i386 Packages
Hit http://us.archive.ubuntu.com wily-backports/multiverse i386 Packages
Hit http://us.archive.ubuntu.com wily-backports/main Translation-en
Hit http://us.archive.ubuntu.com wily-backports/multiverse Translation-en
Hit http://us.archive.ubuntu.com wily-backports/restricted Translation-en
Hit http://us.archive.ubuntu.com wily-backports/universe Translation-en
W: Failed to fetch cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1)/dists/utopic/main/binary-i386/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

W: Failed to fetch cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1)/dists/utopic/restricted/binary-i386/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

E: Some index files failed to download. They have been ignored, or old ones used instead.
joshua@joshua-Presario-C700-Notebook-PC:~/scrivener/scrivener-1.9.0.1-amd64$ sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
libncurses5 is already the newest version.
libstdc++6 is already the newest version.
libc6 is already the newest version.
The following packages were automatically installed and are no longer required:
account-plugin-tools accountsservice-ubuntu-schemas bluez-obexd
ca-certificates-java dbus-property-service default-jre-headless
grilo-plugins-0.2-base gstreamer1.0-plugins-ugly-amr indicator-network
java-common kde-l10n-engb libatk-wrapper-java libatk-wrapper-java-jni
libc-ares2 libconnectivity-qt1 libdbus-cpp5 libgnomevfs2-0
libgnomevfs2-common libgom-1.0-0 libgom-1.0-common libhardware2 libhybris
libhybris-common1 libhybris-utils libmedia1 libprocess-cpp3 libqgsttools-p1
libqmenumodel0 libqofono-qt5-0 libqt5concurrent5 libqt5multimedia5-plugins
libqt5multimediaquick-p5 libqt5multimediawidgets5 libqt5systeminfo5
libqt5xmlpatterns5 libsystemsettings1 libtrust-store2 libubuntuoneauth-2.0-0
libx264-142 ofono openjdk-7-jre-headless python3-gnupg qmenumodel-qml
qml-module-qt-labs-folderlistmodel qml-module-qtmultimedia
qml-module-qtsysteminfo qml-module-ubuntu-connectivity
qtdeclarative5-gsettings1.0 qtdeclarative5-ofono0.2
qtdeclarative5-ubuntu-settings-components sqlite3 system-image-common
system-image-dbus tzdata-java ubuntu-keyboard-data
ubuntuone-credentials-common urfkill vcdimager
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 20 not upgraded.
joshua@joshua-Presario-C700-Notebook-PC:~/scrivener/scrivener-1.9.0.1-amd64$ sudo apt-get install libgstreamer-plugins-base0.10-0:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgstreamer-plugins-base0.10-0 is already the newest version.
The following packages were automatically installed and are no longer required:
account-plugin-tools accountsservice-ubuntu-schemas bluez-obexd
ca-certificates-java dbus-property-service default-jre-headless
grilo-plugins-0.2-base gstreamer1.0-plugins-ugly-amr indicator-network
java-common kde-l10n-engb libatk-wrapper-java libatk-wrapper-java-jni
libc-ares2 libconnectivity-qt1 libdbus-cpp5 libgnomevfs2-0
libgnomevfs2-common libgom-1.0-0 libgom-1.0-common libhardware2 libhybris
libhybris-common1 libhybris-utils libmedia1 libprocess-cpp3 libqgsttools-p1
libqmenumodel0 libqofono-qt5-0 libqt5concurrent5 libqt5multimedia5-plugins
libqt5multimediaquick-p5 libqt5multimediawidgets5 libqt5systeminfo5
libqt5xmlpatterns5 libsystemsettings1 libtrust-store2 libubuntuoneauth-2.0-0
libx264-142 ofono openjdk-7-jre-headless python3-gnupg qmenumodel-qml
qml-module-qt-labs-folderlistmodel qml-module-qtmultimedia
qml-module-qtsysteminfo qml-module-ubuntu-connectivity
qtdeclarative5-gsettings1.0 qtdeclarative5-ofono0.2
qtdeclarative5-ubuntu-settings-components sqlite3 system-image-common
system-image-dbus tzdata-java ubuntu-keyboard-data
ubuntuone-credentials-common urfkill vcdimager
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 20 not upgraded.
joshua@joshua-Presario-C700-Notebook-PC:~/scrivener/scrivener-1.9.0.1-amd64$
Joshua Kimball
Author of The Haunting on X Avenue

Gr
Graybyrd
Posts: 182
Joined: Tue Apr 29, 2008 5:39 am
Platform: Mac, Win + Linux
Location: Whidbey Island, WA
Contact:

Sun Mar 20, 2016 3:59 pm Post

I'm no Linux expert, although we're successfully running a variety of Debian linux here at home on several machines.

I think the issue is that you're overlooking the "apt" installer message:

"W: Failed to fetch cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1)/dists/utopic/restricted/binary-i386/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs"

Try doing what it's telling you: type "apt-cdrom" instead of "apt-get update" ... you're pulling files off the cdrom, not the online repository.
On my honor, I will do my best not to do anything unlawful, infringing, disruptive, harmful, threatening, abusive, tortious, defamatory, libelous, lewd, profane, obscene, hateful or otherwise objectionable. Pinky Promise. :mrgreen:

re
reluctant-robot
Posts: 1
Joined: Sat Apr 09, 2016 8:34 pm
Platform: Linux

Sat Apr 09, 2016 9:00 pm Post

I followed the instructions, it still wasn't working I did some googling and found to install some plugins using: sudo apt-get install libgstreamer-plugins-base0.10-dev

Now it works.

Sa
SageMichael
Posts: 9
Joined: Wed Jan 27, 2016 5:24 pm
Platform: Linux

Mon Apr 18, 2016 12:47 am Post

Yep. You must have ubuntu 16.04. Glad you solved it!