Changing interface language doesn’t work

sc
scrivenerwriter
Posts: 8
Joined: Wed Dec 30, 2015 10:42 am
Platform: Linux

Tue Jan 19, 2016 7:35 pm Post

Hi everybody,

updating to the two new versions was working fine.
But there’s a bug with the interface language (Tools/Options/General/Startup Options/Language).

Under 1.7.2.3 and now 1.7.2.4 I set German. A big part is shown in German, but some items are still in English.
Do you have any idea why? How to fix this?

Under 1.9.0.1, setting the interface language to German (or French, Italian or sth. else) doesn’t work at all. I did of course a restart of Scrivener, even of Linux. The complete interface remains in English. :-(
Do you have any idea why? How to fix this?

Thanks in advance for your help!

ma
matty7
Posts: 4
Joined: Tue Jan 19, 2016 11:04 pm
Platform: Linux + Windows

Tue Jan 19, 2016 11:10 pm Post

I quote.
Italian version don't exist

sc
scrivenerwriter
Posts: 8
Joined: Wed Dec 30, 2015 10:42 am
Platform: Linux

Wed Jan 20, 2016 7:23 am Post

Hi matty7,

sorry, but I don’t understand in what way your post responds to my questions.
My installation shows an interface language option "Italian". But that wasn’t the problem.

It was that whatever other language you choose there, Scrivener’s interface still displays everything only in English. So I asked why and how to fix it?

Any ideas out there how I can set the interface language to German (or any other language)?
Thanks in advance!

ph
philjaq
Posts: 29
Joined: Tue Dec 22, 2015 7:07 pm
Platform: Linux

Fri Jan 22, 2016 3:14 pm Post

I've only ever used scrivener 1.9.0.1 and I use it in English (although I write sometimes in French and I got the spell-checker working in French ok).

I've had a search through the installed file structure of scrivener 1.9.0.1 and I can't see any obvious application language packages (apart from the Spell checker). I don't know where they would be found in any other earlier versions of scrivener. I would suspect that in 1.9.0.1 at least, there is only the English version, unless someone knows better.

I can't remember if there was any choice of operating language to be made at installation.

The Tools/options/general tab has an item in the languages drop down box "System language". I imagine you already tried that ?

sc
scrivenerwriter
Posts: 8
Joined: Wed Dec 30, 2015 10:42 am
Platform: Linux

Sat Jan 23, 2016 10:09 am Post

Thanks for your information!

Yes, spellchecker in other languages work fine.

But the application language is always English although you can choose system language or some other languages (doesn’t work no longer in 1.9.0.1).
It worked before (1.7.2.3/1.7.2.4) for example in German or French. So, perhaps in 1.9.0.1 there is an programmation error?!

Any idea how to get system language working anyway in another language but English?

sc
scrivenerwriter
Posts: 8
Joined: Wed Dec 30, 2015 10:42 am
Platform: Linux

Wed Feb 03, 2016 11:55 am Post

Any news? Any idea how to get system language working in another language but English?

Pa
Paralullus
Posts: 5
Joined: Wed Feb 18, 2015 4:45 pm
Platform: Linux
Location: Berlin Germany

Thu Feb 04, 2016 4:05 pm Post

Hello everybody here:
Maybe this will work for you : in all given Scriveners languages.
For me it works so far as and easy.
I am using a Linux Mint 17.3 Rosa and Scrivener 19.0.1 and the language is easy to enabele to german:
See /usr/share/scrivener/translations and find it empty.
So take the elder Scrivener 17.x for example
/home/til/Downloads/1c-scrivener/scrivener-1.7.2.4-amd64/translations.
There you detect your language.
Now copy this -your language file- in to the first folder.
And start your Scrivener, see, enjoy. :D :D .

@admin
Maybe you can include the language files in to the Scrivener-Linux19.x download packages also?

You all have an excellent time.


I post my problem with Scriv. after upgrading to 17.3 in this Forum as a new topic.
Perhaps you can help me there.
See you there?

sc
scrivenerwriter
Posts: 8
Joined: Wed Dec 30, 2015 10:42 am
Platform: Linux

Thu Feb 04, 2016 10:34 pm Post

Hi Paralullus,

your’re great, that works!!!
Thanks so much!


To precise: For example open the file
scrivener-1.7.2.4-amd64.deb
with an archive manager. Go to the folder
/usr/share/scrivener/translations
and find there 22 language files.
The German one is called:
Scrivener_de.qm

Copy this (or other language files, I took the German one) to your system folder
/usr/share/scrivener/translations

After having started Scrivener, its system language could now be modified under options to German (or another language you choosed).


Now, just another question: Into the German translation some words remain in English. How could I edit the file
Scrivener_de.qm
in order to translate the missing words from English to German?

@admin
Maybe you can include the language files in to the Scrivener-Linux19.x download packages also?

Yeah, this would be great! Thanks in advance!!!

Pa
Paralullus
Posts: 5
Joined: Wed Feb 18, 2015 4:45 pm
Platform: Linux
Location: Berlin Germany

Fri Feb 05, 2016 8:14 am Post

Hi scrivenerwriter,

scrivenerwriter wrote:Hi Paralullus,

your’re great, that works!!!
Thanks so much!

I do like that.

Maybe here is something confusing in your text?
If so please change it , or better make a newer one below.
Otherwise - it's going to be really mixed up .

In my description are there two different places where the translating files are stored!
or better : should be. In version Linux 19.x they are missing. That what causes the problem ( per Feb. 4. 2016)
In your terms they are absolutely the same places? That seemed to me a wrong information.
To precise: For example open the file
scrivener-1.7.2.4-amd64.deb
with an archive manager. Go to the folder

??? /usr/share/scrivener/translations ???
and find there 22 language files.
The German one is called:
Scrivener_de.qm

This should be empty, (if you have only english menu prompts in your running Linux1.9.0.1 Scrivener installation)
The other language files are only in the elder Linux version of Scrivener!
You have to get them there! As I described at top.

then you can do the next step
Copy this (or other language files, I took the German one) to your system folder
/usr/share/scrivener/translations


-----------------------------------------
By the way,
if you prefer German like I do,
where do you life maybe in Germany?
Idea is to talk in German about Scrivener and so on.
-----------------------------------------

Have a nice time

User avatar
MacDavid
Posts: 59
Joined: Tue Jul 28, 2009 5:47 am
Platform: Mac + Linux
Location: Montreal
Contact:

Sat Dec 17, 2016 8:24 pm Post

philjaq wrote:I've only ever used scrivener 1.9.0.1 and I use it in English (although I write sometimes in French and I got the spell-checker working in French ok)


Mine doesn't work.
How did you set the French spell-checker working?

My best,
Merci !
Author of http://www.prisonvalley.com, a webdocumentary proudly written with Scrivener ;-) World Press Photo Non-Linear Program Award-winner 2011 (look at the table in the motel and you'll find a clue...) Scrivener under Ubuntu 16.10