A Mostly Complete Guide to Installing Scrivener on Linux

Posts: 1
Joined: Sun Apr 16, 2017 9:46 pm
Platform: Mac + Linux

Sun Apr 16, 2017 9:58 pm Post

middletwig wrote:"sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev"

Once I ran that I ran it and have not had an issue. Hope this helps and thanks again to everyone who make this possible.

I'm new to Ubuntu (Using 16.04 LTS) and learning new technology for everything- this system, Scrivener, etc. Just discovered I was eligible for a half price code from NaNoWriMo 2016, but I use two systems in two locations and wanted the application on both- the description of the application sounds exactly like my existing PAPER process, which currently involves carrying about 60 tons of gear with me to the different areas and locations where I work, when counting a huge laptop, three paper copies of alpha reader manuscript notations, my own paper notes, my Alphasmart, and and and... I recently bought a small lightweight computer for travel, and am trying to coordinate all my technology to minimize hauling things to write... I could not figure out the install issues in Ubuntu until I found your post. It worked like a charm.

Now to import the manuscript and get working on revisions!!



Posts: 1
Joined: Fri Aug 18, 2017 11:16 am
Platform: Linux

Fri Aug 18, 2017 11:55 am Post

I bought an Asus Chromebook with an Arm71 chip. I installed Ubunto 3.14.0 with Crouton and then installed Scrivener I found the executable in my /usr/share/scrivener/bin folder. However, when I try to run the executable I get the error: "Scrivener: command not found". All the fixes for this involve running on a 64bit chip. This is 32bit. One comment said that Scrivener will not run on an Arm chip. I really hope that is not the case. Any ideas? Thanks!

Posts: 3
Joined: Tue Oct 03, 2017 12:20 am
Platform: Linux

Tue Oct 03, 2017 12:40 am Post

Good evening, I'm "in the mood!".
I use Scrivener from time to time and I'm happy!
Finally I worked under ubuntu 17.04 and everything went well ...
I just passed in 17.10 (complete reinstallation by caution)
So, after installing Artful, I wanted to install Scrivener.
I was downloading the deb, no problem;
I do dpkg -i no problem;
so everything is fine, except that when I click on the icon, nothing happens ...
After reviewing the log, I notice that I do not have permission to run, yet I took the precaution of positioning owner and permissions in /usr/bin and /usr/share.
Is there a new safeguard mechanism that needs to be taken into account?

Posts: 3
Joined: Tue Oct 03, 2017 12:20 am
Platform: Linux

Tue Oct 03, 2017 1:32 pm Post

After much experimentation, research and exchange, I believe that this problem is intrinsic to Wayland, which is unavoidable.
I was even told that : "the easiest and most restless to use software designed for Wayland and polkit (the system operations manager)." !!!
The policy of all linux distributions is of course to switch to Wayland, much more modern and better built than the very old X11. But at the same time there have been added security considerations, conceivable in network, but which are not generally the environment of the writer rather solitary.
So I worry about the future of Scrivener under Linux ...

Posts: 3
Joined: Tue Oct 03, 2017 12:20 am
Platform: Linux

Tue Oct 03, 2017 5:44 pm Post

Victory !!!! :D
I got to install correctly scrivener on ubuntu 17.10 from the downloaded package
In fact, I just used pkcon with the install-local [files] option
(just type pkcon in the terminal and we have all the man ...)
for me:

Code: Select all

pkcon install-local scrivener-
Installation des fichiers     [=========================]         
Test des changements          [=========================]         
Terminé                      [=========================]         
Installation des fichiers     [=========================]         rre/.local/shaAttente de l'authentification [=========================]         
Démarrage                    [=========================]         
Chargement du cache           [=========================]         
Téléchargement des paquets  [=========================]         
Exécution                    [=========================]         
Installation des paquets      [=========================]         
Terminé                      [                         ] (0%) 
(pkcon:12135): GLib-CRITICAL [=========================]          attempting to Téléchargé   scrivener- (local)                                Scrivener is a powerful content-generation tool for writers designed for composing and structuring long and difficult documents. While it gives you complete control of the formatting, its focus is on getting you to the end of that awkward first draft. Compose your text in any order and in pieces as large or small as you like. View the components of your draft individually or as a whole. Import and refer to research files such as images and PDFs alongside your writing. Whether you prefer to outline first, hammer out your first draft and restructure later, Scrivener's corkboard and outliner tools are completely integrated with the text, so working with an overview of your draft is just a click away. Scrivener's users include best-selling novelists, screenwriters, students, academics, lawyers, journalists and translators. It won't presume to tell you how to write - it just provides an array of flexible tools that allow you to do things your way, no matter what kind of writing you do.
Installé      scrivener- (local) 

so on

So it's a lot simpler than I opens and in addition we do not have the security problems, Wayland taking care during installation ...