Page 1 of 1

Pasting text into Scrivener prevents changing font size

Posted: Fri Feb 09, 2018 6:29 am
by Shubius
When I paste text from Evernote into Scrivener I cannot change the font size.

Steps to reproduce:
1. Create an Evernote document (assuming you have an account) and make a note with some Gothom font size 10 text.
2. Copy this text via Control + C
3. Create a Scrivener document via Add -> New Text
4. Use Control + V to paste in the copied text.

You will notice that the font size displays as -1 and if you highlight and select a new font from the font size combo box nothing happens. Nothing I do allows me to change the font size.

Thanks,
-Phillip

Re: Pasting text into Scrivener prevents changing font size

Posted: Fri Feb 09, 2018 2:59 pm
by DavidR
I just tried to do this, and discovered that I do not have the Gothom (or Gotham) font on my Windows 7 system. Is that a Windows 10 font, or did you download it from somewhere? I did try it with Tahoma 10, and nothing went wrong (it actually pasted using the standard font I have set up in Scrivener, not Tahoma). Afraid I can't reproduce it.

Re: Pasting text into Scrivener prevents changing font size

Posted: Fri Feb 09, 2018 8:35 pm
by Shubius
I am using Windows 10 but I am pulling from Evernote via Chrome browser. It is possible however that it is picking up fonts from my system I suppose. The font does seem to be the issue. I found a few techniques to work around this for now. If anyone else has the issue you can do the same.

1. Paste into another native Windows app like Notepad first. If you already pasted into Scrivener then delete all the text that was pasted (into Scrivener) including any white space around it in your Scrivener document until you see the -1 size font change back to your default. Then you should be able to paste from Notepad into Scrivener.

2. May not work for everyone but you can also try importing into Scrivener instead of pasting which is usually what I do anyway. I use Evernote on the go and then port over to Scrivener at home because although I like Scrivener, $20 for an app is just the most asinine thing I have ever seen,

Re: Pasting text into Scrivener prevents changing font size

Posted: Fri Feb 09, 2018 9:11 pm
by DavidR
OK, I was using the standalone Evernote Windows program before, but I tried it with the Web browser version of Evernote just now, and I can confirm that it is exactly as you say. Pasting into a Scrivener document (new or existing) pastes text in Helvetica at size -1; and there is no way to change this size.

I find that using Documents > Convert > Formatting to Default Text Style changes the text to my default font and size, so that might be the simplest solution. Even simpler, actually, is to use Ctrl+Shift+V (Paste and Match Style), which pastes without a problem.

The Gotham font is what Evernote uses in its Web-based editor, and I suspect that the problem is caused by the font not existing on Windows machines. To that extent, it's an Evernote problem. Scrivener should know how to handle this, though, but seems not to. MS Word, for instance, pastes it as Helvetica also, but uses a size of 10.5--also unusual, but not negative!

Re: Pasting text into Scrivener prevents changing font size

Posted: Thu Mar 08, 2018 12:32 am
by Traici
Just confirming that this is also a problem when copying from other web sites, also using google chrome. DavidR's suggestion of ctrl-shift-v does solve the problem, but can be problematic if you are used to using your mouse to copy/paste. Documents > Convert > Formatting to Default Text Style seems to convert the entire page/file and not just the text that you have selected, so is not always a good solution.

Other things I have noticed with copy/paste: if you try and change font, as mentioned, it does not work, but it also does not allow you to change font for the remainder of the document once you have copied and pasted something of a different font size. So if you paste something and it defaults the font size to 8, nothing after that paste can be changed, even if you change the font size before typing anything. The other thing was that if you have pasted a paragraph into scrivener, even if you have the correct font type and size, you can not select the entire paragraph by clicking three times, although you can with every other paragraph that has not been copied and pasted.

Seems to me that there is something very buggy when it comes to copying and pasting (built in plagiarism detection?? - just joking).

Re: Pasting text into Scrivener prevents changing font size

Posted: Sun Apr 29, 2018 10:41 pm
by Gilesy
Same problem pasting text from Chrome to Research Text. Font stuck on font size 26 but when I paste same text into a new Character Sketch I get the same problem unless I use right click/paste & match style. If I do this last method, the font is the correct size and I am able to change size as long as I select the whole line, including text already on the Cahracter Sketch.

Re: Pasting text into Scrivener prevents changing font size

Posted: Mon May 28, 2018 10:25 pm
by georgiene
Somehow some of my work was deleted from scrivener. I've watched hour long boot camps and put most of my novel back together. Now, for the last missing chapters I copied from gmail and tried to paste. The font is correct but the margins are extremely short compared to the page. Is there any way to correct this without retyping the entire scene? Driving me crazy. I've tried everything and have even stopped writing until I get this corrected. Thanks