MOBI output shows CSS code

bo
bostonquad
Posts: 38
Joined: Tue Nov 28, 2017 7:12 pm
Platform: Mac

Sun Jan 07, 2018 6:59 pm Post

When I compile the following for KF8, using the default format...

Testing KF8 compile…
• with a bullet point

... my PaperWhite and Mac Kindle app both display the result as...

Testing KF8 compile… style =" color: #053300; background-color: #FFFEFE" > • with a bullet point


(I am in fact intentionally using a dark green color for the font.) The scriv file is attached.
Attachments
KF8 test.scriv.zip
(44.61 KiB) Downloaded 43 times

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Sun Jan 07, 2018 9:53 pm Post

You can get it to work in compile by applying a css name and then appending the appropriate css style:

Code: Select all

/* Styles */
.green { font-weight: normal; font-style: normal; text-decoration: none; color: #2F9602; }


Also seems to help to remove the background colour in the editor.

Made it bright green in the sample above (and image below). You could substitute your #053300 colour in the css.

Green.jpg
Green.jpg (18.99 KiB) Viewed 1382 times


KF8 Green.scriv.zip
(57.13 KiB) Downloaded 38 times

User avatar
KB
Site Admin
Posts: 19864
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Jan 08, 2018 12:29 pm Post

This should be fixed for 3.0.2.

Thanks and all the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

bo
bostonquad
Posts: 38
Joined: Tue Nov 28, 2017 7:12 pm
Platform: Mac

Tue Jan 09, 2018 8:07 am Post

Thanks Bridey, and thanks Keith for fixing it in the next release!

bo
bostonquad
Posts: 38
Joined: Tue Nov 28, 2017 7:12 pm
Platform: Mac

Wed Feb 14, 2018 4:55 am Post

I'm also seeing an error in ePub output when it comes to my bullet points. It seems likely it's the same root issue, so I'm posting here so Keith can be aware.

A sample iBooks error message is:

“This page contains the following errors:

error on line 13 at column 83: Opening and ending tag mismatch: p line 0 and span
Below is a rendering of the page up to the first error.”

(I can provide more detail if needed.)

mb
mbasch@mac.com
Posts: 1
Joined: Tue Feb 20, 2018 8:00 pm
Platform: Mac

Tue Feb 20, 2018 8:06 pm Post

I have the same issue on several pages when compiling to Epub format. I started completely over downloading the entire book. Several chapters work without the error, but it shows up in the beginning of other chapters.

bo
bostonquad
Posts: 38
Joined: Tue Nov 28, 2017 7:12 pm
Platform: Mac

Fri Mar 16, 2018 6:10 am Post

I'm confirming this is fixed in 3.0.2. Yay!

Thanks Keith.

User avatar
KB
Site Admin
Posts: 19864
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Fri Mar 16, 2018 2:34 pm Post

Great, thanks for confirming!
All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."