Highlighting PDFs not working properly

Posts: 403
Joined: Mon Aug 29, 2011 12:12 am
Platform: Mac

Thu Dec 28, 2017 5:49 pm Post

I am running the latest public beta of High Sierra, 10.13.3 Beta (17D25b). I am seeing this behavior in two machines (MacBook and MacBook Pro 13" first generation) both running Scrivener 3.0.1 (966). When I highlight multiple lines of a PDF only one line gets highlighted. When re-highlight the non highlighted lines, again only one line gets highlighted and the previously highlighted line is no longer highlighted!

Tried a couple of PDFs, obviously both imported in a Scrivener project, just to make sure it's not a file-specific issue.

Checked console and the only thing I found that might be related to this issue and in both machines is what is shown in the screenshots. There are multiple messages per second. What I am saying is, it may not be a Scrivener problem, since I would assume someone else should have noticed this.

I think this is all the meaningful information I can provide. Happy to answer questions if there is something that you need to know and I am not reporting.

Screenshot 2017-12-28 09.44.29.png
Screenshot 2017-12-28 09.44.29.png (43.27 KiB) Viewed 556 times

User avatar
Site Admin
Posts: 19412
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall

Fri Jan 05, 2018 5:33 pm Post

Testing on 10.13.2 I'm not seeing any issues. Strange.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

Posts: 1
Joined: Mon Feb 12, 2018 4:45 pm
Platform: Mac

Mon Feb 12, 2018 4:46 pm Post


I'm having this same issue. I'm not tech savvy so I don't really know how to fix it if the problem is not with Scrivener.